Автоматизация заполнения документа "Возврат товаров от покупателя" в УТ 10.3

Публикация № 546035 31.08.16

Пользовательские инструменты - Адаптация типовых решений

обработка заполнения

Изменение логики заполнения документа "ВозвратТовароОтПокупателя" на основании документа "РеализацияТоваровУслуг".

На работе столкнулся с такой проблемой как оформление возврата от покупателя. Новый и неопытный продавец на основании Реализации товаров и услуг создала несколько документов Возврат товаров от покупателя. При этом в табличной части Товары в каждом из созданных документов оказалось одинаковое количество товара, которое было продано. Как результат оприходовано больше, чем было продано. Из чего возникла задача доработки процедуры ОбработкаЗаполнения документа ВозвратТоваровОтПокупателя. Возможно решение и не оптимально, но работает. За основу была взята эта публикация. Далее в процедуре ЗаполнитьТоварыПоОснованию(ДокументОснование) модуля документа были внесены следующие изменения:

	...
     Выборка = РезультатЗапроса.Выбрать();
		мСписокПодчиненныхДокументов = ПолучитьПодчиненныеДокументы(ДокументОснование);
		Если мСписокПодчиненныхДокументов.Количество() > 0 Тогда
			ЗапросВозвращенных = Новый Запрос;
		
			ЗапросВозвращенных.Текст = 
			"ВЫБРАТЬ
			|	ВозвратТоваровОтПокупателяТовары.Номенклатура,
			|	ВозвратТоваровОтПокупателяТовары.ХарактеристикаНоменклатуры,
			|	СУММА(ВозвратТоваровОтПокупателяТовары.Количество) КАК Количество
			|ИЗ
			|	Документ.ВозвратТоваровОтПокупателя.Товары КАК ВозвратТоваровОтПокупателяТовары
			|		ЛЕВОЕ СОЕДИНЕНИЕ Документ.ВозвратТоваровОтПокупателя КАК ВозвратТоваровОтПокупателя
			|		ПО ВозвратТоваровОтПокупателяТовары.Ссылка = ВозвратТоваровОтПокупателя.Ссылка
			|ГДЕ
			|	ВозвратТоваровОтПокупателя.Ссылка В(&СписокВозвратов)
			|	И ВозвратТоваровОтПокупателя.Проведен = ИСТИНА
			|
			|СГРУППИРОВАТЬ ПО
			|	ВозвратТоваровОтПокупателяТовары.Номенклатура,
			|	ВозвратТоваровОтПокупателяТовары.ХарактеристикаНоменклатуры";	
			ЗапросВозвращенных.УстановитьПараметр("СписокВозвратов",ПолучитьПодчиненныеДокументы(ДокументОснование));
			РезультатЗВ = ЗапросВозвращенных.Выполнить().Выгрузить();
		КонецЕсли;
	
	Пока Выборка.Следующий() Цикл
		кДобавляемых = Выборка.Количество;
		Для Каждого СтрокаРЗВ Из РезультатЗВ Цикл
			Если СтрокаРЗВ.Номенклатура = Выборка.Номенклатура И СтрокаРЗВ.ХарактеристикаНоменклатуры = Выборка.ХарактеристикаНоменклатуры Тогда
				кДобавляемых = Выборка.Количество - СтрокаРЗВ.Количество;
			КонецЕсли;
			
		КонецЦикла;
	    Если кДобавляемых > 0 Тогда 
		СтрокаТабличнойЧасти = Товары.Добавить();

		СтрокаТабличнойЧасти.Номенклатура                        = Выборка.Номенклатура;
		СтрокаТабличнойЧасти.Количество                          = кДобавляемых;
		СтрокаТабличнойЧасти.ЕдиницаИзмерения                    = Выборка.ЕдиницаИзмерения;
		СтрокаТабличнойЧасти.ЕдиницаИзмеренияМест                = Выборка.ЕдиницаИзмеренияМест;
		СтрокаТабличнойЧасти.Коэффициент                         = Выборка.Коэффициент;
		СтрокаТабличнойЧасти.СтавкаНДС                           = Выборка.СтавкаНДС;
		СтрокаТабличнойЧасти.ПроцентСкидкиНаценки                = Выборка.ПроцентСкидкиНаценки;
		СтрокаТабличнойЧасти.ПроцентАвтоматическихСкидок         = Выборка.ПроцентАвтоматическихСкидок;
		СтрокаТабличнойЧасти.УсловиеАвтоматическойСкидки         = Выборка.УсловиеАвтоматическойСкидки;
		СтрокаТабличнойЧасти.ЗначениеУсловияАвтоматическойСкидки = Выборка.ЗначениеУсловияАвтоматическойСкидки;
		СтрокаТабличнойЧасти.Качество                            = Выборка.Качество;
		СтрокаТабличнойЧасти.Склад                               = Выборка.Склад;
		СтрокаТабличнойЧасти.Цена                                = Выборка.Цена;
        Если ТипДокументаОснования = Тип("ДокументСсылка.ЗаказПокупателя") Тогда
        	СтрокаТабличнойЧасти.ЗаказПокупателя 	  = ДокументОснование;
		Иначе
            СтрокаТабличнойЧасти.ЗаказПокупателя 	  = Выборка.ЗаказПокупателя;
		КонецЕсли;

		Если ОтКомиссионера Тогда
			
			КолвоПереданных = ?(Выборка.КоличествоОстатокПереданных = NULL, 0, Выборка.КоличествоОстатокПереданных);
			Если КолвоПереданных>0 Тогда
				Сумма = МодульВалютногоУчета.ПересчитатьИзВалютыВВалюту(Выборка.СтоимостьОтданнаяВалОстаток * СтрокаТабличнойЧасти.Количество / КолвоПереданных, 
				                   ДоговорКонтрагента.ВалютаВзаиморасчетов, ВалютаДокумента, КурсВзаиморасчетов, мКурсДокумента,
				                   КратностьВзаиморасчетов, мКратностьДокумента);

				СтрокаТабличнойЧасти.Сумма = Ценообразование.ПересчитатьЦенуПриИзмененииФлаговНалогов(Сумма, 
				                                              Перечисления.СпособыЗаполненияЦен.ПоЦенамНоменклатуры, 
				                                              Истина, УчитыватьНДС, СуммаВключаетНДС, 
				                                              УчетНДС.ПолучитьСтавкуНДС(СтрокаТабличнойЧасти.СтавкаНДС));
				ОбработкаТабличныхЧастей.ПриИзмененииСуммыТабЧасти(СтрокаТабличнойЧасти, ЭтотОбъект, ТекПользователь,,
				                                              ЕстьРеквизитПроцентСкидкиНаценки,ПересчитыватьСкидку,
				                                              ЕстьАвтоматическиеСкидки,"Товары");
			КонецЕсли;
		Иначе

			СтрокаТабличнойЧасти.Цена = Выборка.Цена;

			// Пересчитаем цену в валюту документа (может отличаться от валюты основания).
			Цена = МодульВалютногоУчета.ПересчитатьИзВалютыВВалюту(СтрокаТабличнойЧасти.Цена, Выборка.ВалютаДокумента, ВалютаДокумента, 
			                                                   Выборка.КурсДокумента, мКурсДокумента,
			                                                   Выборка.КратностьДокумента, мКратностьДокумента);

			СтрокаТабличнойЧасти.Цена = Ценообразование.ПересчитатьЦенуПриИзмененииФлаговНалогов(Цена,
										Перечисления.СпособыЗаполненияЦен.ПоЦенамНоменклатуры,
										Выборка.УчитыватьНДС И Выборка.СуммаВключаетНДС,
										УчитыватьНДС, СуммаВключаетНДС,
										УчетНДС.ПолучитьСтавкуНДС(СтрокаТабличнойЧасти.СтавкаНДС));

			ОбработкаТабличныхЧастей.РассчитатьСуммуТабЧасти(СтрокаТабличнойЧасти, ЭтотОбъект);

		КонецЕсли;

		ОбработкаТабличныхЧастей.РассчитатьКоличествоМестТабЧасти(СтрокаТабличнойЧасти, ЭтотОбъект);
		ОбработкаТабличныхЧастей.РассчитатьСуммуНДСТабЧасти(СтрокаТабличнойЧасти, ЭтотОбъект);

		СтрокаТабличнойЧасти.ХарактеристикаНоменклатуры = Выборка.ХарактеристикаНоменклатуры;

		ОбработкаТабличныхЧастей.ЗаполнитьСкладИОрдерТабЧасти(СтрокаТабличнойЧасти, ЭтотОбъект);
		
		Если ОснованиеРеализацияТоваров Тогда

			СтрокаТабличнойЧасти.СерияНоменклатуры      = Выборка.СерияНоменклатуры;
			СтрокаТабличнойЧасти.ДокументПартии         = ДокументОснование;
			СтрокаТабличнойЧасти.ЗаказПокупателя        = Выборка.ЗаказПокупателя;

		КонецЕсли;

		Если ЕстьСоставНабора
		   И Выборка.Комплект Тогда
			СтрокаТабличнойЧасти.КлючСтроки = СтрокаТабличнойЧасти.НомерСтроки;
		КонецЕсли;
	КонецЕсли;
	КонецЦикла;
...

После чего логика заполнения документа ВозвратТоваровОтПокупателя изменилась в лучшую сторону. А именно:

На основании реализации может быть введено несколько возвратов. Логика доработки предусматривает этот вариант и добавляет только те позиции, которые не были возвращены ранее.

Далее. После формирования документа возврата продавец может изменить состав документа. Чтобы предотвратить подобные действия в Процедуре ПередЗаписью были внесены следующие изменения:

Перем мСписокПодчиненныхДокументов;
...
	//Проверка превышения проданных товаров
	Если ЗначениеЗаполнено(Сделка) ТОгда
		Если ТипЗнч(Сделка) = Тип("ДокументСсылка.РеализацияТоваровУслуг") Тогда
			ЗапросРеализация = Новый Запрос;
			ЗапросРеализация.Текст =
				"ВЫБРАТЬ
				|	РеализацияТоваровУслугТовары.Номенклатура,
				|	РеализацияТоваровУслугТовары.ХарактеристикаНоменклатуры,
				|	РеализацияТоваровУслугТовары.Количество
				|ИЗ
				|	Документ.РеализацияТоваровУслуг.Товары КАК РеализацияТоваровУслугТовары
				|		ЛЕВОЕ СОЕДИНЕНИЕ Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
				|		ПО РеализацияТоваровУслугТовары.Ссылка = РеализацияТоваровУслуг.Ссылка
				|ГДЕ
				|	РеализацияТоваровУслуг.Ссылка = &Реализация";
			ЗапросРеализация.УстановитьПараметр("Реализация",Сделка);
			РезультатЗапроса = ЗапросРеализация.Выполнить().Выгрузить();
			
			
		мСписокПодчиненныхДокументов = ПолучитьПодчиненныеДокументы(Сделка);
		Если мСписокПодчиненныхДокументов.Количество() > 0 Тогда
			ЗапросВозвращенных = Новый Запрос;
		
			ЗапросВозвращенных.Текст = 
			"ВЫБРАТЬ
			|	ВозвратТоваровОтПокупателяТовары.Номенклатура,
			|	ВозвратТоваровОтПокупателяТовары.ХарактеристикаНоменклатуры,
			|	СУММА(ВозвратТоваровОтПокупателяТовары.Количество) КАК Количество
			|ИЗ
			|	Документ.ВозвратТоваровОтПокупателя.Товары КАК ВозвратТоваровОтПокупателяТовары
			|		ЛЕВОЕ СОЕДИНЕНИЕ Документ.ВозвратТоваровОтПокупателя КАК ВозвратТоваровОтПокупателя
			|		ПО ВозвратТоваровОтПокупателяТовары.Ссылка = ВозвратТоваровОтПокупателя.Ссылка
			|ГДЕ
			|	ВозвратТоваровОтПокупателя.Ссылка В(&СписокВозвратов)
			|	И ВозвратТоваровОтПокупателя.Проведен = ИСТИНА
			|
			|СГРУППИРОВАТЬ ПО
			|	ВозвратТоваровОтПокупателяТовары.Номенклатура,
			|	ВозвратТоваровОтПокупателяТовары.ХарактеристикаНоменклатуры";	
			Если мСписокПодчиненныхДокументов.Количество() > 1 Тогда
				мСписокПодчиненныхДокументов.Удалить(мСписокПодчиненныхДокументов.НайтиПоЗначению(Ссылка));
			КонецЕсли;
			ЗапросВозвращенных.УстановитьПараметр("СписокВозвратов",мСписокПодчиненныхДокументов);
			РезультатЗВ = ЗапросВозвращенных.Выполнить().Выгрузить();
		КонецЕсли;
		
		
		
			Для Каждого СтрокаТовары Из Товары Цикл
				Найден = Ложь;
				Для Каждого СтрокаРЗ Из  РезультатЗапроса Цикл
					Если СтрокаТовары.Номенклатура = СтрокаРЗ.Номенклатура И СтрокаТовары.ХарактеристикаНоменклатуры = СтрокаРЗ.ХарактеристикаНоменклатуры Тогда
						Найден = Истина;
						кКВозврату = СтрокаРЗ.Количество;
						Если мСписокПодчиненныхДокументов.Количество() > 0 Тогда
							Для Каждого СтрокаВозвращенных Из РезультатЗВ Цикл
								Если СтрокаВозвращенных.Номенклатура = СтрокаТовары.Номенклатура И СтрокаВозвращенных.ХарактеристикаНоменклатуры = СтрокаТовары.ХарактеристикаНоменклатуры Тогда
									кКВозврату = кКВозврату - СтрокаВозвращенных.Количество;
								КонецЕсли;
							КонецЦикла;
						КонецЕсли;
						Если СтрокаТовары.Количество > кКВозврату Тогда
							Сообщить("В документе " + Строка(Сделка) + " указано количество товара " + Строка(СтрокаТовары.Номенклатура)+ " меньше чем в текущем документе, или был оформлен возврат ранее.");
							Отказ = Истина;
						КонецЕсли;
					КонецЕсли;
					
				КонецЦикла;
				Если Не Найден Тогда
					Отказ = Истина;
					Сообщить("Товар " + Строка(СтрокаТовары.Номенклатура) + " не подлежит возврату, так как он отсутствует в документе реализации или был оформлен возврат ранее.");
				КонецЕсли;
				
			КонецЦикла;
		КонецЕсли;	

	КонецЕсли;
...

После отработки этого кода мы гарантированно получаем правильно оформленный документ возврата товаров от покупателя.

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Re:аниматор 336 01.09.16 07:19 Сейчас в теме
Ни чего не запрещает продавцу добавить товар через подбор и указать любое кол-во.
У себя решил эту проблему через контроль возвращаемого товара при проведении документа по регистру накопления "Продажи".
Как известно при проведении возврата кол-во продажи уменьшается.

часть кода

					Запрос = Новый Запрос;
					Запрос.Текст = "ВЫБРАТЬ РАЗРЕШЕННЫЕ
					               |	ПродажиОбороты.Номенклатура,
					               |	ПродажиОбороты.Качество,
					               |	СУММА(ПродажиОбороты.КоличествоОборот) КАК Количество
					               |ИЗ
					               |	РегистрНакопления.Продажи.Обороты(&ДатаНач, &ДатаКон, , ДокументПродажи = &ДокументПродажи) КАК ПродажиОбороты
					               |ГДЕ
					               |	ПродажиОбороты.Номенклатура = &Номенклатура
					               |	И ПродажиОбороты.Качество = &Качество
					               |
					               |СГРУППИРОВАТЬ ПО
					               |	ПродажиОбороты.Номенклатура,
					               |	ПродажиОбороты.Качество";
					Запрос.УстановитьПараметр("ДатаНач", СтрокаТаблицы.ДокументПартии.Дата);			   
					Запрос.УстановитьПараметр("ДатаКон", ДокументОбъект.МоментВремени());
					Запрос.УстановитьПараметр("ДокументПродажи", СтрокаТаблицы.ДокументПартии);								   
					Запрос.УстановитьПараметр("Номенклатура", СтрокаТаблицы.Номенклатура);
					Запрос.УстановитьПараметр("Качество", СтрокаТаблицы.Качество);
					Выборка = Запрос.Выполнить().Выбрать();
					Пока Выборка.Следующий() Цикл
						КоличествоПродажа = КоличествоПродажа + Выборка.Количество;		
					КонецЦикла;	
					
					Если СтрокаТаблицы.КоличествоДок > КоличествоПродажа Тогда 
						СтрокаСообщенияОбОшибке = СтрокаНачалаСообщенияОбОшибке + "количество превышает количество продажи. " + "
						|  Номенклатура: " + СтрокаТаблицы.Номенклатура + ", партия: " + СтрокаТаблицы.ДокументПартии + ", продано " + КоличествоПродажа + ", возврат: " + СтрокаТаблицы.КоличествоДок;
						ЗаписьЖурналаРегистрации("Возврат товаров от покупателя. Превышение количества", УровеньЖурналаРегистрации.Ошибка, ДокументОбъект.Ссылка.Метаданные(), ДокументОбъект.Ссылка, СтрокаСообщенияОбОшибке);
						ОбщегоНазначения.СообщитьОбОшибке(СтрокаСообщенияОбОшибке, Отказ, Заголовок);										   
					КонецЕсли;

Показать
splitter01; +1 Ответить
2. splitter01 3 01.09.16 15:18 Сейчас в теме
(1) Re:аниматор, Верное замечание. На данный момент проблема уже устранена. Но в Вашем предложении не учитываются ранее возвращенные товары. В ближайшее время исправлю публикацию. И еще: в Вашем варианте рассмотрите ситуацию, когда было продано 2 холодильника и 1 пылесос, а в документе возврата указать 2 пылесоса и 1 холодильник.
3. Re:аниматор 336 06.09.16 07:19 Сейчас в теме
(2)
Но в Вашем предложении не учитываются ранее возвращенные товары.


Вообще то учитываются ранее возвращенные товары. Возврат делает записи в регистр "Продажи" со знаком "-", СУММА(ПродажиОбороты.КоличествоОборот) это учтется в суммировании


И еще: в Вашем варианте рассмотрите ситуацию, когда было продано 2 холодильника и 1 пылесос, а в документе возврата указать 2 пылесоса и 1 холодильник.


Разрешит сделать возврат только на 1 холоднильник, т.к. пылесоса продано 1

А для чего рассмотреть данную ситуацию?
4. V.Nikonov 119 09.09.16 19:49 Сейчас в теме
В некоторых конторах, осуществляющих регулярные продажи однотипных товаров, фактически покупатель возвращает товар из неизвестной поставки. Однако для взаиморасчетов действует правило - цена возврата по последней отгрузке (не текущие продажные цены и не Закупочные).
При первичном заполнении документа возврата обычно используется Подбор по справочнику, при этом не заполняются данные по Себестоимости...
Добавил обработку Табличных частей, которая анализировала продажи (с учетом проведенных возвратов) за период (например, 3 мес.). При необходимости разбивала строку на несколько строк под каждую отгрузку (Учет по Заказам и Заказ=Реализация). При необходимости снимались ограничения по Договорам и добавлялся период анализа. Найденные отгрузки использовались как ПартиеОбразующие документы, использовались для определения Цены возвращаемого товара и становилось видны попытки вернуть "НеОтгруженный товар". Возможно отгружались двойники номенклатуры...
Для строк под которые не нашлось отгрузок, подставлялась Плановая себестоимость (Закупочная цена).
Обработка позволяла при необходимости повторить распределение по отгрузкам,предварительно свернув строки по Номенклатуре (очистив документы партий). Дополнительно Обработка печатала отчет по сформированному распределению (практиковалась корректировка "свежих Реализаций").
Кстати, добавил проверку перед записью: наличие нужного товара в заявленных документах партий...
5. white-mount 10.09.16 14:44 Сейчас в теме
Возвратом товаров обычно занимается не продавец, а менеджер, имеющий выше полномочия. Это всегда чп. Либо дефект, либо пересортица - продано не то. Для маленькой фирмы предложенный механизм подходит, для крупной нет.
Оставьте свое сообщение

См. также

При начислении заработной платы за декабрь 2022 в ЗУП 3.1.24.308 при участии в проекте Сколково начисляются страховые за весь год

Зарплата Адаптация типовых решений Платформа 1С v8.3 Платформа 1С v8.3 Сложные периодические расчеты Сложные периодические расчеты 1С:Зарплата и Управление Персоналом 3.x 1С:Зарплата и Управление Персоналом 3.x Россия Россия Налоговый учет Налоговый учет ФОМС, ЕФС ФОМС, ЕФС Бесплатно (free) Бесплатно (free)

При расчете считаются взносы начиная с января 2022, хотя согласно участию в программе Сколково, мы освобождены от уплаты взносов, и только с января 2023 мы должны их уплачивать, в связи с новым постановлением, но программа делает расчет за весь год на всех сотрудников, а за год там накопилось больше, чем заработная плата сотрудников.

11.01.2023    1722    hottion    9    

Доработка визуализации ЭП для 1С:Документооборот государственного учреждения КОРП

Адаптация типовых решений Платформа 1С v8.3 Платформа 1С v8.3 1С:Документооборот 1С:Документооборот Бесплатно (free) Бесплатно (free)

В этот раз хочу поделиться с вами решением одной практической задачи для одного из проектов Компании Омега, а именно доработки механизма визуализации электронной подписи, т.к. это потребовало проработки 3-х различных способах взаимодействия со сторонним ПО: работа с com-объектом Word (вставка в .doc), разбор структуры docx и создание картинки для дополнения ЭП и вставки этого добра в pdf.

01.12.2022    563    zeltyr    0    

Исправление ошибок в типовых релизах 1С: УТ 10.3 и Розница 1.0 при отражении продаж в ЕГАИС Промо

Адаптация типовых решений Обмен с ГосИС Платформа 1С v8.3 Платформа 1С v8.3 1С:Управление торговлей 10 1С:Управление торговлей 10 Бесплатно (free) Бесплатно (free)

При продаже алкогольной продукции в программах Управление торговлей и Розница возникают ошибки. В статье разберем причины ошибок и способ их решения.

05.06.2016    43540    @lexandr    21    

Корректный вывод суммы и сроков в печатной форме

Адаптация типовых решений Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Бесплатно (free) Бесплатно (free)

Простой лайфхак для вывода суммы или числа дней В скобках и склоняемых единиц измерения или валюты ЗА скобками.

16.11.2022    534    vladimir-89    0    

Дополнительные сведения в типовых конфигурациях 1С

Адаптация типовых решений Платформа 1С v8.3 Платформа 1С v8.3 1С:Бухгалтерия 3.0 1С:Бухгалтерия 3.0 Бесплатно (free) Бесплатно (free)

В статье рассказывается, как использование дополнительных сведений помогает расширить функциональность типовых конфигураций без «снятия с замка» и с минимумом программирования.

08.11.2022    3612    accounting_cons    15    

Стандартные доработки. Штрихкодирование документов. Промо

Адаптация типовых решений Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Россия Россия Бесплатно (free) Бесплатно (free)

Эта статья описывает процесс доработки типовых 1С конфигураций, для добавления функционала штрихкодирования документов и быстрого их поиска по штрихкоду. Метод работает для управляемых и неуправляемых печатных форм.

14.12.2010    72419    milkers    63    

Автоматизация ОТК: как лакокрасочная компания снижает себестоимость изделий на 3–5%

Адаптация типовых решений Внедрение ИТ-системы Платформа 1С v8.3 Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:ERP Управление предприятием 2 Управленческий учет Управленческий учет Бесплатно (free) Бесплатно (free)

Добиться высокого качества продукции минимальными усилиями? Легко. Читайте кейс компании «Внедренцы и программисты»: как доработка «1С:ERP» помогла лакокрасочной компании отсеять некачественное сырьё и сократить себестоимость изделий.

19.09.2022    428    ystetsenko    4    

Не заполняется субконто счета 10.07 в распределении расходов на себестоимость товаров

Закрытие периода Адаптация типовых решений Платформа 1С v8.3 Платформа 1С v8.3 Бухгалтерский учет Бухгалтерский учет 1С:ERP Управление предприятием 2 1С:ERP Управление предприятием 2 Бухгалтерский учет Бухгалтерский учет Налоговый учет Налоговый учет Бесплатно (free) Бесплатно (free)

При выполнении закрытия месяца не заполняется себестоимость в распределении расходов по счёту 10.07, разбираемся, почему, и показываю решение для тех, кто не использует отдельное ведение партнеров и контрагентов.

17.08.2022    688    Volfy    0    

Отрицательные страховые взносы Промо

Механизмы типовых конфигураций Запросы Адаптация типовых решений Платформа 1С v8.3 Платформа 1С v8.3 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры бюджетного учреждения Бесплатно (free) Бесплатно (free)

Иногда возникает необходимость рассчитать страховые взносы с отрицательной базы, но типовая зарплата сделать этого не позволяет. Предлагаю пример изменения запросов на релизе ЗКБУ 1.0.47.2 и всё будет считаться. Проверено на больших бюджетных организациях.

30.10.2012    12891    Nowa    25    

Изменение размера штампа электронной подписи (ЭП) в файле Docx

Документооборот и делопроизводство Адаптация типовых решений Платформа 1С v8.3 Платформа 1С v8.3 1С:Документооборот 1С:Документооборот Россия Россия Бесплатно (free) Бесплатно (free)

В конфигурации 1С:Документооборот реализована возможность вставки изображения электронной подписи (ЭП) в файлы формата Docx, Doc, Odt. В данной статье мы расскажем, как изменить размер вставки изображения ЭП в файлы формата Docx.

25.07.2022    1443    iclect    5    

Предупреждения при загрузке больничных: Сотрудник уволен больше месяца назад, Сотрудник в месяце регистрации в отпуске. УПП 1.3

Зарплата Адаптация типовых решений Платформа 1С v8.3 Платформа 1С v8.3 Сложные периодические расчеты Сложные периодические расчеты 1С:Зарплата и Управление Персоналом 2.5 1С:Зарплата и Управление Персоналом 2.5 1С:Управление производственным предприятием 1С:Управление производственным предприятием Бухгалтерский учет Бухгалтерский учет Бесплатно (free) Бесплатно (free)

Это решение для УПП 1.3 (в ЗУП 2.5 и Комплексной автоматизации должно быть аналогично). Документ "Начисление по больничному листу" при нажатии на кнопку "Рассчитать" проверяется на два условия: 1) Сотрудник уволен больше месяца назад от даты начала больничного 2) В месяце больничного было начисление отпускных.

20.07.2022    426    user1252779    2    

Допиливаем форму выбора серий номенклатуры для отображения остатков Промо

Адаптация типовых решений Платформа 1С v8.3 Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Управление торговлей 10 1С:Управление производственным предприятием 1С:Управление производственным предприятием Россия Россия Бесплатно (free) Бесплатно (free)

В этой статье я хочу рассмотреть задачу, которая довольно часто возникает у начинающих (и не только) разработчиков, адаптирующих типовые конфигурации (УТ, КА, УПП) на предприятиях торговли. Речь пойдет про отображение остатков в форме выбора серий номенклатуры при подборе в документы. Это актуально в тех случаях, когда не ведется партионный учет по сериям, либо когда документы вводятся неоперативно и нет возможности воспользоваться волшебной кнопкой "Заполнить и провести". На первый взгляд задача банальна, но я хочу показать некоторые "грабли", на которые часто наступают новички в процессе ее реализации, а также сопоставлю алгоритмы решения на платформе 8.1 и 8.2.

20.01.2011    34403    practik1c    20    

Добавление собственного виджета в 1С:Документооборот версии 3.0

Документооборот и делопроизводство Адаптация типовых решений Механизмы типовых конфигураций Платформа 1С v8.3 Платформа 1С v8.3 1С:Документооборот 1С:Документооборот Россия Россия Бесплатно (free) Бесплатно (free)

В данной публикации я хочу описать процесс добавления собственного виджета для отслеживания задач по видам документов в 1С документооборот версии 3.0.

18.07.2022    2098    ArseniyFenix    2    

Опрос пользователя в цикле с оповещением (управляемые формы)

Адаптация типовых решений Платформа 1С v8.3 Платформа 1С v8.3 Управляемые формы Управляемые формы Бесплатно (free) Бесплатно (free)

Пример вопроса пользователю по каждой строке при обходе таблицы значений в цикле с помощью оповещения.

01.06.2022    914    nikolasx    10    

Как настроить вывод списка документов 1С в режиме предприятия? Часть 1. Настройка колонок

Адаптация типовых решений Инструкции пользователю Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Бесплатно (free) Бесплатно (free)

В данной статье представлена подробная инструкция по настройке списка документов программных продуктах 1С в режиме предприятия. Ответим на следующие вопросы: 1. Как убрать колонку? 2. Как добавить колонку? 3. Как вывести свой реквизит (Добавленный в режиме «Предприятие» или расширением/доработкой). 4. Как поменять порядок вывода колонок ? 5. Как добавить дополнительный элемент, которого нет в документе. (Например: Контактное лицо).

12.05.2022    3316    Yotata    6    

Еще раз о дополнительных реквизитах и дополнительных сведениях

Адаптация типовых решений БСП (Библиотека стандартных подсистем) Механизмы типовых конфигураций Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Россия Россия Бесплатно (free) Бесплатно (free)

Дополнительные реквизиты и сведения существуют давно. Задумка очень хорошая. Суть этих механизмов понятна всем. По этому поводу написано много. Что тут можно сказать нового? Однако бес, как всегда, в деталях. Как создавали реквизиты в объектах типовых конфигураций, так и продолжаем это делать. Почему это происходит? За всех сказать не могу. Могу рассуждать только на своем примере. Являясь убежденным практиком, одно могу сказать вполне определенно. Если что-то на практике недостаточно удобно, то останется оно главным образом в теории... Если не приложить немного усилий.

11.05.2022    7411    user1374747    19    

Допиливаем типовой отчет "Связанные документы" (структура подчиненности) так, чтобы он видел документы из расширения конфигурации

Адаптация типовых решений Платформа 1С v8.3 Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:ERP Управление предприятием 2 Россия Россия Бесплатно (free) Бесплатно (free)

Наконец-то мы перешли на платформу 1С 8.3.20 и смогли отказаться от режима совместимости в 1С ЕРП. Это позволило нам окончательно закрыть вопрос о перемещении ВСЕХ добавленных объектов из самой конфигурации в её расширение.  Одним из камней преткновения на пути к переезду, был вопрос работы типового отчета "связанные документы".  Ну что же, давайте вместе его решим.

02.05.2022    7939    dima_home    66    

Пример доработки проведения в ERP 2.5 по одному регистру накопления

Адаптация типовых решений Платформа 1С v8.3 Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:ERP Управление предприятием 2 Бесплатно (free) Бесплатно (free)

В дополнение к публикации № 1343740 показан быстрый способ встраивания в механизмы конфигурации проведения существующего документа "ПриобретениеТоваровУслуг" по добавленному новому регистру накопления "АТХ_ПартииНоменклатурыДляРемонтовТверь_НД". Пример реализован на 1С:ERP Управление предприятием 2 (2.5.7.390).

27.04.2022    1699    vsasav    5    

Не удалось сделать проверку отзыва сертификата в 1С (при маркировке, директ-банк, 1С-Отчетность, ЭДО)

Адаптация типовых решений ЭДО и ОФД Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Россия Россия Бесплатно (free) Бесплатно (free)

Если возникает ошибка при подписании ЭЦП документов в 1С, при проверке и подписании маркировки и документов в ЧЗ, при подключении к директ-банку и всем, что связано с электронной подписью.

18.03.2022    5352    ClickUp    10    

Доработка новой Транспортной накладной (с 01.03.2022 г.) при помощи расширения

Адаптация типовых решений Платформа 1С v8.3 Платформа 1С v8.3 Бухгалтерский учет Бухгалтерский учет 1С:Бухгалтерия 3.0 1С:Бухгалтерия 3.0 Россия Россия Бухгалтерский учет Бухгалтерский учет Бесплатно (free) Бесплатно (free)

Покажу на примере, как достаточно быстро доработать заполнение новой транспортной накладной с 01.03.2022 года, используя расширение. Статья для начинающих разработчиков и консультантов.

15.03.2022    2043    niko11s    1    

Авансы, кредиты и предоплаты ФФД 1.05. Изменение типовой УТ 10.3.72.3

Адаптация типовых решений Универсальные функции Механизмы типовых конфигураций Платформа 1С v8.3 Платформа 1С v8.3 1С:Управление торговлей 10 1С:Управление торговлей 10 Бесплатно (free) Бесплатно (free)

Изменение типовой конфигурации Управление торговлей 10.3.72.3 и ниже для случаев, когда клиент оплачивает частично по накладной. В расчетной части чека должны быть типы оплат "Постоплата кредит" - сумма оставшегося долга, "Зачет аванса" - сумма предыдущих оплат. Также исправлена ошибка при оплате за накладную, в которой указаны товарные позиции с разными ставками НДС.

05.03.2022    702    andrew.ab    0    

Как сделать сотрудникам детей

Адаптация типовых решений Платформа 1С v8.3 Платформа 1С v8.3 Бесплатно (free) Бесплатно (free)

За этим провокационным заголовком скрывается небольшая задача, которая, однако, вызвала некоторую дискуссию в кулуарах на последней конференции. Как хранить список детей сотрудников - в табличной части справочника или в регистре сведений?

28.10.2021    3791    Alxby    50    

Не выводятся подписи ответственных лиц в печатных формах. Как победить проблему [БП 3.0]

Печатные формы Адаптация типовых решений Платформа 1С v8.3 Платформа 1С v8.3 Бухгалтерский учет Бухгалтерский учет 1С:Бухгалтерия 3.0 1С:Бухгалтерия 3.0 Бесплатно (free) Бесплатно (free)

Проблема: ни в одной печатной форме (ПКО, РКО, кассовая книга, счет, накладные и пр.) не подставляется ФИО руководителя, ФИО главного бухгалтера, кассира.

19.10.2021    2673    config    4    

Отправка ссылки на документ в обработку вызовом из формы документа, управляемая и обычная формы

Адаптация типовых решений Платформа 1С v8.3 Платформа 1С v8.3 Управляемые формы Управляемые формы Конфигурации 1cv8 Конфигурации 1cv8 Бесплатно (free) Бесплатно (free)

По шагам рассматривается настройка открытия формы обработки из формы документа в управляемой и обычной форме. При открытии формы обработки в реквизит ДокументОснование должен автоматом проставляться документ, из которого выполнялся запуск обработки. Автоматизация выбора документа в обработке.

21.09.2021    2665    etmarket    5    

Google почта, IMAP и 1C на обычных формах

Адаптация типовых решений Email рассылки Платформа 1С v8.3 Платформа 1С v8.3 Бесплатно (free) Бесплатно (free)

В настоящее время огромное количество пользователей продолжает работать на конфигурациях 1С для обычных форм. Это отличные, проверенные временем конфигурации. Но компания 1С давно их перестала активно развивать, и некоторые вещи не решить без доработок. Столкнулся с невозможностью работы конфигураций на обычных формах с самым распространенным почтовым сервисом, а именно Google почтой. Почта от Google давно поддерживает работу через IMAP протокол, вместо устаревшего POP3. Также через IMAP работают почти все почтовые ящики, поэтому эта статья пригодится Вам, даже если Вы используете другой ящик с IMAP, нежели гугловский. Итак, поехали....

30.07.2021    2282    lisrws    4    

УНФ - установка даты запрета редактирования для регистра сведений

Адаптация типовых решений Платформа 1С v8.3 Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Управление нашей фирмой 1.6 Бесплатно (free) Бесплатно (free)

В типовой конфигурации УНФ дата запрета редактирования распространяется только на документы. Иногда требуется распространить дату запрета на регистры сведений - например на "Цены номенклатуры". В статье будет описание как это можно сделать. Указанные доработки можно выполнить как в конфигурации, так и в расширении.

28.06.2021    1831    teyana    0