Переход на новые форматы ЭДО после 01.07.2017. (использование УПД)

02.08.17

Задачи пользователя - Инструкции пользователю

В статье я постарался кратко расписать, какие варианты обмена ЭДО с контрагентами доступны в 1С (любой конфигурации 1С) по новым форматам. Скрины новых форматов в списке картинок к статье. Добавил исправление поведения УПД при формировании ЭД.

        Как все мы знаем, наше государство подарило нам с 01.07.2017 г новые форматы электронных документов. После этой даты все должны были решить какой тип первичных документов они будут использовать, УПД или новый формат накладной. Тогда как формировать СФ теперь можно только в форме УПД (как отдельно так и в связке с первичным документом). В списке ниже приведены варианты настройки 1С (справочник «Профили настроек ЭДО), между которыми вам придётся выбирать при переходе на новые форматы. Каждому варианту пришлось дать незамысловатые названия, уж не обессудьте. 

Основной принцип настроек.

        Настройка форматов документов производится с помошью двух справочниках «Профили настроек ЭДО» и «Настройки ЭДО».

        Общая настройка для всех клиентов указываются в справочнике «Профили настроек ЭДО». Выбранные настройки в профиле автоматически применятся ко всем элементам справочника «Настройки ЭДО», кроме элементов у которых установлен «расширенный режим настроек ЭДО», по таким элементам необходимо выполнить ручную настройку.

         Если у вас есть необходимость использовать индивидуальные настройки форматов (отличающиеся от тех которые указаны в справочнике «Профили настроек ЭДО»), с определенным клиентом, то необходимо в справочнике «Настройки ЭДО», для этого клиента, включить «Расширенный режим настроек ЭДО». Затем установить форматы документов, которые вы будите использовать при обмене.

Выбор варианта новых настроек.   

        Чтобы выбрать какой вариант нам подходит необходимо определить все ли форматы первичных документов, которые мы хотим передавать через ЭД имеют рекомендованный формат от налоговой. Если да, то выбираем настройку «Как раньше», и продолжаем обмен с использованием ТОРГ, АКТ и СФ, только теперь в новых форматах.

         Если на предприятии есть первичные документы которые нам приходится передавать через произвольный формат, что лишает получающую сторону удобной обработки ЭД, такие документы теперь можно передавать через УПД (более подробно Письмо от 21.10.2013 № ММВ-20-3/96 ). Следовательно у нас есть желание перевести документы которые мы формировали в произвольном формате на УПД, но мы не хотим полностью переходить на этот формат, в данном случае используем настройку «Смешанный».

        Если мы хотим полностью перейти на УПД. Тут хотелось бы написать, ставьте галку «Использовать УПД» в справочнике «Профили настроек ЭДО» и работайте, но нет. По этой галке для отправки будут формироваться только УПД со статусом 1, что влечёт за собой необходимость формировать СФ, даже для перечисленных документов не содержавших НДС. Если у вас нет отгрузок «Без НДС» смело используйте настройку «Классический УПД». Для остальных, желающих использовать только УПД при обмене ЭД, остался только один вариант использовать настройку «Разделенный УПД», при использовании этой настройки УПД формируется только со статусом 2, что лишает его основного назначения как единого формата для первичного документа и СФ, но остается его универсальность в плане передачи видов документов.

Скриншоты новых форматов, для «визуального» выбора в приложении к статье

Просьба доработать функционал настройки использования УПД отправлена  и принята 1с, ждем ее реализации.

 От 1С пришло исправление поведения УПД. кому надо срочно, смотрим код.

 Примере для БЭД 1.1

Если вам необходимо отредактировать код БЭД 1.3 то общие модули называются иначе, а код такойже. Код который необходимо добавить обрамлен комментарием "// Пример ("

  • В модуле "ЭлектронныеДокументыПереопределяемый" (БЭД 1.3 "ОбменСКонтрагентамиПереопределяемый")

    Процедура "ПроверитьВозможностьФормированияЕдиногоДокумента" полностью закомментируем проверку     


	ДанныеДокумента = ОбщегоНазначения.ЗначенияРеквизитовОбъекта(Документ,
		"Организация, Контрагент, ДоговорКонтрагента");
		
	ИспользоватьУПД = ЭлектронныеДокументыСлужебныйВызовСервера.ИспользованиеУниверсальногоПередаточногоДокумента(
		ДанныеДокумента.Организация, ДанныеДокумента.Контрагент, ДанныеДокумента.ДоговорКонтрагента);
		
	ИспользоватьУКД = ЭлектронныеДокументыСлужебныйВызовСервера.ИспользованиеУниверсальногоКорректировочногоДокумента(
		ДанныеДокумента.Организация, ДанныеДокумента.Контрагент, ДанныеДокумента.ДоговорКонтрагента);
		
	ОтборСФ = Новый Структура("ПометкаУдаления", Ложь);
	Если ИспользоватьУПД И ТипЗнч(Документ) = Тип("ДокументСсылка.РеализацияТоваровУслуг") Тогда
			
		// Если в реализации указан вид документа - УПД, то формировать его можно только в том случае,
		// если выписан счет-фактура и на основании этого счета-фактуры также будет формироваться УПД.
		СчетФактура = УчетНДС.НайтиПодчиненныйСчетФактуру(Документ, , ОтборСФ);
		
		ВидДоговора =  Документ.ДоговорКонтрагента.ВидДоговора;
		
		// Пример(
		//Если ВидДоговора <> Перечисления.ВидыДоговоровКонтрагентов.СКомиссионером И НЕ ЗначениеЗаполнено(СчетФактура) Тогда
		//	СообщениеОбОшибке = НСтр("ru='Для формирования УПД для %1 нужно выписать счет-фактуру.'");
		//	СообщениеОбОшибке = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(СообщениеОбОшибке, Документ);
		//	ОбщегоНазначенияКлиентСервер.СообщитьПользователю(СообщениеОбОшибке, , , , Отказ);
		//	Возврат;
		//КонецЕсли;
		// Пример)

		АктуальныйЭД = АктуальныйЭлектронныйДокумент(СчетФактура);
		Если ЗначениеЗаполнено(АктуальныйЭД) 
			И ОбщегоНазначения.ЗначениеРеквизитаОбъекта(АктуальныйЭД, "ТипЭлементаВерсииЭД") <> Перечисления.ТипыЭлементовВерсииЭД.СЧФДОПУПД Тогда
			СообщениеОбОшибке = НСтр("ru='Формирование УПД на основании %1 невозможно, т.к. для счета-фактуры %2
			|уже сформирован электронный документ %3.'");
			СообщениеОбОшибке = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
							СообщениеОбОшибке, Документ, СчетФактура, АктуальныйЭД);
			ОбщегоНазначенияКлиентСервер.СообщитьПользователю(СообщениеОбОшибке, , , , Отказ);
		КонецЕсли;
		

В функции "ЗаполнитьДанныеДляУПДИнформацияПродавцаФНС" добавим признак, что СФ ненужна. Тут вам будет необходимо вписать вашу проверку, когда вы хотите УПД со статусом 2, а кода надо выдать ошибку что СФ нужна. У нас проверка есть нет НДС.

Если ТипЗнч(СсылкаНаОбъект) <> Тип("ДокументСсылка.СчетФактураВыданный") Тогда
		
		СтруктураОтбораСчетаФактуры = Новый Структура;
		СтруктураОтбораСчетаФактуры.Вставить("ПометкаУдаления", Ложь);
		СсылкаСчетаФактуры = УчетНДС.НайтиПодчиненныйСчетФактуру(СсылкаНаОбъект, , СтруктураОтбораСчетаФактуры);
		
		Если НЕ ЗначениеЗаполнено(СсылкаСчетаФактуры) Тогда

// Пример(
			ЕстьНДС = МС_ДоработкиЭДО.ЕстьНДС(СсылкаНаОбъект);
			Если ЕстьНДС = Ложь Тогда
				СтруктураЭД.вставить("ЕстьНДС",ЕстьНДС);
				Возврат;
			КонецЕсли; 
// Пример )		

			ТекстСообщения = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
			НСтр("ru = 'По документу ""%1"" не выписан счет-фактура или он помечен на удаление!'"), СсылкаНаОбъект);
			ОбщегоНазначенияКлиентСервер.СообщитьПользователю(ТекстСообщения);
		Иначе
			ЗаполнитьДанныеДляДОПИнформацияПродавцаФНС(СсылкаНаОбъект, СтруктураЭД, ДеревоДанных);
			ДополнитьУПД_ДаннымиПоСчетуФактуре(СсылкаСчетаФактуры, ДеревоДанных);
		КонецЕсли;

	Иначе
		ЗаполнитьДанныеДляСЧФИнформацияПродавцаФНС(СсылкаНаОбъект, СтруктураЭД, ДеревоДанных);
	КонецЕсли;
	

  • В модуле "ЭлектронныеДокументыВнутренний" (БЭД 1.3 "ОбменСКонтрагентамиВнутренний") 

Процедура "СформироватьИнформациюПродавца" добавим следующее условие

	    ВидОперации = ОбщегоНазначенияЭД.ЗначениеРеквизитаВДереве(ДеревоДанных, "ВидОперации");
		ВидСчетаФактуры = ОбщегоНазначенияЭД.ЗначениеРеквизитаВДереве(ДеревоДанных, "ВидСчетаФактуры");
		Если ЗначениеЗаполнено(ВидСчетаФактуры) И ВидСчетаФактуры = "Авансовый" Тогда
			СтруктураЭД.Вставить("Функция",        "СЧФ");
			СтруктураЭД.Вставить("ПоФактХЖ",       "");
			СтруктураЭД.Вставить("НаимДокОпр",     "");
			СтруктураЭД.Вставить("ТипЭлементаВерсииЭД", Перечисления.ТипыЭлементовВерсииЭД.СЧФУПД);
			
		ИначеЕсли ЗначениеЗаполнено(ВидОперации) И ВидОперации = Перечисления.ВидыОперацийЭД.Комиссия Тогда
			СтруктураЭД.Вставить("Функция",        "ДОП");
			СтруктураЭД.Вставить("ПоФактХЖ",       "Документ об отгрузке товаров (выполнении работ), передаче имущественных прав (документ об оказании услуг)");
			СтруктураЭД.Вставить("НаимДокОпр",     "Документ об отгрузке товаров (выполнении работ), передаче имущественных прав (Документ об оказании услуг)");
			СтруктураЭД.Вставить("ТипЭлементаВерсииЭД", Перечисления.ТипыЭлементовВерсииЭД.ДОПУПД);
			СтруктураЭД.Вставить("ВидЭД",               Перечисления.ВидыЭД.ТОРГ12Продавец);
// Пример(
		ИначеЕсли СтруктураЭД.Свойство("ЕстьНДС") и СтруктураЭД.ЕстьНДС = Ложь Тогда     
			СтруктураЭД.Вставить("Функция",        "ДОП");
			СтруктураЭД.Вставить("ПоФактХЖ",       "Документ об отгрузке товаров (выполнении работ), передаче имущественных прав (документ об оказании услуг)");
			СтруктураЭД.Вставить("НаимДокОпр",     "Документ об отгрузке товаров (выполнении работ), передаче имущественных прав (Документ об оказании услуг)");
			СтруктураЭД.Вставить("ТипЭлементаВерсииЭД", Перечисления.ТипыЭлементовВерсииЭД.ДОПУПД);
			СтруктураЭД.Вставить("ВидЭД",               Перечисления.ВидыЭД.ТОРГ12Продавец);
			
			НастройкиОбменаЭД.ВерсияФормата = "ФНС 5.01 (УПД:Первичный документ)";
// Пример )
		
		Иначе
			СсылкаСчетаФактуры = ОбщегоНазначенияЭД.ЗначениеРеквизитаВДереве(ДеревоДанных, "СсылкаСчетаФактуры");
			Если ЗначениеЗаполнено(СсылкаСчетаФактуры) Тогда
				

Описание вариантов настроек  

Как раньше.

                Эта настройка практически не отличается от предыдущей работы ЭД. Вы, как и раньше, используете знакомые формы ТОРГ12, Акт и СФ, только теперь в новых форматах. Данный вариант хорош для тех у кого такая настройка покрывает все формы документов на предприятии.

Настройка справочника «Профили настроек ЭДО»

  1. Реализация товаров и услуг (акт выполненных работ); Акт об оказании производственных услуг; Корректировка реализации (ФНС 5.01 (с 10.01.2016г.))
  2. Реализация товаров и услуг (акт на передачу прав); Корректировка реализации (исправление) (ФНС 5.01 (с 10.01.2016г.))
  3. Счет-фактура выданный (на реализацию) (ФНС 5.01 (УПД:Счет-фактура))
  4. Все счета и заказы перевести на формат CML 4.02

Классический УПД.

               Данный формат обмена дает немого больше возможностей по сравнению со схемой «Как раньше», Т. К. в УПД не описано какой именно документ передается как первичный, то можно передавать практически любой первичный документ в этом формате (более подробно Письмо от 21.10.2013 № ММВ-20-3/96 ).

Плюсы

  1. Если у вас были первичные документы, которые приходилось отправлять в произвольной форме, то теперь можно воспользоваться этим форматом.
  2. СФ и Первичный документ идет одним документом.
  3. При отсутствии СФ формируется такой же формат УПД только со статусом 2.
  4. При получении УПД можно выбрать каким документом его отразить в учете (Акт торг …..).

Минусы

  1. Нет явного указания номера первичного документа.

Настройка справочника «Профили настроек ЭДО»

  1. Данная настройка осуществляется с помощью галок «Использовать УПД» и «Использовать УКД».

Разделенный УПД.

                Данный вариант использования удобен тем, кому важно получать первичный документ и СФ как два разных документа, но при этом использовать преимущества УПД. На моей практике таких пока не нашлось.         

Основное отличие от пункта «Классический УПД» это:

  1. Первичный документ и СФ идут как два отдельных документа.
  2. Каждый документ идет со своим номером.

Настройка справочника «Профили настроек ЭДО»

  1. Реализация товаров и услуг (акт на передачу прав); Корректировка реализации (исправление) (ФНС 5.01 (УПД:Первичный документ))
  2. Реализация товаров и услуг (акт выполненных работ); Акт об оказании производственных услуг; Корректировка реализации(ФНС 5.01 (УПД:Первичный документ))
  3. Реализация товаров и услуг (продажа, комиссия); Корректировка реализации (исправление) (ФНС 5.01 (УПД:Первичный документ))
  4. Счет-фактура выданный (на реализацию) (ФНС 5.01 (УПД:Счет-фактура))
  5. Все счета и заказы перевести на формат CML 4.02

Смешанный

        СФ передается в формате УПД, а у каждого типа первичного документа указывается тот формат которым необходимо обмениваться. Удобно если вам необходимо выставлять, ТОРГ12, а вместо актов хотелось бы использовать УПД, чтобы иметь возможность передавать ранее не формализованные акты.

Настройка справочника «Профили настроек ЭДО»

  1. Счет-фактура выданный (на реализацию) (ФНС 5.01 (УПД:Счет-фактура)
  2. Остальные форматы выбираются в по необходимости.

Если статья была полезна, то пишите или ставьте звездочку, а то непонятно есть смысл продвигать тему ЭДО.

ЭДО УПД 01.07.2017

См. также

Документооборот и делопроизводство (СЭД) Типовые Бухгалтер Пользователь Руководитель проекта Платформа 1С v8.3 Управленческий учет Платные (руб)

Организуйте правильный оборот документов на вашем предприятии в 1С. Ведение учета и хранения документов. Управление потоками документации между подразделениями. Работа с договорами в компании. Автоматизация процессов подготовки, согласования и подписания документов. Сократите время и объем ошибок с 1С:ДО!

48500 руб.

19.02.2016    107882    108    5    

89

Документооборот и делопроизводство (СЭД) Платформа 1С v8.3 Платные (руб)

"1С:Архив" – это универсальная система, обеспечивающая надежное долговременное хранение документов с гарантией юридической значимости на неограниченный срок. "1С:Архив" разработан на основе нормативно-правовых актов по архивному делу, поддерживает операции хранения документов – от попадания в архив до уничтожения – и не имеет ограничений на объем хранимых данных. "1С:Архив" сопровождается методологической поддержкой в виде организационных документов по хранению, входящих в состав "Комплекта нормативных документов" к "Методике управления документами и совместной работой", разработанной специалистами фирмы "1С". Использование "1С:Архива" позволяет организовать единое хранилище всех бумажных и электронных документов из разных информационных систем, вести архивный учет в соответствии с требованиями Росархива и снизить нагрузку на учетные системы. Продукт подходит для малых, средних, крупных предприятий и учреждений любых отраслей.

90000 руб.

24.10.2022    5191    7    1    

6

Операции по ВЭД Документооборот и делопроизводство (СЭД) Бухгалтер Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Управление холдингом 1С:Комплексная автоматизация 2.х Россия Бухгалтерский учет Платные (руб)

Программа предназначена для автоматизации внешнеторговых компаний и обеспечивает документооборот валютного контроля: присвоение Уникального номера контракта (УНК), формирований сведений о валютных операциях (СВО) и справок о подтверждающих документах (СПД), прочих необходимых форм учета и отчетности по валютным операциям согласно действующему валютному законодательству Российской Федерации, документооборот валютных платежей согласно международным стандартам и документооборот купли-продажи валюты, а также выгрузку любых документов 1С в любую систему клиент-банк.

30000 руб.

13.05.2009    67376    3    29    

42

SALE! 50%

Кассовые операции Файловый обмен (TXT, XML, DBF), FTP ЭДО и ОФД Программист Бухгалтер Пользователь Платформа 1С v8.3 Бухгалтерский учет 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 Россия Бухгалтерский учет Налоговый учет Управленческий учет Платные (руб)

В публикации размещены специализированные обработки для загрузки кассовых чеков в базах 1С (для локальных баз): '1С:Бухгалтерия предприятия, ред. 3.0', '1С:Управление нашей фирмой 8, ред. 3.0', '1С:Комплексная автоматизация, ред. 2.5', ‘1С:ERP Управление предприятием, ред. 2’ и ‘1С:Управление торговлей, ред. 11.5’. Вы просто сканируете QR коды с бумажных и электронных чеков c помощью мобильного приложения ФНС и чеки автоматически (без ручного ввода) загружаются в документы 'Авансовый отчет', 'Расходы предпринимателя', 'Путевой лист', 'Приходная накладная', 'Поступление (акты, накладные, УПД)', 'Приобретение товаров и услуг', 'Отчет о розничных продажах' и 'Поступление денежных документов'.

12960 9720 руб.

19.08.2020    66778    318    73    

215

Кассовые операции ЭДО и ОФД Бухгалтер Платформа 1С v8.3 Бухгалтерский учет 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Комплексная автоматизация 2.х Россия Бухгалтерский учет Платные (руб)

Согласно 54-ФЗ по правилам ведения кассовых операций необходимо оформлять приходные кассовые ордера (ПКО) и расходные кассовые ордера (РКО) на основании чеков ККМ. Все данные о чеках, можно взять на сайте оператора фискальных данных (ОФД). Обработка загрузки данных из ОФД в 1С сделает за вас в 1С - ПКО и РКО, Операции по платежным картам или Отчет о розничных продажах (может создать номенклатуру в 1С, указать налоги и др. реквизиты в документах в зависимости от налогообложения ККМ в торговой точке). Проверено на: OFD.RU / Первый ОФД / Такском / Платформа ОФД / Ярус / ОФД Яндекс / ОФД Астрал /ОФД СБИС / Гарант ОФД / КОРУС ОФД / КОНТУР ОФД / ОФД АО Тандер / ИнитПро / Группа Элемент/

3600 руб.

09.08.2017    149579    883    372    

534

Регламентированный учет и отчетность ЭДО и ОФД Бухгалтер Платформа 1С v8.3 1С:Бухгалтерия 3.0 Пищевая промышленность Россия Бухгалтерский учет Налоговый учет Акцизы Платные (руб)

Расширение для Бухгалтерии предприятия 3.0 «Акцизы на сахаросодержащие напитки» предназначено для автоматизированного учета сумм акцизов по реализованным сахаросодержащим напиткам с 01 июля 2023 года. Позволяет выделить суммы акциза в первичных документах («Реализация товаров и услуг», «Корректировка реализации»), сформировать проводки по начислению акциза, а также сформировать и отправить корректные документы по ЭДО.

14400 руб.

16.10.2023    1523    14    0    

12

SALE! 30%

Загрузка и выгрузка в Excel Документооборот и делопроизводство (СЭД) Учет документов Распознавание документов и образов Бухгалтер Пользователь Управляемые формы 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Управление холдингом 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 Бухгалтерский учет Управленческий учет Платные (руб)

Универсальная программа для распознавания ЛЮБЫХ СКАНОВ ИЛИ ФОТО ТОВАРНЫХ ДОКУМЕНТОВ в 1С. Не требует указания параметров и предварительной настройки. Просто выбираете файл (PDF, JPG, DOC, XLS, HTML и т.д.) выбираете документ 1С и нажимаете кнопку "Распознать и загрузить".

6000 5520 руб.

04.06.2019    103683    303    173    

318
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. Efimoff 130 26.07.17 10:45 Сейчас в теме
"Смешенный" исправьте на "Смешанный". Проверочное слово "мешАть"
2. igo1 269 26.07.17 14:45 Сейчас в теме
3. sml 41 26.07.17 16:23 Сейчас в теме
а в обмене с банк-клиентом Сбера тоже УПД планируют?
4. igo1 269 26.07.17 16:57 Сейчас в теме
(3)
по банк-клиенту я не знаю.
5. vgrichuk 28.07.17 09:37 Сейчас в теме
с 1.07.17 обязательным является наличие поля 8 - Идентификатор госконтракта. Почему-то его на скриншотах нет. Не предусмотрены?
6. igo1 269 28.07.17 13:08 Сейчас в теме
(5)
да вы правы, это еще одна ошибка в системе БЭД, в представлении ЭД этого поля нет, но в самих XML файлах поле есть. Ждем исправления в ближайшее время.
7. kwazi 641 01.08.17 16:16 Сейчас в теме
Еще ошибки:
как отдельно так а в связке
даже для перечных документов
8. igo1 269 01.08.17 16:47 Сейчас в теме
9. d4rkmesa 04.09.17 09:36 Сейчас в теме
Я так понял, если использовать "смешанные" настройки, то с 01.07.17 в качестве Торг-12 будет отправляться DP_TOVTORGPR (со стороны продавца)?
10. igo1 269 04.09.17 12:49 Сейчас в теме
11. пользователь 02.04.20 16:57
Сообщение было скрыто модератором.
...
12. isnail 05.07.21 10:08 Сейчас в теме
А у меня справочник Профили настроек ЭДО теперь с пометкой "Не используется", а при попытке открыть любую накладную, ошибка - Передан недопустимый тип документа. Типы УПД и УКД использовать запрещено.
13. isnail 05.07.21 10:10 Сейчас в теме
Ой, не посмотрел что это ветка 2017 года )))
Простите, был напуган
Оставьте свое сообщение