Печать в PDF в фоновом режиме через регламентные задания 1с 8.2 с помощью Yoksel.dll на х64 сервере

Публикация № 90080

Разработка - Практика программирования

Была поставлена задача автоматической рассылки документов на почтовые ящики ответственных лиц.
Был опробован виртуальный принтер PDFСreator - результат отрицательный.
Фоновый режим рассылки документов сервером осуществлен с помощью внешней компоненты Yoksel.dll, которая была зарегистрирована на х32 1с-сервере с помощью команды regsvr32 Yoksel.dll
Ниже приведенные процедуры созданы в общем модуле.
Ссылки на документы, печатные формы которых необходимо разослать ответственным лицам накапливаютя в регистре сведений рдУведомлениеГотовности.
В процедурах показана сама идея автоматического формирования PDF-документов на сервере 1с. Если 1с-сервер х64, то в кластер вносится х32 1с сервер и создается рабочий процесс, в который автоматически перекочевывает фоновое задание и Йоксель запускается и работает физически на х32 сервере.
Процедура УведомлениеГотовности() Экспорт
    
    Запрос = Новый Запрос;
                   
    Запрос.Текст =  "ВЫБРАТЬ РАЗЛИЧНЫЕ
                    |    рдУведомлениеГотовности.ОтчетПроизводства КАК ОтчетПроизводства,
                    |    ЗаказНаПроизводствоПродукция.Заказ.Ссылка КАК ЗаказПокупателя
                    |ИЗ
                    |    РегистрСведений.рдУведомлениеГотовности КАК рдУведомлениеГотовности
                    |        ПОЛНОЕ СОЕДИНЕНИЕ РегистрНакопления.ВыпускПродукции КАК ВыпускПродукции
                    |            ПОЛНОЕ СОЕДИНЕНИЕ Документ.ЗаказНаПроизводство.Продукция КАК ЗаказНаПроизводствоПродукция
                    |            ПО ВыпускПродукции.Заказ.Ссылка = ЗаказНаПроизводствоПродукция.Ссылка
                    |        ПО рдУведомлениеГотовности.ОтчетПроизводства = ВыпускПродукции.Регистратор
                    |ГДЕ
                    |    рдУведомлениеГотовности.Отправлено = ЛОЖЬ
                    |    И рдУведомлениеГотовности.Обработано = ЛОЖЬ";
        
    ТЗ = Запрос.Выполнить().Выгрузить();
    ТЗ.Сортировать("ЗаказПокупателя Возр,ОтчетПроизводства Убыв");
    Заказ="";
    Для каждого Строчка из ТЗ Цикл
        Если Заказ <> Строчка.ЗаказПокупателя Тогда
            Заказ = Строчка.ЗаказПокупателя;
            Если НЕ ПустаяСтрока(Строчка.ОтчетПроизводства) Тогда 
                //ТЗ1 = Запрос.Выполнить().Выгрузить().ВыбратьСтроку();
                рдОбработкаПроведенияОтчетПроизводстваЗаСменуРассылкаУведомленийГотовности(Строчка.ОтчетПроизводства);
            КонецЕсли;
        КонецЕсли;    
    КонецЦикла;

КонецПроцедуры    

  
Процедура рдОбработкаПроведенияОтчетПроизводстваЗаСменуРассылкаУведомленийГотовности(Источник) Экспорт
    
    Запрос = Новый Запрос;
    Запрос.УстановитьПараметр("Ссылка",Источник);
    Запрос.УстановитьПараметр("Услуга","Услуга");
    Запрос.УстановитьПараметр("ПустойОтчет",Документы.ОтчетПроизводстваЗаСмену.ПустаяСсылка());
    
    Запрос.Текст =  "ВЫБРАТЬ РАЗЛИЧНЫЕ
                    |    ЗаказНаПроизводствоПродукция.Заказ.Ссылка КАК ЗаказПокупателя
                    |ПОМЕСТИТЬ ТЕМП
                    |ИЗ
                    |    РегистрНакопления.ВыпускПродукции КАК ВыпускПродукции
                    |        ПОЛНОЕ СОЕДИНЕНИЕ Документ.ЗаказНаПроизводство.Продукция КАК ЗаказНаПроизводствоПродукция
                    |        ПО ВыпускПродукции.Заказ.Ссылка = ЗаказНаПроизводствоПродукция.Ссылка
                    |ГДЕ
                    |    ВыпускПродукции.Регистратор.Ссылка = &Ссылка
                    |;
                    |
                    |////////////////////////////////////////////////////////////////////////////////
                    |ВЫБРАТЬ РАЗЛИЧНЫЕ
                    |    ЗаказыПокупателей.Номенклатура КАК Номенклатура,
                    |    ЗаказыПокупателей.ХарактеристикаНоменклатуры КАК Характеристика,
                    |    ЗаказыПокупателей.Количество КАК КолЗаказ,
                    |    0 КАК КолВыпуск,
                    |    &ПустойОтчет КАК Выпуск,
                    |    ТЕМП.ЗаказПокупателя КАК Заказ
                    |ПОМЕСТИТЬ ТЗЗаказ
                    |ИЗ
                    |    РегистрНакопления.ЗаказыПокупателей КАК ЗаказыПокупателей
                    |        ВНУТРЕННЕЕ СОЕДИНЕНИЕ ТЕМП КАК ТЕМП
                    |        ПО ЗаказыПокупателей.Регистратор = ТЕМП.ЗаказПокупателя
                    |ГДЕ
                    |    ЗаказыПокупателей.Номенклатура.ВидНоменклатуры.Наименование <> &Услуга
                    |;
                    |
                    |////////////////////////////////////////////////////////////////////////////////
                    |ВЫБРАТЬ РАЗЛИЧНЫЕ
                    |    ВыпускПродукции.Продукция,
                    |    ВыпускПродукции.ХарактеристикаПродукции,
                    |    0 КАК КолЗаказ,
                    |    ВыпускПродукции.Количество КАК КолВыпуск,
                    |    ВыпускПродукции.Регистратор КАК Выпуск,
                    |    ЗаказНаПроизводствоПродукция.Заказ.Ссылка КАК Заказ
                    |ПОМЕСТИТЬ ТЗВыпуск
                    |ИЗ
                    |    РегистрНакопления.ВыпускПродукции КАК ВыпускПродукции
                    |        ВНУТРЕННЕЕ СОЕДИНЕНИЕ Документ.ЗаказНаПроизводство.Продукция КАК ЗаказНаПроизводствоПродукция
                    |            ВНУТРЕННЕЕ СОЕДИНЕНИЕ ТЕМП КАК ТЕМП
                    |            ПО ЗаказНаПроизводствоПродукция.Заказ.Ссылка = ТЕМП.ЗаказПокупателя.Ссылка
                    |        ПО ВыпускПродукции.Заказ.Ссылка = ЗаказНаПроизводствоПродукция.Ссылка
                    |;
                    |
                    |////////////////////////////////////////////////////////////////////////////////
                    |ВЫБРАТЬ
                    |    ТЗЗаказ.Номенклатура КАК Номенклатура,
                    |    ТЗЗаказ.Характеристика КАК Характеристика,
                    |    ТЗЗаказ.КолЗаказ КАК КолЗаказ,
                    |    ТЗВыпуск.КолВыпуск КАК КолВыпуск,
                    |    ТЗВыпуск.Выпуск КАК Выпуск,
                    |    ТЗЗаказ.Заказ КАК Заказ
                    |ИЗ
                    |    ТЗЗаказ КАК ТЗЗаказ
                    |        ЛЕВОЕ СОЕДИНЕНИЕ ТЗВыпуск КАК ТЗВыпуск
                    |            ВНУТРЕННЕЕ СОЕДИНЕНИЕ Документ.ОтчетПроизводстваЗаСмену КАК ОтчетПроизводстваЗаСмену
                    |            ПО ТЗВыпуск.Выпуск = ОтчетПроизводстваЗаСмену.Ссылка
                    |        ПО ТЗЗаказ.Номенклатура = ТЗВыпуск.Продукция
                    |            И ТЗЗаказ.Характеристика = ТЗВыпуск.ХарактеристикаПродукции";

           
    
    //ТЗ = Запрос.Выполнить().Выгрузить().ВыбратьСтроку();
//Возврат;
    Выборка = Запрос.Выполнить().Выбрать();

    Отсылать = Ложь;
    Пока Выборка.Следующий() Цикл
        Если (Выборка.КолВыпуск = Выборка.КолЗаказ) И (Выборка.КолЗаказ<>0) Тогда
            Отсылать = Истина;
        иначе    
            Отсылать = Ложь;
            Прервать;
        КонецЕсли;
    КонецЦикла;
    Результат = Ложь;
    Если Отсылать Тогда
        //Результат = Истина;
        Результат = ОтправитьУведомление(Выборка.Заказ,Источник);
    КонецЕсли;
    
    СтрокаРегистра = РегистрыСведений.рдУведомлениеГотовности.СоздатьМенеджерЗаписи();
    СтрокаРегистра.ОтчетПроизводства = Источник;
    СтрокаРегистра.Отправлено = Результат;
    СтрокаРегистра.Обработано = Истина;

    Попытка
        СтрокаРегистра.Записать();
    Исключение    
    КонецПопытки;    

КонецПроцедуры

Функция ОтправитьУведомление(Документ,ОтчетПр)
    
    ДокОбъект = Документ.ПолучитьОбъект();
    
    //Удалим pdf и flg оставшийся с прошлого раза
    ИмяФайла = "1c_notify.pdf";
    ПолноеИмяФайла = КаталогВременныхФайлов() + ИмяФайла;
    УдалитьФайлы(ПолноеИмяФайла);
    
    ИмяФлага = "1c_notify.flg";
    ПолноеИмяФлага = КаталогВременныхФайлов() + ИмяФлага;
    УдалитьФайлы(ПолноеИмяФлага);
        
    ПрофильЭлектроннойПочты = ПолучитьПрофильЭлектроннойПочты();
    Если ПрофильЭлектроннойПочты = Неопределено Тогда
        Возврат Ложь;
    КонецЕсли;    
    
    АдресНазначения = ксОбщийМодуль.ПолучитьПочтуПоСотруднику(ДокОбъект.ксОсновнойИнженерКонсультант);
    Если ПустаяСтрока(АдресНазначения) Тогда 
        ЗаписьЖурналаРегистрации("Не указан email у " + ДокОбъект.ксОсновнойИнженерКонсультант + ". Отправка сообщений указанному получателю не возможна!", УровеньЖурналаРегистрации.Ошибка, , ,"Уведомление");
        Возврат Ложь;
    КонецЕсли;
        
    //Создадим новое письмо на указаный адрес
    Письмо = Новый ИнтернетПочтовоеСообщение;
    Письмо.Отправитель = "1c@ridan.ru";
    Письмо.ИмяОтправителя = "ЗАО Ридан (отдел отгрузки)";
    Письмо.Получатели.Добавить(АдресНазначения);
    Письмо.Получатели.Добавить("ryuchin_a@ridan.ru");
        
    Письмо.Тема = "Уведомление о готовности";
    Письмо.Тексты.Добавить(Строка(ОтчетПр) + "
        |Уведомление об готовности выпуска для " + ДокОбъект.Контрагент + " по счету " + СокрЛП(ДокОбъект.Ссылка.Номер) + " от " + Формат(ДокОбъект.Ссылка.Дата, "ДФ=dd.MM.yy") + " находится во вложении");
    ПолноеИмяФайла = ФайлВложенияЙоксель(ДокОбъект,ОтчетПр);
    Письмо.Вложения.Добавить(ПолноеИмяФайла, "Уведомление о готовности");
    ИПочта = Новый ИнтернетПочта;
    
    Попытка
        ИПочта.Подключиться(ПрофильЭлектроннойПочты);
        ИПочта.Послать(Письмо);
        ИПочта.Отключиться();
        ЗаписьЖурналаРегистрации("Уведомление об готовности выпуска для " + ДокОбъект.Контрагент + " по счету " + СокрЛП(ДокОбъект.Ссылка.Номер) + " от " + Формат(ДокОбъект.Ссылка.Дата, "ДФ=dd.MM.yy") + " отправлено " + ДокОбъект.ксОсновнойИнженерКонсультант, УровеньЖурналаРегистрации.Информация, , ,"Уведомление");
        
        //ЗаписьЖурналаРегистрации("Удалить "+ПолноеИмяФайла, УровеньЖурналаРегистрации.Информация, , ,"Уведомление");
        //УдалитьФайлы(ПолноеИмяФайла);        
        Возврат Истина;
    Исключение
        ЗаписьЖурналаРегистрации("Необходимо проверить настройки электронной почты! Отправка невозможна! (" + ОписаниеОшибки() + ")", УровеньЖурналаРегистрации.Ошибка, , ,"Уведомление");
        Возврат Ложь;
    КонецПопытки;
    
КонецФункции

Функция ПолучитьПрофильЭлектроннойПочты()
    
    ПрофильПочты = Новый ИнтернетПочтовыйПрофиль;
    
    Запрос = Новый Запрос;
    Запрос.УстановитьПараметр("УчетнаяЗапись", Константы.ксУчетнаяЗаписьЭлектроннойПочты.Получить());
    Запрос.Текст = 
    "ВЫБРАТЬ
    |    УчетныеЗаписиЭлектроннойПочты.SMTPСервер,
    |    УчетныеЗаписиЭлектроннойПочты.ПортSMTP,
    |    УчетныеЗаписиЭлектроннойПочты.ЛогинSMTP,
    |    УчетныеЗаписиЭлектроннойПочты.ПарольSMTP,
    |    УчетныеЗаписиЭлектроннойПочты.ТребуетсяSMTPАутентификация,
    |    УчетныеЗаписиЭлектроннойПочты.АдресЭлектроннойПочты,
    |    УчетныеЗаписиЭлектроннойПочты.Логин,
    |    УчетныеЗаписиЭлектроннойПочты.Пароль,
    |    УчетныеЗаписиЭлектроннойПочты.ВремяОжиданияСервера
    |ИЗ
    |    Справочник.УчетныеЗаписиЭлектроннойПочты КАК УчетныеЗаписиЭлектроннойПочты
    |ГДЕ
    |    УчетныеЗаписиЭлектроннойПочты.Ссылка = &УчетнаяЗапись";
    Результат = Запрос.Выполнить();
    
    ЭлектроннаяПочта = Результат.Выбрать();
    Если ЭлектроннаяПочта.Следующий() Тогда
        
        Если ЭлектроннаяПочта.ТребуетсяSMTPАутентификация Тогда
            
            ПрофильПочты.АутентификацияSMTP = СпособSMTPАутентификации.Login;
            ПрофильПочты.ПользовательSMTP = ЭлектроннаяПочта.ЛогинSMTP;
            ПрофильПочты.ПарольSMTP = ЭлектроннаяПочта.ПарольSMTP;
            
        Иначе
            
            ПрофильПочты.АутентификацияSMTP = СпособSMTPАутентификации.ПоУмолчанию;
            
        КонецЕсли;
        
        ПрофильПочты.АдресСервераSMTP = ЭлектроннаяПочта.SMTPСервер;
        ПрофильПочты.ПортSMTP = ЭлектроннаяПочта.ПортSMTP;
        ПрофильПочты.ВремяОжидания = ЭлектроннаяПочта.ВремяОжиданияСервера;
        
        Возврат ПрофильПочты;
        
    Иначе
        
        ЗаписьЖурналаРегистрации("Не удалось получить учетную запись электронной почты - Отправка сообщений не возможна!", УровеньЖурналаРегистрации.Ошибка, , ,"Уведомление");
                 
        Возврат Неопределено;
        
    КонецЕсли;
    
КонецФункции

Функция ПечатьУведомления(СсылкаНаОбъект,ОтчетПр)
    
    НомерПечать = ОбщегоНазначения.ПолучитьНомерНаПечать(СсылкаНаОбъект);
    
    ТабДокумент = Новый ТабличныйДокумент;
    ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_УВЕДОМЛЕНИЕ_ОБ_ОТГРУЗКЕ";
    
    Макет = ПолучитьОбщийМакет("УведомлениеГотовности");
    Обл   = Макет.ПолучитьОбласть("Шапка");
    
    Обл.Параметры.Заголовок = "Уведомление о готовности к отгрузке " + НомерПечать + " от " + Формат(ТекущаяДата(), "ДФ=dd.MM.yyyy");
    Обл.Параметры.Плательщик = "Плательщик: " + СсылкаНаОбъект.Контрагент.Наименование;
    Обл.Параметры.Уведомление = "Информируем Вас, что оборудование по Счету №" + НомерПечать + " от " + Формат(СсылкаНаОбъект.Дата, "ДФ=dd.MM.yyyy") + Символы.ПС + "готово к отгрузке по следующим позициям:";
    ТабДокумент.Вывести(Обл);
    
    НомерСтроки = 1;
    Обл = Макет.ПолучитьОбласть("Строка");
    Для Каждого ТекСтрока ИЗ СсылкаНаОбъект.Товары Цикл
        
        Обл.Параметры.НомерСтроки = НомерСтроки;
        Обл.Параметры.Товар = ТекСтрока.Номенклатура.НаименованиеПолное + ", расчет " + ТекСтрока.ксРасчет;
        Обл.Параметры.Единица = ТекСтрока.ЕдиницаИзмерения;
        Обл.Параметры.Количество = ТекСтрока.Количество;
        Обл.Параметры.ДатаОтгрузки =  Формат(ТекущаяДата(), "ДФ=dd.MM.yyyy");
        //Обл.Параметры.ДатаОтгрузки =  Формат(ОтчетПр.Дата, "ДФ=dd.MM.yyyy");
        ТабДокумент.Вывести(Обл);
        НомерСтроки = НомерСтроки + 1;
        
    КонецЦикла;
    
    Обл = Макет.ПолучитьОбласть("Подвал");
    Обл.Параметры.УсловияПоставки = СсылкаНаОбъект.ДополнениеКАдресуДоставки;
    ТабДокумент.Вывести(Обл);
    
    ТабДокумент.АвтоМасштаб = Истина;
    ТабДокумент.ИмяПринтера = "1c_notifyer";

    Возврат ТабДокумент;
    
КонецФункции

Функция ФайлВложенияЙоксель(пСтр,ОтчетПр)
    
    ИмяФайла = "1c_notify.pdf";
    ПолноеИмяФайла = КаталогВременныхФайлов() + ИмяФайла;
    ИмяФлага = "1c_notify.flg";
    ПолноеИмяФлага = КаталогВременныхФайлов() + ИмяФлага;

    //СтруктураПараметров = новый структура("ИмяФайла",ПолноеИмяФайла);
    
    ТабДокумент = ПечатьУведомления(пСтр.Ссылка,ОтчетПр);
    ПолноеИмяФайла = Йоксель_СохранитьОтчётВПДФ(ТабДокумент,ПолноеИмяФайла);
    
    УдалитьФайлы(ПолноеИмяФлага);
    
    Возврат ПолноеИмяФайла;
    
КонецФункции
// Функция формирует файлы для отправки по электронной почте с помощью внешней компоненты Yoksel.dll
//
Функция Йоксель_СохранитьОтчётВПДФ(ТабДок, ИмяФайла)//Путь)
    Попытка
        //ЗагрузитьВнешнююКомпоненту(КаталогПрограммы() + "Yoksel.dll");
        Йоксель      = ПолучитьCOMОбъект("","Йоксель");
        КонвертерPDF = Йоксель.СоздатьГрафическийКонвертерPDF();
    Исключение
        ЗаписьЖурналаРегистрации(ОписаниеОшибки(), УровеньЖурналаРегистрации.Ошибка, , ,"Уведомление");
        //Предупреждение("Не удалось загрузить внешнюю компоненту Yoksel! Сообщите администратору системы!", 20);
        Возврат Неопределено;
    КонецПопытки;
    ТабДок.Записать(КаталогВременныхФайлов()+ "1c_notify.xls", ТипФайлаТабличногоДокумента.XLS97);
    
    // Конвертируем временный файл в формат pdf
    Попытка
        Таб = Йоксель.СоздатьТабличныйДокумент();
        Таб.Открыть(КаталогВременныхФайлов()+ "1c_notify.xls", "2");
        КонвертерPDF.Документ = Таб;
        КонвертерPDF.КоличествоБитНаПиксел = 24; //1, 4, 8, 24
        //КонвертерPDF.ПолеСлева = 1134; // в твипах (1 твип = 1/567 см)
        КонвертерPDF.ЗаписатьВФайл(ИмяФайла);
    Исключение
        УдалитьФайлы(КаталогВременныхФайлов()+ "1c_notify.xls");
        ЗаписьЖурналаРегистрации(ОписаниеОшибки(), УровеньЖурналаРегистрации.Ошибка, , ,"Уведомление");
        //Сообщить(ОписаниеОшибки(), СтатусСообщения.Важное);
        Возврат Неопределено;
    КонецПопытки;

Специальные предложения

См. также

Использование программных перечислений, ч.1: строковые константы Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Часто ли у вас возникает необходимость в коде выполнять сравнение на строку?

10.12.2016    37556    unichkin    74    

Программная работа с настройками СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Нюансы программной работы с настройками системы компоновки данных в отчетах и динамических списках. Обзор всех видов настроек компоновки. Что в каких случаях правильно применять. В качестве примера рассмотрена работа с отборами и группировками.

27.01.2020    27841    ids79    26    

[СКД] Программное создание схемы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Сделаем отчет на СКД полностью программно, без использования макета "схема компоновки данных".

15.01.2020    24563    John_d    22    

Последовательности событий при проведении документа 1С. Шпаргалка + про формы + про расширения

Практика программирования v8 Россия Бесплатно (free)

Собрал информацию о событиях/подписках/расширениях в одном месте.

30.12.2019    18930    kuzyara    33    

Вспомогательные инструкции в коде 1С Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    30533    tormozit    100    

30 задач. Странных и не очень

Практика программирования v8 Бесплатно (free)

30 задач на знание языка программирования 1С и некоторого поведения платформы. Маленьких. Странных и не очень.

02.12.2019    17232    YPermitin    72    

Как передать IP адрес, который вызвал HTTP запрос в 1C (для веб-сервера Apache)

Практика программирования v8 Бесплатно (free)

Столкнулся с задачей получения IP адреса, который вызывает http сервис 1С. Итак, решение:

22.11.2019    8561    Sibars    19    

Таблица значений. Нюансы

Практика программирования v8 Бесплатно (free)

Обзор некоторых аспектов использования общеизвестного инструмента 1С.

01.10.2019    33990    Yashazz    50    

Оформление и рефакторинг сложных логических выражений Промо

Практика программирования v8 Россия Бесплатно (free)

В сложных логических выражениях нередко самому автору спустя какое-то время тяжело разобраться, не говоря уже о других программистах. Предлагаемая методика позволяет повысить наглядность таких выражений путем оформления в виде И-ИЛИ дерева и одновременно выполнять их рефакторинг.

20.09.2012    78191    tormozit    131    

О программе Postman для тестирования API и для чего она нужна 1С-нику

Практика программирования Программное обеспечение (software) v8 Бесплатно (free)

Для чего нужна программа Postman для тестирования API и какая от него польза для 1С-программиста.

24.09.2019    12177    budidich    28    

[Шпаргалка] Программное создание элементов формы

Практика программирования Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Программное создание практически всех популярных элементов формы.

06.09.2019    51671    rpgshnik    63    

Агрегатные функции СКД, о которых мало кто знает

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    50356    ids79    54    

Запись значения в поле ввода/формы со срабатыванием события ПриИзменении Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Иногда возникает необходимость после записи значения в какое либо поле ввода/формы вызвать для него обработчик события ПриИзменении, а о вызове самого события приходится только мечтать. В этой статье приводится программный способ вызова этого события.

11.07.2007    48661    tormozit    41    

Регистры бухгалтерии. Общая информация

Практика программирования Математика и алгоритмы v8 v8::БУ БУ Бесплатно (free)

Общая информация о внутреннем устройстве регистров бухгалтерии.

05.09.2019    29009    YPermitin    24    

Три костыля. Сказ про фокусы в коде

Практика программирования v8 Бесплатно (free)

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    25713    YPermitin    80    

Отслеживание выполнения фонового задания

Практика программирования Универсальные функции Разработка v8 1cv8.cf Бесплатно (free)

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    31805    ids79    16    

Как сделать из &НаКлиентеНаСервереБезКонтекста почти &НаКлиентеНаСервере Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Как сделать метод формы, доступный на клиенте и на сервере одновременно, и сохранить при этом удобство разработки

10.09.2017    45007    tormozit    74    

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    85026    ids79    49    

Фоновое выполнение кода в 1С - это просто

Практика программирования v8 1cv8.cf Бесплатно (free)

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    36377    avalakh    22    

Разбираемся с параметрами редактирования СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Связь по типу, Параметры выбора, Связи параметров выбора

31.07.2019    24462    json    13    

Выгрузка документа по условию Промо

Практика программирования Разработка v8 Бесплатно (free)

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    16117    m-rv    2    

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    61461    ids79    11    

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ

Инструментарий разработчика Практика программирования v8 v8::СКД Бесплатно (free)

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    36291    ids79    27    

Регистры сведений. За кулисами

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Небольшие заметки по внутреннему устройству регистров сведений.

09.07.2019    26316    YPermitin    14    

Как прикрутить ГУИД к регистру сведений Промо

Практика программирования Перенос данных из 1C8 в 1C8 Разработка v8 Бесплатно (free)

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    20365    m-rv    17    

"Меньше копипаста!", или как Вася универсальную процедуру писал

Практика программирования Разработка v8 v8::СКД 1cv8.cf Бесплатно (free)

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    19773    SeiOkami    50    

Работа с настройками системы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Варианты отчетов, работа с настройками вариантов: структура группировок, поля отчета, отборы, сортировка, условное оформление, другие настройки, настройки отображения диаграмм.

02.07.2019    47940    ids79    17    

Создание отчетов с помощью СКД - основные понятия и элементы

Практика программирования Математика и алгоритмы v8 v8::СКД Бесплатно (free)

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    53493    ids79    25    

Как сделать запрос на изменение данных Промо

Практика программирования v8 v8::Запросы 1cv8.cf Бесплатно (free)

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    30847    m-rv    21    

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017

Практика программирования Производительность и оптимизация (HighLoad) v8 v8::Запросы Бесплатно (free)

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    25348    dmurk    145    

Регистры накопления. Структура хранения в базе данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    43856    YPermitin    30    

О расширениях замолвите слово...

Практика программирования Разработка v8 Бесплатно (free)

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    35682    ellavs    126    

Метод формирования движений в типовых регистрах нетиповыми регистраторами Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    28340    itriot11    34    

Git-репозитории для 1С-кода (опыт использования при небольших проектах)

Практика программирования v8 Бесплатно (free)

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    27577    ellavs    90    

Трюки с внешними источниками данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    31651    YPermitin    53    

Ошибки при работе с хранилищем конфигурации и способы их решения

Практика программирования v8 Бесплатно (free)

В статье собраны наиболее распространенные ошибки при работе с хранилищем конфигурации и способы их обхода и решения.

01.03.2019    40176    Смешной 1С    28    

Использование классов .Net в 1С для новичков Промо

Практика программирования Разработка внешних компонент Универсальные функции v7.7 v8 Бесплатно (free)

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    76662    Serginio    108    

Разработка и сценарное тестирование с Vanessa-ADD. Отчетность Allure. Автоматизация запуска сценариев

Практика программирования Vanessa Automation v8 Россия Бесплатно (free)

Формируем отчетность о результатах выполнения сценариев. Автоматизируем запуск.

26.02.2019    22341    Vladimir Litvinenko    27    

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS)

Практика программирования БСП (Библиотека стандартных подсистем) Роли и права v8 v8::Права Бесплатно (free)

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    40389    ids79    9    

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С Промо

Математика и алгоритмы Практика программирования v8 v8::blocking 1cv8.cf Бесплатно (free)

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    35118    ids79    40    

EnterpriseData – часть 2. Процесс выгрузки данных

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Основные этапы выгрузки данных через ED, обработчики событий выгрузки, правила обработки данных, правила конвертации объектов, конвертация свойств первого и второго этапов, процедуры БСП, используемые при выгрузке данных, структура «КомпонентыОбмена».

26.12.2018    27116    ids79    31    

Новый подход к обмену данными EnterpriseData

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Хочу предложить Вашему вниманию цикл статей, посвященных обмену данными через универсальный формат (EnterpriseData или ED).

14.12.2018    41976    ids79    72    

Тестер: частые вопросы Промо

Практика программирования v8 Бесплатно (free)

Ошибкам бой - тесты норма жизни!

25.07.2018    29353    grumagargler    28    

Партионный учет товаров в конфигурациях УТ, КА, ЕРП

Управленческий учет (прочее) Бухгалтерский учет Учет ТМЦ Учет ТМЦ v8 v8::УФ ERP2 УТ11 КА2 Россия УУ Бесплатно (free)

История развития, особенности реализации в текущих версиях ЕРП 2.4, КА 2.4, УТ 11.4, методы оценки стоимости запасов, примеры расчета стоимости списания

08.12.2018    51887    ids79    63    

Учет товаров по сериям в типовых конфигурациях УТ 11.4, КА 2.4, ЕРП 2.4

Бухгалтерский учет Учет ТМЦ Управленческий учет (прочее) Учет ТМЦ v8 v8::УФ ERP2 УТ11 КА2 Россия УУ Бесплатно (free)

Возможности и настройки подсистемы серийного учета, отражение данных по сериям в регистрах и отчетах системы, выявленные нюансы

02.12.2018    58199    ids79    147    

EnterpriseData - пример доработки правил конвертации без использования КД 3.0 в расширении конфигурации

Практика программирования Обмен через XML v8 v8::УФ БП3.0 УТ11 Россия Бесплатно (free)

В статье подробно описан реальный пример доработки обмена данными через EnterpriseData (универсальный формат обмена) между конфигурациями УТ 11.4 и Бухгалтерия 3.0

16.11.2018    37559    ids79    42    

Ускоряем 1С: модули с повторным использованием возвращаемых значений Промо

Практика программирования v8 Бесплатно (free)

По роду своей деятельности, мне часто приходится обсуждать с программистами детали реализации той или иной функциональности. Очень часто, разговаривая даже с квалифицированными специалистами я сталкиваюсь с незнанием сути платформенной функциональности Повторного использования возвращаемых значений общих модулей. В данной статье я постараюсь дать краткий обзор и основные особенности этой функциональности.

04.09.2017    52996    m-rv    61    

Программное заполнение пользовательских параметров и отборов СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Публикация представляет из себя краткие примеры того, как можно заполнять параметры СКД программно так, чтобы все параметры и отборы были доступны в быстрых настройках и в обычных (типовых) настройках параметров и отборов СКД.

13.11.2018    48683    Unk92    25