Внешняя печатная форма акта сверки с комментариями (для БП 1.6, БП 2.0, КА 1.1)

06.11.10

Учетные задачи - Печатные формы

Внешняя печатная форма акта сверки с выводом в табличную часть содержимого номеров счетов-фактур для реализации и  поступления, назначения платежей для платежных документов.
Разработано для:
БП 1.6 (8.1)
БП 2.0 (8.2)
КА 1.1 (8.2)

Обновлено:
06.11.2010 - добавлена колонка "Единица измерения". Перенесено на платформу 8.2. Добавлена возможность формирования в комплексной автоматизации

Скачать исходный код

Наименование Файл Версия Размер
Внешняя расширенная форма акта сверки 8.1
.epf 15,65Kb
273
.epf 15,65Kb 273 Скачать
Внешняя расширенная форма акта сверки 8.2
.epf 15,34Kb
250
.epf 15,34Kb 250 Скачать

Внешняя печатная форма акта сверки с выводом в табличную часть содержимого номеров счетов-фактур для реализации и поступления, назначения платежей для платежных документов.

Подключается стандартным способом.

В связи с тем, что в  места в табличной части акта немного - убрана часть таблицы "По данным контрагента". Вся информация выводится только по данным организации.

Код открыт.

Подключение внешней печатной формы к конфигурации:

  1. Запускаем 1С: Бухгалтерию в режиме 1С:Предприятия. 
  2. Заходим в меню "Сервис", "Дополнительные отчеты и обработки", "Дополнительные внешние печатные формы"
  3. Нажимаем "Добавить" 
  4. Нажимаем кнопку-картинку "Заменить файл внешней обработки"  (в виде папки со стрелкой) и выбираем скачанный файл
  5. На вопрос "Указанная внешняя печатная форма содержит параметры авторегистрации. Использовать их..." - отвечаем "ДА"
  6. Нажимаем "ОК" 
  7. Открываем документ "Акт сверки" - формируем его.
  8. Нажимаем печать и выбираем вновь появившуюся форму "Акт сверки расширенный"
  9. Наслаждаемся!

 

 

См. также

Infostart PrintWizard - создание и редактирование печатных форм в 1С 8.3

Пакетная печать Печатные формы Инструментарий разработчика Программист Платформа 1С v8.3 Запросы 1С:Зарплата и кадры бюджетного учреждения 1С:Конвертация данных 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 Платные (руб)

Инструмент, позволяющий абсолютно по-новому взглянуть на процесс разработки печатных форм. Благодаря конструктору можно значительно снизить затраты времени на разработку печатных форм, повысить качество и "прозрачность" разработки, а также навести порядок в многообразии корпоративных печатных форм.

18000 руб.

06.10.2023    9478    27    6    

49

Перенос данных из УТ 10.3 в УТ 11 / КА 2 / ERP 2. Переносятся документы, справочники и остатки

Перенос данных 1C Взаиморасчеты Оптовая торговля Логистика, склад и ТМЦ Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Управление торговлей 10 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Управленческий учет Платные (руб)

Можно проверить до покупки, оставьте заявку! Воспользовались более 268 компаний! Перенос в продаже с 2015г., и мы постоянно работаем над его развитием. Перенос данных из УТ 10.3 в УТ 11 | из УТ 10.3 в КА 2 | из УТ 10.3 в ERP. Предлагаем качественное и проверенное временем решение для перехода с УТ 10.3. Можно перенести начальные остатки, нормативно-справочную информацию и все возможные документы. При выгрузке можно установить отбор по периоду, организациям и складам. При выходе новых релизов конфигураций 1C оперативно выпускаем обновление переноса данных.

45650 руб.

24.04.2015    191694    135    239    

270

Универсальная печать по шаблонам Word (Печать договоров из 1С БП 3, УНФ 1.6, ЗУП 3, УТ 11, КА 2, ERP 2, ДО 3)

Печатные формы Программист Пользователь Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 1С:ERP Управление предприятием 2 Платные (руб)

Научите вашу 1C печатать из 1С в файл Word (Например: трудовые договоры, договоры с контрагентами, спецификации, дополнительные соглашения, приказы, коммерческие предложения, акты, накладные, карточки партнера или любого справочника и многие другие). Универсальная печать предназначена для формирования печатных форм на основе шаблонов в формате Word из любой конфигурации 1С. С помощью данного инструмента можно самостоятельно заполнить шаблон реквизитами справочника или документа 1С и сформировать печатные формы на основании ссылки на любой объект.

5400 руб.

08.10.2019    44064    151    89    

147

"Акты сверки +" Групповая подготовка и рассылка актов сверки для Бухгалтерии 3.0.

Взаиморасчеты Email рассылки Акт сверки Бухгалтер Пользователь Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Бухгалтерский учет Платные (руб)

Внешняя обработка для Бухгалтерии 3.0 - позволяет автоматически формировать документы «Акт сверки расчетов» с контрагентами за выбранный период с последующей фоновой отправкой на почту контрагента.

3000 руб.

25.11.2020    22759    186    7    

167

Печатные формы КС-2 и КС-3 в "1С:Бухгалтерия 3.0"

Печатные формы Производство готовой продукции (работ, услуг) Бухгалтер Платформа 1С v8.3 Бухгалтерский учет Оперативный учет 1С:Бухгалтерия 3.0 Строительство Россия Бухгалтерский учет Платные (руб)

Откройте для себя заполнение КС-2 и КС-3 в "1С:Бухгалтерия 3.0". Вы получаете удобство, скорость и систему, чтобы заполнить, распечатать и сохранить формы КС-2 и КС-3 из документов "Оказание производственных услуг" или "Реализация товаров услуг". Вы можете заполнить дополнительную информацию о материалах из документов "Требование-накладная" и указать сведения, которые не предусмотрены типовой конфигурацией "1С:Бухгалтерия 3.0". Так же доступно множество настроек для формирования КС-2 и КС-3.

3240 руб.

13.02.2019    89617    404    44    

386

УТ 11, КА 2, ERP 2: Настраиваемые под каждую организацию печать и подпись ответственных лиц в печатных формах (ТОРГ-12, Счёт-фактура, УПД, УКД, Заказ клиента, Акт сверки, М-15 и др.)

Печатные формы Взаиморасчеты Оптовая торговля Производство готовой продукции (работ, услуг) Акт сверки Бухгалтер Пользователь Оперативный учет Управляемые формы 1С:Управление торговлей 11 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Задайте для каждой организации свою печать и для каждого физического лица свою подпись. Выберите в документе печатную форму "... с печатью и подписью" - и автоматически сформируется табличный документ с печатью и подписями той организации и ответственных лиц, которые указаны в документе.

12000 руб.

13.03.2018    57334    187    76    

117

Дебиторская задолженность по срокам долга

Взаиморасчеты Бухгалтер Пользователь Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Управление производственным предприятием 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Бухгалтерский учет Управленческий учет Платные (руб)

Один из лучших вариантов отчета по дебиторской задолженности. Отображает сроки возникновения задолженности, просроченной задолженности с точностью до регистратора, а также многое другое, вне зависимости от схемы взаиморасчетов (online / offline) и объекта расчетов (УТ 11.3, 11.4, 11.5, КА 2.4, 2.5, ERP 2.4, 2.5), состояния флажка "по документам расчета" ( УТ 10, КА 1.1, УПП 1.3) в договоре. Группирует задолженность по интервалам. Имеет большое количество настроек. Не требует доработок конфигурации.

15120 руб.

28.09.2012    95247    591    281    

141
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. Доня 285 29.01.10 15:19 Сейчас в теме
По картинке Акт содержательный!
А где сам файл? :o
2. AvtoBuhgalter 105 29.01.10 16:20 Сейчас в теме
(1) Где-то выскочил при загрузке. :)
Исправил.
4. valkovaolga 03.02.10 11:15 Сейчас в теме
(2) 1C Бухгалтерия 8.1 редакция 1.6 (1.6.22.4)

Файл вообще не открывается!
6. AvtoBuhgalter 105 03.02.10 20:10 Сейчас в теме
(4) (5) Что значит не открывается? Через Файл открыть чтоли?
(3) В заголовке сказано "Внешняя печатная форма для документа". Это означает, что её нельзя открыть просто так, а она предназначена для конкретного документа.

В описание добавлю как это сделать.
7. valkovaolga 04.02.10 08:49 Сейчас в теме
(6) Урра, все заработало. Спасибо!
3. Nadezhda09 03.02.10 08:02 Сейчас в теме
Здравствуйте!
А что значит "Подключается стандартным способом"?
5. света1969 03.02.10 13:36 Сейчас в теме
ни фига не открывает. изучение спроса?
8. Nadezhda09 05.02.10 10:20 Сейчас в теме
P.S. Для тех, кто в танке:

Спасибо. :{} Именно так я и делала. :)
Мне понравилось представление документов.
Но акт не формируется. Выходит сообщение:
Не удалось сформировать внешнюю печатную форму!
Поле объекта не обнаружено (РазбитьПоДоговорам)




10. AvtoBuhgalter 105 05.02.10 18:20 Сейчас в теме
(8) Проверил на релизах 1.6.19.3, 1.6.20.6, 1.6.23.2
с разными положениями галочек.
Все работает.
Чтоб не засорять лишними вопросами напишу в личку.
9. света1969 05.02.10 12:31 Сейчас в теме
Бухгалтерия предприятия, редакция 1.6 (1.6.22.4)
почему то 1с не видит этот файл?
11. AvtoBuhgalter 105 08.06.10 14:02 Сейчас в теме
Для УПП не предназначено.
12. Borisych 503 20.04.11 00:23 Сейчас в теме
Товарищи, зачем загружать мозг пользователей и терять свое время объясняя как подключить ВПФ или ОЗТЧ к документу?

Делаем в обработке форму с кодом, приведенным ниже, устанавливаем её основной.

Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
	СтандартнаяОбработка = Ложь;
	Отказ 				 = Истина;
	
	Если Ложь Тогда
		ЭтотОбъект = "";
		ИспользуемоеИмяФайла = "";
	КонецЕсли; 
	
	Если Найти(Строка(ЭтотОбъект), "Внешн") = 0 Тогда
		Сообщить("Автоматическая регистрация в справочнике ""Внешние обработки"" для обработки из конфигурации не предусмотрена. Сохраните обработку во внешний файл.", СтатусСообщения.БезСтатуса);
		Возврат;
	КонецЕсли;
	
	
	// инициализация параметров регистрации обработки
	ТипОбработки = "ПечатнаяФорма"; // "ПечатнаяФорма", "ЗаполнениеТабличныхЧастей", "Отчет", "Обработка"
    //
	СписокДокументов = Новый СписокЗначений; 
	СписокДокументов.Добавить("", "");
	//СписокДокументов.Добавить("АктСверкиВзаиморасчетов", "Акт сверки взаиморасчетов");
	//
	СписокТабличныхЧастейДокументов = Новый СписокЗначений; // для ОЗТЧ
	СписокТабличныхЧастейДокументов.Добавить("", "");
	//СписокТабличныхЧастейДокументов.Добавить("ПоДаннымКонтрагента", "По данным контрагента");
	//
	СписокПредставленийКнопки = Новый СписокЗначений; // для ОЗТЧ
	СписокПредставленийКнопки.Добавить("", "");
	//СписокПредставленийКнопки.Добавить("Заполнить по данным филиала", "Заполнить по данным филиала");
	//
	ОбработкаСиноним = ЭтотОбъект.Метаданные().Синоним;
	Для каждого Док Из СписокДокументов Цикл
		ДокМетаданные = Метаданные.Документы.Найти(Док.Значение);
		Если ДокМетаданные = Неопределено Тогда
			Предупреждение("Данная обработка предназначена для документа " + Док.Представление + "! 
			|В данной конфигурации не найден такой тип документа, регистрация обработки не проведена!");
			Возврат;
		ИначеЕсли ТипОбработки = "ЗаполнениеТабличныхЧастей" И ДокМетаданные.ТабличныеЧасти.Найти(СписокТабличныхЧастейДокументов[СписокДокументов.Индекс(Док)].Значение) = Неопределено Тогда
			Предупреждение("В данной конфигурации у документа """ + Док.Представление + """ не обнаружена табличная часть """
								+ СписокТабличныхЧастейДокументов[СписокДокументов.Индекс(Док)].Представление + """. Регистрация обработки не проведена!", 15);
			Возврат;
		КонецЕсли;
	КонецЦикла;
	Если НЕ ПравоДоступа("Изменение", Метаданные.Справочники.ВнешниеОбработки) Тогда
		Предупреждение("У Вас недостаточно прав доступа для регистрации обработки в информационной базе! Обратитесь к пользователю с административными правами!");
		Возврат;
	КонецЕсли;
	Эл = Справочники.ВнешниеОбработки.НайтиПоНаименованию(ОбработкаСиноним);
	Режим = "";
	Если Эл = Справочники.ВнешниеОбработки.ПустаяСсылка() Тогда
		Режим = "Создать";
	Иначе
		Если Вопрос("В информационной базе уже зарегистрирован" + 
					?(ТипОбработки = "ПечатнаяФорма", "а внешняя печатная форма", 
					  ?(ТипОбработки = "ЗаполнениеТабличныхЧастей", "а обработка заполнения табличных частей", 
					    ?(ТипОбработки = "Отчет", " отчет","а обработка"))) + " """ + 
					ОбработкаСиноним + """. Обновить существующую?", РежимДиалогаВопрос.ДаНет) = КодВозвратаДиалога.Да 
		Тогда
			Режим = "Обновить";
		КонецЕсли;
	КонецЕсли; 	
	Если Режим = "" Тогда                                                       
		Возврат;                                                                     
	КонецЕсли;
	Если Режим = "Создать" Тогда
		ЭлСпрВнОбр = Справочники.ВнешниеОбработки.СоздатьЭлемент();
	КонецЕсли;	
	Если Режим = "Обновить" Тогда 
		ЭлСпрВнОбр = Эл.ПолучитьОбъект();
	КонецЕсли;
	ЭлСпрВнОбр.ВидОбработки = Перечисления.ВидыДополнительныхВнешнихОбработок[ТипОбработки];
	ЭлСпрВнОбр.Наименование = ОбработкаСиноним;
	Файл = Новый Файл(ИспользуемоеИмяФайла);
	ЭлСпрВнОбр.КомментарийКФайлуИсточнику = "Исходный файл: " + Файл.Имя + Символы.ПС + "размер:" + Файл.Размер()+" байт; изменен:" + Файл.ПолучитьВремяИзменения() + "; сохранен в ИБ:" + ТекущаяДата();
	ЭлСпрВнОбр.ХранилищеВнешнейОбработки = Новый ХранилищеЗначения(Новый ДвоичныеДанные(ИспользуемоеИмяФайла));
	ЭлСпрВнОбр.Принадлежность.Очистить();
	Если ТипОбработки = "ПечатнаяФорма" ИЛИ ТипОбработки = "ЗаполнениеТабличныхЧастей" Тогда 
		Для каждого Док Из СписокДокументов Цикл                         
			Прин = ЭлСпрВнОбр.Принадлежность.Добавить();
			Прин.СсылкаОбъекта = Документы[Док.Значение].ПустаяСсылка();
			Если ТипОбработки = "ЗаполнениеТабличныхЧастей" Тогда
				Прин.ПредставлениеКнопки = СписокПредставленийКнопки[СписокДокументов.Индекс(Док)].Значение;
			Иначе
				Прин.ПредставлениеКнопки = ОбработкаСиноним;
			КонецЕсли;
			Прин.ПредставлениеОбъекта = "Документ """ + Метаданные.Документы[Док.Значение].Синоним +"""";
			Если ТипОбработки = "ЗаполнениеТабличныхЧастей" Тогда
				Прин.ТабличнаяЧастьИмя			 = СписокТабличныхЧастейДокументов[СписокДокументов.Индекс(Док)].Значение;	
				Прин.ТабличнаяЧастьПредставление = СписокТабличныхЧастейДокументов[СписокДокументов.Индекс(Док)].Представление;	
			КонецЕсли;
		КонецЦикла;
	КонецЕсли;
	ЭлСпрВнОбр.Записать();
	СтрокаТекста = "";
	Для каждого Док Из СписокДокументов Цикл
		СтрокаТекста = СтрокаТекста + ?(СтрокаТекста <> "",Символы.ПС,"") +
						?(ТипОбработки = "ПечатнаяФорма", "Внешняя печатная форма  """ + ОбработкаСиноним + """ документа  """ +  Док.Представление + """ зарегистрирована ", 
									  ?(ТипОбработки = "ЗаполнениеТабличныхЧастей", "Обработка заполнения табличной части """ + СписокТабличныхЧастейДокументов[СписокДокументов.Индекс(Док)].Представление + """ документа """ +  Док.Представление + """ зарегистрирована ", 
									    ?(ТипОбработки = "Отчет", "Отчет """ + ОбработкаСиноним + """ зарегистрирован ","Обработка """ + ОбработкаСиноним + """ зарегистрирована ")))
						 + "в справочнике ""Внешние обработки""";
	КонецЦикла;
	Предупреждение(СтрокаТекста,10);
	
	ФВО = Справочники.ВнешниеОбработки.ПолучитьФормуСписка();
	РеквизитОтбора = "Наименование";
	ФВО.Отбор[РеквизитОтбора].ВидСравнения	= ВидСравнения.Равно;
	ФВО.Отбор[РеквизитОтбора].Значение 		= ОбработкаСиноним;
	ФВО.Отбор[РеквизитОтбора].Использование	= Истина;
	ФВО.ЭлементыФормы.СправочникСписок.НастройкаОтбора[РеквизитОтбора].Доступность = Ложь;
	ФВО.Открыть();
	ФВО.ЭлементыФормы.СправочникСписок.ИерархическийПросмотр = Ложь;
	Для каждого Док Из СписокДокументов Цикл
		Если НЕ ПравоДоступа("Просмотр",Метаданные.Документы[Док.Значение]) Тогда
			Предупреждение("У Вас недостаточно прав доступа просмотра документов " + Метаданные.Документы[Док.Значение].Синоним + "!",10);
		Иначе
			Док = Документы[Док.Значение].Выбрать(,,,"Дата Убыв");
			Если Док.Следующий() Тогда
				Док.Ссылка.ПолучитьФорму().Открыть();
			КонецЕсли;
		КонецЕсли;
	КонецЦикла;	
	СтрокаТекста = "";
	Если ТипОбработки = "ПечатнаяФорма" ИЛИ ТипОбработки = "ЗаполнениеТабличныхЧастей" Тогда 
		Для каждого Стр Из ЭлСпрВнОбр.Принадлежность Цикл
			СтрокаТекста = СтрокаТекста + ?(СтрокаТекста <> "",Символы.ПС,"") + 
							?(ТипОбработки = "ПечатнаяФорма", 
								"Внешняя печатная форма " + Стр.ПредставлениеКнопки + """ документа """ + Стр.СсылкаОбъекта.Метаданные().Синоним + """",
							  	"Обработка заполнения табличной части """ + Стр.ПредставлениеКнопки + """ документа """ +  Стр.СсылкаОбъекта.Метаданные().Синоним + """");
		КонецЦикла;
	КонецЕсли;
	Справка = СтрокаТекста;
	Сообщить(Справка);				
	//Предупреждение(Справка,600);
КонецПроцедуры
Показать
Прикрепленные файлы:
ШаблонВПФ.epf
13. Anyu-n 28 18.03.14 22:36 Сейчас в теме
Классная идея! Только я еще цену добавила. А вы не подскажите для УТ тоже что-нибудь в разрезе по номенклатуре?
Оставьте свое сообщение