Подписи для 1С

28.02.19

Функциональные - Документооборот и делопроизводство (СЭД)

Получение подписей в Мобильной платформе 1С с помощью приложения.

Скачать исходный код

Наименование Файл Версия Размер
Подписи для 1С:
.apk 1,56Mb
8
.apk 1,56Mb 8 Скачать
Подписи для 1С:
.cf 1,39Mb
9
.cf 1 1,39Mb 9 Скачать

Публикация изменена.

Код приведен в виде примера из тестовой конфигурации.

Есть форма, при открытии которой мы обязаны проверить.

&НаКлиенте
Процедура ПриОткрытии(Отказ)
	
		#Если МобильноеПриложениеКлиент Тогда
			НовВз = Новый ЗапускПриложенияМобильногоУстройства();				
			НовВз.Действие 		= "com.example.avilmov.PAINT";
			НовВз.ДополнительныеДанные.Добавить("COMMAND", "SERCH");
			НовВз.ДополнительныеДанные.Добавить("OBJECT", "com.example.avilmov");
			Результат = НовВз.Запустить(Истина);
			Если НЕ Результат = -1 Тогда
				ИмяФайла = КаталогДокументов()+"PaintPGS.apk";
				ПроизвестиУстановкуПГСПайнт(ИмяФайла);
				ПоказатьПредупреждение(, "Будет установлено приложение для подписей 'PaintPGS.apk'",,"Установка 'PaintPGS.apk'");
				ЗапуститьПриложение(ИмяФайла,КаталогДокументов(),Истина);
				Установлено = Истина; //Реквизит формы, показывающий пользователю, установлено ли приложение
			Иначе
				Установлено = Истина;
			КонецЕсли;
		#КонецЕсли	
	
КонецПроцедуры

&НаСервере
Процедура ПроизвестиУстановкуПГСПайнт(Путь)
	
	Макет = ПолучитьОбщийМакет("Роспись"); // в макет сохранен АПК PaintPGS в виде двоичных данных
	Макет.Записать(Путь);
	
КонецПроцедуры

Добавляем команду "ПолучитьПодпись" и код

&НаКлиенте
Процедура ПолучитьПодпись(Команда)
	
	#Если МобильноеПриложениеКлиент Тогда
		НовВз = Новый ЗапускПриложенияМобильногоУстройства();
		
		НовВз.Действие 		= "com.example.avilmov.PAINT";
		
		//Подпись
		Результат = НовВз.Запустить(Истина);
		Если Результат = -1 Тогда
			Массив = НовВз.ДополнительныеДанные.Получить("IMG").Значение;
		Иначе 
			Предупреждение("Клиент не запустился",, "Ошибка запуска ПО");
			Возврат;
		КонецЕсли;
		
		Картинка = Base64Значение(Массив);
		Если НЕ Картинка = Неопределено Тогда
			ПодписьКартинка = ПоместитьВоВременноеХранилище(Картинка); //Отображаем картинку на форме
		КонецЕсли;
		
	#КонецЕсли
	
КонецПроцедуры

 

Картинка = Base64Значение(Массив) - получаем двоичные данные картинки, которые можем использовать при формировании табличных документов.

Картинка получаемая из приложения обрезается от пустот.

Это хорошо видно при тестировании.

 

Рисовалка Подписи

См. также

1С:Документооборот - цена на лицензии КОРП, ПРОФ и ДГУ

Документооборот и делопроизводство (СЭД) Типовые Платформа 1С v8.3 Управленческий учет Платные (руб)

Организуйте правильный оборот документов на вашем предприятии в 1С. Ведение учета и хранения документов. Управление потоками документации между подразделениями. Работа с договорами в компании. Автоматизация процессов подготовки, согласования и подписания документов. Сократите время и объем ошибок с 1С:ДО!

48500 руб.

19.02.2016    107488    106    5    

87

RayCon® Foreign Trade - Документооборот валютного контроля и международных платежей для участников ВЭД

Операции по ВЭД Документооборот и делопроизводство (СЭД) Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Управление холдингом 1С:Комплексная автоматизация 2.х Россия Бухгалтерский учет Платные (руб)

Программа предназначена для автоматизации внешнеторговых компаний и обеспечивает документооборот валютного контроля: присвоение Уникального номера контракта (УНК), формирований сведений о валютных операциях (СВО) и справок о подтверждающих документах (СПД), прочих необходимых форм учета и отчетности по валютным операциям согласно действующему валютному законодательству Российской Федерации, документооборот валютных платежей согласно международным стандартам и документооборот купли-продажи валюты, а также выгрузку любых документов 1С в любую систему клиент-банк.

30000 руб.

13.05.2009    67140    3    29    

42

Таймлист (1С:Совещание, Таймлист Лайт)

Документооборот и делопроизводство (СЭД) Конфигурации 1cv8

«Таймлист» – экосистема сервисов («Таймлист Лайт», «1C:Совещание», «Таймлист Recorder»), основанная на искусственном интеллекте Таймлист, который позволяет эффективно работать с легкими поручениями за счет фиксации всех важных идей при расшифровке и последующем формировании автопротокола встречи. Сервисы, в которые интегрирован ИИ, позволяют работать с задачами (поручениями), полученными из автопротокола.

10000 руб.

06.12.2023    1650    0    0    

8

"Штрихкод-информер" - мобильный ТСД и прайс-чекер в смартфоне

Мобильная разработка Сканер штрих-кода Терминал сбора данных Управляемые формы Мобильная платформа 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Управленческий учет Платные (руб)

Сбор заказов, инвентаризация, проверка ценников, просмотр полной информации об остатках и ценах со смартфона Онлайн. Отправка данных со смартфона выполняется либо напрямую в открытую форму документа, отсканировав QR-код, либо в общую корзину учетной системы, не подходя к компьютеру. Кассир или оператор сможет просмотреть список присланных данных и загрузить в любую форму, поддерживающую работу с ТСД. Для работы с мобильным приложением требуется опубликовать HTTP-сервис из поставляемого расширения.

2880 руб.

03.12.2018    55829    166    102    

163

SALE! 25%

Что нам стоит бота построить? Нарисуем - будет жить! Графический конструктор телеграм-ботов/Telegram

Мобильная разработка Мессенджеры и боты Платформа 1С v8.3 Платные (руб)

Теперь создать telegram-бота - элементарно. Достаточно просто нарисовать блок-схему телеграм-бота, и он сразу заработает. Это возможно при использовании Графического конструктора телеграм-ботов. Это единственный конструктор ботов для telegram, чье качество и функционал подтверждены фирмой 1С, есть сертификат 1С:Совместимо. Расширение в интерактивном режиме, с помощью блок-схем, позволяет с минимальными трудозатратами создать телеграм-ботов в любой конфигурации, работающей на платформе «1С:Предприятие 8.3».

13200 9900 руб.

27.12.2021    34529    87    161    

183

1С:Архив

Документооборот и делопроизводство (СЭД) Платформа 1С v8.3 Платные (руб)

"1С:Архив" – это универсальная система, обеспечивающая надежное долговременное хранение документов с гарантией юридической значимости на неограниченный срок. "1С:Архив" разработан на основе нормативно-правовых актов по архивному делу, поддерживает операции хранения документов – от попадания в архив до уничтожения – и не имеет ограничений на объем хранимых данных. "1С:Архив" сопровождается методологической поддержкой в виде организационных документов по хранению, входящих в состав "Комплекта нормативных документов" к "Методике управления документами и совместной работой", разработанной специалистами фирмы "1С". Использование "1С:Архива" позволяет организовать единое хранилище всех бумажных и электронных документов из разных информационных систем, вести архивный учет в соответствии с требованиями Росархива и снизить нагрузку на учетные системы. Продукт подходит для малых, средних, крупных предприятий и учреждений любых отраслей.

90000 руб.

24.10.2022    5026    5    1    

5

Программа "Мобильный ТСД сканер для 1С" - приложение для телефона для инвентаризации и сбора штрихкодов для iOS и Android

Сканер штрих-кода Терминал сбора данных Мобильная разработка Монитор заказов Оптовая торговля Розничная торговля Ценообразование, анализ цен Платформа 1С v8.3 Мобильная платформа 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Управленческий учет Платные (руб)

Простой мобильный ТСД (терминал сбора данных) сканер для 1С для смартфонов на iOS и Android, не требующий сложных настроек и установки дополнительных программ. Обмен между Вашей 1С и мобильным приложением осуществляется через облачный сервис и расширение конфигурации. Работает с конфигурациями УТ 11, ERP, КА2, Розница 2, Розница 3, УНФ 1.6, УНФ 3.0. Полнофункциональный демо-доступ для своей конфигурации можно запросить в настройках мобильного приложения - все необходимое придет на почту автоматически.

2000 руб.

22.04.2019    93027    532    186    

302

ЭДО: организация архива оригиналов первичных документов, комплексный отчет по ошибкам

Документооборот и делопроизводство (СЭД) ЭДО и ОФД Учет документов Платформа 1С v8.3 Конфигурации 1cv8 Россия Платные (руб)

Мощный, единый инструмент для решения всех проблем, связанных с переходом на ЭДО. Экономит бумагу и время - организует архив оригиналов первичных документов прямо в базе 1С, в прикрепленных файлах к соответствующим документам. С помощью комплексного отчета по ошибкам в ЭДО позволяет выявить и исправить все возможные ошибки - ошибочно сопоставленные документы, не подписанные документы, подписанные, но не загруженные в 1С документы. Автоматически сопоставляет не сопоставленные между собой документы. Может работать по расписанию и присылать отчет о состоянии архива/по ошибкам на почту. Взаимодействует напрямую с сервисами Диадок/СБИС, имеет интуитивно понятный интерфейс и учитывает 3-х летний опыт 40+ клиентов.

14880 руб.

17.12.2018    44665    60    51    

74
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. bulpi 215 01.03.19 20:40 Сейчас в теме
Все бы хорошо, но нужно выложить демо-конфигурацию, или хотя бы обработку. Иначе :
ИзменениеЗаголовкаЭлемента
ПроизвестиУстановкуПГСПайнт

это что такое ?
3. Grivba 15 04.03.19 23:52 Сейчас в теме
(1)
ИзменениеЗаголовкаЭлемента

В мобильном приложении версии 8.3.12 (если форма содержит несколько групп элементов) при изменении на клиенте "ползет"
4. Grivba 15 07.03.19 14:45 Сейчас в теме
(1)Приложил файл базы с сохраненной apk в макете
5. bulpi 215 07.03.19 16:31 Сейчас в теме
(4)
Спасибо, вот теперь +
2. Grivba 15 04.03.19 23:50 Сейчас в теме
Код выдернут из рабочей конфигурации.
ИзменениеЗаголовкаЭлемента - серверная процедура изменяющая заголовок декорации (элемента формы)
ПроизвестиУстановкуПГСПайнт - серверная процедура, сохраняющая макет по указанному пути в телефон, в дальнейшем этот фаул устанавливается.
6. onec.developer 181 01.04.19 19:39 Сейчас в теме
7. Grivba 15 02.04.19 16:33 Сейчас в теме
(6)
В это приложении отсутствует все то многообразие настроек, вроде толщины пера, цвета и т.д.
Все линии одной толщины, как ручкой.
Итоговый рисунок - в нашем случае это роспись, обрезается по нарисованному. это легко удивить в примере.
Все просто и ничего лишнего.
+ В этом приложении реализуются допы, Сейчас добавлены возможность отправлять строковые данные на БТ принтер, работа со модулем сканера на ТСД Zebra.
Оставьте свое сообщение