Выгрузка работников из Бухгалтерии в Документооборот КОРП

27.09.19

Функциональные - Документооборот и делопроизводство (СЭД)

Описание реализации выгрузки пользователей из конфигурации Бухгалтерия для Казахстана (ред. 1) в Документооборот для Казахстана КОРП (ред. 2). На стороне источника используется веб-сервис. На стороне приемника внешняя обработка.

Скачать исходный код

Наименование Файл Версия Размер
Выгрузка работников из Бухгалтерии в Документооборот КОРП:
.7z 6,45Kb
1
.7z 6,45Kb 1 Скачать

На стороне источника (БП) реализован веб-сервис UploadUsers и метод Upload().

Для передачи данных реализован XDTO-пакет следующей структуры:

Написана функция для метода Upload(). Код приведен ниже:

Функция Upload()
	
	УстановитьПривилегированныйРежим(Истина);
	
	Запрос = Новый Запрос;
	Запрос.Текст=
	"ВЫБРАТЬ РАЗРЕШЕННЫЕ
	|	РаботникиОрганизацийСрезПоследних.Физлицо,
	|	МАКСИМУМ(РаботникиОрганизацийСрезПоследних.Период) КАК Период,
	|	РаботникиОрганизацийСрезПоследних.ПричинаИзмененияСостояния,
	|	РаботникиОрганизацийСрезПоследних.ПодразделениеОрганизации,
	|	РаботникиОрганизацийСрезПоследних.Должность
	|ПОМЕСТИТЬ втПриемы
	|ИЗ
	|	РегистрСведений.РаботникиОрганизаций.СрезПоследних(
	|			&ДатаАктуальности,
	|			Организация = &Организация
	|				И ПричинаИзмененияСостояния В (&сзСостояния)) КАК РаботникиОрганизацийСрезПоследних
	|
	|СГРУППИРОВАТЬ ПО
	|	РаботникиОрганизацийСрезПоследних.Физлицо,
	|	РаботникиОрганизацийСрезПоследних.ПричинаИзмененияСостояния,
	|	РаботникиОрганизацийСрезПоследних.ПодразделениеОрганизации,
	|	РаботникиОрганизацийСрезПоследних.Должность
	|;
	|
	|////////////////////////////////////////////////////////////////////////////////
	|ВЫБРАТЬ РАЗРЕШЕННЫЕ
	|	РаботникиОрганизацийСрезПоследних.Физлицо,
	|	МАКСИМУМ(РаботникиОрганизацийСрезПоследних.Период) КАК Период,
	|	РаботникиОрганизацийСрезПоследних.ПричинаИзмененияСостояния
	|ПОМЕСТИТЬ втУволенные
	|ИЗ
	|	РегистрСведений.РаботникиОрганизаций.СрезПоследних(
	|			&ДатаАктуальности,
	|			Организация = &Организация
	|				И ПричинаИзмененияСостояния = &парамУвольнение) КАК РаботникиОрганизацийСрезПоследних
	|
	|СГРУППИРОВАТЬ ПО
	|	РаботникиОрганизацийСрезПоследних.Физлицо,
	|	РаботникиОрганизацийСрезПоследних.ПричинаИзмененияСостояния
	|;
	|
	|////////////////////////////////////////////////////////////////////////////////
	|ВЫБРАТЬ РАЗРЕШЕННЫЕ
	|	втПриемы.Физлицо,
	|	втПриемы.ПричинаИзмененияСостояния КАК Принят,
	|	втУволенные.ПричинаИзмененияСостояния КАК Уволен,
	|	втПриемы.ПодразделениеОрганизации,
	|	втПриемы.Должность
	|ПОМЕСТИТЬ втПредРаботники
	|ИЗ
	|	втПриемы КАК втПриемы
	|		ЛЕВОЕ СОЕДИНЕНИЕ втУволенные КАК втУволенные
	|		ПО втПриемы.Физлицо = втУволенные.Физлицо
	|			И втПриемы.Период < втУволенные.Период
	|;
	|
	|////////////////////////////////////////////////////////////////////////////////
	|ВЫБРАТЬ РАЗРЕШЕННЫЕ
	|	втПредРаботники.Физлицо,
	|	втПредРаботники.ПодразделениеОрганизации,
	|	втПредРаботники.Должность
	|ПОМЕСТИТЬ втРаботающие
	|ИЗ
	|	втПредРаботники КАК втПредРаботники
	|ГДЕ
	|	втПредРаботники.Уволен ЕСТЬ NULL
	|;
	|
	|////////////////////////////////////////////////////////////////////////////////
	|ВЫБРАТЬ
	|	КонтактнаяИнформация.Объект,
	|	КонтактнаяИнформация.Тип,
	|	КонтактнаяИнформация.Вид,
	|	КонтактнаяИнформация.Представление
	|ПОМЕСТИТЬ втДоменныеУчетныеЗаписи
	|ИЗ
	|	РегистрСведений.КонтактнаяИнформация КАК КонтактнаяИнформация
	|ГДЕ
	|	КонтактнаяИнформация.Тип = &Тип
	|	И КонтактнаяИнформация.Вид = &Вид
	|;
	|
	|////////////////////////////////////////////////////////////////////////////////
	|ВЫБРАТЬ РАЗРЕШЕННЫЕ
	|	втРаботающие.Физлицо,
	|	втРаботающие.ПодразделениеОрганизации,
	|	ЕСТЬNULL(втРаботающие.Должность, """") КАК Должность,
	|	ЕСТЬNULL(втРаботающие.ПодразделениеОрганизации.Родитель, """") КАК ПодразделениеОрганизацииРодитель,
	|	ЕСТЬNULL(втДоменныеУчетныеЗаписи.Представление, """") КАК ДомменнаяУчетнаяЗапись
	|ИЗ
	|	втРаботающие КАК втРаботающие
	|		ЛЕВОЕ СОЕДИНЕНИЕ втДоменныеУчетныеЗаписи КАК втДоменныеУчетныеЗаписи
	|		ПО втРаботающие.Физлицо = втДоменныеУчетныеЗаписи.Объект
	|
	|УПОРЯДОЧИТЬ ПО
	|	втРаботающие.Физлицо.Наименование";
	Запрос.УстановитьПараметр("Организация", Справочники.Организации.НайтиПоКоду("000000001"));
	Запрос.УстановитьПараметр("ДатаАктуальности", ТекущаяДата());
	Запрос.УстановитьПараметр("Тип", Перечисления.ТипыКонтактнойИнформации.Другое);
	Запрос.УстановитьПараметр("Вид", Справочники.ВидыКонтактнойИнформации.НайтиПоКоду("KR0000007"));

	
	сзСостояния = Новый СписокЗначений;
	сзСостояния.Добавить(Перечисления.ПричиныИзмененияСостояния.ПриемНаРаботу);
	сзСостояния.Добавить(Перечисления.ПричиныИзмененияСостояния.Перемещение);
	
	Запрос.УстановитьПараметр("сзСостояния", сзСостояния);
	Запрос.УстановитьПараметр("парамУвольнение", Перечисления.ПричиныИзмененияСостояния.Увольнение);
	
	тзРез = Запрос.Выполнить().Выгрузить();
	
	Если тзРез.Количество()>0 тогда
		
		МассивПользователейТип = ФабрикаXDTO.Тип("http://www.company.kz/ws/users", "UserList");
		ПользовательТип = ФабрикаXDTO.Тип("http://www.company.kz/ws/users", "User");
		
		UserList = ФабрикаXDTO.Создать(МассивПользователейТип);
		
		Для каждого стр из тзРез Цикл
			
			User = ФабрикаXDTO.Создать(ПользовательТип);
			
			User.FIO         = стр.ФизЛицо.Наименование;
			User.unit_name   = стр.ПодразделениеОрганизации.Наименование;
			User.unit_id     = стр.ПодразделениеОрганизации.Код;
			User.upunit_name = стр.ПодразделениеОрганизацииРодитель.Наименование;
			User.upunit_id   = стр.ПодразделениеОрганизацииРодитель.Код;
			User.user_id     = стр.ФизЛицо.Код; 
			User.user_post   = стр.Должность.Наименование;
			User.dclogin     = стр.ДомменнаяУчетнаяЗапись;
			
			UserList.User.Добавить(User);
			
		КонецЦикла;
		
		Возврат UserList;		
		
	КонецЕсли;
	
	УстановитьПривилегированныйРежим(Ложь);
	
КонецФункции

 

На стороне приемника (ДО) запускается внешняя обработка, которая получает данные от веб-сервиса и создает в ДО подразделения, пользователи, должности. Код обработки приведен ниже:


&НаСервере
Процедура НачатьСинхронизациюНаСервере()
	//подключаемся к веб-сервису
	всОпред = Новый WSОпределения(Объект.СтрокаПодключенияКВебСервису,Объект.Пользователь,Объект.Пароль,,,);
	всПрокси = Новый WSПрокси(всОпред, "http://www.company.kz/ws/users", "UploadUsers", "UploadUsersSoap",,,);
	всПрокси.Пользователь=Объект.Пользователь;
	всПрокси.Пароль=Объект.Пароль;
	//вызываем метод веб-сервиса
	Значение = всПрокси.Upload();
	//создаем таблицу значений, в которую выгрузим данные
	ТЗПользователей = Новый ТаблицаЗначений;
	ТЗПользователей.Колонки.Добавить("ФИО");
	ТЗПользователей.Колонки.Добавить("ДоменнаяУчетнаяЗапись");
	ТЗПользователей.Колонки.Добавить("Подразделение");
	ТЗПользователей.Колонки.Добавить("ВышестоящееПодразделение");
	ТЗПользователей.Колонки.Добавить("Должность");
	ТЗПользователей.Колонки.Добавить("КодСотрудника");
	ТЗПользователей.Колонки.Добавить("КодПодразделения");
	ТЗПользователей.Колонки.Добавить("КодВышестоящееПодразделение");
	
	Для каждого стр из Значение.User цикл
		
		НоваяСтрока = ТЗПользователей.Добавить();
		НоваяСтрока.ФИО                          = стр.FIO;
		НоваяСтрока.ДоменнаяУчетнаяЗапись        = стр.dclogin;
		НоваяСтрока.Подразделение                = стр.unit_name;
		НоваяСтрока.ВышестоящееПодразделение     = стр.upunit_name;
		НоваяСтрока.Должность                    = стр.user_post;
		НоваяСтрока.КодСотрудника                = стр.user_id;
		НоваяСтрока.КодПодразделения             = стр.unit_id;
		НоваяСтрока.КодВышестоящееПодразделение  = стр.upunit_id;
		
	КонецЦикла;
	
	Для каждого стрТЗ из ТЗПользователей цикл
		//ищем подразделение вместе с вышестоящим
		ИскПодразделение = НайтиИлиСоздатьПодразделение(стрТЗ.КодПодразделения,стрТЗ.Подразделение,стрТЗ.КодВышестоящееПодразделение,стрТЗ.ВышестоящееПодразделение);
		//ищем пользователя
		ИскСотрудник = НайтиПользователя(стрТЗ.КодСотрудника);
		
		Если ИскСотрудник=Неопределено тогда
			ОбъектПользователь = Справочники.Пользователи.СоздатьЭлемент();
			//заполняем дополнительный реквизит "КодСотрудника" кодом из источника
			НовСтрока = ОбъектПользователь.ДополнительныеРеквизиты.Добавить();
			НовСтрока.Свойство = ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("КодСотрудника");
			НовСтрока.Значение = стрТЗ.КодСотрудника;
			НовСтрока.ТекстоваяСтрока = стрТЗ.КодСотрудника;

		Иначе ОбъектПользователь = ИскСотрудник.ПолучитьОбъект();	
		КонецЕсли;
		
		ОбъектПользователь.Наименование = стрТЗ.ФИО;
		ОбъектПользователь.Подразделение = ИскПодразделение.Ссылка;
		ОбъектПользователь.КодЯзыка = "ru";
		ОбъектПользователь.ПредставлениеВДокументах = стрТЗ.ФИО;
		ОбъектПользователь.ПредставлениеВПереписке = стрТЗ.ФИО;
		ОбъектПользователь.ПредставлениеВПерепискеСРангом = стрТЗ.ФИО;
		
		//создаем пользователя информационной базы отправляя структуру параметров через дополнительные свойства
		//процедуры сами сделают связь с элементом справочника "Пользователи" и пользователем ИБ через уникальный идентификатор
		ОписаниеПользователяИБ = Новый Структура; 
		ОписаниеПользователяИБ.Вставить("Действие", "Записать"); 
		ОписаниеПользователяИБ.Вставить("Имя", стрТЗ.ФИО);
		ОписаниеПользователяИБ.Вставить("ПолноеИмя", стрТЗ.ФИО);
		ОписаниеПользователяИБ.Вставить("АутентификацияОС", Истина); 
		ОписаниеПользователяИБ.Вставить("ПоказыватьВСпискеВыбора", Истина); 
		ОписаниеПользователяИБ.Вставить("ПользовательОС", стрТЗ.ДоменнаяУчетнаяЗапись); 
		ОписаниеПользователяИБ.Вставить("АутентификацияСтандартная", Ложь); 

		ОбъектПользователь.ДополнительныеСвойства.Вставить("ОписаниеПользователяИБ", ОписаниеПользователяИБ); 
		ОбъектПользователь.Записать();
		//записываем доп сведения по пользователю, чтобы в карточке пользователя отображались
		НаборЗаписей = РегистрыСведений.СведенияОПользователяхДокументооборот.СоздатьНаборЗаписей();
		НаборЗаписей.Отбор.Пользователь.Установить(ОбъектПользователь.Ссылка);
		НаборЗаписей.Прочитать();
		НаборЗаписей.Записать();
		Запись = НаборЗаписей.Добавить();
		Запись.Пользователь = ОбъектПользователь.Ссылка;
		Запись.Подразделение = ИскПодразделение.Ссылка;
		Запись.Должность = ?(ПустаяСтрока(стрТЗ.Должность),"", НайтиИлиСоздатьДолжность(стрТЗ.Должность));
		Запись.ГрафикРаботы = Справочники.ГрафикиРаботы.НайтиПоНаименованию("Пятидневка");
		НаборЗаписей.Записать();		
		
	КонецЦикла;
		
КонецПроцедуры

&НаСервере
Функция НайтиИлиСоздатьДолжность(НаименованиеДолжности)
	
	ИскДолжность = Справочники.Должности.НайтиПоНаименованию(НаименованиеДолжности, Истина);
	
	Если ИскДолжность=Справочники.Должности.ПустаяСсылка() тогда
		ДолжноситьОбъект = Справочники.Должности.СоздатьЭлемент();
		ДолжноситьОбъект.Наименование = НаименованиеДолжности;
		ДолжноситьОбъект.Записать();
		
		ИскДолжносить = ДолжноситьОбъект.Ссылка;
	КонецЕсли;
	
	Возврат ИскДолжность.Ссылка;  	
	
КонецФункции


&НаСервере
Функция НайтиИлиСоздатьПодразделение(КодПодразделения,Подразделение,КодВышестоящееПодразделение,ВышестоящееПодразделение)

	//сперва изем вышестоящее подразделение, если нет то создаем
	Запрос = новый Запрос;
	Запрос.Текст=
	"ВЫБРАТЬ
	|	СтруктураПредприятияДополнительныеРеквизиты.Ссылка
	|ИЗ
	|	Справочник.СтруктураПредприятия.ДополнительныеРеквизиты КАК СтруктураПредприятияДополнительныеРеквизиты
	|ГДЕ
	|	СтруктураПредприятияДополнительныеРеквизиты.Свойство = &Свойство
	|	И СтруктураПредприятияДополнительныеРеквизиты.Значение = &Значение";
	Запрос.УстановитьПараметр("Свойство", ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("ВнешнийКод"));
	Запрос.УстановитьПараметр("Значение", КодВышестоящееПодразделение);	
	
	тзВышПод = Запрос.Выполнить().Выгрузить();
	
	Если тзВышПод.Количество()>0 тогда
		ВышПод = тзВышПод[0].Ссылка.ПолучитьОбъект();
	Иначе ВышПод = Справочники.СтруктураПредприятия.СоздатьЭлемент();	
	    ВышПод.Наименование = ВышестоящееПодразделение;	
		
		НовСтрока = ВышПод.ДополнительныеРеквизиты.Добавить();
		НовСтрока.Свойство = ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("ВнешнийКод");
		НовСтрока.Значение = КодВышестоящееПодразделение;
		НовСтрока.ТекстоваяСтрока = КодВышестоящееПодразделение;
		ВышПод.Записать();

	КонецЕсли;
		
	//теперь ищем само подразделение
	Запрос = новый Запрос;
	Запрос.Текст=
	"ВЫБРАТЬ
	|	СтруктураПредприятияДополнительныеРеквизиты.Ссылка
	|ИЗ
	|	Справочник.СтруктураПредприятия.ДополнительныеРеквизиты КАК СтруктураПредприятияДополнительныеРеквизиты
	|ГДЕ
	|	СтруктураПредприятияДополнительныеРеквизиты.Свойство = &Свойство
	|	И СтруктураПредприятияДополнительныеРеквизиты.Значение = &Значение";
	Запрос.УстановитьПараметр("Свойство", ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("ВнешнийКод"));
	Запрос.УстановитьПараметр("Значение", КодПодразделения);	
	
	тзПод = Запрос.Выполнить().Выгрузить();
	
	Если тзПод.Количество()>0 тогда
		Под = тзПод[0].Ссылка.ПолучитьОбъект();
	Иначе Под = Справочники.СтруктураПредприятия.СоздатьЭлемент();	
	    Под.Наименование = Подразделение;
		
		НовСтрока = Под.ДополнительныеРеквизиты.Добавить();
		НовСтрока.Свойство = ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("ВнешнийКод");
		НовСтрока.Значение = КодПодразделения;
		НовСтрока.ТекстоваяСтрока = КодПодразделения;
		Под.Записать();

	КонецЕсли;
	
	Под.Родитель = ВышПод.Ссылка;
	
	Под.Записать();
	
	Возврат Под.Ссылка;	
	
КонецФункции

&НаСервере
Функция НайтиПользователя(КодСотрудника)
	
	ИскПользователь = Неопределено;
	
	Запрос = Новый Запрос;
	Запрос.Текст=
	"ВЫБРАТЬ
	|	ПользователиДополнительныеРеквизиты.Ссылка
	|ИЗ
	|	Справочник.Пользователи.ДополнительныеРеквизиты КАК ПользователиДополнительныеРеквизиты
	|ГДЕ
	|	ПользователиДополнительныеРеквизиты.Свойство = &Свойство
	|	И ПользователиДополнительныеРеквизиты.Значение = &Значение";
	Запрос.УстановитьПараметр("Свойство",ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("КодСотрудника"));
	Запрос.УстановитьПараметр("Значение",КодСотрудника);
	
	тзРез = Запрос.Выполнить().Выгрузить();
	
	Если тзРез.Количество()>0 тогда
		ИскПользователь = тзРез[0].Ссылка;
	КонецЕсли;
	
	Возврат ИскПользователь; 	
	
КонецФункции


&НаКлиенте
Процедура НачатьСинхронизацию(Команда)
	НачатьСинхронизациюНаСервере();
КонецПроцедуры

Можете скачать архив со схемой XDTO-пакета и обработкой "Синхронизация пользователей".

В итоге получаем выстроенную структуру предприятия, пользователей и авторизацию через ОС. Затем, опубликовав базу Документооборот на веб-сервере, получаем работающую систему ДО.

 

документооборот веб-сервис пользователь синхронизация

См. также

1С:Документооборот - цена на лицензии КОРП, ПРОФ и ДГУ

Документооборот и делопроизводство (СЭД) Типовые Бухгалтер Пользователь Руководитель проекта Платформа 1С v8.3 Управленческий учет Платные (руб)

Организуйте правильный оборот документов на вашем предприятии в 1С. Ведение учета и хранения документов. Управление потоками документации между подразделениями. Работа с договорами в компании. Автоматизация процессов подготовки, согласования и подписания документов. Сократите время и объем ошибок с 1С:ДО!

48500 руб.

19.02.2016    107556    107    5    

89

Перенос данных из УПП 1.3 в ERP 2 / УТ 11 / КА 2. Переносятся документы, справочная информация и остатки

Перенос данных 1C Программист Платформа 1С v8.3 1С:Управление производственным предприятием 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

Перенос документов, начальных остатков и справочной информации из УПП 1.3 в ERP 2 | из УПП 1.3 в УТ 11 | из УПП в КА 2 | Правила конвертации (КД 2) в продаже с 2015 года, постоянно работаем над их развитием | Более 360 предприятий выполнили переход с использованием этого продукта! | Сэкономьте время - используйте готовое решение для перехода! | Позволяет перенести из УПП 1.3 в ERP / УТ 11 / КА 2 всю возможную информацию | В переносе есть фильтр по организации и множество других опциональных параметров выгрузки | Есть несколько алгоритмов выгрузки остатков на выбор

45650 руб.

04.08.2015    161423    362    269    

354

SALE! 10%

Синхронизация и обмен для ERP 2.5, КА 2.5, УТ 11.5 БП 3.0, Розница, УНФ и других с EnterpriseData (универсальный формат обмена), правила обмена

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Россия Платные (руб)

Правила в универсальном формате обмена для ERP 2.5, КА 2.5, УТ 11.5, БП 3.0, Розница, УНФ, для последних версий конфигураций. Ссылки на другие конфигурации в описании публикации. Правила совместимы со всеми другими версиями конфигураций новыми и старыми, поддерживающими обмен и синхронизацию в формате EnterpriseData. Не требуется синхронного обновления правил после обновления другой конфигурации, участвующей в обмене. Типовой обмен через планы обмена кнопкой Синхронизация вручную или автоматически по расписанию, или вручную обработкой.

25080 руб.

12.06.2017    136817    735    292    

394

Перенос данных из ERP 2 / КА 2 / УТ 11 в БП 3.0. Переносятся документы, начальные остатки и справочники

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

Перенос данных из ERP в БП 3 | из КА 2 в БП 3 | из УТ 11 в БП 3 | из ЕРП в БП 3 | В продаже с 2019г. | Воспользовались более 176 предприятий! | Сэкономьте время - используйте готовое решение для перехода! | Перенос разработан в формате КД 2 (правила конвертации данных) | Переносятся все возможные виды документов, начальных остатков и нормативно-справочная информация| Можно опционально выгружать каждую пару "номенклатура+характеристика" как отдельную номенклатуру | Есть выгрузка настроек счетов учета и зарплатных данных из ERP / КА 2 | Можно проверить на вашем сервере перед покупкой, обращайтесь!

34650 руб.

15.04.2019    69546    167    141    

112

Перенос данных из УТ 10.3 в УТ 11.5. Переносятся документы (обороты за период), справочная информация и остатки

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 10 1С:Управление торговлей 11 Россия Управленческий учет Платные (руб)

Перенос данных из 1С:Управление торговлей 10.3 в 1С:Управление торговлей 11.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УТ 10.3.87.x и УТ 11.5.16.x

28000 руб.

23.07.2020    47566    205    64    

166

Перенос данных из УПП 1.3 в БП 3.0. Переносятся документы (обороты за период), справочная информация и остатки

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Управление производственным предприятием 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:Бухгалтерия предприятия 3.0 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УПП 1.3 (1.3.227.x) и БП 3.0 (3.0.151.x). Правила подходят для версии ПРОФ и КОРП.

28000 руб.

15.12.2021    21135    138    38    

97

1С:Архив

Документооборот и делопроизводство (СЭД) Платформа 1С v8.3 Платные (руб)

"1С:Архив" – это универсальная система, обеспечивающая надежное долговременное хранение документов с гарантией юридической значимости на неограниченный срок. "1С:Архив" разработан на основе нормативно-правовых актов по архивному делу, поддерживает операции хранения документов – от попадания в архив до уничтожения – и не имеет ограничений на объем хранимых данных. "1С:Архив" сопровождается методологической поддержкой в виде организационных документов по хранению, входящих в состав "Комплекта нормативных документов" к "Методике управления документами и совместной работой", разработанной специалистами фирмы "1С". Использование "1С:Архива" позволяет организовать единое хранилище всех бумажных и электронных документов из разных информационных систем, вести архивный учет в соответствии с требованиями Росархива и снизить нагрузку на учетные системы. Продукт подходит для малых, средних, крупных предприятий и учреждений любых отраслей.

90000 руб.

24.10.2022    5051    6    1    

5

Таймлист (1С:Совещание, Таймлист Лайт)

Документооборот и делопроизводство (СЭД) Конфигурации 1cv8

«Таймлист» – экосистема сервисов («Таймлист Лайт», «1C:Совещание», «Таймлист Recorder»), основанная на искусственном интеллекте Таймлист, который позволяет эффективно работать с легкими поручениями за счет фиксации всех важных идей при расшифровке и последующем формировании автопротокола встречи. Сервисы, в которые интегрирован ИИ, позволяют работать с задачами (поручениями), полученными из автопротокола.

10000 руб.

06.12.2023    1709    0    0    

8
Оставьте свое сообщение