Выгрузка работников из Бухгалтерии в Документооборот КОРП

Публикация № 1128232

Управление - Документооборот и делопроизводство

документооборот веб-сервис пользователь синхронизация

1
Описание реализации выгрузки пользователей из конфигурации Бухгалтерия для Казахстана (ред. 1) в Документооборот для Казахстана КОРП (ред. 2). На стороне источника используется веб-сервис. На стороне приемника внешняя обработка.

На стороне источника (БП) реализован веб-сервис UploadUsers и метод Upload().

Для передачи данных реализован XDTO-пакет следующей структуры:

Написана функция для метода Upload(). Код приведен ниже:

Функция Upload()
	
	УстановитьПривилегированныйРежим(Истина);
	
	Запрос = Новый Запрос;
	Запрос.Текст=
	"ВЫБРАТЬ РАЗРЕШЕННЫЕ
	|	РаботникиОрганизацийСрезПоследних.Физлицо,
	|	МАКСИМУМ(РаботникиОрганизацийСрезПоследних.Период) КАК Период,
	|	РаботникиОрганизацийСрезПоследних.ПричинаИзмененияСостояния,
	|	РаботникиОрганизацийСрезПоследних.ПодразделениеОрганизации,
	|	РаботникиОрганизацийСрезПоследних.Должность
	|ПОМЕСТИТЬ втПриемы
	|ИЗ
	|	РегистрСведений.РаботникиОрганизаций.СрезПоследних(
	|			&ДатаАктуальности,
	|			Организация = &Организация
	|				И ПричинаИзмененияСостояния В (&сзСостояния)) КАК РаботникиОрганизацийСрезПоследних
	|
	|СГРУППИРОВАТЬ ПО
	|	РаботникиОрганизацийСрезПоследних.Физлицо,
	|	РаботникиОрганизацийСрезПоследних.ПричинаИзмененияСостояния,
	|	РаботникиОрганизацийСрезПоследних.ПодразделениеОрганизации,
	|	РаботникиОрганизацийСрезПоследних.Должность
	|;
	|
	|////////////////////////////////////////////////////////////////////////////////
	|ВЫБРАТЬ РАЗРЕШЕННЫЕ
	|	РаботникиОрганизацийСрезПоследних.Физлицо,
	|	МАКСИМУМ(РаботникиОрганизацийСрезПоследних.Период) КАК Период,
	|	РаботникиОрганизацийСрезПоследних.ПричинаИзмененияСостояния
	|ПОМЕСТИТЬ втУволенные
	|ИЗ
	|	РегистрСведений.РаботникиОрганизаций.СрезПоследних(
	|			&ДатаАктуальности,
	|			Организация = &Организация
	|				И ПричинаИзмененияСостояния = &парамУвольнение) КАК РаботникиОрганизацийСрезПоследних
	|
	|СГРУППИРОВАТЬ ПО
	|	РаботникиОрганизацийСрезПоследних.Физлицо,
	|	РаботникиОрганизацийСрезПоследних.ПричинаИзмененияСостояния
	|;
	|
	|////////////////////////////////////////////////////////////////////////////////
	|ВЫБРАТЬ РАЗРЕШЕННЫЕ
	|	втПриемы.Физлицо,
	|	втПриемы.ПричинаИзмененияСостояния КАК Принят,
	|	втУволенные.ПричинаИзмененияСостояния КАК Уволен,
	|	втПриемы.ПодразделениеОрганизации,
	|	втПриемы.Должность
	|ПОМЕСТИТЬ втПредРаботники
	|ИЗ
	|	втПриемы КАК втПриемы
	|		ЛЕВОЕ СОЕДИНЕНИЕ втУволенные КАК втУволенные
	|		ПО втПриемы.Физлицо = втУволенные.Физлицо
	|			И втПриемы.Период < втУволенные.Период
	|;
	|
	|////////////////////////////////////////////////////////////////////////////////
	|ВЫБРАТЬ РАЗРЕШЕННЫЕ
	|	втПредРаботники.Физлицо,
	|	втПредРаботники.ПодразделениеОрганизации,
	|	втПредРаботники.Должность
	|ПОМЕСТИТЬ втРаботающие
	|ИЗ
	|	втПредРаботники КАК втПредРаботники
	|ГДЕ
	|	втПредРаботники.Уволен ЕСТЬ NULL
	|;
	|
	|////////////////////////////////////////////////////////////////////////////////
	|ВЫБРАТЬ
	|	КонтактнаяИнформация.Объект,
	|	КонтактнаяИнформация.Тип,
	|	КонтактнаяИнформация.Вид,
	|	КонтактнаяИнформация.Представление
	|ПОМЕСТИТЬ втДоменныеУчетныеЗаписи
	|ИЗ
	|	РегистрСведений.КонтактнаяИнформация КАК КонтактнаяИнформация
	|ГДЕ
	|	КонтактнаяИнформация.Тип = &Тип
	|	И КонтактнаяИнформация.Вид = &Вид
	|;
	|
	|////////////////////////////////////////////////////////////////////////////////
	|ВЫБРАТЬ РАЗРЕШЕННЫЕ
	|	втРаботающие.Физлицо,
	|	втРаботающие.ПодразделениеОрганизации,
	|	ЕСТЬNULL(втРаботающие.Должность, """") КАК Должность,
	|	ЕСТЬNULL(втРаботающие.ПодразделениеОрганизации.Родитель, """") КАК ПодразделениеОрганизацииРодитель,
	|	ЕСТЬNULL(втДоменныеУчетныеЗаписи.Представление, """") КАК ДомменнаяУчетнаяЗапись
	|ИЗ
	|	втРаботающие КАК втРаботающие
	|		ЛЕВОЕ СОЕДИНЕНИЕ втДоменныеУчетныеЗаписи КАК втДоменныеУчетныеЗаписи
	|		ПО втРаботающие.Физлицо = втДоменныеУчетныеЗаписи.Объект
	|
	|УПОРЯДОЧИТЬ ПО
	|	втРаботающие.Физлицо.Наименование";
	Запрос.УстановитьПараметр("Организация", Справочники.Организации.НайтиПоКоду("000000001"));
	Запрос.УстановитьПараметр("ДатаАктуальности", ТекущаяДата());
	Запрос.УстановитьПараметр("Тип", Перечисления.ТипыКонтактнойИнформации.Другое);
	Запрос.УстановитьПараметр("Вид", Справочники.ВидыКонтактнойИнформации.НайтиПоКоду("KR0000007"));

	
	сзСостояния = Новый СписокЗначений;
	сзСостояния.Добавить(Перечисления.ПричиныИзмененияСостояния.ПриемНаРаботу);
	сзСостояния.Добавить(Перечисления.ПричиныИзмененияСостояния.Перемещение);
	
	Запрос.УстановитьПараметр("сзСостояния", сзСостояния);
	Запрос.УстановитьПараметр("парамУвольнение", Перечисления.ПричиныИзмененияСостояния.Увольнение);
	
	тзРез = Запрос.Выполнить().Выгрузить();
	
	Если тзРез.Количество()>0 тогда
		
		МассивПользователейТип = ФабрикаXDTO.Тип("http://www.company.kz/ws/users", "UserList");
		ПользовательТип = ФабрикаXDTO.Тип("http://www.company.kz/ws/users", "User");
		
		UserList = ФабрикаXDTO.Создать(МассивПользователейТип);
		
		Для каждого стр из тзРез Цикл
			
			User = ФабрикаXDTO.Создать(ПользовательТип);
			
			User.FIO         = стр.ФизЛицо.Наименование;
			User.unit_name   = стр.ПодразделениеОрганизации.Наименование;
			User.unit_id     = стр.ПодразделениеОрганизации.Код;
			User.upunit_name = стр.ПодразделениеОрганизацииРодитель.Наименование;
			User.upunit_id   = стр.ПодразделениеОрганизацииРодитель.Код;
			User.user_id     = стр.ФизЛицо.Код; 
			User.user_post   = стр.Должность.Наименование;
			User.dclogin     = стр.ДомменнаяУчетнаяЗапись;
			
			UserList.User.Добавить(User);
			
		КонецЦикла;
		
		Возврат UserList;		
		
	КонецЕсли;
	
	УстановитьПривилегированныйРежим(Ложь);
	
КонецФункции

 

На стороне приемника (ДО) запускается внешняя обработка, которая получает данные от веб-сервиса и создает в ДО подразделения, пользователи, должности. Код обработки приведен ниже:


&НаСервере
Процедура НачатьСинхронизациюНаСервере()
	//подключаемся к веб-сервису
	всОпред = Новый WSОпределения(Объект.СтрокаПодключенияКВебСервису,Объект.Пользователь,Объект.Пароль,,,);
	всПрокси = Новый WSПрокси(всОпред, "http://www.company.kz/ws/users", "UploadUsers", "UploadUsersSoap",,,);
	всПрокси.Пользователь=Объект.Пользователь;
	всПрокси.Пароль=Объект.Пароль;
	//вызываем метод веб-сервиса
	Значение = всПрокси.Upload();
	//создаем таблицу значений, в которую выгрузим данные
	ТЗПользователей = Новый ТаблицаЗначений;
	ТЗПользователей.Колонки.Добавить("ФИО");
	ТЗПользователей.Колонки.Добавить("ДоменнаяУчетнаяЗапись");
	ТЗПользователей.Колонки.Добавить("Подразделение");
	ТЗПользователей.Колонки.Добавить("ВышестоящееПодразделение");
	ТЗПользователей.Колонки.Добавить("Должность");
	ТЗПользователей.Колонки.Добавить("КодСотрудника");
	ТЗПользователей.Колонки.Добавить("КодПодразделения");
	ТЗПользователей.Колонки.Добавить("КодВышестоящееПодразделение");
	
	Для каждого стр из Значение.User цикл
		
		НоваяСтрока = ТЗПользователей.Добавить();
		НоваяСтрока.ФИО                          = стр.FIO;
		НоваяСтрока.ДоменнаяУчетнаяЗапись        = стр.dclogin;
		НоваяСтрока.Подразделение                = стр.unit_name;
		НоваяСтрока.ВышестоящееПодразделение     = стр.upunit_name;
		НоваяСтрока.Должность                    = стр.user_post;
		НоваяСтрока.КодСотрудника                = стр.user_id;
		НоваяСтрока.КодПодразделения             = стр.unit_id;
		НоваяСтрока.КодВышестоящееПодразделение  = стр.upunit_id;
		
	КонецЦикла;
	
	Для каждого стрТЗ из ТЗПользователей цикл
		//ищем подразделение вместе с вышестоящим
		ИскПодразделение = НайтиИлиСоздатьПодразделение(стрТЗ.КодПодразделения,стрТЗ.Подразделение,стрТЗ.КодВышестоящееПодразделение,стрТЗ.ВышестоящееПодразделение);
		//ищем пользователя
		ИскСотрудник = НайтиПользователя(стрТЗ.КодСотрудника);
		
		Если ИскСотрудник=Неопределено тогда
			ОбъектПользователь = Справочники.Пользователи.СоздатьЭлемент();
			//заполняем дополнительный реквизит "КодСотрудника" кодом из источника
			НовСтрока = ОбъектПользователь.ДополнительныеРеквизиты.Добавить();
			НовСтрока.Свойство = ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("КодСотрудника");
			НовСтрока.Значение = стрТЗ.КодСотрудника;
			НовСтрока.ТекстоваяСтрока = стрТЗ.КодСотрудника;

		Иначе ОбъектПользователь = ИскСотрудник.ПолучитьОбъект();	
		КонецЕсли;
		
		ОбъектПользователь.Наименование = стрТЗ.ФИО;
		ОбъектПользователь.Подразделение = ИскПодразделение.Ссылка;
		ОбъектПользователь.КодЯзыка = "ru";
		ОбъектПользователь.ПредставлениеВДокументах = стрТЗ.ФИО;
		ОбъектПользователь.ПредставлениеВПереписке = стрТЗ.ФИО;
		ОбъектПользователь.ПредставлениеВПерепискеСРангом = стрТЗ.ФИО;
		
		//создаем пользователя информационной базы отправляя структуру параметров через дополнительные свойства
		//процедуры сами сделают связь с элементом справочника "Пользователи" и пользователем ИБ через уникальный идентификатор
		ОписаниеПользователяИБ = Новый Структура; 
		ОписаниеПользователяИБ.Вставить("Действие", "Записать"); 
		ОписаниеПользователяИБ.Вставить("Имя", стрТЗ.ФИО);
		ОписаниеПользователяИБ.Вставить("ПолноеИмя", стрТЗ.ФИО);
		ОписаниеПользователяИБ.Вставить("АутентификацияОС", Истина); 
		ОписаниеПользователяИБ.Вставить("ПоказыватьВСпискеВыбора", Истина); 
		ОписаниеПользователяИБ.Вставить("ПользовательОС", стрТЗ.ДоменнаяУчетнаяЗапись); 
		ОписаниеПользователяИБ.Вставить("АутентификацияСтандартная", Ложь); 

		ОбъектПользователь.ДополнительныеСвойства.Вставить("ОписаниеПользователяИБ", ОписаниеПользователяИБ); 
		ОбъектПользователь.Записать();
		//записываем доп сведения по пользователю, чтобы в карточке пользователя отображались
		НаборЗаписей = РегистрыСведений.СведенияОПользователяхДокументооборот.СоздатьНаборЗаписей();
		НаборЗаписей.Отбор.Пользователь.Установить(ОбъектПользователь.Ссылка);
		НаборЗаписей.Прочитать();
		НаборЗаписей.Записать();
		Запись = НаборЗаписей.Добавить();
		Запись.Пользователь = ОбъектПользователь.Ссылка;
		Запись.Подразделение = ИскПодразделение.Ссылка;
		Запись.Должность = ?(ПустаяСтрока(стрТЗ.Должность),"", НайтиИлиСоздатьДолжность(стрТЗ.Должность));
		Запись.ГрафикРаботы = Справочники.ГрафикиРаботы.НайтиПоНаименованию("Пятидневка");
		НаборЗаписей.Записать();		
		
	КонецЦикла;
		
КонецПроцедуры

&НаСервере
Функция НайтиИлиСоздатьДолжность(НаименованиеДолжности)
	
	ИскДолжность = Справочники.Должности.НайтиПоНаименованию(НаименованиеДолжности, Истина);
	
	Если ИскДолжность=Справочники.Должности.ПустаяСсылка() тогда
		ДолжноситьОбъект = Справочники.Должности.СоздатьЭлемент();
		ДолжноситьОбъект.Наименование = НаименованиеДолжности;
		ДолжноситьОбъект.Записать();
		
		ИскДолжносить = ДолжноситьОбъект.Ссылка;
	КонецЕсли;
	
	Возврат ИскДолжность.Ссылка;  	
	
КонецФункции


&НаСервере
Функция НайтиИлиСоздатьПодразделение(КодПодразделения,Подразделение,КодВышестоящееПодразделение,ВышестоящееПодразделение)

	//сперва изем вышестоящее подразделение, если нет то создаем
	Запрос = новый Запрос;
	Запрос.Текст=
	"ВЫБРАТЬ
	|	СтруктураПредприятияДополнительныеРеквизиты.Ссылка
	|ИЗ
	|	Справочник.СтруктураПредприятия.ДополнительныеРеквизиты КАК СтруктураПредприятияДополнительныеРеквизиты
	|ГДЕ
	|	СтруктураПредприятияДополнительныеРеквизиты.Свойство = &Свойство
	|	И СтруктураПредприятияДополнительныеРеквизиты.Значение = &Значение";
	Запрос.УстановитьПараметр("Свойство", ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("ВнешнийКод"));
	Запрос.УстановитьПараметр("Значение", КодВышестоящееПодразделение);	
	
	тзВышПод = Запрос.Выполнить().Выгрузить();
	
	Если тзВышПод.Количество()>0 тогда
		ВышПод = тзВышПод[0].Ссылка.ПолучитьОбъект();
	Иначе ВышПод = Справочники.СтруктураПредприятия.СоздатьЭлемент();	
	    ВышПод.Наименование = ВышестоящееПодразделение;	
		
		НовСтрока = ВышПод.ДополнительныеРеквизиты.Добавить();
		НовСтрока.Свойство = ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("ВнешнийКод");
		НовСтрока.Значение = КодВышестоящееПодразделение;
		НовСтрока.ТекстоваяСтрока = КодВышестоящееПодразделение;
		ВышПод.Записать();

	КонецЕсли;
		
	//теперь ищем само подразделение
	Запрос = новый Запрос;
	Запрос.Текст=
	"ВЫБРАТЬ
	|	СтруктураПредприятияДополнительныеРеквизиты.Ссылка
	|ИЗ
	|	Справочник.СтруктураПредприятия.ДополнительныеРеквизиты КАК СтруктураПредприятияДополнительныеРеквизиты
	|ГДЕ
	|	СтруктураПредприятияДополнительныеРеквизиты.Свойство = &Свойство
	|	И СтруктураПредприятияДополнительныеРеквизиты.Значение = &Значение";
	Запрос.УстановитьПараметр("Свойство", ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("ВнешнийКод"));
	Запрос.УстановитьПараметр("Значение", КодПодразделения);	
	
	тзПод = Запрос.Выполнить().Выгрузить();
	
	Если тзПод.Количество()>0 тогда
		Под = тзПод[0].Ссылка.ПолучитьОбъект();
	Иначе Под = Справочники.СтруктураПредприятия.СоздатьЭлемент();	
	    Под.Наименование = Подразделение;
		
		НовСтрока = Под.ДополнительныеРеквизиты.Добавить();
		НовСтрока.Свойство = ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("ВнешнийКод");
		НовСтрока.Значение = КодПодразделения;
		НовСтрока.ТекстоваяСтрока = КодПодразделения;
		Под.Записать();

	КонецЕсли;
	
	Под.Родитель = ВышПод.Ссылка;
	
	Под.Записать();
	
	Возврат Под.Ссылка;	
	
КонецФункции

&НаСервере
Функция НайтиПользователя(КодСотрудника)
	
	ИскПользователь = Неопределено;
	
	Запрос = Новый Запрос;
	Запрос.Текст=
	"ВЫБРАТЬ
	|	ПользователиДополнительныеРеквизиты.Ссылка
	|ИЗ
	|	Справочник.Пользователи.ДополнительныеРеквизиты КАК ПользователиДополнительныеРеквизиты
	|ГДЕ
	|	ПользователиДополнительныеРеквизиты.Свойство = &Свойство
	|	И ПользователиДополнительныеРеквизиты.Значение = &Значение";
	Запрос.УстановитьПараметр("Свойство",ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("КодСотрудника"));
	Запрос.УстановитьПараметр("Значение",КодСотрудника);
	
	тзРез = Запрос.Выполнить().Выгрузить();
	
	Если тзРез.Количество()>0 тогда
		ИскПользователь = тзРез[0].Ссылка;
	КонецЕсли;
	
	Возврат ИскПользователь; 	
	
КонецФункции


&НаКлиенте
Процедура НачатьСинхронизацию(Команда)
	НачатьСинхронизациюНаСервере();
КонецПроцедуры

Можете скачать архив со схемой XDTO-пакета и обработкой "Синхронизация пользователей".

В итоге получаем выстроенную структуру предприятия, пользователей и авторизацию через ОС. Затем, опубликовав базу Документооборот на веб-сервере, получаем работающую систему ДО.

 

1

Скачать файлы

Наименование Файл Версия Размер
Выгрузка работников из Бухгалтерии в Документооборот КОРП:
.7z 6,45Kb
27.09.19
0
.7z 6,45Kb Скачать

Специальные предложения

Избранное Подписка Сортировка: Древо
В этой теме еще нет сообщений.
Оставьте свое сообщение

См. также

Отладка правил обмена КД2 для подсистемы БСП Обмен данными 41

Статья Программист Расширение (cfe) v8 1cv8.cf Абонемент ($m) Перенос данных из 1C8 в 1C8

Уже давно нельзя отлаживать правила обмена при помощи внешних файлов. Попробуем исправить это.

1 стартмани

27.05.2019    3652    4    fenixnow    5       

Выгрузка и загрузка данных XML с гибкими отборами 34

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Обмен через XML Перенос данных из 1C8 в 1C8

Обработка выгрузки и загрузки данных через XML между идентичными конфигурациями с возможностью установки произвольных отборов на выгружаемые объекты.

1 стартмани

07.04.2019    4193    108    sapervodichka    7       

Ручная выгрузка и загрузка данных через универсальный обмен данными с настройками (расширение, платформа 8.3+) 46

Инструменты и обработки Программист Архив с данными v8 Розница УНФ ERP2 БП3.0 УТ11 КА2 ЗУП3.x Абонемент ($m) Обработка документов Обработка справочников Обмен через XML Перенос данных из 1C8 в 1C8

Данное расширение (не требует изменения конфигураций) служит как надстройка для конфигураций, у которых обмен между базами происходит через универсальный формат (EnterpriseData), с использованием стандартных правил конвертации, которые уже есть в конфигурации. Интерфейс адаптирован для простых пользователей, сделан общий отбор по Организации для всех документов, имеется пару настроек для передачи в параметры конвертации, которые расположены в общем модуле конфигураций, а так же есть возможность выбора запуска - в фоне или в текущем сеансе. Теперь не нужно настраивать обмен между базами, для того чтоб просто перенести нужные документы. Подходит точно для УТ 11.4, БП 3.0.67, КА 2.4.5, Розница 2.2.9 (Обновление 1.2 от 02.03.2019)

2 стартмани

19.01.2019    7204    84    hakerxp    8       

Обмен без правил. От простого к сложному 128

Статья Программист Архив с данными v8 1cv8.cf Абонемент ($m) Перенос данных из 1C8 в 1C8

Пишем обмен с нуля, разбираемя с разными способами сериализации, учимся редактировать XML документы, создаем XDTO и Web service, осваиваем Script variant - English.

1 стартмани

16.01.2019    12232    7    fr13    26       

Выполнение запроса в другой базе 1С без com-соединения. HTTP-сервис 66

Инструменты и обработки Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Перенос данных из 1C8 в 1C8

Выполнение любого запроса с параметрами из одной базы 1С в другую. Используя HTTP-сервис. Посредством POST-запроса и JSON.

1 стартмани

30.11.2018    8406    16    John_d    19       

Пример получения данных из другой базы 1С через Web-сервис 99

Инструменты и обработки Программист Архив с данными v8 Россия Windows Абонемент ($m) Перенос данных из 1C8 в 1C8

В данной статье описан пример получения данных справочника из другой базы 1С через Web-сервис.

1 стартмани

11.11.2018    12306    13    flyDrag    28       

Способы оптимизации переносов данных 56

Статья Программист Нет файла v8 КД Абонемент ($m) Перенос данных из 1C8 в 1C8

Хочу рассказать вам про способы оптимизации разработки правил обмена в программе «Конвертация данных» второй редакции. Казалось бы, про эту программу и разработку в ней правил конвертации уже сказано все, что можно. Появились уже более современные и быстрые технологии. Почему же все еще она? Дело в том, что «Конвертация данных» второй редакции все еще актуальна для огромного круга задач. Она имеет очень широкую функциональность и позволяет реализовывать сложные алгоритмы. Годы идут, а люди продолжают ей пользоваться и у них возникает много вопросов по этой программе. Возможно, в будущем вы тоже будете заниматься такими проектами и столкнетесь с задачами, похожими на те, про которые я собираюсь рассказать. Мне хочется вам в этом помочь.

1 стартмани

02.08.2018    9689    93    primat    7       

Опыт проведения сложных переносов данных на 1С 166

Статья Программист Архив с данными v8 КД Абонемент ($m) Перенос данных из 1C8 в 1C8

В статье я расскажу про опыт сложных переносов на платформе 1С:Предприятие. Она будет адресована в первую очередь разработчикам 1С, которые уже имеют опыт использования методики «Конвертация данных» (как второй, так и третьей редакции) – я думаю, это большинство из нас. • Я расскажу про различные методики организации переносов данных. • Мы рассмотрим рекомендуемые способы оптимизации правил конвертации, которые позволят вам быстрее выполнять свои переносы. • Также мы разберем, какие могут возникнуть сложности в ходе переноса данных. • Я покажу сравнительный анализ по ряду параметров инструментов «Конвертация данных» второй редакции и третьей, которая вышла уже более года назад.

30.07.2018    22005    44    primat    12       

Простая подсистема согласования 54

Отчеты и формы no Архив с данными v8 v8::УФ 1cv8.cf УУ Документооборот и делопроизводство Абонемент ($m) Рабочее место

Простая система согласования (утверждения), с простой установкой на любую конфигурацию с управляемыми формами.

1 стартмани

27.03.2018    10474    49    eugenevk    22       

Синхронизация (выгрузка) данных ЗУП 3.1 - БП 2.0, УПП 1.3 47

Инструменты и обработки Системный администратор Программист Бухгалтер Внешняя обработка (ert,epf) v8 v8::БУ v8::СПР БП2.0 ЗУП3.x Россия БУ Зарплата Управление персоналом (HRM) Абонемент ($m) Перенос данных из 1C8 в 1C8

Подобная выгрузка не была предусмотрена разработчиками 1С, поэтому и существует эта публикация. Поддерживается выгрузка оценочных обязательств и резервов отпусков. Непосредственная выгрузка в базу Бухгалтерии.

3 стартмани

22.03.2018    26799    516    diso    160       

Правила конвертации документов ЗУП 2.5 - ЗУП 3.1 44

Инструменты и обработки Системный администратор Программист Бухгалтер Документ XML v8 v8::СПР ЗУП2.5 ЗУП3.x Россия БУ Зарплата Абонемент ($m) Обмен через XML Перенос данных из 1C8 в 1C8

Правила конвертации документов ЗУП 2.5 - ЗУП 3.1. Позволяют вести параллельную работу в базах ЗУП редакций 2,5 и 3.1.

10 стартмани

06.03.2018    24352    123    kostya_whiskas    23       

Организация обмена с базой филиала (розничного магазина) в торговой сети через XML (универсальный обмен) 70

Статья Программист Архив с данными v8 КД УТ11 Розничная и сетевая торговля (FMCG) Розничная торговля Абонемент ($m) Обмен через XML Перенос данных из 1C8 в 1C8

В статье по шагам рассматривается создание обмена между центральной базой и базами филиалов на базе конфигурации УТ 11. Для решения поставленной задачи было решено не использовать РИБ, т.к. требуется односторонний обмен ограниченным набором данных, к тому же по определенным условиям. Обмен реализован на основе типовой синхронизации на основе универсального обмена в формате EnterpriseData. Данная публикация может быть полезна внедренцам, которые работают с торговыми сетями, в том числе по модели франчайзинга.

1 стартмани

26.02.2018    25000    14    Kutuzov    18       

[УТ 11][БП 3.0] Перенос данных из БП 3.0 в УТ 11 (начальное заполнение УТ 11 по данным БП 3.0) 32

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 БП3.0 УТ11 Россия УУ Windows Абонемент ($m) Перенос данных из 1C8 в 1C8

Перенос данных из БП 3.0 в Ут 11 для первоначального заполнения УТ данными из БП. 26.02.2019 Версия 2.8.5.5 БП 3.0.68.58.72 УТ 11.4.6.230 платформа 8.3.13.1690. Исправлен (по возможности) перенос остатков взаиморасчетов в части формирования типов расчетных документов и типа операции документов ВНО. Вопрос к знатокам УТ 11, остатки по субсчетам 76 счета (не 76.05 или 76.06) каким типом операции ввода остатков должны переноситься?

1 стартмани

29.01.2018    26100    371    Alex_E    122       

Проверка данных после неполного ("нового") переноса из ЗУП 2.5 в ЗУП 3.1 18

Отчеты и формы Бухгалтер Архив с данными v8 v8::СПР ЗУП3.x Россия БУ Зарплата Абонемент ($m) Бухгалтерский учет Перенос данных из 1C8 в 1C8

Описаны данные, которые необходимо проверить после неполного ("нового") переноса из ЗУП 2.5 в ЗУП 3.1. Описано, на что необходимо обратить внимание, где найти перенесенные данные, что НЕ переносится, где найти настройки.

1 стартмани

17.01.2018    15927    137    btydj    3       

Правила переноса документов из ЗУП 2.5 в ЗУП 3.1 33

Инструменты и обработки Программист Документ XML v8 v8::СПР ЗУП3.x Россия БУ Windows Зарплата Управление персоналом (HRM) Абонемент ($m) Обмен через XML Перенос данных из 1C8 в 1C8

Перенос документов из ЗУП 2.5 в ЗУП 3.1 - позволяет снизить объем работ при опытной эксплуатации ЗУП 3.1 параллельно с ЗУП 2.5.

1 стартмани

04.12.2017    23259    486    AntonH851    38       

1С:Конвертация данных 2.0. Анализ состава выгруженных данных из базы источника до загрузки в базу-приемник 30

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 КД БП3.0 ЗУП3.x Россия Windows Абонемент ($m) Перенос данных из 1C8 в 1C8 Перенос данных из 1С7.7 в 1C8.X

Обработка анализирует файл выгрузки данных конвертации и формирует дерево выгруженных объектов по категориям с возможностью просмотра выгруженных реквизитов (свойств). Идеально подходит для анализа выгруженных данных при переходе на ЗУП 3.1 или Бухгалтерия 3.0 с ранних версий.

1 стартмани

16.11.2017    10498    77    leosoft    4       

Механизмы и транспорт обмена данными. Пример создания в КД 2.1 правил обмена данными ЗУП 2.5 -> БП 3.0. Выгрузка ведомостей и банковских счетов. Передача параметров обмена из Источника в Приемник. ВыгрузитьПоПравилу(). ПередатьОдинПараметрВПриемник(). 37

Статья Программист Документ XML v8 ЗУП2.5 КД БП3.0 Абонемент ($m) Обмен через XML Перенос данных из 1C8 в 1C8

В статье рассказываю: 1) о механизмах и транспорте обмена данными, где одной из сторон обмена выступает конфигурация на базе 1С, и о том, какой транспорт и в каких случаях лучше использовать 2) о решении задачи выгрузки данных документа «Зарплата к выплате организаций» (с выгрузкой банковский счетов физ лиц документа) из ЗУП 2.5.123.1 (далее Источник) в БП КОРП 3.0.52.39 (далее Приемник) путем создания правил обмена данными с использованием конфигурации «Конвертация данных» (далее просто КД) ред. 2.1.8.2. для (далее ЗкВО) 3) о тестирование полученных правил обмена данными.

1 стартмани

03.11.2017    20754    7    RailMen    5       

Синхронизация данных по правилам КД2.0 113

Инструменты и обработки Системный администратор Программист Бизнес-аналитик Бухгалтер Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Перенос данных из 1C8 в 1C8

Новый инструмент для сравнения и загрузки данных, сочетающий в себе: гибкость запросов (используются для сопоставления объектов); наглядный вывод отличий; удобный отбор загружаемых данных; возможность пообъектной синхронизации двух баз по правилам КД2 с помощью вызова обработки "Универсальный обмен XML" в базе-источнике через COM-соединение.

1 стартмани

27.08.2017    16282    107    vikad    30       

Правила обмена ЗУП 3.1 - БП 2.0 и ЗУП 3.1 - УПП 1.3 (отражение, ведомости и справочники) 97

Инструменты и обработки Программист Документ XML v8 v8::БУ v8::СПР БП2.0 БП3.0 ЗУП3.x Россия БУ Зарплата Управление персоналом (HRM) Абонемент ($m) Перенос данных из 1C8 в 1C8 Обмен через XML

Правила обмена для выгрузки документов "Отражение зарплаты в бухучете", "Ведомость в банк", "Ведомость в кассу", справочников "Сотрудники" и "Физические лица"

1 стартмани

01.08.2017    60313    1476    forseil    191       

Перенос справочников и документов из УТ 10.3 в БП 3.0 7

Инструменты и обработки Программист Бухгалтер Внешняя обработка (ert,epf) v8 УТ10 БП3.0 Россия БУ НУ УУ Абонемент ($m) Перенос данных из 1C8 в 1C8

Синхронизация справочников и документов из Управление торговлей 10.3 в Бухгалтерию предприятия 3.0. Обработка не затрагивает штатный механизм. Подключение и перенос документов происходит посредством OLE. Без ввода начальных остатков.

10 стартмани

25.07.2017    14361    9    2casp    5       

Знакомство с 1С:Документооборот. История автоматизации и доработок. Печатная форма Лист согласования 23

Статья Программист Архив с данными v8 ДО УУ Документооборот и делопроизводство Абонемент ($m) Практика программирования

Документооборот 2.1.10.2 ПРОФ. История автоматизации и доработок. Ввод на основании внутреннего документа из задачи согласование с переносом прикрепленных файлов(копировать и вставить файлы). ПФ Лист согласования для процесса Согласование и для справочника Внутренние документы(печатается с историей). Автоматическая загрузка справочника по com-соединению из другой базы.

1 стартмани

04.07.2017    15306    24    SPonomareff    14       

«Горыныч - то НЕ НАСТОЯЩИЙ!» … или О Конвертации Данных ред.3 (КД 3) и обменах в универсальном формате Enterprise Data… доступным русско-народным языком 58

Инструменты и обработки Программист Архив с данными v8 КД Абонемент ($m) Внешние источники данных Обмен через XML Перенос данных из 1C8 в 1C8

Тем, кто хочет быстро разобраться с темой инструмента Конвертация данных 3.0 и технологией обмена по новому формату 1С, активно применяемому во всех новых конфигурациях от 1С на БСП, расширяющем возможности интеграции, пакет полезных материалов.

1 стартмани

13.06.2017    14155    135    Davlad_A    16       

Соответствия объектов обмена 7

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 КА1 Россия Абонемент ($m) Распределенная БД (УРИБ, УРБД) Перенос данных из 1C8 в 1C8

Обработка позволяет проверять, исправлять ошибки, добавлять и удалять соответствия объектов в обменах данными между конфигурациями на основе «Комплексной автоматизации 1.1» или похожими конфигурациям. Подходит для обменов с использованием регистра сведений «СоответствиеОбъектовДляОбмена».

2 стартмани

26.08.2016    14837    3    xxxelaaa    0       

Согласование (подсистема). Для любого справочника и документа в 1С. Встраивается в любые конфигурации 128

Инструменты и обработки Пользователь Руководитель проекта Архив с данными v8 1cv8.cf БП3.0 КА2 УУ Документооборот и делопроизводство Абонемент ($m) Управление бизнес-процессами (BPM) Обработка документов Обработка справочников

Подсистема для согласования в 1С. Для настройки нового согласования не требуется программировать, все делается в режиме исполнения. Открытый код. Бизнес-процессы. Документооборот. Проект выложен на GitHub.

1 стартмани

25.08.2016    36939    218    BlizD    179       

Перенос объектов по OLE из идентичной конфигурации 27

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Россия Абонемент ($m) Перенос данных из 1C8 в 1C8

Перенос по OLE справочников, документов и пользователей из базы источника с идентичной конфигурацией без использования правил обмена, поиск по реквизитам, замена ГУИД, сохранение настроек в файл

1 стартмани

10.07.2016    11382    113    slava_1c    8       

Перенос данных из ЗУП 2.5 в ЗУП 3.1 45

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::СПР ЗУП2.5 ЗУП3.x БУ Windows Зарплата Управление персоналом (HRM) Абонемент ($m) Перенос данных из 1C8 в 1C8

Данная обработка предназначена для переноса некоторых данных из ЗУП 2.5 в ЗУП 3.1 через COM-соединения. Обработка была написана потому, что типовые правила переноса не предоставляют возможности переносить данные по отдельности, а некоторые данные не переносят вовсе. Тестировалась на версии 3.1.9.159 (8.3.12.1790).

1 стартмани

26.05.2016    31549    674    yojeeg    64       

Выгрузка/загрузка данных в формате JSON v 1.0.5 56

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Распределенная БД (УРИБ, УРБД) Перенос данных из 1C8 в 1C8

Обработка предназначена для обмена данными между схожими конфигурациями в формате JSON. Этот формат обладает рядом существенных преимуществ по сравнению с xml и прочими популярными форматами. В отличие от существующих аналогов, обработка не использует никаких дополнительных библиотек. (де)Сериализация всех объектов происходит средствами встроенного языка и методов ЗаписатьJSON() и ПрочитатьJSON(). Работает на платформе версии не ниже 8.3.6.

3 стартмани

27.01.2016    35703    303    kser87    39       

[COM] Перенос данных через COMConnector 79

Инструменты и обработки Системный администратор Программист Бухгалтер Внешняя обработка (ert,epf) v8 1cv8.cf Россия Windows Абонемент ($m) Перенос данных из 1C8 в 1C8

Обработка обмена между двумя информационными базами схожей (не обязательно совпадающей) структуры. Изначально была заточена под бухгалтерию предприятия, сейчас используется для для обменов через COM любых конфигураций с режимом запуска "Управляемое приложение". Ближайший аналог - выгрузка-загрузка XML, но здесь нет промежуточных файлов выгрузки/загрузки, и обмен не прекращается в случае, когда состав реквизитов источника и приёмника различен!!! 27.09.2019 Версия 5.2.3.2 Исправлены исправленыц замеченные ошибки (версия от мая 19 года)

2 стартмани

23.11.2015    40608    595    Alex_E    167       

Интерфейс сопоставления объектов для обмена (для типового регистра СоответствиеОбъектовДляОбмена) 22

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 КА1 БП2.0 ЗУП2.5 УТ10 УПП1 Windows Абонемент ($m) Инструментарий разработчика Универсальные обработки Перенос данных из 1C8 в 1C8

Вы внедряете обмен данными между двумя типовыми или основанными на типовых БД и вам необходим инструмент, чтобы сопоставить между собой справочники этих конфигураций? Вы хотите навести порядок в обмене данными, потому что вам надоело вылавливать дублирующиеся объекты? Вам очень хочется перепоручить сопоставление объектов обменивающихся баз пользователям, но нет подходящего и понятного пользователям интерфейса? Тогда вам нужна именно эта обработка!

4 стартмани

11.11.2015    29513    221    catsam    8       

Создание договоров по шаблонам Word в УТ 11.2, БП 3.0 с возможностью хранения в справочнике "Файлы" 40

Инструменты и обработки Программист Архив с данными v8 БП3.0 УТ11 УУ Документооборот и делопроизводство Абонемент ($m) Универсальные печатные формы Универсальные обработки

Публикация предназначена тем, кто ведет договоры в УТ 11 не только в справочнике "Договоры с контрагентами", но также формирует и согласовывает с контрагентами договоры в формате Word (*.doc). А так как программисты люди ленивые и я не являюсь исключением в этом (хорошем) смысле :), была создана эта печатная форма. Но это не простая печатная форма, а инструмент, который позволяет на основании шаблона, хранящегося в информационной базе в справочнике "Файлы", быстро заполнять и сохранять тут же в справочник "Файлы", но в другую папку, уже заполненный на основании шаблона договор в формате Word.

1 стартмани

08.10.2015    27249    232    Diversus    49       

Управление изменениями в планах обмена (Управляемое приложение) v 1.0 6

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Распределенная БД (УРИБ, УРБД) Внешние источники данных Перенос данных из 1C8 в 1C8

Простая в использовании и наглядная обработка для регистрации изменений или отмены регистрации в планах обмена используя гибкие возможности отбора СКД.

2 стартмани

15.08.2015    24536    46    kser87    3       

Регистрация и согласование договоров, редакция 2.0 6

Отчеты и формы Пользователь Архив с данными v8 УУ Windows Документооборот и делопроизводство Абонемент ($m) Управленческий учет (прочее)

Конфигурация "Регистрация и согласование договоров" является готовым решением для управления и учета договоров на предприятии. Позволяет организовать единую информационную систему регистрации и согласования. Включает CRM подсистему.

1000 руб.

26.05.2015    13819    18    5       

Приемная руководителя, редакция 1.1 23

Инструменты и обработки Пользователь Конфигурация (md, cf) v8 Windows Документооборот и делопроизводство Абонемент ($m) Управленческий учет (прочее)

Приемная руководителя, редакция 1.1. Конфигурация на управляемых формах (интерфейс - Такси) с открытым кодом, создана для секретарей.

1500 руб.

19.05.2015    22812    21    6       

УПД за поставщика c подписями и факсимиле для БП 3.0 39

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 v8::БУ БП3.0 Россия БУ Windows Документооборот и делопроизводство Оптовая торговля Абонемент ($m) Печатные формы документов

Внешняя печатная форма для печати - "Универсальный передаточный документ" за поставщика. ВПФ (с формой и без) в форме заполняются должности и фамилии и происходит заполнение полей 10,13, 15,18.Так же есть возможность хранить и выводить на печать подписи руководителя и глав.бухгалтера поставщика. Внесены изменения под требования конфигураций выше 3.0.67.38 (НДС20%). Версия 0.2 без формы выбора подписантов(будет полезна тем у кого ответственные лица неизменные).

5 стартмани

19.03.2015    68799    953    kn    96       

Перенос объектов 1С 254

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Windows Абонемент ($m) Перенос данных из 1C8 в 1C8

Простой и наглядный перенос объектов между любыми базами 1С 8 с предварительным анализом на возможные различия в данных (через файл, через интернет, через буфер обмена). Интерактивная настройка правил обмена на стороне источника и получателя. В обработке есть удобный обзор по подсистемам, поиск и обработка данных по заданному фильтру. Сравнение объектов, поиск ссылок. Конструктор кода по созданию объектов, написание скриптов и отладка мини-функций в УФ. Отключение/включение регламентных заданий. Регистрация/снятие с регистрации объектов в планах обмена. И многое другое.

1 стартмани

16.03.2015    78015    1986    moolex    189       

Перенос данных из Бухгалтерии 2.0 в Бухгалтерию 3.0 15

Инструменты и обработки Системный администратор Программист Документ XML v8 БП2.0 БП3.0 Россия БУ Windows Абонемент ($m) Обмен через XML Перенос данных из 1C8 в 1C8

Перенос данных и остатков с Бухгалтерии 2.0 в Бухгалтерию 3.0 с помощью универсального обмена данными XML.

1 стартмани

30.12.2014    38736    308    sergeyzhuravlev    8       

Выгрузка данных из УТ 10.3 в БП 3.0 (своими руками) 34

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 УТ10 БП3.0 Россия Windows Абонемент ($m) Перенос данных из 1C8 в 1C8

Старая добрая, позабытая многими выгрузка из УТ 10.3 в БП 1.6. Ее еще можно оживить, и она послужит на благо всем желающим, всем уставшим от автоматических обменов.

3 стартмани

30.10.2014    33372    309    TESL    40       

Реестр договоров для 1С:Бухгалтерии 14

Инструменты и обработки Бухгалтер Архив с данными v8 v8::БУ БП3.0 Россия БУ Документооборот и делопроизводство Абонемент ($m) Обработка документов Обработка справочников

Реестр договоров для 1С:Бухгалтерии - дополнительная обработка для конфигурации "Бухгалтерия предприятия", версия 3.0

5 стартмани

28.10.2014    33688    110    RespectSoft    23       

Универсальная выгрузка/загрузка данных для отличающихся конфигураций (JSON, Такси+ОФ) 410

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Перенос данных из 1C8 в 1C8 Универсальные обработки Распределенная БД (УРИБ, УРБД)

Простой перенос через JSON данных между двумя базами 1С (документов, справочников, ПВХ, ПВР, счетов). Аналогична произвольной выгрузке в типовой "Выгрузка/загрузка XML", но может использоваться для отличающихся конфигураций. Подходит для любых пар баз с любым интерфейсом (управляемый + обычный). Без настроек. Не требует идентичности конфигураций и платформ. При переносе типы данных сопоставляются по наименованиям метаданных, объекты и ссылки по UID.

1 стартмани

22.10.2014    189979    4180    ekaruk    174       

Инструкция по интеграции «1С:Управление производственным предприятием» с «1С:Документооборот» 29

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 УПП1 ДО Windows Абонемент ($m) Перенос данных из 1C8 в 1C8

В данной публикации описано как сделать, чтобы было возможным настроить интеграцию «1С:Управление производственным предприятием» и «1С:Документооборот»

1 стартмани

13.08.2014    36373    77    simich    18       

Перенос изображений номенклатуры УТ10 <-> УТ11 9

Инструменты и обработки Руководитель проекта Внешняя обработка (ert,epf) v8 УТ10 УТ11 Windows Абонемент ($m) Перенос данных из 1C8 в 1C8

Обработка позволяет переносить изображения номенклатуры между УТ10 и УТ11. В обоих направлениях! Перенос изображений происходит через каталог. Синхронизация происходит по коду номенклатуры. Обработка корректно работает в том числе и с изображениями при хранении их вне базы в УТ11.

10 стартмани

30.06.2014    28797    72    GATTUSO    17       

Перенос данных. Правила конвертации из УПП 1.3 в БП 3.0 31

Инструменты и обработки Системный администратор Программист Бухгалтер Документ XML v8 УПП1 БП3.0 Windows Абонемент ($m) Обработка документов Обмен через XML Перенос данных из 1C8 в 1C8

Выкладываю рабочий пример правил конвертации. Разрабатывался для потребности в периодическом переносе части документов и справочников из базы УПП в БП 3.0. Надеюсь, кому-нибудь пригодится данная наработка. Проверялась работоспособность на конфигурации Управление производственным предприятием, редакция 1.3 (1.3.51.4) и Бухгалтерия предприятия, редакция 3.0 (3.0.31.13).

1 стартмани

05.05.2014    35999    483    appolon321    34       

Обмен документами между идентичными конфигурациями 25

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Перенос данных из 1C8 в 1C8

Комплект обработок, позволяющий выгружать и загружать документ и его составляющие в XML Может быть актуально для БАЗОВЫХ версий

1 стартмани

18.03.2014    20242    135    SITR-utyos    14