Выгрузка работников из Бухгалтерии в Документооборот КОРП

Публикация № 1128232

Управление - Документооборот и делопроизводство

документооборот веб-сервис пользователь синхронизация

Описание реализации выгрузки пользователей из конфигурации Бухгалтерия для Казахстана (ред. 1) в Документооборот для Казахстана КОРП (ред. 2). На стороне источника используется веб-сервис. На стороне приемника внешняя обработка.

На стороне источника (БП) реализован веб-сервис UploadUsers и метод Upload().

Для передачи данных реализован XDTO-пакет следующей структуры:

Написана функция для метода Upload(). Код приведен ниже:

Функция Upload()
	
	УстановитьПривилегированныйРежим(Истина);
	
	Запрос = Новый Запрос;
	Запрос.Текст=
	"ВЫБРАТЬ РАЗРЕШЕННЫЕ
	|	РаботникиОрганизацийСрезПоследних.Физлицо,
	|	МАКСИМУМ(РаботникиОрганизацийСрезПоследних.Период) КАК Период,
	|	РаботникиОрганизацийСрезПоследних.ПричинаИзмененияСостояния,
	|	РаботникиОрганизацийСрезПоследних.ПодразделениеОрганизации,
	|	РаботникиОрганизацийСрезПоследних.Должность
	|ПОМЕСТИТЬ втПриемы
	|ИЗ
	|	РегистрСведений.РаботникиОрганизаций.СрезПоследних(
	|			&ДатаАктуальности,
	|			Организация = &Организация
	|				И ПричинаИзмененияСостояния В (&сзСостояния)) КАК РаботникиОрганизацийСрезПоследних
	|
	|СГРУППИРОВАТЬ ПО
	|	РаботникиОрганизацийСрезПоследних.Физлицо,
	|	РаботникиОрганизацийСрезПоследних.ПричинаИзмененияСостояния,
	|	РаботникиОрганизацийСрезПоследних.ПодразделениеОрганизации,
	|	РаботникиОрганизацийСрезПоследних.Должность
	|;
	|
	|////////////////////////////////////////////////////////////////////////////////
	|ВЫБРАТЬ РАЗРЕШЕННЫЕ
	|	РаботникиОрганизацийСрезПоследних.Физлицо,
	|	МАКСИМУМ(РаботникиОрганизацийСрезПоследних.Период) КАК Период,
	|	РаботникиОрганизацийСрезПоследних.ПричинаИзмененияСостояния
	|ПОМЕСТИТЬ втУволенные
	|ИЗ
	|	РегистрСведений.РаботникиОрганизаций.СрезПоследних(
	|			&ДатаАктуальности,
	|			Организация = &Организация
	|				И ПричинаИзмененияСостояния = &парамУвольнение) КАК РаботникиОрганизацийСрезПоследних
	|
	|СГРУППИРОВАТЬ ПО
	|	РаботникиОрганизацийСрезПоследних.Физлицо,
	|	РаботникиОрганизацийСрезПоследних.ПричинаИзмененияСостояния
	|;
	|
	|////////////////////////////////////////////////////////////////////////////////
	|ВЫБРАТЬ РАЗРЕШЕННЫЕ
	|	втПриемы.Физлицо,
	|	втПриемы.ПричинаИзмененияСостояния КАК Принят,
	|	втУволенные.ПричинаИзмененияСостояния КАК Уволен,
	|	втПриемы.ПодразделениеОрганизации,
	|	втПриемы.Должность
	|ПОМЕСТИТЬ втПредРаботники
	|ИЗ
	|	втПриемы КАК втПриемы
	|		ЛЕВОЕ СОЕДИНЕНИЕ втУволенные КАК втУволенные
	|		ПО втПриемы.Физлицо = втУволенные.Физлицо
	|			И втПриемы.Период < втУволенные.Период
	|;
	|
	|////////////////////////////////////////////////////////////////////////////////
	|ВЫБРАТЬ РАЗРЕШЕННЫЕ
	|	втПредРаботники.Физлицо,
	|	втПредРаботники.ПодразделениеОрганизации,
	|	втПредРаботники.Должность
	|ПОМЕСТИТЬ втРаботающие
	|ИЗ
	|	втПредРаботники КАК втПредРаботники
	|ГДЕ
	|	втПредРаботники.Уволен ЕСТЬ NULL
	|;
	|
	|////////////////////////////////////////////////////////////////////////////////
	|ВЫБРАТЬ
	|	КонтактнаяИнформация.Объект,
	|	КонтактнаяИнформация.Тип,
	|	КонтактнаяИнформация.Вид,
	|	КонтактнаяИнформация.Представление
	|ПОМЕСТИТЬ втДоменныеУчетныеЗаписи
	|ИЗ
	|	РегистрСведений.КонтактнаяИнформация КАК КонтактнаяИнформация
	|ГДЕ
	|	КонтактнаяИнформация.Тип = &Тип
	|	И КонтактнаяИнформация.Вид = &Вид
	|;
	|
	|////////////////////////////////////////////////////////////////////////////////
	|ВЫБРАТЬ РАЗРЕШЕННЫЕ
	|	втРаботающие.Физлицо,
	|	втРаботающие.ПодразделениеОрганизации,
	|	ЕСТЬNULL(втРаботающие.Должность, """") КАК Должность,
	|	ЕСТЬNULL(втРаботающие.ПодразделениеОрганизации.Родитель, """") КАК ПодразделениеОрганизацииРодитель,
	|	ЕСТЬNULL(втДоменныеУчетныеЗаписи.Представление, """") КАК ДомменнаяУчетнаяЗапись
	|ИЗ
	|	втРаботающие КАК втРаботающие
	|		ЛЕВОЕ СОЕДИНЕНИЕ втДоменныеУчетныеЗаписи КАК втДоменныеУчетныеЗаписи
	|		ПО втРаботающие.Физлицо = втДоменныеУчетныеЗаписи.Объект
	|
	|УПОРЯДОЧИТЬ ПО
	|	втРаботающие.Физлицо.Наименование";
	Запрос.УстановитьПараметр("Организация", Справочники.Организации.НайтиПоКоду("000000001"));
	Запрос.УстановитьПараметр("ДатаАктуальности", ТекущаяДата());
	Запрос.УстановитьПараметр("Тип", Перечисления.ТипыКонтактнойИнформации.Другое);
	Запрос.УстановитьПараметр("Вид", Справочники.ВидыКонтактнойИнформации.НайтиПоКоду("KR0000007"));

	
	сзСостояния = Новый СписокЗначений;
	сзСостояния.Добавить(Перечисления.ПричиныИзмененияСостояния.ПриемНаРаботу);
	сзСостояния.Добавить(Перечисления.ПричиныИзмененияСостояния.Перемещение);
	
	Запрос.УстановитьПараметр("сзСостояния", сзСостояния);
	Запрос.УстановитьПараметр("парамУвольнение", Перечисления.ПричиныИзмененияСостояния.Увольнение);
	
	тзРез = Запрос.Выполнить().Выгрузить();
	
	Если тзРез.Количество()>0 тогда
		
		МассивПользователейТип = ФабрикаXDTO.Тип("http://www.company.kz/ws/users", "UserList");
		ПользовательТип = ФабрикаXDTO.Тип("http://www.company.kz/ws/users", "User");
		
		UserList = ФабрикаXDTO.Создать(МассивПользователейТип);
		
		Для каждого стр из тзРез Цикл
			
			User = ФабрикаXDTO.Создать(ПользовательТип);
			
			User.FIO         = стр.ФизЛицо.Наименование;
			User.unit_name   = стр.ПодразделениеОрганизации.Наименование;
			User.unit_id     = стр.ПодразделениеОрганизации.Код;
			User.upunit_name = стр.ПодразделениеОрганизацииРодитель.Наименование;
			User.upunit_id   = стр.ПодразделениеОрганизацииРодитель.Код;
			User.user_id     = стр.ФизЛицо.Код; 
			User.user_post   = стр.Должность.Наименование;
			User.dclogin     = стр.ДомменнаяУчетнаяЗапись;
			
			UserList.User.Добавить(User);
			
		КонецЦикла;
		
		Возврат UserList;		
		
	КонецЕсли;
	
	УстановитьПривилегированныйРежим(Ложь);
	
КонецФункции

 

На стороне приемника (ДО) запускается внешняя обработка, которая получает данные от веб-сервиса и создает в ДО подразделения, пользователи, должности. Код обработки приведен ниже:


&НаСервере
Процедура НачатьСинхронизациюНаСервере()
	//подключаемся к веб-сервису
	всОпред = Новый WSОпределения(Объект.СтрокаПодключенияКВебСервису,Объект.Пользователь,Объект.Пароль,,,);
	всПрокси = Новый WSПрокси(всОпред, "http://www.company.kz/ws/users", "UploadUsers", "UploadUsersSoap",,,);
	всПрокси.Пользователь=Объект.Пользователь;
	всПрокси.Пароль=Объект.Пароль;
	//вызываем метод веб-сервиса
	Значение = всПрокси.Upload();
	//создаем таблицу значений, в которую выгрузим данные
	ТЗПользователей = Новый ТаблицаЗначений;
	ТЗПользователей.Колонки.Добавить("ФИО");
	ТЗПользователей.Колонки.Добавить("ДоменнаяУчетнаяЗапись");
	ТЗПользователей.Колонки.Добавить("Подразделение");
	ТЗПользователей.Колонки.Добавить("ВышестоящееПодразделение");
	ТЗПользователей.Колонки.Добавить("Должность");
	ТЗПользователей.Колонки.Добавить("КодСотрудника");
	ТЗПользователей.Колонки.Добавить("КодПодразделения");
	ТЗПользователей.Колонки.Добавить("КодВышестоящееПодразделение");
	
	Для каждого стр из Значение.User цикл
		
		НоваяСтрока = ТЗПользователей.Добавить();
		НоваяСтрока.ФИО                          = стр.FIO;
		НоваяСтрока.ДоменнаяУчетнаяЗапись        = стр.dclogin;
		НоваяСтрока.Подразделение                = стр.unit_name;
		НоваяСтрока.ВышестоящееПодразделение     = стр.upunit_name;
		НоваяСтрока.Должность                    = стр.user_post;
		НоваяСтрока.КодСотрудника                = стр.user_id;
		НоваяСтрока.КодПодразделения             = стр.unit_id;
		НоваяСтрока.КодВышестоящееПодразделение  = стр.upunit_id;
		
	КонецЦикла;
	
	Для каждого стрТЗ из ТЗПользователей цикл
		//ищем подразделение вместе с вышестоящим
		ИскПодразделение = НайтиИлиСоздатьПодразделение(стрТЗ.КодПодразделения,стрТЗ.Подразделение,стрТЗ.КодВышестоящееПодразделение,стрТЗ.ВышестоящееПодразделение);
		//ищем пользователя
		ИскСотрудник = НайтиПользователя(стрТЗ.КодСотрудника);
		
		Если ИскСотрудник=Неопределено тогда
			ОбъектПользователь = Справочники.Пользователи.СоздатьЭлемент();
			//заполняем дополнительный реквизит "КодСотрудника" кодом из источника
			НовСтрока = ОбъектПользователь.ДополнительныеРеквизиты.Добавить();
			НовСтрока.Свойство = ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("КодСотрудника");
			НовСтрока.Значение = стрТЗ.КодСотрудника;
			НовСтрока.ТекстоваяСтрока = стрТЗ.КодСотрудника;

		Иначе ОбъектПользователь = ИскСотрудник.ПолучитьОбъект();	
		КонецЕсли;
		
		ОбъектПользователь.Наименование = стрТЗ.ФИО;
		ОбъектПользователь.Подразделение = ИскПодразделение.Ссылка;
		ОбъектПользователь.КодЯзыка = "ru";
		ОбъектПользователь.ПредставлениеВДокументах = стрТЗ.ФИО;
		ОбъектПользователь.ПредставлениеВПереписке = стрТЗ.ФИО;
		ОбъектПользователь.ПредставлениеВПерепискеСРангом = стрТЗ.ФИО;
		
		//создаем пользователя информационной базы отправляя структуру параметров через дополнительные свойства
		//процедуры сами сделают связь с элементом справочника "Пользователи" и пользователем ИБ через уникальный идентификатор
		ОписаниеПользователяИБ = Новый Структура; 
		ОписаниеПользователяИБ.Вставить("Действие", "Записать"); 
		ОписаниеПользователяИБ.Вставить("Имя", стрТЗ.ФИО);
		ОписаниеПользователяИБ.Вставить("ПолноеИмя", стрТЗ.ФИО);
		ОписаниеПользователяИБ.Вставить("АутентификацияОС", Истина); 
		ОписаниеПользователяИБ.Вставить("ПоказыватьВСпискеВыбора", Истина); 
		ОписаниеПользователяИБ.Вставить("ПользовательОС", стрТЗ.ДоменнаяУчетнаяЗапись); 
		ОписаниеПользователяИБ.Вставить("АутентификацияСтандартная", Ложь); 

		ОбъектПользователь.ДополнительныеСвойства.Вставить("ОписаниеПользователяИБ", ОписаниеПользователяИБ); 
		ОбъектПользователь.Записать();
		//записываем доп сведения по пользователю, чтобы в карточке пользователя отображались
		НаборЗаписей = РегистрыСведений.СведенияОПользователяхДокументооборот.СоздатьНаборЗаписей();
		НаборЗаписей.Отбор.Пользователь.Установить(ОбъектПользователь.Ссылка);
		НаборЗаписей.Прочитать();
		НаборЗаписей.Записать();
		Запись = НаборЗаписей.Добавить();
		Запись.Пользователь = ОбъектПользователь.Ссылка;
		Запись.Подразделение = ИскПодразделение.Ссылка;
		Запись.Должность = ?(ПустаяСтрока(стрТЗ.Должность),"", НайтиИлиСоздатьДолжность(стрТЗ.Должность));
		Запись.ГрафикРаботы = Справочники.ГрафикиРаботы.НайтиПоНаименованию("Пятидневка");
		НаборЗаписей.Записать();		
		
	КонецЦикла;
		
КонецПроцедуры

&НаСервере
Функция НайтиИлиСоздатьДолжность(НаименованиеДолжности)
	
	ИскДолжность = Справочники.Должности.НайтиПоНаименованию(НаименованиеДолжности, Истина);
	
	Если ИскДолжность=Справочники.Должности.ПустаяСсылка() тогда
		ДолжноситьОбъект = Справочники.Должности.СоздатьЭлемент();
		ДолжноситьОбъект.Наименование = НаименованиеДолжности;
		ДолжноситьОбъект.Записать();
		
		ИскДолжносить = ДолжноситьОбъект.Ссылка;
	КонецЕсли;
	
	Возврат ИскДолжность.Ссылка;  	
	
КонецФункции


&НаСервере
Функция НайтиИлиСоздатьПодразделение(КодПодразделения,Подразделение,КодВышестоящееПодразделение,ВышестоящееПодразделение)

	//сперва изем вышестоящее подразделение, если нет то создаем
	Запрос = новый Запрос;
	Запрос.Текст=
	"ВЫБРАТЬ
	|	СтруктураПредприятияДополнительныеРеквизиты.Ссылка
	|ИЗ
	|	Справочник.СтруктураПредприятия.ДополнительныеРеквизиты КАК СтруктураПредприятияДополнительныеРеквизиты
	|ГДЕ
	|	СтруктураПредприятияДополнительныеРеквизиты.Свойство = &Свойство
	|	И СтруктураПредприятияДополнительныеРеквизиты.Значение = &Значение";
	Запрос.УстановитьПараметр("Свойство", ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("ВнешнийКод"));
	Запрос.УстановитьПараметр("Значение", КодВышестоящееПодразделение);	
	
	тзВышПод = Запрос.Выполнить().Выгрузить();
	
	Если тзВышПод.Количество()>0 тогда
		ВышПод = тзВышПод[0].Ссылка.ПолучитьОбъект();
	Иначе ВышПод = Справочники.СтруктураПредприятия.СоздатьЭлемент();	
	    ВышПод.Наименование = ВышестоящееПодразделение;	
		
		НовСтрока = ВышПод.ДополнительныеРеквизиты.Добавить();
		НовСтрока.Свойство = ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("ВнешнийКод");
		НовСтрока.Значение = КодВышестоящееПодразделение;
		НовСтрока.ТекстоваяСтрока = КодВышестоящееПодразделение;
		ВышПод.Записать();

	КонецЕсли;
		
	//теперь ищем само подразделение
	Запрос = новый Запрос;
	Запрос.Текст=
	"ВЫБРАТЬ
	|	СтруктураПредприятияДополнительныеРеквизиты.Ссылка
	|ИЗ
	|	Справочник.СтруктураПредприятия.ДополнительныеРеквизиты КАК СтруктураПредприятияДополнительныеРеквизиты
	|ГДЕ
	|	СтруктураПредприятияДополнительныеРеквизиты.Свойство = &Свойство
	|	И СтруктураПредприятияДополнительныеРеквизиты.Значение = &Значение";
	Запрос.УстановитьПараметр("Свойство", ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("ВнешнийКод"));
	Запрос.УстановитьПараметр("Значение", КодПодразделения);	
	
	тзПод = Запрос.Выполнить().Выгрузить();
	
	Если тзПод.Количество()>0 тогда
		Под = тзПод[0].Ссылка.ПолучитьОбъект();
	Иначе Под = Справочники.СтруктураПредприятия.СоздатьЭлемент();	
	    Под.Наименование = Подразделение;
		
		НовСтрока = Под.ДополнительныеРеквизиты.Добавить();
		НовСтрока.Свойство = ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("ВнешнийКод");
		НовСтрока.Значение = КодПодразделения;
		НовСтрока.ТекстоваяСтрока = КодПодразделения;
		Под.Записать();

	КонецЕсли;
	
	Под.Родитель = ВышПод.Ссылка;
	
	Под.Записать();
	
	Возврат Под.Ссылка;	
	
КонецФункции

&НаСервере
Функция НайтиПользователя(КодСотрудника)
	
	ИскПользователь = Неопределено;
	
	Запрос = Новый Запрос;
	Запрос.Текст=
	"ВЫБРАТЬ
	|	ПользователиДополнительныеРеквизиты.Ссылка
	|ИЗ
	|	Справочник.Пользователи.ДополнительныеРеквизиты КАК ПользователиДополнительныеРеквизиты
	|ГДЕ
	|	ПользователиДополнительныеРеквизиты.Свойство = &Свойство
	|	И ПользователиДополнительныеРеквизиты.Значение = &Значение";
	Запрос.УстановитьПараметр("Свойство",ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("КодСотрудника"));
	Запрос.УстановитьПараметр("Значение",КодСотрудника);
	
	тзРез = Запрос.Выполнить().Выгрузить();
	
	Если тзРез.Количество()>0 тогда
		ИскПользователь = тзРез[0].Ссылка;
	КонецЕсли;
	
	Возврат ИскПользователь; 	
	
КонецФункции


&НаКлиенте
Процедура НачатьСинхронизацию(Команда)
	НачатьСинхронизациюНаСервере();
КонецПроцедуры

Можете скачать архив со схемой XDTO-пакета и обработкой "Синхронизация пользователей".

В итоге получаем выстроенную структуру предприятия, пользователей и авторизацию через ОС. Затем, опубликовав базу Документооборот на веб-сервере, получаем работающую систему ДО.

 

Скачать файлы

Наименование Файл Версия Размер
Выгрузка работников из Бухгалтерии в Документооборот КОРП:

.7z 6,45Kb
27.09.19
0
.7z 6,45Kb Скачать

Специальные предложения

Оставьте свое сообщение

См. также

Выгрузка документов из ЗУП в БП (1С 8.2-8.3) Промо

Перенос данных из 1C8 в 1C8 Зарплата Зарплата v8 БП2.0 ЗУП2.5 Абонемент ($m)

Обработка для выгрузки документов из конфигурации "Зарплата и управление персоналом" 8.2 в конфигурацию "Бухгалтерия предприятия" 8.2. Использует правила обмена. В обработке создан удобный интерфейс для гибкого формирования списка документов кадрового учета и начисления ЗП.

1 стартмани

18.12.2012    14801    12    d.zhukov    20    

Загрузка из XML файла ЭДО в документ поступления для конфигураций 1С: Розница 2.2/2.3, Управление торговлей 10.3/11.4

Розничная торговля Обработка документов Документооборот и делопроизводство Обмен через XML v8 УТ10 Розница Розничная и сетевая торговля (FMCG) Россия УУ Абонемент ($m)

Внешние обработки загрузки данных из XML файлов формата ON_NSCHFDOPPRMARK ЭДО в документы поступления 1С Розница версия 2.2.10.19 и выше, Управление торговлей 10.3.52.2 и выше, Управление торговлей 11.4.5.63 и выше

1 стартмани

04.06.2020    11574    161    independ    105    

Самописный обмен данными через веб сервис маленькими пакетами с большой скоростью

Перенос данных из 1C8 в 1C8 v8 1cv8.cf Россия Абонемент ($m)

Подсистема в конфигурацию 1С, обеспечивающая обмен данными по настраиваемым правилам в разные системы 1С. Обмен осуществляется сообщениями через сервис. Разработка и тестирование на версии 8.3.15.1656

10 стартмани

06.02.2020    5315    5    visork    12    

Универсальный обмен данными между идентичными конфигурациями, версия 2020.3.1

Перенос данных из 1C8 в 1C8 v8 1cv8.cf Абонемент ($m)

Обработка «Универсальная выгрузка и загрузка» предназначена для оперативного переноса объектов между двумя идентичными или похожими конфигурациями. Быстрая, надежная и очень простая в использовании обработка.

1 стартмани

29.01.2020    10721    153    vladnet    28    

Универсальная выгрузка/загрузка данных для отличающихся конфигураций (JSON, Такси+ОФ) Промо

Перенос данных из 1C8 в 1C8 Универсальные обработки Распределенная БД (УРИБ, УРБД) v8 1cv8.cf Абонемент ($m)

Простой перенос через JSON данных между двумя базами 1С (документов, справочников, ПВХ, ПВР, счетов). Аналогична произвольной выгрузке в типовой "Выгрузка/загрузка XML", но может использоваться для отличающихся конфигураций. Подходит для любых пар баз с любым интерфейсом (управляемый + обычный). Без настроек. Не требует идентичности конфигураций и платформ. При переносе типы данных сопоставляются по наименованиям метаданных, объекты и ссылки по UID.

1 стартмани

22.10.2014    207205    3137    ekaruk    183    

Помощник подготовки данных для СЗВ-ТД

Зарплата Обработка документов Документооборот и делопроизводство v8 v8::СПР ЗКГУ3.0 ЗУП3.x Россия БУ ФОМС, ПФ, ФСС Абонемент ($m)

С 1 января 2020 г. начался переход на электронные трудовые книжки. Работодателям в 2020 г. предстоит выполнить ряд мероприятий для перехода на ЭТК, а также ежемесячно отчитываться в ПФР обо всех кадровых изменениях по форме СЗВ-ТД. В этой публикации размещена обработка, которая поможет быстро подготовить кадровые документы для заполнения СЗВ-ТД в программе 1С ЗУП 3.1, 1С ЗКГУ 3.1.

1 стартмани

23.01.2020    9681    109    Kaval88    61    

hsИнтегратор 3. Онлайновый обмен и удаленное исполнение функций по HTTP протоколу

Перенос данных из 1C8 в 1C8 v8 Абонемент ($m)

Кроссплатформенный онлайновый обмен данными и удаленное исполнение функций по протоколу HTTP. Новая функциональность - обмен элементами плана видов расчета и данными расчетных регистров. Увеличение производительности и упрощение пользовательского API. Тестирование обменов выполнялось с демонстрационными базами: "Бухгалтерия предприятия, редакция 3.0 3.0.72.66" и "Зарплата и Управление Персоналом, редакция 3 3.1.10.135"

1 стартмани

19.05.2019    5361    27    hobi    9    

Выгрузка и загрузка данных XML с гибкими отборами

Обмен через XML Перенос данных из 1C8 в 1C8 v8 1cv8.cf Абонемент ($m)

Обработка выгрузки и загрузки данных через XML между идентичными конфигурациями с возможностью установки произвольных отборов на выгружаемые объекты.

1 стартмани

07.04.2019    19435    475    sapervodichka    7    

Перенос объектов 1С Промо

Перенос данных из 1C8 в 1C8 v8 v8::УФ 1cv8.cf Абонемент ($m)

Простой и наглядный перенос объектов между любыми базами 1С 8 с предварительным анализом на возможные различия в данных (через файл, через интернет, через буфер обмена). Интерактивная настройка правил обмена на стороне источника и получателя. В обработке есть удобный обзор по подсистемам, поиск и обработка данных по заданному фильтру. Сравнение объектов, поиск ссылок. Конструктор кода по созданию объектов, написание скриптов и отладка мини-функций в УФ. Отключение/включение регламентных заданий. Регистрация/снятие с регистрации объектов в планах обмена. И многое другое. Инструменты администратора в одной обработке.

1 стартмани

16.03.2015    90581    1387    moolex    193    

Доработка функционала отправки дополнительных реквизитов 1С: ЭДО для Татнефть

Внешние источники данных Документооборот и делопроизводство Документооборот и делопроизводство v8 ERP2 БУ Абонемент ($m)

Подключаемое расширение к конфигурации ERP с функционалом отправки дополнительных реквизитов 1С ЭДО для Татнефть (№ и дата договора, подразделение, автор, примечание) в электронных документах Счет-фактуры и ТОРГ-12 Проверялось на 1С:ERP Управление предприятием 2.4.6.160.

2 стартмани

07.04.2019    9546    14    sapervodichka    10    

Расширение для загрузки в 1С сканов документов, pdf файлов, распознанных с помощью OCR

Обработка документов Документооборот и делопроизводство Документооборот и делопроизводство v8 1cv8.cf Россия Абонемент ($m)

Подсистема, предназначенная для автоматического разбора распознанного файла, извлечение из него полезной информации и загрузки данных в 1С.

1 стартмани

27.03.2019    6855    27    trim89    7    

Перенос данных КА 1.1 -> КА 2

Перенос данных из 1C8 в 1C8 Обмен через XML v8 КА1 КА2 Россия Абонемент ($m)

Перенос данных КА 1.1 => КА 2 с помощью правил обмена данными в формате XML КД 2 (переносятся остатки, документы, справочная информация).

5 стартмани

20.03.2019    16941    261    gudogu    143    

Соответствия объектов обмена Промо

Распределенная БД (УРИБ, УРБД) Перенос данных из 1C8 в 1C8 v8 КА1 Россия Абонемент ($m)

Обработка позволяет проверять, исправлять ошибки, добавлять и удалять соответствия объектов в обменах данными между конфигурациями на основе «Комплексной автоматизации 1.1» или похожими конфигурациям. Подходит для обменов с использованием регистра сведений «СоответствиеОбъектовДляОбмена».

1 стартмани

26.08.2016    22128    11    xxxelaaa    0    

Правила обмена УПП 1.3 -> БП 3.0 (+ БП КОРП 3.0 + перенос остатков)

Перенос данных из 1C8 в 1C8 Обмен через XML v8 УПП1 КД БП3.0 БУ Абонемент ($m)

Актуальные правила обмена: УПП 1.3.137.1 -> БП 3.0.76.77; УПП 1.3.137.1 -> БП КОРП 3.0.76.77; УПП 1.3.128.1 -> БП 3.0.74.63; УПП 1.3.128.1 -> БП КОРП 3.0.74.63; УПП 1.3.123.3 -> БП 3.0.71.83; УПП 1.3.123.3 -> БП КОРП 3.0.71.83; УПП 1.3.118.1 -> БП 3.0.68.61; УПП 1.3.118.1 -> БП КОРП 3.0.68.61.

1 стартмани

04.03.2019    12434    285    Смешной 1С    44    

Визуализация электронной подписи на исходящих документах в соответствии с ГОСТ Р 7.0.97-2016. Полная автоматизация

Печатные формы документов Документооборот и делопроизводство Документооборот и делопроизводство v8 ДО Россия Абонемент ($m)

Визуализация ЭЦП по ГОСТу Р 7.0.97-2016, предложенная в предыдущей статье (https://infostart.ru/public/931674/) на данную тему, очень прижилась у меня в организации. Начальник часть писем повелел подписывать ЭЦП и не тревожить его по пустякам. Но механизм подписи требовал некоторого количества ручных действий, а хочется полной автоматизации. Итак, постановка задачи: штамп должен позиционироваться сам, pdf-файл со штампом ЭЦП должен создаваться сам и в карточку исходящего документа тоже должен сам загружаться.

1 стартмани

19.02.2019    17081    51    soulner    45    

Ручная выгрузка и загрузка данных через универсальный обмен данными с настройками (расширение, платформа 8.3+)

Обработка документов Обработка справочников Обмен через XML Перенос данных из 1C8 в 1C8 v8 Розница УНФ ERP2 БП3.0 УТ11 КА2 ЗУП3.x Абонемент ($m)

Данное расширение (не требует изменения конфигураций) служит как надстройка для конфигураций, у которых обмен между базами происходит через универсальный формат (EnterpriseData), с использованием стандартных правил конвертации, которые уже есть в конфигурации. Интерфейс адаптирован для простых пользователей, сделан общий отбор по Организации для всех документов, имеется пару настроек для передачи в параметры конвертации, которые расположены в общем модуле конфигураций, а так же есть возможность выбора запуска - в фоне или в текущем сеансе. Теперь не нужно настраивать обмен между базами, для того чтоб просто перенести нужные документы. Подходит точно для УТ 11.4, БП 3.0.67, КА 2.4.5, Розница 2.2.9 (Обновление 1.2 от 02.03.2019)

2 стартмани

19.01.2019    22960    135    hakerxp    10    

Перенос данных КА 1.1.115.1 => БП 3.0.75.104 (перенос остатков, документов, зарплатный блок и справочной информации)

Перенос данных из 1C8 в 1C8 Обмен через XML v8 КА1 БП3.0 Россия Абонемент ($m)

Переносятся: остатки по счетам 01, 02, 10, 20, 41, 60, 62, 71, 97 и их субсчетам; документы; отдельно можно перенести справочники (номенклатура, контрагенты, договоры контрагентов, организации, склады, физические лица, сотрудники).

5 стартмани

22.12.2018    15466    363    gudogu    157    

Выполнение запроса в другой базе 1С без com-соединения. HTTP-сервис

Перенос данных из 1C8 в 1C8 v8 1cv8.cf Абонемент ($m)

Выполнение любого запроса с параметрами из одной базы 1С в другую. Используя HTTP-сервис. Посредством POST-запроса и JSON.

1 стартмани

30.11.2018    21825    24    John_d    23    

Пример получения данных из другой базы 1С через Web-сервис

Перенос данных из 1C8 в 1C8 v8 Россия Абонемент ($m)

В данной статье описан пример получения данных справочника из другой базы 1С через Web-сервис.

1 стартмани

11.11.2018    30159    25    flyDrag    29    

Выгрузка данных из УТ 10.3 в БП 3.0 (своими руками) Промо

Перенос данных из 1C8 в 1C8 v8 УТ10 БП3.0 Россия Абонемент ($m)

Старая добрая, позабытая многими выгрузка из УТ 10.3 в БП 1.6. Ее еще можно оживить, и она послужит на благо всем желающим, всем уставшим от автоматических обменов.

3 стартмани

30.10.2014    41115    179    TESL    40    

Мобильный сканер документов

Обработка документов Пользователю системы Обработка справочников Документооборот и делопроизводство Документооборот и делопроизводство v8 ДО ERP2 БП3.0 Россия Абонемент ($m)

Если под рукой нет обычного сканера, то можно воспользоваться собственным телефоном в качестве сканера для документов 1С.

3 стартмани

29.09.2018    9767    13    RSConsulting    16    

Интерфейс сопоставления объектов для обмена (для типового регистра СоответствиеОбъектовДляОбмена) Промо

Инструментарий разработчика Универсальные обработки Перенос данных из 1C8 в 1C8 v8 КА1 БП2.0 ЗУП2.5 УТ10 УПП1 Абонемент ($m)

Вы внедряете обмен данными между двумя типовыми или основанными на типовых БД и вам необходим инструмент, чтобы сопоставить между собой справочники этих конфигураций? Вы хотите навести порядок в обмене данными, потому что вам надоело вылавливать дублирующиеся объекты? Вам очень хочется перепоручить сопоставление объектов обменивающихся баз пользователям, но нет подходящего и понятного пользователям интерфейса? Тогда вам нужна именно эта обработка!

4 стартмани

11.11.2015    39617    135    catsam    8    

Правила переноса документов из ЗУП 2.5 в ЗУП 3.1

Обмен через XML Перенос данных из 1C8 в 1C8 Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 v8::СПР ЗУП2.5 ЗУП3.x Россия БУ Абонемент ($m)

Перенос документов, справочников и планов видов расчета из конфигурации 1С ЗУП 2.5 в ЗУП 3.1.

3 стартмани

28.03.2018    29527    413    Cobranet123    64    

Настройка соответствий подразделений ЗУП 3.1 и БП 3.0

Перенос данных из 1C8 в 1C8 Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 v8::БУ v8::СПР БП3.0 ЗУП3.x Россия БУ Абонемент ($m)

Синхронизация ЗУП 3 и БП 3.0: настройка соответствий подразделений при помощи внешней обработки.

5 стартмани

23.03.2018    25756    174    pas    26    

Выгрузка - загрузка данных в XML с отбором по организации Промо

Обмен через XML Перенос данных из 1C8 в 1C8 v8 1cv8.cf Абонемент ($m)

Выгрузка - загрузка данных в XML с отбором по организации (УФ)

1 стартмани

25.05.2014    47148    303    buganov    42    

Синхронизация (выгрузка) данных ЗУП 3.1 - БП 2.0, УПП 1.3

Перенос данных из 1C8 в 1C8 Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 v8::БУ v8::СПР БП2.0 ЗУП3.x Россия БУ Абонемент ($m)

Подобная выгрузка не была предусмотрена разработчиками 1С, поэтому и существует эта публикация. Поддерживается выгрузка оценочных обязательств и резервов отпусков. Непосредственная выгрузка в базу Бухгалтерии. Решение проблем с COM-соединением одной кнопкой.

3 стартмани

22.03.2018    43160    658    diso    186    

Перенос данных из конфигурации "Зарплата и управление персоналом" 3.1 в "Бухгалтерию предприятия" 2.0

Зарплата Перенос данных из 1C8 в 1C8 Зарплата v8 v8::БУ БП2.0 Россия БУ Абонемент ($m)

Перенос данных по Ole Automation из ЗУП 3.1 в БП 2.0. Тестировался на релизах 2.0.66.46 и 3.1.2.483.

3 стартмани

15.03.2018    13544    20    roma_semenov79    0    

Правила конвертации документов ЗУП 2.5 - ЗУП 3.1

Обмен через XML Зарплата Перенос данных из 1C8 в 1C8 Зарплата v8 v8::СПР ЗУП2.5 ЗУП3.x Россия БУ Абонемент ($m)

Правила конвертации документов ЗУП 2.5 - ЗУП 3.1. Позволяют вести параллельную работу в базах ЗУП редакций 2,5 и 3.1.

10 стартмани

06.03.2018    39726    153    kostya_whiskas    24    

Перенос справочников и документов из УТ 10.3 в БП 3.0 Промо

Перенос данных из 1C8 в 1C8 v8 УТ10 БП3.0 Россия БУ НУ УУ Абонемент ($m)

Синхронизация справочников и документов из Управление торговлей 10.3 в Бухгалтерию предприятия 3.0. Обработка не затрагивает штатный механизм. Подключение и перенос документов происходит посредством OLE. Без ввода начальных остатков.

10 стартмани

25.07.2017    22920    15    2casp    5    

[УТ 11][БП 3.0] Перенос данных из БП 3.0 в УТ 11 (начальное заполнение УТ 11 по данным БП 3.0)

Перенос данных из 1C8 в 1C8 v8 БП3.0 УТ11 Россия УУ Абонемент ($m)

Перенос данных из БП 3.0 в Ут 11 для первоначального заполнения УТ данными из БП. 31.01.2020 Версия 2.8.7.0 БП 3.0.75.70 платформа 8.3.16.1148. Исправлено подключение COM, более ничего...и это-то по многочисленным просьбам трудящихся... Нет пока времени (ну, или клиента) чтобы заняться этой обработкой...

1 стартмани

29.01.2018    40225    498    Alex_E    155    

Конвертация данных: Поиск при загрузке по дополнительному реквизиту

Перенос данных из 1C8 в 1C8 v8 УТ10 КД БП3.0 Абонемент ($m)

Конвертация данных 2.1. Поиск при загрузке справочника по дополнительному реквизиту.

1 стартмани

13.12.2017    17020    4    vowg    12    

Перенос НФА (ОС и МЗ) между учреждениями/базами через документы списания и поступления [БГУ 1.0] Промо

Перенос данных из 1C8 в 1C8 Обработка документов Учет ОС и НМА Учет ОС и НМА v8 v8::БУ БГУ Государственные, бюджетные структуры Россия БУ Госбюджет Абонемент ($m)

Обработка выполняет перенос основных средств/материалов между учреждениями/базами через документы списания НФА и безвозмездного получения в другом учреждении/базе данных.

10 стартмани

18.09.2014    41734    49    qwinter    31    

Правила переноса документов из ЗУП 2.5 в ЗУП 3.1

Перенос данных из 1C8 в 1C8 Обмен через XML Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 v8::СПР ЗУП3.x Россия БУ Абонемент ($m)

Перенос документов из ЗУП 2.5 в ЗУП 3.1 - позволяет снизить объем работ при опытной эксплуатации ЗУП 3.1 параллельно с ЗУП 2.5.

1 стартмани

04.12.2017    33152    498    AntonH851    38    

1С:Конвертация данных 2.0. Анализ состава выгруженных данных из базы источника до загрузки в базу-приемник

Перенос данных из 1C8 в 1C8 Перенос данных из 1С7.7 в 1C8.X v8 КД БП3.0 ЗУП3.x Россия Абонемент ($m)

Обработка анализирует файл выгрузки данных конвертации и формирует дерево выгруженных объектов по категориям с возможностью просмотра выгруженных реквизитов (свойств). Идеально подходит для анализа выгруженных данных при переходе на ЗУП 3.1 или Бухгалтерия 3.0 с ранних версий.

1 стартмани

16.11.2017    16194    85    leosoft    4    

Перенос данных УПП/КА в ЕРП и КА2, что таит этот чудный процесс

Перенос данных из 1C8 в 1C8 v8 КА1 УПП1 ERP2 КА2 Россия Абонемент ($m)

По итогам нескольких переносов УПП/КА в ЕРП и КА появилась данная статья. Не так счастлив этот процесс и его результаты.

1 стартмани

20.09.2017    26578    73    Константин С.    23    

Синхронизация данных по правилам КД2.0

Перенос данных из 1C8 в 1C8 v8 1cv8.cf Абонемент ($m)

Новый инструмент для сравнения и загрузки данных, сочетающий в себе: гибкость запросов (используются для сопоставления объектов); наглядный вывод отличий; удобный отбор загружаемых данных; возможность пообъектной синхронизации двух баз по правилам КД2 с помощью вызова обработки "Универсальный обмен XML" в базе-источнике через COM-соединение.

1 стартмани

27.08.2017    24657    115    vikad    35    

Правила обмена ЗУП 3.1 - БП 2.0 и ЗУП 3.1 - УПП 1.3 (отражение, ведомости и справочники)

Перенос данных из 1C8 в 1C8 Обмен через XML Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 v8::БУ v8::СПР БП2.0 БП3.0 ЗУП3.x Россия БУ Абонемент ($m)

Правила обмена для выгрузки документов "Отражение зарплаты в бухучете", "Ведомость в банк", "Ведомость в кассу", справочников "Сотрудники" и "Физические лица"

1 стартмани

01.08.2017    79372    1558    forseil    209    

Загрузка всех онлайн-чеков с сервиса проверки чеков ФНС – обработка для получения данных о покупках по чекам онлайн-касс с загрузкой в Авансовый отчет

Внешние источники данных WEB Документооборот и делопроизводство Кассовые операции Розничная торговля Учет ТМЦ Кассовые операции Розничная торговля Учет ТМЦ v8 1cv8.cf Россия Абонемент ($m)

В продолжение статьи «Свой кусочек информационного пирога по 54-ФЗ – обработка для получения данных о своих покупках по чекам ОФД» (на примере сети магазинов «Лента») (http://infostart.ru/public/647711/). Однако, в предыдущей публикации был показан пример получения данных с сервиса ОФД Такском по одному магазину, в новой публикации – показан пример загрузки всех чеков по всем ОФД непосредственно с сервиса проверки чеков ФНС. Опубликованы обработки, позволяющие работать по двум схемам: вносить данные по каждому чеку, получая данные с ФНС, или загружать чеки в мобильное приложение ФНС, выбирая в последующем для загрузки нужные чеки из списка. К публикации приложен файл расширения для печати Заявления на возмещения затрат подотчетного лица.

3 стартмани

26.07.2017    25422    122    delta    73    

«Горыныч - то НЕ НАСТОЯЩИЙ!» … или О Конвертации Данных ред.3 (КД 3) и обменах в универсальном формате Enterprise Data… доступным русско-народным языком

Внешние источники данных Обмен через XML Перенос данных из 1C8 в 1C8 v8 КД Абонемент ($m)

Тем, кто хочет быстро разобраться с темой инструмента Конвертация данных 3.0 и технологией обмена по новому формату 1С, активно применяемому во всех новых конфигурациях от 1С на БСП, расширяющем возможности интеграции, пакет полезных материалов.

1 стартмани

13.06.2017    21632    142    Davlad_A    16    

Обмен данными между программами "1С: Бухгалтерия предприятия" редакция 2.0 и "1С: Зарплата и управление персоналом" редакция 3.1

Перенос данных из 1C8 в 1C8 Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 v8::БУ БП2.0 Россия БУ Абонемент ($m)

В связи с отсутствием типовых правил обмена между конфигурациями БП 2.0 и ЗУП 3.1 (3.0) предлагается действующее решение в виде внешней обработки. Алгоритм построен на прямом подключении из базы БП к базе ЗУП. Для переноса данных используется COM-соединение с обработкой COM-объектов базы источника на стороне базы приемника.. Используется односторонний обмен - данные из ЗУП переносятся в БП.

1 стартмани

17.04.2017    26720    245    ivanovmi    38    

Правила обмена ЗУП 3.1(3.1.2.140) - УПП 1.3(1.3.88.2) - документа "Отражение зарплаты в регламентированном учете". Добавлено правило Отражения ERP20->БП30. ***Добавлено правило для ЗУП 3.1.5 и старше с использованием дополнительных реквизитов.

Перенос данных из 1C8 в 1C8 Зарплата Зарплата v8 УПП1 ЗУП3.x Россия БУ Абонемент ($m)

Правила обмена для производственных предприятий, где зарплата отдельной программой ЗУП 3.1 (для оперативного поддержания актуальности релиза), а управленческий и регламентированный учет ведется в УПП 1.3.

1 стартмани

24.03.2017    24240    218    bulas    51    

Синхронизация УТ 11.2 и Розница 2.2 (версии УТ 11.2.3.218, Розница 2.2.4.33+Доп УТ 11.3.4.47, Розница 2.2.6.28+Доп УТ 11.4.5.143, Розница 2.2.9.19). Описание граблей и способы их обхода

Перенос данных из 1C8 в 1C8 Розничная торговля Розничная торговля v8 Розница УТ11 Розничная и сетевая торговля (FMCG) Россия УУ Абонемент ($m)

Много написано о стандартных синхронизациях этих двух почти родных систем, но, к сожалению, из коробки обмен в них не работает. Как обойти грабли, на которые мы часто наступаем, я постараюсь описать в данном материале

1 стартмани

25.11.2016    38656    211    it_sar    34    

Блокировка повторного запуска комплексного процесса в 1С: Документооборот 2

Администрирование данных 1С Документооборот и делопроизводство Документооборот и делопроизводство v8 ДО Абонемент ($m)

Острой проблемой при работе документооборота стал повторный запуск комплексного процесса. Пользователи несколько раз  запускали один и тот же комплексный процесс по документу, не убедившись, что этот же процесс уже запущен. В результате наступил хаос, все возмущались и недоумевали, почему один и тот же документ приходил на согласование и исполнение несколько раз. 

2 стартмани

04.10.2016    21576    82    zabaluev    25