Групповая отправка отчетов в контролирующие органы из БГУ 2.0, ЗУП 3.1 и 1С:Зарплата и кадры государственного учреждения, редакция 3.1

17.03.23

Учетные задачи - Регламентированный учет и отчетность

Групповая отправка отчетов в ФНС, ПФР, Росстат из конфигураций основанных на управляемых формах. Обработка предоставляет возможность указания каталога с xml файлами отчетов на отправку, после чего автоматически отправляет все отчеты в контролирующий орган, самостоятельно закрывая все всплывающие уведомления. Обработка предполагает корректность заполнения форм отчетности - вид, период, организация, получатель. Цель - облегчить работу централизованных бухгалтерий, ведущих десятки бюджетных учреждений и формирующих по тем или иным причинам отчетность вне 1С.

Скачать исходный код

Наименование Файл Версия Размер
Групповая отправка отчетности в контролирующие органы из ЗиК ГУ и ЗУП 3.1, БГУ 2.0:
.epf 7,47Kb
0
.epf 7,47Kb Скачать

Данный код работает в моей конфигурации ЗИК ГУ 3.1, релиз 3.1.17.94

Так же будет работать в БГУ 2.0 и ЗУП 3.1.

Платформа версии 8.3.17, в теории должно работать и на более старых.

Работа интуитивна - открыть обработку, нажать кнопку выбора каталога, нажать кнопку отправки

 

 

Обработчики назначены на кнопки управляемой формы.

Команда 3 выбирает каталог с файлами

Команда 1 начинает отправку

Остальные команды служебные, и их на форме можно не отображать

&НаКлиенте
Перем Форм1;
&НаКлиенте
Перем Форм2;
&НаКлиенте
Перем ФайлыОтч;
&НаКлиенте
Перем i;

&НаКлиенте
Процедура ПослеЗакрытияПредупреждения(Результат, ДополнительныеПараметры) Экспорт
    //Сообщить("После закрытия предупреждения");
    КонтекстЭДОКлиент = Результат.КонтекстЭДО;
    //Сообщить(Результат.ТекстОшибки);
    ДополнительныеПараметры = Новый Структура("Адрес, ФайлыИмпорта", "1", ФайлыОтч[i].ПолноеИмя);
    КонтекстЭДОКлиент.ПолучениеФайловДляИмпортаНачало(ДополнительныеПараметры.Адрес, ДополнительныеПараметры.ФайлыИмпорта); 
    ПодключитьОбработчикОжидания("МойШаг", 3, Истина);
КонецПроцедуры

&НаКлиенте
Процедура МойШаг()
        Команда2(0);
КонецПроцедуры

&НаКлиенте
Процедура Команда1(Команда)
    ОписаниеОповещения = Новый ОписаниеОповещения("ПослеЗакрытияПредупреждения", ЭтотОбъект, Неопределено);
    ДокументооборотСКОКлиент.ПолучитьКонтекстЭДО(ОписаниеОповещения);
КонецПроцедуры

// Окна = ПолучитьОкна();
//Для Каждого Окно Из Окна Цикл
//    Если Не Окно.Основное Тогда
//        Форма = Окно.ПолучитьСодержимое();
//        Форма.Закрыть();
//    КонецЕсли;
//КонецЦикла;   

&НаКлиенте
Процедура ОбработатьОжидание()
 Форм1.Активизировать();
 Форм1.ПолучитьСодержимое().Закрыть();
 Форм2.Активизировать();
 Для каждого Форма из Форм2.Содержимое Цикл
            Форма.Закрыть(0);
        КонецЦикла;
        Если i<ФайлыОтч.Количество()-1 Тогда
        i=i+1;
        Команда4(0);
        Команда1(0);
        КонецЕсли
КонецПроцедуры

&НаКлиенте
Процедура Команда2(Команда)
    // Вставить содержимое обработчика.
    // Получение всех открытых окон приложения
    ОкнаПриложения = ПолучитьОкна();
    Для каждого ОкноПриложения Из ОкнаПриложения Цикл
        // Анализ заголовка окна
        Если Найти(ОкноПриложения.Заголовок, "Загруженный отчет (создание) *") > 0 Тогда
            // Получение формы
            НайденнаяФорма = ОкноПриложения.Содержимое[0];
            Форм2 =   ОкноПриложения;
            // Анализ реквизита формы
            //Если НЕ ЗначениеЗаполнено(НайденнаяФорма.Контрагент) Тогда
            //    ОкноПриложения.Активизировать();
            //    Возврат;
            //КонецЕсли;
            //Сообщить(НайденнаяФорма.Заголовок);
            //НайденнаяФорма.КоманднаяПанель.ПодчиненныеЭлементы.Отправить.Заголовок = "dddd";
             ОкноПриложения.Активизировать();
             ОкноПриложения.ПолучитьСодержимое().Записать();
             РегламентированнаяОтчетностьКлиент.ПриНажатииНаКнопкуОтправкиВКонтролирующийОрган(НайденнаяФорма, "ФНС");         
                 ОкнаПриложения2 = ПолучитьОкна();
                Для каждого ОкноПриложения2 Из ОкнаПриложения2 Цикл
                            Если Найти(ОкноПриложения2.Заголовок, "Подтверждение отправки отчета") > 0 Тогда
                            //НайденнаяФорма2 = ОкноПриложения2.Содержимое[0];
                            ОкноПриложения2.ПолучитьСодержимое().Закрыть(КодВозвратаДиалога.ОК);
                                ОкнаПриложения3 = ПолучитьОкна();
                                Для каждого ОкноПриложения3 Из ОкнаПриложения3 Цикл
                                    Если Найти(ОкноПриложения3.Заголовок, "Пожалуйста, подождите...") > 0 Тогда
                                        //Пока ОкноПриложения3.Заголовок<>"Успешно!" Цикл
                                        //    Продолжить;
                                        //Sleep(1);
                                        //КонецЦикла;
                                        Форм1 = ОкноПриложения3;
                                        ПодключитьОбработчикОжидания("ОбработатьОжидание", 8, Истина);
                                        //ОкноПриложения3.ПолучитьСодержимое().Закрыть();
                                    КонецЕсли
                                КонецЦикла
                            КонецЕсли                    
                        КонецЦикла;
                //ОкноПриложения.ПолучитьСодержимое().Закрыть();
         КонецЕсли;
    КонецЦикла;
КонецПроцедуры


&НаКлиенте
Процедура Команда3(Команда)
    i = 0;
     Режим = РежимДиалогаВыбораФайла.ВыборКаталога;
    ДиалогОткрытия = Новый ДиалогВыбораФайла(Режим);    
    ДиалогОткрытия.Каталог = "c:\\"; 
    ДиалогОткрытия.МножественныйВыбор = False; 
    ДиалогОткрытия.Заголовок = "Выберите каталог"; 
                                
    Если ДиалогОткрытия.Выбрать() Тогда
        ПутьККаталогу = ДиалогОткрытия.Каталог;
       // Сообщить(ПутьККаталогу);
    КонецЕсли;
ФайлыОтчетности = Новый Массив;
    ФайлыОтч = НайтиФайлы(ПутьККаталогу,"*.xml");
    Для Каждого ФайлXLS Из ФайлыОтч Цикл
        Сообщить(ФайлXLS.ПолноеИмя);
    КонецЦикла;
КонецПроцедуры


&НаКлиенте
Процедура Команда4(Команда)
    // Вставить содержимое обработчика.
     Окна1 = ПолучитьОкна();
Для Каждого Окно2 Из Окна1 Цикл
    Если Не Окно2.НачальнаяСтраница И Не Окно2.Основное Тогда
        Форма1 = Окно2.ПолучитьСодержимое();
        //Сообщить(Форма1.ИмяФормы);
        Если Форма1 <> ЭтаФорма И Форма1.ИмяФормы="Справочник.ЭлектронныеПредставленияРегламентированныхОтчетов.Форма.ФормаЭлемента" Тогда
            Форма1.Закрыть();
        КонецЕсли;
    КонецЕсли;
КонецЦикла; 
КонецПроцедуры

 

Отчетность ФНС ПФР Росстат Групповая отправка БГУ 2.0 ЗИК ГУ 3.1 ЗУП 3.1

См. также

Обновление для КА 1.1, ЗУП 2.5, БУХ 2.0: НДС, ЕФС-1, Расчет страховых взносов, Мобилизация, Статистика, Электронные трудовые книжки, 2-НДФЛ, Регламентированная отчетность, Кадровый учет, Прослеживаемость импортных товаров

Зарплата Регламентированный учет и отчетность Кадровый учет Обновление 1С Бухгалтер Платформа 1С v8.3 Сложные периодические расчеты 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 2.0 1С:Зарплата и Управление Персоналом 2.5 Бухгалтерский учет Налоговый учет Управленческий учет Акцизы ЕНВД ЕСН Земельный налог ИП, ПБОЮЛ, КФХ Налог на имущество Налог на прибыль НДС НДФЛ ФОМС, ЕФС Транспортный налог УСН ПСН (патентная система налогообложения) Платные (руб)

Обновления для конфигураций: КА 1.1; ЗУП 2.5; БУХ 2.0; КА 1.1 Комплексная автоматизация торговли алкогольной продукцией; КА 1.1 Комплексный учет сельскохозяйственного предприятия

19900 руб.

01.04.2020    141929    667    352    

233

SALE! 10%

Синхронизация и обмен для ERP 2.5, КА 2.5, УТ 11.5 БП 3.0, Розница, УНФ и других с EnterpriseData (универсальный формат обмена), правила обмена

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Россия Платные (руб)

Правила в универсальном формате обмена для ERP 2.5, КА 2.5, УТ 11.5, БП 3.0, Розница, УНФ, для последних версий конфигураций. Ссылки на другие конфигурации в описании публикации. Правила совместимы со всеми другими версиями конфигураций новыми и старыми, поддерживающими обмен и синхронизацию в формате EnterpriseData. Не требуется синхронного обновления правил после обновления другой конфигурации, участвующей в обмене. Типовой обмен через планы обмена кнопкой Синхронизация вручную или автоматически по расписанию, или вручную обработкой.

25080 22572 руб.

12.06.2017    136600    730    292    

393

Перенос данных из ERP 2 / КА 2 / УТ 11 в БП 3.0. Переносятся документы, начальные остатки и справочники

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

Перенос данных из ERP в БП 3 | из КА 2 в БП 3 | из УТ 11 в БП 3 | из ЕРП в БП 3 | В продаже с 2019г. | Воспользовались более 176 предприятий! | Сэкономьте время - используйте готовое решение для перехода! | Перенос разработан в формате КД 2 (правила конвертации данных) | Переносятся все возможные виды документов, начальных остатков и нормативно-справочная информация| Можно опционально выгружать каждую пару "номенклатура+характеристика" как отдельную номенклатуру | Есть выгрузка настроек счетов учета и зарплатных данных из ERP / КА 2 | Можно проверить на вашем сервере перед покупкой, обращайтесь!

34650 руб.

15.04.2019    69486    166    141    

112

SALE! 10%

Перенос данных из УТ 10.3 в УТ 11.5. Переносятся документы (обороты за период), справочная информация и остатки

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 10 1С:Управление торговлей 11 Россия Управленческий учет Платные (руб)

Перенос данных из 1С:Управление торговлей 10.3 в 1С:Управление торговлей 11.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УТ 10.3 (10.3.87.x) и УТ 11.5 (11.5.16.x).

28000 25200 руб.

23.07.2020    47479    203    64    

164

SALE! 10%

Перенос данных из УПП 1.3 в БП 3.0. Переносятся документы (обороты за период), справочная информация и остатки

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Управление производственным предприятием 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:Бухгалтерия предприятия 3.0 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УПП 1.3 (1.3.227.x) и БП 3.0 (3.0.151.x). Правила подходят для версии ПРОФ и КОРП.

28000 25200 руб.

15.12.2021    21064    138    38    

97

Перенос данных из ERP 2 / КА 2 в ЗУП 3. Переносятся остатки, документы и справочники

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из ERP в ЗУП 3 | из КА 2 в ЗУП | Воспользовались более 79 предприятий! | Предлагаем приобрести готовые правила конвертации данных (КД 2) для переноса остатков, документов с движениями и справочной информации 3 | В продаже с 2020г. | Оперативно обновляем правила до актуальных релизов 1С | Есть перенос начальной задолженности по зарплате и начальной штатной расстановки на выбранную дату | Обороты за прошлые годы (данные для расчета среднего) переносятся свернуто в документ "Перенос данных" | Есть фильтр по организациям | Документы за текущий период переносятся сразу с движениями, поэтому не потребуется делать перерасчеты | Перенос можно проверить перед покупкой, обращайтесь!

43450 руб.

03.12.2020    34796    83    58    

81

[ED2] Обмен УПП 1.3, КА 1.1, УТ 10.3 с EnterpriseData (универсальный формат обмена), обработка

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 Платформа 1C v8.2 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Управление производственным предприятием Россия Платные (руб)

Регулярный обмен, выгрузка, перенос из КА 1.1, УПП 1.3, УТ 10.3 для обмена с любыми конфигурациями, поддерживающими обмен в формате EnterpriseData (КД3) - БП 3.0, ERP, КА 2, УТ 11, Розница 2, УНФ 1.6 и другими. Правила для старых и доработанных конфигураций не требуют синхронного обновления и совместимы с новыми и будущими конфигурациями. Обмен по расписанию, через папку, FTP, почту.

14580 руб.

18.02.2016    183602    565    508    

509

SALE! 10%

Переход и перенос данных из УПП 1.3 в ERP 2.5, КА 2.5. Переносятся документы (обороты за период), справочная информация и остатки

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:Управление производственным предприятием 1С:ERP Управление предприятием 2 Бухгалтерский учет Управленческий учет Платные (руб)

Переход и перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:ERP Управление предприятием 2.5 и 1С:Комплексную автоматизацию 2.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УПП 1.3 (1.3.227.x), ERP 2.5 (2.5.16.x), КА 2.5 (2.5.16.x) .

28000 25200 руб.

24.06.2020    61667    45    27    

75
Оставьте свое сообщение