Добавляем новый документ в обработку Диадок

07.10.22

Интеграция - Файловый обмен (TXT, XML, DBF), FTP

Добавляем новый документ для подписания и отправки в обработку Диадок (через подключаемый модуль). Отправлять его будем, как неформализованный (внешняя печатная форма в формате pdf).

Скачать исходный код

Наименование Файл Версия Размер
ДиадокПодключаемыйМодуль.epf
.epf 7,31Kb
24
.epf 7,31Kb 24 Скачать

Для начала сгенерируем нужные нам события

 

 

 

Выбираем обработать типовой результат. Можно и переопределить полностью, но тогда придется описывать все документы, с которыми мы работаем.

 

 

Получаем шаблон с событиями, которые нам нужно обработать

 

 

1. ПолучитьТаблицуИспользуемыхПакетов()

 

 

Функция ПолучитьТаблицуИспользуемыхПакетов(Параметры)

	Если ТипЗнч(Параметры) = Тип("Структура") И Параметры.Свойство("Результат_ИМ") Тогда 
		
		//ТЗ = ТаблицаЗначенийСКолонками("ID, Наименование, СоставПакета, КатегорияПакета, НаименованиеКатегории, Шаблон");

		ТЗ  = Параметры.Результат_ИМ;
		ОсновнойМодуль.ЭДО_Служебные_ДобавитьСтрокуВТаблицуЗначений(ТЗ, "ID_Приложение", "Приложение" , "ID_Приложение", "ЗаказКлиента", "ЗаказКлиента");  
					
		Возврат ТЗ;

	КонецЕсли;

КонецФункции 

 

2. ПолучитьТаблицуИспользуемыхВидовДокументов()

 

 

Функция ПолучитьТаблицуИспользуемыхВидовДокументов(Параметры)

	Если ТипЗнч(Параметры) = Тип("Структура") И Параметры.Свойство("Результат_ИМ") Тогда  
		
		ТЗ  = Параметры.Результат_ИМ;
		ОсновнойМодуль.ЭДО_Служебные_ДобавитьСтрокуВТаблицуЗначений(ТЗ, "ID_Приложение", "Приложение", "Nonformalized", "");   

		Возврат ТЗ;

	КонецЕсли;

КонецФункции 

 

3.ПолучитьТекстЗапросаДляСпискаПакетовНаОтправкуПоМассивуВидовПакетов()

 

 

Функция ПолучитьТекстЗапросаДляСпискаПакетовНаОтправкуПоМассивуВидовПакетов(Параметры)

	Если ТипЗнч(Параметры) = Тип("Структура") И Параметры.Свойство("Результат_ИМ") Тогда 
				
		Если Параметры.МассивВидовПакетов.Найти("ID_Приложение") <> Неопределено Тогда
		
			ОписаниеВидаПакета = ОсновнойМодуль.ЭДО_СправочникМенеджер_ПолучитьЭлемент("ВидыПакетов", "ID_Приложение");
			     
			Параметры.ПараметрыЗапроса.Вставить("ВидПакетаID_ID_Приложение","ID_Приложение");
			
			Если Параметры.МассивВидовПакетов.Количество() = 1 Тогда
				Результат = ТекстЗапроса_Приложение(ОписаниеВидаПакета);   
				Результат = "ВЫБРАТЬ РАЗРЕШЕННЫЕ" + Сред(Результат, СтрДлина("ВЫБРАТЬ") + 1);
				Результат = ТекстЗапроса_ВременныеТаблицыДляСпискаПакетовНаОтправку_1С() + "
							|;
							|
							|//////////////////////////
							|" + Результат + "
							|УПОРЯДОЧИТЬ ПО
							|	ДатаДокумента, НомерДокумента";    
				Параметры.Результат_ИМ = Результат;

			Иначе	
				Результат = ДобавитьОбъединениеВТекстЗапроса() + ТекстЗапроса_Приложение(ОписаниеВидаПакета);
				ТекстДляЗамены = "
							|" + Результат + " 
							|
							|УПОРЯДОЧИТЬ ПО 
							|";
				Параметры.Результат_ИМ = СтрЗаменить(Параметры.Результат_ИМ, "УПОРЯДОЧИТЬ ПО" , ТекстДляЗамены); 
			КонецЕсли;
						
			Возврат Параметры.Результат_ИМ;
    	КонецЕсли;
	КонецЕсли;

КонецФункции

 

В функции ПолучитьТекстЗапросаДляСпискаПакетовНаОтправкуПоМассивуВидовПакетов нужно определить, запрос идет ко всем документам, с которыми мы работаем, или только к новому документу. Если ко всем, то запрос просто дописываем в конец основного запроса, а если только к новому документу, то нужно написать весь запрос (со всеми временными таблицами).

 
 Запрос к новому документу

 Если у вас модуль Диадока встроен в конфигурацию, то у вас будут другие временные таблицы. Их можно будет взять из запроса, когда мы добавляем наш запрос к основному запросу.

 
 Временные таблицы

4. ПодготовитьПакет()

 

 

Функция ПодготовитьПакет(Параметры)

	Если ТипЗнч(Параметры) = Тип("Структура") И Параметры.Свойство("Результат_ИМ") Тогда
		
		Если Параметры.ВидПакетаРазвернутый.ID = "ID_Приложение" Тогда	
			ОсновнойМодуль.ЭДО_ДокументМенеджер_ПодготовитьИДобавитьДокументВПакет(Параметры.Пакет, Параметры.СтрокаСписка.Документ, "ID_Приложение");     
			Возврат Истина;
		КонецЕсли;	

	КонецЕсли;

КонецФункции

 

Далее подключаем модуль и жмем сохранить

 

 

Заходим в настройки организации.

Ставим галочку на новый документ

 

 

 

 

Там же выбираем нужную печатную форму (желательно, чтобы в печатной форме была одна команда), которую будем отправлять и подписывать

 

 

 

готово

 

 

 

Тестировал: 

  • 1С:Комплексная автоматизация 2 (2.4.13.209)
  • Платформа 1С:Предприятие 8.3 (8.3.19.1467)

Диадок:

  • Версия модуля: 4.21.2.2018
  • Версия плагина: 1.4.5.286
  • Расположение модуля: ВСправочнике
  • Модуль интеграции: ПМ_УТ_11

Диадок

См. также

SALE! 15%

Синхронизация и обмен для ERP 2.5, КА 2.5, УТ 11.5 БП 3.0, Розница, УНФ и других с EnterpriseData (универсальный формат обмена), правила обмена

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Россия Платные (руб)

Правила в универсальном формате обмена для ERP 2.5, КА 2.5, УТ 11.5, БП 3.0, Розница, УНФ, для последних версий конфигураций. Ссылки на другие конфигурации в описании публикации. Правила совместимы со всеми другими версиями конфигураций новыми и старыми, поддерживающими обмен и синхронизацию в формате EnterpriseData. Не требуется синхронного обновления правил после обновления другой конфигурации, участвующей в обмене. Типовой обмен через планы обмена кнопкой Синхронизация вручную или автоматически по расписанию, или вручную обработкой.

25080 руб.

12.06.2017    137270    747    292    

399

Перенос данных из ERP 2 / КА 2 / УТ 11 в БП 3.0. Переносятся документы, начальные остатки и справочники

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

Перенос данных из ERP в БП 3 | из КА 2 в БП 3 | из УТ 11 в БП 3 | из ЕРП в БП 3 | В продаже с 2019г. | Воспользовались более 176 предприятий! | Сэкономьте время - используйте готовое решение для перехода! | Перенос разработан в формате КД 2 (правила конвертации данных) | Переносятся все возможные виды документов, начальных остатков и нормативно-справочная информация| Можно опционально выгружать каждую пару "номенклатура+характеристика" как отдельную номенклатуру | Есть выгрузка настроек счетов учета и зарплатных данных из ERP / КА 2 | Можно проверить на вашем сервере перед покупкой, обращайтесь!

34650 руб.

15.04.2019    69744    172    143    

113

Перенос данных из УТ 10.3 в УТ 11.5. Переносятся документы (обороты за период), справочная информация и остатки

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 10 1С:Управление торговлей 11 Россия Управленческий учет Платные (руб)

Перенос данных из 1С:Управление торговлей 10.3 в 1С:Управление торговлей 11.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УТ 10.3.87.x и УТ 11.5.16.x

28000 руб.

23.07.2020    47861    207    64    

169

[ED2] Обмен УПП 1.3, КА 1.1, УТ 10.3 с EnterpriseData (универсальный формат обмена), обработка

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 Платформа 1C v8.2 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Управление производственным предприятием Россия Платные (руб)

Регулярный обмен, выгрузка, перенос из КА 1.1, УПП 1.3, УТ 10.3 для обмена с любыми конфигурациями, поддерживающими обмен в формате EnterpriseData (КД3) - БП 3.0, ERP, КА 2, УТ 11, Розница 2, УНФ 1.6 и другими. Правила для старых и доработанных конфигураций не требуют синхронного обновления и совместимы с новыми и будущими конфигурациями. Обмен по расписанию, через папку, FTP, почту.

14580 руб.

18.02.2016    184004    570    509    

513

Переход и перенос данных из УПП 1.3 в ERP 2.5, КА 2.5. Переносятся документы (обороты за период), справочная информация и остатки

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:Управление производственным предприятием 1С:ERP Управление предприятием 2 Бухгалтерский учет Управленческий учет Платные (руб)

Переход и перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:ERP Управление предприятием 2.5 и 1С:Комплексную автоматизацию 2.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УПП 1.3 (1.3.227.x), ERP 2.5 (2.5.16.x), КА 2.5 (2.5.16.x) .

28000 руб.

24.06.2020    61935    47    27    

78

Перенос данных из ERP 2 / КА 2 в ЗУП 3. Переносятся остатки, документы и справочники

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из ERP в ЗУП 3 | из КА 2 в ЗУП | Воспользовались более 79 предприятий! | Готовые правила конвертации данных (КД 2) для переноса остатков, документов с движениями и справочной информации 3 | В продаже с 2020г. | Оперативно обновляем правила до актуальных релизов 1С | Есть перенос начальной задолженности по зарплате и начальной штатной расстановки на выбранную дату | Обороты за прошлые годы (данные для расчета среднего) переносятся свернуто в документ "Перенос данных" | Есть фильтр по организациям | Документы за текущий период переносятся сразу с движениями, поэтому не потребуется делать перерасчеты | Перенос можно проверить перед покупкой, обращайтесь!

43450 руб.

03.12.2020    34970    84    59    

82

Перенос данных из УПП 1.3 в БП 3.0. Переносятся документы (обороты за период), справочная информация и остатки

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Управление производственным предприятием 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:Бухгалтерия предприятия 3.0 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УПП 1.3 (1.3.227.x) и БП 3.0 (3.0.151.x). Правила подходят для версии ПРОФ и КОРП.

28000 руб.

15.12.2021    21369    138    40    

97

Перенос данных из УПП 1.3 / КА 1.1 в БП 3. Переносятся документы, справочники и начальные остатки

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Управление производственным предприятием 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Платные (руб)

В продаже с 2015 года | Воспользовались более 287 предприятий! | Перенос данных из УПП 1.3 в БП 3.0 | из КА 1.1 в БП 3.0 | Переносятся документы, начальные остатки и вся справочная информация | Сэкономьте свое время - используйте готовое решение для перехода! | Есть фильтр по организации и множество других параметров выгрузки | Поддерживается несколько сценариев работы: как первичный полный перенос, так и перенос только новых документов | Перенос данных возможен в "1С: Бухгалтерия 3.0" версии ПРОФ, КОРП или базовую | Переход с "1С: Управление производственным предприятием 1.3" / "1С:Комплексная автоматизация 1.1" на "1С:Бухгалтерия предприятия 3.0" с помощью наших правил конвертации будет максимально комфортным! | Над развитием алгоритмов и улучшением качества переноса Можно бесплатно проверить перенос на вашем сервере!

39500 руб.

25.02.2015    169246    292    251    

373
Вознаграждение за ответ
Показать полностью
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. bavkyz 4 07.10.22 10:54 Сейчас в теме
Добрый, спасибо за труд +1, Маленько не понял, в вашем решении пользователь с ЭЦП или пользователь по логин/пароль, создает документ и передать на подписание руководителю?

И еще вопрос, где вы нашли описание по работе с универсальной обработкой диадока?
2. John_d 5534 07.10.22 11:23 Сейчас в теме
(1) -Только пользователи с ЭЦП могут подписать документ, но просматривать документы в обработке могут все.
-Документы после создания и проведения сами появляются в обработке. Пользователь их выбирает подписывает и отправляет.
https://developer.kontur.ru/Docs/Diadoc_UM/
sapervodichka; +1 Ответить
3. bavkyz 4 07.10.22 11:28 Сейчас в теме
(2)
пользователи с ЭЦП могут подписать документ
- это логично), в вашем решении обязательно ли пользователю иметь ЭЦП для создания документа?

P.S. мне надо чтоб пользователь мог создать документ, а руководитель "потом" подпишет
4. tricolor 23 07.10.22 11:34 Сейчас в теме
(3) у нас пользователи заходят по логину и паролю, и отправляют документ на согласование, далее руководитель подписывает и отправляет документы.
6. John_d 5534 07.10.22 11:40 Сейчас в теме
(3) не обязательно. Пользователь вообще может не заходить в обработку Диадок создать документ, как обычно создает в 1с.
5. stsasha87 135 07.10.22 11:40 Сейчас в теме
Зная, насколько сложно там всё реализовано, понимаешь сколько времени и трудов ушло на эту доработку.

Тоже сижу разбираюсь с подключаемым модулем. Пытаюсь решить задачу автоматического получения подписанных файлов и прикрепления их к документам 1с. Очень хитро всё сделано. Не попадалось случайно ничего подобного?
tricolor; mrChOP93; KRIHA; +3 Ответить
7. John_d 5534 07.10.22 11:42 Сейчас в теме
(5) решал, через диадок API. Чтобы подключаться к API Диадока нужно оплатить данную услугу отдельно.
8. bavkyz 4 07.10.22 11:48 Сейчас в теме
(6) Спасибо, понял.


(5) Полностью согласен, сложно все там на первый взгляд и нормальной инструкции нет ... то что есть мне мало.


Я маленько изменил алгоритм создание документа "поступление товара" (создание новой ном-ры, создание СФ и документ Измен. цены), но так и не решил вопрос с сопоставлением ном-ры... вроде все сопоставлено, т.е. сообщения о не сопоставленной ном-ры нет.... но документ не создается, пишет что не сопоставлено. Нужно обязательно нажать кнопку "Сопоставить", а потом кнопку "Ок".
12. Razyiller 10.10.22 04:49 Сейчас в теме +2 $m
(5)
м модулем. Пытаюсь решить задачу автоматического получения подписанных файлов и прикрепления их к документам 1с. Очень

попробуйте плагины использовать.
Настройки - Системные.

В Плагинах есть "Плагин для выгрузки архива документов".
14. stsasha87 135 19.10.22 16:15 Сейчас в теме
(12) Добрался, попробовал, спасибо! Честно говоря, не знал, что он там есть. Вроде всё указал, галки установил. Но в 1С присоединенных файлов у подписанных документов почему-то не вижу... Может не там смотрю или этот плагин надо как-то отдельно запускать?

Попробовал в подключаемом модуле запускать в событии ПослеОбновленияСпискаДокументов что-то типа
АрхивДокументооборота = ОсновнойМодуль.ЭДО_ПолучитьАрхивДокументооборота(boxId, letterId, documentId);

и получаю ошибку авторизации...

В прошлой версии обходился финтом ушами - в основном модуле на клиенте дёргал метод SaveAllContentZipAsync() при формировании списка документов, тут же всё иначе... Весь мозг уже сломал.
Если есть где подсмотреть, поделитесь, плиз ))
15. Razyiller 19.10.22 17:17 Сейчас в теме
(14)
Плагин это всего лишь конструктор с примерами, доработать все равно приходится.
Там помоему и пример авторизации есть.

Примера нет, просто изучал этот генератор ПМ и видел что там такое есть. для целей добавление в пакет своих печатных форм и отправку своих видов документов.
17. Razyiller 22.11.22 10:03 Сейчас в теме
(14)
Функция ОбработатьСобытие(ИмяСобытия, Параметры) Экспорт
............................
ИначеЕсли ИмяСобытия = "ВыполнитьРегламентныеДействия" Тогда

		Возврат ВыполнитьРегламентныеДействия(Параметры); 
................................
КонецФункции

Функция ВыполнитьРегламентныеДействия(Параметры)

	// Имя шаблона: Авторизация под логином (РЗ)
	АвторизоватьсяПодЛогином();

КонецФункции 

Функция УчетнаяЗапись()
    
    Результат = Новый Структура;

    Результат.Вставить("Логин"	, ОсновнойМодуль.ЭДО_Модуль_ОбщиеНастройки().СлужебнаяУчетнаяЗаписьЛогин);
    Результат.Вставить("Пароль"	, ОсновнойМодуль.ЭДО_Модуль_ОбщиеНастройки().СлужебнаяУчетнаяЗаписьПароль);
    
    Возврат Результат;
    
КонецФункции

Процедура АвторизоватьсяПодЛогином()
ДанныеУчетнойЗаписи = УчетнаяЗапись();

	ЗаписатьВЖурналРегистрацииИнформацию("Диадок.АвторизацияПодЛогином", ДанныеУчетнойЗаписи.Логин);

	ОсновнойМодуль.ЭДО_АвторизоватьсяПодЛогином(ДанныеУчетнойЗаписи.Логин, ДанныеУчетнойЗаписи.Пароль);		
	ОсновнойМодуль.ЭДО_ЗаполнитьКонтекстСеансаДляСлужебнойУчетнойЗаписи();
        МассивВидовДокументов = Новый Массив;
	МассивВидовДокументов.Добавить("ID_УПД_НаАванс");
	МассивВидовДокументов.Добавить("ID_СФ_НаАванс");
	МассивВидовДокументов.Добавить("ID_УПД_раздельно");
	МассивВидовДокументов.Добавить("ID_КСФ");
	МассивВидовДокументов.Добавить("ID_АктСверки");
	МассивВидовДокументов.Добавить("ID_УКД");
	МассивВидовДокументов.Добавить("ID_УКД_раздельно");
	МассивВидовДокументов.Добавить("ID_ИУПД_БезНДС");
	МассивВидовДокументов.Добавить("ID_УКД_БезНДС");
	МассивВидовДокументов.Добавить("ID_ТОРГ12_Акт_БезНДС");
	МассивВидовДокументов.Добавить("ID_Счет");
	МассивВидовДокументов.Добавить("ID_ИСФ_НаАванс");
	МассивВидовДокументов.Добавить("ID_ИУПД_НаАванс");
	МассивВидовДокументов.Добавить("ID_УПД_БезНДС");
	МассивВидовДокументов.Добавить("ID_ИКСФ");
	МассивВидовДокументов.Добавить("ID_ОсновнойПакет");
	МассивВидовДокументов.Добавить("ID_ИУКД");
	МассивВидовДокументов.Добавить("ID_ИУКД_раздельно");
	МассивВидовДокументов.Добавить("ID_ИСФ");
	МассивВидовДокументов.Добавить("ID_АктСверкиТара");
	МассивВидовДокументов.Добавить("ID_СчетФормализованный");
	МассивВидовДокументов.Добавить("ID_УПД" );
	МассивВидовДокументов.Добавить("ID_АктСверкиОборудование");
	МассивВидовДокументов.Добавить("ID_ИУПД_раздельно");
	МассивВидовДокументов.Добавить("ID_ИУПД");
	
	
	МассивСтатусов = Новый Массив;
	МассивСтатусов.Добавить("Подписан");
	//Результат.Добавить("Отказано в подписи контрагенту");
	МассивСтатусов.Добавить("Документооборот завершен");
	//Результат.Добавить("Аннулирован");
	//Результат.Добавить("Контрагент отказал в подписи");
	МассивСтатусов.Добавить("Подписан контрагентом");
	МассивСтатусов.Добавить("Подписан с разногласиями");

	
	
	
	ПараметрыОбновленияСписка = Новый Структура;
	ПараметрыОбновленияСписка.Вставить("Режим", "ОтправленныеДокументы");
	ПараметрыОбновленияСписка.Вставить("НачалоПериода", Дата('2019.04.01 00:00:00'));
	ПараметрыОбновленияСписка.Вставить("КонецПериода", Дата('2019.08.01 00:00:00'));
	ПараметрыОбновленияСписка.Вставить("МассивВыбранныхВидов", Неопределено);
	ПараметрыОбновленияСписка.Вставить("ОтборПоОрганизации ", Неопределено);
	ПараметрыОбновленияСписка.Вставить("ОтборПоКонтрагенту ", Неопределено);
	ПараметрыОбновленияСписка.Вставить("ОтборПоПакету ", Неопределено);
	//ПараметрыОбновленияСписка.Вставить("ОтборПоСтатусу ", МассивСтатусов);
	                                                        
	
	ПараметрыОбновленияСписка.Вставить("ВключитьОтборПоКонтрагенту ", ЛОЖЬ);
	ПараметрыОбновленияСписка.Вставить("ВключитьОтборПоОрганизации ", ЛОЖЬ);
	ПараметрыОбновленияСписка.Вставить("ВключитьОтборПоСтатусу ", ЛОЖЬ);
	ПараметрыОбновленияСписка.Вставить("ПоказыватьЗавершенные ", ИСТИНА);
	ПараметрыОбновленияСписка.Вставить("РежимОтбораПоПериоду ", "ПоДатеДокумента");
	
	
	ОсновнойМодуль.ЭДО_Модуль_ОбновитьСписокДокументов(ПараметрыОбновленияСписка);
               Для Каждого Стр Из ОсновнойМодуль.СписокДокументов Цикл
                                BoxId = ОсновнойМодуль.ЭДО_Модуль_ТаблицаОрганизацийПользователя()[0].BoxId;
				Архив = ОсновнойМодуль.ЭДО_ПолучитьАрхивДокументооборота(BoxId,Стр.LetterId,Стр.DocumentId);
                                Если Архив<>Неопределено Тогда
				
				   Каталог = "каталог куда сохранять будем" ;
				   Каталог = ЗаменитьНедопустимыеСимволыИмениФайла(Каталог);
				   ПроверитьСуществованиеКаталога(Каталог);
				   Архив.Записать(Каталог + Стр.ПредставлениеДокументаДиадок + ".zip");	
			        КонецЕсли;
			//сохранение архива ДО

		
		
	          КонецЦикла;
Показать


как то так сохраняю ДО. в настройках обработки Диадок необходимо указать логин пароль для авторизации
tricolor; John_d; +2 Ответить
9. ZOMI 452 07.10.22 12:21 Сейчас в теме
API для Диадока стоит 18 000 в год и я посмотрев на решение Контура для 1С взялся и написал свое решение. Дорабатывать обработку Контура - которую несколько десятков разработчиков видоизменяли - то еще удовольствие. Простейшие доработки вызывают боль.
10. bavkyz 4 07.10.22 12:36 Сейчас в теме
(9)
написал свое решение.


Поделитесь решением )
13. Razyiller 10.10.22 04:54 Сейчас в теме
Тоже реализовал такой функционал, только еще к каждому виду документов заказчик попросил отдельные пакеты печатных форм, причем пакет динамический. сделал через ПМ.

текущий релиз обработки Диадока намного удобнее в доработке нежели предыдущий))))
11. ZOMI 452 07.10.22 12:51 Сейчас в теме
(10)сейчас сложно назвать сроки... но видимо в течение месяца выложу
tambu; prestige; Evgenij1990; Dach; bavkyz; +5 Ответить
16. user954261 19.11.22 09:03 Сейчас в теме
Здравствуйте. Прошу помощи.
1С:УПП 1.3.190, настраиваю универсальный модуль КонтурДиадокИнтеграция 4.24.
Задача:
сопоставлять номенклатуру поставщика с нашей номенклатурой в соответствии с алгоритмом (на лету, без хранения таблицы соответствия, т.к. хранить не целесообразно). Это актуально, например, для услуг, когда каждый раз от поставщика прилетает уникальное наименование услуги. Это уникальное наименование нужно транслировать в нашу номенклатуру (примитивно, по вхождению подстроки).
При загрузке входящего док-та Накладная в док-т 1С:ПоступлениеТоваровУслуг сопоставление происходит дважды (как я понял). Первый этап удалось победить: в ПодключаемомМодуле добавил "Функция ПрочитатьСопоставлениеНоменклатуры(Параметры)". Сопоставление проходит успешно, далее нажимаю "Создать документы", после чего модуль второй раз пытается сопоставить номенклатуру (предположительно из РегистраСведений.НоменклатураКонтрагентов и из Справочник.ХранилищеДополнительнойИнформации).
Вопрос:
как победить второй этап сопоставления (при создании док-та ПоступлениеТоваров) ? Или есть решение, которое поможет пройти сразу два этапа сопоставления?
18. Vo-Va 801 26.11.22 13:36 Сейчас в теме
Кто бы написал еще статью как добавить выгрузку счет фактуры сделанной по отчету комиссионера. Только формализованную по стандарту фнс.
19. kai068 5 05.12.22 10:51 Сейчас в теме
Друзья, никто не сталкивался с добавлением документа Реализации(УПД) в Диадок со статусом "Отправлено на подпись"?
т.е чтобы не заходить в обработку Диадока, а программно отправить нужную накладную по "кнопке" сразу в обработку с нужным статусом.
Буду признателен, если направите куда копать.
20. kai068 5 05.12.22 10:53 Сейчас в теме
21. charushkin 107 27.03.23 13:56 Сейчас в теме
Привет!

Спасибо за хороший пример работы с модулем Диадока. В вашем кейсе документы на отправку выводятся в отдельном пакете. Я подготовил статью с примерами кейса, когда нужно добавить документы в уже готовый пакет Программное добавление документа в исходящий пакет (Контур.Диадок).Надеюсь, будет полезно вам или читателям вашей статьи
22. AKV77 260 14.02.24 13:18 Сейчас в теме
Оставьте свое сообщение