Расчет тарифов

30.07.13

Задачи пользователя - Адаптация типовых решений

Отчет по расчету ЗП в зависимости от категории сотрудников.

Скачать исходный код

Наименование Файл Версия Размер
Расчет тарифов
.erf 9,72Kb
1
.erf 9,72Kb 1 Скачать


Процедура КнопкаСформироватьНажатие(Кнопка)

Если ЭтаФорма.Подразделение = Справочники.Подразделения.ПустаяСсылка() Тогда
Вопрос("Для формирования отчета необходимо выбрать производственный участок!", РежимДиалогаВопрос.ОК);
Возврат;
КонецЕсли;

ТабДокумент = ЭтаФорма.ЭлементыФормы.ТД;
Макет = Отчеты.ОтчетРасчетаТарифовДок.ПолучитьМакет("Макет");

ТабДокумент.Очистить();

//Получение производительности
ЗапросПроизводительности = Новый Запрос();
ЗапросПроизводительности.Текст = "ВЫБРАТЬ
| ПроизводительностьПоУчасткамСрезПоследних.Номенклатура КАК Номенклатура,
| ПроизводительностьПоУчасткамСрезПоследних.ПроизводственныйУчасток КАК Подразделение,
| ПроизводительностьПоУчасткамСрезПоследних.Организация КАК Организация,
| ПроизводительностьПоУчасткамСрезПоследних.Производительность,
| ПроизводительностьПоУчасткамСрезПоследних.Период
|ИЗ
| РегистрСведений.ПроизводительностьПоУчасткам.СрезПоследних(&Период, ) КАК ПроизводительностьПоУчасткамСрезПоследних
|ГДЕ
| ПроизводительностьПоУчасткамСрезПоследних.ПроизводственныйУчасток = &Подразделение
| И ПроизводительностьПоУчасткамСрезПоследних.Организация = &Организация
|
|УПОРЯДОЧИТЬ ПО
| ПроизводственныйУчасток,
| Номенклатура,
| Организация";

ЗапросПроизводительности.УстановитьПараметр("Подразделение", ЭтаФорма.Подразделение);
ЗапросПроизводительности.УстановитьПараметр("Организация", ЭтаФорма.Организация);
ЗапросПроизводительности.УстановитьПараметр("Период", ЭтаФорма.ДатаОтчета);

ВыборкаПроизводительности = ЗапросПроизводительности.Выполнить().Выбрать();

ЗапросКатегорий = Новый Запрос();
ЗапросКатегорий.Текст = "ВЫБРАТЬ
| ДоговорнаяЗарплата.Категория КАК Категория,
| ДоговорнаяЗарплата.Сумма
|ИЗ
| РегистрСведений.ДоговорнаяЗарплата КАК ДоговорнаяЗарплата
|
|УПОРЯДОЧИТЬ ПО
| Категория";

ВыборкаКатегорий = ЗапросКатегорий.Выполнить().Выбрать();


//Вывод шапки отчета
тШапкаОтчета = Макет.ПолучитьОбласть("ШапкаОтчета|Данные");
тШапкаОтчета.Параметры["Подразделение"] = ЭтаФорма.Подразделение;

ТабДокумент.Вывести(тШапкаОтчета);

//Вывод шапки таблицы
тШапкаДанные = Макет.ПолучитьОбласть("ШапкаТаблицы|Данные");
ТабДокумент.Вывести(тШапкаДанные);
тШапкаКатегория = Макет.ПолучитьОбласть("ШапкаТаблицы|Категория");
Пока ВыборкаКатегорий.Следующий() Цикл
тШапкаКатегория.Параметры["Категория"] = ВыборкаКатегорий.Категория;
ТабДокумент.Присоединить(тШапкаКатегория);
КонецЦикла;

//Формирование отчета
тСтрокаДанные = Макет.ПолучитьОбласть("СтрокаТаблицы|Данные");
тСтрокаКатегория = Макет.ПолучитьОбласть("СтрокаТаблицы|Категория");
Пока ВыборкаПроизводительности.Следующий() Цикл

//Вывод номенклатуры
тСтрокаДанные.Параметры["Номенклатура"] = ВыборкаПроизводительности.Номенклатура;
ТабДокумент.Вывести(тСтрокаДанные);

//Проход по выборке категорий (для вывода тарифа по каждой категории)
ВыборкаКатегорий.Сбросить();
Пока ВыборкаКатегорий.Следующий() Цикл
тСтрокаКатегория.Параметры["Сумма"] = Окр(ВыборкаКатегорий.Сумма / ВыборкаПроизводительности.Производительность, 2);
ТабДокумент.Присоединить(тСтрокаКатегория);
КонецЦикла;

КонецЦикла;
ТабДокумент.Показать();

КонецПроцедуры

Процедура ПриОткрытии()

Организация = УправлениеПользователями.ПолучитьЗначениеПоУмолчанию(глЗначениеПеременной("глТекущийПользователь"), "ОсновнаяОрганизация");
ДатаОтчета = ТекущаяДата();

КонецПроцедуры

Процедура ПодразделениеНачалоВыбораИзСписка(Элемент, СтандартнаяОбработка)

СтандартнаяОбработка = Ложь;

СписокПодразделений = Новый СписокЗначений;

Запрос = Новый Запрос();
Запрос.Текст =
"ВЫБРАТЬ
| Подразделения.Ссылка КАК Ссылка
|ИЗ
| Справочник.Подразделения КАК Подразделения
|ГДЕ
| Подразделения.Родитель = &Родитель
|
|УПОРЯДОЧИТЬ ПО
| Подразделения.Наименование";


ПРУчастки = Справочники.Подразделения.НайтиПоНаименованию("Производственные участки");
Если ПРУчастки = неопределено Тогда
ПРУчастки = Справочники.Подразделения.ПустаяСсылка();
КонецЕсли;

Запрос.УстановитьПараметр("Родитель",ПРУчастки);
Результат = Запрос.Выполнить();
Выборка = Результат.Выбрать();

Пока Выборка.Следующий() Цикл
//Сообщить(Выборка.Ссылка);
СписокПодразделений.Добавить(Выборка.Ссылка, Выборка.Ссылка.Наименование);
КонецЦикла;

ВыбранноеЗначение = ЭтаФорма.ВыбратьИзСписка(СписокПодразделений, Элемент);

Если ВыбранноеЗначение <> Неопределено Тогда
Элемент.Значение = ВыбранноеЗначение.Значение;
КонецЕсли;

КонецПроцедуры

 

 

 

 

 

См. также

Табличная часть в доп. реквизитах и формирование таблиц в шаблоне docx для 1С:ДО 3.0

Адаптация типовых решений Платформа 1С v8.3 1С:Документооборот Россия Платные (руб)

Расширение конфигурации для «1С:Документооборот КОРП», редакция 3.0. позволяет: 1.использовать произвольные табличные части в качестве дополнительных реквизитов к документу; 2 использовать произвольные табличные части в шаблонах в формате docx для автоматического заполнения таблиц.

29400 руб.

29.06.2023    4884    10    5    

19

Расширение для 1С:УНФ. Автоматическое снятие резервов в Заказах покупателей

Логистика, склад и ТМЦ Адаптация типовых решений Пользователь Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Управление нашей фирмой 3.0 Россия Управленческий учет Платные (руб)

Чтобы не допустить путаницы с обещаниями клиентам и для четкого контроля исполнения заказов мы используем резервирование товаров. Мы доработали УНФ, чтобы она автоматически отменяла старые резервы и не мешала эффективно продавать.

7200 руб.

02.08.2023    3261    5    0    

22

Каждому менеджеру нужен свой Excel

Адаптация типовых решений Программист Пользователь Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Абонемент ($m)

Каждый из нас сталкивается с ситуацией, когда какой-нибудь менеджер показывает свой Excel и рассказывает, как он что-то из 1С копирует в него, снабжает пояснениями, выделяет цветом и т.д. и т.п. Заканчивается все просьбой сделать вот чтобы также было в 1С. И оказывается такой человек (почти с гарантией) либо лучшим продажником, либо каким-то важным, за все отвечающим, - на ком все держится.

2 стартмани

22.04.2024    4409    dimanich70    15    

18

Создать на основании - своя кнопка (БСП). Проблема двух подменю Создать на основании

БСП (Библиотека стандартных подсистем) Адаптация типовых решений Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 Бесплатно (free)

Понадобилось в подменю "Создать на основании" добавить свою команду, которая открывает обработку. В процессе доработок появилась проблема двух подменю "Создать на основании". В статье о том, как решились проблемы.

01.03.2024    2495    dimanich70    8    

15

Доработка отчета "Связанные документы" (структура подчиненности) для вывода объектов из любого расширения

Адаптация типовых решений Программист Платформа 1С v8.3 1С:Управление торговлей 11 Россия Абонемент ($m)

Доработка типового отчета "Связанные документы" позволяет просто и быстро расширять состав объектов для построения структуры подчиненности документов, используя объекты основной конфигурации и любых расширений.

1 стартмани

27.10.2023    2304    19    avmartynov    14    

44

Печать непроведенных документов для УТ, КА, ERP. Настройка печати по пользователям, документам и печатным формам

Пакетная печать Печатные формы Адаптация типовых решений Универсальные функции Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Абонемент ($m)

Расширение для программ 1С:Управление торговлей, 1С:Комплексная автоматизация, 1С:ERP, которое позволяет распечатывать печатные формы для непроведенных документов. Можно настроить, каким пользователям, какие конкретные формы документов разрешено печатать без проведения документа.

2 стартмани

22.08.2023    2505    34    progmaster    8    

4
Оставьте свое сообщение