Групповое присвоение штрих-кодов номенклатуре в Рознице 2.2, 2.3

02.11.20

Учетные задачи - Розничная торговля

Групповое присвоение штрих кодов номенклатуре на основании подбора, документа поступления или остатков на складе

Скачать файл

ВНИМАНИЕ: Файлы из Базы знаний - это исходный код разработки. Это примеры решения задач, шаблоны, заготовки, "строительные материалы" для учетной системы. Файлы ориентированы на специалистов 1С, которые могут разобраться в коде и оптимизировать программу для запуска в базе данных. Гарантии работоспособности нет. Возврата нет. Технической поддержки нет.

Наименование SM По подписке [?] Купить один файл
ГрупповоеПрисвоениеШтрихкодов
.epf 16,90Kb
31
31
1 SM
Скачать Купить за 1 850 руб.
ГрупповоеПрисвоениеШтрихкодов 2
.epf 16,96Kb
55
55
1 SM
Скачать Купить за 1 850 руб.
Групповое присвоение штрих-кодов номенклатуре в Рознице 2.2:
.epf 18,55Kb
66
66
1 SM
Скачать Купить за 1 850 руб.
Групповое присвоение штрих-кодов номенклатуре в Рознице 2.3:
.epf 18,55Kb
54
54
1 SM
Скачать Купить за 1 850 руб.

Внес небольшие изменения в обработку //infostart.ru/public/144785/.

Отличия:

  1. Выбирать номенклатуру не надо, где ввели штрихкод - там он и записался
  2. Ограничений на количество штрихкодов нет.
  3. Убрал в таблице артикул и характеристику номенклатуры.
  4. Работает на Рознице 2.1, 2.2, 2.3

Добавил вторую обработку, для тех кому нужно автоматическое формирование штрих кодов. В ней если Вы не заполнили новый штрих-код, то он генерируется автоматически.

В версии 2.4 добавил функцию проверки существования штрих кода, т.е. если есть - не создаем.

Версия 2.5 проверена на версии Розницы 2.3.6.17

Розница штрих-код

См. также

Бюджетирование и планирование Оптовая торговля Розничная торговля Логистика, склад и ТМЦ Анализ продаж Пользователь Платформа 1С v7.7 Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Управление нашей фирмой 1.6 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Беларусь Украина Россия Казахстан Управленческий учет Платные (руб)

Система управления запасами для 1С помогает работать с запасами правильно: автоматически рассчитывает потребность и делает заказ поставщику, загружает прайсы, перемещает товары по филиалам, анализирует продажи и позволяет управлять ассортиментом.

28500 руб.

21.04.2017    93366    119    40    

210

Оптовая торговля Розничная торговля Обмен с ГосИС Бухгалтер Платформа 1С v8.3 1С:Управление торговлей 10 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Рестораны, кафе и фаст-фуд Россия Бухгалтерский учет Управленческий учет Акцизы Платные (руб)

Полнофункциональное расширение (ранее известное как Модуль 1С-ЕГАИС) для взаимодействия типовых конфигураций 1С и ЕГАИС, предоставляющее максимум возможностей по работе с УТМ. Получение и отправка ТТН, отправка акта о постановке на баланс и акта о списании. Получение остатков. Загрузка и сопоставление номенклатуры и контрагентов. Оправка в ЕГАИС отчетов о производстве и импорте.

8970 руб.

15.12.2015    168482    755    364    

394

ККМ Кассовые операции Розничная торговля Системный администратор Программист Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Бухгалтерия государственного учреждения 1С:Бухгалтерия 1.6 1С:Бухгалтерия автономного учреждения 1С:CRM ПРОФ, КОРП Россия Платные (руб)

Универсальная обработка для обслуживания любых фискальных регистраторов (ККТ), в том числе Веб сервер АТОЛ. Работает в соответствии с 54-ФЗ. (ФФД 1.0, ФФД 1.05, ФФД 1.1). Подключайте любую онлайн кассу к практически любой конфигурации. Нет необходимости обновлять 1С. Можно бесплатно скачать и протестировать. Может работать одновременно с несколькими онлайн-кассами, либо одной с разных рабочих мест. (через RDP, TCP\IP или веб-сервер) Позволяет разделить один чек сразу на несколько ККТ или на несколько систем налогообложения. Поддерживает разрешительный режим. Можно настроить собственный шаблонов чека. Можно использовать эквайринг там, где он не поддерживается. Работает на LINUX и Windows ЭМУЛЯТОР + ЭКВАЙРИНГ + МАРКИРОВКА + ПОДДЕРЖКА ФФД 1.2

6000 руб.

27.02.2017    787035    4739    9507    

2812

Логистика, склад и ТМЦ Бухгалтер Пользователь Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Оптовая торговля, дистрибуция, логистика Управленческий учет Платные (руб)

Программа позволяет организовать учет ответственного хранения товаров с весовыми характеристиками, в том числе со сроком годности и личным кабинетом Поклажедателя. Модуль реализован в виде расширения конфигурации, устанавливается в режиме 1С:Предприятие 8 за 5 минут по инструкции, что позволяет оставить конфигурацию 1С на стандартной поддержке и продолжать получать стандартные обновления от фирмы "1С".

60000 руб.

09.06.2020    36386    32    59    

61

Розничная торговля Маркетплейсы Программист Платформа 1С v8.3 1С:Розница 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Розничная и сетевая торговля (FMCG) Россия Управленческий учет Платные (руб)

Модуль для интеграции 1С с сервисом СберМаркет/Купер. Предназначен для обмена данными из торговых точек розничных сетей из баз данных 1С в базы данных СберМаркет/Купер, для отображения информации по товарам, остаткам, ценам, заказам и статусам заказов. Позволяет оперативно начать работать с сервисом СберМаркет, существенно повысить продажи и лояльность клиентов.

35000 руб.

14.10.2022    8567    15    13    

10

Оптовая торговля Розничная торговля Обмен с ГосИС Программист Бухгалтер Пользователь Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия Бухгалтерский учет Управленческий учет Платные (руб)

Данная публикация создана для помощи разработчикам, интеграторам и другим заинтересованным лицам по настройке системы маркировки обуви, одежды, лекарств, табака, фото, молока, духов(парфюма), питьевой воды, велосипедов и шин. Смело задавайте вопросы по работе с ЦРПТ, GS1, ЭДО, Национальным каталогом, накопили достаточно большую базу знаний по данным темам и готовы ответить на все Ваши вопросы.

5000 руб.

18.03.2019    111704    28    114    

181
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. sebastianp 27.05.16 02:20 Сейчас в теме
А зачем характеристики то убрал? Как быть тем, кто с ними работает?

P.S. Не работает обработка. Кнопка "Сформировать штрихкоды" не функционирует вообще.
user794614; dikd; +2 Ответить
2. MRuslan 7 27.05.16 19:02 Сейчас в теме
Вводим новый штрих-код, жмем сформировать новые штрих-коды. Profit. Если нет, пишите версию, проверим)
3. sebastianp 30.05.16 15:09 Сейчас в теме
(2) т.е. ваша обработка не заполняет недостающие штрихкоды, как это делала обработка-оригинал, а просто выводит список товаров по отбору и предлагает заполнять для них штрихкоды вручную (брать из головы)?
4. MRuslan 7 30.05.16 18:20 Сейчас в теме
Да. Необходимости в генерации штрих кода не было.
5. unoboss 05.08.16 17:02 Сейчас в теме
Точно автоматическое заполнение штрих кодов отсутствует или не работает. ВЕРНИТЕ ДЕНЬГИ,
6. unoboss 05.08.16 17:03 Сейчас в теме
Не работает Платформа 8.3.8.1964
Розница 2.2.4.17
7. Валентин89 12.02.17 08:51 Сейчас в теме
Спасибо! Очень помогла обработка!
8. nextdoor 6 17.04.17 12:48 Сейчас в теме
Спасибо, пригодилось. Странно, что убрали возможность массово присвоить ШК в 1с через обработку печати этикеток.
9. user818648 27.08.17 01:15 Сейчас в теме
Установил расширение в администрировании (печатные формы и обработки) где дальше запустить расширение?
Спасибо.
10. MRuslan 7 27.08.17 06:50 Сейчас в теме
(9) Там же открывайте или через файл-открыть.
11. dikd 17 28.12.17 10:51 Сейчас в теме
В разрезе характеристик формирует?
12. MRuslan 7 28.12.17 14:27 Сейчас в теме
нет, см исходник: infostart.ru/public/144785/
13. kent2007 31.01.18 21:01 Сейчас в теме
14. MRuslan 7 01.02.18 00:16 Сейчас в теме
до конца недели исправлю
15. MRuslan 7 06.02.18 09:38 Сейчас в теме
проверил на версии 2.2.7.32 - все работает.
16. Д_К 14.10.20 12:56 Сейчас в теме
Добрый день на Розница 2.3 планируется доработка?
17. altaro 13 19.10.20 14:30 Сейчас в теме
(16)Там нетрудно поправить. Метод СформироватьШтрихкод переехал в другой модуль. Перепишите путь и вызывайте его &НаСервере
18. altaro 13 19.10.20 14:33 Сейчас в теме
С позволения автора


  
			
			НовыйШтрихкод = ПодключаемоеОборудованиеРТ.СформироватьШтрихкод();
			СтрокаТовар.НовыйШтрихкод = НовыйШтрихкод;	

  
19. dk-ros 01.11.20 17:46 Сейчас в теме
Не могу поправить, готов оплатить доработку
20. dk-ros 01.11.20 17:46 Сейчас в теме
Розница, редакция 2.3 (2.3.5.35)
21. user911872 26.11.20 10:50 Сейчас в теме
Доброго дня. Изменил путь. Всё равно ошибка. Теперь переменная не определена. Что не так .

&НаКлиенте
Процедура Сформироватьновыйштрихкод(Команда)
	
	Ответ = Вопрос("Будет произведена запись новых штрихкодов. Этот процесс может занять некоторое время. Вы уверены?", РежимДиалогаВопрос.ДаНет, 60);
	Если Ответ <> КодВозвратаДиалога.Да Тогда
		Возврат;
	КонецЕсли;  
		
	Для каждого СтрокаТовар Из Объект.Товары Цикл
		
		Если СтрокаТовар.СтарыйШтрихкод = "" И СтрокаТовар.НовыйШтрихкод = "" И СтрокаТовар.Обрабатывать Тогда
			
			НовыйШтрихкод = ПодключаемоеОборудованиеРТ.Сформироватьновыйштрихкод();
			СтрокаТовар.НовыйШтрихкод = НовыйШтрихкод;	
			
			//Записываем в регистр
			ПроизвестиЗаписьВРегистрШтрихкоды(СтрокаТовар.Номенклатура, СтрокаТовар.Характеристика, НовыйШтрихкод);
		КонецЕсли; 
		
	КонецЦикла; 
	
КонецПроцедуры

&НаСервереБезКонтекста
Процедура ПроизвестиЗаписьВРегистрШтрихкоды(Владелец, Характеристика, НовыйШтрихкод)
	
	НоваяЗапись = РегистрыСведений.Штрихкоды.СоздатьМенеджерЗаписи();
	НоваяЗапись.Владелец = Владелец;
	НоваяЗапись.Характеристика = Характеристика;
	
	//Пытаемся прочитать запись
	НоваяЗапись.Прочитать();
	//Если записи нет
	Если Не НоваяЗапись.Выбран() Тогда
		НоваяЗапись.Владелец = Владелец;
		НоваяЗапись.Штрихкод = НовыйШтрихкод;
		НоваяЗапись.Характеристика = Характеристика;
		НоваяЗапись.ТипШтрихкода = ПредопределенноеЗначение("ПланВидовХарактеристик.ТипыШтрихкодов.EAN13");
		НоваяЗапись.ПредставлениеШтрихкода = "";
		НоваяЗапись.Записать(Истина);	
	КонецЕсли;
		
КонецПроцедуры
Показать
22. MRuslan 7 26.11.20 14:15 Сейчас в теме
23. user911872 26.11.20 14:44 Сейчас в теме
(22)Розница (базовая), редакция 2.3 (2.3.6.17)
24. MRuslan 7 26.11.20 18:34 Сейчас в теме
(23)
Групповое присвоение штрих-кодов номенклатуре в Рознице 2.3.epf, версия 2.5
Проверена на этой версии Розницы , все работает.
26. proha1985 07.01.21 10:33 Сейчас в теме
(24)вы не могли бы мне помочь?
25. пользователь 06.12.20 18:19
Сообщение было скрыто модератором.
...
27. botvans2 21.01.21 18:54 Сейчас в теме
Здравствуйте, обработка создаёт штрихкоды для номенклатуры с характеристиками ? под каждую характеристику свой штрих код.?
28. MRuslan 7 22.01.21 04:31 Сейчас в теме
Характеристики отключены, делал на основании этой https://infostart.ru/public/144785/. В ней есть характеристики.
29. kent2007 19.10.21 11:34 Сейчас в теме
метод объекта не обнаружен (сформироватьштрихкод), как исправить под Розницу 2.3
30. MRuslan 7 19.10.21 17:32 Сейчас в теме
Скачать Групповое присвоение штрих-кодов номенклатуре в Рознице 2.3
Если и там ошибка, написать версию Розницы поточнее.
31. TundaNC 481 21.05.23 17:05 Сейчас в теме
Имеются ошибки типа:
Ошибка при вызове метода контекста (Вопрос)
{ВнешняяОбработка.ГрупповоеПрисвоениеШтрихкодов.Форма.Форма.Форма(193)}:Ответ = Вопрос("Табличная часть будет очищена. Продолжить?", РежимДиалогаВопрос.ДаНет, 60);

по причине:
Использование модальных окон в данном режиме запрещено!
32. MRuslan 7 22.05.23 06:04 Сейчас в теме
33. TundaNC 481 22.05.23 12:24 Сейчас в теме
Оставьте свое сообщение