Механизм доп. реквизитов и сведений

23.06.16

Задачи пользователя - Адаптация типовых решений

Как к новому справочнику подключить механизм дополнительных реквизитов и сведений

Скачать исходный код

Наименование Файл Версия Размер
НастрокаНабораДополнительныхРеквизитовИСведений
.epf 6,52Kb
52
.epf 1.0 6,52Kb 52 Скачать

Это совсем не сложно но в первый раз может отнять пару часов времени

Я буду показывать на примере Бухгалтерии версии (3.0.43.152) 

Есть у меня новый справочник "я_ПодразделенияОрганизаций" вот в него и будем добавлять

1.  К новому справочнику нам необходимо добавить табличную часть для хранения доп. 

реквизитов. Идем в номенклатуру - Копировать - Вставить

 

2. Далее в справочнике НаборыДополнительныхРеквизитовИСведений добавляем 
предопределенный элемент Справочник_я_ПодразделенияОрганизаций

3. Включаем тип этого справочника в состав ПВХ ДополнительныеРеквизитыИСведения

4. Заполняем Характеристики в справочнике я_ПодразделенияОрганизаций

5. Идем в Общие - Определяемые типы - ВладелецДополнительныхСведений и ставим там галочку

6. В форму элемента нашего справочника переносим стандартный код и создаем группу "ГруппаДополнительныеРеквизиты"

 

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	
	// Обработчик подсистемы "Свойства"
	ДополнительныеПараметры = Новый Структура;
	ДополнительныеПараметры.Вставить("Объект", Объект);
	ДополнительныеПараметры.Вставить("ИмяЭлементаДляРазмещения", "ГруппаДополнительныеРеквизиты");
	УправлениеСвойствами.ПриСозданииНаСервере(ЭтаФорма, ДополнительныеПараметры);
	
КонецПроцедуры

&НаСервере
Процедура ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
	
	// Обработчик подсистемы "Свойства"
	УправлениеСвойствами.ПередЗаписьюНаСервере(ЭтаФорма, ТекущийОбъект);
КонецПроцедуры

&НаКлиенте
Процедура ПриОткрытии(Отказ)
	
	// СтандартныеПодсистемы.Свойства
	УправлениеСвойствамиКлиент.ПослеЗагрузкиДополнительныхРеквизитов(ЭтотОбъект);
	// Конец СтандартныеПодсистемы.Свойства
КонецПроцедуры

&НаКлиенте
Процедура ОбработкаОповещения(ИмяСобытия, Параметр, Источник)
	
	// Подсистема "Свойства"
	Если УправлениеСвойствамиКлиент.ОбрабатыватьОповещения(ЭтаФорма, ИмяСобытия, Параметр) Тогда
		ОбновитьЭлементыДополнительныхРеквизитов();
		УправлениеСвойствамиКлиент.ПослеЗагрузкиДополнительныхРеквизитов(ЭтотОбъект);
	КонецЕсли;
КонецПроцедуры

&НаСервере
Процедура ОбработкаПроверкиЗаполненияНаСервере(Отказ, ПроверяемыеРеквизиты)
	
	// СтандартныеПодсистемы.Свойства
	УправлениеСвойствами.ОбработкаПроверкиЗаполнения(ЭтаФорма, Отказ, ПроверяемыеРеквизиты);
	// Конец СтандартныеПодсистемы.Свойства
	
КонецПроцедуры

// СтандартныеПодсистемы.Свойства

&НаКлиенте
Процедура ОбновитьЗависимостиДополнительныхРеквизитов()
	УправлениеСвойствамиКлиент.ОбновитьЗависимостиДополнительныхРеквизитов(ЭтотОбъект);
КонецПроцедуры

&НаКлиенте
Процедура Подключаемый_ПриИзмененииДополнительногоРеквизита(Элемент)
	УправлениеСвойствамиКлиент.ОбновитьЗависимостиДополнительныхРеквизитов(ЭтотОбъект);
КонецПроцедуры

// Конец СтандартныеПодсистемы.Свойства&НаСервере

Процедура ОбновитьЭлементыДополнительныхРеквизитов()
	
	УправлениеСвойствами.ОбновитьЭлементыДополнительныхРеквизитов(ЭтаФорма, РеквизитФормыВЗначение("Объект"));
КонецПроцедуры

&НаСервере
Процедура ПриЧтенииНаСервере(ТекущийОбъект)
	
	// СтандартныеПодсистемы.Свойства
	УправлениеСвойствами.ПриЧтенииНаСервере(ЭтаФорма, ТекущийОбъект);
	// Конец СтандартныеПодсистемы.Свойства
КонецПроцедуры

7. Сохраняем обновляем конфу и запускаем 1С 

8. Ну и последнее. Нам необходимо выполнить обновление идентификаторов метаданных

и выставить значение реквизита Используется = истина для созданного нами предопределенного элемента.

Хотя в настройках конфы у меня стоит что значение заполнения = истина в предопределяемом так не вышло. Пришлось накидать обработку для этого дела, ну и заодно добавил туда обновление идентификаторов метаданных

доп реквизит НаборыДополнительныхРеквизитовИСведений

См. также

Табличная часть в доп. реквизитах и формирование таблиц в шаблоне docx для 1С:ДО 3.0

Адаптация типовых решений Платформа 1С v8.3 1С:Документооборот Россия Платные (руб)

Расширение конфигурации для «1С:Документооборот КОРП», редакция 3.0. позволяет: 1.использовать произвольные табличные части в качестве дополнительных реквизитов к документу; 2 использовать произвольные табличные части в шаблонах в формате docx для автоматического заполнения таблиц.

29400 руб.

29.06.2023    4858    10    5    

19

Расширение для 1С:УНФ. Автоматическое снятие резервов в Заказах покупателей

Логистика, склад и ТМЦ Адаптация типовых решений Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Управление нашей фирмой 3.0 Россия Управленческий учет Платные (руб)

Чтобы не допустить путаницы с обещаниями клиентам и для четкого контроля исполнения заказов мы используем резервирование товаров. Мы доработали УНФ, чтобы она автоматически отменяла старые резервы и не мешала эффективно продавать.

7200 руб.

02.08.2023    3233    5    0    

22

Каждому менеджеру нужен свой Excel

Адаптация типовых решений Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Абонемент ($m)

Каждый из нас сталкивается с ситуацией, когда какой-нибудь менеджер показывает свой Excel и рассказывает, как он что-то из 1С копирует в него, снабжает пояснениями, выделяет цветом и т.д. и т.п. Заканчивается все просьбой сделать вот чтобы также было в 1С. И оказывается такой человек (почти с гарантией) либо лучшим продажником, либо каким-то важным, за все отвечающим, - на ком все держится.

2 стартмани

22.04.2024    4319    dimanich70    15    

18

Создать на основании - своя кнопка (БСП). Проблема двух подменю Создать на основании

БСП (Библиотека стандартных подсистем) Адаптация типовых решений Платформа 1С v8.3 1С:ERP Управление предприятием 2 Бесплатно (free)

Понадобилось в подменю "Создать на основании" добавить свою команду, которая открывает обработку. В процессе доработок появилась проблема двух подменю "Создать на основании". В статье о том, как решились проблемы.

01.03.2024    2363    dimanich70    8    

14

Доработка отчета "Связанные документы" (структура подчиненности) для вывода объектов из любого расширения

Адаптация типовых решений Платформа 1С v8.3 1С:Управление торговлей 11 Россия Абонемент ($m)

Доработка типового отчета "Связанные документы" позволяет просто и быстро расширять состав объектов для построения структуры подчиненности документов, используя объекты основной конфигурации и любых расширений.

1 стартмани

27.10.2023    2269    19    avmartynov    14    

44

Печать непроведенных документов для УТ, КА, ERP. Настройка печати по пользователям, документам и печатным формам

Пакетная печать Печатные формы Адаптация типовых решений Универсальные функции Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Абонемент ($m)

Расширение для программ 1С:Управление торговлей, 1С:Комплексная автоматизация, 1С:ERP, которое позволяет распечатывать печатные формы для непроведенных документов. Можно настроить, каким пользователям, какие конкретные формы документов разрешено печатать без проведения документа.

2 стартмани

22.08.2023    2474    33    progmaster    8    

4
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. nixel 1415 23.06.16 01:21 Сейчас в теме
Не надоело итс перепечатывать?
Не говоря уже о том, что пару версий БСП вперед или назад и алгоритм может быть уже другой?
furman2000; Yashazz; +2 1 Ответить
2. jaroslav.h 180 23.06.16 11:50 Сейчас в теме
(1) nixel, нехай передруковує, не всі ж мають доступ до ІТС, в мене немає доступу і мені дуже цікаво!
3. Yashazz 4735 23.06.16 19:35 Сейчас в теме
Одно из двух - или это беспардонный копипаст без указания источника, что, насколько помню, нарушение законодательства, насчёт перепечатки материалов с ИТС, или это самостоятельное и героическое изобретение велосипеда.
4. eskor 98 30.06.16 12:03 Сейчас в теме
(3) Yashazz, да не похоже на перепечатку, просто человек почитав ИТС понял, что не всем дано вникнуть в глубинных смысл тамошних статей, поэтому и написал пошаговую инструкцию: что, где, когда.
В конце концов, на сайте множество новичков, для них такие статьи благо. Однозначно пусть будет!
Valerianich; 1c_uZer; Wilka; georgebgk; Olenevod; Areal; user1011815; VerunchikNe; trio-tlt; tsmult; kuril; user1081367; SmArtist; Winstoncuk; +14 Ответить
5. proonec 30.06.16 13:15 Сейчас в теме
Спрос на ИТС в формате "для народа" есть!
Инфостарт и сам себя позиционирует в том числе для домохозяек бухгалтеров, плюс все молодые бойцы из франчей на инфостарте сидят - набираются опыта, кто-то с ноля.

Но и проблема есть!
Инфостарт по контенту сделали реально крутые в 1С и не только ребята. А сейчас их труд размывается и замывается не таким эксклюзивным материалом. В общей массе уровень падает - плата за популярность.

Интересно когда старожилы будут вытеснены армией новых неофитов 1С, куда они уйдут?

Ну в общем я про то, что, по-моему мнению, Инфостарту пора начинать разводить контент по уровню сложности. Просто деления на роли пользователей (бухгалтер, директор, менеджер, программист) не хватает - программист программисту рознь!

PS. Прости автор за оффтоп и спасибо за повод.
Winstoncuk; igo1; +2 Ответить
6. director04 3657 01.07.16 16:00 Сейчас в теме
У меня к автору один вопрос: а нахрена прикручивать механизм доп. реквизитов к созданному тобой же справочнику?
Механизм доп. реквизитов подразумевает возможность добавления дополнительных разрезов аналитики, без изменения типовой конфигурации.
Вы уже добавили свой справочник. Почему бы вам не добавить в него необходимые вам реквизиты, и без лишнего гемороя?

И второе: в представленном вами примере, вы карежите типовую конфигурацию (Бухгалтерия предприятия). Ну и огребете же вы говна при очередных обновлениях своей базы.
Мое мнение - вся ваша работа - это детский сад - желание поупражняться типа "а получится ли это у меня".
А вот подумать, как потом все это обслуживать при обновлениях - на это уже соображения не хватило.

Прошу прощения за нравоучение.
Drivingblind; Daemon73; pm74; teflon; +4 Ответить
8. MenZurKa 26.04.17 10:54 Сейчас в теме
(6) Это иногда требуется, когда необходимо включить не типовой объект в уже работающую схему с использованием доп. реквизитов, без внесения изменений в типовой механизм типовых объектов.

Прошу прощения за масло-масляное.
7. rozer 309 02.07.16 21:30 Сейчас в теме
Вроде тут в разделе видео от компании neti про бсп много различных видео...
9. robix 09.01.18 21:16 Сейчас в теме
Что имеется ввиду под "выставить значение реквизита Используется = истина для созданного нами предопределенного элемента." ? Это как ?
10. vis_tmp 32 23.06.18 23:54 Сейчас в теме
(9)Это реквизит справочника "НаборыДополнительныхРеквизитовИСведений"
11. robix 25.06.18 10:15 Сейчас в теме
12. shinline922 04.01.19 08:30 Сейчас в теме
Жесть, вот это Вы набросились, статья явно не с ИТС иначе бы пункт:

2. Далее в справочнике НаборыДополнительныхРеквизитовИСведений добавляем
предопределенный элемент Справочник_я_ПодразделенияОрганизаций

Был бы таким

3. В общем модуле УправлениеСвойствамиПереопределяемый в процедуре ПриПолученииПредопределенныхНаборовСвойств вставить строки
Строка = Наборы.Строки.Добавить();
	 Строка.Имя = "Task";
	 Строка.Идентификатор = "Документ_Task";
	 Строка.Используется = Истина;
	 Строка.ЭтоГруппа = Ложь;


Автору спасибо весьма познавательно для новичков!!!
13. Neco 133 09.09.19 12:26 Сейчас в теме
Ссылка на раздел ИТС в котором описаны приведенные в статье настройки https://its.1c.ru/db/bsp244doc#content:67:1
14. Neco 133 09.09.19 12:28 Сейчас в теме
В список функций для вставки желательно добавить команду открытия настройки доп.реквизитов:
&НаКлиенте
Процедура Подключаемый_СвойстваВыполнитьКоманду(ЭлементИлиКоманда, НавигационнаяСсылка = Неопределено, СтандартнаяОбработка = Неопределено)
    УправлениеСвойствамиКлиент.ВыполнитьКоманду(ЭтотОбъект, ЭлементИлиКоманда, СтандартнаяОбработка);
КонецПроцедуры
OlgaGSer; +1 Ответить
21. OlgaGSer 21.04.22 13:37 Сейчас в теме
(14) Это очень важное замечание, т.к. без добавления этой процедуры в модуль формы при нажатии на появившуюся кнопку контекстного меню "Изменить состав дополнительных реквизитов" ничего не происходит, не открывается форма для редактирования/добавления доп.реквизитов.
15. ducks01 31.12.19 12:08 Сейчас в теме
от души спасибо за мануальчик, особенно за последний абзац!
16. tireal 74 12.06.20 10:35 Сейчас в теме
я наверное из тех "кто читал текст ИТС и не разобрался". Набрел на статью когда ни хрена не получалось сделать все по инструкции. Ну а как бы получилось если в мануале к БСП 3 + (на кой и написана БП 3) как раз написано в процедуре "ПриПолученииПредопределенныхНаборовСвойств" опишите предопределенный набор свойств... а где пункт где его нужно создать? Или пояснения что херячить в Идентификатор? В общем ничего не вижу плохого в таких статьях где будет описан лаконично рабочий алгоритм добавления того или иного сервиса БСП. Автору спасибо.
vakham; trio-tlt; +2 Ответить
17. kolodina240751 17.11.20 14:02 Сейчас в теме
мне статья понравилась. прочитала то, чего нет на ИТС. про характеристики, которые надо добавить к новому объекту, чтобы иметь возможность добавлять сведения. об этом на ИТС на видела.
18. drevilo 5 04.12.20 13:23 Сейчас в теме
Автор молодец, четко и по существу (даже про обработку написал :) ) !
19. popkovsf65 114 15.07.21 10:33 Сейчас в теме
Спасибо большое. Второй день бьюсь с такой же проблемой.
20. Vancy43 87 11.02.22 12:09 Сейчас в теме
Спасибо автору за такой подробное описание с картинками. Очень удобно.
22. OlgaGSer 21.04.22 13:40 Сейчас в теме
Отличная статья! Всё очень понятно расписано, большое спасибо автору! Процедуру по комментарию (14) тоже нужно включить, т. к. без неё не открывается форма для редактирования/добавления доп.реквизитов.
23. qux 25 20.05.24 11:34 Сейчас в теме
Сначала сделал по статье автора, затем сделал по тексту в ИТС. Не появляется на форме отображение доп. реквизитов( Забыл про реквизит Использовать) Все норм заработало)
Оставьте свое сообщение