Импорт справочников из Инфо-Предприятие 1.91 в БП2.0/ЗУП2.5 (из файлов *.db или *.xls/*.xlsx)

05.12.16

Интеграция - Файловый обмен (TXT, XML, DBF), FTP

Обработка для импорта справочников Контрагенты, Номенклатура, ОсновныеСредства и ФизическиеЛица из DB-файлов Инфо-Предприятие 1.91 или из DB-файлов, сохранённых как файлы MS Excel (XLS/XLSX-файлы).

Скачать исходный код

Наименование Файл Версия Размер
ZagruzkaIzInfoPredpriyatie.epf.7z
.7z 12,90Kb
11
.7z 0.1 12,90Kb 11 Скачать

Проверялось на: Бухгалтерия Предприятия 2.0.65.3, Зарплата и Управление Персоналом 2.5.98.1.

В рамках проекта по переводу клиента с Инфо-Предприятие 1.91 на 1С:БП2.0+1С:ЗУП2.5 возникла задача по автоматическому переносу основных справочников. Готовое решение не нашёл, поэтому написал данную обработку.

Обработка умеет загружать справочники Контрагенты, Номенклатура, ОсновныеСредства и ФизическиеЛица как из DB-файлов Инфо-Предприятие (СУБД Paradox), так и из DB-файлов, сохранённых в формате MS Excel (XLS/XLSX-файлов).

Чтение DB-файлов работает на порядок быстрее, чем XLS/XLSX, но у меня оно отработало не на всех компьютерах, на которых пробовал запускать обработку. Не знаю точно, действительно ли это оказало влияние, но на тех компьютерах, на которых чтение DB-файлов отработало, был установлен BDE.

Теперь немного про код самой обработки.

Была написана пара универсальных функций для чтения данных: 1) из DB-файла (через ADO) и 2) из файла Excel. Обе функции в качестве параметра получают полное имя файла и возвращают таблицу значений, которая содержит все данные, прочитанные из этого DB-/XLS(X)-файла. Имена колонок возвращаемой таблицы значений совпадают с именами колонок DB-файла. В случае чтения из файла MS Excel, имена колонок берутся из первой строки таблицы.

Функция чтения из DB-файла в таблицу значений:

Функция ПолучитьТаблицуИзФайлаПарадокс(ИмяФайла)
	
	ТЗ = Новый ТаблицаЗначений;
	
	Файл = Новый Файл(ИмяФайла);
	
	СтрокаПодключения = "Driver={Microsoft Paradox Driver (*.db )};DefaultDir=" + Файл.Путь + ";CollatingSequence=ASCII";
	
	ПодключениеАДОДБ = Новый COMОбъект("ADODB.Connection");
	ПодключениеАДОДБ.Open(СтрокаПодключения);
	
	ТекстЗапроса = "SELECT * FROM " + Файл.ИмяБезРасширения;
	ВыборкаАДОДБ = ПодключениеАДОДБ.Execute(ТекстЗапроса);
	
	ВыборкаАДОДБ.MoveFirst();
	
	КолвоКолонок = ВыборкаАДОДБ.Fields.Count;
	
	Если КолвоКолонок = 0 Тогда
		ВызватьИсключение "Ошибка чтения файла " + ИмяФайла + ": таблица не содержит колонок!";
	КонецЕсли; 
	
	СоответствиеКолонок = Новый Соответствие; 
	Для НомКол = 0 По КолвоКолонок - 1 Цикл
		ИмяКолонки = ВыборкаАДОДБ.Fields(НомКол).Name;
		ТЗ.Колонки.Добавить(ИмяКолонки);
		СоответствиеКолонок.Вставить(НомКол, ИмяКолонки);
	КонецЦикла; 

	Пока НЕ ВыборкаАДОДБ.EOF Цикл
		НоваяСтрока = ТЗ.Добавить(); 
		Для НомКол = 0 По КолвоКолонок - 1 Цикл
			НоваяСтрока[СоответствиеКолонок.Получить(НомКол)] = ВыборкаАДОДБ.Fields(НомКол).Value;
		КонецЦикла;
		ВыборкаАДОДБ.MoveNext();
	КонецЦикла; 
	
	Возврат ТЗ; 
	
КонецФункции

Функция чтения из XLS/XLSX-файла в таблицу значений:

Функция ПолучитьТаблицуИзФайлаЕксель(ИмяФайла)
	
	ТЗ = Новый ТаблицаЗначений;
	
	Ексель = Новый COMОбъект("Excel.Application");
	КнигаЕксель = Ексель.Workbooks.Open(ИмяФайла, Ложь, Истина);
	ЛистЕксель = КнигаЕксель.Worksheets(1);
	
	// читаем первую строку с заголовками столбцов
	НомКол = 1;
	СоответствиеКолонок = Новый Соответствие; 
	Пока Истина Цикл
		ТекЗнач = СокрЛП(ЛистЕксель.Cells(1, НомКол).Value);
		Если ПустаяСтрока(ТекЗнач) Тогда
			Прервать;
		КонецЕсли;
		ТЗ.Колонки.Добавить(ТекЗнач);
		СоответствиеКолонок.Вставить(НомКол, ТекЗнач);
		НомКол = НомКол + 1; 
	КонецЦикла;
	
	КолвоКолонок = ТЗ.Колонки.Количество();
	
	Если КолвоКолонок = 0 Тогда
		ВызватьИсключение "Ошибка чтения таблицы Excel " + ИмяФайла + ": в первой строке не найдены заголовки столбцов!";
	КонецЕсли; 
	
	НомСтр = 2;
	Пока Истина Цикл
		ЕстьДанные = Ложь;
		СтруктураДанных = Новый Структура;
		Для НомКол = 1 По КолвоКолонок Цикл
			ИмяКолонки = СоответствиеКолонок.Получить(НомКол);
			ТекЗнач = ЛистЕксель.Cells(НомСтр, НомКол).Value;
			Если НЕ ПустаяСтрока(ТекЗнач) Тогда
				ЕстьДанные = Истина;
			КонецЕсли; 
			СтруктураДанных.Вставить(ИмяКолонки, ТекЗнач);
		КонецЦикла;
		Если НЕ ЕстьДанные Тогда
			Прервать;
		КонецЕсли; 
		НоваяСтрока = ТЗ.Добавить();
		ЗаполнитьЗначенияСвойств(НоваяСтрока, СтруктураДанных);
		НомСтр = НомСтр + 1; 
	КонецЦикла; 
	
	Возврат ТЗ; 
	
КонецФункции

Для унификации вызвова функции чтения данных используется функция ПолучитьТаблицуИзФайла(), которая в зависимости от расширения файла вызывает одну из вышеприведённых функций:

Функция ПолучитьТаблицуИзФайла(ИмяФайла)
	
	Попытка
		Файл = Новый Файл(ИмяФайла);
		Если Лев(ВРег(Файл.Расширение), 4) = ".XLS" Тогда
			Возврат ПолучитьТаблицуИзФайлаЕксель(ИмяФайла);
		ИначеЕсли ВРег(Файл.Расширение) = ".DB" Тогда
			Возврат ПолучитьТаблицуИзФайлаПарадокс(ИмяФайла);
		Иначе 
			Сообщить("ПолучитьТаблицуИзФайла(): загрузка из файла " + ИмяФайла 
				+ " невозможна! Неизвестный тип файла: " + Файл.Расширение + "!", СтатусСообщения.Важное);
		КонецЕсли;
	Исключение
	    Сообщить("Ошибка загрузки данных из файла " + ИмяФайла + ": " + ОписаниеОшибки(), СтатусСообщения.Внимание);
	КонецПопытки; 
	
	Возврат Неопределено;
	
КонецФункции

Далее на основе прочитанных данных создаются необходимые элементы справочников и заполняются данные в регистрах сведений.

Для примера рассмотрим загрузку справочника ФизическиеЛица. При нажатии соответствующей кнопки "Загрузить" (см.скриншот) вызывается процедура-обработчик КнопкаЗагрузитьСотрудникиНажатие():

Процедура КнопкаЗагрузитьСотрудникиНажатие(Элемент)

	ИмяФайла = ИмяФайлаСотрудники;
	НазваниеФайла = "Сотрудники";
	
	Если НЕ ПроверитьИмяФайла(ИмяФайла, НазваниеФайла) Тогда
		Возврат;
	КонецЕсли; 
	
	Сообщить("Начало загрузки: " + ТекущаяДата());
	
	Состояние("Чтение данных из файла...");
	ТаблицаДанных = ПолучитьТаблицуИзФайла(ИмяФайла);
	
	Колво = 0;
	КолвоВсего = ТаблицаДанных.Количество();
	
	Для Каждого СтрокаТаблицы Из ТаблицаДанных Цикл
		ОбработкаПрерыванияПользователя();
		Колво = Колво + 1; 
		ПроцентЗагружено = Цел(Колво / КолвоВсего * 100);
		Состояние("[" + Строка(ПроцентЗагружено) + "%] " + СтрокаТаблицы.famSotr);
		ЗагрузитьФизЛицо(СтрокаТаблицы, ФлагПерезаписыватьСуществующие);
	КонецЦикла; 
	
	Сообщить("Окончание загрузки: " + ТекущаяДата());
	
КонецПроцедуры

В этой процедуре вызывается ранее рассмотренная функция ПолучитьТаблицуИзФайла(ИмяФайла), которая возвращает таблицу значений с данными для загрузки, а затем в цикле по строкам полученной таблицы значений вызывается процедура ЗагрузитьФизЛицо(), которая непосредственно осуществляет создание элемента справочника ФизическиеЛица и сопутствующих ему записей в регистрах сведений (эта процедура работает как в БП2.0, так и в ЗУП2.5):

Процедура ЗагрузитьФизЛицо(Данные, Перезаписывать) Экспорт 
	
	Комментарий = СформироватьКомментарий(Данные, "ID");
	
	Запрос = Новый Запрос;
	Запрос.Текст = 
	"ВЫБРАТЬ
	|	ФизическиеЛица.Ссылка
	|ИЗ
	|	Справочник.ФизическиеЛица КАК ФизическиеЛица
	|ГДЕ
	|	ФизическиеЛица.Комментарий ПОДОБНО &Комментарий";
	Запрос.УстановитьПараметр("Комментарий", Комментарий);
	РезультатЗапроса = Запрос.Выполнить();
	
	ТекОбъект = Неопределено;
	
	Если НЕ РезультатЗапроса.Пустой() Тогда
		Если НЕ Перезаписывать Тогда
			Возврат;
		КонецЕсли;
		Выборка = РезультатЗапроса.Выбрать();
		Выборка.Следующий();
		ТекОбъект = Выборка.Ссылка.ПолучитьОбъект();
	Иначе 
		ТекОбъект = Справочники.ФизическиеЛица.СоздатьЭлемент();
	КонецЕсли; 
	
	ТекОбъект.Комментарий = Комментарий;
	
	ФамилияФЛ = СПрописной(СокрЛП(Данные.famSotr));
	ИмяФЛ = СПрописной(СокрЛП(Данные.imyaSotr));
	ОтчествоФЛ = СПрописной(СокрЛП(Данные.otchSotr));
	
	ФИО = ФамилияФЛ
		+ ?(ПустаяСтрока(ИмяФЛ), "", " " + ИмяФЛ)
		+ ?(ПустаяСтрока(ОтчествоФЛ), "", " " + ОтчествоФЛ);
	
	ТекОбъект.Наименование = ФИО;
	ТекОбъект.ДатаРождения = ПолучитьДатуИзДанных(Данные.dataR22);
	
	// 1с: МестоРожденияСтрокойПослеРедактирования = ""+СокрЛП(Особое)+","+СокрЛП(Город)+","+СокрЛП(Район)+","+СокрЛП(Область)+","+СокрЛП(Страна);
	ТекОбъект.МестоРождения = "0," + СокрЛП(Данные.gorodJ2) + "," + СокрЛП(Данные.raiionJ2) + "," + СокрЛП(Данные.nazvRegJ2);
		
	ТекОбъект.ИНН = СокрЛП(Данные.innSotr2);
	ТекОбъект.КодИМНС = СокрЛП(Данные.kodGNISotr);
	ТекОбъект.СтраховойНомерПФР = СокрЛП(Данные.regNomerPF);
	КодПола = Лев(ВРег(СокрЛП(Данные.pol)), 1);
	Если КодПола = "Ж" Тогда
		ТекОбъект.Пол = Перечисления.ПолФизическихЛиц.Женский;
	ИначеЕсли КодПола = "М" Тогда
		ТекОбъект.Пол = Перечисления.ПолФизическихЛиц.Мужской;
	Иначе 
		// оно?
		ТекОбъект.Пол = Перечисления.ПолФизическихЛиц.ПустаяСсылка();
	КонецЕсли; 
	
	ТекОбъект.Записать();
	ФизЛицоСсылка = ТекОбъект.Ссылка;
	
	// ФИО физ.лиц
	ПериодЗаписи = ТекОбъект.ДатаРождения;
	НЗ = РегистрыСведений.ФИОФизЛиц.СоздатьНаборЗаписей();
	НЗ.Отбор.ФизЛицо.Установить(ФизЛицоСсылка);
	НЗ.Отбор.Период.Установить(ПериодЗаписи);
	Запись = НЗ.Добавить();
	Запись.ФизЛицо = ФизЛицоСсылка;
	Запись.Период = ПериодЗаписи;
	Запись.Фамилия = ФамилияФЛ;
	Запись.Имя = ИмяФЛ;
	Запись.Отчество = ОтчествоФЛ;
	НЗ.Записать();
	
	// паспортные данные
	ДатаВыдачи = ПолучитьДатуИзДанных(Данные.data_vyidachi);
	ПериодЗаписи = ?(ЗначениеЗаполнено(ДатаВыдачи), ДатаВыдачи, ТекОбъект.ДатаРождения);
	НЗ = РегистрыСведений.ПаспортныеДанныеФизЛиц.СоздатьНаборЗаписей();
	НЗ.Отбор.ФизЛицо.Установить(ФизЛицоСсылка);
	НЗ.Отбор.Период.Установить(ПериодЗаписи);
	Запись = НЗ.Добавить();
	Запись.ФизЛицо = ФизЛицоСсылка;
	Запись.Период = ПериодЗаписи;
	Если ЗначениеЗаполнено(Данные.kodDokumenta) Тогда
		Запись.ДокументВид = Справочники.ДокументыУдостоверяющиеЛичность.НайтиПоРеквизиту("КодИМНС", СокрЛП(Данные.kodDokumenta));
	КонецЕсли; 
	Запись.ДокументНомер = СокрЛП(Данные.seriya);
	Запись.ДокументДатаВыдачи = ДатаВыдачи;
	Запись.ДокументКемВыдан = СокрЛП(Данные.pasportnyie_dannyie);
	НЗ.Записать();
	
	// контактная информация
	СтруктураАдреса = Новый Структура; 
	СтруктураАдреса.Вставить("Индекс"			, СокрЛП(Данные.indeks));
	СтруктураАдреса.Вставить("Регион"			, СокрЛП(Данные.nazvReg));
	СтруктураАдреса.Вставить("Район"			, СокрЛП(Данные.raiion));	
	СтруктураАдреса.Вставить("Город"			, СокрЛП(Данные.gorod));
	СтруктураАдреса.Вставить("НаселенныйПункт"	, СокрЛП(Данные.nasPunkt));
	СтруктураАдреса.Вставить("Улица"			, СокрЛП(Данные.ulica));
	СтруктураАдреса.Вставить("Дом"				, СокрЛП(Данные.dom2));
	СтруктураАдреса.Вставить("Корпус"			, СокрЛП(Данные.korpus));
	СтруктураАдреса.Вставить("Квартира"			, СокрЛП(Данные.kvartira22));
	МЗ = РегистрыСведений.КонтактнаяИнформация.СоздатьМенеджерЗаписи();
	УправлениеКонтактнойИнформацией.ЗаполнитьОбъектРедактированияАдресаПоСтруктуре(МЗ, СтруктураАдреса);
	МЗ.Объект = ФизЛицоСсылка;
	МЗ.Тип = Перечисления.ТипыКонтактнойИнформации.Адрес;
	МЗ.Вид = Справочники.ВидыКонтактнойИнформации.ЮрАдресФизЛица;
	МЗ.Записать();
	
КонецПроцедуры

Проверка существует ли уже такой элемент справочника осуществляется по реквизиту Комментарий. У загружаемых объектов в этом реквизите указывается уникальная строка, возвращаемая функцией СформироватьКомментарий(), которая помимо всего прочего содержит в себе значение ID объекта системы Инфо-предприятие.

Вот код функции СформироватьКомментарий():

Функция СформироватьКомментарий(Данные, ПереченьПолей)
	
	Стр = "#Загружено из Инфо-Предприятие {";
	
	ДанныеКомментария = Новый Структура(ПереченьПолей);
	СписокПолей = Новый СписокЗначений;
	Для Каждого КлючИЗначение Из ДанныеКомментария Цикл
		СписокПолей.Добавить(КлючИЗначение.Ключ);
	КонецЦикла; 
	
	СписокПолей.СортироватьПоЗначению();
	
	ЗаполнитьЗначенияСвойств(ДанныеКомментария, Данные);
	Для Каждого ЭлементСписка Из СписокПолей Цикл
		ИмяПоля = ЭлементСписка.Значение;
		Стр = Стр + ИмяПоля + "=" + ДанныеКомментария[ИмяПоля] + ";";
	КонецЦикла; 
	
	Стр = Стр + "}#";
	
	Возврат Стр;
	
КонецФункции

Вот, собственно, и всё. Процедуры загрузки остальных справочников (Контрагенты, Номенклатура, ОсновныеСредства) аналогичны приведённой здесь процедуре ЗагрузитьФизЛицо(). Если кому-то они будут нужны - пишите, вышлю код.

Весь код под GPLv3.

обработка импорт загрузка инфо-предприятие paradox excel

См. также

SALE! 10%

Синхронизация и обмен для ERP 2.5, КА 2.5, УТ 11.5 БП 3.0, Розница, УНФ и других с EnterpriseData (универсальный формат обмена), правила обмена

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Россия Платные (руб)

Правила в универсальном формате обмена для ERP 2.5, КА 2.5, УТ 11.5, БП 3.0, Розница, УНФ, для последних версий конфигураций. Ссылки на другие конфигурации в описании публикации. Правила совместимы со всеми другими версиями конфигураций новыми и старыми, поддерживающими обмен и синхронизацию в формате EnterpriseData. Не требуется синхронного обновления правил после обновления другой конфигурации, участвующей в обмене. Типовой обмен через планы обмена кнопкой Синхронизация вручную или автоматически по расписанию, или вручную обработкой.

25080 22572 руб.

12.06.2017    136434    730    291    

393

Загрузка отчета о продажах WildBerries для бухгалтера из API Статистики и Отчетов в формате *.xlsx в 1С документ "Отчет комиссионера"

Загрузка и выгрузка в Excel Маркетплейсы Платформа 1С v8.3 Бухгалтерский учет Оперативный учет 1С:Управление торговлей 10 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 Бухгалтерский учет Платные (руб)

Загрузка данных детализированного отчета о продажах WildBerries в 1С документ "Отчет комиссионера" для следующих конфигураций: Бухгалтерия предприятия, редакция 3.0; Управление нашей фирмой, редакция 3.0; Управление торговлей, редакция 10.3; Управление торговлей, редакция 11

4800 руб.

11.12.2019    55206    969    3    

225

Перенос данных из ERP 2 / КА 2 / УТ 11 в БП 3.0. Переносятся документы, начальные остатки и справочники

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

Перенос данных из ERP в БП 3 | из КА 2 в БП 3 | из УТ 11 в БП 3 | из ЕРП в БП 3 | В продаже с 2019г. | Воспользовались более 176 предприятий! | Сэкономьте время - используйте готовое решение для перехода! | Перенос разработан в формате КД 2 (правила конвертации данных) | Переносятся все возможные виды документов, начальных остатков и нормативно-справочная информация| Можно опционально выгружать каждую пару "номенклатура+характеристика" как отдельную номенклатуру | Есть выгрузка настроек счетов учета и зарплатных данных из ERP / КА 2 | Можно проверить на вашем сервере перед покупкой, обращайтесь!

34650 руб.

15.04.2019    69445    166    141    

112

SALE! 10%

Перенос данных из УТ 10.3 в УТ 11.5. Переносятся документы (обороты за период), справочная информация и остатки

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 10 1С:Управление торговлей 11 Россия Управленческий учет Платные (руб)

Перенос данных из 1С:Управление торговлей 10.3 в 1С:Управление торговлей 11.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УТ 10.3 (10.3.87.x) и УТ 11.5 (11.5.16.x).

28000 25200 руб.

23.07.2020    47434    202    64    

163

SALE! 10%

Перенос данных из УПП 1.3 в БП 3.0. Переносятся документы (обороты за период), справочная информация и остатки

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Управление производственным предприятием 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:Бухгалтерия предприятия 3.0 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УПП 1.3 (1.3.226.x) и БП 3.0 (3.0.151.x). Правила подходят для версии ПРОФ и КОРП.

28000 25200 руб.

15.12.2021    21007    137    38    

96

Загрузка номенклатуры в УТ11, КА 2, ERP 2, Розница 2 из Excel. Дополнительные реквизиты и сведения, характеристики, картинки, цены, остатки

Загрузка и выгрузка в Excel Розничная торговля Логистика, склад и ТМЦ Ценообразование, анализ цен Прайсы Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Розница 2 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Управленческий учет Платные (руб)

Загрузка номенклатуры из файлов Excel (xls, xlsx, ods, csv, mxl) в УТ11, КА 2, ERP 2, Розница 2. Задействованы все возможности конфигурации - заполнение реквизитов номенклатуры, дополнительных реквизитов и сведений, характеристики, доп.реквизиты и сведения характеристик. Дополнительные обработки для расширения возможностей.

10560 руб.

29.10.2014    212813    632    526    

447

Перенос данных из ERP 2 / КА 2 в ЗУП 3. Переносятся остатки, документы и справочники

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из ERP в ЗУП 3 | из КА 2 в ЗУП | Воспользовались более 79 предприятий! | Предлагаем приобрести готовые правила конвертации данных (КД 2) для переноса остатков, документов с движениями и справочной информации 3 | В продаже с 2020г. | Оперативно обновляем правила до актуальных релизов 1С | Есть перенос начальной задолженности по зарплате и начальной штатной расстановки на выбранную дату | Обороты за прошлые годы (данные для расчета среднего) переносятся свернуто в документ "Перенос данных" | Есть фильтр по организациям | Документы за текущий период переносятся сразу с движениями, поэтому не потребуется делать перерасчеты | Перенос можно проверить перед покупкой, обращайтесь!

43450 руб.

03.12.2020    34772    83    58    

81

[ED2] Обмен УПП 1.3, КА 1.1, УТ 10.3 с EnterpriseData (универсальный формат обмена), обработка

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1C v8.2 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Управление производственным предприятием Россия Платные (руб)

Регулярный обмен, выгрузка, перенос из КА 1.1, УПП 1.3, УТ 10.3 для обмена с любыми конфигурациями, поддерживающими обмен в формате EnterpriseData (КД3) - БП 3.0, ERP, КА 2, УТ 11, Розница 2, УНФ 1.6 и другими. Правила для старых и доработанных конфигураций не требуют синхронного обновления и совместимы с новыми и будущими конфигурациями. Обмен по расписанию, через папку, FTP, почту.

14580 руб.

18.02.2016    183556    565    508    

509
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. user1511150 24.12.20 14:01 Сейчас в теме
q_i, здравствуйте.
Обратили внимание, что у Вас есть наработки по ИМ.
У нас возникла необходимость вести БД по сотрудникам в 1С ЗуП (другой конфигурацией не получится воспользоваться в силу требований от контрагента). Т.е все начисления, расчеты больничных, отпускных, налогов и страховых взносов будут вестись в ней.
Но для целей налогообложения по УСН и налога на прибыль, нам необходимо отражать все эти затраты в регистрах бухгалтерского и налогового учета в программе "Инфо-Передприятие", в которой ведется основная бухгалтерия, формируются отчеты по предприятиям, форма 1 и форма 2.
Следовательно, нужно дописать модуль синхронизации между 1С ЗуП и "Инфо-Предприятие".
Нас интересует, можете ли Вы взяться за этот проект? сколько это займет времени и средств?
Полностью переходить на 1С мы не планируем — нас устраивает "Инфо-Предприятие", в котором БУ и НУ ведется уже много лет.
Ждем Ваши предложения.
2. q_i 580 24.12.20 17:30 Сейчас в теме
(1) Здравствуйте!
Эта публикация была написана в 2016 г по мотивам решения задачи выгрузки конкретных справочников из Инфо-Предприятия в 1С. С Инфо-Предприятием я особо тогда не разбирался, только посмотрел откуда можно вытащить необходимые данные. И с тех пор с ним больше ни разу не сталкивался.
Думаю, вам нужен кто-то, кто более досконально разбирается в Инфо-Предприятии, чем я.
С уважением.
Оставьте свое сообщение