Импорт справочников из Инфо-Предприятие 1.91 в БП2.0/ЗУП2.5 (из файлов *.db или *.xls/*.xlsx)

Публикация № 565473

Администрирование - Администрирование данных 1С - Обработка справочников

обработка импорт загрузка инфо-предприятие paradox excel

Обработка для импорта справочников Контрагенты, Номенклатура, ОсновныеСредства и ФизическиеЛица из DB-файлов Инфо-Предприятие 1.91 или из DB-файлов, сохранённых как файлы MS Excel (XLS/XLSX-файлы).

Проверялось на: Бухгалтерия Предприятия 2.0.65.3, Зарплата и Управление Персоналом 2.5.98.1.

В рамках проекта по переводу клиента с Инфо-Предприятие 1.91 на 1С:БП2.0+1С:ЗУП2.5 возникла задача по автоматическому переносу основных справочников. Готовое решение не нашёл, поэтому написал данную обработку.

Обработка умеет загружать справочники Контрагенты, Номенклатура, ОсновныеСредства и ФизическиеЛица как из DB-файлов Инфо-Предприятие (СУБД Paradox), так и из DB-файлов, сохранённых в формате MS Excel (XLS/XLSX-файлов).

Чтение DB-файлов работает на порядок быстрее, чем XLS/XLSX, но у меня оно отработало не на всех компьютерах, на которых пробовал запускать обработку. Не знаю точно, действительно ли это оказало влияние, но на тех компьютерах, на которых чтение DB-файлов отработало, был установлен BDE.

Теперь немного про код самой обработки.

Была написана пара универсальных функций для чтения данных: 1) из DB-файла (через ADO) и 2) из файла Excel. Обе функции в качестве параметра получают полное имя файла и возвращают таблицу значений, которая содержит все данные, прочитанные из этого DB-/XLS(X)-файла. Имена колонок возвращаемой таблицы значений совпадают с именами колонок DB-файла. В случае чтения из файла MS Excel, имена колонок берутся из первой строки таблицы.

Функция чтения из DB-файла в таблицу значений:

Функция ПолучитьТаблицуИзФайлаПарадокс(ИмяФайла)
	
	ТЗ = Новый ТаблицаЗначений;
	
	Файл = Новый Файл(ИмяФайла);
	
	СтрокаПодключения = "Driver={Microsoft Paradox Driver (*.db )};DefaultDir=" + Файл.Путь + ";CollatingSequence=ASCII";
	
	ПодключениеАДОДБ = Новый COMОбъект("ADODB.Connection");
	ПодключениеАДОДБ.Open(СтрокаПодключения);
	
	ТекстЗапроса = "SELECT * FROM " + Файл.ИмяБезРасширения;
	ВыборкаАДОДБ = ПодключениеАДОДБ.Execute(ТекстЗапроса);
	
	ВыборкаАДОДБ.MoveFirst();
	
	КолвоКолонок = ВыборкаАДОДБ.Fields.Count;
	
	Если КолвоКолонок = 0 Тогда
		ВызватьИсключение "Ошибка чтения файла " + ИмяФайла + ": таблица не содержит колонок!";
	КонецЕсли; 
	
	СоответствиеКолонок = Новый Соответствие; 
	Для НомКол = 0 По КолвоКолонок - 1 Цикл
		ИмяКолонки = ВыборкаАДОДБ.Fields(НомКол).Name;
		ТЗ.Колонки.Добавить(ИмяКолонки);
		СоответствиеКолонок.Вставить(НомКол, ИмяКолонки);
	КонецЦикла; 

	Пока НЕ ВыборкаАДОДБ.EOF Цикл
		НоваяСтрока = ТЗ.Добавить(); 
		Для НомКол = 0 По КолвоКолонок - 1 Цикл
			НоваяСтрока[СоответствиеКолонок.Получить(НомКол)] = ВыборкаАДОДБ.Fields(НомКол).Value;
		КонецЦикла;
		ВыборкаАДОДБ.MoveNext();
	КонецЦикла; 
	
	Возврат ТЗ; 
	
КонецФункции

Функция чтения из XLS/XLSX-файла в таблицу значений:

Функция ПолучитьТаблицуИзФайлаЕксель(ИмяФайла)
	
	ТЗ = Новый ТаблицаЗначений;
	
	Ексель = Новый COMОбъект("Excel.Application");
	КнигаЕксель = Ексель.Workbooks.Open(ИмяФайла, Ложь, Истина);
	ЛистЕксель = КнигаЕксель.Worksheets(1);
	
	// читаем первую строку с заголовками столбцов
	НомКол = 1;
	СоответствиеКолонок = Новый Соответствие; 
	Пока Истина Цикл
		ТекЗнач = СокрЛП(ЛистЕксель.Cells(1, НомКол).Value);
		Если ПустаяСтрока(ТекЗнач) Тогда
			Прервать;
		КонецЕсли;
		ТЗ.Колонки.Добавить(ТекЗнач);
		СоответствиеКолонок.Вставить(НомКол, ТекЗнач);
		НомКол = НомКол + 1; 
	КонецЦикла;
	
	КолвоКолонок = ТЗ.Колонки.Количество();
	
	Если КолвоКолонок = 0 Тогда
		ВызватьИсключение "Ошибка чтения таблицы Excel " + ИмяФайла + ": в первой строке не найдены заголовки столбцов!";
	КонецЕсли; 
	
	НомСтр = 2;
	Пока Истина Цикл
		ЕстьДанные = Ложь;
		СтруктураДанных = Новый Структура;
		Для НомКол = 1 По КолвоКолонок Цикл
			ИмяКолонки = СоответствиеКолонок.Получить(НомКол);
			ТекЗнач = ЛистЕксель.Cells(НомСтр, НомКол).Value;
			Если НЕ ПустаяСтрока(ТекЗнач) Тогда
				ЕстьДанные = Истина;
			КонецЕсли; 
			СтруктураДанных.Вставить(ИмяКолонки, ТекЗнач);
		КонецЦикла;
		Если НЕ ЕстьДанные Тогда
			Прервать;
		КонецЕсли; 
		НоваяСтрока = ТЗ.Добавить();
		ЗаполнитьЗначенияСвойств(НоваяСтрока, СтруктураДанных);
		НомСтр = НомСтр + 1; 
	КонецЦикла; 
	
	Возврат ТЗ; 
	
КонецФункции

Для унификации вызвова функции чтения данных используется функция ПолучитьТаблицуИзФайла(), которая в зависимости от расширения файла вызывает одну из вышеприведённых функций:

Функция ПолучитьТаблицуИзФайла(ИмяФайла)
	
	Попытка
		Файл = Новый Файл(ИмяФайла);
		Если Лев(ВРег(Файл.Расширение), 4) = ".XLS" Тогда
			Возврат ПолучитьТаблицуИзФайлаЕксель(ИмяФайла);
		ИначеЕсли ВРег(Файл.Расширение) = ".DB" Тогда
			Возврат ПолучитьТаблицуИзФайлаПарадокс(ИмяФайла);
		Иначе 
			Сообщить("ПолучитьТаблицуИзФайла(): загрузка из файла " + ИмяФайла 
				+ " невозможна! Неизвестный тип файла: " + Файл.Расширение + "!", СтатусСообщения.Важное);
		КонецЕсли;
	Исключение
	    Сообщить("Ошибка загрузки данных из файла " + ИмяФайла + ": " + ОписаниеОшибки(), СтатусСообщения.Внимание);
	КонецПопытки; 
	
	Возврат Неопределено;
	
КонецФункции

Далее на основе прочитанных данных создаются необходимые элементы справочников и заполняются данные в регистрах сведений.

Для примера рассмотрим загрузку справочника ФизическиеЛица. При нажатии соответствующей кнопки "Загрузить" (см.скриншот) вызывается процедура-обработчик КнопкаЗагрузитьСотрудникиНажатие():

Процедура КнопкаЗагрузитьСотрудникиНажатие(Элемент)

	ИмяФайла = ИмяФайлаСотрудники;
	НазваниеФайла = "Сотрудники";
	
	Если НЕ ПроверитьИмяФайла(ИмяФайла, НазваниеФайла) Тогда
		Возврат;
	КонецЕсли; 
	
	Сообщить("Начало загрузки: " + ТекущаяДата());
	
	Состояние("Чтение данных из файла...");
	ТаблицаДанных = ПолучитьТаблицуИзФайла(ИмяФайла);
	
	Колво = 0;
	КолвоВсего = ТаблицаДанных.Количество();
	
	Для Каждого СтрокаТаблицы Из ТаблицаДанных Цикл
		ОбработкаПрерыванияПользователя();
		Колво = Колво + 1; 
		ПроцентЗагружено = Цел(Колво / КолвоВсего * 100);
		Состояние("[" + Строка(ПроцентЗагружено) + "%] " + СтрокаТаблицы.famSotr);
		ЗагрузитьФизЛицо(СтрокаТаблицы, ФлагПерезаписыватьСуществующие);
	КонецЦикла; 
	
	Сообщить("Окончание загрузки: " + ТекущаяДата());
	
КонецПроцедуры

В этой процедуре вызывается ранее рассмотренная функция ПолучитьТаблицуИзФайла(ИмяФайла), которая возвращает таблицу значений с данными для загрузки, а затем в цикле по строкам полученной таблицы значений вызывается процедура ЗагрузитьФизЛицо(), которая непосредственно осуществляет создание элемента справочника ФизическиеЛица и сопутствующих ему записей в регистрах сведений (эта процедура работает как в БП2.0, так и в ЗУП2.5):

Процедура ЗагрузитьФизЛицо(Данные, Перезаписывать) Экспорт 
	
	Комментарий = СформироватьКомментарий(Данные, "ID");
	
	Запрос = Новый Запрос;
	Запрос.Текст = 
	"ВЫБРАТЬ
	|	ФизическиеЛица.Ссылка
	|ИЗ
	|	Справочник.ФизическиеЛица КАК ФизическиеЛица
	|ГДЕ
	|	ФизическиеЛица.Комментарий ПОДОБНО &Комментарий";
	Запрос.УстановитьПараметр("Комментарий", Комментарий);
	РезультатЗапроса = Запрос.Выполнить();
	
	ТекОбъект = Неопределено;
	
	Если НЕ РезультатЗапроса.Пустой() Тогда
		Если НЕ Перезаписывать Тогда
			Возврат;
		КонецЕсли;
		Выборка = РезультатЗапроса.Выбрать();
		Выборка.Следующий();
		ТекОбъект = Выборка.Ссылка.ПолучитьОбъект();
	Иначе 
		ТекОбъект = Справочники.ФизическиеЛица.СоздатьЭлемент();
	КонецЕсли; 
	
	ТекОбъект.Комментарий = Комментарий;
	
	ФамилияФЛ = СПрописной(СокрЛП(Данные.famSotr));
	ИмяФЛ = СПрописной(СокрЛП(Данные.imyaSotr));
	ОтчествоФЛ = СПрописной(СокрЛП(Данные.otchSotr));
	
	ФИО = ФамилияФЛ
		+ ?(ПустаяСтрока(ИмяФЛ), "", " " + ИмяФЛ)
		+ ?(ПустаяСтрока(ОтчествоФЛ), "", " " + ОтчествоФЛ);
	
	ТекОбъект.Наименование = ФИО;
	ТекОбъект.ДатаРождения = ПолучитьДатуИзДанных(Данные.dataR22);
	
	// 1с: МестоРожденияСтрокойПослеРедактирования = ""+СокрЛП(Особое)+","+СокрЛП(Город)+","+СокрЛП(Район)+","+СокрЛП(Область)+","+СокрЛП(Страна);
	ТекОбъект.МестоРождения = "0," + СокрЛП(Данные.gorodJ2) + "," + СокрЛП(Данные.raiionJ2) + "," + СокрЛП(Данные.nazvRegJ2);
		
	ТекОбъект.ИНН = СокрЛП(Данные.innSotr2);
	ТекОбъект.КодИМНС = СокрЛП(Данные.kodGNISotr);
	ТекОбъект.СтраховойНомерПФР = СокрЛП(Данные.regNomerPF);
	КодПола = Лев(ВРег(СокрЛП(Данные.pol)), 1);
	Если КодПола = "Ж" Тогда
		ТекОбъект.Пол = Перечисления.ПолФизическихЛиц.Женский;
	ИначеЕсли КодПола = "М" Тогда
		ТекОбъект.Пол = Перечисления.ПолФизическихЛиц.Мужской;
	Иначе 
		// оно?
		ТекОбъект.Пол = Перечисления.ПолФизическихЛиц.ПустаяСсылка();
	КонецЕсли; 
	
	ТекОбъект.Записать();
	ФизЛицоСсылка = ТекОбъект.Ссылка;
	
	// ФИО физ.лиц
	ПериодЗаписи = ТекОбъект.ДатаРождения;
	НЗ = РегистрыСведений.ФИОФизЛиц.СоздатьНаборЗаписей();
	НЗ.Отбор.ФизЛицо.Установить(ФизЛицоСсылка);
	НЗ.Отбор.Период.Установить(ПериодЗаписи);
	Запись = НЗ.Добавить();
	Запись.ФизЛицо = ФизЛицоСсылка;
	Запись.Период = ПериодЗаписи;
	Запись.Фамилия = ФамилияФЛ;
	Запись.Имя = ИмяФЛ;
	Запись.Отчество = ОтчествоФЛ;
	НЗ.Записать();
	
	// паспортные данные
	ДатаВыдачи = ПолучитьДатуИзДанных(Данные.data_vyidachi);
	ПериодЗаписи = ?(ЗначениеЗаполнено(ДатаВыдачи), ДатаВыдачи, ТекОбъект.ДатаРождения);
	НЗ = РегистрыСведений.ПаспортныеДанныеФизЛиц.СоздатьНаборЗаписей();
	НЗ.Отбор.ФизЛицо.Установить(ФизЛицоСсылка);
	НЗ.Отбор.Период.Установить(ПериодЗаписи);
	Запись = НЗ.Добавить();
	Запись.ФизЛицо = ФизЛицоСсылка;
	Запись.Период = ПериодЗаписи;
	Если ЗначениеЗаполнено(Данные.kodDokumenta) Тогда
		Запись.ДокументВид = Справочники.ДокументыУдостоверяющиеЛичность.НайтиПоРеквизиту("КодИМНС", СокрЛП(Данные.kodDokumenta));
	КонецЕсли; 
	Запись.ДокументНомер = СокрЛП(Данные.seriya);
	Запись.ДокументДатаВыдачи = ДатаВыдачи;
	Запись.ДокументКемВыдан = СокрЛП(Данные.pasportnyie_dannyie);
	НЗ.Записать();
	
	// контактная информация
	СтруктураАдреса = Новый Структура; 
	СтруктураАдреса.Вставить("Индекс"			, СокрЛП(Данные.indeks));
	СтруктураАдреса.Вставить("Регион"			, СокрЛП(Данные.nazvReg));
	СтруктураАдреса.Вставить("Район"			, СокрЛП(Данные.raiion));	
	СтруктураАдреса.Вставить("Город"			, СокрЛП(Данные.gorod));
	СтруктураАдреса.Вставить("НаселенныйПункт"	, СокрЛП(Данные.nasPunkt));
	СтруктураАдреса.Вставить("Улица"			, СокрЛП(Данные.ulica));
	СтруктураАдреса.Вставить("Дом"				, СокрЛП(Данные.dom2));
	СтруктураАдреса.Вставить("Корпус"			, СокрЛП(Данные.korpus));
	СтруктураАдреса.Вставить("Квартира"			, СокрЛП(Данные.kvartira22));
	МЗ = РегистрыСведений.КонтактнаяИнформация.СоздатьМенеджерЗаписи();
	УправлениеКонтактнойИнформацией.ЗаполнитьОбъектРедактированияАдресаПоСтруктуре(МЗ, СтруктураАдреса);
	МЗ.Объект = ФизЛицоСсылка;
	МЗ.Тип = Перечисления.ТипыКонтактнойИнформации.Адрес;
	МЗ.Вид = Справочники.ВидыКонтактнойИнформации.ЮрАдресФизЛица;
	МЗ.Записать();
	
КонецПроцедуры

Проверка существует ли уже такой элемент справочника осуществляется по реквизиту Комментарий. У загружаемых объектов в этом реквизите указывается уникальная строка, возвращаемая функцией СформироватьКомментарий(), которая помимо всего прочего содержит в себе значение ID объекта системы Инфо-предприятие.

Вот код функции СформироватьКомментарий():

Функция СформироватьКомментарий(Данные, ПереченьПолей)
	
	Стр = "#Загружено из Инфо-Предприятие {";
	
	ДанныеКомментария = Новый Структура(ПереченьПолей);
	СписокПолей = Новый СписокЗначений;
	Для Каждого КлючИЗначение Из ДанныеКомментария Цикл
		СписокПолей.Добавить(КлючИЗначение.Ключ);
	КонецЦикла; 
	
	СписокПолей.СортироватьПоЗначению();
	
	ЗаполнитьЗначенияСвойств(ДанныеКомментария, Данные);
	Для Каждого ЭлементСписка Из СписокПолей Цикл
		ИмяПоля = ЭлементСписка.Значение;
		Стр = Стр + ИмяПоля + "=" + ДанныеКомментария[ИмяПоля] + ";";
	КонецЦикла; 
	
	Стр = Стр + "}#";
	
	Возврат Стр;
	
КонецФункции

Вот, собственно, и всё. Процедуры загрузки остальных справочников (Контрагенты, Номенклатура, ОсновныеСредства) аналогичны приведённой здесь процедуре ЗагрузитьФизЛицо(). Если кому-то они будут нужны - пишите, вышлю код.

Весь код под GPLv3.

Скачать файлы

Наименование Файл Версия Размер
ZagruzkaIzInfoPredpriyatie.epf.7z

.7z 12,90Kb
10
.7z 0.1 12,90Kb 10 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. user1511150 24.12.20 14:01 Сейчас в теме
q_i, здравствуйте.
Обратили внимание, что у Вас есть наработки по ИМ.
У нас возникла необходимость вести БД по сотрудникам в 1С ЗуП (другой конфигурацией не получится воспользоваться в силу требований от контрагента). Т.е все начисления, расчеты больничных, отпускных, налогов и страховых взносов будут вестись в ней.
Но для целей налогообложения по УСН и налога на прибыль, нам необходимо отражать все эти затраты в регистрах бухгалтерского и налогового учета в программе "Инфо-Передприятие", в которой ведется основная бухгалтерия, формируются отчеты по предприятиям, форма 1 и форма 2.
Следовательно, нужно дописать модуль синхронизации между 1С ЗуП и "Инфо-Предприятие".
Нас интересует, можете ли Вы взяться за этот проект? сколько это займет времени и средств?
Полностью переходить на 1С мы не планируем — нас устраивает "Инфо-Предприятие", в котором БУ и НУ ведется уже много лет.
Ждем Ваши предложения.
2. q_i 421 24.12.20 17:30 Сейчас в теме
(1) Здравствуйте!
Эта публикация была написана в 2016 г по мотивам решения задачи выгрузки конкретных справочников из Инфо-Предприятия в 1С. С Инфо-Предприятием я особо тогда не разбирался, только посмотрел откуда можно вытащить необходимые данные. И с тех пор с ним больше ни разу не сталкивался.
Думаю, вам нужен кто-то, кто более досконально разбирается в Инфо-Предприятии, чем я.
С уважением.
Оставьте свое сообщение

См. также

Заготовка обработки (внешняя печатная форма) заполнения Excel документа из 1С Промо

Загрузка и выгрузка в Excel v8 1cv8.cf Абонемент ($m)

Умеет заполнять как отдельные ячейки, так и таблицы в рамках листов Excel. Удобно при разработке различных “дашбордов” (с графиками, диаграммами), отчетов финансистов (где много формул), заполнения форм документов организации. Эксель шаблон может сделать пользователь (с нужным ему оформлением, формулами и т.д.) и впоследствии самостоятельно этот шаблон менять. Программисту нужно только настроить выдачу данных для заполнения шаблона. Может подключаться как внешняя печатная форма (для обычных и управляемых форм).

2 стартмани

29.07.2020    1802    5    wonderboy    0    

Шаблон http-сервиса для вашего проекта

Внешние источники данных WEB Мобильная разработка v8 v8::Mobile 1cv8.cf Абонемент ($m)

Http-сервис для обмена данными в формате JSON. Обработчики этого сервиса находятся во внешней обработке, что позволяет дорабатывать его без изменения конфигурации. Также прилагаю пример мобильного приложения для работы с данным сервисом (получает номенклатуру и остатки на складе). Сервис очень быстро разворачивается и масштабируется под ваши задачи.

3 стартмани

04.05.2019    21222    78    MarkoSokolov    48    

Универсальный инструмент для переноса данных через табличный документ (УФ)

Обработка документов Универсальные обработки Обработка справочников v8 v8::УФ 1cv8.cf Абонемент ($m)

Для опытных пользователей, разработчиков, администраторов, консультантов

5 стартмани

15.10.2018    37013    139    json    42    

Мониторинг показателей систем 1С 8.3 с помощью Zabbix

Внешние источники данных Zabbix v8 1cv8.cf Абонемент ($m)

Опишу свой опыт мониторинга наших систем 1С с помощью Zabbix и ту пользу, которую можно извлечить из этого.

1 стартмани

05.10.2018    44974    63    akimych    49    

Конвертация данных Парус 7, 10 - ЗУП 2.5, ЗИКБУ 1.0, КА 1.1, УПП Промо

Внешние источники данных Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 КА1 ЗУП2.5 УПП1 БГУ Россия БУ Госбюджет Абонемент ($m)

Перенос данных Парус 7, 10 - ЗУП 2.5, ЗИКБУ 1.0, КА 1.1, УПП Переносит данные сотрудника, физического лица и начисления за произвольный период

1 стартмани

10.06.2014    34395    65    kns77    87    

RabbitMQ + 1С. Быстрый старт

Внешние источники данных v8 1cv8.cf Абонемент ($m)

Внешняя компонента для отправки сообщения из 1С в кролика. Сервис прослушивания и перенаправления сообщений из кролика в http или web-сервис.

1 стартмани

10.06.2018    34474    103    Goleff74    42    

Вы больше не будете разбирать Excel как раньше

Загрузка и выгрузка в Excel v8 1cv8.cf Абонемент ($m)

Кому не приходилось разбирать файлы в формате Excel? Все матерятся, плюются, требуют обещаний что "это в последний раз", но таки пишут загрузку из Excel. Потом форматы меняются, строки съезжают, колонки переставляют... Вам это не надоело?

1 стартмани

07.05.2018    31131    64    m-rv    34    

Автоматическое заполнение графиков в ЗУП 3.1

Зарплата Учет рабочего времени Обработка справочников Зарплата Учет рабочего времени v8 v8::СПР ЗУП3.x Россия БУ Абонемент ($m)

Данная разработка будет актуальна для организаций с большим количеством графиков (несколько десятков/сотен).

1 стартмани

05.05.2018    25943    18    notserioussam    2    

Правильные аналоги номенклатуры (кроссы запчастей) для 1С / Управляемые формы Промо

Обработка справочников Оптовая торговля Учет ТМЦ Оптовая торговля Учет ТМЦ v8 v8::УФ 1cv8.cf УУ Абонемент ($m)

По опыту работы с запчастями много раз сталкивался с проблемой организации кроссов в разных 1С - от записи артикулов через запятую в текстовом поле до хранения кроссов в документах. Предлагаю одну из простейших и функциональных на мой взгляд схем "одноуровневого" хранения кроссов.

5 стартмани

29.07.2015    38162    3    taurus__    22    

Интеграция между Atlassian Jira и 1С:Предприятие 8.3 используя Jira REST API (выборка, создание и изменение запросов, чтение, создание и удаление записей о работах, чтение комментариев и другие возможности)

Внешние источники данных WEB v8 v8::УФ 1cv8.cf Абонемент ($m)

Внешняя обработка на управляемой форме для 1С:Предприятие 8.3 по интеграции с Atlassian Jira используя Jira REST API. Ключевые функции: выборка запросов с использованием JQL; добавление и изменение запросов; добавление, изменение и удаление записей о работах; чтение комментариев к запросам; сохранение всех ключевых параметров между сеансами работы. Тестирование проводилось на платформе 1С (8.3.11.2954) совместно с JIRA Server platform (7.3.7)

1 стартмани

24.04.2018    36274    202    Ko1t    82    

Чтение и запись из таблиц гугл (google sheets) в табличный документ 1С (8.3, управляемые формы)

Внешние источники данных WEB v8 v8::УФ 1cv8.cf Абонемент ($m)

Внешняя обработка на управляемой форме для 1С версии 8.3 для доступа к сервисам Google Sheets c использованием протокола авторизации OAuth 2.0. Выполняет получение списка листов таблицы гугл, чтение таблицы гугл в табличный документ 1С и запись из табличного документа 1С в таблицу гугл. Тестирование проводилось на платформе 1С:Предприятие 8.3 (8.3.11.2954).

1 стартмани

09.04.2018    44731    297    Ko1t    76    

Добавление возможности в конфигурации ЗУП 3.1 работать с фотографиями сотрудников (Зарплата и Управление Персоналом, редакция 3.1)

Обработка справочников Управление персоналом (HRM) Управление персоналом (HRM) v8 v8::СПР ЗУП3.x БУ Абонемент ($m)

Добавление возможности в ЗУП 3.1 работать с фотографиями сотрудников (физических лиц). Расширение тестировалось на релизе ЗУП 3.1.5.129.

1 стартмани

09.04.2018    32623    77    charivnick    4    

Загрузка данных из М-Аптеки+ в 1С:Бухгалтерия 8 (ред. 3.0) Промо

Внешние источники данных Файловые протоколы обмена, FTP v8 v8::БУ БП3.0 Фармацевтика, аптеки БУ Абонемент ($m)

Обработка для загрузки файлов выгрузки из программы для автоматизации аптек и аптечных сетей М-Аптека+ в 1С:Бухгалтерия 8, редакция 3.0.

11.07.2014    36905    70    1C_MApteka    38    

Расчет начисления зарплаты со сложной формулой, по данным из внешнего источника. ЗУП 3.1

Обработка документов Загрузка и выгрузка в Excel Зарплата Зарплата v8 v8::СПР ЗКГУ3.0 ЗУП3.x БУ Абонемент ($m)

Расчет начисления зарплаты со сложной формулой, по данным из внешнего источника по данным экономического отдела. ЗУП 3.1.

3 стартмани

20.12.2017    51979    32    mvv1975    7    

Приемы эффективной загрузки данных из Excel в 1С

Загрузка и выгрузка в Excel v8 1cv8.cf Абонемент ($m)

Показаны приемы эффективной работы с Excel для загрузки данных в 1С.

1 стартмани

13.12.2017    61413    107    alexey.kutya    87    

Менеджер загрузки данных из весов с печатью этикеток Промо

Внешние источники данных Весы Учет ТМЦ Учет ТМЦ v8 УТ10 УПП1 Абонемент ($m)

Программное обеспечение "Менеджер загрузки данных из весов с печатью этикеток" предназначено для автоматического получения данных по сети Ethernet из весов МАССА-К моделей ВПМ и ТВ_Р3 (модификация MF) в режиме On-Line.

1 стартмани

20.12.2011    24167    81    hrip    10    

Загрузка дополнительных реквизитов и сведений справочника Номенклатура из Excel и таблиц УТ 11, ERP 2

Обработка справочников Загрузка и выгрузка в Excel Учет ТМЦ Учет ТМЦ v8 v8::ОУ ERP2 УТ11 Россия УУ Абонемент ($m)

Внешняя обработка "Загрузка дополнительных реквизитов и сведений справочника Номенклатура"

1 стартмани

07.08.2017    44170    286    Windyhead    42    

Загрузка номенклатуры по штрихкоду: Управление Торговлей 11.3; Розница 2.2; Розница для Казахстана 2.2

Обработка справочников Оптовая торговля Розничная торговля Ценообразование, анализ цен Ценообразование, прайсы Оптовая торговля Розничная торговля Ценообразование, анализ цен v8 v8::ОУ v8::УФ Розница УТ11 Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Россия УУ Абонемент ($m)

Розница 2.2, Управление Торговлей 11.3. Создание номенклатуры из интернета с помощью сканера штрихкодов либо терминала сбора данных. Варианты создания, автовыбор наилучшей позиции, источники, цены, загрузка картинки - всё это очень гибко и просто настраивается. Текущие открытые источники: barcode-list.ru(на текущий момент не работает); goodsmatrix.ru; ean13.info(может не работать капча); barcodes.olegon.ru. Автор программы не несёт ответственность за информацию, предоставляемую перечисленными выше открытыми источниками, так же не отвечает за их работоспособность. Данные источники принадлежат не автору программы. Данная программа нужна лишь для автоматизированного поиска информации на них.

10 стартмани

30.03.2017    62110    55    myALKleon    46    

Процессор вывода результата компоновки данных в JSON. И не только...

Внешние источники данных v8 Абонемент ($m)

У каждого разработчика возникают задачи интеграции решений. Основная масса решений призвана вывести данные из «1С:Предприятие 8» в обусловленном формате. Разработчики используют огромную часть своих драгоценных ресурсов на реализацию определенной структуры вывода и необходимого формата. А что если...

1 стартмани

14.02.2017    24669    47    pbazeliuk    33    

Прыг-Скок...или из MS EXCEL в 1С (8.2) (открытый код) Промо

Обработка документов Обработка справочников Загрузка и выгрузка в Excel v8 1cv8.cf Абонемент ($m)

Универсальная загрузка данных из Microsoft Office Excel. Автоматическая загрузка из любых по форме документов с очень удобным редактором. Почти готовый шаблон для любой конфигурации. Не требует регистрации-бесплатно.

1 стартмани

16.09.2015    66304    362    Tatitutu    48    

Определение ИНН Сотрудника (service.nalog.ru). ЗУП, редакция 3.1 и 2.5 (Проф и Корп)

Обработка справочников Управление персоналом (HRM) Управление персоналом (HRM) v8 v8::СПР ЗУП2.5 Россия БУ Абонемент ($m)

Внешняя печатная форма для справочника "Сотрудники организаций". ЗУП, редакция 3.1 и 2.5 (Проф и Корп)

1 стартмани

03.02.2017    74218    50    Indgo    34    

Что нам стоит Push построить

Внешние источники данных v8 v8::Mobile Абонемент ($m)

Попробовал некоторое время назад, push сообщения, реализованные в платформе. Понравилось, но есть несколько минусов, на примере одной программы сообщений (не буду показывать пальцем), спустя некоторое время, сообщения переставали приходить онлайн, а на компьютере приходили моментально, при этом сами смартфоны звались флагманами. Читал позднее статью, где описывалось, что проблема на стороне смартфонов, что-то вроде технологий энергосбережения, но точно не помню. Также немалый минус доступно только для смартфонов.

1 стартмани

08.09.2016    29103    17    PloAl    8    

Согласование (подсистема). Для любого справочника и документа в 1С. Встраивается в любые конфигурации

Управление бизнес-процессами (BPM) Обработка документов Обработка справочников Документооборот и делопроизводство Документооборот и делопроизводство v8 1cv8.cf БП3.0 КА2 УУ Абонемент ($m)

Подсистема для согласования в 1С. Для настройки нового согласования не требуется программировать, все делается в режиме исполнения. Открытый код. Бизнес-процессы. Документооборот. Проект выложен на GitHub.

1 стартмани

25.08.2016    59838    290    BlizD    232    

Изменение реквизитов справочников, документов, табличных частей, движений (Обычные и Управляемые формы) Промо

Обработка документов Обработка справочников v8 v8::УФ 1cv8.cf Казахстан Абонемент ($m)

Обработка позволяет редактировать реквизиты справочника, документа, его табличные части и движения.

1 стартмани

15.10.2012    50132    478    Exit_in    42    

Подсистема обмена данными с порталом ИМНС по электронным счетам-фактурам (автоматический обмен)

Внешние источники данных WEB Инструментарий разработчика v8 1cv8.cf Беларусь БУ НДС Абонемент ($m)

Подсистема включает документы и обработки для автоматического обмена данными с порталом ИМНС через web-сервис. Присутствует возможность заполнения данными типовых операций за период, учёта входящих документов, учёта произвольных исходящих документов. Приложены обработки для запуска задания планировщика на автоматический обмен данными.

1 стартмани

28.07.2016    35048    19    c1nil    4    

 Интеграция 1С и C#. Обращение к 1С через COM. Создание номенклатуры и выполнение запроса к 1С из C# на примере интеграции с Союз-PLM (система информационной поддержки жизненного цикла изделий). Обработка «Загрузка заказа на сборку». (ERP)

Загрузка и выгрузка в Excel Внешние источники данных Интеграция v8 ERP2 Абонемент ($m)

Союз-PLM представляет собой полнофункциональный программный комплекс для решения  широкого спектра задач управления инженерной технической информацией наукоемких изделий и сложных инженерных объектов в области машиностроения, приборостроения, архитектуры, строительства. На практике, это управление конструкторской документацией, интегрированное с САПР, бизнес-процессы, файловый архив. Все это работает в SQL и шевелится с помощью скриптов на C#. Скрипты свободно  отлаживаются в MS Visual Studio. Подробнее смотрите на их сайте: http://www.programsoyuz.ru/products/system-soyuz-plm.html  Редактирование, конструирование и использование бизнес-процессов на порядок лучше систем на базе 1С из тех, что я изучил.

1 стартмани

25.07.2016    47847    5    milkers    2    

Номенклатура (Расширенная форма списка) и Корзина [Расширение]

Рабочее место Обработка справочников Учет ТМЦ Учет ТМЦ v8 БП3.0 Абонемент ($m)

Красивая, удобная и эргономичная форма списка номенклатуры. В общем списке номенклатуры отображаются и остатки, и цены. А еще есть возможность быстро создать документы по выбранным позициям через корзину.

5 стартмани

29.02.2016    40090    117    mrXoxot    66    

Выгрузка и загрузка данных из файла Excel с поиском по любым полям (есть поиск по ссылке, всего три итерации поиска. Управляемые формы или "Такси") Промо

Загрузка и выгрузка в Excel Обработка документов v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработка позволяет загружать данные с поиском по ссылке как для загружаемого объекта, так и его свойств. Загружает справочники, документы, планы видов характеристик. Будет полезна как замена использования конвертации данных для задач переноса, а также как классическая загрузка из табличного документа (Excel). Поиск объекта при загрузке выполняется до трех раз с разными полями поиска (поля поиска настраиваются). Также реализована выгрузка в Excel по ссылкам. У обработки удобный интерфейс, в котором разберется даже начинающий пользователь. Загрузка накладных из файлов xls реализована с интеллектуальным поиском колонок с данными. В интеллектуальном поиске поддерживаются все основные типовые печатные формы.

5 стартмани

16.10.2015    62254    516    primat    35    

Модуль для работы 1С (платформа 8.2 и выше) с внешними SOAP Web-сервисами

Внешние источники данных WEB Интеграция v8 1cv8.cf Абонемент ($m)

Модуль для работы 1С (платформа 8.2 и выше) с внешними Web-сервисами, реализованными по протоколу SOAP.

2 стартмани

15.02.2016    41218    85    lunjio    15    

Автозаполнение реквизитов контрагентов по ИНН для БП3.0, ERP2.4, УТ11.4, КА2.4, Розница 2.2, Документооборот 2.1

Обработка справочников v8 КА1 ERP2 БП3.0 УТ11 Абонемент ($m)

Расширение для конфигурации 1С: БП 3.0, ERP 2.4, УТ 11.4, КА 2.4, Розница 2.3, Документооборот 2.1

3 стартмани

22.01.2016    62184    671    oslokot    367    

Оформление ветеринарных документов на продукты питания и грядущие глобальные изменения в 1С (часть 1)

Внешние источники данных Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v8 Сельское хозяйство и рыболовство Оптовая торговля, дистрибуция, логистика Пищевая промышленность УУ Абонемент ($m)

С 01 января 2016 года возможно оформление ветеринарно-сопроводительных документов в электронном виде. Что это означает для предприятий, производящих и торгующих подконтрольной продукцией?

3 стартмани

27.12.2015    62981    7    axxell    28    

Отключение доступа уволенным пользователям Промо

Информационная безопасность Обработка справочников Администрирование данных 1С v8 v8::Права БП2.0 УПП1 Абонемент ($m)

Давно хотели навести порядок в пользователях? Надоело, что в списке мешаются давно уволенные сотрудники? Тогда эта обработка для Вас!

3 стартмани

15.10.2013    51737    109    VBod    17    

Самый простой клиент ЕГАИС УТМ для розницы. $m

Внешние источники данных Рабочее место Розничная торговля Розничная торговля v8 1cv8.cf Россия УУ Абонемент ($m)

Данная обработка позволяет обеспечить приходную часть магазина розничной торговли алкоголем(ЕГАИС розница), или прочего предприятия. Эти действия становятся обязательными для розничного звена в городских поселениях с 01.01.2016 и будут достаточными до 01.07.2016. Предлагаю Вашему вниманию простое и доступное решение, которое позволяет отсрочить проблему интеграции ЕГАИС в розничное звено до указанной даты. (открытый код). Реализовано на открытой модели http://infostart.ru/public/402052/.

2 стартмани

14.12.2015    40304    8    Terrain25    47    

1С:Интеграция ЕГАИС + Инвентаризация на ТСД

Обработка справочников Обмен через XML Оптовая торговля Оптовая торговля v8 1cv8.cf Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Абонемент ($m)

Интеграция ЕГАИС модуля для 1С: 8.3 + модуль WMS контура для инвентаризации алкогольных марок на ТСД.

1 стартмани

10.12.2015    38265    27    JetBrain    5    

Передача больших пакетов через веб-сервисы

Практика программирования Администрирование данных 1С Внешние источники данных v8 Абонемент ($m)

Реализация механизма передачи больших пакетов через веб-сервисы. С его помощью передать файл размером в несколько гигабайт не составит проблем.

1 стартмани

06.12.2015    59528    49    YPermitin    19    

Универсальное средство чтения файлов Excel Промо

Универсальные обработки Загрузка и выгрузка в Excel v8 1cv8.cf Абонемент ($m)

Унифицируем чтение файлов Excel, читаем "неудобные" файлы, переносим содержимое таблиц Excel через буфер обмена.

5 стартмани

27.03.2013    31456    169    Infector    4    

Пример связи 1С и мессенджера Telegram. Получение данных из 1С запросом из Telegram

Практика программирования Внешние источники данных v8 1cv8.cf Абонемент ($m)

В результате чтения публикации Вы получите готовую внешнюю обработку, позволяющую получать из 1С данные, запрашиваемые через Telegram. В данной статье рассмотрим следующее: Использование HTTPСоединение; Чтение JSON для версии 1С 8.3.6 и выше, а также аналог JSON для версии 1С ниже 8.3.6; Подключение обработчика ожидания; Некоторые основные возможности API Telegram; Как создать бота для Telegram; Программное создание колонок дерева на управляемой форме;

1 стартмани

19.11.2015    99975    475    Luchik    209    

Выгрузка и подготовка данных для программы "Перечень льготных профессий" для 1С: ЗУП 2.5 (ОТКРЫТЫЙ КОД)

Рабочее место Внешние источники данных Управление персоналом (HRM) Управление персоналом (HRM) v8 v8::СПР ЗУП2.5 Россия БУ ФОМС, ПФ, ФСС Абонемент ($m)

Обработка для формирования и редактирования данных для перечня льготных профессий. В связи с прекращением поддержки ЗУП 2.5 и отсутствием времени на доработку для сдачи годовой отчетности открыл код модуля. Не очередная выгрузка стажей, а практически полный аналог перечня для 1С. Формирование и редактирование стажей с последующей выгрузкой в формат перечня, но только ГОРАЗДО удобнее и быстрее. В общем, смотрите видео. Где-то половина времени на написание обработки ушла именно на удобство и скорость работы. Внимание: код модуля обработки открыт

5 стартмани

09.11.2015    53727    62    Black-fog    62    

Сброс неверной нумерации объектов

Обработка документов Обработка справочников v8 1cv8.cf Абонемент ($m)

Кратко о выправлении нумерации объектов

1 стартмани

07.11.2015    99829    858    magobato    40    

Загрузка УПД в Бухгалтерию 3.0

Обработка документов Загрузка и выгрузка в Excel Оптовая торговля Оптовая торговля v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Загрузка УПД из Excel в Бухгалтерию предприятия 3.0, с добавлением номенклатуры, ГТД, стран происхождения.

3 стартмани

20.10.2015    24889    13    teyana    12    

Загрузка изображений с поисковых сайтов сети Интернет в 1С

Обработка справочников WEB Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v8 v8::ОУ v8::УФ УТ10 УТ11 Абонемент ($m)

Обработка загрузки изображений из интернета в 1С:Предприятие. Платформа 1С:Предприятие версий 8.2 и 8.3.

10 стартмани

13.10.2015    43975    165    premierex    151    

Асинхронная загрузка данных на Управляемую Форму. Прогресс бар (УФ 8.3). Индикация состояния процесса

Работа с интерфейсом Универсальные функции Внешние источники данных v8 v8::УФ 1cv8.cf Абонемент ($m)

Часто бывает, что возникает необходимость загрузить множество данных из разнообразных источников в определенную форму или рабочее место. В процессе загрузки пользователь в неведении — информация готовится или нет. Прием позволяет загружать данные из нескольких источников асинхронно, не блокируя форму\интерфейс, а также отображать ошибки и состояние прогресса. По мере готовности данных, они будут отображены на форме

1 стартмани

09.10.2015    37671    129    pbazeliuk    6    

7 причин, почему интеграция стала приятной. Не упускайте ряд потрясающих возможностей

Внешние источники данных Интеграция Мобильная разработка v8 1cv8.cf Абонемент ($m)

В статье показаны примеры получения данных без программирования на стороне «1С:Предприятие 8». Вам нужно проверить гипотезу и проанализировать данные, почему бы не интегрироваться с Excel? Используете технологии .NET и «1С:Предприятие 8», процесс связывания систем движется катастрофически медленно? Хотите native Android приложение с вашими данными всегда под рукой?

1 стартмани

01.10.2015    58619    47    pbazeliuk    23    

Полезные приемы при работе с Excel из 1С (Версия 3.1)

Практика программирования Разработка внешних компонент Загрузка и выгрузка в Excel v8 1cv8.cf Абонемент ($m)

Программисту 1С часто приходится работать с таблицами Excel из 1С. Я постарался собрать небольшой FAQ и набор функций для работы с файлами Excel. Надеюсь, кому-то будет полезна данная статья.

1 стартмани

22.09.2015    216360    471    Zerocl    75    

Автоматическая загрузка классификатора адресов КЛАДР

Обработка справочников WEB v8 УТ10 Россия Абонемент ($m)

Обработка автоматически загружает классификатор с сайта www.gnivc.ru, распаковывает и загружает все регионы в информационную базу.

1 стартмани

02.09.2015    26264    39    kolos    1    

Управление изменениями в планах обмена (Управляемое приложение) v 1.0

Распределенная БД (УРИБ, УРБД) Внешние источники данных Перенос данных из 1C8 в 1C8 v8 1cv8.cf Абонемент ($m)

Простая в использовании и наглядная обработка для регистрации изменений или отмены регистрации в планах обмена используя гибкие возможности отбора СКД.

2 стартмани

15.08.2015    31056    47    kser87    3