Автоматическое переименование ЕГАИС номенклатуры

13.12.16

Учетные задачи - Розничная торговля

Автоматически создаем наименования алкогольной номенклатуры на основании классификатора ЕГАИС. Товаровед - отдыхает.

Скачать файл

ВНИМАНИЕ: Файлы из Базы знаний - это исходный код разработки. Это примеры решения задач, шаблоны, заготовки, "строительные материалы" для учетной системы. Файлы ориентированы на специалистов 1С, которые могут разобраться в коде и оптимизировать программу для запуска в базе данных. Гарантии работоспособности нет. Возврата нет. Технической поддержки нет.

Наименование SM По подписке [?] Купить один файл
РеформаторНаименованияПоЕГАИС
.epf 10,69Kb
49
49
1 SM
Скачать Купить за 1 850 руб.

Когда, после напряженной работы, Вы с трудом узнаете номенклатуру, нужно: или пойти поспать, или привести наименования товара в читаемый шаблонный вид.

Обработка полезна, в паре с Инвентаризацией ЕГАИС. При ее применении можно загрузить классификатор ЕГАИС и создать Номенклатуру из НСИ - Сопоставление номенклатуры ЕГАИС. При создании можно допустить стандартную подстановку наименования из классификатора. Затем наступает время данной обработки.

По нажатии кнопки Переформатировать в колонке наименования появляется имя по формату:

[Наименование сопоставленное из Классификатора] [Объем в литрах] [Крепость] [Производитель]

При этом вальяжные наименования классификатора по возможности сокращаются принимая более сжатый вид.

Например:

  • Вино ст. полусл. кр. "Саперави", "Бахчишараб" 0,75л. 12% "Винный Дом Фотисаль"
  • Российский коньяк пятилетний "Золотой резерв" 0,5л 0,5л. 40% АО "УРАЛАЛКО"
  • Текила "Мессикано Альтено Сильвер" 0,75л. 40% ПродуктосФиносДеАгаве
  • Пиво св. "Жатецкий Гусь" ("Zatecky Gus") в ж/б,Тула 1л. 4,6% " "БАЛТИКА"

Наименования можно дополнительно отшлифовать вручную.  По нажатии кнопки Записать изменяется Наименование и Полное наименование номенклатуры у отмеченного галками товара.

Установка

Для подключения обработки нужно зайти в "Администрирование" - "Печатные формы, отчеты, обработки" - "Дополнительные отчеты и обработки" и в появившемся списке добавить файл этой обработки. 

ЕГАИС замена формат наименование порядок сокращение

См. также

Бюджетный учет Обмен с ГосИС Бухгалтер Пользователь Бухгалтерский учет 1С:Управление производственным предприятием 1С:Бухгалтерия 3.0 1С:Управление холдингом Государственные, бюджетные структуры Россия Бухгалтерский учет Бюджетный учет Платные (руб)

Управляйте учетной политикой раздельного учета ГОЗ в 1С:Бухгалтерия 3.0 ПРОФ/КОРП и УХ 3.2. Отчеты по исполнению госконтрактов, расчетно-калькуляционные материалы и контроль операций для исполнения в срок. Готовое расширение подходит для всех бухгалтеров и руководителей производства, помогая вести правильный учет по гособоронзаказу в соответствии 275-ФЗ. Профессиональный консалтинг и регулярные обновления продукта.

28.08.2020    228673    1831    vvmanannikov    134    

910

Оптовая торговля Розничная торговля Обмен с ГосИС Бухгалтер Платформа 1С v8.3 1С:Управление торговлей 10 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Рестораны, кафе и фаст-фуд Россия Бухгалтерский учет Управленческий учет Акцизы Платные (руб)

Полнофункциональное расширение (ранее известное как Модуль 1С-ЕГАИС) для взаимодействия типовых конфигураций 1С и ЕГАИС, предоставляющее максимум возможностей по работе с УТМ. Получение и отправка ТТН, отправка акта о постановке на баланс и акта о списании. Получение остатков. Загрузка и сопоставление номенклатуры и контрагентов. Оправка в ЕГАИС отчетов о производстве и импорте.

8970 руб.

15.12.2015    168654    807    364    

394

Обмен с ГосИС Программист Платформа 1С v8.3 Конфигурации 1cv8 Оптовая торговля, дистрибуция, логистика Россия Управленческий учет Платные (руб)

Универсальная конфигурация ХамелеонЗерно для взаимодействия с системой ФГИС Зерно (тестовый+рабочий контур) может использоваться для интеграции в любую конфигурацию на базе 1С, версии ПРОФ и выше. Работа через API 1.0.7 и на API 1.0.8. Для удобства реализован общий интерфейс в виде обработки, схожей с интерфейсом ФГИС Зерно, но возможностей гораздо больше, т.к. при интеграции в Вашу учетную систему, можно на основании Ваших справочников и документов, создавать соответствующие документы и справочники в системе ФГИС Зерно и наоборот.

20400 руб.

27.06.2023    3861    19    1    

16

ККМ Кассовые операции Розничная торговля Системный администратор Программист Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Бухгалтерия государственного учреждения 1С:Бухгалтерия 1.6 1С:Бухгалтерия автономного учреждения 1С:CRM ПРОФ, КОРП Россия Платные (руб)

Универсальная обработка для обслуживания любых фискальных регистраторов (ККТ), в том числе Веб сервер АТОЛ. Работает в соответствии с 54-ФЗ. (ФФД 1.0, ФФД 1.05, ФФД 1.1). Подключайте любую онлайн кассу к практически любой конфигурации. Нет необходимости обновлять 1С. Можно бесплатно скачать и протестировать. Может работать одновременно с несколькими онлайн-кассами, либо одной с разных рабочих мест. (через RDP, TCP\IP или веб-сервер) Позволяет разделить один чек сразу на несколько ККТ или на несколько систем налогообложения. Поддерживает разрешительный режим. Можно настроить собственный шаблонов чека. Можно использовать эквайринг там, где он не поддерживается. Работает на LINUX и Windows ЭМУЛЯТОР + ЭКВАЙРИНГ + МАРКИРОВКА + ПОДДЕРЖКА ФФД 1.2

6000 руб.

27.02.2017    788009    4750    9507    

2816

Бюджетирование и планирование Оптовая торговля Розничная торговля Логистика, склад и ТМЦ Анализ продаж Пользователь Платформа 1С v7.7 Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Управление нашей фирмой 1.6 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Беларусь Украина Россия Казахстан Управленческий учет Платные (руб)

Система управления запасами для 1С помогает работать с запасами правильно: автоматически рассчитывает потребность и делает заказ поставщику, загружает прайсы, перемещает товары по филиалам, анализирует продажи и позволяет управлять ассортиментом.

28500 руб.

21.04.2017    93617    119    40    

210

Бюджетный учет Обмен с ГосИС Бухгалтер Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Государственные, бюджетные структуры Россия Бухгалтерский учет Платные (руб)

Доработка конфигурации 1С: Бухгалтерия предприятия, редакция 3.0. Предназначена для ведения раздельного учета и автоматизации заполнения отчетности исполнения контрактов ГОЗ в конфигурациях 1С БП КОРП, ПРОФ, БИТ.ФИНАНС.

30000 руб.

16.08.2019    89865    216    86    

134

Обмен с ГосИС Бухгалтер Платформа 1С v8.3 Бухгалтерский учет 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Платные (руб)

Обработка для обмена платежными документами в формате xml для системы Федерального казначейства "Электронный бюджет" из конфигураций 1С. Поставляется для БП 3.0 Работа только с контрагентами.

15000 руб.

14.10.2020    61058    376    101    

298

Логистика, склад и ТМЦ Бухгалтер Пользователь Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Оптовая торговля, дистрибуция, логистика Управленческий учет Платные (руб)

Программа позволяет организовать учет ответственного хранения товаров с весовыми характеристиками, в том числе со сроком годности и личным кабинетом Поклажедателя. Модуль реализован в виде расширения конфигурации, устанавливается в режиме 1С:Предприятие 8 за 5 минут по инструкции, что позволяет оставить конфигурацию 1С на стандартной поддержке и продолжать получать стандартные обновления от фирмы "1С".

60000 руб.

09.06.2020    36528    32    59    

61
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. Denya.S 13.12.16 12:47 Сейчас в теме
Очень было бы удобно засунуть сюда и запрос номенклатуры ЕГАИС по алкокоду, чтобы не грузить всю номенклатуру поставщика.
2. automatizator 170 13.12.16 12:55 Сейчас в теме
(1) Туда-же и сканирование марок... Иначе запрос по каким данным?
Для этого и нужна обозначенная обработка Инвентаризация ЕГАИС.
3. Denya.S 13.12.16 13:16 Сейчас в теме
а можно ли с помощью данной обработки исправить уже заведенную и сопоставленную номенклатуру?
4. coolseo 80 14.12.16 02:44 Сейчас в теме
(3) Да

Дмитрий, огромное спасибо
Добавьте чекбокс снятия всех галочек и добавления всех.

Баг:
Неважно сколько выбрал галочек все время обрабатывает полностью ТЧ
&НаКлиенте
Процедура Переформатировать(Команда)
	Для Каждого Строка Из Объект.Товары цикл
		Строка.Наименование = ПереформатироватьНаСервере(Строка.НоменклатураЕГАИС);
	КонецЦикла;
КонецПроцедуры
6. automatizator 170 14.12.16 03:10 Сейчас в теме
(4) Галочки отрабатывают только на запись
7. coolseo 80 14.12.16 03:14 Сейчас в теме
(6) ок

Вот что еще предлагаю добавить



Наименование = СтрЗаменить(Наименование,"Пастеризованное","");
Наименование = СтрЗаменить(Наименование,"Пастеризованный","");
Наименование = СтрЗаменить(Наименование,"Алюминевый","Алюм.");
Наименование = СтрЗаменить(Наименование,"ароматом","аром.");
Наименование = СтрЗаменить(Наименование,"напиток","нап.");
Наименование = СтрЗаменить(Наименование,"Пивной","Пив.");
11. automatizator 170 14.12.16 10:59 Сейчас в теме
(7) Пив. нап. - по моему это перебор )))
5. automatizator 170 14.12.16 03:09 Сейчас в теме
(3) Она именно для уже заведеной номенклатуры
8. user635667 135 14.12.16 04:15 Сейчас в теме
Я уже видел похожую обработку и кидал кое какие совты тому авору, но он что-то так и не соизволил ее доделать. Напишу и вам, мне кажется будет востребованно - Дать возможность выбирать дописывать-ли "л." и "%", а также дописывать-ли вообще крепость и производителя. Бывает нужно просто цифру литража вставить и все.
9. user635667 135 14.12.16 05:54 Сейчас в теме
и по галочкам - не нашел кнопки убирающей все и ставящей обратно все галочки. а если мне надо только пару из всего списка переименовать?
ну и я так понимаю можно писать сюда что можно допиливать в логике замены?
то что я нашел и хотелось бы что бы вы поправили в своей обработке:
Стеклянная бутылка вместимостью - ст.б.
Металлическая банка - ж.б.
ПЭТФ-бутылка вместимостью - переименовать в просто бут. либо вообще удалять
Бутылка стеклянная - ст.б.
Бутылка полимерная ПЭТ - переименовать в просто бут. либо вообще удалять
СТЕКЛЯННАЯ БУТЫЛКА - ст.б.
Пастеризованное. - вообще удалять, считаю лишним.
12. automatizator 170 14.12.16 11:02 Сейчас в теме
(9) не понимаю откуда брать инфу по таре. В наименовании - почти не встречается
10. user635667 135 14.12.16 07:37 Сейчас в теме
только сейчас понял что штуку с заменой можно через конфигуратор самому допилить. спасибо большое. каждый может под свои нужды сделать как надо)
13. user635667 135 14.12.16 11:41 Сейчас в теме
Надо наверное добавить сортировку по столбикам. и добавить возможность открывать номенклатуру прямо из окна обработки, скажем правой кнопкой на номенклатуре - изменить
14. automatizator 170 14.12.16 11:54 Сейчас в теме
(13) Хорошо. Обработка бесплатная, так что за оперативность не ручаюсь. Пока делитесь предложениями в стиле СтрЗаменить() - т.е. что, на что менять в названии.
15. user635667 135 15.12.16 07:26 Сейчас в теме
Я сделал кучу всяких исправлений. Теперь мне надо сделать отдельную обработку которая бы чистила лишние пробелы в номенклатуре уже имеющейся. Я не программист 1С. Подскажите пожалуйста что поправить в этом коде, что бы просто убирались лишние пробелы в уже переписанном справочнике номенклатура(накалякал вариант как я его вижу, но не знаю как поменять что бы он брал названия уже не из справочника егаис, а из простого справочника номенклатуры):

Скрытый текст
16. automatizator 170 15.12.16 11:25 Сейчас в теме
(15) Егор надо поискать другую обработку.
25. Ryukenden 10.02.17 12:56 Сейчас в теме
(15)
// Удаление задвоенных пробелов
Пока СтрНайти(ИсходнаяСтрока, " ") <> 0 Цикл
ИсходнаяСтрока= СтрЗаменить(ИсходнаяСтрока, " ", " ");
КонецЦикла;

Результат = СокрЛП(ИсходнаяСтрока);
26. user635667 135 14.02.17 09:17 Сейчас в теме
(25) в какую строку это можно вставить?
27. Ryukenden 14.02.17 10:41 Сейчас в теме
(26)
в какую строку это можно вставить?


Это для вашей задачи очистки всей номенклатуры от лишних пробелов. Я для Розницы 2.2 такой код использую:

&НаКлиенте
Процедура ОбработатьНоменклатуру(Команда)
	ОбработатьНоменклатуруНаСервере();
КонецПроцедуры

&НаСервере
Процедура ОбработатьНоменклатуруНаСервере()
	
	Запрос = Новый Запрос;
	Запрос.Текст = 
		"ВЫБРАТЬ
		|	Номенклатура.Ссылка КАК Номенклатура,
		|	Номенклатура.Наименование,
		|	Номенклатура.НаименованиеПолное
		|ИЗ
		|	Справочник.Номенклатура КАК Номенклатура
		|ГДЕ
		|	НЕ Номенклатура.ЭтоГруппа";
	
	РезультатЗапроса = Запрос.Выполнить();
	
	Выборка = РезультатЗапроса.Выбрать();
	
	Пока Выборка.Следующий() Цикл
		
		НоменклатураОбъект = Выборка.Номенклатура;
		
		НоменклатураОбъект.Наименокание = УдалитьЛишниеСимволы(Выборка.Наименование);
		НоменклатураОбъект.НаименованиеПолное = УдалитьЛишниеСимволы(Выборка.НаименованиеПолное);
		
		НоменклатураОбъект.Записать();
		
	КонецЦикла;
	
КонецПроцедуры

&НаСервереБезКонтекста
Функция УдалитьЛишниеСимволы(Текст) 
	
	Если Текст = "" Тогда
		Возврат "";
	КонецЕсли;
	
	Результат = Текст;
	
	// Удаление задвоенных символов
	УдаляемыеСимволы = """.,;\/_";
	
	Для Поз = 1 По СтрДлина(УдаляемыеСимволы) Цикл
		Симв = Лев(УдаляемыеСимволы, Поз);
		
		Пара = Симв + Симв;
		
		Пока СтрНайти(Результат, Пара) <> 0 Цикл
			Результат = СтрЗаменить(Результат, Пара, " ");
		КонецЦикла;
		
	КонецЦикла;
	
	// Удаление недопустимых символов в начале и конце строки:
	// Чистим слева
	УдаляемыеСимволы = ".:,;\/_";
	Работаем = Истина;
	Пока Работаем Цикл		
		Симв = Лев(Результат, 1);
		Если СтрНайти(УдаляемыеСимволы, Симв) <> 0 Тогда
			Результат = Прав(Результат, СтрДлина(Результат) - 1);
		Иначе
			Работаем = Ложь;
		КонецЕсли;
	КонецЦикла;
	
	//Чистим справа
	УдаляемыеСимволы = ":,;\/_";
	Работаем = Истина;
	Пока Работаем Цикл
		Симв = Прав(Результат, 1);
		Если СтрНайти(УдаляемыеСимволы, Симв) <> 0 Тогда
			Результат = Лев(Результат, СтрДлина(Результат) - 1);
		Иначе
			Работаем = Ложь;
		КонецЕсли;
	КонецЦикла;
	
	// Удаление задвоенных пробелов
	Пока СтрНайти(Результат, "  ") <> 0 Цикл
		Результат = СтрЗаменить(Результат, "  ", " ");
	КонецЦикла;
	
	Результат = СокрЛП(Результат);
	
	Возврат Результат;
	
КонецФункции
Показать
17. maxL 20.12.16 21:49 Сейчас в теме
Дмитрий, а возможно сделать такую обработку для УТ 10.3 ?
18. automatizator 170 21.12.16 01:20 Сейчас в теме
(17) Готовы оплатить работу?
19. maxL 21.12.16 19:44 Сейчас в теме
Готовы, цена вопроса ?
20. automatizator 170 22.12.16 00:23 Сейчас в теме
21. user635667 135 07.02.17 07:09 Сейчас в теме
Не пойму что не так - я добавил строку:
Наименование = СтрЗаменить(Наименование,"Вино контролируемого наименования по происхождению","Вино");
Но это условие не работает. Связано это как-то с длинной наименования? Из всех позиций номенклатуры с таким начало самые длинные и у них у всех не срабатывает мое условие.
п.с.
наименование таких позиций выглядит так - Вино контролируемого наименовани по происхождению белое полусладкое "Молоко любимой женщины. Мадонна. Наэ. Ланселот"
ну и плюс мы еще пытаемся добавить емкость, крепость и завод.
22. automatizator 170 07.02.17 10:04 Сейчас в теме
(21) Если это добавлено в конец, то поступает уже раздерганное наименование. Длинные наименования нужно ставить в начало.
23. user635667 135 08.02.17 11:55 Сейчас в теме
Другой вопрос. Я сделал так что бы цыфры в начале удалялись. А потом выеснилось что у некоторых позиций в названиях тоже есть цыфры. И в итоге у меня напиток "Портвей 777" преврящается просто в напиток "Портвейн". Вопрос - как сделать так что бы условие не проверяло наименования которые в скобках. например удалять 7, но не удалять ее там где " 7 ". ????
24. automatizator 170 08.02.17 13:26 Сейчас в теме
(23) Такого обработка не умеет
28. user635667 135 20.04.17 16:36 Сейчас в теме
(24) Приветствую. В последнее время в мои торговые точки часто привозят новый ассортимент. Возникает необходимость в переименовании этих позиций. Пользуюсь данной обработкой т.к. она великолепна. НО мучает рутина постоянно нажимать Поиск, потом вставлять название которое надо переделать и так по многим позициям. Можете сделать отбор по номенклатурным группам? Например можно было бы кидать всю новую номенклатуру в корень справочника Номенклатура, а потом просто в данной обработке все разом их обработать!?!?
29. user635667 135 27.04.17 07:40 Сейчас в теме
Оставьте свое сообщение