XML JSON преобразователь

11.10.17

Интеграция - Файловый обмен (TXT, XML, DBF), FTP

Обработка демонстрирует возможность программного преобразования XML в JSON и обратно без подключения внешних модулей.

Скачать исходный код

Наименование Файл Версия Размер
XML <-> JSON преобразователь:
.epf 10,50Kb
108
.epf 10,50Kb 108 Скачать

Преобразование выполняется полностью средствами 1С, при помощи объектов ЧтениеXML, ЗаписьXML, ЧтениеJSON и ЗаписьJSON, без подключения внешних библиотек. Преобразование учитывает возможность наличия в JSON массивов, значений типа Число, Строка, Булево и возможность наличия атрибутов в XML. Эти параметры настраиваются, все видно на скриншотах.

Все процедуры написаны с инструкцией &НаКлиентеНаСервереБезКонтекста, что позволит использовать их как на клиентской так и на серверной стороне, в общих модулях и на формах. Код открыт.

Обработка не претендует на учет всех возможных случаев и в некоторых сложных ситуациях может приводить к невоспроизводимому результату (преобразование XML->JSON->XML не вернет исходный текст) или приводить к исключению, но все случаи встречавшиеся мне на практике обрабатывает успешно.

Платформа 8.3.9.2233.

См. также

SALE! 10%

[ED3] Обмен для ERP 2.5, КА 2.5, УТ 11.5 БП 3.0, Розница, УНФ и других с EnterpriseData (универсальный формат обмена), правила обмена

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Россия Платные (руб)

Правила в универсальном формате обмена для ERP 2.5, КА 2.5, УТ 11.5, БП 3.0, Розница, УНФ, для последних версий конфигураций. Ссылки на другие конфигурации в описании публикации. Правила совместимы со всеми другими версиями конфигураций новыми и старыми, поддерживающими обмен в формате EnterpriseData. Не требуется синхронного обновления правил после обновления другой конфигурации, участвующей в обмене. Типовой обмен через планы обмена кнопкой Синхронизация вручную или автоматически по расписанию, или вручную обработкой.

25080 руб.

12.06.2017    135597    729    291    

391

SALE! 10%

Перенос данных из ERP 2 / КА 2 / УТ 11 в БП 3.0. Переносятся документы, начальные остатки и справочники

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

Перенос данных из ERP в БП 3 | из КА 2 в БП 3 | из УТ 11 в БП 3 | из ЕРП в БП 3 | В продаже с 2019г. | Воспользовались более 176 предприятий! | Сэкономьте время - используйте готовое решение для перехода! | Перенос разработан в формате КД 2 (правила конвертации данных) | Переносятся все возможные виды документов, начальных остатков и нормативно-справочная информация| Можно опционально выгружать каждую пару "номенклатура+характеристика" как отдельную номенклатуру | Есть выгрузка настроек счетов учета и зарплатных данных из ERP / КА 2 | Можно проверить на вашем сервере перед покупкой, обращайтесь!

38500 34650 руб.

15.04.2019    68884    181    139    

111

Перенос данных из УПП 1.3 в БП 3.0. Переносятся документы (обороты за период), справочная информация и остатки

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Управление производственным предприятием 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:Бухгалтерия предприятия 3.0 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УПП 1.3 (1.3.226.x) и БП 3.0 (3.0.151.x). Правила подходят для версии ПРОФ и КОРП.

28000 руб.

15.12.2021    20639    136    38    

94

Перенос данных из УТ 10.3 в УТ 11.5. Переносятся документы (обороты за период), справочная информация и остатки

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 10 1С:Управление торговлей 11 Россия Управленческий учет Платные (руб)

Перенос данных из 1С:Управление торговлей 10.3 в 1С:Управление торговлей 11.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УТ 10.3 (10.3.87.x) и УТ 11.5 (11.5.16.x).

28000 руб.

23.07.2020    46804    199    64    

162

SALE! 10%

Перенос данных из ERP 2 / КА 2 в ЗУП 3. Переносятся остатки, документы и справочники

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из ERP в ЗУП 3 | из КА 2 в ЗУП | Воспользовались более 79 предприятий! | Предлагаем приобрести готовые правила конвертации данных (КД 2) для переноса остатков, документов с движениями и справочной информации 3 | В продаже с 2020г. | Оперативно обновляем правила до актуальных релизов 1С | Есть перенос начальной задолженности по зарплате и начальной штатной расстановки на выбранную дату | Обороты за прошлые годы (данные для расчета среднего) переносятся свернуто в документ "Перенос данных" | Есть фильтр по организациям | Документы за текущий период переносятся сразу с движениями, поэтому не потребуется делать перерасчеты | Перенос можно проверить перед покупкой, обращайтесь!

48278 43450 руб.

03.12.2020    34464    83    58    

78

SALE! 10%

Перенос данных из БП 3.0 в УНФ 3.0 / УНФ 1.6. Переносятся остатки, документы и справочная информация

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Управление нашей фирмой 3.0 Россия Платные (руб)

В продаже с 2018г. | Воспользовались более 41 предприятия! | Правила конвертации (КД 2) для переноса данных из БП 3 в УНФ | Переносятся все виды документов, начальные остатки и вся возможная справочная информация | Есть фильтр по организациям | Оперативно обновляем на новые релизы | Оказываем техподдержку | В комплект файлов входит инструкция, авторская версия обработки "Универсальный обмен...", актуальные правила переноса данных и архив старых версий переноса | Учет в БП 3 должен быть корректным, некорректные данные не переносятся | Можно бесплатно проверить на вашем сервере до покупки!

50722 руб.

10.07.2018    67792    41    123    

46

Загрузка номенклатуры c картинками (несколько потоков одновременно) и сопутствующими данными в базу и любые документы из yml, xls, xlsx, xlsm, ods, ots, csv для УТ 10.3, УТ 11 (все), БП 3, КА 2, ERP 2, УНФ 1.6/3.0, Розница 2

Загрузка и выгрузка в Excel Логистика, склад и ТМЦ Ценообразование, анализ цен Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 Платные (руб)

Эволюция не стоит на месте - новая удобная версия функциональной обработки для Вашего бизнеса! Что же Вы получаете? Удобный и интуитивно понятный интерфейс с 3-мя этапами работы. 2 режима - автоматический и ручной. Чтение XLSX, XLSM, CSV, XML/YML форматов без офиса, на любом сервере! Визуальное связывание колонок файла и реквизитов простым перетаскиванием колонок. Создание или обновление номенклатуры с иерархией, характеристик, доп. реквизитов, упаковок, загрузка практически неограниченного количества картинок на одну номенклатуру (с возможностью загрузки в несколько потоков одновременно), с хранением в томах или в базе. Загрузка номенклатуры поставщиков или поиск по их данным номенклатуры. Загрузка доп. реквизитов в характеристики. Загрузка штрихкодов с генерацией новых. Создание элементов справочников и ПВХ "на лету" для выбранных реквизитов. (Обновление от 09.04.2024, версия 9.9 - 9.10)

14400 руб.

20.11.2015    151493    367    376    

503

SALE! 10%

Перенос данных из УТ 10.3 в УТ 11 / КА 2 / ERP 2. Переносятся документы, справочники и остатки

Обмен между базами 1C Взаиморасчеты Оптовая торговля Логистика, склад и ТМЦ Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Управление торговлей 10 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Управленческий учет Платные (руб)

Можно проверить до покупки, оставьте заявку! Воспользовались более 268 компаний! Перенос в продаже с 2015г., и мы постоянно работаем над его развитием. Перенос данных из УТ 10.3 в УТ 11 | из УТ 10.3 в КА 2 | из УТ 10.3 в ERP. Предлагаем качественное и проверенное временем решение для перехода с УТ 10.3. Можно перенести начальные остатки, нормативно-справочную информацию и все возможные документы. При выгрузке можно установить отбор по периоду, организациям и складам. При выходе новых релизов конфигураций 1C оперативно выпускаем обновление переноса данных.

50722 45650 руб.

24.04.2015    190830    270    239    

270
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. m-rv 963 11.10.17 17:39 Сейчас в теме
Если будут встречаться ошибки преобразования и вы ими захотите поделиться - доводите пжста текст XML/JSON до минимально необходимого для воспроизведения объема перед отправкой, а также указывайте значения настроек при которых они возникли. Не гарантирую, что отвечу всем, но в целом я заинтересован в том, чтобы этот инструмент работал на как можно лучше.
2. kuzyara 1913 18.10.17 13:34 Сейчас в теме
&НаКлиенте
Функция ПрочитатьXML_(XML)	
	Ветка = Новый Соответствие;
	Значение = "";
	
	Пока XML.Прочитать() Цикл
		ТипУзла = XML.ТипУзла;
		Если ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда
			Имя = XML.Имя;
			Временно = Ветка.Получить(Имя);
			Если Временно = Неопределено Тогда
				Ветка.Вставить(Имя, ПрочитатьXML_(XML));
			Иначе
				Если ТипЗнч(Временно) <> Тип("Массив") Тогда
					нз = новый Массив;
					нз.Добавить(Временно);
					Временно = нз;
					нз = "";
					Ветка.Удалить(Имя);
					Ветка.Вставить(Имя, Временно);
				КонецЕсли;
				Временно.Добавить(ПрочитатьXML_(XML));
			КонецЕсли;
		ИначеЕсли ТипУзла = ТипУзлаXML.КонецЭлемента Тогда
			Возврат ?(ЗначениеЗаполнено(Ветка), Ветка, Значение);
		ИначеЕсли ТипУзла = ТипУзлаXML.Текст Тогда
			Значение = Значение + XML.Значение;
			XML.Прочитать(); //Вычитка закрывающего тега
			Возврат Значение;
		КонецЕсли;
	КонецЦикла;
	
	Возврат Ветка;
КонецФункции
Показать


&НаКлиенте
Функция json(Объект)

    Тип = ТипЗнч(Объект);

    Если
                    Тип = Тип("Массив")
            ИЛИ Тип = Тип("СписокЗначений")

            Тогда

            Количество = Объект.Количество();
            Результат = "[";

            Для н = 0 ПО Количество - 1 Цикл
                    Результат = Результат + json(Объект[н]) + ?(н < Количество - 1, ", ", "");
            КонецЦикла;

            Результат = Результат + "]";
            Возврат Результат;

    ИначеЕсли
                    Тип = Тип("Структура")
            ИЛИ Тип = Тип("Соответствие") Тогда
            н = 0;
            Количество = Объект.Количество();
            Результат = "{";

            Для Каждого Пара Из Объект Цикл
                    Результат = Результат + json(Пара.Ключ) + ": " + json(Пара.Значение) + ?(н < Количество - 1, ", ", "");
                    н = н + 1;
            КонецЦикла;
            Результат = Результат + "}";
            Возврат Результат;

    ИначеЕсли Тип = Тип("ЭлементСпискаЗначений") Тогда
            Возврат json(Объект.Значение);

    ИначеЕсли Тип = Тип("Строка") Тогда
            Результат = Объект;

            Результат = СтрЗаменить(Результат, "\",          "\\");
            Результат = СтрЗаменить(Результат, "/",          "\/");
            Результат = СтрЗаменить(Результат, """",         "\""");
            Результат = СтрЗаменить(Результат, Символы.ВК,   "\r");
            Результат = СтрЗаменить(Результат, Символы.Таб,  "\t");
            Результат = СтрЗаменить(Результат, Символы.ПС,   "\n");

            Возврат """" + Результат + """";

    ИначеЕсли Тип = Тип("Число") Тогда
            Возврат Формат(Объект, "ЧРД=.; ЧН=0; ЧГ=0");

    ИначеЕсли Тип = Тип("Булево") Тогда
            Возврат Формат(Объект, "БЛ=false; БИ=true");

    ИначеЕсли Тип = Тип("Дата") Тогда
            Возврат json(Формат(Объект, "ДФ=yyyy-MM-ddThh:mm:ss"));

    ИначеЕсли
                    Объект = Неопределено
            ИЛИ Объект = Null

            Тогда Возврат "null";

    Иначе
            Возврат json(Строка(Объект));

    КонецЕсли;
КонецФункции
Показать


		ЧтениеXML = Новый ЧтениеXML;
		ЧтениеXML.УстановитьСтроку(ТекстXML);
		СоответствиеXML = ПрочитатьXML_(ЧтениеXML);
		
		ТекстJson = json(СоответствиеXML);
bds22; freegman74; vers139; +3 Ответить
3. Zazamuh 23.07.19 18:16 Сейчас в теме
(2)
СоответствиеXML = ПрочитатьXML_(ЧтениеXML);

ТекстJson = json(СоответствиеXML);


Спасибо дружище!
4. agdam_m 6 19.12.19 09:05 Сейчас в теме
Штатными средствами:

ЗаписьJSON = Новый ЗаписьJSON;
ЗаписьJSON.УстановитьСтроку();
ЗаписатьJSON(ЗаписьJSON, СоответствиеXML);
ТекстJson = ЗаписьJSON.Закрыть();
5. samoswork 30.03.21 14:54 Сейчас в теме
Вот из-за таких ошибок спутники с орбит сходят...

Возврат json(Формат(Объект, "ДФ=yyyy-MM-ddThh:mm:ss"));


Переведите региональные установки на 12-часовой формат (AM/PM) и удивитесь результату :)

Чтобы не копать далеко, сразу говорю... не "hh", а "HH"
bds22; Fruktoved; Eillecho; +3 Ответить
6. MaxS 2850 02.12.22 08:30 Сейчас в теме
Что-то пока не разобрался куда копать
Выгрузил документ 1С в JSON и пытаюсь преобразовать в xml. Обратное преобразование из xml не нужно.
Начало json выглядит так:
{
"#type": "jcfg:DocumentObject.АвансовыйОтчет",
"#value": {
"Ref": "91f310ae-ecd0-11e4-92f1-0050568b35ac",
"DeletionMark": false,
"Date": "2017-04-27T15:28:48",
"Number": "ТД00-000001",

Данная обработка не может это разобрать.
Оставьте свое сообщение