Антонов Игорь | Руководитель отдела разработки | АО "ДальЖАСО"

«Механизм расширений. 2 года в продакшн»

Мы, страховая компания, используем для автоматизации большую конфигурацию «Бухгалтерия некредитных финансовых организаций + Континент страхование». Почти 2000 объектов метаданных, регулярные обновления от трех поставщиков и регулярные собственные наработки. Проблема обновления стоит особенно остро. Чтобы не «сойти с ума» мы сделали ставку на механизм расширений. Что из этого получилось через два года. * Что такое механизм расширений. Актуальный список возможностей; * Плюсы и минусы механизма расширений; * Когда расширений становится слишком много; * Особенности разработки и отладки; * Командная разработка; * HTTP-сервисы в расширениях; * Использовать или не использовать;

XML JSON преобразователь

Обмен - Обмен через XML

Обработка демонстрирует возможность программного преобразования XML в JSON и обратно без подключения внешних модулей.

Преобразование выполняется полностью средствами 1С, при помощи объектов ЧтениеXML, ЗаписьXML, ЧтениеJSON и ЗаписьJSON, без подключения внешних библиотек. Преобразование учитывает возможность наличия в JSON массивов, значений типа Число, Строка, Булево и возможность наличия атрибутов в XML. Эти параметры настраиваются, все видно на скриншотах.

Все процедуры написаны с инструкцией &НаКлиентеНаСервереБезКонтекста, что позволит использовать их как на клиентской так и на серверной стороне, в общих модулях и на формах. Код открыт.

Обработка не претендует на учет всех возможных случаев и в некоторых сложных ситуациях может приводить к невоспроизводимому результату (преобразование XML->JSON->XML не вернет исходный текст) или приводить к исключению, но все случаи встречавшиеся мне на практике обрабатывает успешно.

Платформа 8.3.9.2233.

Скачать файлы

Наименование Файл Версия Размер
XML <-> JSON преобразователь:
.epf 10,50Kb
11.10.17
18
.epf 10,50Kb 18 Скачать

См. также

Комментарии
Сортировка: Древо
1. m-rv 500 11.10.17 17:39 Сейчас в теме
Если будут встречаться ошибки преобразования и вы ими захотите поделиться - доводите пжста текст XML/JSON до минимально необходимого для воспроизведения объема перед отправкой, а также указывайте значения настроек при которых они возникли. Не гарантирую, что отвечу всем, но в целом я заинтересован в том, чтобы этот инструмент работал на как можно лучше.
2. kuzyara 515 18.10.17 13:34 Сейчас в теме
&НаКлиенте
Функция ПрочитатьXML_(XML)	
	Ветка = Новый Соответствие;
	Значение = "";
	
	Пока XML.Прочитать() Цикл
		ТипУзла = XML.ТипУзла;
		Если ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда
			Имя = XML.Имя;
			Временно = Ветка.Получить(Имя);
			Если Временно = Неопределено Тогда
				Ветка.Вставить(Имя, ПрочитатьXML_(XML));
			Иначе
				Если ТипЗнч(Временно) <> Тип("Массив") Тогда
					нз = новый Массив;
					нз.Добавить(Временно);
					Временно = нз;
					нз = "";
					Ветка.Удалить(Имя);
					Ветка.Вставить(Имя, Временно);
				КонецЕсли;
				Временно.Добавить(ПрочитатьXML_(XML));
			КонецЕсли;
		ИначеЕсли ТипУзла = ТипУзлаXML.КонецЭлемента Тогда
			Возврат ?(ЗначениеЗаполнено(Ветка), Ветка, Значение);
		ИначеЕсли ТипУзла = ТипУзлаXML.Текст Тогда
			Значение = Значение + XML.Значение;
			XML.Прочитать(); //Вычитка закрывающего тега
			Возврат Значение;
		КонецЕсли;
	КонецЦикла;
	
	Возврат Ветка;
КонецФункции
Показать


&НаКлиенте
Функция json(Объект)

    Тип = ТипЗнч(Объект);

    Если
                    Тип = Тип("Массив")
            ИЛИ Тип = Тип("СписокЗначений")

            Тогда

            Количество = Объект.Количество();
            Результат = "[";

            Для н = 0 ПО Количество - 1 Цикл
                    Результат = Результат + json(Объект[н]) + ?(н < Количество - 1, ", ", "");
            КонецЦикла;

            Результат = Результат + "]";
            Возврат Результат;

    ИначеЕсли
                    Тип = Тип("Структура")
            ИЛИ Тип = Тип("Соответствие") Тогда
            н = 0;
            Количество = Объект.Количество();
            Результат = "{";

            Для Каждого Пара Из Объект Цикл
                    Результат = Результат + json(Пара.Ключ) + ": " + json(Пара.Значение) + ?(н < Количество - 1, ", ", "");
                    н = н + 1;
            КонецЦикла;
            Результат = Результат + "}";
            Возврат Результат;

    ИначеЕсли Тип = Тип("ЭлементСпискаЗначений") Тогда
            Возврат json(Объект.Значение);

    ИначеЕсли Тип = Тип("Строка") Тогда
            Результат = Объект;

            Результат = СтрЗаменить(Результат, "\",          "\\");
            Результат = СтрЗаменить(Результат, "/",          "\/");
            Результат = СтрЗаменить(Результат, """",         "\""");
            Результат = СтрЗаменить(Результат, Символы.ВК,   "\r");
            Результат = СтрЗаменить(Результат, Символы.Таб,  "\t");
            Результат = СтрЗаменить(Результат, Символы.ПС,   "\n");

            Возврат """" + Результат + """";

    ИначеЕсли Тип = Тип("Число") Тогда
            Возврат Формат(Объект, "ЧРД=.; ЧН=0; ЧГ=0");

    ИначеЕсли Тип = Тип("Булево") Тогда
            Возврат Формат(Объект, "БЛ=false; БИ=true");

    ИначеЕсли Тип = Тип("Дата") Тогда
            Возврат json(Формат(Объект, "ДФ=yyyy-MM-ddThh:mm:ss"));

    ИначеЕсли
                    Объект = Неопределено
            ИЛИ Объект = Null

            Тогда Возврат "null";

    Иначе
            Возврат json(Строка(Объект));

    КонецЕсли;
КонецФункции
Показать


		ЧтениеXML = Новый ЧтениеXML;
		ЧтениеXML.УстановитьСтроку(ТекстXML);
		СоответствиеXML = ПрочитатьXML_(ЧтениеXML);
		
		ТекстJson = json(СоответствиеXML);
Оставьте свое сообщение