Перенос e-mail контрагентов из БП 2.0 в БП 3.0

10.11.17

Функциональные - Управление взаимоотношениями с клиентами (CRM)

Перенос E-Mail и контактной информации в конфигурации БП 3.0 после обновления с 2.0. Из РегистраСведений.УдалитьКонтактнаяИнформация в Табличную часть КонтактнаяИнформация по Контрагентам.

Скачать исходный код

Наименование Файл Версия Размер
Перенос e-mail контрагентов из БП 2.0 в БП 3.0:
.epf 6,40Kb
9
.epf 6,40Kb 9 Скачать

Как известно, контактная информация хранилась в 2.0 в соответствующем регистре сведений.

В 3.0 она хранится в Табличной Части Справочника Контрагенты.

Обработка ищет в регистре сведений записи по контрагентам и в случае если Тип = Адресу электронной почты или содержит в Представлении символ @ то добавляет в табличную часть Контактной информации соответствующую запись.

Код обработки открыт и свободен для доработок. 

В результате работы обработки выводятся Сообщения о добавлении Контрагенту - значения из Регистра сведений.

Тестировалось на Релизе 3.0.54.15, 3.0.52.42, 3.0.51.27.

Обработка

См. также

Перенос данных из УПП 1.3 в ERP 2 / УТ 11 / КА 2. Переносятся документы, справочная информация и остатки

Перенос данных 1C Программист Платформа 1С v8.3 1С:Управление производственным предприятием 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

Перенос документов, начальных остатков и справочной информации из УПП 1.3 в ERP 2 | из УПП 1.3 в УТ 11 | из УПП в КА 2 | Правила конвертации (КД 2) в продаже с 2015 года, постоянно работаем над их развитием | Более 360 предприятий выполнили переход с использованием этого продукта! | Сэкономьте время - используйте готовое решение для перехода! | Позволяет перенести из УПП 1.3 в ERP / УТ 11 / КА 2 всю возможную информацию | В переносе есть фильтр по организации и множество других опциональных параметров выгрузки | Есть несколько алгоритмов выгрузки остатков на выбор

45650 руб.

04.08.2015    161398    361    269    

353

SALE! 10%

Синхронизация и обмен для ERP 2.5, КА 2.5, УТ 11.5 БП 3.0, Розница, УНФ и других с EnterpriseData (универсальный формат обмена), правила обмена

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Россия Платные (руб)

Правила в универсальном формате обмена для ERP 2.5, КА 2.5, УТ 11.5, БП 3.0, Розница, УНФ, для последних версий конфигураций. Ссылки на другие конфигурации в описании публикации. Правила совместимы со всеми другими версиями конфигураций новыми и старыми, поддерживающими обмен и синхронизацию в формате EnterpriseData. Не требуется синхронного обновления правил после обновления другой конфигурации, участвующей в обмене. Типовой обмен через планы обмена кнопкой Синхронизация вручную или автоматически по расписанию, или вручную обработкой.

25080 руб.

12.06.2017    136763    731    292    

393

Перенос данных из УТ 10.3 в УТ 11.5. Переносятся документы (обороты за период), справочная информация и остатки

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 10 1С:Управление торговлей 11 Россия Управленческий учет Платные (руб)

Перенос данных из 1С:Управление торговлей 10.3 в 1С:Управление торговлей 11.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УТ 10.3.87.x и УТ 11.5.16.x

28000 руб.

23.07.2020    47542    205    64    

166

Перенос данных из ERP 2 / КА 2 / УТ 11 в БП 3.0. Переносятся документы, начальные остатки и справочники

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

Перенос данных из ERP в БП 3 | из КА 2 в БП 3 | из УТ 11 в БП 3 | из ЕРП в БП 3 | В продаже с 2019г. | Воспользовались более 176 предприятий! | Сэкономьте время - используйте готовое решение для перехода! | Перенос разработан в формате КД 2 (правила конвертации данных) | Переносятся все возможные виды документов, начальных остатков и нормативно-справочная информация| Можно опционально выгружать каждую пару "номенклатура+характеристика" как отдельную номенклатуру | Есть выгрузка настроек счетов учета и зарплатных данных из ERP / КА 2 | Можно проверить на вашем сервере перед покупкой, обращайтесь!

34650 руб.

15.04.2019    69529    166    141    

112

Перенос данных из БП 3.0 в УТ 11 / КА 2 / ERP 2. Переносятся начальные остатки, документы и справочники

Перенос данных 1C Системный администратор Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

В продаже с 2014г. | Воспользовались более 122 предприятий! | Перенос данных из БП 3.0 в УТ 11 | из БП 3.0 в КА 2 | из БП 3.0 в ERP | Сэкономьте свое время - используйте готовое решение для перехода! | Постоянно работаем над развитием переноса данных | Обновляем на новые релизы 1С | Есть фильтр выгрузки по организациям | Переносятся начальные остатки на выбранную дату, документы за период времени и вся возможная справочная информация | Перенос сделан на технологии КД 2 (правила конвертации данных)

45650 руб.

31.10.2014    233217    91    328    

299

Перенос данных из УПП 1.3 в БП 3.0. Переносятся документы (обороты за период), справочная информация и остатки

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Управление производственным предприятием 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:Бухгалтерия предприятия 3.0 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УПП 1.3 (1.3.227.x) и БП 3.0 (3.0.151.x). Правила подходят для версии ПРОФ и КОРП.

28000 руб.

15.12.2021    21114    138    38    

97

Перенос данных из ERP 2 / КА 2 в ЗУП 3. Переносятся остатки, документы и справочники

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из ERP в ЗУП 3 | из КА 2 в ЗУП | Воспользовались более 79 предприятий! | Предлагаем приобрести готовые правила конвертации данных (КД 2) для переноса остатков, документов с движениями и справочной информации 3 | В продаже с 2020г. | Оперативно обновляем правила до актуальных релизов 1С | Есть перенос начальной задолженности по зарплате и начальной штатной расстановки на выбранную дату | Обороты за прошлые годы (данные для расчета среднего) переносятся свернуто в документ "Перенос данных" | Есть фильтр по организациям | Документы за текущий период переносятся сразу с движениями, поэтому не потребуется делать перерасчеты | Перенос можно проверить перед покупкой, обращайтесь!

43450 руб.

03.12.2020    34832    83    58    

81

SALE! 10%

[ED2] Обмен УПП 1.3, КА 1.1, УТ 10.3 с EnterpriseData (универсальный формат обмена), обработка

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 Платформа 1C v8.2 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Управление производственным предприятием Россия Платные (руб)

Регулярный обмен, выгрузка, перенос из КА 1.1, УПП 1.3, УТ 10.3 для обмена с любыми конфигурациями, поддерживающими обмен в формате EnterpriseData (КД3) - БП 3.0, ERP, КА 2, УТ 11, Розница 2, УНФ 1.6 и другими. Правила для старых и доработанных конфигураций не требуют синхронного обновления и совместимы с новыми и будущими конфигурациями. Обмен по расписанию, через папку, FTP, почту.

14580 руб.

18.02.2016    183666    566    508    

509
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. TrinitronOTV 15 11.11.17 14:07 Сейчас в теме
Без вашей обработки адреса что ли не переносятся?
2. Guyer 20 11.11.17 19:31 Сейчас в теме
1. Адреса переносятся штатным способом при обновлении инф базы
2. Код обработки открыт и изменив всего одну строчку Вы можете спокойно перенести адреса
3. Чуть позже сделаю более полную версию переноса
3. Светлый ум 406 25.01.19 12:30 Сейчас в теме
-1
Меняйте заголовок публикации, вашу обработку - нельзя назвать переносом!

- Вы сделали конвертацию данных архивного регистра в данные справочника - в рамках одной конфигурации.

Весь код обработки:

&НаСервере
Процедура ПеренестиНаСервере()
	
	
	Запрос = Новый Запрос;
	Запрос.Текст = 
		"ВЫБРАТЬ
		|	УдалитьКонтактнаяИнформация.Представление КАК Представление,
		|	УдалитьКонтактнаяИнформация.Тип КАК Тип,
		|	УдалитьКонтактнаяИнформация.Вид КАК Вид,
		|	УдалитьКонтактнаяИнформация.Объект КАК Объект
		|ИЗ
		|	РегистрСведений.УдалитьКонтактнаяИнформация КАК УдалитьКонтактнаяИнформация";
	
	РезультатЗапроса = Запрос.Выполнить();
	
	ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
	
	Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
		Если ТипЗнч(ВыборкаДетальныеЗаписи.Объект.Ссылка)=Тип("СправочникСсылка.Контрагенты") Тогда
			Если ВыборкаДетальныеЗаписи.Тип=Перечисления.ТипыКонтактнойИнформации.АдресЭлектроннойПочты Тогда			
				Кон=ВыборкаДетальныеЗаписи.Объект.Ссылка.ПолучитьОбъект();
				ДобавитьЗ=Кон.КонтактнаяИнформация.Добавить();
				ДобавитьЗ.АдресЭП=ВыборкаДетальныеЗаписи.Представление;
				ДобавитьЗ.Тип=ВыборкаДетальныеЗаписи.Тип;
				ДобавитьЗ.Вид=Справочники.ВидыКонтактнойИнформации.EmailКонтрагенты;
				ДобавитьЗ.Представление=ВыборкаДетальныеЗаписи.Представление;
				Кон.Записать();				
				Сообщить("Добавлен "+ВыборкаДетальныеЗаписи.Объект.Ссылка+" "+ СокрЛП(ДобавитьЗ.Тип)+" "+СокрЛП(ВыборкаДетальныеЗаписи.Представление));
			КонецЕсли;
			
			Если ВыборкаДетальныеЗаписи.Тип=Перечисления.ТипыКонтактнойИнформации.Телефон Тогда			
				Кон=ВыборкаДетальныеЗаписи.Объект.Ссылка.ПолучитьОбъект();
				ДобавитьЗ=Кон.КонтактнаяИнформация.Добавить();
				ДобавитьЗ.Тип=ВыборкаДетальныеЗаписи.Тип;
				ДобавитьЗ.Вид=Справочники.ВидыКонтактнойИнформации.ТелефонКонтрагента;
				ДобавитьЗ.Представление=ВыборкаДетальныеЗаписи.Представление;
				Сообщить("Добавлен "+ВыборкаДетальныеЗаписи.Объект.Ссылка+" "+ СокрЛП(ДобавитьЗ.Тип)+" "+СокрЛП(ВыборкаДетальныеЗаписи.Представление));
				Кон.Записать();				
			КонецЕсли;
			
			Если НЕ СтрНайти(ВыборкаДетальныеЗаписи.Представление,"@")=0 Тогда			
				Кон=ВыборкаДетальныеЗаписи.Объект.Ссылка.ПолучитьОбъект();
				ДобавитьЗ=Кон.КонтактнаяИнформация.Добавить();
				ДобавитьЗ.Тип=ВыборкаДетальныеЗаписи.Тип;
				ДобавитьЗ.Вид=Справочники.ВидыКонтактнойИнформации.EmailКонтрагенты;;
				ДобавитьЗ.Представление=ВыборкаДетальныеЗаписи.Представление;
				Сообщить("Добавлен "+ВыборкаДетальныеЗаписи.Объект.Ссылка+" "+ СокрЛП(ДобавитьЗ.Тип)+" "+СокрЛП(ВыборкаДетальныеЗаписи.Представление));
				Кон.Записать();				
			КонецЕсли;

			
		КонецЕсли;
		
		
	КонецЦикла;
	
	

КонецПроцедуры

&НаКлиенте
Процедура Перенести(Команда)
	ПеренестиНаСервере();
КонецПроцедуры
Показать
Оставьте свое сообщение