Исправление ошибки закрытия месяца УТ 11.4: "Обнаружены возвращенные от клиента товары, отсутствующие в документе реализации организации ..."

25.01.18

Учетные задачи - Оптовая торговля

Закрытие месяца предназначено для проведения комплекса операций по фактическому расчету себестоимости товаров и работ в заданном периоде. Для закрытия месяца необходимо выполнить последовательность регламентных операций, перечисленных в форме "Закрытие месяца" в разделе "Финансовый результат и контроллинг". Если при выполнении операций в автоматическом режиме возникают ошибки, то их нужно исправлять вручную.

Скачать исходный код

Наименование Файл Версия Размер
Отвязка возврата от реализации в УТ 11.4
.epf 6,16Kb
24
.epf 6,16Kb 24 Скачать
Одна из ошибок: "Обнаружены возвращенные от клиента товары, отсутствующие в документе реализации организации ...". По данной ошибке указан комментарий "При изменении задним числом документа реализации товарный состав документа возврата от клиента может рассинхронизироваться с реализацией. В этом случае в документе возврата необходимо или указать корректный документ реализации или вообще не указывать его." При нажатии кнопки Подробнее открывается документ возврата, но указать корректный документ реализации или вообще не указывать его в существующем возврате вручную не удается.

Для отвязки возврата от реализации написал небольшую обработку со следующим кодом:
Процедура ОтвязатьНаСервере()
	ВозвратТоваровОтКлиентаОбъект = ВозвратТоваровОтКлиента.ПолучитьОбъект();
	ВозвратТоваровОтКлиентаОбъект.Комментарий = ВозвратТоваровОтКлиентаОбъект.Комментарий + " Создан на основании: " + ВозвратТоваровОтКлиентаОбъект.ДокументРеализации;
	ВозвратТоваровОтКлиентаОбъект.ДокументРеализации = НЕОПРЕДЕЛЕНО;
	Для каждого СтрокаТовары Из ВозвратТоваровОтКлиентаОбъект.Товары Цикл
		СтрокаТовары.ДокументРеализации = НЕОПРЕДЕЛЕНО;
		СтрокаТовары.СпособОпределенияСебестоимости = Перечисления.СпособыОпределенияСебестоимости.ИзТекущегоДокумента;
	КонецЦикла;
	
	Для каждого СтрокаВидыЗапасов Из ВозвратТоваровОтКлиентаОбъект.ВидыЗапасов Цикл
		СтрокаВидыЗапасов.ДокументРеализации = НЕОПРЕДЕЛЕНО;
		СтрокаВидыЗапасов.СпособОпределенияСебестоимости = Перечисления.СпособыОпределенияСебестоимости.ИзТекущегоДокумента;
	КонецЦикла;

	ВозвратТоваровОтКлиентаОбъект.Записать(РежимЗаписиДокумента.Проведение,РежимПроведенияДокумента.Неоперативный);
КонецПроцедуры

 

Тестировалось на 1С:Управление торговлей 11.4.1.273.

УТ 11.4 Управление торговлей

См. также

Автоматический заказ поставщику в 1С: загрузка прайсов и анализ цен поставщиков для УТ 10.3, УТ 11, КА2, УНФ, УПП, ERP, Розница 2

Бюджетирование и планирование Оптовая торговля Розничная торговля Логистика, склад и ТМЦ Анализ продаж Платформа 1С v7.7 Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Управление нашей фирмой 1.6 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Беларусь Украина Россия Казахстан Управленческий учет Платные (руб)

Система управления запасами для 1С помогает работать с запасами правильно: автоматически рассчитывает потребность и делает заказ поставщику, загружает прайсы, перемещает товары по филиалам, анализирует продажи и позволяет управлять ассортиментом.

28500 руб.

21.04.2017    91871    116    40    

204

ЕГАИС++. Опт, производство, импорт

Оптовая торговля Розничная торговля Обмен с ГосИС Платформа 1С v8.3 1С:Управление торговлей 10 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Рестораны, кафе и фаст-фуд Россия Бухгалтерский учет Управленческий учет Акцизы Платные (руб)

Полнофункциональное расширение (ранее известное как Модуль 1С-ЕГАИС) для взаимодействия типовых конфигураций 1С и ЕГАИС, предоставляющее максимум возможностей по работе с УТМ. Получение и отправка ТТН, отправка акта о постановке на баланс и акта о списании. Получение остатков. Загрузка и сопоставление номенклатуры и контрагентов. Оправка в ЕГАИС отчетов о производстве и импорте.

8970 руб.

15.12.2015    167302    724    362    

391

Обмен с системой ЦРПТ (Универсальная конфигурация ХамелеонЦРПТ + маркировка табака, обуви, одежды, лекарств, фото, молока, духов(парфюма), питьевой воды, велосипедов и шин)

Оптовая торговля Розничная торговля Обмен с ГосИС Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия Бухгалтерский учет Управленческий учет Платные (руб)

Данная публикация создана для помощи разработчикам, интеграторам и другим заинтересованным лицам по настройке системы маркировки обуви, одежды, лекарств, табака, фото, молока, духов(парфюма), питьевой воды, велосипедов и шин. Смело задавайте нам вопросы по работе с ЦРПТ, GS1, ЭДО, Национальным каталогом, мы накопили достаточно большую базу знаний по данным темам и готовы ответить на все Ваши вопросы.

104000 руб.

18.03.2019    111078    36    114    

179

Перенос данных из УТ 10.3 в УТ 11 / КА 2 / ERP 2. Переносятся документы, справочники и остатки

Перенос данных 1C Взаиморасчеты Оптовая торговля Логистика, склад и ТМЦ Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Управление торговлей 10 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Управленческий учет Платные (руб)

Можно проверить до покупки, оставьте заявку! Воспользовались более 268 компаний! Перенос в продаже с 2015г., и мы постоянно работаем над его развитием. Перенос данных из УТ 10.3 в УТ 11 | из УТ 10.3 в КА 2 | из УТ 10.3 в ERP. Предлагаем качественное и проверенное временем решение для перехода с УТ 10.3. Можно перенести начальные остатки, нормативно-справочную информацию и все возможные документы. При выгрузке можно установить отбор по периоду, организациям и складам. При выходе новых релизов конфигураций 1C оперативно выпускаем обновление переноса данных.

45650 руб.

24.04.2015    191609    135    239    

270

SALE! 20%

Загрузка документов и номенклатуры из Excel в 1С "одним нажатием": УПД, ТОРГ-12, отчеты маркетплейсов, заказы, счета, прайсы

Загрузка и выгрузка в Excel Оптовая торговля Платформа 1С v8.3 Управляемые формы Платформа 1C v8.2 Конфигурации 1cv8 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 Бухгалтерский учет Управленческий учет Платные (руб)

Универсальная обработка для загрузки документов из Excel в 1С одним нажатием. Не требует указания параметров (номера колонок, номер первой строки таблицы и т.д.) и предварительной настройки. Просто выбираете файл Excel, документ 1С и нажимаете кнопку "Загрузить". Обработка сама находит таблицу в файле Excel, необходимые для загрузки данные в ней (номенклатура, количество, НДС, цена, сумма) и загружает ее в 1С. Вместе с номенклатурой может найти контрагента, номер и дату документа, штрих-коды, серии ГТД, страну и т.д. Распознает документы ЛЮБОЙ ФОРМЫ (УПД, ТОРГ-12, заказ, отчет комиссионера и т.д.). Не требует MS Office. Для поиска таблиц используются методы эвристического поиска. Загружает только то, что нужно, т.е. пропускает повторы шапки таблицы, заголовки, промежуточные итоги, подписи и т.д. Содержит модуль работы с электронной почтой и api-загрузчик отчетов о продажах маркетплейсов.

5000 4000 руб.

09.11.2016    218217    939    886    

950
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. Prapor507 02.02.18 19:46 Сейчас в теме
Там где делается эта проверка в запросе проверяется что реквизит "ВидыЗапасовОтгрузка" табличной части возврата совпадает с тем видом запасов, который в проводке реализации по ТоварыОрганизаций. Проблема в том, что например в моей версии 11.4.2.106 ни в одном возврате этот реквизит не заполнен, соответственно я написал обработку, которая его заполняет тем видом запаса, что был в реализации. Ошибки исчезли. Так имхо правильнее.
insurgut; VictorKa; eeeio; +3 Ответить
2. VictorKa 12 05.04.18 11:06 Сейчас в теме
(1)
"ВидыЗапасовОтгрузка" табличной части возврата

Спасибо, помогло!
Только реквизит "ВидЗапасовОтгрузки" в табличной части "ВидыЗапасов" возврата.
3. insurgut 207 19.08.19 12:18 Сейчас в теме
При помощи расширения вывел на отдельную вкладку табличную часть ВидыЗапасов с колонками ВидыЗапасов и ВидЗапасовОтгрузки.

ВидЗапасовОтгрузки - была пустой. Заполнил тем, что указано в колонке ВидыЗапасов - ошибка ушла.
4. Xershi 1490 05.11.19 10:14 Сейчас в теме
Тут вопрос немного в другом! Как запретить удалять строки, если был возврат?
Пока анализировал вопрос набросал план доработки.
В модуле формы перед записью на сервере проверяем новый ли это документ.
Если документ уже создан ранее, то проверяет табличную часть товаров возврата на наличие ссылки на документ или регистр товаров организаций.
Если что-то нашли, то сравниваем с таблицей товаров реализации. Если чего-то нет делаем отказ!
5. insurgut 207 14.11.23 11:34 Сейчас в теме
2023 год, что-то в коде поменяли видимо, т.к. проблема вернулась. Предлагаемые решения отвязки возврата от реализации - вообще путь в никуда. Это и не правильно, и некорректно с какой стороны не посмотри. Начал разбираться. Сейчас в видах запасов Идентификатор строки в возврате не соответствует идентификатору строки реализации, в результате как бы ты не заполнял виды запасов - проводки формируются по своему. В итоге через расширение при записи возврата сделал такую доработку:

&После("ПередЗаписью")
Процедура Дополнительно_ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
	Если ЗначениеЗаполнено(ДокументРеализации) Тогда
		Для Каждого СтрокаВЗ Из ВидыЗапасов Цикл
			ПараметрыОтбора = Новый Структура;
			ПараметрыОтбора.Вставить("АналитикаУчетаНоменклатуры", СтрокаВЗ.АналитикаУчетаНоменклатуры);
			СтрокиРеализации = ДокументРеализации.ВидыЗапасов.НайтиСтроки(ПараметрыОтбора);
			Если СтрокиРеализации.Количество() > 0 Тогда
				СтрокаВЗ.ВидЗапасовОтгрузки = СтрокаВЗ.ВидЗапасов;
				СтрокаВЗ.АналитикаУчетаНоменклатурыОтгрузки = СтрокаВЗ.АналитикаУчетаНоменклатуры;
				СтрокаВЗ.ИдентификаторСтроки = СтрокиРеализации[0].ИдентификаторСтроки;
			КонецЕсли;
		КонецЦикла;
	КонецЕсли;
КонецПроцедуры
Показать


После просто перепровели возвраты. Ошибки ушли. А проблема да, была в изменении задним числом реализаций.
6. dop38 15.12.23 14:10 Сейчас в теме
(5) Хорошее решение, но мне не помогло. Выяснилось, что расчет себестоимости включён с 01.2023, реализация сделана в 11.2022, Возврат сделан в 01.2023. Итог - раскоряка, хоть обсинхронизируй реквизиты, даже пробовал создать новый возврат из интерфейса на основании реализации - та же ошибка.
Причём ещё недавно всё работало отлично и месяцы закрывались. Обновились, блин.
Оставьте свое сообщение