СБРФ:Эквайринговые терминалы: подключение обработки к новым конфигурациям. Розница 2.2

03.02.19

Учетные задачи - Розничная торговля

В новой конфигурации Розница 2.2.11.24 нет возможности подключить эквайринг от Сбербанка SBRF.DLL (3, 7 параметров).

Скачать файл

ВНИМАНИЕ: Файлы из Базы знаний - это исходный код разработки. Это примеры решения задач, шаблоны, заготовки, "строительные материалы" для учетной системы. Файлы ориентированы на специалистов 1С, которые могут разобраться в коде и оптимизировать программу для запуска в базе данных. Гарантии работоспособности нет. Возврата нет. Технической поддержки нет.

Наименование SM По подписке [?] Купить один файл
Розница 2.2 (СБРФ:Эквайринговые терминалы) подключение обработки к новым конфигурациям.:
.rar 47,42Kb
44
44
1 SM
Скачать Купить за 1 850 руб.

Включить использование обработки Сбербанк эквайринговые терминалы можно с помощью обработки ТерминалСБРФВключить.epf (спасибо independ). Но в новых конфигурациях нет возможности работать с эквайрингом от Сбербанка.

Для того чтобы эквайринг работал, нужно добавить Общий модуль ПодключаемоеОборудованиеСБРФЭквайринговыеТерминалыКлиент и общую форму ФормаНастройкиСБРФЭквайринговыеТерминалы. А также изменить код в Общем модуле МенеджерОборудованияКлиент как показано в примере. ВНИМАНИЕ - все изменения в модуле сопровождаются строками //++ и //--.

Тестировалось на конфигурации Розница  2.2.11.24.

Розница Эквайринг Сбербанк SBRF.DLL СБРФ Розница 2.2

См. также

Внешние источники данных Программист Бизнес-аналитик Пользователь Платформа 1С v8.3 Управляемые формы Анализ и прогнозирование Конфигурации 1cv8 Узбекистан Беларусь Кыргызстан Молдова Россия Казахстан Платные (руб)

Готовое решение для автоматической выгрузки данных из 1С 8.3 в базу данных ClickHouse, PostgreSQL или Microsoft SQL для работы с данными 1С в BI-системах. «Экстрактор данных 1С в BI» работает со всеми типовыми и нестандартными конфигурациями 1С 8.3 и упрощает работу бизнес-аналитиков. Благодаря этому решению, специалистам не требуется быть программистами, чтобы легко получать данные из 1С в вашей BI-системе.

15.11.2022    16366    15    SQV0    48    

35

Бюджетирование и планирование Оптовая торговля Розничная торговля Логистика, склад и ТМЦ Анализ продаж Пользователь Платформа 1С v7.7 Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Управление нашей фирмой 1.6 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Беларусь Украина Россия Казахстан Управленческий учет Платные (руб)

Система управления запасами для 1С помогает работать с запасами правильно: автоматически рассчитывает потребность и делает заказ поставщику, загружает прайсы, перемещает товары по филиалам, анализирует продажи и позволяет управлять ассортиментом.

28500 руб.

21.04.2017    93364    119    40    

210

Оптовая торговля Розничная торговля Обмен с ГосИС Бухгалтер Платформа 1С v8.3 1С:Управление торговлей 10 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Рестораны, кафе и фаст-фуд Россия Бухгалтерский учет Управленческий учет Акцизы Платные (руб)

Полнофункциональное расширение (ранее известное как Модуль 1С-ЕГАИС) для взаимодействия типовых конфигураций 1С и ЕГАИС, предоставляющее максимум возможностей по работе с УТМ. Получение и отправка ТТН, отправка акта о постановке на баланс и акта о списании. Получение остатков. Загрузка и сопоставление номенклатуры и контрагентов. Оправка в ЕГАИС отчетов о производстве и импорте.

8970 руб.

15.12.2015    168478    755    364    

394

ККМ Кассовые операции Розничная торговля Системный администратор Программист Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Бухгалтерия государственного учреждения 1С:Бухгалтерия 1.6 1С:Бухгалтерия автономного учреждения 1С:CRM ПРОФ, КОРП Россия Платные (руб)

Универсальная обработка для обслуживания любых фискальных регистраторов (ККТ), в том числе Веб сервер АТОЛ. Работает в соответствии с 54-ФЗ. (ФФД 1.0, ФФД 1.05, ФФД 1.1). Подключайте любую онлайн кассу к практически любой конфигурации. Нет необходимости обновлять 1С. Можно бесплатно скачать и протестировать. Может работать одновременно с несколькими онлайн-кассами, либо одной с разных рабочих мест. (через RDP, TCP\IP или веб-сервер) Позволяет разделить один чек сразу на несколько ККТ или на несколько систем налогообложения. Поддерживает разрешительный режим. Можно настроить собственный шаблонов чека. Можно использовать эквайринг там, где он не поддерживается. Работает на LINUX и Windows ЭМУЛЯТОР + ЭКВАЙРИНГ + МАРКИРОВКА + ПОДДЕРЖКА ФФД 1.2

6000 руб.

27.02.2017    786967    4739    9507    

2812

Розничная торговля Маркетплейсы Программист Платформа 1С v8.3 1С:Розница 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Розничная и сетевая торговля (FMCG) Россия Управленческий учет Платные (руб)

Модуль для интеграции 1С с сервисом СберМаркет/Купер. Предназначен для обмена данными из торговых точек розничных сетей из баз данных 1С в базы данных СберМаркет/Купер, для отображения информации по товарам, остаткам, ценам, заказам и статусам заказов. Позволяет оперативно начать работать с сервисом СберМаркет, существенно повысить продажи и лояльность клиентов.

35000 руб.

14.10.2022    8559    15    13    

10

Оптовая торговля Розничная торговля Обмен с ГосИС Программист Бухгалтер Пользователь Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия Бухгалтерский учет Управленческий учет Платные (руб)

Данная публикация создана для помощи разработчикам, интеграторам и другим заинтересованным лицам по настройке системы маркировки обуви, одежды, лекарств, табака, фото, молока, духов(парфюма), питьевой воды, велосипедов и шин. Смело задавайте вопросы по работе с ЦРПТ, GS1, ЭДО, Национальным каталогом, накопили достаточно большую базу знаний по данным темам и готовы ответить на все Ваши вопросы.

5000 руб.

18.03.2019    111702    28    114    

181
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. SpartakM 72 03.02.19 19:57 Сейчас в теме
что за чушь? как это нельзя? все работает из коробки без проблем!!!
2. Belou8rs 03.02.19 20:47 Сейчас в теме
3. andrey7617 57 03.02.19 22:09 Сейчас в теме
Значит релиз у вас более ранний. Читайте внимательно Розница 2.2.11.24 если более ранняя то да все работает. В новом Нет.
4. SpartakM 72 03.02.19 22:16 Сейчас в теме
(3)именно этот, он крайний на текущий момент. все работает!!! после обновления нужно перенастроить терминал, драйвера послетали у меня. но после подключения - все работает..
11. s_tagil@mail.ru 39 15.07.19 14:05 Сейчас в теме
У нас тоже после обновления (1С Розница 2.2.11 базовая) терминал перестал работать. 1С:Эквайринговые терминалы Сбербанк - не хочет устанавливаться - пишет при установке, что компонента не обнаружена. Винда 10-ка 64 битная, файловый вариант. Не подскажете куда копать?
5. andrey7617 57 03.02.19 22:37 Сейчас в теме
Через драйвер (СБРФ:Эквайринговые терминалы) ??? - не может быть
Скорей всего вы говорите про драйвер (1С:Эквайринговые терминалы Сбербанк) - этот драйвер остался да
6. SpartakM 72 03.02.19 22:49 Сейчас в теме
(5)в чем принципиальная разница?
7. mafey 2 04.02.19 20:38 Сейчас в теме
в 2.2.11.24 все работает без проблем с драйвером 1С:Эквайринговые терминалы Сбербанк, 1с давно писали, что уберут драйвер СБРФ
SpartakM; +1 Ответить
8. smsfor1c 81 13.03.19 20:35 Сейчас в теме
Для УТ 11.4.7.114 решение подошло как для родной. Новый драйвер "1С:Эквайринговые терминалы Сбербанк", к сожалению, не позволяет работать на одном РМК с двумя терминалами (обращается всегда, похоже, к первому инициализированному) поэтому пришлось "вкрутить" обратно старый "СБРФ:Эквайринговые терминалы"
13. XOCTEP 117 05.12.19 12:50 Сейчас в теме
(8)
работать на одном РМК с двумя терминалами (обращается всегда, похоже, к первому инициализированному) поэтому пришлось "вкрутить" обратно ста

У нас сейчас такая проблема в Рознице 2.2.13.8. Терминал физически один, настроен на 2 организации. В рознице добавил один экземпляр оборудования и указал номер секции "1" - т.е. постоянный выбор отдела (ИП или ООО). Привязал его к 2м кассам ККМ, при оплате не дает выбрать организацию, сразу шлет на ООО. Если создать 2 экземпляра ЭТ с номерами отделов 0 и 1, то всегда шлет оплату на ИП. Обработка обслуживания "1С:Эквайринговые терминалы Сбербанк". Я так понимаю, вариант только в использовании старого драйвера СБРФ?
14. independ 1540 05.12.19 13:03 Сейчас в теме
(13) нужно сделать 2 каталога с банковским ПО типа c:\sc552, c:\sc552-2, и в каждом настроить файл pinpad.ini, в нем указать DEPARTMENT=0 для 1-го каталога, DEPARTMENT=1 для 2-го (возможно 1 и 2 вместо 0 и 1). В Рознице создать 2 эквайринг.терминала и указать пути к c:\sc552, c:\sc552-2 + указать номера отделов
16. XOCTEP 117 05.12.19 16:21 Сейчас в теме
(14) а одним каталогом не обойтись? Спец СБ сделал один каталог и в его утилите после прикладывания картой можно выбрать организацию.
19. smsfor1c 81 05.12.19 21:00 Сейчас в теме
(16) Попробуй тогда так:один физический терминал с драйверами в папке sc552.
В 1С пропиши два ЭТ (один со старым, другой с новым драйвером). Не забудь зарегистрировать библиотеки из sc552.
И тогда останется не ошибиться при выборе организации в утилите при оплате картой:
(16)
Спец СБ сделал один каталог и в его утилите после прикладывания картой можно выбрать организацию.
20. XOCTEP 117 06.12.19 07:57 Сейчас в теме
(19)
1С пропиши два ЭТ

А если оба со старым драйвером? Или это обязательно, чтобы были разные драйвера?
21. smsfor1c 81 06.12.19 08:44 Сейчас в теме
(20) Попробуй и так - в принципе при работе с любым из ЭТ в таком варианте так или иначе в одну папку программа обращаться будет. Может проканает.
15. smsfor1c 81 05.12.19 13:14 Сейчас в теме
(13)Да, при наличии двух терминалов новый драйвер будет отсылать только к одному из подключенных, в не зависимости от того, какой фактически выбран. Вот такой вот косяк. Выход - использование старого драйвера.
17. XOCTEP 117 05.12.19 16:21 Сейчас в теме
(15) у нас подключен фактически 1 терминал, просто в него зашито 2 счета ООО и ИП
18. independ 1540 05.12.19 17:43 Сейчас в теме
(17) никто не запрещает сделать столько каталогов сколько прошито организаций в терминале, смысл в том, что при указании параметра department в pinpad.ini не нужно выбирать организацию, и единственный способ разделить - это создать несколько pinpad.ini в разных каталогах
Такая модель используется во фронтоле, в 1С рознице она тоже применима
9. vertkov2010 3 23.03.19 15:26 Сейчас в теме
Не работает в версии 2.2.11.24
{ОбщаяФорма.ФормаНастройкиСБРФЭквайринговыеТерминалы.Форма(39)}: Значение не является значением объектного типа (РабочееМесто)
Элементы.ТестУстройства.Видимость = (ПараметрыСеанса.РабочееМестоКлиента = Идентификатор.РабочееМесто);
10. andrey7617 57 24.03.19 19:44 Сейчас в теме
Не работает в версии 2.2.11.24
{ОбщаяФорма.ФормаНастройкиСБРФЭквайринговыеТерминалы.Форма(39)}: Значение не является значением объектного типа (РабочееМесто)
Элементы.ТестУстройства.Видимость = (ПараметрыСеанса.РабочееМестоКлиента = Идентификатор.РабочееМесто);

Код посмотрите внимательно ... Терминал там называется "TERMINAL"
12. nvl 129 06.08.19 17:17 Сейчас в теме
Я бы сказал так и все ок в этом месте - ,(ПараметрыСеанса.РабочееМестоКлиента = Параметры.Идентификатор.РабочееМесто) ,
но вылетает далее в другом правда версия у меня 2.2.13,8
23. tolikchus 27.10.20 16:13 Сейчас в теме
Искал настройку фронтол на 2 организации, нашел данный пост. Извиняюсь что с опозданием.
Проблем с новым драйвером СБРФ от 1С в принципе никаких проблем нет, в т.ч. на 2 организации (по слэнгу СБ 2 отдела или мультимерчант).
Библиотеки sbrf.dll, sbrfcom.dll теперь регистрировать не обязательно.
sbrfcom.dll на 3 или 7 параметров теперь не актуально, в настройках 1С для терминала просто указывается путь до ПО Сбербанка.
Символ частичной отрезки (в 1С по умолчанию 22). Если у вас фискальный регистратор без автоотрезчика, то по барабану.
Если автоотрезчик есть, то символ частичной отрезки должен совпадать с параметром PrinterEnd в файле pinpad.ini (данный файл находится в папке с ПО Сбербанка).
Что касается 2-х или более организаций. Поле номер отдела именно за это и отвечает. Тут есть одно но.
По терминологии СБ пример. ООО "Рога и копыта" и ИП Козликов. ООО 1 отдел, ИП 2 отдел.
В данном случае в 1С необходимо прописать: ООО 0 отдел, ИП 1 отдел (в СБ нумерация начинается с 1, в 1С с нуля). Бывали случаи когда у СБ были настроены 1 и 3 отдел (2 был, но закрыли). В таком случае в 1С ставим 0 и 2 отдел. Номера отделов, как настроены в СБ, можно узнать у обслуживающего инженера.
P.S. Параметр файла pinpad.ini (он находится в папке с ПО СБ)
Может пригодиться при переносе на другой комп без вызова инженера.
Достаточно софт СБ скопировать на новый комп, установить драйвера терминала (если терминал работает по USB, номер порта проверяем в диспетчере устройств). Драйвера терминала как правило тоже лежат в папке с ПО Сбербанка (типа папки Driver). Если COM подключение, драйвер не обязателен. Если Ethernet и сетевые настройки не менялись, то ничего менять не надо.
Если номер СОМ порта сменился, либо USB подключение. И. ВАЖНО!!! Часто бывает ничего не меняли, но, переключили на другой юсб порт. Может смениться виртуальный СОМ порт терминала в диспетчере устройств.

В файле pinpad.ini за номер порта отвечает переменная ComPort
Просто ставим ComPort = <номер порта в диспетчере устройств>
isenseu; deaddy64; KPAMOP; Danilov; andrey7617; +5 Ответить
24. KPAMOP 21 14.12.20 16:50 Сейчас в теме
А не подскажите, добрые люди, где на конец 2020-ого года берут драйверы на терминалы Сбербанка?
25. burgomister 59 12.01.21 15:43 Сейчас в теме
(24) поддерживаю. В УТ 11.4.13.103 не могу установить драйвер эквайринга сбербанка. фантастика. спецы из сбербанка говорят у них всё нормально, это у 1с. А до спецов из 1с не достучаться, как до небес.
27. guglion 2 29.09.21 12:56 Сейчас в теме
(25) Можно так : В обычном модуле приложения написать соединение с объектом Сбербанка:
1. В начале модуля обозначить глобальные переменные:

///// подключение эквайринга СБ РФ
Перем МодульОбъектаДрайвера Экспорт; // Модуль Объекта Обработки.СберБанкЭквайринговаяСистема
Перем ОбъектДрайвераСБРФ Экспорт; // Эквайринговый терминал СБ РФ
Перем Драйвер Экспорт;
Перем ОшибкиПриИсполненииСБРФ Экспорт;

////// Переменная ECR - это объект ККМ, чтобы печатать на ней все что угодно, в том числе слип чеки
Перем ECR Экспорт;

2. В удобном месте пишем функцию подключения

// Функция создаёт объект драйвера. Все это скопировано из Модуля Объекта Обработка.СберБанкЭквайринговаяСистема
// (API v2.0)
//
// Параметры:
// Объект - <*>
// - Выходной параметр; объект драйвера торгового
// оборудования.
//
// Модель - <Строка>
// - Модель торгового оборудования, для которой
// создаётся экземпляр драйвера.
//
// Параметры - <Структура>
// - Параметры подключаемого торгового оборудования.
//
// Возвращаемое значение:
// <ПеречислениеСсылка.ТООшибки*> - Результат работы функции.
//
Функция СоздатьОбъектДрайвераСБРФ(Объект, Модель, Параметры) Экспорт

Результат = мНетОшибки;
ОписаниеОшибки = "";

ШиринаСлипЧека = Константы.ШиринаСлипЧекаСБРФ.Получить();//Неопределено;
СовместимыеВерсии = 2.05;//Неопределено;

/// Это уже дописано
Параметры = Новый Структура;
Параметры.Вставить("ШиринаСлипЧека", ШиринаСлипЧека);
Параметры.Вставить("СовместимыеВерсии", СовместимыеВерсии);
//Это уже дописано


Параметры.Свойство("ШиринаСлипЧека", ШиринаСлипЧека);
Параметры.Свойство("СовместимыеВерсии", СовместимыеВерсии);

Если ШиринаСлипЧека = Неопределено Или СовместимыеВерсии = Неопределено Тогда
Результат = мОшибкаПараметровНастройки;
Предупреждение("ОшибкаПараметровНастройки");
Иначе
Попытка
// Подключение внешней компоненты
ПодключитьВнешнююКомпоненту("AddIn.SBRFCOMObject");
Драйвер = Новый("AddIn.SBRFCOMExtension");
//Предупреждение("Драйвер эквайрингового терминал СБ РФ загружен.");
Исключение
Результат = мОшибкаЗагрузкиДрайвера;
ОписаниеОшибки = "Невозможно подключить внешнюю компоненту.
| Проверьте, что внешняя компонента корректно установлена и имеет ту же версию,
| что и требуемая обработкой обслуживания.";
Предупреждение(ОписаниеОшибки);
КонецПопытки;

Если Результат = мНетОшибки Тогда
Попытка
мВерсияИзДрайвера = Неопределено;//Драйвер.ПолучитьНомерВерсии(); // в драйвере получение версии на данный момент не реализовано
ВызватьИсключение "Версия драйвера не определена";
Исключение
Если Не ВерсииСовместимыСБРФ(СовместимыеВерсии) Тогда
Сообщить("""" + Модель + """:" + Символы.ПС +
"Внимание! Невозможно определить версию драйвера." + Символы.ПС +
"Требуемая версия: " + мВерсияТребуемая + Символы.ПС +
"Корректная работа драйвера не гарантируется", СтатусСообщения.Внимание);
КонецЕсли;
КонецПопытки;

Если мВерсияИзДрайвера <> Неопределено И (Не ВерсииРавныСБРФ() И Не ВерсииСовместимыСБРФ(СовместимыеВерсии)) Тогда
Сообщить("""" + Модель + """:" + Символы.ПС +
"Внимание! Текущая версия драйвера отличается от поддерживаемой." + Символы.ПС +
"Текущая версия: " + мВерсияИзДрайвера + Символы.ПС +
"Требуемая версия: " + мВерсияТребуемая + Символы.ПС +
"Корректная работа драйвера не гарантируется", СтатусСообщения.Внимание);
КонецЕсли;

Объект = Новый Структура("Модель, Параметры, Драйвер, ОписаниеОшибки",
Модель, Параметры, Драйвер, ОписаниеОшибки);
КонецЕсли;
КонецЕсли;

Возврат Результат;

КонецФункции // СоздатьОбъектДрайвера()

3. Создаем собственно объект

Сообщить(СоздатьОбъектДрайвераСБРФ(ОбъектДрайвераСБРФ,,));

4. Теперь самое фантастическое - надо заставить его работать, а это непросто, например:

В одном из общих модуле пишем процедуру, которая заставит ккм печатать как принтер:

Процедура ПечатьНеФискальногоДокумента10Драйвер(МассивСтрок) Экспорт

// Открываем нефискальный документ

Результат = ECR.beginNonfiscalDocument();

Если Результат <> 0 Тогда
сообщить("Ошибка ККМ : " + ECR.errorCode() + " " + ECR.ErrorDescription(), СтатусСообщения.Важное);
КонецЕсли;

Попытка

Для Каждого ЭлементМассива из МассивСтрок Цикл

ECR.setParam(ECR.LIBFPTR_PARAM_TEXT, ЭлементМассива);
Результат = ECR.printText();

Если Результат <> 0 Тогда
сообщить("Ошибка ККМ : " + ECR.errorCode() + " " + ECR.ErrorDescription(), СтатусСообщения.Важное);
КонецЕсли;

КонецЦикла;

// Закрываем нефискальный документ
Результат = ECR.endNonfiscalDocument();

Если Результат <> 0 Тогда
сообщить("Ошибка ККМ : " + ECR.errorCode() + " " + ECR.ErrorDescription(), СтатусСообщения.Важное);
КонецЕсли;

Результат = ECR.cut(); // посылаем отрез

Если Результат <> 0 Тогда
сообщить("Ошибка ККМ : " + ECR.errorCode() + " " + ECR.ErrorDescription(), СтатусСообщения.Важное);
КонецЕсли;

Исключение
Сообщить("Ошибка ККМ. Операция отменена."); Return;
КонецПопытки;

КонецПроцедуры

5. Переменная ECR - это объект драйвера ККМ, дальше процедура которая подключит любой драйвер 6, 8, 10

Процедура СоздатьОбъектДрайвераККМ()

/////////////////////////////// Загрузка компоненты драйвера версии 6.х ///////////////////////////////////////

глВерсияДрайвераККМ = Перечисления.ВерсияДрайвераККМ.ВерсияДрайвераНеОпределена;
глНомерВерсииДрайвераККМ = 0;

Попытка
// создаем объект общего драйвера ККМ для Windows 7 x64
ЗагрузитьВнешнююКомпоненту("C:\Program Files\Atol\Drivers\Bin\FPRNM1C.dll");
ECR = Новый("AddIn.FprnM45");
глВерсияДрайвераККМ = Перечисления.ВерсияДрайвераККМ.ДрайверККМ6Версии;
глНомерВерсииДрайвераККМ = 6;
исключение

Попытка
// создаем объект общего драйвера ККМ для Windows 7 x32
ЗагрузитьВнешнююКомпоненту("C:\Program Files (x86)\Atol\Drivers\Bin\FPRNM1C.dll");
ECR = Новый("AddIn.FprnM45");
глВерсияДрайвераККМ = Перечисления.ВерсияДрайвераККМ.ДрайверККМ6Версии;
глНомерВерсииДрайвераККМ = 6;
Исключение
//Предупреждение("Ошибка загрузки внешней компоненты FPRNM1C.dll");
// ЗавершитьРаботуСистемы();

КонецПопытки;

КонецПопытки;

/////////////////////////////// Загрузка компоненты драйвера версии 6.х ///////////////////////////////////////

/////////////////////////////// Загрузка компоненты драйвера версии 8.х ///////////////////////////////////////

Если глВерсияДрайвераККМ = Перечисления.ВерсияДрайвераККМ.ВерсияДрайвераНеОпределена Тогда

Попытка
// создаем объект общего драйвера ККМ для Windows 7 x64
ЗагрузитьВнешнююКомпоненту("C:\Program Files\Atol\Drivers8\Bin_Free\FPRNM1C.dll");
ECR = Новый("AddIn.FprnM45");
глВерсияДрайвераККМ = Перечисления.ВерсияДрайвераККМ.ДрайверККМ8Версии54ФЗ;
глНомерВерсииДрайвераККМ = 8;
исключение

Попытка
// создаем объект общего драйвера ККМ для Windows 7 x32
ЗагрузитьВнешнююКомпоненту("C:\Program Files (x86)\Atol\Drivers8\Bin_Free\FPRNM1C.dll");
ECR = Новый("AddIn.FprnM45");
глВерсияДрайвераККМ = Перечисления.ВерсияДрайвераККМ.ДрайверККМ8Версии54ФЗ;
глНомерВерсииДрайвераККМ = 8;
Исключение
// Предупреждение("Ошибка загрузки внешней компоненты FPRNM1C.dll");
// ЗавершитьРаботуСистемы();

КонецПопытки;

КонецПопытки;

КонецЕсли;

/////////////////////////////// Загрузка компоненты драйвера версии 8.х ///////////////////////////////////////

/////////////////////////////// Загрузка компоненты драйвера версии 10.х ///////////////////////////////////////

Если глВерсияДрайвераККМ = Перечисления.ВерсияДрайвераККМ.ВерсияДрайвераНеОпределена Тогда

Попытка
// создаем объект общего драйвера ККМ
ECR = Новый COMОбъект("AddIn.Fptr10");

//Подключение по COM порту (не работает по неизвестной причине)
//ECR.setSingleSetting(ECR.LIBFPTR_SETTING_MODEL, Строка(ECR.LIBFPTR_MODEL_ATOL_AUTO));
//ECR.setSingleSetting(ECR.LIBFPTR_SETTING_PORT, Строка(ECR.LIBFPTR_PORT_COM));
//ECR.setSingleSetting(ECR.LIBFPTR_SETTING_COM_FILE, "COM03");
//ECR.setSingleSetting(ECR.LIBFPTR_SETTING_BAUDRATE, Строка(ECR.LIBFPTR_PORT_BR_115200));
//ECR.applySingleSettings();

//Подключение по COM порту (работает, в драйвере ККТ надо установить канал связи USB)
ECR.setSingleSetting(ECR.LIBFPTR_SETTING_PORT, Строка(ECR.LIBFPTR_PORT_USB));
ECR.applySingleSettings();


ECR.Open();

Сообщить("Версия драйвера :" + ECR.Version());

глВерсияДрайвераККМ = Перечисления.ВерсияДрайвераККМ.ДрайверККМ8Версии54ФЗ;
глНомерВерсииДрайвераККМ = 10;
исключение

Сообщить("глПринтер не создан AddIn.Fptr10 " + ОписаниеОшибки());

КонецПопытки;

КонецЕсли;

/////////////////////////////// Загрузка компоненты драйвера версии 10.х ///////////////////////////////////////


Если глВерсияДрайвераККМ = Перечисления.ВерсияДрайвераККМ.ДрайверККМ6Версии тогда
Сообщить("Версия драйвера ККМ 6.х.х загружена.", статусСообщения.Информация);
ИначеЕсли глВерсияДрайвераККМ = Перечисления.ВерсияДрайвераККМ.ДрайверККМ8Версии54ФЗ И глНомерВерсииДрайвераККМ = 8 тогда
Сообщить("Версия драйвера ККМ 8.х.х загружена.", статусСообщения.Информация);
ИначеЕсли глВерсияДрайвераККМ = Перечисления.ВерсияДрайвераККМ.ДрайверККМ8Версии54ФЗ И глНомерВерсииДрайвераККМ = 10 Тогда
Сообщить("Версия драйвера ККМ 10.х.х загружена.", статусСообщения.Информация);
Иначе
Сообщить("Невозможно подключить компоненту драйвера ККМ.", статусСообщения.Важное);
Сообщить("1. Проверьте, что компонента корректно установлена и имеет ту же версию", СтатусСообщения.Важное);
Сообщить("что и требуемая обработкой обслуживания.", СтатусСообщения.Важное);
Сообщить("2. Проверьте что драйвер КММ установлен по умолчанию в каталогах:", СтатусСообщения.Важное);
Сообщить("C:\Program Files\Atol\Drivers\Bin\FPRNM1C.dll (для 6 версии драйвера)", СтатусСообщения.Важное);
Сообщить("или C:\Program Files (x86)\Atol\Drivers\Bin\FPRNM1C.dll (для 6 версии драйвера)", СтатусСообщения.Важное);
Сообщить("C:\Program Files\Atol\Drivers8\Bin_Free\FPRNM1C.dll (для 8 версии драйвера)", СтатусСообщения.Важное);
Сообщить("или C:\Program Files (x86)\Atol\Drivers8\Bin_Free\FPRNM1C.dll (для 8 версии драйвера)", СтатусСообщения.Важное);
Сообщить("C:\Program Files\ATOL\Drivers10\KKT\bin\fptr10.dll (для 10 версии драйвера)", СтатусСообщения.Важное);
Сообщить("C:\Program Files (x86)\ATOL\Drivers10\KKT\bin\fptr10.dll (для 10 версии драйвера)", СтатусСообщения.Важное);
КонецЕсли;
КонецПроцедуры

6. Обработка. См. приложенный файл.

7. после некоторых танцев с бубнами - на ККМ можно будет фото печатать. Не только Сбербанковские слип чеки.
Прикрепленные файлы:
СберБанкЭквайринговаяСистема.epf
26. Seniya 20.04.21 11:56 Сейчас в теме
(23) Здравствуйте. может вы подскажите. Выходит 2 чека сверки итогов, один пустой во 2м оба отдела?
Прикрепленные файлы:
Оставьте свое сообщение