Правила переноса остатков на счетах из "БП КОРП" в "БГУ"

Публикация № 1041560

Разработка - Обмен данными 1С - Перенос данных из 1C8 в 1C8

перенос обмен правила конвертация остатков

Готовые правила переноса остатков на счетах из "Бухгалтерия предприятия КОРП" в "Бухгалтерия Государственного Учреждения" Сформированы и протестированы на релизах систем: "Бухгалтерия предприятия КОРП" релиз 2.0.66.71; "Бухгалтерия Государственного Учреждения" релиз 2.0.61.21; "Конвертация данных" релиз 2.1.8.2.

Всем доброго времени суток!

Недавно в связи с реструктуризацией и сменой деятельности компании пришлось организовать перенос остатков с Хозрасчетных счетов системы "Бухгалтерия предприятия КОРП" на Бюджетные счета системы "Бухгалтерия Государственного Учреждения" последнего релиза.

Список счетов по которым выполнялся перенос данных:

ВЗАИМОРАСЧЕТЫ:
Счет 60.01 в БП на счет 302.26 в БГУ;
Счет 60.02 в БП на счет 206.26 в БГУ;

Счет 62.01 в БП на счет 205.31 в БГУ;
Счет 62.02 в БП на счет 205.31 в БГУ.


МАТЕРИАЛЫ:
Счет 10.01 в БП на счет 105.36 в БГУ;
Счет 10.03 в БП на счет 105.33 в БГУ;
Счет 10.05 в БП на счет 105.36 в БГУ;
Счет 10.06 в БП на счет 105.36 в БГУ;
Счет 10.08 в БП на счет 105.34 в БГУ;
Счет 10.09 в БП на счет 105.35 в БГУ;

 

ОСНОВНЫЕ СРЕДСТВА
Счет ОС в БП: 01.01;
Счет амортизации ОС в БП: 02.1

Перенос производится в разрезе групп ОС:

Здания: на счет учета в 101.12; счет амортизации в БГУ 104.12;
Машины и оборудование (кроме офисного): на счет учета в 101.34; счет амортизации в БГУ 104.34;
Транспортные средства: на счет учета в 101.35; счет амортизации в БГУ 104.35;
Производственный и хозяйственный инвентарь: на счет учета в 101.36; счет амортизации в БГУ 104.36;
Другие виды основных средств: на счет учета в 101.38; счет амортизации в БГУ 104.38;

ПРОЧИЕ РАСЧЕТЫ С РАЗНЫМИ ДЕБИТОРАМИ И КРЕДИТОРАМИ
Счет 76.09 в БП на счет 302.21 в БГУ.

ПРОЧИЕ РАСХОДЫ БУДУЩИХ ПЕРИОДОВ
Счет 97.21 в БП на счет 401.50 в БГУ.

СПЕЦОДЕЖДА В ЭКСПЛУАТАЦИИ
Счет МЦ.02 в БП на счет 27 в БГУ.

ИНВЕНТАРЬ И ХОЗ. ПРИНАДЛЕЖНОСТИ В ЭКСПЛУАТАЦИИ
Счет МЦ.04 в БП на счет 27 в БГУ.

НДС ПО АВАНСАМ И ПРЕДОПЛАТАМ
Счет 76.АВ в БП на счет 210.11 в БГУ.


Краткое описание и общий алгоритм правил.
Основным ПВД является "ПроизвольныйАлгоритмВыгрузки". В нем организовано выполнение алгоритмов формирования исходящей информации.

Код ПВД:

////////////////////////////////////////////////////////////////////////////
//ВЗАИМОРАСЧЕТЫ
//+Остатки по счету 60.01 в БП во Ввод начальных остатков по счету 302.26 в БГУ
СчетБП = "60.01"; СчетБГУ = "302.26"; С1 = Истина; С2 = Истина; С3 = Ложь;
Выполнить(Алгоритмы.ПолучитьИсходящиеДанныеИВыполнитьВыгрузку);
//-

//+Остатки по счету 60.02 в БП во Ввод начальных остатков по счету 206.26 в БГУ
СчетБП = "60.02"; СчетБГУ = "206.26"; С1 = Истина; С2 = Истина; С3 = Ложь;
Выполнить(Алгоритмы.ПолучитьИсходящиеДанныеИВыполнитьВыгрузку);
//-

//+Остатки по счету 62.01 в БП во Ввод начальных остатков по счету 205.31 в БГУ
СчетБП = "62.01"; СчетБГУ = "205.31"; С1 = Истина; С2 = Истина; С3 = Ложь;
Выполнить(Алгоритмы.ПолучитьИсходящиеДанныеИВыполнитьВыгрузку);
//-

//+Остатки по счету 62.02 в БП во Ввод начальных остатков по счету 205.31 в БГУ
СчетБП = "62.02"; СчетБГУ = "205.31"; С1 = Истина; С2 = Истина; С3 = Ложь;
Выполнить(Алгоритмы.ПолучитьИсходящиеДанныеИВыполнитьВыгрузку);
//-
////////////////////////////////////////////////////////////////////////////////



////////////////////////////////////////////////////////////////////////////////
//МАТЕРИАЛЫ
//+Остатки по счету 10.01 в БП во Ввод начальных остатков по счету 105.36 в БГУ
СчетБП = "10.01"; СчетБГУ = "105.36"; С1 = Истина; С2 = Истина; С3 = Ложь;
Выполнить(Алгоритмы.ПолучитьИсходящиеДанныеИВыполнитьВыгрузку);
//-

//+Остатки по счету 10.03 в БП во Ввод начальных остатков по счету 105.33 в БГУ
СчетБП = "10.03"; СчетБГУ = "105.33"; С1 = Истина; С2 = Истина; С3 = Ложь;
Выполнить(Алгоритмы.ПолучитьИсходящиеДанныеИВыполнитьВыгрузку);
//-

//+Остатки по счету 10.05 в БП во Ввод начальных остатков по счету 105.36 в БГУ
СчетБП = "10.05"; СчетБГУ = "105.36"; С1 = Истина; С2 = Истина; С3 = Ложь;
Выполнить(Алгоритмы.ПолучитьИсходящиеДанныеИВыполнитьВыгрузку);
//-

//+Остатки по счету 10.06 в БП во Ввод начальных остатков по счету 105.36 в БГУ
СчетБП = "10.06"; СчетБГУ = "105.36"; С1 = Истина; С2 = Истина; С3 = Ложь;
Выполнить(Алгоритмы.ПолучитьИсходящиеДанныеИВыполнитьВыгрузку);

//+Остатки по счету 10.08 в БП во Ввод начальных остатков по счету 105.34 в БГУ
СчетБП = "10.08"; СчетБГУ = "105.34"; С1 = Истина; С2 = Истина; С3 = Ложь;
Выполнить(Алгоритмы.ПолучитьИсходящиеДанныеИВыполнитьВыгрузку);
//-

//+Остатки по счету 10.09 в БП во Ввод начальных остатков по счету 105.35 в БГУ
СчетБП = "10.09"; СчетБГУ = "105.35"; С1 = Истина; С2 = Истина; С3 = Ложь;
Выполнить(Алгоритмы.ПолучитьИсходящиеДанныеИВыполнитьВыгрузку);
//-
//////////////////////////////////////////////////////////////////////////////////


////////////////////////////////////////////////////////////////////////////////
//ОСНОВНЫЕ СРЕДСТВА
//+Остатки по счету 01.01 с типом ОС: 
//Здания;
//Сооружения;
//Капитальные вложения в арендованное имущество;
//Прочие объекты, требующие государственной регистрации, относимые статьей 130 ГК РФ к недвижимости
//в БП во Ввод начальных остатков по счету 101.12 в БГУ
ГруппаУчетаОС = Перечисления.ГруппыОС.Здания; СчетУчетаБГУ = "101.12"; СчетАмортизацииБГУ = "104.12";
КодСчетаАмортизацииОС = "02.1"; КодСчетаОС = "01.01";
Выполнить(Алгоритмы.ПолучитьИсходящиеДанныеИВыполнитьВыгрузкуОС);
//-

//+Остатки по счету 01.01 с типом ОС "Машины и оборудование (кроме офисного)"
//в БП во Ввод начальных остатков по счету 101.12 в БГУ
ГруппаУчетаОС = Перечисления.ГруппыОС.МашиныИОборудование; СчетУчетаБГУ = "101.34"; СчетАмортизацииБГУ = "104.34";
КодСчетаАмортизацииОС = "02.1"; КодСчетаОС = "01.01";
Выполнить(Алгоритмы.ПолучитьИсходящиеДанныеИВыполнитьВыгрузкуОС);
//-

//+Остатки по счету 01.01 с типом ОС "Транспортные средства"
//в БП во Ввод начальных остатков по счету 101.35 в БГУ
ГруппаУчетаОС = Перечисления.ГруппыОС.ТранспортныеСредства; СчетУчетаБГУ = "101.35"; СчетАмортизацииБГУ = "104.35";
КодСчетаАмортизацииОС = "02.1"; КодСчетаОС = "01.01";
Выполнить(Алгоритмы.ПолучитьИсходящиеДанныеИВыполнитьВыгрузкуОС);
//-

//+Остатки по счету 01.01 с типом ОС "Производственный и хозяйственный инвентарь"
//в БП во Ввод начальных остатков по счету 101.36 в БГУ
ГруппаУчетаОС = Перечисления.ГруппыОС.ПроизводственныйИХозяйственныйИнвентарь; СчетУчетаБГУ = "101.36"; СчетАмортизацииБГУ = "104.36";
КодСчетаАмортизацииОС = "02.1"; КодСчетаОС = "01.01";
Выполнить(Алгоритмы.ПолучитьИсходящиеДанныеИВыполнитьВыгрузкуОС);
//-

//+Остатки по счету 01.01 с типом ОС "Другие виды основных средств"
//в БП во Ввод начальных остатков по счету 101.38 в БГУ
ГруппаУчетаОС = Перечисления.ГруппыОС.ДругиеВидыОсновныхСредств; СчетУчетаБГУ = "101.38"; СчетАмортизацииБГУ = "104.38";
КодСчетаАмортизацииОС = "02.1"; КодСчетаОС = "01.01";
Выполнить(Алгоритмы.ПолучитьИсходящиеДанныеИВыполнитьВыгрузкуОС);
//-
////////////////////////////////////////////////////////////////////////////////


////////////////////////////////////////////////////////////////////////////////
//Прочие расчеты с разными дебиторами и кредиторами
//+Остатки по счету 76.09 в БП во Ввод начальных остатков по счету 302.21 в БГУ
СчетБП = "76.09"; СчетБГУ = "302.21"; С1 = Истина; С2 = Истина; С3 = Ложь;
Выполнить(Алгоритмы.ПолучитьИсходящиеДанныеИВыполнитьВыгрузку);
//-
//////////////////////////////////////////////////////////////////////////////



//////////////////////////////////////////////////////////////////////////////
//Прочие расходы будущих периодов
//+Остатки по счету 97.21 в БП во Ввод начальных остатков по счету 401.50 в БГУ
СчетБП = "97.21"; СчетБГУ = "401.50"; С1 = Истина; С2 = Ложь; С3 = Ложь;
Выполнить(Алгоритмы.ПолучитьИсходящиеДанныеИВыполнитьВыгрузку);
//-
//////////////////////////////////////////////////////////////////////////////


//////////////////////////////////////////////////////////////////////////////
//Спецодежда в эксплуатации
//+Остатки по счету МЦ.02 в БП во Ввод начальных остатков по счету 27 в БГУ
СчетБП = "МЦ.02"; СчетБГУ = "27"; С1 = Истина; С2 = Ложь; С3 = Истина;
Выполнить(Алгоритмы.ПолучитьИсходящиеДанныеИВыполнитьВыгрузку);
//-
//////////////////////////////////////////////////////////////////////////////

//////////////////////////////////////////////////////////////////////////////
//Инвентарь и хозяйственные принадлежности в эксплуатации
//+Остатки по счету МЦ.04 в БП во Ввод начальных остатков по счету 27 в БГУ
СчетБП = "МЦ.04"; СчетБГУ = "27"; С1 = Истина; С2 = Ложь; С3 = Истина;
Выполнить(Алгоритмы.ПолучитьИсходящиеДанныеИВыполнитьВыгрузку);
//-
//////////////////////////////////////////////////////////////////////////////

////////////////////////////////////////////////////////////////////////////
//НДС по авансам и предоплатам
//+Остатки по счету 76 .АВ в БП во Ввод начальных остатков НДС по счету 210.11 в БГУ
Счет = "76.АВ"; СчетБГУ = "210.11";
Выполнить(Алгоритмы.ПолучитьИсходящиеДанныеНДС);
//-                 
////////////////////////////////////////////////////////////////////////////


Отказ = Истина;

 

Так - же для демонстрации приведу код алгоритма "ПолучитьИсходящиеДанныеИВыполнитьВыгрузку":

зСубконто = "";
грСубконто = "";
Если С1 Тогда
	зСубконто = зСубконто + " ХозрасчетныйОстатки.Субконто1 КАК Субконто1, ";
	грСубконто = грСубконто + " ХозрасчетныйОстатки.Субконто1, ";
КонецЕсли;
Если С2 Тогда
	зСубконто = зСубконто + " ХозрасчетныйОстатки.Субконто2 КАК Субконто2, ";
	грСубконто = грСубконто + " ХозрасчетныйОстатки.Субконто2, ";
КонецЕсли;
Если С3 Тогда
	зСубконто = зСубконто + " ХозрасчетныйОстатки.Субконто3 КАК Субконто3, ";
	грСубконто = грСубконто + " ХозрасчетныйОстатки.Субконто3, ";
КонецЕсли;
Запрос = Новый Запрос("ВЫБРАТЬ
					|	ХозрасчетныйОстатки.Счет КАК Счет," + зСубконто + "
					|	ХозрасчетныйОстатки.Организация КАК Организация,
					|	СУММА(ХозрасчетныйОстатки.СуммаОстатокДт) КАК СуммаДт,
					|	СУММА(ХозрасчетныйОстатки.СуммаОстатокКт) КАК СуммаКт,
					|	СУММА(ХозрасчетныйОстатки.ВалютнаяСуммаОстатокДт) КАК ВалютнаяСуммаДт,
					|	СУММА(ХозрасчетныйОстатки.ВалютнаяСуммаОстатокКт) КАК ВалютнаяСуммаКт,
					|	СУММА(ХозрасчетныйОстатки.КоличествоОстатокДт) КАК КоличествоДт,
					|	СУММА(ХозрасчетныйОстатки.КоличествоОстатокКт) КАК КоличествоКт,
					|	ХозрасчетныйОстатки.Валюта КАК Валюта
					|ИЗ
					|	РегистрБухгалтерии.Хозрасчетный.Остатки(&ДатаОстатков, Счет В ИЕРАРХИИ (&Счет), , Организация = &Организация) КАК ХозрасчетныйОстатки
					|СГРУППИРОВАТЬ ПО
					|	ХозрасчетныйОстатки.Счет," + грСубконто + "
					|	ХозрасчетныйОстатки.Организация,
					|	ХозрасчетныйОстатки.Валюта");


Запрос.УстановитьПараметр("Счет",ПланыСчетов.Хозрасчетный.НайтиПоКоду(СчетБП));
Запрос.УстановитьПараметр("ДатаОстатков", Параметры.ДатаВводаОстатков);
Запрос.УстановитьПараметр("Организация", Параметры.ВыгружаемаяОрганизация);

ЖурналПроводокЕПСБУ = Неопределено;
Выполнить(Алгоритмы.СоздатьЖурналПроводокЕПСБУ);
КорСчет = "000";
Период = Параметры.ДатаВводаОстатков;

Выборка = Запрос.Выполнить().Выбрать();
Пока Выборка.Следующий() Цикл
	
	ИсходящиеДанные = Новый Структура("Дата, Организация, Комментарий");
	ИсходящиеДанные.Дата		= Параметры.ДатаВводаОстатков;
	ИсходящиеДанные.Комментарий = "Ввод остатков: " + Выборка.Организация +"/"+Выборка.Счет;
	ИсходящиеДанные.Организация = Выборка.Организация;
		
	
	Сторона   = "";
	Если Выборка.Счет.Вид = ВидСчета.Активный Тогда
		Сторона   = "Дт";
	ИначеЕсли Выборка.Счет.Вид = ВидСчета.Пассивный Тогда
		Сторона   = "Кт";
	Иначе
		Если Выборка.СуммаДт <> 0 
			ИЛИ Выборка.КоличествоДт <> 0
			ИЛИ Выборка.ВалютнаяСуммаДт <> 0
		Тогда
		    Сторона   = "Дт";
		Иначе
		    Сторона   = "Кт";
		КонецЕсли;
	КонецЕсли;
	Если Сторона = "Дт" Тогда
		ВспСторона = "Кт";
	Иначе
		ВспСторона = "Дт";
	КонецЕсли;
	
	НовПроводка = ЖурналПроводокЕПСБУ.Добавить();
	НовПроводка.Период = Период;
	Если НЕ Выборка.Счет.Забалансовый Тогда 
		//Вспомогательный счет "000"
		НовПроводка["Счет"+ВспСторона] = КорСчет;
	КонецЕсли;
	//Счет остатков
	НовПроводка["Счет"+Сторона] = СчетБГУ;
	
	НовПроводка["Сумма"] = ?(Сторона = "Дт",Выборка.СуммаДт,Выборка.СуммаКт);
	НовПроводка["Организация"] = Выборка.Организация;
	
	Если Выборка.Счет.Валютный Тогда
		НовПроводка["Валюта"+Сторона] = Выборка.Валюта;
		НовПроводка["ВалютнаяСумма"+Сторона] = ?(Сторона = "Дт",Выборка.ВалютнаяСуммаДт, Выборка.ВалютнаяСуммаКт);
	КонецЕсли;
	Если Выборка.Счет.Количественный Тогда
		НовПроводка["Количество"+Сторона] =?(Сторона = "Дт",Выборка.КоличествоДт, Выборка.КоличествоКт);
	КонецЕсли;
	
	КоличествоСубконто = Выборка.Счет.ВидыСубконто.Количество();
	Для Инд = 0 По КоличествоСубконто-1 Цикл
		Попытка
			НовПроводка["Субконто"+Сторона].Вставить(Выборка.Счет.ВидыСубконто[Инд].ВидСубконто,Выборка["Субконто"+(Инд+1)]);
		Исключение
			НовПроводка["Субконто"+Сторона].Вставить(Выборка.Счет.ВидыСубконто[Инд].ВидСубконто);
		КонецПопытки;
	КонецЦикла;
	
КонецЦикла;

Если ЖурналПроводокЕПСБУ.Количество() > 0 Тогда	
	ИсходящиеДанные.Вставить("ЖурналПроводокЕПСБУ",ЖурналПроводокЕПСБУ);
	ИсходящиеДанные.Вставить("Счет", СчетБГУ);	
	ВыгрузитьПоПравилу(,,ИсходящиеДанные,,"ВводНачальныхОстатков");
	ЖурналПроводокЕПСБУ.Очистить();
КонецЕсли;

 

Т.о. принцип работы выгрузки заключается в поэтапном выполнении 3-х основных алгоритмов формирования исходящих данных, которые формируют информацию в зависимости от типа переносимых остатков:

  • ПолучитьИсходящиеДанныеИВыполнитьВыгрузку;
  • ПолучитьИсходящиеДанныеИВыполнитьВыгрузкуОС;
  • ПолучитьИсходящиеДанныеНДС.

В конце каждого алгоритма после формирования исходящих данных выполняется переход на соответствующее ПКО:

  • ВводНачальныхОстатков;
  • ВводНачальныхОстатковВходящийНДС;
  • ВводНачальныхОстатковОС.

 

Замечание.

Т.к. при формировании данной конвертации полагался на определенные требования своей кампании, для применения ее в Вашем конкретном случае необходим анализ данных и корректировка Вашим специалистом. Т.е. данную конвертацию рекомендуется использовать как базу для создания переноса по Вашим конкретным критериям, иначе при выполнении процедур на данных правилах "по умолчанию" могут возникнуть ошибки.

Ну и естественно перед загрузкой данных ОБЯЗАТЕЛЬНО делайте копию базы.

Скачать файлы

Наименование Файл Версия Размер
Правила переноса остатков на счетах из "БП КОРП" в "БГУ":

.zip 154,70Kb
9
.zip 154,70Kb 9 Скачать
Обработки для организации конвертации и переноса данных

.zip 368,08Kb
9
.zip 368,08Kb 9 Скачать

Специальные предложения

Оставьте свое сообщение

См. также

Перенос объектов 1С Промо

Перенос данных из 1C8 в 1C8 v8 v8::УФ 1cv8.cf Абонемент ($m)

Простой и наглядный перенос объектов между любыми базами 1С 8 с предварительным анализом на возможные различия в данных (через файл, через интернет, через буфер обмена). Интерактивная настройка правил обмена на стороне источника и получателя. В обработке есть удобный обзор по подсистемам, поиск и обработка данных по заданному фильтру. Сравнение объектов, поиск ссылок. Конструктор кода по созданию объектов, написание скриптов и отладка мини-функций в УФ. Отключение/включение регламентных заданий. Регистрация/снятие с регистрации объектов в планах обмена. И многое другое. Инструменты администратора в одной обработке.

1 стартмани

16.03.2015    94677    2048    moolex    199    

Настройка обмена с любой устаревшей конфигурацией на базе 8.2 через обработку "Универсальный обмен данными в формате XML" и "Конвертацию данных 2.0"

Обмен через XML Перенос данных из 1C8 в 1C8 v8 Платформа 1C v8.2 1cv8.cf БУ УУ Абонемент ($m)

Разберем кейс, как настроить простенький обмен с любой устаревшей конфигурацией на базе 8.2 через обработку "Универсальный обмен данными в формате XML" и Конвертацию данных 2.0 с возможностью настройки гибких отборов по периоду, организации и списку документов.

1 стартмани

23.11.2020    4414    5    orfos    14    

Самописный обмен данными через веб сервис маленькими пакетами с большой скоростью

Перенос данных из 1C8 в 1C8 v8 1cv8.cf Россия Абонемент ($m)

Подсистема в конфигурацию 1С, обеспечивающая обмен данными по настраиваемым правилам в разные системы 1С. Обмен осуществляется сообщениями через сервис. Разработка и тестирование на версии 8.3.15.1656

10 стартмани

06.02.2020    6268    8    visork    12    

Универсальный обмен данными между идентичными конфигурациями, версия 2020.3.1

Перенос данных из 1C8 в 1C8 v8 1cv8.cf Абонемент ($m)

Обработка «Универсальная выгрузка и загрузка» предназначена для оперативного переноса объектов между двумя идентичными или похожими конфигурациями. Быстрая, надежная и очень простая в использовании обработка.

1 стартмани

29.01.2020    15205    245    vladnet    36    

Выгрузка данных из УТ 11.3/11.4 в БП 3.0 (перенос документов и справочной информации из "Управление торговлей" ред. 11.3/11.4 в "Бухгалтерия предприятием" ред. 3.0). Обновлен до УТ 11.3.4.х/11.4.7х и БП 3.0.7х.х Промо

Обмен через XML Перенос данных из 1C8 в 1C8 v8 БП3.0 УТ11 Абонемент ($m)

Данная обработка предназначена для выгрузки в формате XML данных из программы «Управление торговлей» ред. 11.3/11.4 по основным группам документов (документы покупки/продажи товаров и услуг, складские документы, счета-фактуры, ценообразование), а также набор основных справочников. Загрузка данных в БП ред. 3.0 через обработку «Универсальный обмен данными XML». Основная цель обработки – оптимизация работы бухгалтеров во время обмена данными между программами, а также выборочная корректировка загруженных ранее документов.

04.03.2016    58844    0    SEOAngels    62    

Правила обмена УТ 11.4 БП 3.0 для обработки "Универсальный обмен данными в формате XML"

Перенос данных из 1C8 в 1C8 v8 БП3.0 УТ11 БУ УУ Абонемент ($m)

Правила обмена УТ 11.4 БП 3.0 для обработки "Универсальный обмен данными в формате XML". Для быстрой или частичной выгрузки справочников и документов, без настройки синхронизации данных.

1 стартмани

23.10.2019    8688    163    RAV38574    45    

hsИнтегратор 3. Онлайновый обмен и удаленное исполнение функций по HTTP протоколу

Перенос данных из 1C8 в 1C8 v8 Абонемент ($m)

Кроссплатформенный онлайновый обмен данными и удаленное исполнение функций по протоколу HTTP. Новая функциональность - обмен элементами плана видов расчета и данными расчетных регистров. Увеличение производительности и упрощение пользовательского API. Тестирование обменов выполнялось с демонстрационными базами: "Бухгалтерия предприятия, редакция 3.0 3.0.72.66" и "Зарплата и Управление Персоналом, редакция 3 3.1.10.135"

1 стартмани

19.05.2019    6579    28    hobi    9    

Доработка универсального обмена в формате EnterpriseData

Перенос данных из 1C8 в 1C8 v8 1cv8.cf Россия Абонемент ($m)

В публикации показана доработка универсального обмена в формате EnterpriseData для получения документа поступления товаров из Бухгалтерии 3.0 в Управление Автотранспортом.

1 стартмани

03.05.2019    9994    14    gzharkoj    2    

Выгрузка документов из ЗУП в БП (1С 8.2-8.3) Промо

Перенос данных из 1C8 в 1C8 Зарплата Зарплата v8 БП2.0 ЗУП2.5 Абонемент ($m)

Обработка для выгрузки документов из конфигурации "Зарплата и управление персоналом" 8.2 в конфигурацию "Бухгалтерия предприятия" 8.2. Использует правила обмена. В обработке создан удобный интерфейс для гибкого формирования списка документов кадрового учета и начисления ЗП.

1 стартмани

18.12.2012    16745    138    d.zhukov    20    

Выгрузка и загрузка данных XML с гибкими отборами

Обмен через XML Перенос данных из 1C8 в 1C8 v8 1cv8.cf Абонемент ($m)

Обработка выгрузки и загрузки данных через XML между идентичными конфигурациями с возможностью установки произвольных отборов на выгружаемые объекты.

1 стартмани

07.04.2019    23625    624    sapervodichka    7    

Перенос данных КА 1.1 -> КА 2

Перенос данных из 1C8 в 1C8 Обмен через XML v8 КА1 КА2 Россия Абонемент ($m)

Перенос данных КА 1.1 => КА 2 с помощью правил обмена данными в формате XML КД 2 (переносятся остатки, документы, справочная информация).

5 стартмани

20.03.2019    19318    292    gudogu    143    

Обработка для выгрузки и загрузки данных XML 8.3. С отбором, предпросмотром данных и сохранением настроек

Обмен через XML Перенос данных из 1C8 в 1C8 v8 v8::УФ 1cv8.cf Россия Абонемент ($m)

Обработка Выгрузки и загрузки данных XML 8.3 на управляемых формах. Универсальная обработка "Выгрузка и загрузка данных XML" производит полную или частичную выгрузку данных информационной базы в файл в формате XML. Впоследствии этот файл может быть загружен в информационную базу с помощью этой же обработки. Формат файла выгрузки отличается от формата файла, создаваемого при выгрузке по плану обмена, заголовочной частью. (Описание взято с ИТС)

1 стартмани

07.03.2019    17042    256    Gmix    10    

Универсальная выгрузка/загрузка данных для отличающихся конфигураций (JSON, Такси+ОФ) Промо

Перенос данных из 1C8 в 1C8 Универсальные обработки Распределенная БД (УРИБ, УРБД) v8 1cv8.cf Абонемент ($m)

Простой перенос через JSON данных между двумя базами 1С (документов, справочников, ПВХ, ПВР, счетов). Аналогична произвольной выгрузке в типовой "Выгрузка/загрузка XML", но может использоваться для отличающихся конфигураций. Подходит для любых пар баз с любым интерфейсом (управляемый + обычный). Без настроек. Не требует идентичности конфигураций и платформ. При переносе типы данных сопоставляются по наименованиям метаданных, объекты и ссылки по UID.

1 стартмани

22.10.2014    212704    4271    ekaruk    184    

Правила обмена УПП 1.3 -> БП 3.0 (+ БП КОРП 3.0 + перенос остатков)

Перенос данных из 1C8 в 1C8 Обмен через XML v8 УПП1 КД БП3.0 БУ Абонемент ($m)

Актуальные правила обмена: УПП 1.3.137.1 -> БП 3.0.76.77; УПП 1.3.137.1 -> БП КОРП 3.0.76.77; УПП 1.3.128.1 -> БП 3.0.74.63; УПП 1.3.128.1 -> БП КОРП 3.0.74.63; УПП 1.3.123.3 -> БП 3.0.71.83; УПП 1.3.123.3 -> БП КОРП 3.0.71.83; УПП 1.3.118.1 -> БП 3.0.68.61; УПП 1.3.118.1 -> БП КОРП 3.0.68.61.

1 стартмани

04.03.2019    15520    372    Смешной 1С    46    

Выгрузка данных из Бухгалтерии ред. 3.0 в Управление небольшой фирмой, ред. 1.6

Обмен через XML Перенос данных из 1C8 в 1C8 v8 УНФ БП3.0 Россия УУ Абонемент ($m)

Выгрузка данных из 1С БП 3.0 в УНФ 1.6. Обработка переносит документы по банку, кассе, движения ТМЦ + справочники контрагентов, номенклатуры и другие связанные справочники. Полный список документов на скриншоте.

1 стартмани

08.02.2019    16310    260    dinarz    114    

Ручная выгрузка и загрузка данных через универсальный обмен данными с настройками (расширение, платформа 8.3+)

Обработка документов Обработка справочников Обмен через XML Перенос данных из 1C8 в 1C8 v8 Розница УНФ ERP2 БП3.0 УТ11 КА2 ЗУП3.x Абонемент ($m)

Данное расширение (не требует изменения конфигураций) служит как надстройка для конфигураций, у которых обмен между базами происходит через универсальный формат (EnterpriseData), с использованием стандартных правил конвертации, которые уже есть в конфигурации. Интерфейс адаптирован для простых пользователей, сделан общий отбор по Организации для всех документов, имеется пару настроек для передачи в параметры конвертации, которые расположены в общем модуле конфигураций, а так же есть возможность выбора запуска - в фоне или в текущем сеансе. Теперь не нужно настраивать обмен между базами, для того чтоб просто перенести нужные документы. Подходит точно для УТ 11.4, БП 3.0.67, КА 2.4.5, Розница 2.2.9 (Обновление 1.2 от 02.03.2019)

2 стартмани

19.01.2019    25992    159    hakerxp    10    

Соответствия объектов обмена Промо

Распределенная БД (УРИБ, УРБД) Перенос данных из 1C8 в 1C8 v8 КА1 Россия Абонемент ($m)

Обработка позволяет проверять, исправлять ошибки, добавлять и удалять соответствия объектов в обменах данными между конфигурациями на основе «Комплексной автоматизации 1.1» или похожими конфигурациям. Подходит для обменов с использованием регистра сведений «СоответствиеОбъектовДляОбмена».

1 стартмани

26.08.2016    23646    8    xxxelaaa    1    

Перенос данных КА 1.1.115.1 => БП 3.0.75.104 (перенос остатков, документов, зарплатный блок и справочной информации)

Перенос данных из 1C8 в 1C8 Обмен через XML v8 КА1 БП3.0 Россия Абонемент ($m)

Переносятся: остатки по счетам 01, 02, 10, 20, 41, 60, 62, 71, 97 и их субсчетам; документы; отдельно можно перенести справочники (номенклатура, контрагенты, договоры контрагентов, организации, склады, физические лица, сотрудники).

5 стартмани

22.12.2018    17392    399    gudogu    157    

Выполнение запроса в другой базе 1С без com-соединения. HTTP-сервис

Перенос данных из 1C8 в 1C8 v8 1cv8.cf Абонемент ($m)

Выполнение любого запроса с параметрами из одной базы 1С в другую. Используя HTTP-сервис. Посредством POST-запроса и JSON.

1 стартмани

30.11.2018    25632    28    John_d    23    

Выгрузка данных из УТ 10.3 в БП 3.0 (своими руками) Промо

Перенос данных из 1C8 в 1C8 v8 УТ10 БП3.0 Россия Абонемент ($m)

Старая добрая, позабытая многими выгрузка из УТ 10.3 в БП 1.6. Ее еще можно оживить, и она послужит на благо всем желающим, всем уставшим от автоматических обменов.

2 стартмани

30.10.2014    43715    321    TESL    40    

Пример получения данных из другой базы 1С через Web-сервис

Перенос данных из 1C8 в 1C8 v8 Россия Абонемент ($m)

В данной статье описан пример получения данных справочника из другой базы 1С через Web-сервис.

1 стартмани

11.11.2018    35097    28    flyDrag    29    

Дозагрузка кадровых документов в ЗУП 3.1 из ЗУП 2.5 в интерактивном режиме (загрузка в документы списком)

Перенос данных из 1C8 в 1C8 Управление персоналом (HRM) Управление персоналом (HRM) v8 v8::СПР ЗУП3.x Россия БУ Абонемент ($m)

При переходе с ЗУП 2.5 на ЗУП 3.1, иногда по тем или иным причинам требуется ручной перенос кадровых документов за период. Это помощник ручного создания кадровых документов в ЗУП 3.1, который пытается по максимуму заполнить открываемую форму данными из ЗУП 2.5 (через COM-соединение), попутно создает сотрудников и физлиц, если их нет. Основано на публикации rilmir https://infostart.ru/public/793479/ , которое было местами переписано заново, почищено, отлажено, и все равно там еще есть что переделать и оптимизировать, и которое в свою очередь было когда то чьим-то еще творением, видимо для более глобальных целей.

1 стартмани

11.09.2018    12719    160    bugtester    23    

Интерфейс сопоставления объектов для обмена (для типового регистра СоответствиеОбъектовДляОбмена) Промо

Инструментарий разработчика Универсальные обработки Перенос данных из 1C8 в 1C8 v8 КА1 БП2.0 ЗУП2.5 УТ10 УПП1 Абонемент ($m)

Вы внедряете обмен данными между двумя типовыми или основанными на типовых БД и вам необходим инструмент, чтобы сопоставить между собой справочники этих конфигураций? Вы хотите навести порядок в обмене данными, потому что вам надоело вылавливать дублирующиеся объекты? Вам очень хочется перепоручить сопоставление объектов обменивающихся баз пользователям, но нет подходящего и понятного пользователям интерфейса? Тогда вам нужна именно эта обработка!

4 стартмани

11.11.2015    41786    108    catsam    8    

Правила переноса документов из ЗУП 2.5 в ЗУП 3.1

Обмен через XML Перенос данных из 1C8 в 1C8 Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 v8::СПР ЗУП2.5 ЗУП3.x Россия БУ Абонемент ($m)

Перенос документов, справочников и планов видов расчета из конфигурации 1С ЗУП 2.5 в ЗУП 3.1.

3 стартмани

28.03.2018    31637    418    Cobranet123    64    

Выгрузка - загрузка данных в XML с отбором по организации Промо

Обмен через XML Перенос данных из 1C8 в 1C8 v8 1cv8.cf Абонемент ($m)

Выгрузка - загрузка данных в XML с отбором по организации (УФ)

1 стартмани

25.05.2014    48884    478    buganov    42    

Настройка соответствий подразделений ЗУП 3.1 и БП 3.0

Перенос данных из 1C8 в 1C8 Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 v8::БУ v8::СПР БП3.0 ЗУП3.x Россия БУ Абонемент ($m)

Синхронизация ЗУП 3 и БП 3.0: настройка соответствий подразделений при помощи внешней обработки.

5 стартмани

23.03.2018    28898    201    pas    34    

Синхронизация (выгрузка) данных ЗУП 3.1 - БП 2.0, УПП 1.3

Перенос данных из 1C8 в 1C8 Зарплата Управление персоналом (HRM) Зарплата v8 v8::БУ v8::СПР БП2.0 ЗУП3.x Россия БУ Абонемент ($m)

Подобная выгрузка не была предусмотрена разработчиками 1С, поэтому и существует эта публикация. Поддерживается выгрузка оценочных обязательств и резервов отпусков. Непосредственная выгрузка в базу Бухгалтерии. Решение проблем с COM-соединением одной кнопкой.

3 стартмани

22.03.2018    47166    690    diso    200    

Перенос данных из конфигурации "Зарплата и управление персоналом" 3.1 в "Бухгалтерию предприятия" 2.0

Зарплата Перенос данных из 1C8 в 1C8 Зарплата v8 v8::БУ БП2.0 Россия БУ Абонемент ($m)

Перенос данных по Ole Automation из ЗУП 3.1 в БП 2.0. Тестировался на релизах 2.0.66.46 и 3.1.2.483.

3 стартмани

15.03.2018    14690    20    roma_semenov79    0    

Перенос справочников и документов из УТ 10.3 в БП 3.0 Промо

Перенос данных из 1C8 в 1C8 v8 УТ10 БП3.0 Россия БУ НУ УУ Абонемент ($m)

Синхронизация справочников и документов из Управление торговлей 10.3 в Бухгалтерию предприятия 3.0. Обработка не затрагивает штатный механизм. Подключение и перенос документов происходит посредством OLE. Без ввода начальных остатков.

10 стартмани

25.07.2017    24564    15    2casp    6    

Правила конвертации документов ЗУП 2.5 - ЗУП 3.1

Обмен через XML Зарплата Перенос данных из 1C8 в 1C8 Зарплата v8 v8::СПР ЗУП2.5 ЗУП3.x Россия БУ Абонемент ($m)

Правила конвертации документов ЗУП 2.5 - ЗУП 3.1. Позволяют вести параллельную работу в базах ЗУП редакций 2,5 и 3.1.

10 стартмани

06.03.2018    42041    141    kostya_whiskas    24    

Дозагрузка кадровых документов в ЗУП 3.1 из ЗУП 2.5 в интерактивном режиме

Перенос данных из 1C8 в 1C8 Управление персоналом (HRM) Обработка документов Управление персоналом (HRM) v8 v8::СПР ЗУП3.x Россия БУ Абонемент ($m)

Обработка для интерактивной "дозагрузки" кадровых документов в ЗУП 3.1 из ЗУП 2.5 являвшейся источником для переноса данных. Как правило, перенос данных из 2.5 в 3.1 осуществляется как перенос остатков на определенную дату. Созданные после этой даты в ЗУП 2.5 документы обычно распроводятся и при переносе не участвуют. Обработка используется для последующей дозагрузки таких документов. Загрузка происходит в интерактивном режиме подокументно. Т.е. собственно "загрузки" как таковой не происходит - происходит заполнение формы документа данными из ЗУП 2.5.

5 стартмани

01.03.2018    20788    153    rilmir    21    

[УТ 11][БП 3.0] Перенос данных из БП 3.0 в УТ 11 (начальное заполнение УТ 11 по данным БП 3.0)

Перенос данных из 1C8 в 1C8 v8 БП3.0 УТ11 Россия УУ Абонемент ($m)

Перенос данных из БП 3.0 в Ут 11 для первоначального заполнения УТ данными из БП. 31.01.2020 Версия 2.8.7.3 БП 3.0.84.35 платформа 8.3.18.1128.

1 стартмани

29.01.2018    44017    539    Alex_E    161    

Конвертация данных: Поиск при загрузке по дополнительному реквизиту

Перенос данных из 1C8 в 1C8 v8 УТ10 КД БП3.0 Абонемент ($m)

Конвертация данных 2.1. Поиск при загрузке справочника по дополнительному реквизиту.

1 стартмани

13.12.2017    19021    4    vowg    12    

Правила переноса документов из ЗУП 2.5 в ЗУП 3.1

Перенос данных из 1C8 в 1C8 Обмен через XML Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 v8::СПР ЗУП3.x Россия БУ Абонемент ($m)

Перенос документов из ЗУП 2.5 в ЗУП 3.1 - позволяет снизить объем работ при опытной эксплуатации ЗУП 3.1 параллельно с ЗУП 2.5.

1 стартмани

04.12.2017    34981    499    AntonH851    38    

1С:Конвертация данных 2.0. Анализ состава выгруженных данных из базы источника до загрузки в базу-приемник

Перенос данных из 1C8 в 1C8 Перенос данных из 1С7.7 в 1C8.X v8 КД БП3.0 ЗУП3.x Россия Абонемент ($m)

Обработка анализирует файл выгрузки данных конвертации и формирует дерево выгруженных объектов по категориям с возможностью просмотра выгруженных реквизитов (свойств). Идеально подходит для анализа выгруженных данных при переходе на ЗУП 3.1 или Бухгалтерия 3.0 с ранних версий.

1 стартмани

16.11.2017    17472    86    leosoft    4    

Перенос данных УПП/КА в ЕРП и КА2, что таит этот чудный процесс

Перенос данных из 1C8 в 1C8 v8 КА1 УПП1 ERP2 КА2 Россия Абонемент ($m)

По итогам нескольких переносов УПП/КА в ЕРП и КА появилась данная статья. Не так счастлив этот процесс и его результаты.

1 стартмани

20.09.2017    28667    79    Константин С.    23    

Синхронизация данных по правилам КД2.0

Перенос данных из 1C8 в 1C8 v8 1cv8.cf Абонемент ($m)

Новый инструмент для сравнения и загрузки данных, сочетающий в себе: гибкость запросов (используются для сопоставления объектов); наглядный вывод отличий; удобный отбор загружаемых данных; возможность пообъектной синхронизации двух баз по правилам КД2 с помощью вызова обработки "Универсальный обмен XML" в базе-источнике через COM-соединение.

1 стартмани

27.08.2017    26516    115    vikad    36    

Правила обмена ЗУП 3.1 - БП 2.0 и ЗУП 3.1 - УПП 1.3 (отражение, ведомости и справочники)

Перенос данных из 1C8 в 1C8 Обмен через XML Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 v8::БУ v8::СПР БП2.0 БП3.0 ЗУП3.x Россия БУ Абонемент ($m)

Правила обмена для выгрузки документов "Отражение зарплаты в бухучете", "Ведомость в банк", "Ведомость в кассу", справочников "Сотрудники" и "Физические лица"

1 стартмани

01.08.2017    82680    1576    forseil    210    

[РТ 2.*] [БП 3.0] [JSON] Выгрузка/загрузка данных из конфигурации Розница 2.* в Бухгалтерию предприятия 3.0 через файл JSON

Перенос данных из 1C8 в 1C8 Розничная торговля Розничная торговля v8 Розница БП3.0 Розничная и сетевая торговля (FMCG) Россия БУ Абонемент ($m)

Обработка переноса данных из Розницы 2.0 (неважно, базовой или ПРОФ) в БП 3.0 (опять-таки, неважно, базовой или ПРОФ), через файл JSON. Выгружаются документы «Поступление товаров», «Отчет о розничных продажах», «Возврат товаров поставщику», и (опционально) «Установка цен номенклатуры». Также в обмене участвуют все «сопутствующие» справочники и регистры, имеющие соответствие в этих конфигурациях. При загрузке в БП 3.0 данные о загруженных объектах записываются в регистр БП 3.0 «Соответствие объектов для обмена». 29.01.2021 Версия 7.6.6 - Платформа 8.3.18.2389, Розница 2.3.1.10, БП 3.0.88.32. Добавлены три типа документов для переноса: Заказ покупателя (переносится в Счет на оплату покупателю), Реализация товаров (Реализация товаров и услуг в БП) и Счет-фактура выданный. Небольшие изменения в компоновщике при изменении реквизитов при выгрузке. В именах конфигурации для выгрузки добавлена розница для стоительного магазина.

1 стартмани

01.08.2017    21958    86    Alex_E    35    

«Горыныч - то НЕ НАСТОЯЩИЙ!» … или О Конвертации Данных ред.3 (КД 3) и обменах в универсальном формате Enterprise Data… доступным русско-народным языком

Внешние источники данных Обмен через XML Перенос данных из 1C8 в 1C8 v8 КД Абонемент ($m)

Тем, кто хочет быстро разобраться с темой инструмента Конвертация данных 3.0 и технологией обмена по новому формату 1С, активно применяемому во всех новых конфигурациях от 1С на БСП, расширяющем возможности интеграции, пакет полезных материалов.

1 стартмани

13.06.2017    23455    143    Davlad_A    16    

Обмен данными между программами "1С: Бухгалтерия предприятия" редакция 2.0 и "1С: Зарплата и управление персоналом" редакция 3.1

Перенос данных из 1C8 в 1C8 Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 v8::БУ БП2.0 Россия БУ Абонемент ($m)

В связи с отсутствием типовых правил обмена между конфигурациями БП 2.0 и ЗУП 3.1 (3.0) предлагается действующее решение в виде внешней обработки. Алгоритм построен на прямом подключении из базы БП к базе ЗУП. Для переноса данных используется COM-соединение с обработкой COM-объектов базы источника на стороне базы приемника.. Используется односторонний обмен - данные из ЗУП переносятся в БП.

1 стартмани

17.04.2017    28141    247    ivanovmi    38    

Правила обмена ЗУП 3.1(3.1.2.140) - УПП 1.3(1.3.88.2) - документа "Отражение зарплаты в регламентированном учете". Добавлено правило Отражения ERP20->БП30. ***Добавлено правило для ЗУП 3.1.5 и старше с использованием дополнительных реквизитов.

Перенос данных из 1C8 в 1C8 Зарплата Зарплата v8 УПП1 ЗУП3.x Россия БУ Абонемент ($m)

Правила обмена для производственных предприятий, где зарплата отдельной программой ЗУП 3.1 (для оперативного поддержания актуальности релиза), а управленческий и регламентированный учет ведется в УПП 1.3.

1 стартмани

24.03.2017    25669    220    bulas    51    

Синхронизация УТ 11.2 и Розница 2.2 (версии УТ 11.2.3.218, Розница 2.2.4.33+Доп УТ 11.3.4.47, Розница 2.2.6.28+Доп УТ 11.4.5.143, Розница 2.2.9.19). Описание граблей и способы их обхода

Перенос данных из 1C8 в 1C8 Розничная торговля Розничная торговля v8 Розница УТ11 Розничная и сетевая торговля (FMCG) Россия УУ Абонемент ($m)

Много написано о стандартных синхронизациях этих двух почти родных систем, но, к сожалению, из коробки обмен в них не работает. Как обойти грабли, на которые мы часто наступаем, я постараюсь описать в данном материале

1 стартмани

25.11.2016    41328    211    it_sar    35