Шаблон внешней печатной управляемой формы с возможностью передачи параметров из клиентской формы в стандартную общую форму печати документов

Публикация № 1043378

Разработка - Печать - Универсальные печатные формы

Управляемы формы внешняя печатная форма параметры печати ОткрытиеФормы печать бирок ПечатьДокументов передача параметров клиента сервер УФ ERP клиент

Шаблон внешней печатной управляемой формы с возможностью передачи параметров из клиентской формы в стандартную общую форму печати документов (проверено на 1С:ERP Управление предприятием 2 (2.4.6.230)).

В процессе написания внешней печатной формы для 1С:ERP Управление предприятием 2 (2.4.6.230), которая, в соответствии с параметрами введенными пользователем в форму, вызываемую при нажатии на соответствующий пункт подменю печати , выводит нужное количество бирок на печать, мною было потрачено много времени на то, чтобы табличный документ, созданный в модуле внешней печатной формы, затем открывался при помощи общей формы печати документов.

Проблема, как мы понимаем, заключается в том, что сначала: нам нужно вызвать на клиенте внешнюю печатную форму, после того как пользователь введет параметры передать их в общую форму печати документов, которая, в свою очередь, должна вызвать процедуру модуля внешней печатной формы - передав в неё нужные параметры, которые пользователь ввел при вызове формы внешней печатной форме на клиенте. Последовательность действий определена и понятна, но тут нужно учитывать креатив создателей общей формы печати документов, единственная переменная, которая может быть передана по всем интересующим звеньям – это массив объектов печати. Сначала я решил не возиться с передачей при помощи массива, а передать параметры через хранилище настроек, но доступ к хранилищам оказался очень ограничен по ролям пользователей, поэтому пришлось вернуться к массиву.

Итак, описание процедур и функций внешней печатной формы:

  1. В модуле обработки создаем обязательные процедуры необходимые для регистрации обработки в базе:
# Область ОбщиеСведения



Функция СведенияОВнешнейОбработке() Экспорт

                ПараметрыРегистрации = Новый Структура;

                МассивНазначений = Новый Массив;

                МассивНазначений.Добавить("Документ.РеализацияТоваровУслуг"); //Указываем документ к которому делаем внешнюю печ. форму

                Попытка

                                //Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиДополнительныйОтчет();

                                Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиПечатнаяФорма();

                                //Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиДополнительнаяОбработка();

                                //Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиЗаполнениеОбъекта();

                Исключение

                                //Вид = "ДополнительныйОтчет";

                                Вид = "ПечатнаяФорма";

                                //Вид = "ДополнительнаяОбработка";

                                //Вид = "ЗаполнениеОбъекта";

                КонецПопытки;              

                ПараметрыРегистрации.Вставить("Вид", Вид); //может быть - ПечатнаяФорма, ЗаполнениеОбъекта, ДополнительныйОтчет, СозданиеСвязанныхОбъектов...

                ПараметрыРегистрации.Вставить("Назначение", МассивНазначений);

                ПараметрыРегистрации.Вставить("Наименование", "Шаблон - открытие формы"); //имя под которым обработка будет зарегестрирована в справочнике внешних обработок

                ПараметрыРегистрации.Вставить("БезопасныйРежим", ЛОЖЬ);

                ПараметрыРегистрации.Вставить("Версия", "1.0");

                ПараметрыРегистрации.Вставить("Информация", "Внешняя печатная форма");

                ТаблицаКоманд = ПолучитьТаблицуКоманд();

                //ОткрытиеФормы – Открывает форму обработки.

                //ВызовКлиентскогоМетода – будет вызвана клиентская процедура из модуля формы обработки.

                //ВызовСерверногоМетода  - будет вызвана серверная процедура из модуля обработки.

                //СценарийВБезопасномРежиме – тоже будет вызвана серверная процедура из модуля обработки в безопасном режиме.

                Попытка

                                //Тип = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыВызовСерверногоМетода();

                                //Тип = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыВызовКлиентскогоМетода();

                                Тип = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыОткрытиеФормы();

                Исключение

                                //Тип = "ВызовСерверногоМетода";

                                //Тип = "ВызовКлиентскогоМетода";

                                Тип = "ОткрытиеФормы";

                КонецПопытки;              

                ДобавитьКоманду(ТаблицаКоманд, "Шаблон - открытие формы", "ШаблонОткрытиеФормы", Тип, Истина);

                ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);

                Возврат ПараметрыРегистрации;         

КонецФункции // СведенияОВнешнейОбработке()



Функция ПолучитьТаблицуКоманд()

                Команды = Новый ТаблицаЗначений;

                Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));//как будет выглядеть описание печ.формы для пользователя

                Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка")); //имя макета печ.формы

                Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка")); //ВызовСерверногоМетода

                Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));

                Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));

                Возврат Команды;

КонецФункции



Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "")

                НоваяКоманда = ТаблицаКоманд.Добавить();

                НоваяКоманда.Представление = Представление;

                НоваяКоманда.Идентификатор = Идентификатор;

                НоваяКоманда.Использование = Использование;

                НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;

                НоваяКоманда.Модификатор = Модификатор;

КонецПроцедуры



# КонецОбласти

 

  1. Создаем реквизит внешней печатной формы «СтруктураПараметровПечати» с типом «Произвольный». Я использовал его в процессе отладки печати для передачи параметров формы на клиенте в серверные процедуры модуля обработки. Реквизит не обязательный. Создаем форму для отображения пользователю, данная форма позволит пользователю ввести нужные параметры. В модуле формы создаем обязательные процедуры необходимые для получения объектов печати при вызове обработки, когда она будет подключена к базе.
&НаКлиенте

Процедура Печать(ИдентификаторКоманды, ОбъектыНазначения) Экспорт

                СтруктураПараметровПечати = Объект.СтруктураПараметровПечати;

                Если СтруктураПараметровПечати = Неопределено ИЛИ НЕ ТипЗнч(СтруктураПараметровПечати) = Тип("Структура") Тогда

                                СтруктураПараметровПечати = Новый Структура;

                КонецЕсли;

                СтруктураПараметровПечати.Вставить("МассивОбъектов", ОбъектыНазначения);

КонецПроцедуры



&НаСервере

Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)

                Если Элементы.Найти("Документ") = Неопределено Тогда

                                Если НЕ Параметры.Свойство("ОбъектыНазначения") Тогда   

                                                Сообщить("Ошибка получения докумнта!");

                                                Отказ = Истина;

                                                Возврат;

                                КонецЕсли;

                КонецЕсли;       

                СтруктураПараметровПечати = Объект.СтруктураПараметровПечати;

                Если СтруктураПараметровПечати = Неопределено ИЛИ НЕ ТипЗнч(СтруктураПараметровПечати) = Тип("Структура") Тогда

                                СтруктураПараметровПечати = Новый Структура;

                КонецЕсли;

                Если Параметры.Свойство("ОбъектыНазначения") Тогда

                                МассивОбъектов = Новый Массив;

                                Для Каждого мЭл Из Параметры.ОбъектыНазначения Цикл

                                                МассивОбъектов.Добавить(мЭл);

                                КонецЦикла;

                                Если НЕ Элементы.Найти("Документ") = Неопределено И НЕ МассивОбъектов.Количество() = 0 Тогда

                                                Документ = МассивОбъектов[0];

                                КонецЕсли;       

                                СтруктураПараметровПечати.Вставить("МассивОбъектов", МассивОбъектов);

                КонецЕсли;

                Объект.СтруктураПараметровПечати = СтруктураПараметровПечати;

                ПечатьБирок = Истина;

КонецПроцедуры

 

ОбъектыНазначения – это массив, в который  платформа помещает объекты печати.

 

  1. В модуле формы: создаем процедуры которые будут отображать табличный документ. При отладке при помощи метода «Показать» табличного документа. Для отображения табличного документа при помощи общей формы вызываем форму печати документов и передаем в неё параметры поместив их в массив «ОбъектыНазначения» элемента структуры «ПараметрыИсточника». Кроме того, необходимо в параметры открытия общей формы поместить элемент с ключом «ИсточникДанных» и в качестве значения поместить ссылку на элемент справочника -  «ДополнительныеОтчетыИОбработки», который будет создан при подключении печатной формы к базе. Это необходимо для того чтобы общая форма при создании на сервере вызвала модуль внешней печатной формы и создала табличный документ.

 

&НаКлиенте

Процедура ПечатьНаКлиенте()

                Если Отладка Тогда

                                мКоллекцияПечатныхФорм = УправлениеПечатьюКлиент.НоваяКоллекцияПечатныхФорм("ШаблонОткрытиеФормы");

                                ТабличныйДокумент = Новый ТабличныйДокумент;

                                КнПечатьНаСервере(мКоллекцияПечатныхФорм);

                                Попытка

                                                ТабличныйДокумент = Объект.СтруктураПараметровПечати.КоллекцияПечатныхФормСтруктура.ТабличныйДокумент;

                                                ТабличныйДокумент.Показать("Шаблон - открытие формы");

                                Исключение

                                КонецПопытки;              

                Иначе

                                ПараметрыОткрытия = Новый Структура;

                                ПолучитьПараметрыОткрытия(ПараметрыОткрытия);

                                Если ПараметрыОткрытия = Неопределено Тогда

                                                Сообщить("Ошибка обработки документа");

                                Иначе

                                                ОткрытьФорму("ОбщаяФорма.ПечатьДокументов", ПараметрыОткрытия);

                                КонецЕсли;       

                                Закрыть();

                КонецЕсли;       

КонецПроцедуры



&НаСервере

Процедура ПолучитьПараметрыОткрытия(ПараметрыОткрытия)

                ИсточникДанных = Справочники.ДополнительныеОтчетыИОбработки.НайтиПоНаименованию("Шаблон - открытие формы");

                Если ИсточникДанных = Неопределено ИЛИ НЕ ТипЗнч(ИсточникДанных) = Тип("СправочникСсылка.ДополнительныеОтчетыИОбработки") Тогда

                                ИсточникДанных = Справочники.ДополнительныеОтчетыИОбработки.ПустаяСсылка();

                КонецЕсли;

                Если Не ЗначениеЗаполнено(ИсточникДанных) Тогда

                                ПараметрыОткрытия = Неопределено;

                                Возврат;

                КонецЕсли;

                ПараметрыОткрытия.Вставить("ИсточникДанных", ИсточникДанных);

                ПараметрыИсточника = Новый Структура;

                ИдентификаторКоманды = "ШаблонОткрытиеФормы";

                ПараметрыПечати = Новый Структура;

                ПараметрыПечати.Вставить("ПечатьБирок", ПечатьБирок);

                ПараметрыПечати.Вставить("КоличествоБирок", КоличествоБирок);

                СтруктураПараметровПечати = Объект.СтруктураПараметровПечати;

                Если СтруктураПараметровПечати = Неопределено ИЛИ НЕ ТипЗнч(СтруктураПараметровПечати) = Тип("Структура") Тогда

                                Если Элементы.Найти("Документ") = Неопределено Тогда

                                                ПараметрыОткрытия = Неопределено;

                                                Возврат;

                                Иначе  

                                                Если ЗначениеЗаполнено(Документ) Тогда

                                                                ТекОбъектыНазначения = Новый Массив;

                                                                ТекОбъектыНазначения.Добавить(Документ);

                                                                ТекОбъектыНазначения.Добавить(ПараметрыПечати);

                                                                ПараметрыИсточника.Вставить("ОбъектыНазначения", ТекОбъектыНазначения);

                                                Иначе  

                                                                ПараметрыОткрытия = Неопределено;

                                                                Возврат;

                                                КонецЕсли;

                                КонецЕсли;

                Иначе

                                Если СтруктураПараметровПечати.Свойство("МассивОбъектов") Тогда

                                                СтруктураПараметровПечати.МассивОбъектов.Добавить(ПараметрыПечати);

                                                ПараметрыИсточника.Вставить("ОбъектыНазначения", СтруктураПараметровПечати.МассивОбъектов);

                                Иначе  

                                                Если ЗначениеЗаполнено(Документ) Тогда

                                                                ТекОбъектыНазначения = Новый Массив;

                                                                ТекОбъектыНазначения.Добавить(Документ);

                                                                ТекОбъектыНазначения.Добавить(ПараметрыПечати);

                                                                ПараметрыИсточника.Вставить("ОбъектыНазначения", ТекОбъектыНазначения);

                                                Иначе  

                                                                ПараметрыОткрытия = Неопределено;

                                                                Возврат;

                                                КонецЕсли;

                                КонецЕсли;

                КонецЕсли;

                ПараметрыИсточника.Вставить("ИдентификаторКоманды", ИдентификаторКоманды);

                ПараметрыОткрытия.Вставить("ПараметрыИсточника", ПараметрыИсточника);

                ПараметрыОткрытия.Вставить("ПараметрКоманды", ПараметрыИсточника.ОбъектыНазначения);

КонецПроцедуры

 

  1. В модуле внешней печатной формы создаем обязательную процедуру: «Печать», которая будет вызвана из процедуры общей формы печать документов – «ПриСозданииНаСервере».

В процедуре печати получаем массив, в котором передавали параметры печати, параметры - помещаем в нужную переменную. Элемент массива, который хранил нужные нам параметры, удаляем. Я прописал удаление перед каждым вызовом общих процедур, для того чтобы убедиться в том, что внутри общих процедур переменная хранящая массив и переданная в процедуру печати модуля внешней печатной формы не перезаполняется из переменной общей формы печати документов.

Процедура Печать(МассивОбъектов = Неопределено, КоллекцияПечатныхФорм = Неопределено,

                ОбъектыПечати = Неопределено, ПараметрыВывода = Неопределено) Экспорт

                ПараметрыПечати = Неопределено;

                н = 0;

                Если НЕ МассивОбъектов = Неопределено И ТипЗнч(МассивОбъектов) = Тип("Массив") Тогда

                                Для Каждого мЭл Из МассивОбъектов Цикл

                                                Если ТипЗнч(мЭл) = Тип("Структура") Тогда

                                                                ПараметрыПечати = Новый Структура;

                                                                ПараметрыПечати.Вставить("ПечатьБирок", мЭл.ПечатьБирок);

                                                                ПараметрыПечати.Вставить("КоличествоБирок", мЭл.КоличествоБирок);

                                        МассивОбъектов.Удалить(н);

                                                КонецЕсли;

                                                н = н + 1;

                                КонецЦикла;

                КонецЕсли;

                Если ПараметрыПечати = Неопределено Тогда

                                СтруктураПараметровПечати = ЭтотОбъект.СтруктураПараметровПечати;

                                ПараметрыПечати = Новый Структура;

                                Если НЕ СтруктураПараметровПечати = Неопределено И ТипЗнч(СтруктураПараметровПечати) = Тип("Структура") Тогда

                                                ПараметрыПечати.Вставить("ПечатьБирок", СтруктураПараметровПечати.ПараметрыПечати.ПечатьБирок);

                                                ПараметрыПечати.Вставить("КоличествоБирок", СтруктураПараметровПечати.ПараметрыПечати.КоличествоБирок);

                                                МассивОбъектов = Новый Массив;

                                                Для Каждого мЭл Из СтруктураПараметровПечати.МассивОбъектов Цикл

                                                                МассивОбъектов.Добавить(мЭл);

                                                КонецЦикла;

                                                КоллекцияПечатныхФорм = Новый ТаблицаЗначений;

                                                Для Каждого ЭлСтруктуры Из СтруктураПараметровПечати.мКоллекцияПечатныхФорм[0] Цикл

                                                                КоллекцияПечатныхФорм.Колонки.Добавить(ЭлСтруктуры.Ключ);

                                                КонецЦикла;

                                                СтрКоллекцияПечатныхФорм = КоллекцияПечатныхФорм.Добавить();

                                                ЗаполнитьЗначенияСвойств(СтрКоллекцияПечатныхФорм, СтруктураПараметровПечати.мКоллекцияПечатныхФорм[0]);

                                                ОбъектыПечати = Новый СписокЗначений;

                                ОбъектыПечати.ЗагрузитьЗначения(СтруктураПараметровПечати.ОбъектыПечати.ВыгрузитьЗначения());

                                                ПараметрыВывода = Новый Структура;

                                                Для Каждого ЭлСтруктуры Из СтруктураПараметровПечати.ПараметрыВывода Цикл

                                                                ПараметрыВывода.Вставить(ЭлСтруктуры.Ключ, ЭлСтруктуры.Значение);

                                                КонецЦикла;

                                КонецЕсли;

                КонецЕсли;

                Если ПараметрыПечати = Неопределено Тогда

                                Сообщить("Не удалось определить параметры печати!");

                                Возврат;

                КонецЕсли;       

                Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "ШаблонОткрытиеФормы") Тогда

                                УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(

                                                КоллекцияПечатныхФорм,

                                                "ШаблонОткрытиеФормы",

                                                НСтр("ru = 'Шаблон - открытие формы'"),

                                                СформироватьПечатнуюФормуНакладная(МассивОбъектов, ОбъектыПечати, ПараметрыПечати));

                КонецЕсли;

                Если НЕ МассивОбъектов = Неопределено И ТипЗнч(МассивОбъектов) = Тип("Массив") Тогда

                                н = 0;

                                Для Каждого мЭл Из МассивОбъектов Цикл

                                                Если ТипЗнч(мЭл) = Тип("Структура") Тогда

                                        МассивОбъектов.Удалить(н);

                                                КонецЕсли;

                                                н = н + 1;

                                КонецЦикла;

                КонецЕсли;

                Если ПараметрыВывода.Свойство("ПараметрыОтправки") Тогда

                                ФормированиеПечатныхФорм.ЗаполнитьПараметрыОтправки(

                                                ПараметрыВывода.ПараметрыОтправки,

                                                МассивОбъектов,

                                                КоллекцияПечатныхФорм);

                Иначе

                                ОбщегоНазначенияБП.ЗаполнитьДополнительныеПараметрыПечати(МассивОбъектов,

                                                КоллекцияПечатныхФорм,

                                                ОбъектыПечати,

                                                ПараметрыВывода);

                                                КоллекцияПечатныхФормСтруктура = Новый Структура;

                                                Для Каждого Колонка Из КоллекцияПечатныхФорм.Колонки Цикл

                                                                КоллекцияПечатныхФормСтруктура.Вставить(Колонка.Имя, КоллекцияПечатныхФорм[0][Колонка.Имя]);

                                                КонецЦикла;

                                                ЭтотОбъект.СтруктураПараметровПечати = Новый Структура("КоллекцияПечатныхФормСтруктура,ОбъектыПечати,ПараметрыВывода",

                                                КоллекцияПечатныхФормСтруктура, ОбъектыПечати, ПараметрыВывода);

                КонецЕсли;                       

КонецПроцедуры

 

Скачать файлы

Наименование Файл Версия Размер
Шаблон внешней печатной управляемой формы с возможностью передачи параметров из клиентской формы в стандартную общую форму печати документов:

.epf 16,43Kb
14.04.19
10
.epf 16,43Kb 10 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
1. TrinitronOTV 5 15.04.19 12:38 Сейчас в теме
По вашему описанию попробовал создать DGA и возникли такие ошибки:
1. В модуле формы
{ВнешняяОбработка.ШаблонВнешняяПечатнаяФорма.Форма.Форма.Форма(55,3)}: Процедура или функция с указанным именем не определена (КнПечатьНаСервере)
<<?>>КнПечатьНаСервере(мКоллекцияПечатныхФорм); (Проверка: Тонкий клиент)

2. В модуле объекта
{ВнешняяОбработка.ШаблонВнешняяПечатнаяФорма.МодульОбъекта(162,3)}: Переменная не определена (ФормированиеПечатныхФорм)
<<?>>ФормированиеПечатныхФорм.ЗаполнитьПараметрыОтправки(ПараметрыВывода.ПараметрыОтправки, МассивОбъектов, КоллекцияПечатныхФорм); (Проверка: Сервер)
{ВнешняяОбработка.ШаблонВнешняяПечатнаяФорма.МодульОбъекта(146,4)}: Процедура или функция с указанным именем не определена (СформироватьПечатнуюФормуНакладная)
<<?>>СформироватьПечатнуюФормуНакладная(МассивОбъектов, ОбъектыПечати, ПараметрыПечати)); (Проверка: Сервер)
2. user995537 23 15.04.19 14:01 Сейчас в теме
(1) В приложенном файле процедура КнПечатьНаСервере отвечает за вывод табличного документа на экран при открытии формы через меню "Файл" - "Открыть". Выложить шаблон бесплатно не удалось. Если интересует могу бросить шаблон на почту.
Оставьте свое сообщение

См. также

Мастер печатных форм v 3.1 Промо

Универсальные печатные формы v8 v8::УФ v8::СКД 1cv8.cf Абонемент ($m)

Создание печатных форм "с нуля" за несколько минут. Моментальная отладка. Не требует знания встроенного языка 1С.

8 стартмани

07.03.2014    89588    384    kser87    210    

Шаблон внешней печатной формы в формате office open XML (Microsoft Word, OpenOffice.org Writer, Google Docs и др.)

Универсальные печатные формы v8 1cv8.cf Абонемент ($m)

В данной публикации я хочу поделиться шаблоном внешней печатной формы в формате office open XML (Microsoft Word, OpenOffice.org Writer, Google Docs и др.) с использованием БСП.

1 стартмани

10.03.2020    1674    5    pavelpribytkin96    0    

Печать пропусков в Камин 3.0 и Камин 5.0. Обычные формы и управляемые формы

Универсальные печатные формы Пакетная печать v8 v8::УФ 1cv8.cf Абонемент ($m)

Внешний произвольный отчет для 1с КАМИН:Расчет заработной платы. Версия 3.0. и 5.0 Позволяет печатать пропуска на выбор из папки с табельными номерами в формате jpg  либо из карточки сотрудника в Камине 3.0 и 5.0

1 стартмани

11.02.2020    1468    2    peshitepisma    0    

Печать и сравнение справочников, документов (печать реквизитов и табличных частей) (обычные и управляемые формы)

Универсальные печатные формы v8 v8::УФ 1cv8.cf Абонемент ($m)

Печать реквизитов и табличных частей объектов метаданных, сравнение объектов с выводом на печать.

1 стартмани

26.12.2019    1750    3    Denr83    0    

Печатная форма, сделанная как расширение конфигурации для БП 3.0. Новые возможности БСП Промо

Практика программирования Универсальные печатные формы v8 БП3.0 Абонемент ($m)

Печатные формы на внешних обработках скоро канут в лету. На смену им приходят ПФ, реализованные в виде расширений конфигурации. Не нашел на сайте примеров таких расширений. Привожу пример подобного расширения для БП 3.0.

1 стартмани

06.12.2017    24838    49    kwazi    6    

Заполнение шаблона Word docx на сервере, без ComОбъект и внешних компонент, только механизмами самой Платформы 1С, методом XML-инъекции

Универсальные печатные формы Печатные формы документов v8 v8::УФ 1cv8.cf Россия Абонемент ($m)

Внешние печатные формы для документа Счет на оплату позволяют сформировать на сервере без использования технологии OLE (Com объекта) и сохранить на печать заполненные docx шаблоны договора поставки и спецификации к договору (УНФ 1.6) (идея универсальна, подойдет для любой конфигурации). Используются только средства самой Платформы 1С:Предприятие 8.3 (8.3.13.1644). Проверено на релизе УНФ 1.6.16.176.

1 стартмани

23.12.2019    7166    26    1sig    3    

Печать штрихкода для любой конфигурации на платформе 8.3

Универсальные печатные формы v8 v8::УФ 1cv8.cf Россия Абонемент ($m)

Платформы младше 8.3.12.1313 использовали ActivX для печати ШтрихКода, сейчас технология изменилась. Эта обработка - замена старого механизма на новый.

2 стартмани

07.11.2019    8813    20    ah7777777    4    

Вывод QR-кода типовыми средствами.

Универсальные печатные формы Сканер штрих-кода Универсальные функции v8 КА1 УТ10 УПП1 Абонемент ($m)

Вывод QR-кода типовыми средствами. На данный момент очень часто нужно вывести в печатную форму QR-код. Показываю как на примере типового кода из УТ11 это сделать. Можно использовать в любых конфигурациях с обычными формами.

1 стартмани

21.10.2019    12501    24    Емельянов Алексей    45    

Создание и печать этикеток (ценников). Со штрих-кодами и без. Универсальная обработка Промо

Универсальные печатные формы Ценники Розничная торговля Розничная торговля v8 1cv8.cf Абонемент ($m)

Эта обработка (в составе демонстрационной конфигурации) представляет собой инструмент, который позволяет делать только лишь два полезных действия: 1. создать макет для печати этикеток (ценников) в пользовательском режиме 2. напечатать заданное количество этикеток (ценников) по выбранной номенклатуре. НО!...

5 стартмани

18.07.2015    67606    260    kentavr27    49    

Пример внешней печатной формы макета Word (двоичные данные) с клиента

Универсальные печатные формы v8 v8::УФ 1cv8.cf Абонемент ($m)

Что делать, если ваша 1С-база клиент-серверная и обычные процедуры получения и заполнения макета Word &НаСервере выдают ошибки? Выход есть! Он представлен в моем примере дополнительной печатной формы с тестовым макетом Word.

1 стартмани

05.09.2019    4409    18    ekaterinaeon    0    

Универсальные печатные формы в управляемой форме

Универсальные печатные формы v8::УФ 1cv8.cf Казахстан Абонемент ($m)

Универсальные печатные формы + Возможность редактировать печатную форму в режиме предприятия на лету + Код заполнения в режиме предприятий + Конструктор запросов и конструктор заполнения областей + Хранит и восстанавливает версий макет и кода заполнения + Легко для изучения и работы не для программистов

5 стартмани

01.07.2019    4755    13    t_prog    0    

Печать бухгалтерской справки для любого документа Промо

Универсальные печатные формы Печатные формы документов v8 УПП1 БУ НУ Абонемент ($m)

Универсальная печать бухгалтерской справки для любого документа.

1 стартмани

13.11.2013    25530    10    stsasha87    5    

Печать штрихкода

Универсальные печатные формы v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработка на управляемых формах. Доступны три варианта печати штрихкода: пользователи, контрагенты и номенклатура.

1 стартмани

28.06.2019    2670    5    v3132    0    

Редактор-конструктор визиток

Универсальные печатные формы v8 Издательство, полиграфия, упаковка Абонемент ($m)

Интерактивный редактор-конструктор визиток / персональных карточек на основании макетов.

5 стартмани

16.06.2019    3861    4    eugenevk    6    

Подсистема справок (ЗУП 3.х)

Универсальные печатные формы Справки Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 v8::СПР ЗУП3.x БУ Абонемент ($m)

Подсистема справок внешней печатной формой для 1C: Зарплата и Управление Персоналом, редакция 3.х.

1 стартмани

25.04.2019    10752    19    🅵🅾️🆇    16    

Подсистема "Настраиваемые печатные формы" Промо

Универсальные печатные формы v8 1cv8.cf Россия Абонемент ($m)

Универсальная подсистема "Настраиваемые печатные формы" предназначена для создания и редактирования печатных форм справочников и документов в режиме 1С:Предприятия. Создание печатной формы может занять всего несколько минут (в зависимости от сложности макета). Подсистему можно использовать в любой конфигурации. Подсистема разработана только для режима запуска "Обычное приложение".

1 стартмани

20.06.2012    35147    39    Gmix    88    

Универсальная печатная форма "Анализ объекта" + шаблон подключаемой обработки для 1С на управляемых формах

Универсальные обработки Универсальные печатные формы v8 v8::УФ 1cv8.cf Россия Абонемент ($m)

Универсальная печатная форма для всех программ на управляемых формах. Результат печати содержит все реквизиты и табличные части любого документа или справочника (имя + синоним + значение реквизита или поля табличной части), показывает уникальный идентификатор (УИД/GUID) объекта и дату создания (даже справочника!) на основании УИД. Отказоустойчивость кода обработки позволяет ей открываться как в типовых, так и в самописных программах (большинство обычных внешних печатных форм этого не могут). Кроме интерактивного открытия есть возможность подключения к конфигурации. После добавления появится команда печати почти во всех документах и справочниках. Автоматически определяет среду подключения и выбирает доступный вариант вывода: общая форма печати или же отображение табличного документа в новой форме. Все реквизиты объекта получает запросом, а не перебором строк, это делает быстрым выполнение команды.

2 стартмани

05.04.2019    10304    26    Aleksandr55555    4    

Счет на оплату, ТОРГ-12, Счет-фактура, УПД для 1С: ERP (комплект пакета одним файлом)

Печатные формы документов Оптовая торговля Универсальные печатные формы Оптовая торговля v8 v8::УФ ERP2 Россия БУ Абонемент ($m)

Комплект рабочих внешних печатных форм за 2019 для 1С: ERP (версия 2.4) Управление предприятием 2 для дальнейших разработок. Простата в установке. Добавил и пользуйся. Либо для тестирование. С формой для откладки. В комплект пакета входит: Счет фактура; Торг-12, счет-фактура, упд (Универсальный передаточный документ).

2 стартмани

01.04.2019    3742    13    Kontakt    4    

Шаблон внешней печатной формы для БСП с универсальной формой тестирования

Универсальные печатные формы v8 ERP2 ЗКГУ3.0 БП3.0 УТ11 КА2 ЗУП3.x Россия Абонемент ($m)

Данный шаблон содержит форму тестирования печати для конфигураций, разработанных на базе БСП. Форма универсальная - сама определяет команды печати и поддерживаемые объекты. Не требует доработок. Скопируйте ее в ваши обработки печатных форм и назначьте основной. Далее тестируйте через файл-открыть.

1 стартмани

25.03.2019    4373    17    aves    2    

Создание произвольных кадровых документов по шаблону Word в ЗУП 3.1 Промо

Универсальные печатные формы Документооборот и делопроизводство Управление персоналом (HRM) Документооборот и делопроизводство Управление персоналом (HRM) v8 v8::СПР ЗУП3.x Россия БУ УУ Абонемент ($m)

В работе кадровых служб часто встречается задача оперативно подготовить кипу однотипных документов (персональные справки, дополнительные соглашения и т.д.). Создайте шаблон нужного документа и отдайте заполнить Вашему помощнику - 1C.

1 стартмани

24.10.2013    24993    34    it4hr    21    

Макет оформления "Печатные формы" для отчетов на СКД (черно-белый)

Универсальные печатные формы v8 v8::СКД 1cv8.cf Абонемент ($m)

Готовый макет оформления для отчетов СКД. Макет представляет собой простой черно-белый вариант, с крупным шрифтом в группировках.

1 стартмани

15.03.2019    7796    7    rpgshnik    5    

Простой календарь

Универсальные печатные формы v8::УФ 1cv8.cf Абонемент ($m)

Простой календарь на формат А4

1 стартмани

13.12.2018    3644    1    malev    7    

Вывод QR-кода типовыми средствами. Управляемое и обычное приложение

Универсальные печатные формы v8 v8::УФ 1cv8.cf Россия Абонемент ($m)

Печать QR кода с использованием лишь одной обработки. Подойдет как при разработке своей конфигурации, так и при использовании типовой. Тестировал на 1С: Реестр государственного и муниципального имущества, редакция 3.0 (3.0.2.9), 1С: УНФ 1.6.19.203

1 стартмани

12.12.2018    4518    8    user785225    2    

Универсальная печать нескольких печатных форм документа с указанным количеством копий одной кнопкой Промо

Универсальные печатные формы Печатные формы документов Документооборот и делопроизводство Документооборот и делопроизводство v8 БП2.0 УТ10 Россия Абонемент ($m)

Это не пакетная печать, это внешняя печатная форма документа, позволяющая запускать другие внешние печатные формы этого же документа в заданном заранее количестве копий, то есть выдает пакет печатных форм нажатием одной кнопки. Обработка универсальная, подходит для любого документа. Тестировалась на конфигурации УТ, но думаю будет работать и на других.

1 стартмани

19.04.2012    28308    18    andrey1312    10    

Шаблон внешней печатной формы (УФ) с формой для отладки

Универсальные печатные формы v8 v8::УФ 1cv8.cf Украина Абонемент ($m)

Шаблон внешней печатной формы (УФ) с формой для отладки, выводом макета на всех языках конфигурации.

1 стартмани

12.12.2018    5512    6    agressor    11    

Разовое начисление для ЗГУ 3.1 (шаблон)

Универсальные печатные формы Печатные формы документов Зарплата Зарплата v8 v8::УФ ЗКГУ3.0 БУ Госбюджет Абонемент ($m)

Шаблон внешней печатной формы для документа Разовое Начисление и не только.

1 стартмани

22.11.2018    5527    6    iPanda    0    

Шаблоны печатных форм на лету!

Универсальные печатные формы v8 Россия Абонемент ($m)

Справочник шаблонов печатных форм. Платформа 1С:Предприятие 8.3 (8.3.12.1616). Функционал новой платформы не использовался.

1 стартмани

12.11.2018    7109    17    zykov_vitaliy    5    

Создание внешней печатной формы под Управляемое Приложение (Управление Торговлей 11.1.1.11) Промо

Универсальные печатные формы v8 УТ10 Россия Абонемент ($m)

Создание внешней печатной формы под Управляемое Приложение (Управление Торговлей 11.1.1.11)

1 стартмани

28.03.2013    145768    117    Stradivari    31    

Универсальный печатный шаблон WORD

Печатные формы документов Универсальные печатные формы v8::УФ 1cv8.cf Россия Абонемент ($m)

Было это в УПП 1.3, кадровики достали с печатками (здесь запятой не хватает, здесь ошибка и т.д.). Сделал обработку, научил. К сожалению,  эта обработка была глубоко интегрирована в УПП, поэтому простой перенос не подошёл. Поэтом перенес на УФ в расширение.

1 стартмани

13.08.2018    7099    8    SanyMaga    4    

Конструктор Word для типовой конфигурации 1C: Зарплата и управление персоналом 3.1.6

Универсальные печатные формы Управление персоналом (HRM) Управление персоналом (HRM) v8 v8::СПР ЗКГУ3.0 ЗУП3.x Россия БУ Абонемент ($m)

Внешняя печатная форма Для создания Word документов практически для всех документов и даже белее. ЗиК 3.1.6, 3.1.7.

2 стартмани

09.06.2018    10168    35    nkp14108    13    

Печать непроведённых документов (Расширение)

Универсальные печатные формы Печатные формы документов Зарплата Зарплата v8 v8::СПР ЗКГУ3.0 ЗУП3.x Абонемент ($m)

Расширение добавляет возможность печатать любой документ, не проверяя его на проведённость.

1 стартмани

12.04.2018    9533    14    the1    3    

Конфигурация "Умные документы". Создание документов по шаблонам Промо

Документооборот и делопроизводство Универсальные печатные формы Документооборот и делопроизводство v8 Россия УУ Абонемент ($m)

Данная конфигурация предназначена для создания готовых документов по шаблонам следующих форматов: MS Word, MS Excel, txt, rtf и mxl. Программа позволяет, используя шаблон, прикрепленный в базу с занесенными в него метками специального формата, создавать документ который нуждается в минимальной ручной обработке пользователем. Конфигурация умеет склонять слова, использовать функцию формат для данных типа число и дата, работать со строками и датами - полный перечень доступных функций можно найти в инструкции.

1 стартмани

18.12.2012    35124    19    Silenser    20    

Внешняя печатная форма с вводом параметров через дополнительную форму

Универсальные печатные формы Практика программирования v8 1cv8.cf Россия Абонемент ($m)

Удобный ввод параметров в печатную форму с помощью дополнительной формы

1 стартмани

23.03.2018    19832    52    Margo462    7    

Обработка печатной формы WORD клиент-сервер УФ

Универсальные печатные формы v8::УФ 1cv8.cf Абонемент ($m)

Это моя первая статья на данном портале, но попытаюсь изложить все понятно и подробно. Долгое время у меня заняло создание такой вот внешней обработки. Есть очень много примеров, как сделать подобное на неуправляемых формах (2.0) и очень мало информации касательно управляемых(3.0), по крайней мере я многого найти не смог в доступе. Создание подобное обработки выглядит вполне несложно, если производить все действия на сервере, как это было с 2.0, но в нашем случае необходимо инициализировать открытие документа на клиенте, чему сильно мешает отсутствие возможности передать макет Active Document с сервера на клиент.

2 стартмани

14.03.2018    23773    83    LeoKeyn    41    

Пользовательские макеты для внешних печатных форм (обработок)

Практика программирования Универсальные печатные формы v8 v8::СКД 1cv8.cf Россия Абонемент ($m)

Расширение БСП по реализации механизма пользовательских макетов для обработок внешних печатных форм.

2 стартмани

05.03.2018    16627    13    simy4    13    

Конструктор внешних печатных форм NEW beta (обычные и управляемые приложения!) Промо

Универсальные печатные формы Инструментарий разработчика v8 1cv8.cf Абонемент ($m)

Версия NEW beta=) "Конструктор внешних печатных форм" максимально автоматизирует процесс создания внешних печатных форм на основе типовых. Создание внешней печатной формы займет от секунд до пары минут! Теперь и на управляемых приложениях =)

1 стартмани

18.11.2012    66687    276    SeiOkami    182    

Внешняя печатная форма с отладкой (шаблон) для управляемых форм

Универсальные печатные формы Печатные формы документов v8 v8::УФ БП3.0 ЗУП3.x Абонемент ($m)

Шаблон обработки предназначен для разработки внешних печатных форм с удобным механизмом отладки. Пример внешней печатной формы "Счет на оплату покупателю" для БП 3.0.64.28

1 стартмани

12.02.2018    14671    70    Mx00    24    

Формирование комплекта печатных форм в типовых конфигурациях для разнотипных документов

Универсальные печатные формы Печатные формы документов v8 v8::БУ v8::ОУ 1cv8.cf Россия БУ УУ Абонемент ($m)

В типовых конфигурациях используется подход к формированию комплекта печатных форм для одного вида документа, что не всегда удобно. В статье рассмотрен способ печати комплекта печатных форм для группы различных видов документов на базе типового (БСП) механизма печати.

1 стартмани

28.12.2017    25864    84    gzharkoj    6    

Простой вывод табличного документа в общую форму "Печать документов", с использованием БСП

Универсальные печатные формы v8 УТ11 Россия Абонемент ($m)

Простой вывод табличного документа из модуля формы внешней обработки, в общую форму "Печать документов", с использованием БСП. Проверялось на версии БСП 2.2.5.30 в конфигурации УТ 11.1.

1 стартмани

08.12.2017    25179    13    dmitry1975    18    

Внешняя печатная форма с использованием БСП и вызовом клиентского метода

Универсальные печатные формы БСП (Библиотека стандартных подсистем) v8 1cv8.cf Россия Абонемент ($m)

Представляю вашему вниманию небольшую статью-справку по разработке внешней печатной формы с использованием БСП и возможностью ведения диалога с пользователем. Запрос различных данных и т. д.

1 стартмани

02.11.2017    20150    61    Andrew189100    12    

Заполнение шаблона Word на сервере, без использования MS Office (docx -> zip -> xml). Предусмотрен вывод табличных частей

Универсальные печатные формы Инструментарий разработчика v8 v8::УФ 1cv8.cf Абонемент ($m)

Шаблон в Word, управляемые формы. Создание заполнение документа Word (docx -> zip -> xml) по шаблону на сервере без использования MS Office. Предусмотрен вывод табличных частей.

2 стартмани

04.10.2017    24303    176    artms    33    

Универсальная печатная форма Трудового договора на основе шаблона Word для ЗУП 3.1

Универсальные печатные формы Печатные формы документов Управление персоналом (HRM) Управление персоналом (HRM) v8 v8::СПР ЗУП3.x БУ Абонемент ($m)

В обработке используются типовые функции печати договоров. При печати учитываются особенности характера работы сотрудника: Вид занятости, График, Срочность, Форма оплаты и т.д. Банковские реквизиты и основание действия руководителя забираются опционально из дополнительных одноименных реквизитов ввиду отсутствия их в типовой конфигурации.

1 стартмани

06.09.2017    15095    120    Spartacus    2    

Универсальный механизм для создания любой печатной формы в 1С Предприятии 8. Промо

Универсальные печатные формы v8 БП2.0 Россия Абонемент ($m)

Эта бесплатная разработка от ООО "О-Планет" даст возможность сконструировать и подключить в любую конфигурацию 1С:Предприятие 8.2 произвольное количество печатных форм любой сложности. Договора, акты выполненных работ, сертификаты, декларации... Теперь все это стало возможным добавить в свою базу бесплатно, в течение нескольких минут, с помощью нашего универсального конструктора печатных форм.

1 стартмани

05.06.2012    47839    21    O-Planet    80    

Корректная двусторонняя печать табличных документов + Простой пример создания внешней печатной формы

Универсальные печатные формы Практика программирования v8 БП3.0 УТ11 Россия Абонемент ($m)

Статья посвящена двухсторонней печати табличных документов из 1С:Предприятия 8.3. А за одно рассмотрено создание Внешней печатной формы (ВПФ). Публикацию про двустороннюю печать на Инфостарте не нашел. Когда передо мной стояла такая задача, решение нашел не сразу. Делюсь, думаю, для многих эта информация будет полезной.

1 стартмани

31.07.2017    21988    15    SmArtist    8    

Самая универсальная обработка печати документов для 1С 8.3

Универсальные печатные формы Пакетная печать Печатные формы документов v8::БУ v8::УФ ERP2 БП3.0 Абонемент ($m)

При внедрении ERP столкнулись с необходимостью разработать универсальную обработку для печати документов. Основная проблема, помимо групповой печати документов, которую необходимо было решить это возможность при печати разбирать документы по копиям, т.е. если необходимо распечатать большой объем документов в 2 экземплярах, разобрав их по копиям, то сначала печатаются именно 2 копии первого документа, затем 2 копии второго и т.д.

10 стартмани

01.06.2017    18676    35    AlPi    4    

Презентабельная печатная форма в табличном документе с использованием картинок

Универсальные печатные формы v8 1cv8.cf Автомобили, автосервисы Россия Абонемент ($m)

Иногда требуется создать красивую печатную форму с картинками. Но как уместить картинки на лист А4 так чтобы они ровно умещались на листе??? На этот вопрос ответит "Презентабельная печатная форма в табличном документе с использованием картинок". В данном случае это пример коммерческого предложения на Роллс Ройс :)

1 стартмани

14.05.2017    10958    2    Drfreeman    0    

Трудовой договор по шаблону WORD Промо

Универсальные печатные формы Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 ЗУП2.5 Абонемент ($m)

Трудовой договор по шаблону WORD для конфы 8.2 Зарплата и Управление Персоналом, редакция 2.5

1 стартмани

12.08.2011    20802    19    aleksey2    33    

Презентабельная печатная форма в WORD

Универсальные печатные формы Практика программирования v8 1cv8.cf Автомобили, автосервисы Россия Абонемент ($m)

Итак, товарищи, наверняка кому-то из Вас доводилось делать красивые печатные формы. И это очень-очень нудновато, особенно если стоит вопрос работы с MS WORD. Привожу пример моей работы и создания некого "коммерческого предложения" для Лады приоры :)

1 стартмани

06.05.2017    12086    12    Drfreeman    8    

Печать данных в готовые типографские бланки

Управление персоналом (HRM) Универсальные печатные формы Управление персоналом (HRM) v8 1cv8.cf БУ Абонемент ($m)

Универсальная обработка для точного позиционирования и печати требуемых данных в любые шаблоны типографских бланков, анкет и т.д.

2 стартмани

19.10.2016    11369    14    sdin101    4    

Внешняя печатная форма в формате WORD на примере ЗУП 3, работает в файловом и клиент-серверном вариантах

Управление персоналом (HRM) Универсальные печатные формы Управление персоналом (HRM) v8 ЗУП3.x Россия Абонемент ($m)

Пример внешней печатной формы для вывода отчета в MS WORD из конфигурации ЗУП 3, работает как в файловом, так и в клиент-серверном варианте работы 1С.

1 стартмани

14.10.2016    85108    105    flyDrag    8