Вычисление произвольного факториала

Публикация № 426870

Разработка - Практика программирования

Факториал расчет факториала сумма цифр факториала программирование примеры кода

Обработка вычисления произвольного факториала. Just for lulz. =)

Обработка вычисляет произвольный факториал и сумму цифр результата.

Написана просто в качестве развлечения.

Может пригодиться в качестве некоего учебного пособия.

=)

Использовано разбиение строкового представления числа на части по N цифр (устанавливается в коде, по умолчанию выставлено в 8) и дальнейшее умножение данных частей "в столбик". Также внутри функции умножения используется сложение "в столбик" в промежуточных вычислениях.

Функции снабжены комментариями. Функция умножения подробными, сложения - общими (т.к. сложение много проще умножения).

Как-то так...

Пользуйтесь на здоровье! =)

Т.к. теперь невозможно разместить абсолютно бесплатный файл, то прилагаю код обработки:

Перем обMSScriptControl; // Использование MSScript
Перем мЗамерыПроизводительности;

Перем чДлинаСегмента;
Перем сФорматСегмента;

Функция НачатьЗамерПроизводительности()
	
	Если обMSScriptControl = Неопределено Тогда
		СтартВыполнения = ТекущаяДата();
	Иначе
		СтартВыполнения = обMSScriptControl.Eval("(new Date()).valueOf()");
	КонецЕсли;
	
	мЗамерыПроизводительности.Добавить(СтартВыполнения);
	
	Возврат мЗамерыПроизводительности.ВГраница();
	
КонецФункции

Функция ЗавершитьЗамерПроизводительности(бСообщитьВремя = Ложь)
	
	мРезультат = Новый Массив;
	
	ВГраницаЗамеров = мЗамерыПроизводительности.ВГраница();
	Если ВГраницаЗамеров > -1 Тогда
		СтартВыполнения = мЗамерыПроизводительности[ВГраницаЗамеров];
		мЗамерыПроизводительности.Удалить(ВГраницаЗамеров);
	Иначе
		Если бСообщитьВремя Тогда
			Сообщить("Нарушен порядок вызовов вложенных замеров. Замер не выполнен!");
		КонецЕсли;
		
		мРезультат.Добавить(0);
		мРезультат.Добавить("0");
		мРезультат.Добавить(-1);
		
		Возврат мРезультат;
	КонецЕсли;
	
	Если обMSScriptControl = Неопределено Тогда
		ФинишВыполнения = ТекущаяДата();
		ВремяВыполнения = ФинишВыполнения-СтартВыполнения;
		ВремяВыполненияСтр = Формат(ВремяВыполнения, "ЧРД=.; ЧГ=");
	Иначе
		ФинишВыполнения = обMSScriptControl.Eval("(new Date()).valueOf()");
		ВремяВыполнения = (ФинишВыполнения-СтартВыполнения)/1000;
		ВремяВыполненияСтр = Формат(ВремяВыполнения, "ЧДЦ=3; ЧРД=.; ЧН=0; ЧГ=");
	КонецЕсли;
	
	Если бСообщитьВремя Тогда
		Сообщить("Замер производительности "+Формат(ВГраницаЗамеров, "ЧН=; ЧГ=") + ": " + ВремяВыполнения + " сек.");
	КонецЕсли;
	
	мРезультат.Добавить(ВремяВыполнения);
	мРезультат.Добавить(ВремяВыполненияСтр);
	мРезультат.Добавить(ВГраницаЗамеров);
	
	Возврат мРезультат;
	
КонецФункции

Функция СложитьСегментыЧисел(мЧисел)
	
	// мЧисел содержит массивы сегментов складываемых чисел
	// Соответственно:
	// 1. Берем в Результат массив 0-го индекса
	// 2. Посегментно (по правилам сложения в столбик) складываем Результат с массивом 1-го индекса
	// 3. Помещаем результат (также массив сегментов) в Результат.
	// 4. Повторяем, пока не закончились массивы сегментов в мЧисел.
	// 5. Возвращаем Результат.
	
	мРезультат = Новый Массив;
	мРезультат.Добавить("0");
	
	Для каждого мСледЧисло из мЧисел Цикл
		// Определим большее число
		Если мСледЧисло.Количество() > мРезультат.Количество() Тогда
			мЧисло0 = мСледЧисло; // Большее
			мЧисло1 = мРезультат; // Меньшее
		Иначе
			мЧисло0 = мРезультат;
			мЧисло1 = мСледЧисло;
		КонецЕсли;
		
		// Теперь нужно по правилам сложения в столбик прибавить к большему числу, меньшее.
		// Перебираем меньшее и складываем согласно индексов.
		мРезультатСложения = Новый Массив;
		мСуммаСегментов = Новый Массив;
		чВГраницаЧисло0 = мЧисло0.ВГраница();
		чВГраницаЧисло1 = мЧисло1.ВГраница();
		Для Т = 0 по чВГраницаЧисло0 Цикл
			Если Т > чВГраницаЧисло1 Тогда
				Если мСуммаСегментов.Количество() > 1 Тогда
					чСуммаСегментов = Число(мСуммаСегментов[1]) + Число(мЧисло0[Т]);
					мСуммаСегментов = РазбитьЧислоНаСегменты(чСуммаСегментов);
					
					мРезультатСложения.Добавить(мСуммаСегментов[0]);
				Иначе
					мРезультатСложения.Добавить(мЧисло0[Т]);
				КонецЕсли;
				
				Продолжить;
			КонецЕсли;
			
			чСуммаСегментов = Число(мЧисло1[Т]) + Число(мЧисло0[Т]);
			Если мСуммаСегментов.Количество() > 1 Тогда
				чСуммаСегментов = чСуммаСегментов + Число(мСуммаСегментов[1]);
			КонецЕсли;
			мСуммаСегментов = РазбитьЧислоНаСегменты(чСуммаСегментов);
			
			мРезультатСложения.Добавить(мСуммаСегментов[0]);
		КонецЦикла;
		
		Если мСуммаСегментов.Количество() > 1 Тогда
			мРезультатСложения.Добавить(мСуммаСегментов[1]);
		КонецЕсли;
		
		мРезультат = мРезультатСложения;
	КонецЦикла;
	
	Возврат мРезультат;
	
КонецФункции

Функция ПеремножитьСегментыЧисел(мСегменты0, мСегменты1)
	
	// Смысл таков, как при умножении в столбик:
	// 00. Т = 0;
	// 01. Е = 0;
	// 02. Сегмент [Т] индекса массива 1 умножаем на сегмент [Е] индекса массива 0.
	// 03. Если есть результат прошлой итерации вычисления, прибавляем к результату вычисления (02) содержимое его индекса [1].
	// 04. Разбиваем результат вычисления (03) на сегменты.
	// 05. Добавляем в мПромежуточный сегмент результат вычисления (04).
	// 06. Е = Е + 1. Повторяем с (02), пока Е <= ВГраница массива 0.
	// 07. Добавляем разряды чДлинаСегмента * Т в мПромежуточный (также, сегментами, по чДлинаСегмента цифр, нулей).
	// 08. Добавляем в мПредрезультатный мПромежуточный.
	// 09. Очищаем мПромежуточный.
	// 10. Е = 0. Т = Т + 1. Повторяем с (02), пока Т <= ВГраница массива 1.
	// 11. Вызываем функцию сложения в столбик с параметром мПредрезультатный.
	// 12. Результат исполнения функции (11) помещаем в массив мРезультат.
	// 12. Возвращаем мРезультат.
	
	сРазрядность = Формат(0, сФорматСегмента);
	
	чВГраница0 = мСегменты0.ВГраница();
	чВГраница1 = мСегменты1.ВГраница();
	
	мПредрезультатный = Новый Массив;
	Для Т = 0 по чВГраница1 Цикл
		мПромежуточный = Новый Массив;
		мРезультатПрошлойИтерации = Новый Массив;
		Для Е = 0 по чВГраница0 Цикл
			чРезультатУмноженияСегментов = Число(мСегменты0[Е]) * Число(мСегменты1[Т]);
			Если мРезультатПрошлойИтерации.Количество() > 1 Тогда
				чРезультатУмноженияСегментов = чРезультатУмноженияСегментов + Число(мРезультатПрошлойИтерации[1]);
			КонецЕсли;
			
			мРезультатПрошлойИтерации = РазбитьЧислоНаСегменты(чРезультатУмноженияСегментов);
			мПромежуточный.Добавить(мРезультатПрошлойИтерации[0]);
			Если Е = чВГраница0
				 И мРезультатПрошлойИтерации.Количество() > 1 Тогда
				мПромежуточный.Добавить(мРезультатПрошлойИтерации[1]);
			КонецЕсли;
		КонецЦикла;
		
		// Для индексов, начиная с 1 добавляем чДлинаСегмента нулей в конец массива для каждой итерации Т
		Для Е = 1 по Т Цикл
			мПромежуточный.Вставить(0, сРазрядность);
		КонецЦикла;
		
		мПредрезультатный.Добавить(мПромежуточный);
	КонецЦикла;
	
	мРезультат = СложитьСегментыЧисел(мПредрезультатный);
	
	Возврат мРезультат;
	
КонецФункции

Функция РазбитьЧислоНаСегменты(Знач сЧисло)
	
	Если ТипЗнч(сЧисло) = Тип("Число") Тогда
		сЧисло = Формат(сЧисло, "ЧН=; ЧГ=");
	КонецЕсли;
	
	// Сюда будем помещать сегменты числа
	мРезультат = Новый Массив;
	
	Пока НЕ ПустаяСтрока(сЧисло) Цикл
		// Вставляем крайний правый сегмент из чДлинаСегмента цифр
		сСегмент = Формат(Число(СокрЛ(Прав(сЧисло, чДлинаСегмента))), сФорматСегмента);
		мРезультат.Добавить(сСегмент);
		
		// Удаляем крайний правый сегмент из числа
		сЧисло = Лев(сЧисло, СтрДлина(сЧисло)-чДлинаСегмента);
	КонецЦикла;
	
	Если мРезультат.Количество() = 0 Тогда
		мРезультат.Добавить(Формат(0, сФорматСегмента));
	КонецЕсли;
		
	// Возвращаем результирующий массив, содержащий сегменты числа в обратном порядке их следования.
	// Индекс массива обозначает разрядность. Рассчитывается по формуле: чДлинаСегмента*Индекс
	Возврат мРезультат;
	
КонецФункции

Процедура ВычислитьСуммуЦифрРезультата()
	
	СтрДлинаРезультата = СтрДлина(Результат);
	
	СуммаЦифрРезультата = 0;
	Для Т = 1 по СтрДлинаРезультата Цикл
		СуммаЦифрРезультата = СуммаЦифрРезультата + Число(Сред(Результат, Т, 1));
	КонецЦикла;
	
КонецПроцедуры

Процедура КнопкаВычислитьНажатие(Элемент)
	
	Если ГраницаФакториала > 2000 Тогда
		Если Вопрос("Вычисление может занять ОЧЕНЬ длительное время (до 10 минут при вычислении 4900 факториал, овер 10 минут далее)!
					|Вы уверены, что действительно хотите вычислить "+Строка(ГраницаФакториала)+" факториал?!", РежимДиалогаВопрос.ДаНет, , КодВозвратаДиалога.Нет, "ВЫ ТОЧНО УВЕРЕНЫ?!") = КодВозвратаДиалога.Нет Тогда
			Возврат;
		КонецЕсли;
	КонецЕсли;
	
	Сообщить("Начато вычисление "+Формат(ГраницаФакториала, "ЧН=; ЧГ=")+"!...");
	НачатьЗамерПроизводительности();
	
	Результат = "";
	СуммаЦифрРезультата = 0;
	
	мСегментыРезультата = Новый Массив;
	мСегментыРезультата.Добавить("1");
	Для Т = 2 по ГраницаФакториала Цикл
		сТекЧисло = Формат(Т, "ЧН=; ЧГ=");
		
		мСегментыТекЧисла = РазбитьЧислоНаСегменты(сТекЧисло);
		
		мСегментыРезультата = ПеремножитьСегментыЧисел(мСегментыРезультата, мСегментыТекЧисла);
	КонецЦикла;
	
	Для каждого Сегмент из мСегментыРезультата Цикл
		Результат = Сегмент + Результат;
	КонецЦикла;
	
	Если ПустаяСтрока(Результат) Тогда
		Результат = "0";
	Иначе
		Пока Лев(Результат, 1) = "0" Цикл
			Результат = Сред(Результат, 2);
		КонецЦикла;
	КонецЕсли;
	
	ВычислитьСуммуЦифрРезультата();
	
	мРезультатЗамера = ЗавершитьЗамерПроизводительности();
	Сообщить("Вычисление "+Формат(ГраницаФакториала, "ЧН=; ЧГ=")+"! завершено. Время вычисления: " + мРезультатЗамера[0] + "сек.");
	
КонецПроцедуры

чДлинаСегмента = 8;

сФорматСегмента = "ЧЦ=" + чДлинаСегмента + "; ЧН=; ЧВН=; ЧГ=";

Попытка
	обMSScriptControl = Новый COMОбъект("MSScriptControl.ScriptControl");
	обMSScriptControl.language = "javascript";
Исключение
	Сообщить("Невозможно подключить MSScriptControl.ScriptControl, некоторые функции будут недоступны.");
КонецПопытки;
мЗамерыПроизводительности = Новый Массив;

Скачать файлы

Наименование Файл Версия Размер
Вычисление факториала (обработка)

.epf 8,74Kb
04.12.15
0
.epf 8,74Kb Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. DrAku1a 1315 07.12.15 02:03 Сейчас в теме
Круто! Давай ещё произвольные степени чисел, например - чему равно: (9^9)^9?
2. pwn 41 07.12.15 12:04 Сейчас в теме
Функция ниже, вроде тоже вычисляет факториал. Или это немного не то?

&НаКлиенте
Процедура ВычислитьФакториал(Команда)
	Факториал = 1;
	Пока Параметр > 0 Цикл
		Факториал = Факториал * Параметр;
		Параметр = Параметр - 1; 
	КонецЦикла; 
	Факториал = СтрЗаменить(Строка(Факториал), Символы.НПП, "");
	Сообщить(Факториал);
	Сообщить(СтрДлина(Факториал));
КонецПроцедуры
Показать
3. pwn 41 07.12.15 12:24 Сейчас в теме
Понял в чем "подвох". Спасибо за решение.
4. catsam 105 07.12.15 14:37 Сейчас в теме
(3) pwn, вот-вот - я сначала тоже так отреагировал. А потом _внезапно_ вспомнил про такую штуковину, как переполнение. =) Кстати, 1С ещё мягко это обрабатывает - просто обрезает левую часть результата. А вот когда не 1С считает, а, например, та же C# - там падение гарантировано. =)))

(1) DrAku1a, а это тоже задача на переполнение - весь необходимый код уже имеется тут. Зачем же плодить лишние сущности? =)
5. alex_4x 81 26.01.16 12:04 Сейчас в теме
Однозначно - ПЛЮС.
Еще бы возведение в произвольную степень, деление, просто умножение, вычисление числа Пи! и поиск простых чисел.
Кстати в поиске простых чисел есть некий подход, который позволяет пропускать те диапазоны, где простого числа не может быть.

Кстати есть интересная форма записи чисел (любых) система счисления, основанная на простых числах
Каждому разряду соответствует простое число и в разряде - 0 или 1. Таким образом любое число может быть представлено как сумма N количества РАЗНЫХ простых чисел. При этом длина записи для чисел больших порядков становится короче, чем например при использовании двоичной системы.
6. ildarovich 7085 26.01.16 12:30 Сейчас в теме
Для саморазвития, конечно, полезно, но вот вопрос: а знал ли автор, затевая программирование, что в платформе уже реализованы вычисления неограниченной разрядности? Что сколько угодно знаков факториала получается и так обычным умножением. То есть вместо
Использовано разбиение строкового представления числа на части по N цифр
в платформе использовано разбиение представление числа на части по 9 разрядов! По этой ссылке есть более подробное обсуждение:
http://forum.infostart.ru/forum24/topic122109/message1275993/#message1275993

Почему именно 9 разрядов? - Думаю, потому, что 32-битное целое как раз укладывается в это представление и элементарные операции над частями по 9 десятичных цифр можно делать как операции над 32-битными целыми.
7. catsam 105 29.01.16 11:24 Сейчас в теме
(6) ildarovich,
Несомненно, автор знал. Как следует из (4).
И несомненно, 1С прекрасно обрабатывает "вычисления неограниченной разрядности". Вот только при выводе результата, он, к сожалению, как это ни печально, обрезается.

Так что теории - это, конечно, хорошо, но попробовать на практике, наверное, все же стоило бы, прежде чем прозрачно намекать на бесполезность кода. ;)
И да - этот код написан и выложен сюда в образовательных целях. =) Несомненно, расчет факториала в бизнесе нафиг никому не нужен. И конечно, есть множество библиотек, которые считают его на порядки быстрее, если он, конечно, вдруг понадобился. Но вот только использование библиотек никак не поможет в, как Вы правильно выразились, "саморазвитии".

С уважением.
8. ildarovich 7085 29.01.16 12:27 Сейчас в теме
(7) а почему не пробовали просто вывод организовать, а сразу стали всю длинную арифметику делать? Вывод по 9 цифр, например? Если сами расчеты делаются, результат хранится, а проблема просто в выводе? Не было бы это проще?
9. catsam 105 17.02.16 16:17 Сейчас в теме
(8) Ну, во-первых, насколько проблема именно в выводе, а не в _хранении_ итогового значения "внутрях" 1С, я не проверял. И, честно говоря, не собираюсь. Ибо это проблема не моя, а 1С.
А во-вторых, как я уже говорил в (7), "этот код написан и выложен сюда в образовательных целях". Знаете, есть такая штука - образование? Вот это оно и есть. Неофит придет сюда, взглянет, код почитает и, есть вероятность, где-то и в чем-то продвинется. Такие вот дела...
Лично мне задача показалась прикольной. Стоящей того, чтобы реализовать именно её, а не "вытаскивание из недр 1С результата вычислений, который она самостоятельно отобразить не в состоянии". =)
Оставьте свое сообщение

См. также

Вам нравятся запросы в 1С? Промо

Практика программирования Разработка v8 v8::Запросы 1cv8.cf Абонемент ($m)

Речь не только о том, что простейший запрос с "легальным" оформлением растянется на пол-экрана, речь еще обо всем, что нужно написать "в нагрузку" к тексту запроса. Все эти "Новый Запрос", "УстановитьПараметр" и последующие пляски с обработкой результата... Пора с этим заканчивать!

1 стартмани

03.07.2019    19506    4    m-rv    86    

Конвейер проверки качества кода

Инструментарий разработчика Практика программирования Математика и алгоритмы v8 1cv8.cf Абонемент ($m)

Jenkinsfile для выполнения проверки качества кода. Собирает информацию с АПК, EDT и BSL-LS. Сопоставляет ошибки с гит-репозиторием, выгруженным ГитКонвертором. Отправляет в Сонар.

3 стартмани

04.09.2019    23321    22    Stepa86    44    

Алгоритмы поиска пути в графе

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

Реализуем алгоритмы поиска пути в графе на платформе 1С 8.3, такие как алгоритм А*, поиск в ширину, жадный поиск, алгоритм Дейкстры и вконце волновой.

1 стартмани

09.07.2019    16787    11    RonX01    10    

Работа с публикациями "Инфостарт"

Практика программирования О сообществе WEB v8 УУ Абонемент ($m)

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    20951    13    RocKeR_13    16    

ВСТАВИТЬ В Справочник.Номенклатура (Код, Наименование) ЗНАЧЕНИЯ ("001", "Новый товар") Промо

Практика программирования v8 v8::Запросы 1cv8.cf Абонемент ($m)

Вас не обманывают ваши глаза, это запрос на изменение данных! И это работает без прямого доступа к БД, регистрации и смс.

1 стартмани

01.06.2018    29668    86    m-rv    57    

HTTP Сервисы: Путь к своему сервису. Часть 3

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Продолжение статьи «HTTP Сервисы: Путь к своему сервису. Часть 2». В предыдущих частях мы использовали только Get, в этой части поговорим о других методах и длительных операциях.

1 стартмани

27.08.2018    35209    51    dsdred    15    

Позиционирование в помещении с помощью нейросети по сигналу Wi-Fi. Интерактивная карта склада в 1С с показом позиции

Инструментарий разработчика Практика программирования v8 Абонемент ($m)

Данная публикация содержит в себе редактор и интерактивную карту склада или иного помещения, на которой в реальном времени отображается позиция устройства, координаты которого вычисляются по уровням сигнала нескольких роутеров Wi-Fi. В статье и приложенным к ней разработкам предлагаются инструменты и методика для реализации вычисления точной геопозиции внутри помещений с помощью нейронной сети. Конфигурация написана на релизе 1С:Предприятие 8.3.12.1412, клиентское приложение имеет минимальный уровень совместимости SDK -16.

5 стартмани

09.08.2018    27152    26    informa1555    26    

Работа с данными выбора

Практика программирования Работа с интерфейсом v8 Россия Абонемент ($m)

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений - уже задать без программирования не получится.

1 стартмани

17.07.2018    44733    17    kalyaka    16    

Заполняем по шаблону (по умолчанию) Промо

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Простой в подключении, универсальный и достаточно удобный механизм заполнения реквизитов произвольных документов/справочников значениями по умолчанию. Реализован в расширении, но может быть и непосредственно включен практически в любую конфигурацию на управляемых формах простым копированием одной формы и двух команд. Весь код в статье.

1 стартмани

08.02.2018    27380    19    mvxyz    17    

Полезные примеры составления схемы компоновки данных #2

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Еще один набор примеров как решить частные задачи в СКД

1 стартмани

22.05.2018    29525    11    SITR-utyos    13    

Печатная форма, сделанная как расширение конфигурации для БП 3.0. Новые возможности БСП

Практика программирования Универсальные печатные формы v8 БП3.0 Абонемент ($m)

Печатные формы на внешних обработках скоро канут в лету. На смену им приходят ПФ, реализованные в виде расширений конфигурации. Не нашел на сайте примеров таких расширений. Привожу пример подобного расширения для БП 3.0.

1 стартмани

06.12.2017    26239    49    kwazi    6    

Паузы при исполнении кода (Sleep для 1С)

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Решил проверить все найденные варианты паузы для 1С. В результате получилась обработка для тестирования и небольшая статья с итогом.

1 стартмани

28.11.2017    42862    12    swimdog    41    

Нечеткий поиск одним запросом Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

Использование механизма полнотекстового поиска в 1С не всегда оправдано, т.к. построение индекса и поддержание его в актуальном состоянии может значительно нагружать систему. Предлагаемая реализация нечеткого поиска методом N-грамм выполняется одним запросом, что позволяет производить поиск в любой таблице и не требует предварительного построения индекса.

1 стартмани

28.12.2015    26784    69    vasvl123    9    

Макет в СКД - пример всех возможных типовых вариантов

Практика программирования Инструментарий разработчика v8 v8::СКД 1cv8.cf Абонемент ($m)

Макет СКД: наглядное представление того, что, как и куда выводится при типовых настройках.

1 стартмани

09.11.2017    21126    76    freelancer    4    

Telegram-боты

Практика программирования v8 Абонемент ($m)

Описание теории, разбор архитектуры и пример реализации telegram-ботов. Сразу скажу, со структурированием изложения мало что могу поделать. :) редакция от 18.07.2018 Правки последней редакции выделены жирным.

1 стартмани

01.09.2017    31313    130    PLAstic    56    

Умный дом на 1С + ардуино

Практика программирования v8 Абонемент ($m)

Конфигурация для автоматизации быта программиста 1C и не только. В данной статье будет рассказано, как можно использовать 1С для задач, не входящих в стандартные рамки этой платформы. Например, управление домом. В качестве периферии для подключения будет использован микроконтроллер (МК) Ардуино, но на нём не будет никакой логической нагрузки, весь процесс будет проходить на сервере 1С. Работа с пинами ввода/вывода происходит напрямую из 1С.

1 стартмани

07.08.2017    21997    21    sasha777666    63    

1С: Предприятие + корпоративный чат, как наладить оперативные уведомления за 10 минут Промо

Практика программирования v8 Абонемент ($m)

Как сделать автоматические уведомления о разных событиях из 1С в корпоративный чат MyChat для сотрудников компании

1 стартмани

14.08.2016    47234    36    Demanoidos    60    

Расширения конфигураций 1С: учимся перехватывать методы

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

В этой статье я на примерах разберу некоторые механизмы расширений конфигураций 1С. А именно «перехваты» методов модуля объекта и «перехваты» событий формы и элементов формы. Данная статья написана с учебными целями, чтобы показать, как при помощи расширений конфигурации можно делать такие доработки, ради которых раньше приходилось снимать конфигурацию с поддержки.

1 стартмани

30.05.2017    125021    13    signum2009    48    

Регулярные выражения – это просто. Построитель и отладчик регулярных выражений

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Предлагается к использованию построитель регулярных выражений. Выполненный в виде внешней обработки, он позволит строить сложно-структурированные выражения на основе параметрического описания, тестировать их, и в результате получить программный код 1С.

1 стартмани

13.03.2017    30523    112    romasna    49    

Распознавание текста с помощью нейросетей Google Cloud Vision и 1С

Практика программирования v8 1cv8.cf Абонемент ($m)

Возможности Google Cloud Vision в распознавании текста.

1 стартмани

08.02.2017    27723    123    kiv1c    18    

Быстрое определение интервалов в запросе Промо

Практика программирования v8 Абонемент ($m)

В статье описывается новый метод определения интервалов между данными различных записей в запросе. В отличие от общеизвестного метода, время работы предлагаемого метода зависит от объема данных ЛИНЕЙНО. Это обеспечивает ему значительный выигрыш по быстродействию на больших объемах данных. В качестве иллюстрации возможностей метода приведен отчет, показывающий гистограмму распределения времени между продажами.

1 стартмани

01.10.2015    50399    35    ildarovich    41    

Графическая схема. Управление при помощи XDTO.

Практика программирования v8 Абонемент ($m)

В статье описывается методика программного управления элементами графической схемы при помощи механизма XDTO. Приложена готовая к использованию библиотека функций для создания и удаления графических объектов, а также для связи элементов схемы соединительными линиями.

2 стартмани

16.01.2017    21227    103    Alxby    23    

Простой редактор плана помещения JavaScript

Практика программирования Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

На ресурсе сейчас очень много решений, которые позволяют редактировать карты, используя географические схемы. Так же много решений, которые позволяют редактировать объекты онлайн веб-карт. Мне же нужно было простое решение, для того чтобы расставить квадратные объекты на плане, показать их пользователю. Ну и распечатать, опять же. Я решил написать простенький редактор на JavaScript с использованием библиотеки Raphael.

1 стартмани

23.11.2016    20281    93    igel9780    22    

Работа с двоичными данными на примере чтения файлов изображений. Новые возможности 8.3.9

Практика программирования WEB v8 1cv8.cf Россия Абонемент ($m)

В статье приводятся новые функции по работе с двоичными данными, появившимися в версии платформы 8.3.9 , на примере анализа формата и размера изображений. А также пример отправки изображения через API ВКонтакте с помощью новых объектов (без использования ОбъединитьФайлы())

1 стартмани

14.11.2016    24605    16    Anton64    22    

Загрузка файлов на сервер с прогрессом и докачкой

Практика программирования v8 1cv8.cf Россия Абонемент ($m)

Пример использования новых возможностей платформы 8.3.9 по низкоуровневой работе с двоичными данными для инкрементальной передачи файлов на сервер.

1 стартмани

04.10.2016    12704    53    mrstomak    21    

Несколько шаблонов для доработки типовых конфигураций

Практика программирования Инструментарий разработчика v8 v8::УФ Абонемент ($m)

Предлагаю несколько каркасов для создания новых объектов в типовых конфигурациях. Это выжимка из кода нескольких конфигураций, которая позволит быстро и красиво создавать и дорабатывать объекты метаданных с соблюдением идеологии исходной системы

1 стартмани

03.10.2016    35816    95    json    25    

HTTP-сервис: отчеты [Расширение]

Практика программирования Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Это HTTP-сервис, который возвращает почти любой отчет в HTML, XLSX или в JSON. Сохраните вариант отчета, получите на него ссылку и можно получить данные без захода в 1С. Работает в конфигурациях на основе БСП 2.3.3+, для отчетов на СКД и в 1С 8.3.8+

2 стартмани

30.08.2016    25839    134    Stepa86    15    

Недокументированное использование стандартных форм Upd.

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Вам не хватает возможностей в платформе 1С или у Вас нет времени на углубленное изучение платформы 1С? Рассмотрены возможности использования стандартных форм, вызываемых из платформы.

1 стартмани

26.07.2016    27261    76    ZhokhovM    60    

Хранение файлов в томах на диске (для УПП 1.3)

Практика программирования v8 УПП1 Абонемент ($m)

Доработка типовой УПП 1.3 в плане хранения присоединенных файлов вне базы данных

2 стартмани

05.06.2016    55815    8    wowik    32    

БСП 2.3 и БСП 3.0: Просто про выполнение внешней обработки в фоне (c индикацией прогресса выполнения)

Инструментарий разработчика Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Простое пояснение о том, как сделать внешнюю обработку с фоновым выполнением и индикацией процесса для любой конфигурации на основе БСП 2.3.2. UPDATE 20/09/19: добавлен вариант обработки с индикацией процента выполнения и статусом выполнения для БСП 3.0.

1 стартмани

18.05.2016    59563    175    rozer    64    

Остатки на каждый день в запросе

Практика программирования Учет ТМЦ Учет ТМЦ v8 1cv8.cf УУ Абонемент ($m)

Запрос формирует остатки товаров на каждый день в пределах выбранного периода.

1 стартмани

26.04.2016    56199    19    arakelyan    18    

Еще один способ расчета остатков на каждый день в запросе

Математика и алгоритмы Практика программирования v8 Абонемент ($m)

Предлагается новый способ расчета остатков на каждый день (час, минуту, секунду) в запросе. Способ не требует предварительного формирования таблицы дат и также подходит для расчета курсов валют, цен номенклатуры и других периодических сведений на каждую дату периода. На больших объемах данных предлагаемый способ может превосходить по быстродействию ранее известные методы из-за линейной (в лучшем случае) зависимости трудоемкости от длины периода.

1 стартмани

24.04.2016    33654    48    ildarovich    23    

Вывод печатных форм с запросом данных в форму "Печать документов" из подсистемы БСП "Печать".

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Все не раз видели, как в типовых конфигурациях, построенных на основе БСП (Библиотека стандартных подсистем), печатные формы, построенные на основе Табличного документа, выводятся в специальную форму "ПечатьДокументов". Эта форма входит в состав подсистемы "Печать" из БСП. При разработке своих печатных форм, иногда необходимо запросить у пользователя дополнительные данные необходимые для печати. Тут встает вопрос, как в этом случае вывести печатную форму в форму "Печать документа". В этой статье я рассмотрю, как реализовать вывод печатной формы в упомянутую форму из подсистемы "Печать", в случае если мы хотим перед выводом печатной формы запросить у пользователя дополнительные данные. Здесь будут рассмотрены два случая: когда реализуется печатная форма с использованием подсистемы "Дополнительные отчеты и обработки" и когда печатная форма добавляется в конфигурацию в режиме конфигуратора, т.е. вносятся изменения в типовую конфигурацию.

1 стартмани

29.03.2016    86473    170    lopatin    14    

Выполнение JavaScript кода из 1С в объекте Поле HTML Документа (HTML 5) и вызов события в 1С ПриНажатии

Практика программирования v8 1cv8.cf Россия Абонемент ($m)

Пример выполнения JS кода из 1С в Поле HTML Документа под управляемыми формами, с удобным получением результата в 1С(С помощью вызова привязанного события ПриНажатии к элементу ПолеHTMLДокумента)

1 стартмани

22.03.2016    78688    154    igo1    54    

Количество дней недели (понедельников/вторников/...) в заданном диапазоне одним запросом

Практика программирования v8 Абонемент ($m)

При реализации периодического авто-заполнения маршрутных листов по графику (недельному) необходимо было просчитать стоимость всего периода, с условием выездов только по определенным дням. Заморачиваться с обходом результата не хотелось. Пришлось написать "Небольшой" запрос.

1 стартмани

03.03.2016    17589    1    Alexander.Shvets    5    

Простые радости жизни программиста 1С: выбор типа значения

Работа с интерфейсом Практика программирования v8 1cv8.cf Абонемент ($m)

Предлагаемая в работе обработка включает обычную и управляемую формы, которые максимально точно реализуют функциональность системного диалога выбора типа в толстом клиенте обычное приложение (включая оформление диалога). Эти формы имеют дополнительные интерфейсные удобства и могут быть использованы в качестве альтернативных диалогов выбора типа.

1 стартмани

17.02.2016    48742    50    yuraos    17    

Отображение прогресса выполнения длительных операций в БСП и их отладка в текущем сеансе.

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

В статье описан способ исполнения длительных операций в конфигурациях, в которых используется библиотека стандартных подсистем, с визуализацией прогресса исполнения и отображения хода обработки данных. Также дается краткое описание процесса отладки длительных операций в текущем сеансе.

1 стартмани

17.02.2016    53152    171    balanton    23    

Яндекс.Деньги "Благотворительность"

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Яндекс.Деньги теперь в 1С. Форма для приема благотворительных взносов. Форму легко сделать и вставить на любую страницу сайта или блога. Платежи будут приходить на ваш кошелек. На форме есть три способа платежа: из кошелька, с банковской карты, с баланса мобильного.

1 стартмани

16.02.2016    22600    8    Tatitutu    5    

Мастер рассылки e-mail 2.2 для управляемых форм

Практика программирования Email v8 v8::УФ ERP2 БП3.0 УТ11 Абонемент ($m)

Для пользователей: переделанный из старый разработки под 8.2 с использованием библиотеки Мастер рассылки e-mail 2.2 (ERP, УТ, БП) (Только управляемые формы), который теперь может запускаться под любой версией платформы с разрешенными или запрещенными модальными/синхронными вызовами в конфигурации. Также удобный выбор e-mail и их владельцев с помощью отбора динамического списка по любым критериям и галочки исключения.

1 стартмани

29.12.2015    36426    19    milkers    4    

Передача больших пакетов через веб-сервисы

Практика программирования Администрирование данных 1С Внешние источники данных v8 Абонемент ($m)

Реализация механизма передачи больших пакетов через веб-сервисы. С его помощью передать файл размером в несколько гигабайт не составит проблем.

1 стартмани

06.12.2015    55579    47    YPermitin    19    

Пример связи 1С и мессенджера Telegram. Получение данных из 1С запросом из Telegram

Практика программирования Внешние источники данных v8 1cv8.cf Абонемент ($m)

В результате чтения публикации Вы получите готовую внешнюю обработку, позволяющую получать из 1С данные, запрашиваемые через Telegram. В данной статье рассмотрим следующее: Использование HTTPСоединение; Чтение JSON для версии 1С 8.3.6 и выше, а также аналог JSON для версии 1С ниже 8.3.6; Подключение обработчика ожидания; Некоторые основные возможности API Telegram; Как создать бота для Telegram; Программное создание колонок дерева на управляемой форме;

1 стартмани

19.11.2015    90160    453    Luchik    202