Изящная доработка движений и проводок документов ERP 2

Публикация № 510334

Разработка - Практика программирования

ERP Доработка

Доработка движений и проводок документов в ERP с минимальным количеством изменений типового кода, на примере добавления в документ "Акт выполненных работ" подразделения в ТЧ "Услуги"

Перед нами стоит следующая задача:

В документе "Акт выполненных работ" добавить возможность указания подразделения в ТЧ "Услги".

И нужно ее сделать так, чтобы потом не было мучительно больно обновлять ERP.

Разобьем нашу задачу на несколько этапов:

0. Добавление реквизита "Подразделение" в ТЧ "Услуги"
1. Вывод данного реквизита на форму документа
2. Исправление движений по регистрам
3. Исправление движений по проводкам

Надеюсь, п.0 не вызывает ни у кого вопросов, поэтому сразу перейдем к п.1

Вывод реквизита на форму документа

В отличие от предыдущих конфигураций, в этот раз 1С реально постаралась упростить работу доработчикам конфигураций. И чтобы было проще дорабатывать формы, в практически в каждую форму добавлены вызовы общих процедур

  • ПриСозданииНаСервере
  • ПриЧтенииНаСервере

ведущие к вызову процедур из модуля МодификацияКонфигурацииПереопределяемый, который и предназначен для доработки.
Добавим на форму вывод реквизита

Процедура ПриСозданииНаСервере(Форма, Отказ, СтандартнаяОбработка) Экспорт
    Если Форма.ИмяФормы = "Документ.АктВыполненныхРабот.Форма.ФормаДокумента" Тогда
        еус_МодификацияКонфигурации_АктВыполненныхРабот.ПриСозданииНаСервере_ФормаДокумента(Форма, Отказ, СтандартнаяОбработка);
    КонецЕсли;
КонецПроцедуры

Тут мы применим небольшую хитрость. Все изменения формы будем проводить в выделенном модуле. Для чего? Можно, конечно, писать доработки прямо в этом модуле. Но что будет, когда несколько разработчиков захотят доработать свои документы, а все доработки лежат в одном модуле? Конечно же, кто первый захватил модуль в хранилище, тот и работает. Остальные ждут.

Вот для того, чтобы и избежать этого,  выделяем для каждого документа свой модуль.

В реальной жизни, конечно же, в этом документе была не 1 доработка, поэтому такой метод вполне оправдан.

Процедура ПриСозданииНаСервере_ФормаДокумента(Форма, Отказ, СтандартнаяОбработка) Экспорт
    НовыйЭлемент = Форма.Элементы.Вставить("еус_Подразделение", Тип("ПолеФормы"), Форма.Элементы.Услуги,);
    НовыйЭлемент.Вид         = ВидПоляФормы.ПолеВвода;
    НовыйЭлемент.ПутьКДанным = "Объект.Услуги.еус_Подразделение";
КонецПроцедуры	

Исправление движений по регистрам

Формирование движений документов происходит следующим образом:

  1. Инициализация данных проведения
  2. Запись движений
  3. Контроль регистров


Тут нас интересует пункт "Инициализация данных проведения". Данная инициализция происходит путем вызова процедуры модуля менеджера

Документы.АктВыполненныхРабот.ИнициализироватьДанныеДокумента(Ссылка, ДополнительныеСвойства);

Инициализация сотосит из пунктов
1. Инициализация шапки документа

Запрос = Новый Запрос;
ЗаполнитьПараметрыИнициализации(Запрос, ДокументСсылка)

2. Формирование списка с текстами запросов

//...
ТекстыЗапроса = Новый СписокЗначений;
ТекстЗапросаТаблицаЗаказыКлиентов(Запрос, ТекстыЗапроса, Регистры);
//...

3. Выполнение запросов

ПроведениеСервер.ИницализироватьТаблицыДляДвижений(Запрос, ТекстыЗапроса, ДополнительныеСвойства.ТаблицыДляДвижений, Истина);

Т.к. последняя процедура вызывается для каждого документа, то логичным вариантом будет модифицировать только ее

Процедура ИницализироватьТаблицыДляДвижений(Запрос, ТекстыЗапроса, Таблицы, ДобавитьРазделитель = Ложь, ДобавлятьСловоТаблица = Истина, ТолькоОтмеченные=Ложь) Экспорт
    //НАЧАЛО ВСТАВКИ
    еус_ОбработчикиПроведенияСервер.ДополнитьТекстыЗапросов(Запрос, ТекстыЗапроса, Таблицы, ДобавитьРазделитель, ДобавлятьСловоТаблица, ТолькоОтмеченные);
    //КОНЕЦ ВСТАВКИ
    ТаблицыЗапроса = ОбщегоНазначенияУТ.ВыгрузитьРезультатыЗапроса(Запрос, ТекстыЗапроса,, ДобавитьРазделитель);
    //...
КонецПроцедуры

Прменим тот же прием, что и для доработки форм: каждому документу свой модуль.

Процедура ДополнитьТекстыЗапросов(Запрос, ТекстыЗапроса, Таблицы, ДобавитьРазделитель, ДобавлятьСловоТаблица, ТолькоОтмеченные) Экспорт
	
    // Дорабатываем тексты запросов перед выполнением
    // в функции  ПроведениеСервер.ИницализироватьТаблицыДляДвижений
    Ссылка = Неопределено;
    Если НЕ Запрос.Параметры.Свойство("Ссылка", Ссылка) Тогда
        Возврат;
    КонецЕсли;	
	
    ТипСсылки = ТипЗнч(Ссылка) ;
    Если ТипСсылки = Тип("ДокументСсылка.АктВыполненныхРабот") Тогда	
        еус_ОбработчикиПроведенияСервер_АктВыполненныхРабот.ТекстЗапроса(Запрос, ТекстыЗапроса, "");
    КонецЕсли;	
	
КонецПроцедуры

Перейдем непосредственно к доработке движений по регистрам

Функция ТекстЗапроса(Запрос, ТекстыЗапроса, Регистры) Экспорт

    ТекстЗапроса_ВтРаботыУслуги(Запрос, ТекстыЗапроса, Регистры);
    ТекстЗапроса_СебестоимостьТоваров(Запрос, ТекстыЗапроса, Регистры);
    ТекстЗапроса_ВыручкаИСебестоимостьПродаж(Запрос, ТекстыЗапроса, Регистры);
    ТекстЗапроса_МатериалыИРаботыВПроизводстве(Запрос, ТекстыЗапроса, Регистры);
    Возврат "";

КонецФункции

Рассмотрим только вариант с доработкой движений по себестоимости. Для исправления запросов будем использовать объектную модель, которую дает нам СхемаЗапроса

Функция ТекстЗапроса_СебестоимостьТоваров(Запрос, ТекстыЗапроса, Регистры) Экспорт
    
    // Подразденение берем из ТЧ
    ЭлементТекстЗапроса = еус_ОбработчикиПроведенияСервер.НайтиЭлементСписка(ТекстыЗапроса, "СебестоимостьТоваров");
    ТекстЗапроса = ЭлементТекстЗапроса.Значение;
	
    СхемаЗапроса = Новый СхемаЗапроса;
    СхемаЗапроса.УстановитьТекстЗапроса(ТекстЗапроса);
	
    ТекстПодразделение = 
    "ВЫБОР 
    |	КОГДА ТаблицаУслуги.Подразделение = ЗНАЧЕНИЕ(Справочник.СтруктураПредприятия.ПустаяСсылка)
    |		ТОГДА &Подразделение
    |	ИНАЧЕ
    |		ТаблицаУслуги.Подразделение
    |КОНЕЦ";
	
    ЗапросВыбораСхемыЗапроса = СхемаЗапроса.ПакетЗапросов[0];
    ОператорВыбратьСхемыЗапроса =    ЗапросВыбораСхемыЗапроса.Операторы[0];
    еус_ОбработчикиПроведенияСервер.ДобавитьДоступноеПолеВТаблицу(ОператорВыбратьСхемыЗапроса, "ТаблицаУслуги", "Подразделение");

    еус_ОбработчикиПроведенияСервер.УстановитьПолеЗапроса(ЗапросВыбораСхемыЗапроса, ОператорВыбратьСхемыЗапроса, "Подразделение", "ТаблицаУслуги.Подразделение"); 
    //|	ЛЕВОЕ СОЕДИНЕНИЕ
    //|		ВтАналитика КАК ВтАналитика
    //|	ПО
    //|		ТаблицаУслуги.Номенклатура = ВтАналитика.Номенклатура
    //|		И ТаблицаУслуги.Характеристика = ВтАналитика.Характеристика
    // Не хватает соединения по подразделению
	
    еус_ОбработчикиПроведенияСервер.ДобавитьДоступноеПолеВТаблицу(ОператорВыбратьСхемыЗапроса, "ВтАналитика", "Склад");
    еус_ОбработчикиПроведенияСервер.ДобавитьУсловиеСоединения(ОператорВыбратьСхемыЗапроса, "ТаблицаУслуги", "ВтАналитика", "ТаблицаУслуги.Подразделение = ВтАналитика.Склад");
    ТекстЗапроса = СхемаЗапроса.ПолучитьТекстЗапроса();

КонецФункции

В данном коде используются функции, упрощающие работу со схемой запроса. Эти функции можно посмотреть в приложенном файле

Исправление движений по проводкам

Порядок формирования проводок из формы документа

1. Кнопка "Дт-Кт"  - Обоработка.ОтражениеДокументовВРеглУчете, команда ПроводкиРеглУчета
2. Кнопка "Отразить в регл. учете" вызыввает следующую процедуру

Процедура ОтразитьДокументВРеглУчетеСервер()

    СтруктураРеквизиты = Новый Структура("Ссылка, Дата, Организация", Документ, Дата, Неопределено);
    РеглУчетПроведениеСервер.ОтразитьДокумент(СтруктураРеквизиты, Истина);
    ПовторноеОткрытиеСервер();

КонецПроцедуры

Если мы потом захотим отразить програмно в рег. учете какой либо документ, то достаточно будет вызвать эту функцию.

В конечном итоге вызываются две функции модуля менеджера, первая возвращает текст запроса формирования временных таблиц, а вторая - проводок

Функция ТекстЗапросаВТОтраженияВРеглУчете() Экспорт
Функция ТекстОтраженияВРеглУчете() Экспорт

Эти функции вызываются из функции

РеглУчетВыборкиСерверПовтИсп.ЗапросДанных(ДокументИмя, ЭтоОбъектРасчетов = Истина)

Добавим в эту функцию перехват и добработку текста запросов
Добавим в функцию ЗапросДанных наш текс для перехватя текста запроса

Функция ЗапросДанных(ДокументИмя, ЭтоОбъектРасчетов = Истина) Экспорт
    
    //....
    ТекстВТОтраженияДокумента = ТекстВТОтраженияДокумента(ДокументИмя);
    
    // НАЧАЛО ВСТАВКИ
    еус_ОбработчикиПроведенияСервер.ТекстОтраженияДокумента(ДокументИмя, ТекстОтраженияДокумента); 
    еус_ОбработчикиПроведенияСервер.ТекстВТОтраженияДокумента(ДокументИмя, ТекстВТОтраженияДокумента); 
    //КОНЕЦ ВСТАВКИ
        
    Если ТекстОтраженияДокумента <> "" Тогда
        ТекстОтраженияДокумента = " ОБЪЕДИНИТЬ ВСЕ " + ТекстОтраженияДокумента; 
    КонецЕсли;
    
    Если ДокументИмя = "РасчетСебестоимостиТоваров" Тогда
        Возврат Новый Запрос(""
            + ТекстПустыеВТ()
            + ТекстВТОтраженияДокумента
            + ТекстИнициализации
            + ТекстОтраженияДокумента);
    Иначе
        Возврат Новый Запрос(""
            + ТекстСебестоимость()
            + ТекстПартии()
            + ТекстЗаписиНДС()
            + ТекстУчетнаяПолитика()
            + ТекстВТОтраженияДокумента
            + ТекстИнициализации
            + ТекстЗачетАвансов
            + ТекстРаспределениеРасходов
            + " ОБЪЕДИНИТЬ ВСЕ " + ТекстНДСПоДаннымФинпартий()
            + ТекстОтраженияДокумента);
    КонецЕсли;
КонецФункции

Разобьем доработку проводок на 2 части:

  1. Изменение уже существующего текста запроса
  2. Добавление нового текста запроса

В нашем случае добавления текста не будет, а только изменение существующего

Функция ТекстОтраженияДокумента(ДокументИмя, Текст) Экспорт
	
    Если ДокументИмя = "АктВыполненныхРабот" Тогда
	еус_ОбработчикиПроведенияСервер_АктВыполненныхРабот.ОбработатьТекстЗапросаОтражениеВРегУчете(Текст);
        ДобавочныйТекст = еус_ОбработчикиПроведенияСервер_АктВыполненныхРабот.ТекстЗапросаОтражениеВРегУчете();
        Если ЗначениеЗаполнено(ДобавочныйТекст) Тогда
            Текст = Текст + " ОБЪЕДИНИТЬ ВСЕ " + ДобавочныйТекст;
        КонцеЕсли;
    КонецЕсли;	
	
КонецФункции

Рассмотрим наши функции по доработке текста запроса бух. проводок. В отличие от запросов движений по регистрам, в данном случае мы имеем 1 большой запрос, состоящий из отдельных запросов по каждой проводке, соединенных через "ОБЪЕДИНИТЬ ВСЕ". Это немного усложняет нам работу, а также приносит потенциальную ошибку смены порядка запросов.

Процедура ОбработатьТекстЗапросаОтражениеВРегУчете(Текст) Экспорт
	
    СхемаЗапроса = Новый СхемаЗапроса;
    СхемаЗапроса.УстановитьТекстЗапроса(Текст);
	
    //Чтобы не запутаться в порядке запросов - пронумеруем их
    Таблицы = Новый Соответствие;
    Таблицы.Вставить("ТекстЗадолженностьПокупателяЗаУслуги",  0);
    Таблицы.Вставить("ТекстНачислениеНДСЗаУслуги",            1);
    Таблицы.Вставить("ТекстОказаниеРабот",                    2);
    Таблицы.Вставить("ТекстНеПодтверждениеНулевойСтавкиНДС",  3);
    Таблицы.Вставить("ТекстПродажаАгентскихУслуг",            4);
    Таблицы.Вставить("ТекстВключениеИсключениеНДСВСтоимость", 5);
	
    ЗапросВыбораСхемыЗапроса = СхемаЗапроса.ПакетЗапросов[0];
	
    //ТекстЗадолженностьПокупателяЗаУслуги
    Оператор = ЗапросВыбораСхемыЗапроса.Операторы[Таблицы["ТекстЗадолженностьПокупателяЗаУслуги"]];

    //Заменим Поле пдразделение на получение из табличной части
    ТекстПодразделение =
    "ВЫБОР 
    |	КОГДА Строки.еус_Подразделение = ЗНАЧЕНИЕ(Справочник.СтруктураПредприятия.ПустаяСсылка)
    |	    ТОГДА Операция.Подразделение
    |	ИНАЧЕ
    |	    Строки.еус_Подразделение
    |КОНЕЦ";
	
    еус_ОбработчикиПроведенияСервер.УстановитьПолеЗапроса(ЗапросВыбораСхемыЗапроса, Оператор, "ПодразделениеДт", "ЕСТЬNULL(Расчеты.Подразделение, " + ТекстПодразделение + ")");
    еус_ОбработчикиПроведенияСервер.УстановитьПолеЗапроса(ЗапросВыбораСхемыЗапроса, Оператор, "ПодразделениеКт", ТекстПодразделение);
	
    //ТекстНачислениеНДСЗаУслуги
    Оператор = ЗапросВыбораСхемыЗапроса.Операторы[Таблицы["ТекстНачислениеНДСЗаУслуги"]];
    еус_ОбработчикиПроведенияСервер.УстановитьПолеЗапроса(ЗапросВыбораСхемыЗапроса, Оператор, "ПодразделениеДт", ТекстПодразделение);
	
    //ТекстОказаниеРабот
    Оператор = ЗапросВыбораСхемыЗапроса.Операторы[Таблицы["ТекстОказаниеРабот"]];

    ТекстПодразделение =
    "ВЫБОР 
    |	КОГДА Строки.Подразделение = ЗНАЧЕНИЕ(Справочник.СтруктураПредприятия.ПустаяСсылка)
    |		ТОГДА Операция.Подразделение
    |	ИНАЧЕ
    |		Строки.Подразделение
    |КОНЕЦ";
	
    еус_ОбработчикиПроведенияСервер.ДобавитьДоступноеПолеВТаблицу(Оператор, "Строки", "Подразделение");
    еус_ОбработчикиПроведенияСервер.УстановитьПолеЗапроса(ЗапросВыбораСхемыЗапроса, Оператор, "ПодразделениеДт", ТекстПодразделение);
    еус_ОбработчикиПроведенияСервер.УстановитьПолеЗапроса(ЗапросВыбораСхемыЗапроса, Оператор, "ПодразделениеКт", ТекстПодразделение);
	
	
    //|	ЛЕВОЕ СОЕДИНЕНИЕ
    //|		ВтСтоимости КАК Стоимости
    //|	ПО
    //|		Строки.Ссылка = Стоимости.Ссылка
    //|		И Строки.Номенклатура = Стоимости.Номенклатура
    //|		И Строки.ГруппаФинансовогоУчета = Стоимости.ГруппаФинансовогоУчета
	
    //Не хватает соединения по складу
    еус_ОбработчикиПроведенияСервер.ДобавитьДоступноеПолеВТаблицу(Оператор, "Строки", "Склад");
    еус_ОбработчикиПроведенияСервер.ДобавитьДоступноеПолеВТаблицу(Оператор, "Стоимости", "Склад");
	
    //Все соединения идут на первую таблицу в запросе
    еус_ОбработчикиПроведенияСервер.ДобавитьУсловиеСоединения(Оператор, "ДокументыКОтражению", "Стоимости", "Строки.Склад = Стоимости.Склад");
	
    Текст = СхемаЗапроса.ПолучитьТекстЗапроса();
	
КонецПроцедуры

Итак, с минимальными врезками в типовой код мы выполнили нашу задачу по доработке документа.

 

P.S. Можете посмотреть другие мои статьи по доработке ERP

Набор тестов xUnit для ERP2, блок Производство

Скачать файлы

Наименование Файл Версия Размер
ОбщийМодуль.zip

.zip 1,01Kb
17
.zip 1,01Kb 17 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. karpik666 3052 05.04.16 13:49 Сейчас в теме
Такая ситуация не только в Erp, но и в Ут 11, даже где-то была статья по доработке Ут с такими же переопределяемыми обработчиками
2. vvr908 411 05.04.16 15:20 Сейчас в теме
Коллеги, а сейчас нет возможности реализовать такие доработки через механизм расширений конфигурации?
3. borodatii 3 05.04.16 15:59 Сейчас в теме
4. Dvornik 25 23.03.17 05:04 Сейчас в теме
7 строка. Опечатка - "Услги".
5. ryutao 50 23.03.17 08:36 Сейчас в теме
Все хорошо, но, коллеги, данный способ требует снятия с поддержки, а это почти вдвое выросший физический объем базы. Такое чувство, что никто с конкретными базами не работает, а только с тестовыми. Последние конфиги ERP, КА, УТ, БП и так еле ворочаются. На данном примере: какова ценность изменения подразделения в ТЧ?
6. acsent 1162 23.03.17 18:36 Сейчас в теме
ЕРП без возможности изменения и в ней работают?
Нет сынок, это фантастика
7. h00k 42 28.04.17 22:07 Сейчас в теме
(6)
ЕРП без возможности изменения и в ней работают?

Смешно. Вы ещё, кроме включения возможности изменения, хранилище конфигураций предложите к рабочей базе подключить... чтоб уж наверняка.

В тестовой базе, после успешного выполнения всех тестов, формируется комплект обновления или поставки. Им и выполняется обновление базы в продуктиве, которая стоит на полной поддержке.
8. acsent 1162 29.04.17 17:04 Сейчас в теме
(7) Своя поставка как раз и означает включение изменений относительно поставки 1С
9. h00k 42 29.04.17 20:49 Сейчас в теме
(8)
Своя поставка как раз и означает включение изменений относительно поставки 1С

Вы вообще о чем?! В рабочих базах не включают возможность изменений, если уж не совсем новички внедрением-доработкой занимаются.
При необходимости доработки типового функционала, разработка ведётся в локальных базах разработчиков, подключенных к хранилищу конфигурации. К этому же хранилищу подключена база для тестирования выполненных доработок и формирования комплектов поставки (обновления). Базы в продуктиве обновляются подготовленными кф-файлами. В них не включают возможность изменения и т.п. - это аксиома.
10. vmalov 12 25.08.17 14:44 Сейчас в теме
Статья полезная. Особенно по отражению в рег. учете, которое в фоне выполняется. Отладчиком можно целый день сидеть, искать нужные процедуры.
11. erp3000 04.07.18 13:55 Сейчас в теме
Парень залез править типовые общие модуля и называется это искусство изящная доработка :-)))
12. acsent 1162 04.07.18 18:42 Сейчас в теме
(11) Точечное исправление модуля - это очень даже изящно.
По другому проводки не поправить
13. erp3000 09.07.18 12:06 Сейчас в теме
Проводки (так же как и движения по РН) правятся в модуле менеджера документа в соответствующих запросах. В общий модуль который является ядром данного механизма руками лучше не лазить. Общие модули которые можно редактировать именуются постфиксом "Переопределяемый"
14. acsent 1162 09.07.18 15:25 Сейчас в теме
(13) предлагаешь делать хук в каждом модуле менеджера?
15. erp3000 09.07.18 16:28 Сейчас в теме
Именно, сама концепция движения по РН и РБ об этом говорит, и не надо лазить шаловливыми ручонками в ядро механизма.
16. acsent 1162 09.07.18 18:43 Сейчас в теме
(15) Значит ты не понял идеи.
Вместо того чтобы в каждом модуле дорабатывать запрос, мы его дорабатываем непосредсвенно перед выполнением.
Ну а тексты кладем в именнованные модули для читабельности
17. erp3000 09.07.18 18:56 Сейчас в теме
Твоя идея - это самодеятельность, а ЕРП это тебе не самописочка для конторочек, это решение которое необходимо эксплуатировать в крупных компаниях с немалым количеством программистов, и если каждый залезет в общий модуль и в самом ядре механизма начнет делать "изящные доработки", то такую ЕРП и заодно компанию ждет печальная участь..
18. Safron 5 09.10.18 02:20 Сейчас в теме
Сделал все по этой схеме, добавил проводку в проведение Поступление безналичных денежных средств. Проводка добавилась, если нажать "Отразить в регл. учете". Но если делать через "Регламентированный учет--Отражение документов в регл. учете" в первом документе появляется доп. проводка, а в последующих нет. Т. е., начиная со второго документа программа как бы проскакивает изменения в модуле. Не могу понять где копать дальше.
19. user767673 28.05.20 21:09 Сейчас в теме
Вопрос : порядок отражения проводок как изменить?
Спасибо !
Оставьте свое сообщение

См. также

FormCodeGenerator Программная доработка форм. Часть 2 (Режим работы "Режим сравнения форм") на примере ERP 2.5 Промо

Практика программирования Адаптация типовых решений Прочие инструменты разработчика v8 1cv8.cf Абонемент ($m)

Данная публикация является продолжением описания функционирования обработки "FormCodeGenerator " в режиме сравнения форм и генерирования кода на основании сравнения. Подходит для перевода уже доработанных форм с интерактивной доработки на программную. Данный режим работы обработки снизит издержки при дальнейших обновлениях конфигураций.

5 стартмани

21.12.2020    2011    12    huxuxuya    11    

Интерактивная справка по объектам 1С (подключаемое расширение)

Практика программирования Работа с интерфейсом v8 ERP2 Абонемент ($m)

База знаний, подключаемая к объектам основной базы. Пополняется интерактивно, формируется в виде статей прямо в 1С (текст, картинки, таблицы, ссылки). Есть возможность прикрепления файлов, привязки к объектам 1С, возможности рейтинга и комментирования пользователями.

3 стартмани

29.09.2020    7902    46    sapervodichka    40    

Конвейер проверки качества кода

Инструментарий разработчика Практика программирования Математика и алгоритмы v8 1cv8.cf Абонемент ($m)

Jenkinsfile для выполнения проверки качества кода. Собирает информацию с АПК, EDT и BSL-LS. Сопоставляет ошибки с гит-репозиторием, выгруженным ГитКонвертором. Отправляет в Сонар.

3 стартмани

04.09.2019    27490    22    Stepa86    46    

Алгоритмы поиска пути в графе

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

Реализуем алгоритмы поиска пути в графе на платформе 1С 8.3, такие как алгоритм А*, поиск в ширину, жадный поиск, алгоритм Дейкстры и вконце волновой.

1 стартмани

09.07.2019    18753    12    RonX01    10    

Вам нравятся запросы в 1С? Промо

Практика программирования Разработка v8 v8::Запросы 1cv8.cf Абонемент ($m)

Речь не только о том, что простейший запрос с "легальным" оформлением растянется на пол-экрана, речь еще обо всем, что нужно написать "в нагрузку" к тексту запроса. Все эти "Новый Запрос", "УстановитьПараметр" и последующие пляски с обработкой результата... Пора с этим заканчивать!

1 стартмани

03.07.2019    22215    5    m-rv    88    

Работа с публикациями "Инфостарт"

Практика программирования О сообществе WEB v8 УУ Абонемент ($m)

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    22957    13    RocKeR_13    16    

HTTP Сервисы: Путь к своему сервису. Часть 3

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Продолжение статьи «HTTP Сервисы: Путь к своему сервису. Часть 2». В предыдущих частях мы использовали только Get, в этой части поговорим о других методах и длительных операциях.

1 стартмани

27.08.2018    40897    63    dsdred    17    

Позиционирование в помещении с помощью нейросети по сигналу Wi-Fi. Интерактивная карта склада в 1С с показом позиции

Инструментарий разработчика Практика программирования v8 Абонемент ($m)

Данная публикация содержит в себе редактор и интерактивную карту склада или иного помещения, на которой в реальном времени отображается позиция устройства, координаты которого вычисляются по уровням сигнала нескольких роутеров Wi-Fi. В статье и приложенным к ней разработкам предлагаются инструменты и методика для реализации вычисления точной геопозиции внутри помещений с помощью нейронной сети. Конфигурация написана на релизе 1С:Предприятие 8.3.12.1412, клиентское приложение имеет минимальный уровень совместимости SDK -16.

5 стартмани

09.08.2018    29668    26    informa1555    26    

ВСТАВИТЬ В Справочник.Номенклатура (Код, Наименование) ЗНАЧЕНИЯ ("001", "Новый товар") Промо

Практика программирования v8 v8::Запросы 1cv8.cf Абонемент ($m)

Вас не обманывают ваши глаза, это запрос на изменение данных! И это работает без прямого доступа к БД, регистрации и смс.

1 стартмани

01.06.2018    31600    88    m-rv    57    

Работа с данными выбора

Практика программирования Работа с интерфейсом v8 Россия Абонемент ($m)

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений - уже задать без программирования не получится.

1 стартмани

17.07.2018    51802    18    kalyaka    16    

Полезные примеры составления схемы компоновки данных #2

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Еще один набор примеров как решить частные задачи в СКД

1 стартмани

22.05.2018    33017    11    SITR-utyos    13    

Печатная форма, сделанная как расширение конфигурации для БП 3.0. Новые возможности БСП

Практика программирования Универсальные печатные формы v8 БП3.0 Абонемент ($m)

Печатные формы на внешних обработках скоро канут в лету. На смену им приходят ПФ, реализованные в виде расширений конфигурации. Не нашел на сайте примеров таких расширений. Привожу пример подобного расширения для БП 3.0.

1 стартмани

06.12.2017    28062    54    kwazi    6    

Заполняем по шаблону (по умолчанию) Промо

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Простой в подключении, универсальный и достаточно удобный механизм заполнения реквизитов произвольных документов/справочников значениями по умолчанию. Реализован в расширении, но может быть и непосредственно включен практически в любую конфигурацию на управляемых формах простым копированием одной формы и двух команд. Весь код в статье.

1 стартмани

08.02.2018    29535    19    mvxyz    17    

Паузы при исполнении кода (Sleep для 1С)

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Решил проверить все найденные варианты паузы для 1С. В результате получилась обработка для тестирования и небольшая статья с итогом.

1 стартмани

28.11.2017    50048    13    swimdog    43    

Макет в СКД - пример всех возможных типовых вариантов

Практика программирования Инструментарий разработчика v8 v8::СКД 1cv8.cf Абонемент ($m)

Макет СКД: наглядное представление того, что, как и куда выводится при типовых настройках.

1 стартмани

09.11.2017    23015    77    freelancer    4    

Telegram-боты

Практика программирования v8 Абонемент ($m)

Описание теории, разбор архитектуры и пример реализации telegram-ботов. Сразу скажу, со структурированием изложения мало что могу поделать. :) редакция от 18.07.2018 Правки последней редакции выделены жирным.

1 стартмани

01.09.2017    34802    134    PLAstic    59    

Нечеткий поиск одним запросом Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

Использование механизма полнотекстового поиска в 1С не всегда оправдано, т.к. построение индекса и поддержание его в актуальном состоянии может значительно нагружать систему. Предлагаемая реализация нечеткого поиска методом N-грамм выполняется одним запросом, что позволяет производить поиск в любой таблице и не требует предварительного построения индекса.

1 стартмани

28.12.2015    29117    71    vasvl123    9    

Умный дом на 1С + ардуино

Практика программирования v8 Абонемент ($m)

Конфигурация для автоматизации быта программиста 1C и не только. В данной статье будет рассказано, как можно использовать 1С для задач, не входящих в стандартные рамки этой платформы. Например, управление домом. В качестве периферии для подключения будет использован микроконтроллер (МК) Ардуино, но на нём не будет никакой логической нагрузки, весь процесс будет проходить на сервере 1С. Работа с пинами ввода/вывода происходит напрямую из 1С.

1 стартмани

07.08.2017    23967    21    sasha777666    63    

Расширения конфигураций 1С: учимся перехватывать методы

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

В этой статье я на примерах разберу некоторые механизмы расширений конфигураций 1С. А именно «перехваты» методов модуля объекта и «перехваты» событий формы и элементов формы. Данная статья написана с учебными целями, чтобы показать, как при помощи расширений конфигурации можно делать такие доработки, ради которых раньше приходилось снимать конфигурацию с поддержки.

1 стартмани

30.05.2017    137845    13    signum2009    48    

Регулярные выражения – это просто. Построитель и отладчик регулярных выражений

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Предлагается к использованию построитель регулярных выражений. Выполненный в виде внешней обработки, он позволит строить сложно-структурированные выражения на основе параметрического описания, тестировать их, и в результате получить программный код 1С.

1 стартмани

13.03.2017    32923    115    romasna    49    

1С: Предприятие + корпоративный чат, как наладить оперативные уведомления за 10 минут Промо

Практика программирования v8 Абонемент ($m)

Как сделать автоматические уведомления о разных событиях из 1С в корпоративный чат MyChat для сотрудников компании

1 стартмани

14.08.2016    49485    36    Demanoidos    60    

Распознавание текста с помощью нейросетей Google Cloud Vision и 1С

Практика программирования v8 1cv8.cf Абонемент ($m)

Возможности Google Cloud Vision в распознавании текста.

1 стартмани

08.02.2017    31269    131    kiv1c    18    

Графическая схема. Управление при помощи XDTO.

Практика программирования v8 Абонемент ($m)

В статье описывается методика программного управления элементами графической схемы при помощи механизма XDTO. Приложена готовая к использованию библиотека функций для создания и удаления графических объектов, а также для связи элементов схемы соединительными линиями.

2 стартмани

16.01.2017    23789    106    Alxby    23    

Простой редактор плана помещения JavaScript

Практика программирования Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

На ресурсе сейчас очень много решений, которые позволяют редактировать карты, используя географические схемы. Так же много решений, которые позволяют редактировать объекты онлайн веб-карт. Мне же нужно было простое решение, для того чтобы расставить квадратные объекты на плане, показать их пользователю. Ну и распечатать, опять же. Я решил написать простенький редактор на JavaScript с использованием библиотеки Raphael.

1 стартмани

23.11.2016    22236    97    igel9780    22    

Быстрое определение интервалов в запросе Промо

Практика программирования v8 Абонемент ($m)

В статье описывается новый метод определения интервалов между данными различных записей в запросе. В отличие от общеизвестного метода, время работы предлагаемого метода зависит от объема данных ЛИНЕЙНО. Это обеспечивает ему значительный выигрыш по быстродействию на больших объемах данных. В качестве иллюстрации возможностей метода приведен отчет, показывающий гистограмму распределения времени между продажами.

1 стартмани

01.10.2015    53574    35    ildarovich    41    

Работа с двоичными данными на примере чтения файлов изображений. Новые возможности 8.3.9

Практика программирования WEB v8 1cv8.cf Россия Абонемент ($m)

В статье приводятся новые функции по работе с двоичными данными, появившимися в версии платформы 8.3.9 , на примере анализа формата и размера изображений. А также пример отправки изображения через API ВКонтакте с помощью новых объектов (без использования ОбъединитьФайлы())

1 стартмани

14.11.2016    27872    16    Anton64    22    

Загрузка файлов на сервер с прогрессом и докачкой

Практика программирования v8 1cv8.cf Россия Абонемент ($m)

Пример использования новых возможностей платформы 8.3.9 по низкоуровневой работе с двоичными данными для инкрементальной передачи файлов на сервер.

1 стартмани

04.10.2016    14193    53    mrstomak    21    

Несколько шаблонов для доработки типовых конфигураций

Практика программирования Инструментарий разработчика v8 v8::УФ Абонемент ($m)

Предлагаю несколько каркасов для создания новых объектов в типовых конфигурациях. Это выжимка из кода нескольких конфигураций, которая позволит быстро и красиво создавать и дорабатывать объекты метаданных с соблюдением идеологии исходной системы

1 стартмани

03.10.2016    37851    96    json    25    

HTTP-сервис: отчеты [Расширение]

Практика программирования Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Это HTTP-сервис, который возвращает почти любой отчет в HTML, XLSX или в JSON. Сохраните вариант отчета, получите на него ссылку и можно получить данные без захода в 1С. Работает в конфигурациях на основе БСП 2.3.3+, для отчетов на СКД и в 1С 8.3.8+

2 стартмани

30.08.2016    28213    143    Stepa86    15    

Недокументированное использование стандартных форм Upd.

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Вам не хватает возможностей в платформе 1С или у Вас нет времени на углубленное изучение платформы 1С? Рассмотрены возможности использования стандартных форм, вызываемых из платформы.

1 стартмани

26.07.2016    29554    80    ZhokhovM    60    

Хранение файлов в томах на диске (для УПП 1.3)

Практика программирования v8 УПП1 Абонемент ($m)

Доработка типовой УПП 1.3 в плане хранения присоединенных файлов вне базы данных

2 стартмани

05.06.2016    59655    11    wowik    32    

БСП 2.3 и БСП 3.0: Просто про выполнение внешней обработки в фоне (c индикацией прогресса выполнения)

Инструментарий разработчика Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Простое пояснение о том, как сделать внешнюю обработку с фоновым выполнением и индикацией процесса для любой конфигурации на основе БСП 2.3.2. UPDATE 20/09/19: добавлен вариант обработки с индикацией процента выполнения и статусом выполнения для БСП 3.0.

1 стартмани

18.05.2016    64424    191    rozer    65    

Остатки на каждый день в запросе

Практика программирования Учет ТМЦ Учет ТМЦ v8 1cv8.cf УУ Абонемент ($m)

Запрос формирует остатки товаров на каждый день в пределах выбранного периода.

1 стартмани

26.04.2016    62240    19    arakelyan    20    

Еще один способ расчета остатков на каждый день в запросе

Математика и алгоритмы Практика программирования v8 Абонемент ($m)

Предлагается новый способ расчета остатков на каждый день (час, минуту, секунду) в запросе. Способ не требует предварительного формирования таблицы дат и также подходит для расчета курсов валют, цен номенклатуры и других периодических сведений на каждую дату периода. На больших объемах данных предлагаемый способ может превосходить по быстродействию ранее известные методы из-за линейной (в лучшем случае) зависимости трудоемкости от длины периода.

1 стартмани

24.04.2016    35834    50    ildarovich    23    

Набор тестов xUnit для ERP2, блок Производство

Инструментарий разработчика Производство готовой продукции (работ, услуг) Производство готовой продукции (работ, услуг) v8 ERP2 Россия Абонемент ($m)

Набор тестовых обработок, эмулирующих цепочку документов по блоку Производство в конфигурации ERP 2.1

1 стартмани

24.04.2016    20286    29    acsent    26    

Вывод печатных форм с запросом данных в форму "Печать документов" из подсистемы БСП "Печать".

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Все не раз видели, как в типовых конфигурациях, построенных на основе БСП (Библиотека стандартных подсистем), печатные формы, построенные на основе Табличного документа, выводятся в специальную форму "ПечатьДокументов". Эта форма входит в состав подсистемы "Печать" из БСП. При разработке своих печатных форм, иногда необходимо запросить у пользователя дополнительные данные необходимые для печати. Тут встает вопрос, как в этом случае вывести печатную форму в форму "Печать документа". В этой статье я рассмотрю, как реализовать вывод печатной формы в упомянутую форму из подсистемы "Печать", в случае если мы хотим перед выводом печатной формы запросить у пользователя дополнительные данные. Здесь будут рассмотрены два случая: когда реализуется печатная форма с использованием подсистемы "Дополнительные отчеты и обработки" и когда печатная форма добавляется в конфигурацию в режиме конфигуратора, т.е. вносятся изменения в типовую конфигурацию.

1 стартмани

29.03.2016    95000    186    lopatin    14    

Выполнение JavaScript кода из 1С в объекте Поле HTML Документа (HTML 5) и вызов события в 1С ПриНажатии

Практика программирования v8 1cv8.cf Россия Абонемент ($m)

Пример выполнения JS кода из 1С в Поле HTML Документа под управляемыми формами, с удобным получением результата в 1С(С помощью вызова привязанного события ПриНажатии к элементу ПолеHTMLДокумента)

1 стартмани

22.03.2016    84314    162    igo1    54    

Количество дней недели (понедельников/вторников/...) в заданном диапазоне одним запросом

Практика программирования v8 Абонемент ($m)

При реализации периодического авто-заполнения маршрутных листов по графику (недельному) необходимо было просчитать стоимость всего периода, с условием выездов только по определенным дням. Заморачиваться с обходом результата не хотелось. Пришлось написать "Небольшой" запрос.

1 стартмани

03.03.2016    19201    1    Alexander.Shvets    5    

Простые радости жизни программиста 1С: выбор типа значения

Работа с интерфейсом Практика программирования v8 1cv8.cf Абонемент ($m)

Предлагаемая в работе обработка включает обычную и управляемую формы, которые максимально точно реализуют функциональность системного диалога выбора типа в толстом клиенте обычное приложение (включая оформление диалога). Эти формы имеют дополнительные интерфейсные удобства и могут быть использованы в качестве альтернативных диалогов выбора типа.

1 стартмани

17.02.2016    51904    54    yuraos    17    

Отображение прогресса выполнения длительных операций в БСП и их отладка в текущем сеансе.

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

В статье описан способ исполнения длительных операций в конфигурациях, в которых используется библиотека стандартных подсистем, с визуализацией прогресса исполнения и отображения хода обработки данных. Также дается краткое описание процесса отладки длительных операций в текущем сеансе.

1 стартмани

17.02.2016    58073    189    balanton    23    

Яндекс.Деньги "Благотворительность"

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Яндекс.Деньги теперь в 1С. Форма для приема благотворительных взносов. Форму легко сделать и вставить на любую страницу сайта или блога. Платежи будут приходить на ваш кошелек. На форме есть три способа платежа: из кошелька, с банковской карты, с баланса мобильного.

1 стартмани

16.02.2016    24297    8    Tatitutu    5    

Мастер рассылки e-mail 2.2 для управляемых форм

Практика программирования Email v8 v8::УФ ERP2 БП3.0 УТ11 Абонемент ($m)

Для пользователей: переделанный из старый разработки под 8.2 с использованием библиотеки Мастер рассылки e-mail 2.2 (ERP, УТ, БП) (Только управляемые формы), который теперь может запускаться под любой версией платформы с разрешенными или запрещенными модальными/синхронными вызовами в конфигурации. Также удобный выбор e-mail и их владельцев с помощью отбора динамического списка по любым критериям и галочки исключения.

1 стартмани

29.12.2015    39838    20    milkers    4