Интеллектуальная загрузка в 1С счетов, накладных из файлов электронных таблиц (типа XLS), не требующая настроек, с указанием номеров строк и колонок. Для примера обработка загрузки в документ "Поступление товаров и услуг" для "Управление Торговлей 10.3"

Публикация № 549192

Администрирование - Администрирование данных 1С - Обработка документов

XLS Загрузка электронные счета поступление

Существует большое количество разработок для загрузки документов из электронных таблиц, в том числе и на ИС. Для загрузки необходимо для каждого вида документа производить настройку с указанием номеров строк и колонок для сопоставления реквизитов документа и ячеек в таблице. Предлагаю отказаться от различных настроек с указанием колонок и строк. Сопоставления данных производить автоматически на основе анализа структуры табличного документа.

Основная идея в следующем.
1. Производится загрузка файла в табличный документ.
2. Далее построчный анализ документа (заодно ищем ИНН для определения поставщика).
3. При нахождениии в одной строке ячеек, содержащих текст "Наименование (Товар)", "Цена" и "Кол" определяемся с окончанием шапки документа и началом табличной части. Тут же по тексту в ячейках определяем номера колонок и для других данных (код, штрихкод, артикул).
4. Загружаем данные из найденных колонок в табличную часть обработки.

Конечно, электронный документ в этом случае должен соответствовать определенным требованиям: 

1) в табличной части счета должны присутствовать, как минимум, колонки, содержащие наименование товара, количество и цену;
2) в название колонки с наименованием товара должно содержаться сочетание «товар» или «наименование»;
3) в названии колонки с количеством должно быть сочетание «кол»;
4) в названии колонки с ценой - сочетание «цена»;
5) в названии колонки с штрихкодом товара — сочетание «штрих»;
6) в названии колонки с кодом товара — сочетание «код»;
7) в название колонки с артикулом товара — сочетание «артикул»;
8) следует также иметь ввиду, что при наличии в счете нескольких колонок с количеством или ценой будут использоваться первые найденные.
 
Ну, а теперь попорядку.

Загрука файла в табличный документ 1С.
В интернете существует большое количество вариантов для этого. Ниже представлен вариант с использованием "OpenOffice". 

// возращает Табличный Документ со считанной информацией
Функция СчитатьФайл(Знач ПутьКФайлу,текЛист) //OpenOffice Calc//

   
Попытка
       
ServiceManager = Новый COMОбъект("com.sun.star.ServiceManager");
    Исключение
       
Предупреждение(ОписаниеОшибки() + Символы.ПС + "программа OpenOffice\LibreOffice не установлена на данном компьютере!");
        Возврат Неопределено;
    КонецПопытки;

   
текЛист = ?(текЛист=0, 1, текЛист);
   
ПутьКФайлу = СтрЗаменить(ПутьКФайлу," ","%20");
   
ПутьКФайлу = СтрЗаменить(ПутьКФайлу,"\","/");
   
ПутьКФайлу = "file:/" + "/localhost/" + ПутьКФайлу;

   
Desktop = ServiceManager.createInstance("com.sun.star.frame.Desktop");
   
Args = Новый COMSafeArray("VT_VARIANT", 3);
   
Свойства = ServiceManager.Bridge_GetStruct("com.sun.star.beans.PropertyValue");
   
Свойства.Name = "AsTemplate";
   
Свойства.Value = Истина;
   
Args.SetValue(0, Свойства);
   
Свойства1 = ServiceManager.Bridge_GetStruct("com.sun.star.beans.PropertyValue");
   
Свойства1.Name = "Hidden";
   
Свойства1.Value = Истина;
   
Args.SetValue(1,Свойства1);
   
Свойства2 = ServiceManager.Bridge_GetStruct("com.sun.star.beans.PropertyValue");
   
Свойства2.Name = "Password";
   
Свойства2.Value = ПарольНаФайл;
   
Args.SetValue(2,Свойства2);
   
Document = Desktop.LoadComponentFromURL(ПутьКФайлу, "_blank", 0, Args);
    Если
Document = Неопределено Тогда
       
Desktop.terminate();
       
Предупреждение("Ошибка чтения файла! Возможно необходимо указать пароль.");
        Возврат Неопределено;
    КонецЕсли;
   
Sheets = Document.getSheets();
   
Sheet = Sheets.getByIndex(текЛист-1);

   
Cursor = Sheet.CreateCursor();
   
Cursor.GoToStartOfUsedArea(Ложь);
   
Cursor.GoToEndOfUsedArea(Истина);
   
КоличествоЗаполненныхКолонок        = Cursor.Columns.Count;
   
КоличествоЗаполненныхСтрок        = Cursor.Rows.Count;
   
RangeAddress = Cursor.GetRangeAddress();
   
ПерваяЗаполненнаяКолонка        = RangeAddress.StartColumn;
   
ПерваяЗаполненнаяСтрока            = RangeAddress.StartRow;
   
ПоследняяЗаполненнаяКолонка        = RangeAddress.EndColumn;
   
ПоследняяЗаполненнаяСтрока        = RangeAddress.EndRow;

   
Range = Sheet.getCellRangeByPosition(ПерваяЗаполненнаяКолонка, ПерваяЗаполненнаяСтрока, ПоследняяЗаполненнаяКолонка, ПоследняяЗаполненнаяСтрока);
   
МассивКом = Range.getDataArray();
   
тмпПростойМассив = МассивКом.Выгрузить();

   
ТабДокумент = Новый ТабличныйДокумент;

   
НомСтр = 0;
    Для каждого
массив из тмпПростойМассив Цикл
       
НомСтр = НомСтр+1;
       
НКол = 0;
        Для каждого
ЭлементМассива из массив цикл
           
НКол = НКол+1;
           
ЗапОбласть = ТабДокумент.Область(НомСтр,НКол);
           
ЗапОбласть.Текст = СокрЛП(Формат(ЭлементМассива,"ЧГ=0"));
        КонецЦикла;
    КонецЦикла;

   
Document.close(True);
   
Desktop.terminate();

    Возврат
ТабДокумент;

КонецФункции

Далее анализируем табличный документ и заполняем таблицу значений.


Процедура ЗаполнитьТаблицуПоДокументу(ТабДокумент)

    Перем
ТоварНК, КоличествоНК, ЦенаНК, АртикулНК, КодНК, ШКодНК; // номера колонок
   
Шапка = Истина; ТабличнаяЧасть = Ложь; НашлиИНН = Ложь;

   
ВысотаТаблицы = ТабДокумент.ВысотаТаблицы;
   
ШиринаТаблицы = ТабДокумент.ШиринаТаблицы;

    Для
ТекСтрока = 1 По ВысотаТаблицы Цикл // цикл по строкам

       
Если ТабличнаяЧасть Тогда // разбираем строку табличной части
            // проверим на служебные строки и подвал
           
Попытка
               
// товар
               
ТекОбласть = ТабДокумент.Область(ТекСтрока,ТоварНК);
               
Товар = ТекОбласть.Текст;
               
// Количество
               
ТекОбласть = ТабДокумент.Область(ТекСтрока,КоличествоНК);
               
Количество = Число(ТекОбласть.Текст);
               
// Цена
               
ТекОбласть = ТабДокумент.Область(ТекСтрока,ЦенаНК);
               
Цена = Число(ТекОбласть.Текст);
                Если
СтрДлина(Товар)<4 ИЛИ Количество=0 ИЛИ Цена=0 Тогда
                    Продолжить;
                КонецЕсли;
            Исключение
                Продолжить;
            КонецПопытки;
           
// Добавляем строку в заполняемую таблицу
           
НовСтрока = ТаблицаЗагрузки.Добавить();
           
НовСтрока.Наименование = Товар;
           
НовСтрока.Количество = Количество;
           
НовСтрока.Цена = Цена;
           
НовСтрока.Сумма = Цена*Количество;
            Если
ЕстьКод Тогда // Код
               
ТекОбласть = ТабДокумент.Область(ТекСтрока,КодНК);
               
НовСтрока.Код = ТекОбласть.Текст;
            КонецЕсли;
            Если
ЕстьШтрихкод Тогда // Штрихкод
               
ТекОбласть = ТабДокумент.Область(ТекСтрока,ШКодНК);
               
НовСтрока.Штрихкод = ТекОбласть.Текст;
            КонецЕсли;
            Если
ЕстьАртикул Тогда // Артикул
               
ТекОбласть = ТабДокумент.Область(ТекСтрока,АртикулНК);
               
НовСтрока.Артикул = ТекОбласть.Текст;
            КонецЕсли;
        КонецЕсли;

        Если
Шапка Тогда  // разбираем шапку документа
           
ТоварНК = 0; КоличествоНК = 0; ЦенаНК = 0;
           
АртикулНК = 0; КодНК = 0; ШКодНК = 0;
            Для
ТекКолонка = 1 По ШиринаТаблицы Цикл // цикл по колонкам
               
ТекОбласть = ТабДокумент.Область(ТекСтрока,ТекКолонка);
               
ТекТекст = ТекОбласть.Текст;
                Если
ПустаяСтрока(ТекТекст) Тогда
                    Продолжить;
                КонецЕсли;
                Если  Не
НашлиИНН И Найти(ТекТекст,"ИНН")>0 Тогда   // ищем ИНН
                   
Для нк = ТекКолонка По ТабДокумент.ШиринаТаблицы Цикл
                       
ОбластьИНН = ТабДокумент.Область(ТекСтрока,нк);
                       
ИНН = НайтиИНН(ОбластьИНН.Текст);
                        Если Не
ПустаяСтрока(ИНН) Тогда
                           
НашлиИНН = Истина;
                           
НайтиПоставщика(ИНН);
                            Прервать;
                        КонецЕсли;
                    КонецЦикла;
                ИначеЕсли
ТоварНК=0 И Найти(ВРег(ТекТекст),"ТОВАР")>0 ИЛИ Найти(ВРег(ТекТекст),"НАИМЕНОВАНИЕ")>0 Тогда
                   
ТоварНК = ТекКолонка;
                ИначеЕсли
КоличествоНК=0 И Найти(ВРег(ТекТекст),"КОЛ")>0 Тогда
                   
КоличествоНК = ТекКолонка;
                ИначеЕсли
ЦенаНК=0 И Найти(ВРег(ТекТекст),"ЦЕНА")>0 Тогда
                   
ЦенаНК = ТекКолонка;
                ИначеЕсли
АртикулНК=0 И Найти(ВРег(ТекТекст),"АРТИКУЛ") Тогда
                   
АртикулНК = ТекКолонка;
                ИначеЕсли
ШКодНК=0 И Найти(ВРег(ТекТекст),"ШТРИХ")>0 Тогда
                   
ШКодНК = ТекКолонка;
                ИначеЕсли
КодНК=0 И Найти(ВРег(ТекТекст),"КОД")>0 Тогда
                   
КодНК = ТекКолонка;
                КонецЕсли;
            КонецЦикла; 
// по колонкам в шапке

           
Если ТоварНК>0 И КоличествоНК>0 И ЦенаНК>0 Тогда // найден заголовок ТЧ
               
Шапка = Ложь;
               
ТабличнаяЧасть = Истина;
               
ЕстьКод = КодНК>0;
               
ЕстьШтрихкод = ШКодНК>0;
               
ЕстьАртикул = АртикулНК>0;
               
ТаблицаЗагрузки.Очистить();
            КонецЕсли;
        КонецЕсли;

    КонецЦикла;
// по строкам

   
Если Шапка Тогда
       
Предупреждение("Не найдена табличная часть в документе!");
    КонецЕсли;

КонецПроцедуры
 

Используемые тут функции "НайтиИНН" и "НайтиПоставщика" можно посмотреть в прилагаемой обработке.

Конечно, ничего идеального не существует. Так некоторые документы (например Торг-12) со сложными шапками без редактирования нормально не загрузятся. Но идея имеет право на жизнь

Для примера выкладываю обработку загрузки файлов в документ "Поступление товаров и услуг" для "Управление торговли 10.3".
Обработка подключается в качестве "Внешней обработки загрузки табличных частей" (Сервис - Внешнии печатные форму и обработки - Внешнии обработки загрузки табличных частей).
В прилагаемой обработке для сопоставления номенклатуры используется регистр сведений "Номенклатура контрагентов", что в принципе не очень удобно и не совсем правильно. Но тем не менее работает и не требует изменения конфигурации. У меня используется для сопоставления собственный регистр сведений "
СоответствиеТоваровПоставщика".

Информация для тех, кто тоже решит использовать такой же регистр:

Регистр независимый, непереодический. 

Измерения: "Поставщик"(СправочникСсылка.Контрагент, ведущее), "ПолеПоиска"(Строка, 15), "СтрокаПоиска"(Строка, 150). 

Ресурс: "Номенклатура"(СправочникСсылка.Номенклатура). 

Для работы обработки с данным регистром в модуле обработки в процедурах "ЗаполнениеСоответствий" и "СохранениеСоответствий" нужно раскоментировать закоментированное и закоментировать незакоментированное. 

Краткая инструкция к обработке.

Загрузка счета производится из документа «Поступление товаров и услуг» через кнопку меню табличной части «Заполнить» -> «Заполнить из электронного документа».

В форме обработке необходимо указать путь к файлу со счетом, при наличии в файле нескольких листов можно указать порядковый номер загружаемого листа из файла (по умолчанию 1). Если файл запоролен, указать пароль.

При нажатии «Загрузить файл» производится считывание и заполнение табличной части обработки. При этом, если в счете присутствуют поля «Код», «Штрихкод» и «Артикул», в табличной части появятся аналогичные колонки. Информационная строка под табличной частью служит для контроля правильности загрузки. Поле «НДС» служит только для формирования данной строки.

В момент загрузки файла производится автоматический поиск соответствий в определенном регистре сведений согласно установленного «Поставщика» и «Метода поиска» (по наименованию, по коду, по штрхкоду или по артикулу). При нахождение определенного ранее соответствия будет заполнено поле «Ссылка в базе». Для строк с неопределенными ранее соответствиями поиск будет продолжен в справочнике "Номенклатура" по полям «Полное наименование», «Штрихкод» и «Артикул». Строки с найденными совпадениями в данном случае будут помечены голубым фоном. Автоматический поиск соответствий также можно запустить вручную кнопкой «Найти соответствия». Позиции с ненайденными соответствиями будут подсвечены розовым цветом.

Для остальных позиций без совпадений необходимо в табличной части указать соответствующую данной позиции номенклатуру из базы. Строки с указанными вручную соответсвиями будут подсвечены голубым цветом. После указания соответствий для автоматического сопоставления в дальнейшем, необходимо произвести запись с помощью кнопки «Записать соответствия». При этом будут сохранены в базе данные сопоставления для данного «Поставщика» согласно указанному «Методу поиска». Предпочтительней для метода поиска использовать поиск «по коду» , «по артикулу» или «по штрихкоду».

Загрузка позиций в документ производится после указания всех соответствий кнопкой «Заполнить документ и закрыть». 

Во второй версии обработки появилась возможность настройки сочетаний для поиска колонок (типа "Цена", "Кол" и т. п.). Для настройки нужно нажать кнопку со значком "Настройка" над кнопкой "Закрыть".

Скачать файлы

Наименование Файл Версия Размер
Обработка заполнения табличной части "Поступление товаров и услуг" (в. 2)

.epf 38,44Kb
43
.epf 2 38,44Kb 43 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Zhilyakovdr 126 21.09.16 11:40 Сейчас в теме
Добрый день!
Сейчас решаю подобную задачу, только исходный материал документы на бумаге.
Документы сканируются поточным сканером, по заданию распознаются и кладутся в формате xlsx (его проще обрабатывать), далее в 1с регламентное задание при помощи регулярных выражений (по вхождению контрольной строки) распознает тип документа и таким же образом значимые данные типа инн и кпп, как организации так и контрагента.
Даже при такой степени распознания от настроек под конкретный загружаемый вид документа уйти не удалось.
Не знаю каким образом вы ищите ИНН и КПП, но как вариант:

........................
ОрганизацияИНН	= ДанныеДляЗаполнения.Организация.ИНН; 
Для каждого стр Из МассивSharedStrings Цикл
	
	МассивИНН	= грт_НаКлиентеИНаСервере.ВыполнитьРегулярноеВыражение(стр, "[0-9][0-9][0-9][0-9][0-9][0-9][0-9][0-9][0-9][0-9]");
	Если не МассивИНН.найти(ОрганизацияИНН) = Неопределено Тогда МассивИНН.удалить(МассивИНН.найти(ОрганизацияИНН)); КонецЕсли; 
	Если 		МассивИНН.количество() = 1 Тогда КонтрагентИНН	= МассивИНН[0];
	ИначеЕсли	МассивИНН.количество() > 1 Тогда КонтрагентИНН	= МассивИНН[0];
	КонецЕсли; 
		
КонецЦикла; 
......................
Показать


Функция ВыполнитьРегулярноеВыражение(ИсходнаяСтрока, Шаблон) Экспорт
	
	RegExp 				= грт_НаКлиентеИНаСервереПовтИсп.RegExp();
	RegExp.Pattern 		= Шаблон;
	RegExp.IgnoreCase	= истина;
	Результат = RegExp.Execute(ИсходнаяСтрока); 
	МассивСовпадений	= новый массив;
	Для Счетчик = 0 По Результат.Count - 1 Цикл 
		Совпадение = Результат.Item(Счетчик);
		МассивСовпадений.Добавить(Совпадение.Value);
	КонецЦикла;
	
	возврат	МассивСовпадений;
	
КонецФункции // ВыполнитьРегулярноеВыражение()
Показать


Функция RegExp() Экспорт
	
	Возврат	Новый COMОбъект("VBScript.RegExp");
	
КонецФункции


Надеюсь эти выдержки из кода помогут оптимизировать ваше решение.
2. hibico 259 21.09.16 15:36 Сейчас в теме
(1) Zhilyakovdr,
Идея понятна, возьму на вооружение. Единственно, как быть, если бывает ИНН с 12-ю символами.

У меня в данной обработке всё проще:
// ищет в переданной строке ИНН
Функция НайтиИНН(Текст)
	
	ОбрТекст = СтрЗаменить(Текст," ",Символы.ПС);
	Для н = 1 По СтрЧислоСтрок(ОбрТекст) Цикл
		Стр = СтрПолучитьСтроку(ОбрТекст,н);
		ДлинаСтр = СтрДлина(Стр);
		Если ДлинаСтр <> 10 И ДлинаСтр <> 12 Тогда
			Продолжить;
		КонецЕсли;
		Если Не ЭтоЦифры(Стр) Тогда
			Продолжить;
		КонецЕсли;
		Если ПравильныйИНН(Стр) Тогда
			Возврат Стр;
		КонецЕсли;
	КонецЦикла;
	Возврат "";
	
КонецФункции

// возвращает Истина, если строка состоит из цифр
Функция ЭтоЦифры(Текст)
	
	Для н = 1 По СтрДлина(Текст) Цикл
		Если Найти("0123456789",Сред(Текст,н,1))=0 Тогда
			Возврат Ложь;
		КонецЕсли;
	КонецЦикла;
	Возврат Истина;
	
КонецФункции
Показать

Функция ПравильныйИНН - больше для баловства, проверяет на правильность ИНН по контрольным числам.
3. hibico 259 30.09.16 12:21 Сейчас в теме
Обновлена процедура "ЗаполнитьТаблицуПоДокументу()" в тексте статьи на более правильную.
Также обновлен файл обработки. Новая версия лучше обрабатывает файлы со сложной структурой. Также появилась возможность настройки списка сочетаний для поиска колонок.
4. jimli 26.06.19 00:14 Сейчас в теме
Супер! А номера ГТД она подтягивает? Делаю подобную обработку, споткнулась на этапе сопоставления колонок...
5. stepinrn 11.07.19 18:07 Сейчас в теме
А эта обработка будет работать только с OpenOffice?
6. hibico 259 15.07.19 09:14 Сейчас в теме
В обработке работа только с OpenOffice. Для Exel надо переделать функцию "СчитатьФайл".
Оставьте свое сообщение

См. также

Групповая установка даты выплаты в документах "Отпуск" и "Командировка" на заданную дату и перерасчет отобранных документов Промо

Обработка документов Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 ЗУП3.x Абонемент ($m)

Обработка позволяет расчетчикам сократить время, затрачиваемое на расчет отпусков и командировок.

2 стартмани

15.02.2017    12846    81    ser6702    16    

"Учет штрафов ГИБДД" с возможной загрузкой из открытых источников в интернет Расширение конфигурации 1С: Предприятие 8.3

Обработка документов WEB v8 v8::УФ 1cv8.cf Россия БУ УУ Абонемент ($m)

Расширение конфигурации Бухгалтерия предприятия, редакция 3.0 (при минимальных изменениях любой типовой конфигурации), позволяющее вести историю данных по штрафам ГИБДД для справочника транспортных средств компании. Бонусом поставляется внешняя обработка, способная загружать эти данные из открытых источников в интернет.

4 стартмани

30.12.2019    9422    12    capitan    11    

Пакетное пробитие чеков на Онлайн-кассе при оплатах от физических лиц на расчетный счет

Банковские операции Кассовые операции Обработка документов v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Автоматизация процесса пробития чеков онлайн при поступлениях на расчетный счет от физических лиц. Помогает сократить трудозатраты таким организациям, как МФЦ, Управляющие компании и т.д. Подходит для 1С:Бухгалтерия 3.0 любой версии (базовая, ПРОФ, КОРП). Не изменяет конфигурацию. Конфигурация остается на поддержке (типовая).

2 стартмани

24.09.2019    12827    4    r.resh39    6    

Списание (корректировка) задолженности контрагентов УНФ 1.6

Закрытие периода Дебиторская и кредиторская задолженность Обработка документов Дебиторская и кредиторская задолженность v8 УНФ Украина БУ Абонемент ($m)

Обнуление задолженности контрагентов в конфигурации "Управление небольшой (нашей) фирмой" версии 1.6 с помощью документа "Корректировка регистров".

1 стартмани

24.07.2019    24508    16    DMon    1    

Помощник по закрытию месяца для УТ 11.3 Промо

Закрытие периода Обработка документов Закрытие периода Закрытие периода v8 v8::ОУ УТ11 Россия УУ Абонемент ($m)

Помощник по закрытию месяца для УТ 11.3. Имеет две функции: обнуление товаров "К оформлению" в интеркампани и обнуление отрицательных остатков в регистре "Себестоимость товаров".

5 стартмани

10.11.2017    25102    9    Zalipaka    1    

Регистрация документов с измененной суммой

Обработка документов v8 1cv8.cf Абонемент ($m)

Обработка берет информацию из истории изменения документов. Удобна для администраторов, когда документы с измененной суммой по какой-то причине не регистрируются в плане обменов. Можно регистрировать не все документы, а только те, которые были изменены.

1 стартмани

20.04.2019    20228    4    ryan    0    

Валовая прибыль для УПП 1.3, КА 1.1 в режиме РАУЗ (работа типового отчета без доработок конфигурации)

Обработка документов v8 КА1 УПП1 УУ Абонемент ($m)

Простое и мгновенное решение для использования типового отчета "Валовая прибыль" в конфигурациях "Управление производственным предприятием 1.3", "Комплексная автоматизация 1.1" (а также отраслевых решений на их базе) при включенном режиме РАУЗ (расширенная аналитика учета затрат). Не требует настройки или изменения конфигурации, либо может быть, для дополнительного удобства, интегрировано в нее с минимальными доработками.

2 стартмани

21.01.2019    20736    25    stvorl    12    

Универсальный инструмент для переноса данных через табличный документ (УФ)

Обработка документов Универсальные обработки Обработка справочников v8 v8::УФ 1cv8.cf Абонемент ($m)

Для опытных пользователей, разработчиков, администраторов, консультантов

5 стартмани

15.10.2018    36020    133    json    42    

Прыг-Скок...или из MS EXCEL в 1С (8.2) (открытый код) Промо

Обработка документов Обработка справочников Загрузка и выгрузка в Excel v8 1cv8.cf Абонемент ($m)

Универсальная загрузка данных из Microsoft Office Excel. Автоматическая загрузка из любых по форме документов с очень удобным редактором. Почти готовый шаблон для любой конфигурации. Не требует регистрации-бесплатно.

1 стартмани

16.09.2015    65409    362    Tatitutu    48    

Помощник корректировки остатков ЕГАИС в небольшом магазине. Розница 2.2

Розничная торговля Обработка документов Розничная торговля v8 Розница Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Россия УУ Абонемент ($m)

Данная обработка упрощает корректировку остатков алкогольной продукции небольшого магазина, где предполагается передача всей продукции в торговый зал сразу после приемки.

5 стартмани

08.09.2018    34856    83    asdfgcom    47    

Расширение резервов отпусков

Обработка документов Зарплата Зарплата v8 v8::СПР ERP2 ЗКГУ3.0 ЗУП3.x Россия БУ Абонемент ($m)

Произвольная настройка базы для расчета резервов отпусков.

2 стартмани

10.08.2018    28415    55    СергейКа    21    

Вы больше не будете разбирать Excel как раньше

Загрузка и выгрузка в Excel v8 1cv8.cf Абонемент ($m)

Кому не приходилось разбирать файлы в формате Excel? Все матерятся, плюются, требуют обещаний что "это в последний раз", но таки пишут загрузку из Excel. Потом форматы меняются, строки съезжают, колонки переставляют... Вам это не надоело?

1 стартмани

07.05.2018    30654    64    m-rv    34    

Перемещение остатков по счету МЦ04 между материально ответственными лицами для конфигураций (8.2). Промо

Обработка документов Универсальные обработки Учет ТМЦ Учет ТМЦ v8 БП2.0 Россия БУ Абонемент ($m)

Небольшая обработка, которая позволяет перекидывать остатки по счету МЦ04 с одного материально ответственного лица на другое

1 стартмани

22.11.2012    16445    102    niksaf    4    

Корректировка остатков ЕГАИС, возврат из регистра 2, загрузка ТТН из файлов, другое для УТ10.3

Розничная торговля Обработка документов Розничная торговля v8 v8::ОУ УТ10 Россия БУ Абонемент ($m)

Набор обработок для автоматизации работы с ЕГАИС: Обработка корректировки остатков ЕГАИС для УТ 10.3, аналогичная имеющимся в УТ 11, Рознице 2.2. Автоматически формирует документы "Передача в торговый зал", "Акт постановки на баланс в торговом зале", "Акт списания в торговом зале". Обработка возврата из регистра 2 с подбором справок Б. Обработка формирования ТТН из файлов xml.

1 стартмани

24.01.2018    37271    18    biz-intel    6    

Расчет начисления зарплаты со сложной формулой, по данным из внешнего источника. ЗУП 3.1

Обработка документов Загрузка и выгрузка в Excel Зарплата Зарплата v8 v8::СПР ЗКГУ3.0 ЗУП3.x БУ Абонемент ($m)

Расчет начисления зарплаты со сложной формулой, по данным из внешнего источника по данным экономического отдела. ЗУП 3.1.

3 стартмани

20.12.2017    51034    32    mvv1975    7    

Копирование меню в Трактир Management

Обработка документов Производство готовой продукции (работ, услуг) Производство готовой продукции (работ, услуг) v8 1cv8.cf Рестораны, кафе и фаст-фуд Россия УУ Абонемент ($m)

Механизм копирования меню в Трактир Management. Данная обработка расширяет функционал типового решения Трактир Management, позволяя быстро вводить в эксплуатацию новую точку путём создания нового меню на основании имеющегося.

1 стартмани

28.11.2017    29380    2    integrator1983    0    

Универсальный ввод на основании (заполнение) документов Промо

Обработка документов v8 v8::УФ КА1 БП2.0 ЗУП2.5 УТ10 Розница УПП1 ERP2 БП3.0 КА2 ЗУП3.x Абонемент ($m)

Обработка позволяет на основании документов одного вида создавать документы другого.

2 стартмани

19.05.2010    40236    1891    nika.1007    90    

Загрузка дополнительных реквизитов и сведений справочника Номенклатура из Excel и таблиц УТ 11, ERP 2

Обработка справочников Загрузка и выгрузка в Excel Учет ТМЦ Учет ТМЦ v8 v8::ОУ ERP2 УТ11 Россия УУ Абонемент ($m)

Внешняя обработка "Загрузка дополнительных реквизитов и сведений справочника Номенклатура"

1 стартмани

07.08.2017    43263    276    Windyhead    41    

Упрощение работы с актами сверки в УТ/КА/УПП - вывод номеров счетов в документе и печатной форме

Обработка документов Печатные формы документов Дебиторская и кредиторская задолженность Дебиторская и кредиторская задолженность v8 КА1 УТ10 УПП1 БУ УУ Абонемент ($m)

Обычно акт сверки с клиентами содержат информацию о документах реализации товаров (накладных) и выполненных платежах. Но платежи делаются на основании счетов, номера которых отсутствуют в актах, что затрудняет собственно сверку. Данная обработка находит соответствующие расходным накладным счета/заказы, показывает их в форме документа и выводит в печатную форму акта.

2 стартмани

12.05.2017    31918    4    denmax    7    

Изменение реквизитов справочников, документов, табличных частей, движений (Обычные и Управляемые формы) Промо

Обработка документов Обработка справочников v8 v8::УФ 1cv8.cf Казахстан Абонемент ($m)

Обработка позволяет редактировать реквизиты справочника, документа, его табличные части и движения.

1 стартмани

15.10.2012    49363    476    Exit_in    42    

Редактор движений документа. Сохранение в XML, обмен между базами, замена регистратора.

Обработка документов Универсальные обработки Обмен через XML v8 Абонемент ($m)

Редактор набора записей движений документа. Позволяет сохранить набор записей в XML, в настройки пользователя, прочитать сохраненный XML в другой идентичной базе, заменить регистратор. Можно изменять порядок записей, менять активность, как массово, так и по одной и др. Тонкий клиент, управляемые формы.

1 стартмани

07.09.2016    43194    158    Aphanas    4    

 Интеграция 1С и C#. Обращение к 1С через COM. Создание номенклатуры и выполнение запроса к 1С из C# на примере интеграции с Союз-PLM (система информационной поддержки жизненного цикла изделий). Обработка «Загрузка заказа на сборку». (ERP)

Загрузка и выгрузка в Excel Внешние источники данных Интеграция v8 ERP2 Абонемент ($m)

Союз-PLM представляет собой полнофункциональный программный комплекс для решения  широкого спектра задач управления инженерной технической информацией наукоемких изделий и сложных инженерных объектов в области машиностроения, приборостроения, архитектуры, строительства. На практике, это управление конструкторской документацией, интегрированное с САПР, бизнес-процессы, файловый архив. Все это работает в SQL и шевелится с помощью скриптов на C#. Скрипты свободно  отлаживаются в MS Visual Studio. Подробнее смотрите на их сайте: http://www.programsoyuz.ru/products/system-soyuz-plm.html  Редактирование, конструирование и использование бизнес-процессов на порядок лучше систем на базе 1С из тех, что я изучил.

1 стартмани

25.07.2016    47051    5    milkers    2    

Загрузка Счета покупателя из PDF

Обработка документов Файловые протоколы обмена, FTP Оптовая торговля Оптовая торговля v8 v8::БУ БП3.0 Абонемент ($m)

Обработка позволяет загрузить счет покупателя из pdf-файла в документ Счет на оплату покупателю (Бухгалтерия 3.0)

2 стартмани

23.05.2016    20747    24    John_d    3    

Выгрузка и загрузка данных из файла Excel с поиском по любым полям (есть поиск по ссылке, всего три итерации поиска. Управляемые формы или "Такси") Промо

Загрузка и выгрузка в Excel Обработка документов v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработка позволяет загружать данные с поиском по ссылке как для загружаемого объекта, так и его свойств. Загружает справочники, документы, планы видов характеристик. Будет полезна как замена использования конвертации данных для задач переноса, а также как классическая загрузка из табличного документа (Excel). Поиск объекта при загрузке выполняется до трех раз с разными полями поиска (поля поиска настраиваются). Также реализована выгрузка в Excel по ссылкам. У обработки удобный интерфейс, в котором разберется даже начинающий пользователь. Загрузка накладных из файлов xls реализована с интеллектуальным поиском колонок с данными. В интеллектуальном поиске поддерживаются все основные типовые печатные формы.

5 стартмани

16.10.2015    61597    512    primat    35    

Обработка "Все одной кнопкой" (групповое создание и печать документов) для УПП ред. 1.3

Обработка документов Пакетная печать Кассовые операции Оптовая торговля Производство готовой продукции (работ, услуг) Кассовые операции Оптовая торговля Производство готовой продукции (работ, услуг) v8 УПП1 БУ УУ Абонемент ($m)

Данная обработка предназначена для группового создания, редактирования и печати основных документов («Реализация товаров и услуг», «Счет-Фактура выданный», «Счет на оплату клиентом», «Доверенность» на получение продукции, "Приходного кассового ордера") на основании документа «Заказ клиента». Основная цель обработки – оптимизация работы менеджеров при формировании пакета документов клиентам.

5 стартмани

09.04.2016    24011    30    SEOAngels    0    

Управление доставкой розничным покупателям

Обработка документов Розничная торговля Розничная торговля v8 УТ10 Розничная и сетевая торговля (FMCG) Россия УУ Абонемент ($m)

Дополнение для УТ 11.1, оформление доставки для розничного покупателя на основании кассового чека в связке с мягким чеком покупателя.

5 стартмани

10.03.2016    30088    8    Denis_Viktorovich    5    

Ночное восстановление последовательности документов (фоновым заданием) для БП 3.0

Обработка документов v8 v8::БУ БП3.0 Россия Абонемент ($m)

Внешняя обработка служит для восстановления последовательности документов в БП 3.0 за месяц, по расписанию, фоновым заданием на сервере 1С. Подключается как дополнительная обработка в режиме пользователя.

5 стартмани

25.02.2016    37734    89    SmArtist    8    

Редактирование движений документа (Управляемый и неуправляемый интерфейс) Промо

Обработка документов v8 v8::УФ 1cv8.cf Абонемент ($m)

Не все конфигурации позволяют вручную отредактировать движения документа без перепроведения. А если надо? Тогда можно воспользоваться данной обработкой.

1 стартмани

19.10.2012    29830    225    NILS2009    13    

Перечисление НДФЛ в бюджет РФ (13%, 30%)

Обработка документов Зарплата Зарплата v8 v8::СПР ЗУП2.5 БУ НУ НДФЛ Абонемент ($m)

Внешняя обработка (табличных частей), предназначенная для корректного заполнения документа "Перечисление НДФЛ в бюджет РФ". Конфигурация: Зарплата и Управление Персоналом, редакция 2.5

1 стартмани

27.01.2016    37164    239    1kashak    23    

Начисление процентов по кредитам и займам для 1С:Бухгалтерии 3.0

Обработка документов Займы, кредит, лизинг Займы, кредит, лизинг v8 БП2.0 Россия БУ Абонемент ($m)

Универсальная обработка по начислению процентов по кредитам и займам для 1С:Бухгалтерии 3.0 без изменения конфигурации

1 стартмани

22.01.2016    68035    167    algora    27    

Пакетная замена номенклатуры с учетом характеристик

Обработка документов Оптовая торговля Учет ТМЦ Оптовая торговля Учет ТМЦ v8 КА1 УТ10 УПП1 УУ Абонемент ($m)

Обработка "Пакетная замена номенклатуры" в Заказе покупателя, Реализации и Поступлении товаров с использованием отбора по значениям характеристик

1 стартмани

22.01.2016    25465    3    trendy    1    

Формирование актов сверки взаиморасчётов и групповая печать

Обработка документов Пакетная печать Дебиторская и кредиторская задолженность Дебиторская и кредиторская задолженность v8 БП2.0 БУ Абонемент ($m)

Обработка позволяет сформировать новые акты сверки и распечатать за период разом на принтере

3 стартмани

15.01.2016    36257    38    gortol    4    

Перечисление НДФЛ в бюджет: заполнение НДФЛ по расчетной ведомости для ЗУП 2.5

Обработка документов Зарплата Зарплата v8 ЗУП2.5 Россия БУ НДФЛ Абонемент ($m)

Внешняя обработка для заполнению сумм НДФЛ для перечисления в бюджет по данным расчетной ведомости для 1С ЗУП 2.5

2 стартмани

30.12.2015    24096    71    Snork    4    

Акт сверки с номерами счетов-фактур, начальными остатками по договорам и заполнением по головному контрагенту [Расширение]

Обработка документов Дебиторская и кредиторская задолженность Дебиторская и кредиторская задолженность v8 БП3.0 Россия БУ Абонемент ($m)

Акт сверки взаиморасчетов (БП 3.0): - Вывод начальных и конечных остатков по договорам в печатную форму; - Вывод валютной суммы для договоров в условных единицах; - Заполнение данных счетов-фактур или УПД; - Заполнение данных по головному контрагенту и всем обособленным подразделениям; - Заполнение представителя организации из ответственных лиц; - Факсимильная подпись и печать. Не требует снятия с поддержки и подходит для базовых конфигураций

1 стартмани

15.12.2015    59436    95    mrXoxot    40    

Резервы отпусков для УПП 1.3

Обработка документов Зарплата Зарплата v8 УПП1 Россия БУ Абонемент ($m)

Обработка для создания резерва отпусков в 1С: УПП 1.3

1 стартмани

14.12.2015    28910    42    sarun    5    

Загрузка УПД в Бухгалтерию 3.0

Обработка документов Загрузка и выгрузка в Excel Оптовая торговля Оптовая торговля v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Загрузка УПД из Excel в Бухгалтерию предприятия 3.0, с добавлением номенклатуры, ГТД, стран происхождения.

3 стартмани

20.10.2015    24342    13    teyana    12    

Полезные приемы при работе с Excel из 1С (Версия 3.1)

Практика программирования Разработка внешних компонент Загрузка и выгрузка в Excel v8 1cv8.cf Абонемент ($m)

Программисту 1С часто приходится работать с таблицами Excel из 1С. Я постарался собрать небольшой FAQ и набор функций для работы с файлами Excel. Надеюсь, кому-то будет полезна данная статья.

1 стартмани

22.09.2015    210265    449    Zerocl    73    

Перепроведение документа по части регистров

Обработка документов v8 1cv8.cf Абонемент ($m)

Обработка для перепроведения документов выбранного вида с частичным сохранением движений регистров и проводок.

1 стартмани

16.09.2015    25404    51    NILS2009    6    

УПП. Реализация товаров в у.е. Формирование рублевых сумм проводок и регистров накопления с учетом ранее поступивших авансов : сразу при проведении документа

Дебиторская и кредиторская задолженность Закрытие периода Обработка документов Дебиторская и кредиторская задолженность Закрытие периода v8 УПП1 Россия БУ НУ Налог на прибыль НДС Абонемент ($m)

Договор с покупателем ведется в условных единицах. Вид взаиморасчетов : по договору. Ведем взаиморасчеты в разрезе документов расчетов. Ранее поступил аванс на 2 000 EUR. Курс был 45 руб Теперь производим отгрузку на 5 000 EUR. Курс изменился и стал : 60 руб. Проводки по отгрузке формируются с учетом ранее поступившего аванса. Сумма реализации должна составить : 2 000 х 45 + 3 000 х 60 = 90 000 + 180 000 = 270 000 руб.е В типовой реализации проведение дает сумму по реализации 270 000 только для регистра накопления "Взаиморасчеты с контрагентами по документам расчетов" После внесения доработок в обработку проведения (процедура "Движения Регистров") данные по другим регистрам тоже выходят на сумму с учетом поступившего ранее аванса. Проверено для вариантов настройки программы: 1.Валюта упр.учета - Рубли 2.Валюта упр.учета НЕ Рубли

2 стартмани

08.09.2015    40214    18    Designer1C    9    

Обмен прайс-листами и анализ ценовой политики конкурентов, партнёров и поставщиков в программе 1С:Предприятие

Ценообразование, прайсы Обработка документов Загрузка и выгрузка в Excel Ценообразование, анализ цен Ценообразование, анализ цен v8 УТ10 УПП1 УУ Абонемент ($m)

Универсальная программа для загрузки Прайс-листов в базу 1С:Предприятия 8. Основные достоинства: простота использования и широкие функциональные возможности поиска товаров для записи цен. Область применения: обмен прайс-листами и анализ ценовой политики конкурентов, партнёров и поставщиков в программе 1С:Предприятие.

10 стартмани

16.07.2015    33987    4    Destroy    2    

И снова "Как сжать картинки для экспорта в EXCEL?" или Умная картинка 8.2

Практика программирования Загрузка и выгрузка в Excel v8 1cv8.cf Абонемент ($m)

Прошла уже эпоха , когда экономили на трафике интернета. Но все же...повторюсь. Я предлагаю совершенно новый способ сжатия картинки - эффект в 20 раз !!!

1 стартмани

17.06.2015    31307    53    Tatitutu    10    

Расчет процентов по займам и кредитам

Обработка документов Займы, кредит, лизинг Займы, кредит, лизинг v8 БП2.0 Россия БУ Абонемент ($m)

В свое время взяла с Инфостарта обработку по расчету процентов по полученным займам и кредитам и переработала ее. Подходит для автоматического расчета исчисленных процентов по полученным займам и кредитам (особенно при большом количестве договоров займа) с нетрудоемким отражением в бухгалтерском и налоговом учете исчисленных процентов. Уточнен налоговый учет расходов по процентам в соответствии с изменениями законодательства в 2015 году. Внесены исправления по техническим ошибкам (в Бухучете расходы отражались по группе счета 91, а также в НУ по Дт счета отражены суммы процентов)

1 стартмани

17.04.2015    17792    16    lvk74    13    

Перепроведение документов только по выбранным регистрам (Управляемые формы, 8.2, 8.3)

Обработка документов v8 v8::УФ 1cv8.cf Абонемент ($m)

Проводит движения по выбранным документам и регистрам, работает на 1с 8.2 - 8.3, управляемые формы. Возможно отбирать или не отбирать по периоду, останавливать по ошибке, выполнять прерывание пользователя, выводить ошибки. И главное преимущество - работает по УФ (управляемые формы)!

3 стартмани

03.04.2015    21894    122    Dmitrii D    1