Дата создания во всех документах, не снимая документы с поддержки

Публикация № 724129

Разработка - Практика программирования

общий реквизит дата создания документа

Дата создания во всех документах, при этом документы остаются на поддержке

Здравствуйте! Я расскажу на примере конфигурации Бухгалтерия предприятия 3.0 как я добавила реквизит "Дата создания" во все документы не снимая документы с поддержки. Предлагаю два варианта решения:

Первый вариант:


1. Создать общий реквизит "_ДатаСоздания", указать состав документов, которые будут содержать данный реквизит;

2. Найти процедуру, в которую обращаются все документы при создании, у меня это процедура "ПриСозданииНаСервере" в общем модуле "ПодключаемыеКоманды" и написать там одну строчку: 

Процедура ПриСозданииНаСервере(Форма, ПараметрыРазмещения = Неопределено) Экспорт

_Общий.ПриСозданииФормыНаСервере(Форма);

//*Дальше стандартный код, я не буду его здесь показывать

КонецПроцедуры

 

3. И последнее:) Создать общий модуль под названием "_Общий" или использовать существующий, в котором будут лежать нужные процедуры для прорисовки реквизита "Дата создания" на форме документа и на форме списка. Процедуры модуля:

Процедура ПриСозданииФормыНаСервере(Форма) Экспорт
	 
	 МДФормы	  = Метаданные.НайтиПоПолномуИмени(Форма.ИмяФормы);
	 МДОбъекта = МДФормы.Родитель();
	 
	 Если Метаданные.Документы.Содержит(МДОбъекта) Тогда
		 // это какая то из форм документа
		 Если Метаданные.ОбщиеРеквизиты._ДатаСоздания.Состав.Найти(МДОбъекта).Использование = Метаданные.СвойстваОбъектов.ИспользованиеОбщегоРеквизита.Использовать Тогда
			 //общий реквизит _ДатаСоздания есть
			 Если МДФормы = МДОбъекта.ОсновнаяФормаДляВыбора Тогда
				 //ничего не делаем
			 ИначеЕсли МДФормы = МДОбъекта.ОсновнаяФормаСписка Тогда
				 // это основная форма списка
				 Реквизиты = Форма.ПолучитьРеквизиты();
				 //МДОбъекта.Движения.Содержит(Метаданные.РегистрыБухгалтерии.Хозрасчетный)
				 
				 Для каждого Рекв из Реквизиты цикл
					 Если Рекв.ТипЗначения.СодержитТип(Тип("ДинамическийСписок")) Тогда
						 Список = Форма[Рекв.Имя];
						 
						 Если Список.ОсновнаяТаблица = МДОбъекта.ПолноеИмя() Тогда
							 // Это динамический список с нужными документами
							 ДобавитьДопПоляВДинСписок(Форма, Рекв.Имя);
						 КонецЕсли;
					 КонецЕсли;
				 КонецЦикла;
			 ИначеЕсли НЕ (Форма.Элементы.Найти("Дата") = Неопределено ИЛИ Форма.Элементы.Найти("Номер") = Неопределено) Тогда
				 //это форма документа
				 Если Форма.Параметры.Ключ.Пустая() Тогда
					 //новый документ - заполним дату создания
					 Форма.Объект._ДатаСоздания = ТекущаяДата();
				 КонецЕсли;
				 
				 ОтобразитьДатуСозданияНаФорме(Форма);
			 КонецЕсли;
		 КонецЕсли;
		 
	 ИначеЕсли Метаданные.ЖурналыДокументов.Содержит(МДОбъекта) Тогда
		 //журнал документов - добавим поле
		 ПолеФормы_ДатаСоздания = Форма.Элементы.Добавить("_ДатаСоздания", Тип("ПолеФормы"),Форма.Элементы.Список);	
		 ПолеФормы_ДатаСоздания.Вид		   = ВидПоляФормы.ПолеВвода;
		 ПолеФормы_ДатаСоздания.ПутьКДанным = "Список.Ссылка._ДатаСоздания";
		 ПолеФормы_ДатаСоздания.Заголовок   = "Создан";
		 
	 КонецЕсли;
	 
 КонецПроцедуры
 

Процедура ОтобразитьДатуСозданияНаФорме(Форма)
	 
	 мЭлементы = Форма.Элементы;
	 ЭУ = мЭлементы.Найти("_ДатаСоздания"); 
	 Если ЭУ = Неопределено Тогда
		 ГруппаДатаСоздания = мЭлементы.Найти("_ГруппаДатаСоздания");
		 Если НЕ ГруппаДатаСоздания = Неопределено Тогда
			 ЭУ = мЭлементы.Добавить("_ДатаСоздания", Тип("ПолеФормы"), ГруппаДатаСоздания);
		 Иначе
			 ЭлементОрганизация = мЭлементы.Найти("Организация");
			 Если ЭлементОрганизация = Неопределено Тогда
				 //пока просто добавим поле
				 ЭУ = мЭлементы.Добавить("_ДатаСоздания", Тип("ПолеФормы"));
			 Иначе
				 //создадим группу _ДатаСоздания и поместим туда
				 Если ТипЗнч(ЭлементОрганизация.Родитель) = Тип("ГруппаФормы") Тогда
					 ГруппаДатаСоздания = мЭлементы.Добавить("_ГруппаДатаСоздания", Тип("ГруппаФормы"), ЭлементОрганизация.Родитель);
				 Иначе
					 ГруппаДатаСоздания = мЭлементы.Добавить("_ГруппаДатаСоздания", Тип("ГруппаФормы"));
				 КонецЕсли;
				 
				 ГруппаДатаСоздания.Вид				   = ВидГруппыФормы.ОбычнаяГруппа;
				 ГруппаДатаСоздания.Группировка		   = ГруппировкаПодчиненныхЭлементовФормы.Горизонтальная;
				 ГруппаДатаСоздания.Отображение		   = ОтображениеОбычнойГруппы.Нет;	
				 ГруппаДатаСоздания.ОтображатьЗаголовок = Ложь;	
				 
				 //перемещаем группу перед организацией
				 мЭлементы.Переместить(ГруппаДатаСоздания, ГруппаДатаСоздания.Родитель, ЭлементОрганизация);
				 
				 //меняем группу у организации
				 мЭлементы.Переместить(ЭлементОрганизация, ГруппаДатаСоздания);
				 
				 //добавляем в созданную группу дату создания
				 ЭУ = мЭлементы.Добавить("_ДатаСоздания", Тип("ПолеФормы"), ГруппаДатаСоздания);
			 КонецЕсли;
		 КонецЕсли;
	 КонецЕсли;
	 
	 ЭУ.Вид						= ВидПоляФормы.ПолеВвода;
	 ЭУ.ПутьКДанным				= "Объект._ДатаСоздания";
	 ЭУ.Ширина					= 12;
	 ЭУ.РастягиватьПоГоризонтали = Ложь;
	 ЭУ.Заголовок				= "Создан";
	 ЭУ.ПоложениеЗаголовка		= ПоложениеЗаголовкаЭлементаФормы.Лево;
	 ЭУ.Доступность				= Ложь;
	 
	 Если НЕ Форма.Параметры.Ключ.Пустая() Тогда
		 //существующий документ
		 Если Форма.Объект._ДатаСоздания <> '00010101' Тогда
			 //дата создания заполнена
			 РазностьВСекундах = НачалоДня(Форма.Объект._ДатаСоздания) - НачалоДня(Форма.Объект.Дата);
			 Если РазностьВСекундах / 86400 > 15 Тогда
				 //совсем задним число ввели - обведем рамку
				 ЭУ.ЦветРамки = WebЦвета.КрасноФиолетовый;
			 КонецЕсли;
		 КонецЕсли;
	 КонецЕсли;
	 
 КонецПроцедуры //ОтобразитьДатуСозданияНаФорме()
 
Процедура ДобавитьДопПоляВДинСписок(Форма, ИмяРеквизита)
	 
	 Список	   = Форма[ИмяРеквизита];
	 ИмяТаблицы = Список.ОсновнаяТаблица;
	 
	 Если Список.ПроизвольныйЗапрос Тогда
		 
		 Схема = Новый СхемаЗапроса();
		 Схема.УстановитьТекстЗапроса(Список.ТекстЗапроса);
		 
		 // Теперь нужно добавить дату создания
		 Если Схема.ПакетЗапросов.Количество() > 1 Тогда
			 //внутренние таблицы в дин.списках только с 8.3.8 и пока нигде не используются
			 ЗаписьЖурналаРегистрации("Отладка", УровеньЖурналаРегистрации.Примечание, Метаданные.НайтиПоПолномуИмени(Форма.ИмяФормы), ,
			 "Не могу добавить доп.поля, т. к. в пакете больше одного запроса.
			 |" + Форма.ИмяФормы + ", " + ИмяРеквизита);
			 Возврат;
		 КонецЕсли;
		 
		 ЗапросПакета = Схема.ПакетЗапросов[0];
		 
		 Если ЗапросПакета.Операторы.Количество() > 1 тогда
			 ЗаписьЖурналаРегистрации("Отладка", УровеньЖурналаРегистрации.Примечание, Метаданные.НайтиПоПолномуИмени(Форма.ИмяФормы), ,
			 "Не могу добавить доп.поля, т. к. в запросе больше одного оператора.
			 |" + Форма.ИмяФормы + ", " + ИмяРеквизита);
			 Возврат;
		 КонецЕсли;
		 
		 ИндексОператора = 0;
		 Оператор  = ЗапросПакета.Операторы[ИндексОператора];
		 Источник1 = Оператор.Источники[0];
		 Если ТипЗнч(Источник1.Источник) <> Тип("ТаблицаСхемыЗапроса") или Источник1.Источник.ИмяТаблицы <> ИмяТаблицы тогда
			 ЗаписьЖурналаРегистрации("Отладка", УровеньЖурналаРегистрации.Примечание, Метаданные.НайтиПоПолномуИмени(Форма.ИмяФормы), ,
			 "Не могу добавить доп.поля, т. к. первый источник — не основная таблица.
			 |" + Форма.ИмяФормы + ", " + ИмяРеквизита);
			 Возврат;
		 КонецЕсли;
		 
		 Выражение = Оператор.ВыбираемыеПоля.Добавить(Источник1.Источник.Псевдоним + "._ДатаСоздания");
		 
		 Колонка = ЗапросПакета.Колонки[ЗапросПакета.Колонки.Количество()-1];
		 Колонка.Поля.Установить(ИндексОператора, Выражение);
		 Колонка.Псевдоним = "Создан";

 
		 ПсевдонимДока = Источник1.Источник.Псевдоним;
		 Список.ТекстЗапроса = СтрЗаменить(Список.ТекстЗапроса, ""+ПсевдонимДока+".ПометкаУдаления КАК ПометкаУдаления,", ""+ПсевдонимДока+".ПометкаУдаления,"); //Схема.ПолучитьТекстЗапроса();
		 Список.ТекстЗапроса = СтрЗаменить(Список.ТекстЗапроса, ""+ПсевдонимДока+".ПометкаУдаления,", ""+ПсевдонимДока+".ПометкаУдаления," + Символы.ПС + ПсевдонимДока +"._ДатаСоздания КАК Создан, "); //Схема.ПолучитьТекстЗапроса();
	 
		 Элт = Форма.Элементы.Добавить("Создан", Тип("ПолеФормы"), Форма.Элементы[ИмяРеквизита]);
		 Элт.Вид			= ВидПоляФормы.ПолеВвода;
		 Элт.Заголовок	= "Создан";
		 Элт.ПутьКДанным = ИмяРеквизита + ".Создан";
		 Элт.Видимость	= Истина;
		 
	 КонецЕсли;
	 
 КонецПроцедуры //ДобавитьДопПоляВДинСписок()

Второй вариант:


1. Создать общий реквизит "_ДатаСоздания", указать состав документов, которые будут содержать данный реквизит;

2. Установить расширение,  я его тестировала на релизе 3.0.57.10, в принципе будет работать и на прошлых релизах, но придется решить некоторые несоответствия совместимости расширения и конфигурации,  т.к. с выходом нового релиза приходится постоянно менять совместимость в расширении... С расширением не придется создавать и снимать общие модули с поддержки), также расширение необходимо снять с безопасного режима.

Скачать файлы

Наименование Файл Версия Размер
Расширение по дате создания:

.cfe 8,75Kb
1
.cfe 8,75Kb 1 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. script 230 08.01.18 03:58 Сейчас в теме
Вы хотя бы написали бы причину, почему это нельзя сделать через расширения.
motorsoft; Silenser; alexveraww; +3 Ответить
3. Margo462 263 08.01.18 09:43 Сейчас в теме
(1) можно попробовать в расширении добавить общий модуль и там процедуры те написать, и перехватить модуль подключаемых команд, я делала это давно когда расширения еще не перехватывали процедуры, надо будет попробовать, тут уже на Ваш вкус, как говориться))
4. Margo462 263 08.01.18 09:46 Сейчас в теме
(1) я не помню просто в 8.3.9 проблема была с общими модулями, поэтому если сделаю в расширении, то добавлю сюда
13. u_n_k_n_o_w_n 45 08.01.18 10:40 Сейчас в теме
(1),
Как только данные расширения "глючить" перестанут и будут поддерживать полный функционал изменения типовой конфигурации, тогда будет можно говорить, как про инструмент изменения типовых конфигураций.
А так можно все менять непосредственно в конфигурации, при этом спокойно обновляя на последующие релизы.

Расширения больше нужны для Freshа.
rpgshnik; +1 Ответить
2. tahir.akchurin 08.01.18 06:24 Сейчас в теме
Отличное решение, когда необходимо видеть дату создания именно в списке документов.
В других случаях можно настроить Версионирование объектов
igo1; rpgshnik; u_n_k_n_o_w_n; +3 Ответить
5. Alex_E 2193 08.01.18 09:46 Сейчас в теме
Сказать, что это удивительно
Правда этот общий модуль придется снять с поддержки;
- ничего не сказать...

Добавить нужный модуль в расширение, создать там процедуру

&После("ПриСозданииНаСервере")
Процедура _ПриСозданииНаСервереФорма, ПараметрыРазмещения = Неопределено) Экспорт 


и все дела... А то как - то смысл заголовка "не снимая документы с поддержки" смазывается...
vovan_victory; rpgshnik; u_n_k_n_o_w_n; +3 Ответить
6. Margo462 263 08.01.18 09:50 Сейчас в теме
(5) этот вариант точно работает, можете попробовать в расширении перехватить
7. Margo462 263 08.01.18 09:53 Сейчас в теме
(5) там же не написано не снимая конфы с поддержки, там только про документы, так что не придирайтесь)
u_n_k_n_o_w_n; +1 Ответить
8. Alex_E 2193 08.01.18 09:56 Сейчас в теме
(7) Да я и не придираюсь, просто удивляюсь, что сказав "А" Вы говорите что "Б" не бывает))))

ЗЫ а в (6) это что? вопрос, пожелание, утверждение?

ЗЫЫ вообще-то я Вам помочь хотел - вернуться на поддержку полностью (в чём, собственно, ИМХО, суть расширений). А то как у Ширвинта - "тут играем, тут пропускаем, тут мы рыбу заворачивали")))))
9. Margo462 263 08.01.18 10:02 Сейчас в теме
(8) ахах))))) полностью не вернемся на поддержку там общий реквизит надо вставлять, расширение позже будет)
10. Alex_E 2193 08.01.18 10:08 Сейчас в теме
(9) Дополнительное сведение спасёт отца русской демократии ситуацию не дожидаясь выхода релиза в режиме совместимости с 8.3.11...понимаю, что с ДС работать чуть сложнее, чем с добавленным реквизитом (кстати, что есть общий реквизит просветите пожалуйста, как создаётся, с чем едят?), но снятия с поддержки тут ни разу не нужно...
11. Margo462 263 08.01.18 10:17 Сейчас в теме
(10) согласна, придется заморочиться с ДС, у меня конфа давно снята с поддержки, поэтому общий реквизит не мешает) в отличие от ДС общий реквизит можно создать один раз и указать в каких объектах будет участвовать, удобно и быстро)
12. Alex_E 2193 08.01.18 10:38 Сейчас в теме
(11) ДС тоже разные бывают, общие в том числе...
u_n_k_n_o_w_n; +1 Ответить
14. Margo462 263 08.01.18 10:41 Сейчас в теме
15. q_i 424 08.01.18 15:28 Сейчас в теме
s/снять с поддержки/разрешить редактирование с сохранением поддержки/ ;)
rpgshnik; +1 Ответить
16. BigBoss 2 09.01.18 09:54 Сейчас в теме
Очень интересное решение!!!
17. sasha777666 310 10.01.18 10:46 Сейчас в теме
Функция ДатаСозданияСсылки(Ссылка)
    ГУИД = Ссылка.УникальныйИдентификатор();
    Строка16 = Сред(ГУИД, 16, 3) + Сред(ГУИД, 10, 4) + Сред(ГУИД, 1, 8);
    Разрядность = СтрДлина(Строка16);
    ЧислоСек = 0;
    Для Позиция = 1 По Разрядность Цикл
        ЧислоСек = ЧислоСек + Найти("123456789abcdef",Сред(Строка16,Позиция,1))*Pow(16,Разрядность - Позиция);
    КонецЦикла;
    ЧислоСек = ЧислоСек / 10000000;
    Возврат Дата(1582, 10, 15, 04, 00, 00) + ЧислоСек;
КонецФункции
Показать
klinval; almierm; корум; itriot11; the1; Korolev; 02RUSlan; primat; DarkAn; Margo462; +10 1 Ответить
18. primat 2577 10.01.18 14:43 Сейчас в теме
Пока смотрел публикацию, думал о том, что ведь правда в ссылке хранится дата создания объекта. В (17) привели пример. Считаю, решение более корректно и повлиять никто не сможет на эту дату. Недостаток только в том, что в форму списка это не получится вывести.
19. Margo462 263 10.01.18 14:59 Сейчас в теме
(18) это да, с формой списка заморочка)
20. palsergeich 10.01.18 15:13 Сейчас в теме
(17) (18) Вы же понимаете, что дата создания документа в конкрентой базе и дата из GUID могут быть различные (такое возможно например при обмене при синхронизации по guid)
AZel84; Irwin; корум; +3 Ответить
21. unichkin 1351 22.04.18 18:01 Сейчас в теме
Только идентификаторы не стоит начинать с нижнего подчеркивания... https://its.1c.ru/db/v8std#content:2149184103:hdoc, п.3
Оставьте свое сообщение

См. также

FormCodeGenerator Программная доработка форм. Часть 2 (Режим работы "Режим сравнения форм") на примере ERP 2.5 Промо

Практика программирования Адаптация типовых решений Прочие инструменты разработчика v8 1cv8.cf Абонемент ($m)

Данная публикация является продолжением описания функционирования обработки "FormCodeGenerator " в режиме сравнения форм и генерирования кода на основании сравнения. Подходит для перевода уже доработанных форм с интерактивной доработки на программную. Данный режим работы обработки снизит издержки при дальнейших обновлениях конфигураций.

5 стартмани

21.12.2020    4663    19    huxuxuya    11    

Интерактивная справка по объектам 1С (подключаемое расширение)

Практика программирования Работа с интерфейсом v8 ERP2 Абонемент ($m)

База знаний, подключаемая к объектам основной базы. Пополняется интерактивно, формируется в виде статей прямо в 1С (текст, картинки, таблицы, ссылки). Есть возможность прикрепления файлов, привязки к объектам 1С, возможности рейтинга и комментирования пользователями.

3 стартмани

29.09.2020    10541    64    sapervodichka    43    

Конвейер проверки качества кода

Инструментарий разработчика Практика программирования Математика и алгоритмы v8 1cv8.cf Абонемент ($m)

Jenkinsfile для выполнения проверки качества кода. Собирает информацию с АПК, EDT и BSL-LS. Сопоставляет ошибки с гит-репозиторием, выгруженным ГитКонвертором. Отправляет в Сонар.

3 стартмани

04.09.2019    30799    27    Stepa86    46    

Алгоритмы поиска пути в графе

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

Реализуем алгоритмы поиска пути в графе на платформе 1С 8.3, такие как алгоритм А*, поиск в ширину, жадный поиск, алгоритм Дейкстры и вконце волновой.

1 стартмани

09.07.2019    20479    12    RonX01    10    

Вам нравятся запросы в 1С? Промо

Практика программирования Разработка v8 v8::Запросы 1cv8.cf Абонемент ($m)

Речь не только о том, что простейший запрос с "легальным" оформлением растянется на пол-экрана, речь еще обо всем, что нужно написать "в нагрузку" к тексту запроса. Все эти "Новый Запрос", "УстановитьПараметр" и последующие пляски с обработкой результата... Пора с этим заканчивать!

1 стартмани

03.07.2019    24213    6    m-rv    90    

Работа с публикациями "Инфостарт"

Практика программирования О сообществе WEB v8 УУ Абонемент ($m)

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    24949    13    RocKeR_13    16    

HTTP Сервисы: Путь к своему сервису. Часть 3

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Продолжение статьи «HTTP Сервисы: Путь к своему сервису. Часть 2». В предыдущих частях мы использовали только Get, в этой части поговорим о других методах и длительных операциях.

1 стартмани

27.08.2018    45742    64    dsdred    17    

Позиционирование в помещении с помощью нейросети по сигналу Wi-Fi. Интерактивная карта склада в 1С с показом позиции

Инструментарий разработчика Практика программирования v8 Абонемент ($m)

Данная публикация содержит в себе редактор и интерактивную карту склада или иного помещения, на которой в реальном времени отображается позиция устройства, координаты которого вычисляются по уровням сигнала нескольких роутеров Wi-Fi. В статье и приложенным к ней разработкам предлагаются инструменты и методика для реализации вычисления точной геопозиции внутри помещений с помощью нейронной сети. Конфигурация написана на релизе 1С:Предприятие 8.3.12.1412, клиентское приложение имеет минимальный уровень совместимости SDK -16.

5 стартмани

09.08.2018    32012    28    informa1555    26    

ВСТАВИТЬ В Справочник.Номенклатура (Код, Наименование) ЗНАЧЕНИЯ ("001", "Новый товар") Промо

Практика программирования v8 v8::Запросы 1cv8.cf Абонемент ($m)

Вас не обманывают ваши глаза, это запрос на изменение данных! И это работает без прямого доступа к БД, регистрации и смс.

1 стартмани

01.06.2018    33432    88    m-rv    58    

Работа с данными выбора

Практика программирования Работа с интерфейсом v8 Россия Абонемент ($m)

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений - уже задать без программирования не получится.

1 стартмани

17.07.2018    57797    22    kalyaka    16    

Полезные примеры составления схемы компоновки данных #2

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Еще один набор примеров как решить частные задачи в СКД

1 стартмани

22.05.2018    35931    11    SITR-utyos    13    

Печатная форма, сделанная как расширение конфигурации для БП 3.0. Новые возможности БСП

Практика программирования Универсальные печатные формы v8 БП3.0 Абонемент ($m)

Печатные формы на внешних обработках скоро канут в лету. На смену им приходят ПФ, реализованные в виде расширений конфигурации. Не нашел на сайте примеров таких расширений. Привожу пример подобного расширения для БП 3.0.

1 стартмани

06.12.2017    29875    56    kwazi    6    

Заполняем по шаблону (по умолчанию) Промо

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Простой в подключении, универсальный и достаточно удобный механизм заполнения реквизитов произвольных документов/справочников значениями по умолчанию. Реализован в расширении, но может быть и непосредственно включен практически в любую конфигурацию на управляемых формах простым копированием одной формы и двух команд. Весь код в статье.

1 стартмани

08.02.2018    31429    20    mvxyz    17    

Паузы при исполнении кода (Sleep для 1С)

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Решил проверить все найденные варианты паузы для 1С. В результате получилась обработка для тестирования и небольшая статья с итогом.

1 стартмани

28.11.2017    57510    15    swimdog    46    

Макет в СКД - пример всех возможных типовых вариантов

Практика программирования Инструментарий разработчика v8 v8::СКД 1cv8.cf Абонемент ($m)

Макет СКД: наглядное представление того, что, как и куда выводится при типовых настройках.

1 стартмани

09.11.2017    24659    77    freelancer    4    

Telegram-боты

Практика программирования v8 Абонемент ($m)

Описание теории, разбор архитектуры и пример реализации telegram-ботов. Сразу скажу, со структурированием изложения мало что могу поделать. :) редакция от 18.07.2018 Правки последней редакции выделены жирным.

1 стартмани

01.09.2017    37907    141    PLAstic    66    

Нечеткий поиск одним запросом Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

Использование механизма полнотекстового поиска в 1С не всегда оправдано, т.к. построение индекса и поддержание его в актуальном состоянии может значительно нагружать систему. Предлагаемая реализация нечеткого поиска методом N-грамм выполняется одним запросом, что позволяет производить поиск в любой таблице и не требует предварительного построения индекса.

1 стартмани

28.12.2015    31060    72    vasvl123    9    

Умный дом на 1С + ардуино

Практика программирования v8 Абонемент ($m)

Конфигурация для автоматизации быта программиста 1C и не только. В данной статье будет рассказано, как можно использовать 1С для задач, не входящих в стандартные рамки этой платформы. Например, управление домом. В качестве периферии для подключения будет использован микроконтроллер (МК) Ардуино, но на нём не будет никакой логической нагрузки, весь процесс будет проходить на сервере 1С. Работа с пинами ввода/вывода происходит напрямую из 1С.

1 стартмани

07.08.2017    25678    21    sasha777666    64    

Расширения конфигураций 1С: учимся перехватывать методы

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

В этой статье я на примерах разберу некоторые механизмы расширений конфигураций 1С. А именно «перехваты» методов модуля объекта и «перехваты» событий формы и элементов формы. Данная статья написана с учебными целями, чтобы показать, как при помощи расширений конфигурации можно делать такие доработки, ради которых раньше приходилось снимать конфигурацию с поддержки.

1 стартмани

30.05.2017    149872    13    signum2009    48    

Регулярные выражения – это просто. Построитель и отладчик регулярных выражений

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Предлагается к использованию построитель регулярных выражений. Выполненный в виде внешней обработки, он позволит строить сложно-структурированные выражения на основе параметрического описания, тестировать их, и в результате получить программный код 1С.

1 стартмани

13.03.2017    35222    119    romasna    49    

1С: Предприятие + корпоративный чат, как наладить оперативные уведомления за 10 минут Промо

Практика программирования v8 Абонемент ($m)

Как сделать автоматические уведомления о разных событиях из 1С в корпоративный чат MyChat для сотрудников компании

1 стартмани

14.08.2016    51506    36    Demanoidos    60    

Распознавание текста с помощью нейросетей Google Cloud Vision и 1С

Практика программирования v8 1cv8.cf Абонемент ($m)

Возможности Google Cloud Vision в распознавании текста.

1 стартмани

08.02.2017    34035    139    kiv1c    18    

Графическая схема. Управление при помощи XDTO.

Практика программирования v8 Абонемент ($m)

В статье описывается методика программного управления элементами графической схемы при помощи механизма XDTO. Приложена готовая к использованию библиотека функций для создания и удаления графических объектов, а также для связи элементов схемы соединительными линиями.

2 стартмани

16.01.2017    26036    115    Alxby    23    

Простой редактор плана помещения JavaScript

Практика программирования Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

На ресурсе сейчас очень много решений, которые позволяют редактировать карты, используя географические схемы. Так же много решений, которые позволяют редактировать объекты онлайн веб-карт. Мне же нужно было простое решение, для того чтобы расставить квадратные объекты на плане, показать их пользователю. Ну и распечатать, опять же. Я решил написать простенький редактор на JavaScript с использованием библиотеки Raphael.

1 стартмани

23.11.2016    24066    99    igel9780    22    

Быстрое определение интервалов в запросе Промо

Практика программирования v8 Абонемент ($m)

В статье описывается новый метод определения интервалов между данными различных записей в запросе. В отличие от общеизвестного метода, время работы предлагаемого метода зависит от объема данных ЛИНЕЙНО. Это обеспечивает ему значительный выигрыш по быстродействию на больших объемах данных. В качестве иллюстрации возможностей метода приведен отчет, показывающий гистограмму распределения времени между продажами.

1 стартмани

01.10.2015    56360    35    ildarovich    41    

Работа с двоичными данными на примере чтения файлов изображений. Новые возможности 8.3.9

Практика программирования WEB v8 1cv8.cf Россия Абонемент ($m)

В статье приводятся новые функции по работе с двоичными данными, появившимися в версии платформы 8.3.9 , на примере анализа формата и размера изображений. А также пример отправки изображения через API ВКонтакте с помощью новых объектов (без использования ОбъединитьФайлы())

1 стартмани

14.11.2016    30717    17    Anton64    23    

Загрузка файлов на сервер с прогрессом и докачкой

Практика программирования v8 1cv8.cf Россия Абонемент ($m)

Пример использования новых возможностей платформы 8.3.9 по низкоуровневой работе с двоичными данными для инкрементальной передачи файлов на сервер.

1 стартмани

04.10.2016    15447    54    mrstomak    21    

Несколько шаблонов для доработки типовых конфигураций

Практика программирования Инструментарий разработчика v8 v8::УФ Абонемент ($m)

Предлагаю несколько каркасов для создания новых объектов в типовых конфигурациях. Это выжимка из кода нескольких конфигураций, которая позволит быстро и красиво создавать и дорабатывать объекты метаданных с соблюдением идеологии исходной системы

1 стартмани

03.10.2016    39648    96    json    25    

HTTP-сервис: отчеты [Расширение]

Практика программирования Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Это HTTP-сервис, который возвращает почти любой отчет в HTML, XLSX или в JSON. Сохраните вариант отчета, получите на него ссылку и можно получить данные без захода в 1С. Работает в конфигурациях на основе БСП 2.3.3+, для отчетов на СКД и в 1С 8.3.8+

2 стартмани

30.08.2016    30259    144    Stepa86    15    

Недокументированное использование стандартных форм Upd.

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Вам не хватает возможностей в платформе 1С или у Вас нет времени на углубленное изучение платформы 1С? Рассмотрены возможности использования стандартных форм, вызываемых из платформы.

1 стартмани

26.07.2016    31390    93    ZhokhovM    65    

Хранение файлов в томах на диске (для УПП 1.3)

Практика программирования v8 УПП1 Абонемент ($m)

Доработка типовой УПП 1.3 в плане хранения присоединенных файлов вне базы данных

2 стартмани

05.06.2016    62665    11    wowik    32    

БСП 2.3 и БСП 3.0: Просто про выполнение внешней обработки в фоне (c индикацией прогресса выполнения)

Инструментарий разработчика Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Простое пояснение о том, как сделать внешнюю обработку с фоновым выполнением и индикацией процесса для любой конфигурации на основе БСП 2.3.2. UPDATE 20/09/19: добавлен вариант обработки с индикацией процента выполнения и статусом выполнения для БСП 3.0.

1 стартмани

18.05.2016    68353    201    rozer    67    

Остатки на каждый день в запросе

Практика программирования Учет ТМЦ Учет ТМЦ v8 1cv8.cf УУ Абонемент ($m)

Запрос формирует остатки товаров на каждый день в пределах выбранного периода.

1 стартмани

26.04.2016    68168    19    arakelyan    23    

Еще один способ расчета остатков на каждый день в запросе

Математика и алгоритмы Практика программирования v8 Абонемент ($m)

Предлагается новый способ расчета остатков на каждый день (час, минуту, секунду) в запросе. Способ не требует предварительного формирования таблицы дат и также подходит для расчета курсов валют, цен номенклатуры и других периодических сведений на каждую дату периода. На больших объемах данных предлагаемый способ может превосходить по быстродействию ранее известные методы из-за линейной (в лучшем случае) зависимости трудоемкости от длины периода.

1 стартмани

24.04.2016    37840    51    ildarovich    23    

Вывод печатных форм с запросом данных в форму "Печать документов" из подсистемы БСП "Печать".

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Все не раз видели, как в типовых конфигурациях, построенных на основе БСП (Библиотека стандартных подсистем), печатные формы, построенные на основе Табличного документа, выводятся в специальную форму "ПечатьДокументов". Эта форма входит в состав подсистемы "Печать" из БСП. При разработке своих печатных форм, иногда необходимо запросить у пользователя дополнительные данные необходимые для печати. Тут встает вопрос, как в этом случае вывести печатную форму в форму "Печать документа". В этой статье я рассмотрю, как реализовать вывод печатной формы в упомянутую форму из подсистемы "Печать", в случае если мы хотим перед выводом печатной формы запросить у пользователя дополнительные данные. Здесь будут рассмотрены два случая: когда реализуется печатная форма с использованием подсистемы "Дополнительные отчеты и обработки" и когда печатная форма добавляется в конфигурацию в режиме конфигуратора, т.е. вносятся изменения в типовую конфигурацию.

1 стартмани

29.03.2016    102563    199    lopatin    14    

Выполнение JavaScript кода из 1С в объекте Поле HTML Документа (HTML 5) и вызов события в 1С ПриНажатии

Практика программирования v8 1cv8.cf Россия Абонемент ($m)

Пример выполнения JS кода из 1С в Поле HTML Документа под управляемыми формами, с удобным получением результата в 1С(С помощью вызова привязанного события ПриНажатии к элементу ПолеHTMLДокумента)

1 стартмани

22.03.2016    88746    165    igo1    54    

Количество дней недели (понедельников/вторников/...) в заданном диапазоне одним запросом

Практика программирования v8 Абонемент ($m)

При реализации периодического авто-заполнения маршрутных листов по графику (недельному) необходимо было просчитать стоимость всего периода, с условием выездов только по определенным дням. Заморачиваться с обходом результата не хотелось. Пришлось написать "Небольшой" запрос.

1 стартмани

03.03.2016    20711    1    Alexander.Shvets    5    

Простые радости жизни программиста 1С: выбор типа значения

Работа с интерфейсом Практика программирования v8 1cv8.cf Абонемент ($m)

Предлагаемая в работе обработка включает обычную и управляемую формы, которые максимально точно реализуют функциональность системного диалога выбора типа в толстом клиенте обычное приложение (включая оформление диалога). Эти формы имеют дополнительные интерфейсные удобства и могут быть использованы в качестве альтернативных диалогов выбора типа.

1 стартмани

17.02.2016    54738    55    yuraos    18    

Отображение прогресса выполнения длительных операций в БСП и их отладка в текущем сеансе.

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

В статье описан способ исполнения длительных операций в конфигурациях, в которых используется библиотека стандартных подсистем, с визуализацией прогресса исполнения и отображения хода обработки данных. Также дается краткое описание процесса отладки длительных операций в текущем сеансе.

1 стартмани

17.02.2016    62437    204    balanton    23    

Яндекс.Деньги "Благотворительность"

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Яндекс.Деньги теперь в 1С. Форма для приема благотворительных взносов. Форму легко сделать и вставить на любую страницу сайта или блога. Платежи будут приходить на ваш кошелек. На форме есть три способа платежа: из кошелька, с банковской карты, с баланса мобильного.

1 стартмани

16.02.2016    25756    8    Tatitutu    5    

Мастер рассылки e-mail 2.2 для управляемых форм

Практика программирования Email v8 v8::УФ ERP2 БП3.0 УТ11 Абонемент ($m)

Для пользователей: переделанный из старый разработки под 8.2 с использованием библиотеки Мастер рассылки e-mail 2.2 (ERP, УТ, БП) (Только управляемые формы), который теперь может запускаться под любой версией платформы с разрешенными или запрещенными модальными/синхронными вызовами в конфигурации. Также удобный выбор e-mail и их владельцев с помощью отбора динамического списка по любым критериям и галочки исключения.

1 стартмани

29.12.2015    43166    20    milkers    4