Дата создания во всех документах, не снимая документы с поддержки

Публикация № 724129

Разработка - Практика программирования

общий реквизит дата создания документа

17
Дата создания во всех документах, при этом документы остаются на поддержке

Здравствуйте! Я расскажу на примере конфигурации Бухгалтерия предприятия 3.0 как я добавила реквизит "Дата создания" во все документы не снимая документы с поддержки. Предлагаю два варианта решения:

Первый вариант:


1. Создать общий реквизит "_ДатаСоздания", указать состав документов, которые будут содержать данный реквизит;

2. Найти процедуру, в которую обращаются все документы при создании, у меня это процедура "ПриСозданииНаСервере" в общем модуле "ПодключаемыеКоманды" и написать там одну строчку: 

Процедура ПриСозданииНаСервере(Форма, ПараметрыРазмещения = Неопределено) Экспорт

_Общий.ПриСозданииФормыНаСервере(Форма);

//*Дальше стандартный код, я не буду его здесь показывать

КонецПроцедуры

 

3. И последнее:) Создать общий модуль под названием "_Общий" или использовать существующий, в котором будут лежать нужные процедуры для прорисовки реквизита "Дата создания" на форме документа и на форме списка. Процедуры модуля:

Процедура ПриСозданииФормыНаСервере(Форма) Экспорт
	 
	 МДФормы	  = Метаданные.НайтиПоПолномуИмени(Форма.ИмяФормы);
	 МДОбъекта = МДФормы.Родитель();
	 
	 Если Метаданные.Документы.Содержит(МДОбъекта) Тогда
		 // это какая то из форм документа
		 Если Метаданные.ОбщиеРеквизиты._ДатаСоздания.Состав.Найти(МДОбъекта).Использование = Метаданные.СвойстваОбъектов.ИспользованиеОбщегоРеквизита.Использовать Тогда
			 //общий реквизит _ДатаСоздания есть
			 Если МДФормы = МДОбъекта.ОсновнаяФормаДляВыбора Тогда
				 //ничего не делаем
			 ИначеЕсли МДФормы = МДОбъекта.ОсновнаяФормаСписка Тогда
				 // это основная форма списка
				 Реквизиты = Форма.ПолучитьРеквизиты();
				 //МДОбъекта.Движения.Содержит(Метаданные.РегистрыБухгалтерии.Хозрасчетный)
				 
				 Для каждого Рекв из Реквизиты цикл
					 Если Рекв.ТипЗначения.СодержитТип(Тип("ДинамическийСписок")) Тогда
						 Список = Форма[Рекв.Имя];
						 
						 Если Список.ОсновнаяТаблица = МДОбъекта.ПолноеИмя() Тогда
							 // Это динамический список с нужными документами
							 ДобавитьДопПоляВДинСписок(Форма, Рекв.Имя);
						 КонецЕсли;
					 КонецЕсли;
				 КонецЦикла;
			 ИначеЕсли НЕ (Форма.Элементы.Найти("Дата") = Неопределено ИЛИ Форма.Элементы.Найти("Номер") = Неопределено) Тогда
				 //это форма документа
				 Если Форма.Параметры.Ключ.Пустая() Тогда
					 //новый документ - заполним дату создания
					 Форма.Объект._ДатаСоздания = ТекущаяДата();
				 КонецЕсли;
				 
				 ОтобразитьДатуСозданияНаФорме(Форма);
			 КонецЕсли;
		 КонецЕсли;
		 
	 ИначеЕсли Метаданные.ЖурналыДокументов.Содержит(МДОбъекта) Тогда
		 //журнал документов - добавим поле
		 ПолеФормы_ДатаСоздания = Форма.Элементы.Добавить("_ДатаСоздания", Тип("ПолеФормы"),Форма.Элементы.Список);	
		 ПолеФормы_ДатаСоздания.Вид		   = ВидПоляФормы.ПолеВвода;
		 ПолеФормы_ДатаСоздания.ПутьКДанным = "Список.Ссылка._ДатаСоздания";
		 ПолеФормы_ДатаСоздания.Заголовок   = "Создан";
		 
	 КонецЕсли;
	 
 КонецПроцедуры
 

Процедура ОтобразитьДатуСозданияНаФорме(Форма)
	 
	 мЭлементы = Форма.Элементы;
	 ЭУ = мЭлементы.Найти("_ДатаСоздания"); 
	 Если ЭУ = Неопределено Тогда
		 ГруппаДатаСоздания = мЭлементы.Найти("_ГруппаДатаСоздания");
		 Если НЕ ГруппаДатаСоздания = Неопределено Тогда
			 ЭУ = мЭлементы.Добавить("_ДатаСоздания", Тип("ПолеФормы"), ГруппаДатаСоздания);
		 Иначе
			 ЭлементОрганизация = мЭлементы.Найти("Организация");
			 Если ЭлементОрганизация = Неопределено Тогда
				 //пока просто добавим поле
				 ЭУ = мЭлементы.Добавить("_ДатаСоздания", Тип("ПолеФормы"));
			 Иначе
				 //создадим группу _ДатаСоздания и поместим туда
				 Если ТипЗнч(ЭлементОрганизация.Родитель) = Тип("ГруппаФормы") Тогда
					 ГруппаДатаСоздания = мЭлементы.Добавить("_ГруппаДатаСоздания", Тип("ГруппаФормы"), ЭлементОрганизация.Родитель);
				 Иначе
					 ГруппаДатаСоздания = мЭлементы.Добавить("_ГруппаДатаСоздания", Тип("ГруппаФормы"));
				 КонецЕсли;
				 
				 ГруппаДатаСоздания.Вид				   = ВидГруппыФормы.ОбычнаяГруппа;
				 ГруппаДатаСоздания.Группировка		   = ГруппировкаПодчиненныхЭлементовФормы.Горизонтальная;
				 ГруппаДатаСоздания.Отображение		   = ОтображениеОбычнойГруппы.Нет;	
				 ГруппаДатаСоздания.ОтображатьЗаголовок = Ложь;	
				 
				 //перемещаем группу перед организацией
				 мЭлементы.Переместить(ГруппаДатаСоздания, ГруппаДатаСоздания.Родитель, ЭлементОрганизация);
				 
				 //меняем группу у организации
				 мЭлементы.Переместить(ЭлементОрганизация, ГруппаДатаСоздания);
				 
				 //добавляем в созданную группу дату создания
				 ЭУ = мЭлементы.Добавить("_ДатаСоздания", Тип("ПолеФормы"), ГруппаДатаСоздания);
			 КонецЕсли;
		 КонецЕсли;
	 КонецЕсли;
	 
	 ЭУ.Вид						= ВидПоляФормы.ПолеВвода;
	 ЭУ.ПутьКДанным				= "Объект._ДатаСоздания";
	 ЭУ.Ширина					= 12;
	 ЭУ.РастягиватьПоГоризонтали = Ложь;
	 ЭУ.Заголовок				= "Создан";
	 ЭУ.ПоложениеЗаголовка		= ПоложениеЗаголовкаЭлементаФормы.Лево;
	 ЭУ.Доступность				= Ложь;
	 
	 Если НЕ Форма.Параметры.Ключ.Пустая() Тогда
		 //существующий документ
		 Если Форма.Объект._ДатаСоздания <> '00010101' Тогда
			 //дата создания заполнена
			 РазностьВСекундах = НачалоДня(Форма.Объект._ДатаСоздания) - НачалоДня(Форма.Объект.Дата);
			 Если РазностьВСекундах / 86400 > 15 Тогда
				 //совсем задним число ввели - обведем рамку
				 ЭУ.ЦветРамки = WebЦвета.КрасноФиолетовый;
			 КонецЕсли;
		 КонецЕсли;
	 КонецЕсли;
	 
 КонецПроцедуры //ОтобразитьДатуСозданияНаФорме()
 
Процедура ДобавитьДопПоляВДинСписок(Форма, ИмяРеквизита)
	 
	 Список	   = Форма[ИмяРеквизита];
	 ИмяТаблицы = Список.ОсновнаяТаблица;
	 
	 Если Список.ПроизвольныйЗапрос Тогда
		 
		 Схема = Новый СхемаЗапроса();
		 Схема.УстановитьТекстЗапроса(Список.ТекстЗапроса);
		 
		 // Теперь нужно добавить дату создания
		 Если Схема.ПакетЗапросов.Количество() > 1 Тогда
			 //внутренние таблицы в дин.списках только с 8.3.8 и пока нигде не используются
			 ЗаписьЖурналаРегистрации("Отладка", УровеньЖурналаРегистрации.Примечание, Метаданные.НайтиПоПолномуИмени(Форма.ИмяФормы), ,
			 "Не могу добавить доп.поля, т. к. в пакете больше одного запроса.
			 |" + Форма.ИмяФормы + ", " + ИмяРеквизита);
			 Возврат;
		 КонецЕсли;
		 
		 ЗапросПакета = Схема.ПакетЗапросов[0];
		 
		 Если ЗапросПакета.Операторы.Количество() > 1 тогда
			 ЗаписьЖурналаРегистрации("Отладка", УровеньЖурналаРегистрации.Примечание, Метаданные.НайтиПоПолномуИмени(Форма.ИмяФормы), ,
			 "Не могу добавить доп.поля, т. к. в запросе больше одного оператора.
			 |" + Форма.ИмяФормы + ", " + ИмяРеквизита);
			 Возврат;
		 КонецЕсли;
		 
		 ИндексОператора = 0;
		 Оператор  = ЗапросПакета.Операторы[ИндексОператора];
		 Источник1 = Оператор.Источники[0];
		 Если ТипЗнч(Источник1.Источник) <> Тип("ТаблицаСхемыЗапроса") или Источник1.Источник.ИмяТаблицы <> ИмяТаблицы тогда
			 ЗаписьЖурналаРегистрации("Отладка", УровеньЖурналаРегистрации.Примечание, Метаданные.НайтиПоПолномуИмени(Форма.ИмяФормы), ,
			 "Не могу добавить доп.поля, т. к. первый источник — не основная таблица.
			 |" + Форма.ИмяФормы + ", " + ИмяРеквизита);
			 Возврат;
		 КонецЕсли;
		 
		 Выражение = Оператор.ВыбираемыеПоля.Добавить(Источник1.Источник.Псевдоним + "._ДатаСоздания");
		 
		 Колонка = ЗапросПакета.Колонки[ЗапросПакета.Колонки.Количество()-1];
		 Колонка.Поля.Установить(ИндексОператора, Выражение);
		 Колонка.Псевдоним = "Создан";

 
		 ПсевдонимДока = Источник1.Источник.Псевдоним;
		 Список.ТекстЗапроса = СтрЗаменить(Список.ТекстЗапроса, ""+ПсевдонимДока+".ПометкаУдаления КАК ПометкаУдаления,", ""+ПсевдонимДока+".ПометкаУдаления,"); //Схема.ПолучитьТекстЗапроса();
		 Список.ТекстЗапроса = СтрЗаменить(Список.ТекстЗапроса, ""+ПсевдонимДока+".ПометкаУдаления,", ""+ПсевдонимДока+".ПометкаУдаления," + Символы.ПС + ПсевдонимДока +"._ДатаСоздания КАК Создан, "); //Схема.ПолучитьТекстЗапроса();
	 
		 Элт = Форма.Элементы.Добавить("Создан", Тип("ПолеФормы"), Форма.Элементы[ИмяРеквизита]);
		 Элт.Вид			= ВидПоляФормы.ПолеВвода;
		 Элт.Заголовок	= "Создан";
		 Элт.ПутьКДанным = ИмяРеквизита + ".Создан";
		 Элт.Видимость	= Истина;
		 
	 КонецЕсли;
	 
 КонецПроцедуры //ДобавитьДопПоляВДинСписок()

Второй вариант:


1. Создать общий реквизит "_ДатаСоздания", указать состав документов, которые будут содержать данный реквизит;

2. Установить расширение,  я его тестировала на релизе 3.0.57.10, в принципе будет работать и на прошлых релизах, но придется решить некоторые несоответствия совместимости расширения и конфигурации,  т.к. с выходом нового релиза приходится постоянно менять совместимость в расширении... С расширением не придется создавать и снимать общие модули с поддержки), также расширение необходимо снять с безопасного режима.

17

Скачать файлы

Наименование Файл Версия Размер
Расширение по дате создания:
.cfe 8,75Kb
09.01.18
1
.cfe 8,75Kb 1 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. script 206 08.01.18 03:58 Сейчас в теме
Вы хотя бы написали бы причину, почему это нельзя сделать через расширения.
motorsoft; Silenser; alexveraww; +3 Ответить
3. Margo462 192 08.01.18 09:43 Сейчас в теме
(1) можно попробовать в расширении добавить общий модуль и там процедуры те написать, и перехватить модуль подключаемых команд, я делала это давно когда расширения еще не перехватывали процедуры, надо будет попробовать, тут уже на Ваш вкус, как говориться))
4. Margo462 192 08.01.18 09:46 Сейчас в теме
(1) я не помню просто в 8.3.9 проблема была с общими модулями, поэтому если сделаю в расширении, то добавлю сюда
13. u_n_k_n_o_w_n 37 08.01.18 10:40 Сейчас в теме
(1),
Как только данные расширения "глючить" перестанут и будут поддерживать полный функционал изменения типовой конфигурации, тогда будет можно говорить, как про инструмент изменения типовых конфигураций.
А так можно все менять непосредственно в конфигурации, при этом спокойно обновляя на последующие релизы.

Расширения больше нужны для Freshа.
rpgshnik; +1 Ответить
2. tahir.akchurin 08.01.18 06:24 Сейчас в теме
Отличное решение, когда необходимо видеть дату создания именно в списке документов.
В других случаях можно настроить Версионирование объектов
igo1; rpgshnik; u_n_k_n_o_w_n; +3 Ответить
5. Alex_E 2054 08.01.18 09:46 Сейчас в теме
Сказать, что это удивительно
Правда этот общий модуль придется снять с поддержки;
- ничего не сказать...

Добавить нужный модуль в расширение, создать там процедуру

&После("ПриСозданииНаСервере")
Процедура _ПриСозданииНаСервереФорма, ПараметрыРазмещения = Неопределено) Экспорт 


и все дела... А то как - то смысл заголовка "не снимая документы с поддержки" смазывается...
vovan_victory; rpgshnik; u_n_k_n_o_w_n; +3 Ответить
6. Margo462 192 08.01.18 09:50 Сейчас в теме
(5) этот вариант точно работает, можете попробовать в расширении перехватить
7. Margo462 192 08.01.18 09:53 Сейчас в теме
(5) там же не написано не снимая конфы с поддержки, там только про документы, так что не придирайтесь)
u_n_k_n_o_w_n; +1 Ответить
8. Alex_E 2054 08.01.18 09:56 Сейчас в теме
(7) Да я и не придираюсь, просто удивляюсь, что сказав "А" Вы говорите что "Б" не бывает))))

ЗЫ а в (6) это что? вопрос, пожелание, утверждение?

ЗЫЫ вообще-то я Вам помочь хотел - вернуться на поддержку полностью (в чём, собственно, ИМХО, суть расширений). А то как у Ширвинта - "тут играем, тут пропускаем, тут мы рыбу заворачивали")))))
9. Margo462 192 08.01.18 10:02 Сейчас в теме
(8) ахах))))) полностью не вернемся на поддержку там общий реквизит надо вставлять, расширение позже будет)
10. Alex_E 2054 08.01.18 10:08 Сейчас в теме
(9) Дополнительное сведение спасёт отца русской демократии ситуацию не дожидаясь выхода релиза в режиме совместимости с 8.3.11...понимаю, что с ДС работать чуть сложнее, чем с добавленным реквизитом (кстати, что есть общий реквизит просветите пожалуйста, как создаётся, с чем едят?), но снятия с поддержки тут ни разу не нужно...
11. Margo462 192 08.01.18 10:17 Сейчас в теме
(10) согласна, придется заморочиться с ДС, у меня конфа давно снята с поддержки, поэтому общий реквизит не мешает) в отличие от ДС общий реквизит можно создать один раз и указать в каких объектах будет участвовать, удобно и быстро)
12. Alex_E 2054 08.01.18 10:38 Сейчас в теме
(11) ДС тоже разные бывают, общие в том числе...
u_n_k_n_o_w_n; +1 Ответить
14. Margo462 192 08.01.18 10:41 Сейчас в теме
15. q_i 381 08.01.18 15:28 Сейчас в теме
s/снять с поддержки/разрешить редактирование с сохранением поддержки/ ;)
rpgshnik; +1 Ответить
16. BigBoss 3 09.01.18 09:54 Сейчас в теме
Очень интересное решение!!!
17. sasha777666 294 10.01.18 10:46 Сейчас в теме
Функция ДатаСозданияСсылки(Ссылка)
    ГУИД = Ссылка.УникальныйИдентификатор();
    Строка16 = Сред(ГУИД, 16, 3) + Сред(ГУИД, 10, 4) + Сред(ГУИД, 1, 8);
    Разрядность = СтрДлина(Строка16);
    ЧислоСек = 0;
    Для Позиция = 1 По Разрядность Цикл
        ЧислоСек = ЧислоСек + Найти("123456789abcdef",Сред(Строка16,Позиция,1))*Pow(16,Разрядность - Позиция);
    КонецЦикла;
    ЧислоСек = ЧислоСек / 10000000;
    Возврат Дата(1582, 10, 15, 04, 00, 00) + ЧислоСек;
КонецФункции
Показать
klinval; Klash; корум; itriot11; the1; Korolev; 02RUSlan; primat; DarkAn; Margo462; +10 1 Ответить
18. primat 2048 10.01.18 14:43 Сейчас в теме
Пока смотрел публикацию, думал о том, что ведь правда в ссылке хранится дата создания объекта. В (17) привели пример. Считаю, решение более корректно и повлиять никто не сможет на эту дату. Недостаток только в том, что в форму списка это не получится вывести.
19. Margo462 192 10.01.18 14:59 Сейчас в теме
(18) это да, с формой списка заморочка)
20. palsergeich 10.01.18 15:13 Сейчас в теме
(17) (18) Вы же понимаете, что дата создания документа в конкрентой базе и дата из GUID могут быть различные (такое возможно например при обмене при синхронизации по guid)
AZel84; Irwin; корум; +3 Ответить
21. unichkin 1199 22.04.18 18:01 Сейчас в теме
Только идентификаторы не стоит начинать с нижнего подчеркивания... https://its.1c.ru/db/v8std#content:2149184103:hdoc, п.3
Оставьте свое сообщение

См. также

Описание формата внутреннего представления данных 1С в контексте обмена данными 143

Статья Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Практика программирования Внешние источники данных Разработка

Фирма 1С не рекомендует использовать внутреннее представление данных для любых целей, которые отличны от обмена с 1С:Предприятием 7.7. Но сама возможность заглянуть на "внутреннюю кухню" платформы с помощью функций ЗначениеВСтрокуВнутр(), ЗначениеВФайл(), ЗначениеИзСтрокиВнутр() и ЗначениеИзФайла(), дала возможность сообществу программистов 1С разработать новые приемы разработки и анализа. Так, именно на использовании внутреннего представления был построен алгоритм "быстрого массива", который позволяет практически мгновенно создать массив в памяти на основании строки с разделителями. С помощью разбора внутреннего представления можно "на лету" программным кодом выполнить анализ обычной формы и даже сделать редактор графической схемы. Во внутреннем формате сохраняют свои данные между сеансами различные популярные внешние обработки. А еще это возможность сделать быстрый обмен с внешними системами.

1 стартмани

06.09.2019    4358    4    Dementor    27       

Вам нравятся запросы в 1С? 13

Инструменты и обработки Программист Конфигурация (md, cf) v8 v8::Запросы 1cv8.cf Абонемент ($m) Практика программирования Разработка

Речь не только о том, что простейший запрос с "легальным" оформлением растянется на пол-экрана, речь еще обо всем, что нужно написать "в нагрузку" к тексту запроса. Все эти "Новый Запрос", "УстановитьПараметр" и последующие пляски с обработкой результата... Пора с этим заканчивать!

1 стартмани

03.07.2019    9137    1    m-rv    73       

1С:Ассемблер. Немного летнего веселья! 284

Статья Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Практика программирования Разработка

Все вы, наверное, слышали, что 1С-ники жалуются на свою систему, считая язык 1С недостаточно низкоуровневым, скучным и т.п. Все они с тоской поглядывают в сторону "настоящих" языков программирования. Так вот, господа, они неправы. В системе 1С есть места, где можно размять программерский мозг и получить удовольствие от низкоуровневой техники. Предлагаю вам погрузиться в недра виртуальной машины 1С и понять, как она работает. Там есть свой "ассемблер" и мы попробуем его в действии!

1 стартмани

21.06.2019    12442    37    Evil Beaver    108       

Простые примеры сложных отчетов на СКД 250

Статья Программист Архив с данными v8 v8::СКД 1cv8.cf Абонемент ($m) Практика программирования

Подписи в отчете. Особенности соединения наборов: как соединить несоединяемое. Остатки на дату и обороты по месяцам в одном отчете. Курс валюты на каждую дату без группировок и соединений в запросе. Отчет с произвольными колонками и с произвольной последовательностью. "Неадекватный отчет".

1 стартмани

12.06.2019    11554    10    Hatson    22       

Безопасная работа с транзакциями во встроенном языке 183

Статья Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Практика программирования Разработка

Разбираемся с опасностями использования транзакций во встроенном языке 1С. Познаем ошибку "В данной транзакции уже происходили ошибки". Учимся защищаться от них.

1 стартмани

25.03.2019    13364    7    tormozit    35       

Баг или фича? Неожиданное поведение платформы 165

Статья Системный администратор Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Практика программирования Тестирование и исправление Разработка

Рассмотрим несколько случаев неожиданного поведения платформы 1С, а также что с этим можно cделать.

18.02.2019    12028    31    YPermitin    88       

Коннектор: удобный HTTP-клиент для 1С:Предприятие 8 512

Инструменты и обработки Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Практика программирования Внешние источники данных WEB Универсальные функции Инструментарий разработчика Универсальные обработки

Коннектор - библиотека для работы с HTTP запросами. Библиотека берет на себя всю рутину работы с HTTP запросами. Буквально в одну строку можно получать данные, отправлять, не заботясь о необходимости конструирования URL, кодирования данных и т.п.

1 стартмани

31.01.2019    25209    243    bonv    108       

HTML в новой версии 8.3.14 на примере 3-х JavaScript библиотек: AmCharts, HighCharts, DHTMLX 167

Статья Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Универсальные обработки Практика программирования Разработка

Тестируем возможности HTML в новой версии 8.3.14 платформы на примере 3-х JavaScript библиотек: AmCharts, HighCharts, DHTMLX.

1 стартмани

29.01.2019    12773    62    Synoecium    33       

Отладка сложных отчетов на СКД 137

Отчеты и формы Программист Расширение (cfe) v8 v8::СКД 1cv8.cf Россия Абонемент ($m) Практика программирования

Расширение для отладки сложных отчетов на СКД (в т.ч. для собираемых программно "на лету") и быстрого перехода к отладке таких отчетов в консоли запросов и отчетов на СКД.

1 стартмани

28.12.2018    13266    53    maxx    42       

Реализация простого http-сервиса "Просмотр карточки номенклатуры(товара) в браузере" 144

Статья Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Практика программирования

Практический пример реализации простого http-сервиса средствами 1С Предприятие 8.3. Обеспечивает просмотр списка товаров и просмотр данных товара в браузере.

1 стартмани

07.12.2018    12781    10    dmitry1975    31       

Использование подсистемы БСП "Заполнение объектов" 134

Статья Программист Расширение (cfe) v8 v8::УФ 1cv8.cf Россия Абонемент ($m) Практика программирования Универсальные функции БСП (Библиотека стандартных подсистем)

Применение механизмов БСП для добавления новых команд заполнения к формам различных объектов. Использование расширений конфигурации для доработки. Шаблоны для реализации собственных команд заполнения.

1 стартмани

23.11.2018    13008    8    ids79    22       

Работа с публикациями "Инфостарт" 13

Инструменты и обработки Программист Архив с данными v8 УУ Абонемент ($m) Практика программирования О сообществе WEB

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    8220    10    RocKeR_13    12       

HTTP Сервисы: Путь к своему сервису. Часть 3 133

Инструменты и обработки Системный администратор Программист Расширение (cfe) v8 1cv8.cf Абонемент ($m) Инструментарий разработчика Практика программирования

Продолжение статьи «HTTP Сервисы: Путь к своему сервису. Часть 2». В предыдущих частях мы использовали только Get, в этой части поговорим о других методах и длительных операциях.

1 стартмани

27.08.2018    14878    29    dsdred    13       

Позиционирование в помещении с помощью нейросети по сигналу Wi-Fi. Интерактивная карта склада в 1С с показом позиции 63

Инструменты и обработки Программист Бизнес-аналитик Приложение (apk) v8 Windows Абонемент ($m) Инструментарий разработчика Практика программирования

Данная публикация содержит в себе редактор и интерактивную карту склада или иного помещения, на которой в реальном времени отображается позиция устройства, координаты которого вычисляются по уровням сигнала нескольких роутеров Wi-Fi. В статье и приложенным к ней разработкам предлагаются инструменты и методика для реализации вычисления точной геопозиции внутри помещений с помощью нейронной сети. Конфигурация написана на релизе 1С:Предприятие 8.3.12.1412, клиентское приложение имеет минимальный уровень совместимости SDK -16.

5 стартмани

09.08.2018    14770    23    informa1555    26       

Работа с данными выбора 38

Инструменты и обработки Программист Архив с данными v8 Россия Абонемент ($m) Практика программирования Работа с интерфейсом

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений - уже задать без программирования не получится.

1 стартмани

17.07.2018    19867    13    kalyaka    15       

HTTP Сервисы: Путь к своему сервису. Часть 1 258

Статья Системный администратор Программист Расширение (cfe) v8 1cv8.cf Абонемент ($m) Практика программирования WEB

Уже много было написано про http-сервисы, но то и дело всплывают «Новые» статьи по обмену между базами V8 по COM, что «Немножко» удивляет. Решил внести свои 5 копеек, поработаем с http-сервисом.

1 стартмани

15.07.2018    35132    15    dsdred    22       

ВСТАВИТЬ В Справочник.Номенклатура (Код, Наименование) ЗНАЧЕНИЯ ("001", "Новый товар") 105

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::Запросы 1cv8.cf Абонемент ($m) Практика программирования

Вас не обманывают ваши глаза, это запрос на изменение данных! И это работает без прямого доступа к БД, регистрации и смс.

1 стартмани

01.06.2018    19044    86    m-rv    57       

БСП: Дополнительная обработка (Регламенты), примеры от простого к сложному 236

Статья Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Практика программирования БСП (Библиотека стандартных подсистем)

Очень много попадается странных решений, которые можно решить через БСП:Дополнительные отчеты и обработки. Я бы вообще БСП из-за этой подсистемы переименовал в «Большое Спасибо Программистам». Поработаем с подсистемой в части написания регламентных заданий.

1 стартмани

10.05.2018    26291    24    dsdred    34       

Как выполнить отчет на СКД через COM и получить данные отчета? 85

Статья Программист Архив с данными v8 УПП1 Россия Windows Абонемент ($m) Практика программирования

Для чего это нужно. Например, нужно в одной базе получить какой-либо показатель из другой базы. Этот показатель вычисляется в каком-либо сложном отчете, который написан на СКД. Можно, конечно, "скопипастить" текст запроса из другой базы, немного подправить его и выполнять в том же COM подключении. Но с этим теряется гибкость: если отчет изменился, то нужно помнить о том, что где-то есть его "немного модифицированная" копия. В статье будет рассмотрен пример получения данных из базы ЗУП.

2 стартмани

08.05.2018    17241    10    wowik    3       

Работа со схемой запроса 171

Статья Программист Конфигурация (md, cf) v8 v8::Запросы Абонемент ($m) Инструментарий разработчика Практика программирования

Стандартом взаимодействия с реляционной базой данных стал язык SQL. Приемником SQL в 1С является язык запросов. Язык запросов, также как и SQL, является структурированным. Составляющие структуры запроса отвечают на разные вопросы о том, какие данные требуется получить и какие манипуляции с множествами данных необходимо произвести при получении. В простых случаях текст запроса можно написать вручную, однако в сложных случаях, а также при программном формировании, - лучше воспользоваться объектной моделью запроса и использовать объект "Схема запроса". В статье дается описание объектной модели и особенностей работы с ней, а также приводится решение, упрощающее взаимодействие с объектом "Схема запроса".

1 стартмани

24.04.2018    27235    72    kalyaka    34       

Асинхронная запись и чтение файла без использования модальных методов и временных файлов 130

Статья Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Практика программирования

В статье рассмотрено решение задачи формирования и записи файла на основе данных информационной базы. Формирование происходит на стороне сервера с помощью механизма потоков. Используются асинхронные методы передачи файлов между клиентом и сервером. Также рассмотрено решение обратной задачи - чтение файла и запись его данных в информационную базу. Статья ориентирована прежде всего на новичков, также приведенный код может использоваться в качестве шаблона.

1 стартмани

10.04.2018    18112    17    Alxby    23       

Заполняем по шаблону (по умолчанию) 68

Инструменты и обработки Программист Архив с данными v8 v8::УФ 1cv8.cf Абонемент ($m) Практика программирования

Простой в подключении, универсальный и достаточно удобный механизм заполнения реквизитов произвольных документов/справочников значениями по умолчанию. Реализован в расширении, но может быть и непосредственно включен практически в любую конфигурацию на управляемых формах простым копированием одной формы и двух команд. Весь код в статье.

1 стартмани

08.02.2018    17447    20    mvxyz    17       

Бесплатная проверка контрагентов в ФНС (общий модуль с алгоритмом). На примере выводим статус в список справочника контрагентов 122

Статья Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Практика программирования

Если вам интересно проверить контрагенте в ФНС, вам поможет данная публикация. Весь алгоритм работы строится на основе данных, полученных с сервиса http://npchk.nalog.ru совершенно бесплатно.

1 стартмани

01.02.2018    24309    61    rpgshnik    46       

Расширение возможностей печати: Вывод произвольного нижнего и верхнего колонтитула 8

Отчеты и формы Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Печатные формы документов Практика программирования Универсальные функции

Расширяем функционал вывода нижнего / верхнего колонтитула. Стандартно 1С имеет достаточно ограничений по выводу и наполнению колонтитулов содержимым, взять хотя бы такие, как вывод только текста и отсутствие ограничения на номер конечной страницы. А при разработке кода сталкиваешься с тем, что свой блок с нижним колонтитулом нужно прижимать к низу страницы. Казалось бы быстро решаемый вопрос, но и в нем есть нюансы. Сейчас я расскажу о том, как решалась эта задача. UPD 15.02.2018. Добавлен вывод верхнего колонтитула; Вывод колонтитулов на первой и последней странице управляется параметрами; Научился считать страницы: Добавлено заполнение переменных аналогичных стандартным из колонтитулов; Задаются форматы даты и времени. Ограничения прежние: 1. Повторно сформировать табличный документ после смены параметров страницы интерактивно.; 2. Передавать данные для более плотной печати как можно более мелко нарезанными кусками.

1 стартмани

29.12.2017    21474    21    agent00mouse    0       

Практика доступа в базу 1С через протокол oData. Чтение данных 276

Статья Системный администратор Программист Бизнес-аналитик Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Сервисные утилиты Практика программирования Администрирование данных 1С

Для чего нужен доступ в базу 1С через REST-интерфейс по протокол oData? Как его организовать? Как не будучи гуру в JavaScript и .NET получить быстрый визуальный доступ к данным базы 1С? Попробую дать ответ на эти вопросы и прокомментирую некоторые нюансы, с которыми я столкнулся.

1 стартмани

11.12.2017    55088    232    Dementor    42       

Печатная форма, сделанная как расширение конфигурации для БП 3.0. Новые возможности БСП 26

Инструменты и обработки Программист Расширение (cfe) v8 БП3.0 Абонемент ($m) Практика программирования Универсальные печатные формы

Печатные формы на внешних обработках скоро канут в лету. На смену им приходят ПФ, реализованные в виде расширений конфигурации. Не нашел на сайте примеров таких расширений. Привожу пример подобного расширения для БП 3.0.

1 стартмани

06.12.2017    17870    52    kwazi    6       

Простой бесплатный DashBoard с помощью http сервиса 256

Статья Программист Конфигурация (md, cf) v8 Абонемент ($m) Практика программирования

Как создать свой DashBoard без дополнительных затрат и сложных технических доработок.

1 стартмани

25.11.2017    43446    58    dewersia    32       

Полезный код для программистов 1С (часть 1). Управление свойствами элементов формы. Хранение копии данных реквизитов 141

Статья Программист Архив с данными v8 Абонемент ($m) Инструментарий разработчика Практика программирования

У каждого программиста за время работы накапливается полезный инструментарий, которым он привык пользоваться. Естественно и у меня он тоже имеется. И вот решено было немного поделиться с сообществом. Возможно идеи не новые. Более того, допускаю, что реализованы они не самым оптимальным образом. Но ведь для этого сообщество и существует, чтобы делиться с ним, получая обратную связь.

1 стартмани

24.09.2017    31481    17    vandalsvq    79       

Telegram-боты 149

Инструменты и обработки Программист Архив с данными v8 Абонемент ($m) Практика программирования

Описание теории, разбор архитектуры и пример реализации telegram-ботов. Сразу скажу, со структурированием изложения мало что могу поделать. :) редакция от 18.07.2018 Правки последней редакции выделены жирным.

1 стартмани

01.09.2017    21799    119    PLAstic    45       

Макеты СКД 282

Статья Программист Внешний отчет (ert,erf) v8 v8::СКД 1cv8.cf Абонемент ($m) Практика программирования

Рассмотрены некоторые типовые задачи, которые решаются с помощью предопределенных макетов, а также перечислены несколько случаев, для которых макеты не подходят

1 стартмани

25.07.2017    68212    106    json    24       

Расширения конфигураций 1С: учимся перехватывать методы 110

Инструменты и обработки Программист Расширение (cfe) v8 v8::УФ 1cv8.cf Абонемент ($m) Практика программирования

В этой статье я на примерах разберу некоторые механизмы расширений конфигураций 1С. А именно «перехваты» методов модуля объекта и «перехваты» событий формы и элементов формы. Данная статья написана с учебными целями, чтобы показать, как при помощи расширений конфигурации можно делать такие доработки, ради которых раньше приходилось снимать конфигурацию с поддержки.

1 стартмани

30.05.2017    82007    14    signum2009    45       

Многопоточность. Универсальный «Менеджер потоков» (фреймворк) с отслеживанием зависимости объектов 175

Статья Программист Архив с данными v8 1cv8.cf Россия Абонемент ($m) Практика программирования Математика и алгоритмы Универсальные функции Производительность и оптимизация (HighLoad)

Восстановление партий, расчет зарплаты, пакетное формирование документов или отчетов - теперь все это стало доступнее. * Есть желание повысить скорость работы медленных алгоритмов! Но... * Нет времени думать о реализации многопоточности? * о запуске и остановке потоков? * о поддержании потоков в рабочем состоянии? * о передаче данных в потоки и как получить ответ из потока? * об организации последовательности? Тогда ЭТО - то что надо!!!

26.05.2017    38405    166    DarkAn    86       

Регулярные выражения – это просто. Построитель и отладчик регулярных выражений 181

Инструменты и обработки Программист Архив с данными v8 1cv8.cf Абонемент ($m) Инструментарий разработчика Практика программирования

Предлагается к использованию построитель регулярных выражений. Выполненный в виде внешней обработки, он позволит строить сложно-структурированные выражения на основе параметрического описания, тестировать их, и в результате получить программный код 1С.

1 стартмани

13.03.2017    22353    112    romasna    47       

Несколько шаблонов для доработки типовых конфигураций 174

Инструменты и обработки Программист Конфигурация (md, cf) v8 v8::УФ Абонемент ($m) Практика программирования Инструментарий разработчика

Предлагаю несколько каркасов для создания новых объектов в типовых конфигурациях. Это выжимка из кода нескольких конфигураций, которая позволит быстро и красиво создавать и дорабатывать объекты метаданных с соблюдением идеологии исходной системы

1 стартмани

03.10.2016    27556    102    json    25       

Простой способ индексирования интервалов 181

Статья Программист Конфигурация (md, cf) v8 Абонемент ($m) Практика программирования

Предлагается простой способ индексирования интервалов для решения задач выборки записей, включающих заданный момент времени, пересекающихся с заданным интервалом или множеством интервалов. Способ основан на добавлении к исходной таблице особого числового индексированного поля, рассчитываемого по специальной формуле. Приведен код функций, необходимых для расчетов поля поиска и параметров поисковых запросов. Приведены также результаты тестирования метода, доказывающие его высокую эффективность.

1 стартмани

28.09.2016    31659    39    ildarovich    22       

1С: Предприятие + корпоративный чат, как наладить оперативные уведомления за 10 минут 61

Инструменты и обработки Системный администратор Программист Компонента, плагин (dll, vbs,..) v8 Windows Абонемент ($m) Практика программирования

Как сделать автоматические уведомления о разных событиях из 1С в корпоративный чат MyChat для сотрудников компании

1 стартмани

14.08.2016    38114    35    Demanoidos    60       

Хранение файлов в томах на диске (для УПП 1.3) 76

Инструменты и обработки Программист Архив с данными v8 УПП1 Windows Абонемент ($m) Практика программирования

Доработка типовой УПП 1.3 в плане хранения присоединенных файлов вне базы данных

2 стартмани

05.06.2016    43546    4    wowik    27       

БСП 2.3 и БСП 3.0: Просто про выполнение внешней обработки в фоне (c индикацией прогресса выполнения) 185

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Инструментарий разработчика Практика программирования БСП (Библиотека стандартных подсистем)

Простое пояснение о том, как сделать внешнюю обработку с фоновым выполнением и индикацией процесса для любой конфигурации на основе БСП 2.3.2. UPDATE 20/09/19: добавлен вариант обработки с индикацией процента выполнения и статусом выполнения для БСП 3.0.

1 стартмани

18.05.2016    45736    136    rozer    52       

Остатки на каждый день в запросе 34

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf УУ Windows Учет ТМЦ Абонемент ($m) Практика программирования

Запрос формирует остатки товаров на каждый день в пределах выбранного периода.

1 стартмани

26.04.2016    33999    19    arakelyan    17       

Выполнение JavaScript кода из 1С в объекте Поле HTML Документа (HTML 5) и вызов события в 1С ПриНажатии 149

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Россия Windows Абонемент ($m) Практика программирования

Пример выполнения JS кода из 1С в Поле HTML Документа под управляемыми формами, с удобным получением результата в 1С(С помощью вызова привязанного события ПриНажатии к элементу ПолеHTMLДокумента)

1 стартмани

22.03.2016    60190    132    igo1    49       

Количество дней недели (понедельников/вторников/...) в заданном диапазоне одним запросом 28

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 Абонемент ($m) Практика программирования

При реализации периодического авто-заполнения маршрутных листов по графику (недельному) необходимо было просчитать стоимость всего периода, с условием выездов только по определенным дням. Заморачиваться с обходом результата не хотелось. Пришлось написать "Небольшой" запрос.

1 стартмани

03.03.2016    12019    1    Alexander.Shvets    5       

Простые радости жизни программиста 1С: выбор типа значения 51

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Практика программирования Работа с интерфейсом

Предлагаемая в работе обработка включает обычную и управляемую формы, которые максимально точно реализуют функциональность системного диалога выбора типа в толстом клиенте обычное приложение (включая оформление диалога). Эти формы имеют дополнительные интерфейсные удобства и могут быть использованы в качестве альтернативных диалогов выбора типа.

1 стартмани

17.02.2016    38555    45    yuraos    17       

Отображение прогресса выполнения длительных операций в БСП и их отладка в текущем сеансе. 160

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Практика программирования БСП (Библиотека стандартных подсистем)

В статье описан способ исполнения длительных операций в конфигурациях, в которых используется библиотека стандартных подсистем, с визуализацией прогресса исполнения и отображения хода обработки данных. Также дается краткое описание процесса отладки длительных операций в текущем сеансе.

1 стартмани

17.02.2016    40292    143    balanton    20       

Яндекс.Деньги "Благотворительность" 17

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Инструментарий разработчика Практика программирования

Яндекс.Деньги теперь в 1С. Форма для приема благотворительных взносов. Форму легко сделать и вставить на любую страницу сайта или блога. Платежи будут приходить на ваш кошелек. На форме есть три способа платежа: из кошелька, с банковской карты, с баланса мобильного.

1 стартмани

16.02.2016    17186    9    Tatitutu    5       

Мастер рассылки e-mail 2.2 для управляемых форм 9

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ ERP2 БП3.0 УТ11 Абонемент ($m) Практика программирования Email

Для пользователей: переделанный из старый разработки под 8.2 с использованием библиотеки Мастер рассылки e-mail 2.2 (ERP, УТ, БП) (Только управляемые формы), который теперь может запускаться под любой версией платформы с разрешенными или запрещенными модальными/синхронными вызовами в конфигурации. Также удобный выбор e-mail и их владельцев с помощью отбора динамического списка по любым критериям и галочки исключения.

1 стартмани

29.12.2015    30464    20    milkers    4       

Нечеткий поиск одним запросом 37

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Практика программирования

Использование механизма полнотекстового поиска в 1С не всегда оправдано, т.к. построение индекса и поддержание его в актуальном состоянии может значительно нагружать систему. Предлагаемая реализация нечеткого поиска методом N-грамм выполняется одним запросом, что позволяет производить поиск в любой таблице и не требует предварительного построения индекса.

1 стартмани

28.12.2015    19081    57    vasvl123    9       

Передача больших пакетов через веб-сервисы 137

Инструменты и обработки Системный администратор Программист Конфигурация (md, cf) v8 Абонемент ($m) Практика программирования Администрирование данных 1С Внешние источники данных

Реализация механизма передачи больших пакетов через веб-сервисы. С его помощью передать файл размером в несколько гигабайт не составит проблем.

1 стартмани

06.12.2015    40884    44    YPermitin    19       

Пример связи 1С и мессенджера Telegram. Получение данных из 1С запросом из Telegram 242

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Практика программирования Внешние источники данных

В результате чтения публикации Вы получите готовую внешнюю обработку, позволяющую получать из 1С данные, запрашиваемые через Telegram. В данной статье рассмотрим следующее: Использование HTTPСоединение; Чтение JSON для версии 1С 8.3.6 и выше, а также аналог JSON для версии 1С ниже 8.3.6; Подключение обработчика ожидания; Некоторые основные возможности API Telegram; Как создать бота для Telegram; Программное создание колонок дерева на управляемой форме;

1 стартмани

19.11.2015    69629    417    Luchik    199