Выгрузка товаров в социальную сеть Twitter

Обмен - Интеграция с WEB

социальные сети twitter выгрузка товаров

3
Конфигурация предназначена для отправки товаров в социальную сеть Twitter.

Конфигурация предназначена для отправки товаров в социальную сеть Twitter.

Имеются следующие справочники: Товары, Категории, Фотографии, Пользователи Твиттера.

И две обработки:

Обработка 1. Загрузка товаров из файлов CSV в справочник Товары и Категории. Выбираете файл и загружаете его в базу данных, путем нажатия на кнопку "Загрузить файл".

Обработка 2. Отправка товаров на сайт Twitter. Выбираете Пользователя с учетной записью Twitter и товар, нажимаете кнопку "Отправить", и товар с картинкой попадает на сайте twitter

Обработка предназначена для Администраторов сайтов и маркетологов, но также будет интересна для разработки собственных конфигураций для автоматической отправки товаров в социальные сети.

Тестировалось на платформе 1С:Предприятие 8.3 (8.3.10.2561).

Отправка выполнена всего одной функцией


&НаСервере
Функция ОтправитьНаСервере()
	ТекстСообщения=СокрЛП(Объект.Товар.Родитель)+" $"+СокрЛП(Объект.Товар.Цена)+" "+СокрЛП(Объект.Товар.СсылкаДляКлика);
	Возврат ФункцииСайта.ДобавитьВТвиттер(Объект.Товар,ТекстСообщения,Объект.ПользовательТвиттер);
КонецФункции

&НаКлиенте
Процедура Отправить(Команда)
	Если Объект.ПользовательТвиттер.Пустая() Тогда
		ПоказатьПредупреждение(,"Не выбран пользователь");
		Возврат;
	КонецЕсли;
	Если Объект.Товар.Пустая() Тогда
		ПоказатьПредупреждение(,"Не выбран товар");
		Возврат;
	КонецЕсли;
	Сообщение=ОтправитьНаСервере();
	Состояние(Сообщение);
КонецПроцедуры

Пример смотрите здесь

 

3

Скачать файлы

Наименование Файл Версия Размер
Выгрузка товаров в социальную сеть Twitter:
.dt 1,56Mb
13.02.18
1
.dt 1.0.0.0 1,56Mb 1 Скачать

См. также

Избранное Подписка Сортировка: Древо
В этой теме еще нет сообщений.
Оставьте свое сообщение