Битрикс24. Работаем с оффлайн событиями

Публикация № 829149

Разработка - Системная интеграция - Внешние источники данных

Появление оффлайн событий упростило синхронизацию Битрикс24 -> 1С. Теперь, например, можно загрузить только измененные между сеансами обмена сделки. А не тащить все незавершенные. В статье описание, как это можно сделать.

И так: регистрируем приложение в своем Битрикс24. Как это сделал описал в //infostart.ru/public/574117/. Помимо прав на CRM дайте еще права на пользователей. В примере по ИД пользователя вытаскивается ФИО. А без прав будет ошибка.

 

Запустим обработку и внесем все регистрационные данные

Сохраните чтобы потом не вводить заново.

Первое, что можно попробовать, это получить список доступных событий. Жмите Получить список событий. Получим что-то вроде этого.

В примере используется событие ONCRMDEALUPDATE. 

Для того, чтобы события начали регистрироваться жмем Начать регистрацию событий.

Теперь перейдем в наш Битрикс24 и изменим уже заранее добавленные сделки. Например изменим статус.

 

Вернемся в обработку и прочитаем события

 

Можно завершить регистрацию и убедится, что после этого события не регистрируются, обработка ничего не вернет.

 

Теперь код. Процедуры ОтправитьRESTЗапрос  и другие используются из модуля описанного в предыдущей статье.

 

Получить список событий

Процедура ПолучитьСписокСобытий() Экспорт
	
	СписокСобытий = "";
	
	Ответ = ОтправитьRESTЗапрос("events", "");
	М = Неопределено;
	Если Ответ.Свойство("result", М) Тогда
		
		Для Каждого С Из М Цикл
			
			СписокСобытий = СписокСобытий + С + Символы.ПС;
			
		КонецЦикла;
		
	КонецЕсли;	
	Сообщить(СписокСобытий);

КонецПроцедуры

Начать регистрацию событий

Процедура НачатьРегистрациюИзменений() Экспорт
	
	Ответ = ОтправитьRESTЗапрос("event.bind", "event=ONCRMDEALUPDATE&event_type=offline");
	Если Ответ.Свойство("result") Тогда
		Сообщить("Ок");
	Иначе
		Сообщить("Ошибка!");
	КонецЕсли;


КонецПроцедуры

 

Обработка изменений сделок

Процедура ПрочитатьСобытия() Экспорт
	
	Ответ = ОтправитьRESTЗапрос("event.offline.get", "filter[EVENT_NAME]=ONCRMDEALUPDATE");
	Р = Неопределено;
	Если Ответ.Свойство("result", Р) Тогда
		
		Для Каждого С Из Р.Events Цикл
			
			Если С.EVENT_NAME = "ONCRMDEALUPDATE" Тогда
				
				// вытащу сделку
				
				Сделка = ОтправитьRESTЗапрос("crm.deal.get", "id=" + С.EVENT_DATA.FIELDS.ID);
				ИмяСделки = "";
				Если Сделка.Свойство("result") Тогда
					ИмяСделки = Сделка.result.TITLE;
				КонецЕсли;
				
				// кто менял
				Пользователь = ОтправитьRESTЗапрос("user.get", "filter[id]=" + С.EVENT_ADDITIONAL.user_id);
				ИмяПользователя = "";
				Если Пользователь.Свойство("result") Тогда
					ИмяПользователя = Пользователь.result[0].LAST_NAME + " " + Пользователь.result[0].NAME;
				КонецЕсли;
				
				
				Сообщить("В " + С.TIMESTAMP_X + " сделку " + ИмяСделки + " изменил пользователь " + ИмяПользователя);
			КонецЕсли;
			
			
		КонецЦикла;
		
	КонецЕсли;		

	
КонецПроцедуры

 

Вся документация по REST API Битрикс24 здесь

Обработка тестировалась на платформе 8.3.10.2580

 

Скачать файлы

Наименование Файл Версия Размер
Битрикс24. Работаем с оффлайн событиями. Пример обработки.

.epf 11,25Kb
11.05.18
39
.epf 11,25Kb 39 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
1. script 220 11.05.18 22:32 Сейчас в теме
Спасибо огромное - продолжение будет?
2. user662672_explorer2000 181 14.05.18 08:23 Сейчас в теме
Добрый день! Продолжение о чем?
4. user662672_explorer2000 181 15.05.18 12:29 Сейчас в теме
Согласен, упустил этот момент, проверю. В текущем варианте скорей всего следующие 50 отработает при последующем запуске
16. novatrade 31.05.18 12:51 Сейчас в теме
(5)Это к Битриксу. Я думаю для регламентного обмена выше крыши.
19. amd1986 06.06.18 19:05 Сейчас в теме
30. berl 64 05.11.18 18:09 Сейчас в теме
(19) Для обхода ограничения в 50 записей используется параметр в запросе "&start=НачальнаяПозиция" где НачальнаяПозиция - номер первого элемента из партии в 50 шт.
При получении ответа в параметре .total находится общее количество элементов, и далее цикл
31. amd1986 08.11.18 17:00 Сейчас в теме
(30) я про другое имел в виду.
6. user662672_explorer2000 181 18.05.18 14:17 Сейчас в теме
Добрый день!

Метод crm.deal.get не списочный, к тому же доп. параметр clear у меня не передается и по умолчанию он равен 1. Т.е. после прочтения событий они удаляются. Для обработки всех событий (если их больше 50) можно доработать например следующим образом

Процедура ПрочитатьСобытия() Экспорт
	
	
	Пока Истина Цикл
	
		Ответ = ОтправитьRESTЗапрос("event.offline.get", "filter[EVENT_NAME]=ONCRMDEALUPDATE");
		
		Р = Неопределено;
		Если Ответ.Свойство("result", Р) Тогда
			
			Если Р.Events.Количество() = 0 Тогда
				Возврат;
			КонецЕсли;
			
			Для Каждого С Из Р.Events Цикл
				
				Если С.EVENT_NAME = "ONCRMDEALUPDATE" Тогда
					
					// вытащу сделку
					
					Сделка = ОтправитьRESTЗапрос("crm.deal.get", "id=" + С.EVENT_DATA.FIELDS.ID);
					ИмяСделки = "";
					Если Сделка.Свойство("result") Тогда
						ИмяСделки = Сделка.result.TITLE;
					КонецЕсли;
					
					// кто менял
					Пользователь = ОтправитьRESTЗапрос("user.get", "filter[id]=" + С.EVENT_ADDITIONAL.user_id);
					ИмяПользователя = "";
					Если Пользователь.Свойство("result") Тогда
						ИмяПользователя = Пользователь.result[0].LAST_NAME + " " + Пользователь.result[0].NAME;
					КонецЕсли;
					
					
					Сообщить("В " + С.TIMESTAMP_X + " сделку " + ИмяСделки + " изменил пользователь " + ИмяПользователя);
				КонецЕсли;
				
				
			КонецЦикла;
			
		КонецЕсли;		
	
	КонецЦикла;

	
КонецПроцедуры
Показать
7. novatrade 22.05.18 11:42 Сейчас в теме
А зачем проверка типа:
Если С.EVENT_NAME = "ONCRMDEALUPDATE" Тогда

Ведь Вы уже сделали выборку по данному событию?
8. user662672_explorer2000 181 22.05.18 12:34 Сейчас в теме
Верно, это лишнее. Может только для того, чтобы показать, что и имя события возвращается.
9. novatrade 22.05.18 15:03 Сейчас в теме
интересно было бы, если выборку делать по нескольким событиям, связанных с сделками. А потом разбор. В фильтре поставить "ONCRMDEAL%"
10. user662672_explorer2000 181 23.05.18 08:42 Сейчас в теме
(9) Проверил, все работает.

1. Регистрируем интерес к нескольким событиям

	Ответ = ОтправитьRESTЗапрос("event.unbind", "event=ONCRMDEALUPDATE&event_type=offline");
	
	Ответ = ОтправитьRESTЗапрос("event.unbind", "event=ONCRMDEALADD&event_type=offline");
	
	Ответ = ОтправитьRESTЗапрос("event.unbind", "event=ONCRMLEADADD&event_type=offline");


2. А забирать буду только события по сделкам

	Ответ = ОтправитьRESTЗапрос("event.offline.get", "filter[EVENT_NAME]=ONCRMDEAL%");


Приходят события и на изменение сделок и на добавление

По лидам события можно прочитать например так

	Ответ = ОтправитьRESTЗапрос("event.offline.get", "filter[EVENT_NAME]=ONCRM%");
11. novatrade 23.05.18 13:11 Сейчас в теме
Я работаю со счетами.
но что интересно - на каждое изменение счета приходят два ответа: Статус и Действие. И только на изменение статуса счета - только Статус.

Ответ = ОтправитьRESTЗапрос("event.offline.get", "filter[EVENT_NAME]=ONCRM%");

получите список всех событий для CRM - которые включены и произошли.
12. user662672_explorer2000 181 23.05.18 14:45 Сейчас в теме
(11) получите список всех событий для CRM - которые включены и произошли. - про лиды в контексте подписки только на 3 события. Если же думаю подписаться на все события CRM то да, будет так.

Про счета интересно, но наверное есть какой-то смысл в этом?
13. novatrade 23.05.18 14:59 Сейчас в теме
подписки только на 3 события. Если же думаю подписаться на все события CRM то да, будет так.
Ну это, чтоб потом не забыть, на что подписался))
задача моя выросла из стандартного обмена. Там получали счета. Потом уткнулись - то нельзя, это нельзя, то не нравится... Пришлось в REST ползти)))
14. novatrade 24.05.18 10:01 Сейчас в теме
А кто может сказать - какое количество оффлайн событий хранится? чтобы не потерялись?500? 1000?
21. amd1986 06.06.18 19:18 Сейчас в теме
(14) Очень много. Но если есть process_id он повторно не выгрузится. Насколько я знаю, периодически эта табличка очищается. Т.е. записи старше месяца с непустым process_id удаляются
15. novatrade 28.05.18 12:14 Сейчас в теме
подскажите - как в запросе описать фильтр по нескольким условиям с условием "ИЛИ". захотели получать новые сделки и счета сразу. Делать отдельные запрос по каждому виду - два запроса. Хотелось бы объединить в один. Заранее спасибо
17. novatrade 02.06.18 22:18 Сейчас в теме
(15) сам и отвечу - в batch объединил в один запрос, а потом обработал
18. amd1986 06.06.18 19:02 Сейчас в теме
Смотрю во всю используют функционал изменений. Это радует.
Скоро появятся новые события: по пользовательским полям компаний/контактов/сделок/счетов/лидов.
Имейте в виду, что есть ограничение в 2 запроса в секунду(с буфером в 100 запросов), так что рекомендую использовать batch
20. amd1986 06.06.18 19:15 Сейчас в теме
И еще. Описана простая схема. Она не подходит, когда нужна повышенная отказоустойчивость. Например, если не удается обработать событие, то событие повторно не получите.

Если не удалось загрузить изменение(ошибка записи например), то можно пометить запись изменения как ошибочное. А потом повторно его получить по запросу event.offline.get с параметром &clear=0&error=1
22. user662672_explorer2000 181 07.06.18 13:52 Сейчас в теме
(20) Безусловно в статье искусственный пример, возможно можно читать события с clear=0 а затем после обработки каждого вычищать его через event.offline.clear
24. novatrade 08.06.18 14:30 Сейчас в теме
(22)сколько обращений будет к сайту?
25. user662672_explorer2000 181 08.06.18 15:02 Сейчас в теме
(24) Хм, давайте накопим все обработанные ИД сообщений, а затем разом их вычистим, event.offline.clear как раз принимает массив message_id. Я так не делал, просто рассуждения
26. novatrade 09.06.18 15:43 Сейчас в теме
23. novatrade 08.06.18 00:01 Сейчас в теме
(20)я пишу в док, потом обрабатываю. Иначе никак. если стопорится, то при повторном обращении остаются необработанные события - они обрабатываются в первую очередь
27. goel 07.08.18 10:18 Сейчас в теме
Хотелось бы передавать себестоимость и выручку по Сделке (Заказу покупателя).

Если создать пользовательское поле в Сделке для каждой строчки товара, я так понимаю что делать надо через метод crm.deal.userfield.update?

Как указать значение до каждой строчки товара?
Как я понимаю параметры id данного метода подойдет для пользовательских полей в шапке документа, т.е. для статичных полей. А нам нужно, чтобы это действовало для табличной части товара (размер списка динамический). Как к нему обращаться при помощи данного метода?

Заранее спасибо, разработчики молчат 4ые сутки, проект стоит(
28. user662672_explorer2000 181 09.08.18 08:13 Сейчас в теме
В CRM - Настройки есть раздел Свойства товаров, думаю можно там добавить свойство Себестоимость. Выручка по идее должна быть в строчке сделки, но я там на первый взгляд не вижу возможности добавить поле.

Через crm.deal.userfield.update меняем пользовательское поле на сделке: название, тип, отображение и т.д. Не для изменения значения поля. Да и на мой взгляд это проще настраивать через интерфейс

Товары в сделке меняем через crm.deal.productrows.set - передаем сразу все строки товаров в сделке.

методы взял отсюда
29. user1073447 23.10.18 13:07 Сейчас в теме
Очень нужна интеграция 1с и битрикс - создание обычного счета и счета/оферты в битрикс, синхронизация с 1с, отладка автоматической интеграции номенклатуры и товаров между битрикс/1с интересуют сроки и стоимость, нахождение программиста в спб обязательно!
Оставьте свое сообщение

См. также

Загрузка данных из М-Аптеки+ в 1С:Бухгалтерия 8 (ред. 3.0) Промо

Внешние источники данных Файловые протоколы обмена, FTP v8 v8::БУ БП3.0 Фармацевтика, аптеки БУ Абонемент ($m)

Обработка для загрузки файлов выгрузки из программы для автоматизации аптек и аптечных сетей М-Аптека+ в 1С:Бухгалтерия 8, редакция 3.0.

11.07.2014    32483    28    1C_MApteka    37    

Улучшенная обработка универсального обмена данными в формате XML (УФ)

Универсальные обработки Внешние источники данных Обмен через XML v8 v8::УФ 1cv8.cf Абонемент ($m)

Улучшенная обработка "Универсальный обмен данными" с полноценными возможностями СКД для выборки данных (не только для отборов).

1 стартмани

23.06.2020    1813    22    Lem0n    0    

И еще раз о HTTP-сервисах

WEB Внешние источники данных Интеграция v8 БП3.0 ЗУП3.x Россия Абонемент ($m)

Как разработать  подсистему обмена  с сильно ограниченными правами доступа к базе вопрошающего субъекта с использованием различных вариантов маршрутизации.

10 стартмани

28.04.2020    3388    5    zavsom    2    

Взаимодействие HTML (COM объект, WebKit) с 1С (обычные и управляемые формы)

Внешние источники данных WEB v8 v8::УФ 1cv8.cf Абонемент ($m)

Показан пример использования HTML (COM объект, WebKit) в 1С (8.3).

2 стартмани

18.01.2020    6175    19    Deniskinr83    0    

Менеджер загрузки данных из весов с печатью этикеток Промо

Внешние источники данных Весы Учет ТМЦ Учет ТМЦ v8 УТ10 УПП1 Абонемент ($m)

Программное обеспечение "Менеджер загрузки данных из весов с печатью этикеток" предназначено для автоматического получения данных по сети Ethernet из весов МАССА-К моделей ВПМ и ТВ_Р3 (модификация MF) в режиме On-Line.

1 стартмани

20.12.2011    20068    3    hrip    10    

Google drive - менеджер файлов

WEB Внешние источники данных v8 1cv8.cf Россия Абонемент ($m)

Синхронизация с гугл диском легко и просто!

10 стартмани

05.12.2019    7540    22    zykov_vitaliy    22    

Использование хранимых процедур MS SQL Server в 1С

Внешние источники данных v8 1cv8.cf Абонемент ($m)

Потребовалось мне как-то построить сложный запрос к внешнему источнику данных, на что платформа радостно послала меня в гугл. Немного подумав, решил написать в SQL процедуру, которая принимала бы какие-то параметры и возвращала какую-то таблицу значений с данными.

1 стартмани

03.12.2019    8071    3    Dedushka    26    

Вебхук. Путь Телеграма

Внешние источники данных Интеграция v8 Абонемент ($m)

Долгое (на самом деле нет) и нелегкое путешествие телеграма к неведомым (из за РКН) конфигурациям 1С. Памятка себе.

1 стартмани

03.10.2019    14683    10    platonov.e    18    

Что нам стоит Push построить Промо

Внешние источники данных v8 v8::Mobile Абонемент ($m)

Попробовал некоторое время назад, push сообщения, реализованные в платформе. Понравилось, но есть несколько минусов, на примере одной программы сообщений (не буду показывать пальцем), спустя некоторое время, сообщения переставали приходить онлайн, а на компьютере приходили моментально, при этом сами смартфоны звались флагманами. Читал позднее статью, где описывалось, что проблема на стороне смартфонов, что-то вроде технологий энергосбережения, но точно не помню. Также немалый минус доступно только для смартфонов.

1 стартмани

08.09.2016    25926    17    PloAl    8    

Обновление расширений с Google Drive

Расширения Внешние источники данных v8 v8::УФ 1cv8.cf Абонемент ($m)

Предлагаемое расширение содержит обработку, которая считывает информацию с диска Google и при наличии новой версии производит обновление текущих расширений конфигурации.

1 стартмани

03.10.2019    3044    3    Sedaiko    4    

Получение изображения с IP-камеры

Внешние источники данных v8 1cv8.cf Абонемент ($m)

Получение изображения JPG с IP-камеры в виде двоичных данных. В 1С может применяться для фотографирования объектов.

1 стартмани

10.09.2019    9014    26    sivin-alexey    8    

Чтение файлов PDF из 1С

Внешние источники данных Универсальные обработки v8 1cv8.cf Абонемент ($m)

Насколько мне известно, у платформы 1С нет встроенных средств чтения на лету файлов PDF для их последующего анализа, и приходится использовать внешние инструменты. Об одном из таких вариантов и пойдет речь.

1 стартмани

09.09.2019    6510    6    da_1c    4    

Описание формата внутреннего представления данных 1С в контексте обмена данными

Практика программирования Внешние источники данных v8 v8::УФ 1cv8.cf Абонемент ($m)

Фирма 1С не рекомендует использовать внутреннее представление данных для любых целей, которые отличны от обмена с 1С:Предприятием 7.7. Но сама возможность заглянуть на "внутреннюю кухню" платформы с помощью функций ЗначениеВСтрокуВнутр(), ЗначениеВФайл(), ЗначениеИзСтрокиВнутр() и ЗначениеИзФайла(), дала возможность сообществу программистов 1С разработать новые приемы разработки и анализа. Так, именно на использовании внутреннего представления был построен алгоритм "быстрого массива", который позволяет практически мгновенно создать массив в памяти на основании строки с разделителями. С помощью разбора внутреннего представления можно "на лету" программным кодом выполнить анализ обычной формы и даже сделать редактор графической схемы. Во внутреннем формате сохраняют свои данные между сеансами различные популярные внешние обработки. А еще это возможность сделать быстрый обмен с внешними системами.

1 стартмани

06.09.2019    17042    11    Dementor    30    

Согласование задач из Outlook

Внешние источники данных v8 1cv8.cf Абонемент ($m)

Согласование задач непосредственно из почтовой программы, в моем случае Outlook 2013 без каких-либо дополнительных настроек. Из почты отправляется GET запрос к HTTP-сервису 1С, который в свою очередь выполняет задачу.

1 стартмани

06.09.2019    6938    11    duhh    17    

Обмен большими данными между клиентом и сервером

Внешние источники данных v8 Абонемент ($m)

В статье рассматривается вопрос передачи больших объемов данных, превышающих теоретический лимит сеансовых данных (4Гб за вызов) (они же временное хранилище) как с клиента на сервер, так и в обратном направлении.

1 стартмани

27.08.2019    12445    5    logos    24    

Выгрузка и подготовка данных для программы "Перечень льготных профессий" для 1С: ЗУП 2.5 (ОТКРЫТЫЙ КОД) Промо

Рабочее место Внешние источники данных Управление персоналом (HRM) Управление персоналом (HRM) v8 v8::СПР ЗУП2.5 Россия БУ ФОМС, ПФ, ФСС Абонемент ($m)

Обработка для формирования и редактирования данных для перечня льготных профессий. В связи с прекращением поддержки ЗУП 2.5 и отсутствием времени на доработку для сдачи годовой отчетности открыл код модуля. Не очередная выгрузка стажей, а практически полный аналог перечня для 1С. Формирование и редактирование стажей с последующей выгрузкой в формат перечня, но только ГОРАЗДО удобнее и быстрее. В общем, смотрите видео. Где-то половина времени на написание обработки ушла именно на удобство и скорость работы. Внимание: код модуля обработки открыт

5 стартмани

09.11.2015    49465    83    Black-fog    62    

Телеграм 1С – почти коробка

Внешние источники данных v8 Абонемент ($m)

Почему это решение называется «почти коробка»? Потому, что это почти коробочное решение. С его помощью, просто добавив подсистему в конфигурацию, уже можно начинать взаимодействовать с мессенджером Telegram.

10 стартмани

20.08.2019    11109    21    zfilin    64    

Расширение Бром для интеграции с 1С

Внешние источники данных WEB v8 Абонемент ($m)

Из этой статьи вы узнаете, как можно быстро и просто синтегрироваться с любой конфигурацией 1С при помощи расширения Бром.

1 стартмани

06.08.2019    5257    4    itworks    13    

Конфигурация для обмена данными (интеграционная шина)

Внешние источники данных WEB v8 1cv8.cf Абонемент ($m)

Система позволяет организовать обмен данными, как с базами 1С, так и любыми другими приложениями. Система представляет собой отдельную конфигурацию. Система позволяет организовать гибкие возможности по настройке обмена. В качестве брокера сообщений, для передачи данных, используется отдельная самостоятельная конфигурация на 1С. Комплект поставки содержит файл расширения для "клиентской" части шины, данное расширение позволяет без снятия "ключа" организовать гибкий механизм обмена данными.

4 стартмани

08.07.2019    9570    26    miha-28    17    

Подсистема обмена данными с порталом ИМНС по электронным счетам-фактурам (автоматический обмен) Промо

Внешние источники данных WEB Инструментарий разработчика v8 1cv8.cf Беларусь БУ НДС Абонемент ($m)

Подсистема включает документы и обработки для автоматического обмена данными с порталом ИМНС через web-сервис. Присутствует возможность заполнения данными типовых операций за период, учёта входящих документов, учёта произвольных исходящих документов. Приложены обработки для запуска задания планировщика на автоматический обмен данными.

1 стартмани

28.07.2016    31838    19    c1nil    4    

Интеграция 1С с Битрикс CRM через REST API

Внешние источники данных v8 1cv8.cf Абонемент ($m)

На фоне неутихающего обострения «бизнеса» по внедрению СРМ-систем остро встают вопросы обмена данными с уже существующими системами. В статье рассматривается выгрузка контактов, товаров и сделок из 1С в Битрикс CRM через REST API, приложена обработка для тестирования.

1 стартмани

28.06.2019    18316    25    muzipov    9    

Почта России - отправка и отслеживание, интеграция с Документооборот 8

Внешние источники данных Документооборот и делопроизводство Документооборот и делопроизводство v8 ДО Россия Абонемент ($m)

Выгрузка почтовых отравлений в личный кабинет отправки Почты России; отслеживание почтовых отправлений через Почту России; расширение для интеграции Документооборот 8 с Почтой России

5 стартмани

04.06.2019    7540    53    wtlz    13    

Пример работы с viber из 1С, отправка сообщений из 1С в viber

Внешние источники данных v8 1cv8.cf Абонемент ($m)

Обработка разработана для примера отправки сообщений в viber из 1С.

1 стартмани

16.05.2019    11410    69    Isa816    24    

 Интеграция 1С и C#. Обращение к 1С через COM. Создание номенклатуры и выполнение запроса к 1С из C# на примере интеграции с Союз-PLM (система информационной поддержки жизненного цикла изделий). Обработка «Загрузка заказа на сборку». (ERP) Промо

Загрузка и выгрузка в Excel Внешние источники данных Интеграция v8 ERP2 Абонемент ($m)

Союз-PLM представляет собой полнофункциональный программный комплекс для решения  широкого спектра задач управления инженерной технической информацией наукоемких изделий и сложных инженерных объектов в области машиностроения, приборостроения, архитектуры, строительства. На практике, это управление конструкторской документацией, интегрированное с САПР, бизнес-процессы, файловый архив. Все это работает в SQL и шевелится с помощью скриптов на C#. Скрипты свободно  отлаживаются в MS Visual Studio. Подробнее смотрите на их сайте: http://www.programsoyuz.ru/products/system-soyuz-plm.html  Редактирование, конструирование и использование бизнес-процессов на порядок лучше систем на базе 1С из тех, что я изучил.

1 стартмани

25.07.2016    41449    4    milkers    2    

Шаблон http-сервиса для вашего проекта

Внешние источники данных WEB Мобильная разработка v8 v8::Mobile 1cv8.cf Абонемент ($m)

Http-сервис для обмена данными в формате JSON. Обработчики этого сервиса находятся во внешней обработке, что позволяет дорабатывать его без изменения конфигурации. Также прилагаю пример мобильного приложения для работы с данным сервисом (получает номенклатуру и остатки на складе). Сервис очень быстро разворачивается и масштабируется под ваши задачи.

3 стартмани

04.05.2019    17091    68    MarkoSokolov    47    

1C + Python + Django Rest Framework + Vue.js. Опыт несложной full-stack разработки

Практика программирования Внешние источники данных Обмен через XML WEB Разработка v8 1cv8.cf Абонемент ($m)

В этой статье мы рассмотрим путь и основные моменты создания небольшого вэб-сервиса, который мы называем "Онлайн Прайс-лист". Выгрузка из 1С, бэкенд, фронтенд, получение заказов в 1С.

1 стартмани

22.04.2019    29682    32    riposte    63    

WhatsApp чат для 1С

Внешние источники данных v8 v8::УФ 1cv8.cf Абонемент ($m)

WhatsApp чат для 1С. Расширение конфигурации, подходит для любых конфигураций 1С (управляемые формы).

5 стартмани

15.04.2019    8970    32    ManyakRus    19    

Импорт из EXCEL и других источников (xls, xlsx, xlsb, ods, sxc, dbf, mxl, csv, clipboard, sql) в 1С Промо

Загрузка и выгрузка в Excel Внешние источники данных Обработка справочников Практика программирования Обработка документов v8 КА1 БП2.0 УТ10 Розница Беларусь Украина Россия БУ Абонемент ($m)

-Наглядная, контролируемая загрузка иерархической номенклатуры с различными атрибутами и картинками из прайсов, файлов табличного вида xls,xlsx,xlsb,ods,sxc,dbf,mxl,csv произвольной структуры по указанному диапазону строк, а также из буфера обмена и внешнего SQL-источника данных в основные, дополнительные и пользовательские реквизиты. -Вариантный поиск номенклатуры. -Создание сопутствующей справочной информации. -Создание документов в национальной/иностранной валюте. -Обычное и управляемое приложение. Файл и Клиент-Сервер.

1 стартмани

16.03.2012    359027    2844    StepByStep    733    

Доработка функционала отправки дополнительных реквизитов 1С: ЭДО для Татнефть

Внешние источники данных Документооборот и делопроизводство Документооборот и делопроизводство v8 ERP2 БУ Абонемент ($m)

Подключаемое расширение к конфигурации ERP с функционалом отправки дополнительных реквизитов 1С ЭДО для Татнефть (№ и дата договора, подразделение, автор, примечание) в электронных документах Счет-фактуры и ТОРГ-12 Проверялось на 1С:ERP Управление предприятием 2.4.6.160.

2 стартмани

07.04.2019    7965    12    sapervodichka    8    

Аутентификация на внешних сервисах посредством OAuth

Информационная безопасность Внешние источники данных v8 v8::УФ 1cv8.cf Абонемент ($m)

Пример подключения к сервисам Google из 1С с помощью протокола OAuth и получения данных с внешнего сервиса.

1 стартмани

03.04.2019    17414    18    binx    123    

Формирование xml файла ЭДО (СБИС, Диадок, Такском и т.п.) для типовых документов (счета-фактуры, накладные)

Внешние источники данных Обмен через XML Документооборот и делопроизводство Документооборот и делопроизводство v8 1cv8.cf Абонемент ($m)

Не все типовые документы типовых конфигураций 1С можно выгрузить в файл формата xml ЭДО. Например счет-фактуру, на текущий момент момент это не предусмотрено. Обработка позволяет сделать это.

4 стартмани

30.03.2019    29766    178    capitan    77    

Самый простой клиент ЕГАИС УТМ для розницы. $m Промо

Внешние источники данных Рабочее место Розничная торговля Розничная торговля v8 1cv8.cf Россия УУ Абонемент ($m)

Данная обработка позволяет обеспечить приходную часть магазина розничной торговли алкоголем(ЕГАИС розница), или прочего предприятия. Эти действия становятся обязательными для розничного звена в городских поселениях с 01.01.2016 и будут достаточными до 01.07.2016. Предлагаю Вашему вниманию простое и доступное решение, которое позволяет отсрочить проблему интеграции ЕГАИС в розничное звено до указанной даты. (открытый код). Реализовано на открытой модели http://infostart.ru/public/402052/.

2 стартмани

14.12.2015    37875    45    Terrain25    47    

Генерация схемы xsd из файла xml

Инструментарий разработчика Внешние источники данных v8 Абонемент ($m)

Утилита, генерирующая xsd схему на основании xml файла.

1 стартмани

25.03.2019    12105    21    nbeliaev    11    

Декларации по формам 11 и 12 алкогольной продукции, интеграция с ПО Декларант-Алко

Розничная торговля Регламентированная отчетность Внешние источники данных Розничная торговля v8 Розничная и сетевая торговля (FMCG) Россия БУ Абонемент ($m)

Конфигурация на обычных формах, платформа 1С 8.2.19.130 и выше, с помощью которой можно сформировать Декларации по формам 11 и 12 алкогольной продукции, гибрид/интеграция с ПО Декларант-Алко версии 4.31.05 и выше.

1 стартмани

25.03.2019    7956    9    independ    8    

Работа с Active Directory из 1С (загрузка / выгрузка данных)

Внешние источники данных v8 1cv8.cf Россия Абонемент ($m)

Загрузка данных из Active Directory / Изменение информации пользователя в AD из 1С.

1 стартмани

26.02.2019    10023    71    Смешной 1С    7    

Модуль для работы 1С (платформа 8.2 и выше) с внешними SOAP Web-сервисами Промо

Внешние источники данных WEB Интеграция v8 1cv8.cf Абонемент ($m)

Модуль для работы 1С (платформа 8.2 и выше) с внешними Web-сервисами, реализованными по протоколу SOAP.

2 стартмани

15.02.2016    38322    83    lunjio    15    

Телеграм + 1С + Вебхуки + Апач + Самоподписанный сертификат

Внешние источники данных v8 Абонемент ($m)

Много строк исписано про интеграцию Телеграма и 1С. Но нигде не увидел полной инструкции по установке и настройке вебхуков. Попробую её написать.

1 стартмани

26.02.2019    13687    12    alexlx    29    

Универсальное расширение 1С для Google Таблиц и Документов

Внешние источники данных v8 1cv8.cf Абонемент ($m)

Эта статья для тех, кто использует G Suite и 1С. Готовое решение для выгрузки отчетов и печатных форм из баз 1С в Google Диск в формате Google Таблиц и Google Документов. Информация по его внедрению. Описание создания и настройки проекта в GCP.

1 стартмани

31.01.2019    14638    27    Maria18    22    

HTTP API Диадок. Загружаем в Диадок любой документ. Посредством POST и GET запросов

Внешние источники данных v8 1cv8.cf Абонемент ($m)

Поставили задачу через HTTP API Диадок (diadoc-api.kontur.ru) отправить любой файл в Диадок и подписать его (например, служебную записку в формате пдф). Посредством POST и GET запросов.

2 стартмани

14.01.2019    9919    24    John_d    8    

7 причин, почему интеграция стала приятной. Не упускайте ряд потрясающих возможностей Промо

Внешние источники данных Интеграция Мобильная разработка v8 1cv8.cf Абонемент ($m)

В статье показаны примеры получения данных без программирования на стороне «1С:Предприятие 8». Вам нужно проверить гипотезу и проанализировать данные, почему бы не интегрироваться с Excel? Используете технологии .NET и «1С:Предприятие 8», процесс связывания систем движется катастрофически медленно? Хотите native Android приложение с вашими данными всегда под рукой?

1 стартмани

01.10.2015    54506    44    pbazeliuk    18    

Применение средств MS SQL R service для 1С

Внешние источники данных v8 1cv8.cf Абонемент ($m)

Некоторое время назад Microsoft добавила в MS SQL сервер службы машинного обучения, позволяющие выполнять программный код на языках программирования R и Python. В статье будет продемонстрирована общая схема и принцип того, как можно использовать данные службы в контексте разработки на 1С. 

1 стартмани

25.11.2018    13754    0    Robbi    14    

Интеграция WhatsApp в 1С (botcorp.io и api-messenger.com)

Внешние источники данных v8 Абонемент ($m)

Сейчас у WhatsApp более 1 млрд. пользователей во всём мире. В России мессенджер держится на верхних строчках по популярности среди всех мессенджеров. Из чего следует, что WhatsApp является самым желанным мессенджером для интеграции с 1С.

3 стартмани

22.11.2018    23172    57    17808849    49    

Исправление ошибки универсального обмена Бухгалтерия предприятия, редакция 3.0 (3.0.65.х, расширение конфигурации)

Внешние источники данных Адаптация типовых решений v8 БП3.0 Абонемент ($m)

Уже у третьего клиента вижу ошибку Ошибка проверки данных XDTO: Структура объекта не соответствует типу: {http://www.1c.ru/SSL/Exchange/Message}Header Значит, как говаривал Винни-Пух - это неспроста. Ну и точно неспроста, 1С что-то подшаманили в обмене через универсальный формат.

1 стартмани

19.10.2018    14594    29    capitan    15    

Загрузка документов из системы Emex через веб-сервисы (Коммерция-Автологистика) Промо

Внешние источники данных WEB v8 v8::ОУ УТ10 УУ Абонемент ($m)

Обработка предназначенная для дилеров системы Emex, для загрузки документов из программы Коммерция(Автологистика) в 1С 8.2 Управление торговлей 10. Для загрузки используются веб-сервисы программы Автологистика.

10 стартмани

11.08.2014    19640    2    desarz    1    

Загрузка чека онлайн-касс (загрузка товаров из чека)

Внешние источники данных WEB Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 1cv8.cf Абонемент ($m)

Обработка-пример, позволяет любому и из любой конфигурации загрузить информацию о товарах из чека(и не только) с сервера ФНС proverkacheka.nalog.ru

2 стартмани

08.10.2018    17141    31    echo77    44    

Мониторинг показателей систем 1С 8.3 с помощью Zabbix

Внешние источники данных Zabbix v8 1cv8.cf Абонемент ($m)

Опишу свой опыт мониторинга наших систем 1С с помощью Zabbix и ту пользу, которую можно извлечить из этого.

1 стартмани

05.10.2018    34536    49    akimych    48    

Связка 1С и Telegram. Отправка стикеров

Практика программирования Внешние источники данных v8 v8::УФ 1cv8.cf Абонемент ($m)

В качестве факультатива сейчас изучаю возможности связки 1С и мессенджера Telegram. И возник вопрос, как помимо сообщений, посылать в ответ на действия пользователя произвольный стикер? Решению этой мини задачи и посвящена данная статья.

1 стартмани

31.07.2018    11653    4    Skin123    4    

Оформление ветеринарных документов на продукты питания и грядущие глобальные изменения в 1С (часть 1) Промо

Внешние источники данных Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v8 Сельское хозяйство и рыболовство Оптовая торговля, дистрибуция, логистика Пищевая промышленность УУ Абонемент ($m)

С 01 января 2016 года возможно оформление ветеринарно-сопроводительных документов в электронном виде. Что это означает для предприятий, производящих и торгующих подконтрольной продукцией?

3 стартмани

27.12.2015    59868    7    axxell    28    

Отправка сообщений через Telegram (через прокси)

Внешние источники данных v8 v8::УФ 1cv8.cf Абонемент ($m)

Простая обработка для отправки сообщений из 1с в Телеграм конкретному пользователю. Используя прокси-сервер: jqlwb.teletype

1 стартмани

20.07.2018    15914    14    Deda    12    

Опыт интеграции мессенджера Telegram c 1C

Внешние источники данных Интеграция v8 Абонемент ($m)

Статья будет полезна всем, кто интересуется возможностями интеграции 1С с мессенджером Telegram. Пустовой Вячеслав в формате короткого мастер-класса рассказывает о создании и настройке бота, позволяющего, к примеру, упростить процессы согласования платежей внутри компании, отгрузки со склада или получение оперативной информации о состоянии дебиторской задолженности.

19.07.2018    19876    0    VachKirp    39    

Обмен 1С:Управление Торговлей 11 и Frontol 5

Внешние источники данных Розничная торговля Розничная торговля v8 УТ11 КА2 Розничная и сетевая торговля (FMCG) Абонемент ($m)

Обработка обмена для 1С Управление Торговлей 11 и фронт-кассовой системы Frontol. Отличия от типовой: выгрузка дисконтных карт с накоплениями. Выгрузка категорий товаров.

3 стартмани

14.07.2018    16954    92    Kutuzov    142    

RabbitMQ + 1С. Быстрый старт

Внешние источники данных v8 1cv8.cf Абонемент ($m)

Внешняя компонента для отправки сообщения из 1С в кролика. Сервис прослушивания и перенаправления сообщений из кролика в http или web-сервис.

1 стартмани

10.06.2018    26264    81    Goleff74    40