При попытке открыть документ Начисление зарплаты и взносов возникает ошибка Недопустимое значение параметра (параметр номер '2'). Исправляем за 5 минут

31.05.20

Учетные задачи - Зарплата

Столкнулся с такой ошибкой. Гугл сходу выводит на Инфостарт, где находится подсказка, что для исправления необходимо программно удалить пустую строку из документа, но подробного алгоритма, как это можно сделать, нет. Поэтому оставлю это здесь во имя добра и света. P.S. "В любой непонятной ситуации - делай копию базы".

Итак, исправляем за 5 мин.

В документе «Начисление зарплаты и взносов» эта ошибка возникает, после того как пользователь добавил пустую строку в документ по кнопке «Добавить» и пробует закрыть документ.

 

 

Если в этот момент нажать «Да», все, строка записалась и документ больше не откроется.

При попытке открыть, получим ошибку:

 

 

Теперь спасаем документ и данные в нем. Для этого используем стандартную обработку «Групповое изменение реквизитов».

Администрирование – Обслуживание – Корректировка данных - Групповое изменение реквизитов.

 

 

Отбираем наш документ.

 

 

Идем на вкладку «Выполнить произвольный алгоритм»

 

 

и вставляем следующий код:

//Искать будем пустые строки по колонке «Результат»

СтруктураДляПоиска = Новый Структура("Результат", 0);       

//На вкладке «Начисления»

ТабличнаяЧастьДок = Объект.Начисления;      

//Получаем список строк соответствующих отбору, и перебором удаляем.       

МассивПустыхСтрок = ТабличнаяЧастьДок.НайтиСтроки(СтруктураДляПоиска);      

Для каждого Строка Из МассивПустыхСтрок Цикл      

ТабличнаяЧастьДок.Удалить(Строка);      

КонецЦикла;  

 

 

Нажимаем кнопку «Выполнить», дожидаемся выполнения, затем нажимаем "Готово".

Все. Пустая строка из документа удалена, с ним можно работать дальше.

Начисление зарплаты взносов ошибка недопустимое значение параметра параметр

См. также

Зарплата Регламентированный учет и отчетность Кадровый учет Обновление 1С Бухгалтер Платформа 1С v8.3 Сложные периодические расчеты 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 2.0 1С:Зарплата и Управление Персоналом 2.5 Бухгалтерский учет Налоговый учет Управленческий учет Акцизы ЕНВД ЕСН Земельный налог ИП, ПБОЮЛ, КФХ Налог на имущество Налог на прибыль НДС НДФЛ ФОМС, ЕФС Транспортный налог УСН ПСН (патентная система налогообложения) Платные (руб)

Обновления для конфигураций: КА 1.1; ЗУП 2.5; БУХ 2.0; КА 1.1 Комплексная автоматизация торговли алкогольной продукцией; КА 1.1 Комплексный учет сельскохозяйственного предприятия

19900 руб.

01.04.2020    143511    674    352    

235

Зарплата Роли и права Системный администратор Бухгалтер Платформа 1С v8.3 Бухгалтерский учет Управление правами 1С:Бухгалтерия 3.0 1С:Комплексная автоматизация 2.х Молдова Россия Казахстан Бухгалтерский учет Платные (руб)

Расширение позволяет максимально полно ограничить доступ пользователей к данным по заработной плате, а именно закрывает доступ к документам начисления и выплаты заработной платы, не позволяет просматривать бухгалтерские отчеты по счету учета зарплаты а также убирает зарплатные проводки из журнала проводок. Расширение запрещает просматривать платежные документы на выплату зарплаты, так же не доступны регламентные отчеты в ПФР и ИФНС. Расширение предлагает готовые настроенные профили "Бухгалтер без зарплаты", "Только просмотр без зарплаты".

5700 руб.

27.05.2021    34626    228    89    

183

Зарплата Программист Бизнес-аналитик Бухгалтер Платформа 1С v8.3 1С:Зарплата и кадры государственного учреждения 3 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет Платные (руб)

При заполнении ведомости на выплату зарплаты вылазят задолженности прошлых периодов, которых быть не должно? Наша обработка позволяется убрать эти доходы прошлых периодов за пару секунд. Больше не нужно тратить часы на анализ каждого такого случая.

27600 руб.

14.09.2022    14166    69    26    

71

Перенос данных 1C Зарплата Бюджетный учет Программист Бухгалтер Платформа 1С v8.3 Сложные периодические расчеты 1С:Зарплата и кадры государственного учреждения 3 1С:Зарплата и Управление Персоналом 3.x Государственные, бюджетные структуры Россия Бюджетный учет Платные (руб)

Обработки для быстрого перехода с конфигураций «КАМИН:Расчет зарплаты для бюджетных учреждений 3.5» и «КАМИН:Зарплата для бюджетных учреждений 5.5» на конфигурацию «Зарплата и кадры государственного учреждения».

12000 руб.

28.07.2016    58103    149    141    

126

Зарплата Анализ продаж Бухгалтер Пользователь Оперативный учет 8.3.14 1С:Управление торговлей 11 Управленческий учет Платные (руб)

Мотивация сотрудников в 1С. Автоматизированный расчет управленческой заработной платы для любых должностей коммерческой организации. Для 1С: Управление торговлей 11.4.

12000 руб.

26.05.2021    13504    22    3    

19

Корректировка данных Зарплата Бухгалтер Платформа 1С v8.3 Сложные периодические расчеты 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет НДФЛ Платные (руб)

Обработка исправляет технические ошибки по НДФЛ, взаиморасчетам с сотрудниками в 1С:ЗУП (1С:ЗКГУ) на начало года. Фактически все ошибки, которые проявляются в ведомостях на выплату, расчетных листках, при заполнении ведомостей на выплату и отчетах 6-НДФЛ и т.д. нужно начинать исправлять с начала расчетного года. Это позволит быть уверенными, что после завершения расчетов предыдущего года, начали работать с «чистого листа» без ошибочных остатков.

4800 руб.

06.10.2023    3490    34    17    

42

Корректировка данных Зарплата Бухгалтер Пользователь Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Платные (руб)

Внешняя обработка предназначена для исправления самых различных ошибок, возникших по самым разным причинам. Общее проявление этих ошибок видно в различии данных между: проводками и различными отчетами по НДФЛ, заполнении ведомостей на выдачу зарплаты, неверным расчетом НДФЛ при начислении ЗП и т.д.

3600 руб.

09.02.2024    1292    8    5    

11
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. ixijixi 1833 31.05.20 12:51 Сейчас в теме
Все хорошо, но надо заменить на
СтруктураДляПоиска = Новый Структура("Сотрудник ", Справочники.Сотрудники.ПустаяСсылка())

Ибо в документе могут быть другие значимые строки с нулевым результатом
3. user1024932 83 31.05.20 19:42 Сейчас в теме
(1) Я честно говоря сначала запустил в режиме отладки и посмотрел что не заполнено. Результат выбрал потому что код короче.
2. PerlAmutor 130 31.05.20 15:50 Сейчас в теме
Подтверждаю, в ERP 2.4.10.94 та же самая ошибка. Есть аналогичная в производственном блоке при "раскрутке" этапов из ресурсных спецификаций.

В этом случае строку:

		Если ФизическиеЛицаСотрудников <> Неопределено Тогда
			ЗаполнитьЗначенияСвойств(СтрокаДанных, ФизическиеЛицаСотрудников[СтрокаДанных[ОписаниеТаблицы.ИмяРеквизитаСотрудник]]);
		КонецЕсли;


Можно заменить на:

		Если ФизическиеЛицаСотрудников <> Неопределено Тогда
			ЗаполнитьЗначенияСвойств(СтрокаДанных, Новый Структура("ФизическоеЛицо", ОбщегоНазначенияКлиентСервер.СвойствоСтруктуры(ФизическиеЛицаСотрудников[СтрокаДанных[ОписаниеТаблицы.ИмяРеквизитаСотрудник]], "ФизическоеЛицо", Неопределено));
		КонецЕсли;

(жалко, что в БСП нет функции аналогичной для соответствий, типа ОбщегоНазначенияКлиентСервер.ЗначениеСоответствия(), где можно было бы указать значение по-умолчанию)

Ну или на:

		Если ФизическиеЛицаСотрудников <> Неопределено Тогда
			СтруктураФизЛица = ФизическиеЛицаСотрудников.Получить(СтрокаДанных[ОписаниеТаблицы.ИмяРеквизитаСотрудник]);

			Если ТипЗнч(СтруктураФизЛица ) = Тип("Структура") Тогда
				ЗаполнитьЗначенияСвойств(СтрокаДанных, СтруктураФизЛица);
			КонецЕсли;
		КонецЕсли;
Показать


Вторым параметром метода ЗаполнитьЗначенияСвойств не могут быть типы: Неопределено, Null, Число, Строка, Дата, Булево.

В качестве альтернативного кода для перезаполнения табличной части документа можно использовать ПостроительЗапроса, который возвращает только строки без пустых ссылок в реквизите Сотрудник:

    ДокОбъект = Док.ПолучитьОбъект();

    Построитель = Новый ПостроительЗапроса;

    ТабличнаяЧастьТЗ = ДокОбъект.Начисления.Выгрузить();

    Построитель.ИсточникДанных = Новый ОписаниеИсточникаДанных(ТабличнаяЧастьТЗ);

    СтрокаОтбора               = Построитель.Отбор.Добавить("Сотрудник");
    СтрокаОтбора.ВидСравнения  = ВидСравнения.НеРавно;
    СтрокаОтбора.Значение      = ПредопределенноеЗначение("Справочник.Сотрудники.ПустаяСсылка");
    СтрокаОтбора.Использование = Истина;

    Построитель.Выполнить();
    СтрокиБезПустыхСотрудников = Построитель.Результат.Выгрузить();
    ДокОбъект.Начисления.Загрузить(СтрокиБезПустыхСотрудников);
Показать
Оставьте свое сообщение