Произвольное закрытие 20,25,26 счетов

Публикация № 171719

Разработка - Практика программирования

Каждый программист сталкивался с тем, что штатными средствами распределение затрат происходит не так как требует главный бухгалтер. В этом случае приходится изменять стандартный механизм: изменять модули, создавать собственные документы, или использовать специальные обработки перед выполнением закрытия месяца, что создает сложность в обновлении. Но есть и другой подход...

В данной статье приводится пример на конфигурации "1С: Комплексная автоматизация 1.1" по созданию универсального механизма распределения затрат по 20ым счетам.

Не вдаваясь в подробности "что, как и почему?", начну с описания своих действий. Сразу замечу, что нам также необходимо добавить свои объекты в конфигруцию, но наши изменения никак не будут влиять на сложность последующего обновления конфигурации.

Первое действие: Открываем конфигуратор Smile

В конфигураторе добавляем общий модуль с специфичным названием "Алгоритм_ОбработкаПроведения". Обязательно выставляем: "Сервер" и "Привилегированный". "Сервер" - необходимо чтобы вызов нашего модуля происходил в последнюю очередь.

Добавленный общий модуль

В модуле прописываем следующий код:

/////----------------- Расчет себестоимости	+++

Процедура Алгоритм_ОбработкаПроведения_РасчетСебестоимостиВыпускаОбработкаПроведения(Источник, Отказ, РежимПроведения) Экспорт
	
	ВыбратьИВыполнитьАлгоритмыОчистки(Источник);
	
	ВыбратьИВыполнитьАлгоритмыРасчета(Источник);
	
КонецПроцедуры

Процедура ВыбратьИВыполнитьАлгоритмыОчистки(Источник)

	Запрос = Новый Запрос;
	Запрос.Текст = 
		"ВЫБРАТЬ
		|	Алгоритм_СпособыЗакрытияСебестоимостиСрезПоследних.ХарактерЗатрат,
		|	Алгоритм_СпособыЗакрытияСебестоимостиСрезПоследних.АлгоритмБУ,
		|	Алгоритм_СпособыЗакрытияСебестоимостиСрезПоследних.АлгоритмНУ,
		|	Алгоритм_СпособыЗакрытияСебестоимостиСрезПоследних.АлгоритмБУРАУЗ
		|ИЗ
		|	РегистрСведений.Алгоритм_СпособыЗакрытияСебестоимости.СрезПоследних(&Период, ОчисткаДанных) КАК Алгоритм_СпособыЗакрытияСебестоимостиСрезПоследних";

	Запрос.УстановитьПараметр("Период", КонецМесяца(Источник.Дата));

	Результат = Запрос.Выполнить();

	ВыборкаДетальныеЗаписи = Результат.Выбрать();

	Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
		////+++ Очищаем регистр бухгалтерии
		АлгоритмОчистки_СКД = ВыборкаДетальныеЗаписи.АлгоритмБУ.Получить();
		
		Для каждого АлгоритмОчистки_НаборДанных из АлгоритмОчистки_СКД.НаборыДанных Цикл
			АлгоритмОчистки_Запрос = Новый Запрос(АлгоритмОчистки_НаборДанных.Запрос);
			Для каждого АлгоритмОчистки_Праметры из АлгоритмОчистки_СКД.Параметры Цикл
				АлгоритмОчистки_Запрос.УстановитьПараметр(АлгоритмОчистки_Праметры.Имя, АлгоритмОчистки_Праметры.Значение);
			КонецЦикла;
			АлгоритмОчистки_Запрос.УстановитьПараметр("НачалоПериода", НачалоМесяца(Источник.Дата));
			АлгоритмОчистки_Запрос.УстановитьПараметр("КонецПериода", КонецМесяца(Источник.Дата));
			АлгоритмОчистки_Запрос.УстановитьПараметр("НачалоПериодаГраница", Новый Граница(НачалоМесяца(Источник.Дата), ВидГраницы.Включая));
			АлгоритмОчистки_Запрос.УстановитьПараметр("КонецПериодаГраница", Новый Граница(КонецМесяца(Источник.Дата), ВидГраницы.Включая));
			АлгоритмОчистки_Запрос.УстановитьПараметр("Регистратор", Источник.Ссылка);
			
			АлгоритмОчистки_Хозрасчетный = Источник.Движения.Хозрасчетный;
			АлгоритмОчистки_Хозрасчетный.Прочитать();
			
			АлгоритмОчистки_Выборка = АлгоритмОчистки_Запрос.Выполнить().Выбрать();
			Пока АлгоритмОчистки_Выборка.Следующий() Цикл
				НомерСтроки = АлгоритмОчистки_Выборка.НомерСтроки - 1;
				АлгоритмОчистки_Хозрасчетный.Удалить(НомерСтроки);
			КонецЦикла;
			Попытка АлгоритмОчистки_Хозрасчетный.Записать(); Исключение
				Сообщить("Ошибки в алгоритме очистки регистра",СтатусСообщения.ОченьВажное);
			КонецПопытки;
		КонецЦикла;
		////--- Очищаем регистр бухгалтерии
		
		////+++ Очищаем регистр налоговый
		АлгоритмОчистки_СКД = ВыборкаДетальныеЗаписи.АлгоритмНУ.Получить();
		
		Для каждого АлгоритмОчистки_НаборДанных из АлгоритмОчистки_СКД.НаборыДанных Цикл
			АлгоритмОчистки_Запрос = Новый Запрос(АлгоритмОчистки_НаборДанных.Запрос);
			Для каждого АлгоритмОчистки_Праметры из АлгоритмОчистки_СКД.Параметры Цикл
				АлгоритмОчистки_Запрос.УстановитьПараметр(АлгоритмОчистки_Праметры.Имя, АлгоритмОчистки_Праметры.Значение);
			КонецЦикла;
			АлгоритмОчистки_Запрос.УстановитьПараметр("НачалоПериода", НачалоМесяца(Источник.Дата));
			АлгоритмОчистки_Запрос.УстановитьПараметр("КонецПериода", КонецМесяца(Источник.Дата));
			АлгоритмОчистки_Запрос.УстановитьПараметр("НачалоПериодаГраница", Новый Граница(НачалоМесяца(Источник.Дата), ВидГраницы.Включая));
			АлгоритмОчистки_Запрос.УстановитьПараметр("КонецПериодаГраница", Новый Граница(КонецМесяца(Источник.Дата), ВидГраницы.Включая));
			АлгоритмОчистки_Запрос.УстановитьПараметр("Регистратор", Источник.Ссылка);
			
			АлгоритмОчистки_Налоговый = Источник.Движения.Налоговый;
			АлгоритмОчистки_Налоговый.Прочитать();
			
			АлгоритмОчистки_Выборка = АлгоритмОчистки_Запрос.Выполнить().Выбрать();
			Пока АлгоритмОчистки_Выборка.Следующий() Цикл
				НомерСтроки = АлгоритмОчистки_Выборка.НомерСтроки - 1;
				АлгоритмОчистки_Налоговый.Удалить(НомерСтроки);
			КонецЦикла;
			АлгоритмОчистки_Налоговый.Записать();
		КонецЦикла;
		////--- Очищаем регистр налоговый
		
		////+++ Очищаем регистр РАУЗРегл
		АлгоритмОчистки_СКД = ВыборкаДетальныеЗаписи.АлгоритмБУРАУЗ.Получить();
		
		Для каждого АлгоритмОчистки_НаборДанных из АлгоритмОчистки_СКД.НаборыДанных Цикл
			АлгоритмОчистки_Запрос = Новый Запрос(АлгоритмОчистки_НаборДанных.Запрос);
			Для каждого АлгоритмОчистки_Праметры из АлгоритмОчистки_СКД.Параметры Цикл
				АлгоритмОчистки_Запрос.УстановитьПараметр(АлгоритмОчистки_Праметры.Имя, АлгоритмОчистки_Праметры.Значение);
			КонецЦикла;
			АлгоритмОчистки_Запрос.УстановитьПараметр("НачалоПериода", НачалоМесяца(Источник.Дата));
			АлгоритмОчистки_Запрос.УстановитьПараметр("КонецПериода", КонецМесяца(Источник.Дата));
			АлгоритмОчистки_Запрос.УстановитьПараметр("НачалоПериодаГраница", Новый Граница(НачалоМесяца(Источник.Дата), ВидГраницы.Включая));
			АлгоритмОчистки_Запрос.УстановитьПараметр("КонецПериодаГраница", Новый Граница(КонецМесяца(Источник.Дата), ВидГраницы.Включая));
			АлгоритмОчистки_Запрос.УстановитьПараметр("Регистратор", Источник.Ссылка);
			
			АлгоритмОчистки_УчетЗатратРегл = Источник.Движения.УчетЗатратРегл;
			АлгоритмОчистки_УчетЗатратРегл.Прочитать();
			
			АлгоритмОчистки_Выборка = АлгоритмОчистки_Запрос.Выполнить().Выбрать();
			Пока АлгоритмОчистки_Выборка.Следующий() Цикл
				НомерСтроки = АлгоритмОчистки_Выборка.НомерСтроки - 1;
				АлгоритмОчистки_УчетЗатратРегл.Удалить(НомерСтроки);
			КонецЦикла;
			АлгоритмОчистки_УчетЗатратРегл.Записать();
		КонецЦикла;
		////--- Очищаем регистр РАУЗРегл
	КонецЦикла;

КонецПроцедуры
	
Процедура ВыбратьИВыполнитьАлгоритмыРасчета(Источник)
	
	Запрос = Новый Запрос;
	Запрос.Текст = 
		"ВЫБРАТЬ
		|	Алгоритм_СпособыЗакрытияСебестоимостиСрезПоследних.ХарактерЗатрат,
		|	Алгоритм_СпособыЗакрытияСебестоимостиСрезПоследних.АлгоритмБУ,
		|	Алгоритм_СпособыЗакрытияСебестоимостиСрезПоследних.АлгоритмНУ,
		|	Алгоритм_СпособыЗакрытияСебестоимостиСрезПоследних.АлгоритмБУРАУЗ
		|ИЗ
		|	РегистрСведений.Алгоритм_СпособыЗакрытияСебестоимости.СрезПоследних(&Период, (НЕ ОчисткаДанных)) КАК Алгоритм_СпособыЗакрытияСебестоимостиСрезПоследних";

	Запрос.УстановитьПараметр("Период", КонецМесяца(Источник.Дата));

	Результат = Запрос.Выполнить();

	ВыборкаДетальныеЗаписи = Результат.Выбрать();

	Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
		////+++ Пишем регистр бухгалтерии
		АлгоритмЗаполнения_СКД = ВыборкаДетальныеЗаписи.АлгоритмБУ.Получить();
		
		Для каждого АлгоритмЗаполнения_НаборДанных из АлгоритмЗаполнения_СКД.НаборыДанных Цикл
			АлгоритмЗаполнения_Запрос = Новый Запрос(АлгоритмЗаполнения_НаборДанных.Запрос);
			Для каждого АлгоритмЗаполнения_Праметры из АлгоритмЗаполнения_СКД.Параметры Цикл
				АлгоритмЗаполнения_Запрос.УстановитьПараметр(АлгоритмЗаполнения_Праметры.Имя, АлгоритмЗаполнения_Праметры.Значение);
			КонецЦикла;
			АлгоритмЗаполнения_Запрос.УстановитьПараметр("НачалоПериода", НачалоМесяца(Источник.Дата));
			АлгоритмЗаполнения_Запрос.УстановитьПараметр("КонецПериода", КонецМесяца(Источник.Дата));
			АлгоритмЗаполнения_Запрос.УстановитьПараметр("НачалоПериодаГраница", Новый Граница(НачалоМесяца(Источник.Дата), ВидГраницы.Включая));
			АлгоритмЗаполнения_Запрос.УстановитьПараметр("КонецПериодаГраница", Новый Граница(КонецМесяца(Источник.Дата), ВидГраницы.Включая));
			АлгоритмЗаполнения_Запрос.УстановитьПараметр("Регистратор", Источник.Ссылка);
			
			АлгоритмЗаполнения_Хозрасчетный = Источник.Движения.Хозрасчетный;
			АлгоритмЗаполнения_Хозрасчетный.Прочитать();
			
			АлгоритмЗаполнения_Выборка = АлгоритмЗаполнения_Запрос.Выполнить().Выбрать();
			Пока АлгоритмЗаполнения_Выборка.Следующий() Цикл
				АлгоритмЗаполнения_Запись = АлгоритмЗаполнения_Хозрасчетный.Добавить();
				ЗаполнитьЗначенияСвойств(АлгоритмЗаполнения_Запись, АлгоритмЗаполнения_Выборка);
				Для и1 = 1 по 3 Цикл
					Попытка
						Знач_Субк = АлгоритмЗаполнения_Выборка["СубконтоДт"+и1];
						СчетДт = АлгоритмЗаполнения_Выборка["СчетДт"];
						ВидСубконто = ОпределитьВидСубконто(СчетДт, Знач_Субк);
						Если не ВидСубконто = неопределено Тогда
							АлгоритмЗаполнения_Запись.СубконтоДт.Вставить(ВидСубконто, Знач_Субк);
						КонецЕсли;
					Исключение КонецПопытки;
					
					Попытка
						Знач_Субк = АлгоритмЗаполнения_Выборка["СубконтоКт"+и1];
						СчетКт = АлгоритмЗаполнения_Выборка["СчетКт"];
						ВидСубконто = ОпределитьВидСубконто(СчетКт, Знач_Субк);
						Если не ВидСубконто = неопределено Тогда
							АлгоритмЗаполнения_Запись.СубконтоКт.Вставить(ВидСубконто, Знач_Субк);
						КонецЕсли;
					Исключение КонецПопытки;
				КонецЦикла;
			КонецЦикла;
			АлгоритмЗаполнения_Хозрасчетный.Записать();
		КонецЦикла;
		////--- Пишем регистр бухгалтерии
		
		////+++ Пишем регистр налоговый
		АлгоритмЗаполнения_СКД = ВыборкаДетальныеЗаписи.АлгоритмНУ.Получить();
		
		Для каждого АлгоритмЗаполнения_НаборДанных из АлгоритмЗаполнения_СКД.НаборыДанных Цикл
			АлгоритмЗаполнения_Запрос = Новый Запрос(АлгоритмЗаполнения_НаборДанных.Запрос);
			Для каждого АлгоритмЗаполнения_Праметры из АлгоритмЗаполнения_СКД.Параметры Цикл
				АлгоритмЗаполнения_Запрос.УстановитьПараметр(АлгоритмЗаполнения_Праметры.Имя, АлгоритмЗаполнения_Праметры.Значение);
			КонецЦикла;
			АлгоритмЗаполнения_Запрос.УстановитьПараметр("НачалоПериода", НачалоМесяца(Источник.Дата));
			АлгоритмЗаполнения_Запрос.УстановитьПараметр("КонецПериода", КонецМесяца(Источник.Дата));
			АлгоритмЗаполнения_Запрос.УстановитьПараметр("НачалоПериодаГраница", Новый Граница(НачалоМесяца(Источник.Дата), ВидГраницы.Включая));
			АлгоритмЗаполнения_Запрос.УстановитьПараметр("КонецПериодаГраница", Новый Граница(КонецМесяца(Источник.Дата), ВидГраницы.Включая));
			АлгоритмЗаполнения_Запрос.УстановитьПараметр("Регистратор", Источник.Ссылка);
			
			АлгоритмЗаполнения_Налоговый = Источник.Движения.Налоговый;
			АлгоритмЗаполнения_Налоговый.Прочитать();
			
			АлгоритмЗаполнения_Выборка = АлгоритмЗаполнения_Запрос.Выполнить().Выбрать();
			Пока АлгоритмЗаполнения_Выборка.Следующий() Цикл
				АлгоритмЗаполнения_Запись = АлгоритмЗаполнения_Налоговый.Добавить();
				ЗаполнитьЗначенияСвойств(АлгоритмЗаполнения_Запись, АлгоритмЗаполнения_Выборка);
				Для и1 = 1 по 3 Цикл
					Попытка
						Знач_Субк = АлгоритмЗаполнения_Выборка["СубконтоДт"+и1];
						СчетДт = АлгоритмЗаполнения_Выборка["СчетДт"];
						ВидСубконто = ОпределитьВидСубконто(СчетДт, Знач_Субк);
						Если не ВидСубконто = неопределено Тогда
							АлгоритмЗаполнения_Запись.СубконтоДт.Вставить(ВидСубконто, Знач_Субк);
						КонецЕсли;
					Исключение КонецПопытки;
					
					Попытка
						Знач_Субк = АлгоритмЗаполнения_Выборка["СубконтоКт"+и1];
						СчетКт = АлгоритмЗаполнения_Выборка["СчетКт"];
						ВидСубконто = ОпределитьВидСубконто(СчетКт, Знач_Субк);
						Если не ВидСубконто = неопределено Тогда
							АлгоритмЗаполнения_Запись.СубконтоКт.Вставить(ВидСубконто, Знач_Субк);
						КонецЕсли;
					Исключение КонецПопытки;
				КонецЦикла;
			КонецЦикла;
			АлгоритмЗаполнения_Налоговый.Записать();
		КонецЦикла;
		////--- Пишем регистр налоговый
		
		////+++ Пишем регистр РАУЗРегл
		АлгоритмЗаполнения_СКД = ВыборкаДетальныеЗаписи.АлгоритмБУРАУЗ.Получить();
		
		Для каждого АлгоритмЗаполнения_НаборДанных из АлгоритмЗаполнения_СКД.НаборыДанных Цикл
			АлгоритмЗаполнения_Запрос = Новый Запрос(АлгоритмЗаполнения_НаборДанных.Запрос);
			Для каждого АлгоритмЗаполнения_Праметры из АлгоритмЗаполнения_СКД.Параметры Цикл
				АлгоритмЗаполнения_Запрос.УстановитьПараметр(АлгоритмЗаполнения_Праметры.Имя, АлгоритмЗаполнения_Праметры.Значение);
			КонецЦикла;
			АлгоритмЗаполнения_Запрос.УстановитьПараметр("НачалоПериода", НачалоМесяца(Источник.Дата));
			АлгоритмЗаполнения_Запрос.УстановитьПараметр("КонецПериода", КонецМесяца(Источник.Дата));
			АлгоритмЗаполнения_Запрос.УстановитьПараметр("НачалоПериодаГраница", Новый Граница(НачалоМесяца(Источник.Дата), ВидГраницы.Включая));
			АлгоритмЗаполнения_Запрос.УстановитьПараметр("КонецПериодаГраница", Новый Граница(КонецМесяца(Источник.Дата), ВидГраницы.Включая));
			АлгоритмЗаполнения_Запрос.УстановитьПараметр("Регистратор", Источник.Ссылка);
			
			АлгоритмЗаполнения_УчетЗатратРегл = Источник.Движения.УчетЗатратРегл;
			АлгоритмЗаполнения_УчетЗатратРегл.Прочитать();
			
			АлгоритмЗаполнения_Выборка = АлгоритмЗаполнения_Запрос.Выполнить().Выбрать();
			Пока АлгоритмЗаполнения_Выборка.Следующий() Цикл
				АлгоритмЗаполнения_Запись = АлгоритмЗаполнения_УчетЗатратРегл.Добавить();
				ЗаполнитьЗначенияСвойств(АлгоритмЗаполнения_Запись, АлгоритмЗаполнения_Выборка);
			КонецЦикла;
			АлгоритмЗаполнения_УчетЗатратРегл.Записать();
		КонецЦикла;
		////--- Пишем регистр РАУЗРегл
		
	КонецЦикла;
	
КонецПроцедуры
 
Функция ОпределитьВидСубконто(Счет, Знач_Субк) Экспорт
	
	Результат = Неопределено;
	ТипЗнчСК = ТипЗнч(Знач_Субк);
	Для каждого ВС из Счет.ВидыСубконто Цикл
		Если ВС.ВидСубконто.ТипЗначения.СодержитТип(ТипЗнчСК) Тогда
			Результат = ВС.ВидСубконто;
			Прервать;
		КонецЕсли;
	КонецЦикла;
	
	Возврат Результат;
	
КонецФункции

/////----------------- Расчет себестоимости	---

Подробные разъяснения по представленному коду давать особого смысла не вижу смысла. т.к. по окнчании статьи станет ясен каждый выполненный шаг. А что происходит в приведенном модуле примерно ясно по коду, даже на первый взгляд.

А в кратце так:

  1. Сначала ищем актуальный на текущий месяц алгоритм очистки регистров
  2. Выполняем непосредственное удаление записей по фильтру
  3. Ищем актуальный на текущий месяц алгоритм распределения
  4. Последовательно перебираем все запросы в СКД по определенному разделу учета. Производим заполнение параметров и выполнеям. Ничего осверхъестественного. Условности есть только в специфичных бухгалтерских регистрах, что видно по коду
Удобство данный схемы работы заключается в возможности отлдаки запроса в режиме предприятия через консоль. При желании можно доработать, добавив внешний источник данных и ввода произвольных дополнительных параметров.
 

Второе действие:

Добавляем подписку на событие. Источник - документ производящий стандартное распределение 20ых счетов (мой случай: "РасчетСебестоимостиВыпуска"). Событие - ОбработкаПроведения. Обработчик - указываем нашу процедуру в созданном общем модуле (Алгоритм_ОбработкаПроведения_РасчетСебестоимостиВыпускаОбработкаПроведения - точка входа).

Добавленная подписка на собтие

На текущем этапе у нас есть модуль, который срабатавает при рспределении затрат. Но так и нет механизма, который бы отработал и распределил затраты так как надо нам.

Третие действие:

Добавляем регистр сведений "Алгоритм_СпособыЗакрытияСебестоимости". Устанавливаем периодичность "Месяц", режим записи "независимый". Добавляем ресурсы "АлгоритмБУ, АлгоритмНУ, АлгоритмБУРАУЗ" тип "ХранилищеЗначения". Измерения хоть у меня и добавлены, практическое применение они не имеют. В реквизиты добавляем "Описание" - строка, "ОчисткаДанных"- булево. Собственно информация из этого регистра и будет использоваться для выполнения распределения.

Добавленный регистр сведений

Но чтоб нам было понятно что там будет храниться и как с этим работать выполним следующий шаг.

Четвертый шаг:

Добавляем форму записи для регистра сведений, примерно следующего вида (но, в принципе, у каждого человека своя фантазия Wink ):

Форма записи регистра сведений

В форме редактирование ресурсов организуем через элемент надпись с свойством гиперссылка. По нажатии на надпись выдается стандартное окно СКД, в котором и будем в последующим указывать что и как делать.

Модуль формы:

Перем ВыбраннаяСКД;

Процедура ОбработкаВыбора(ЗначениеВыбора, Источник)
	
	Если Тип(ЗначениеВыбора) = Тип("СхемаКомпоновкиДанных") Тогда
		
		Если ВыбраннаяСКД = "АлгоритмБУ" Тогда
			АлгоритмБУ = Новый ХранилищеЗначения(ЗначениеВыбора);
		ИначеЕсли ВыбраннаяСКД = "АлгоритмБУРАУЗ" Тогда
			АлгоритмБУРАУЗ = Новый ХранилищеЗначения(ЗначениеВыбора);
		ИначеЕсли ВыбраннаяСКД = "АлгоритмНУ" Тогда
			АлгоритмНУ = Новый ХранилищеЗначения(ЗначениеВыбора);
		КонецЕсли;
		
	КонецЕсли;
	
КонецПроцедуры

Процедура НадписьАлгоритмРаспределенияБУНажатие(Элемент)
	
	СКД = АлгоритмБУ.Получить();
	Если СКД = Неопределено Тогда
		СКД = Новый СхемаКомпоновкиДанных;
	КонецЕсли;
	
	ВыбраннаяСКД = "АлгоритмБУ";
	
	// Вызовем конструктор для интерактивного изменения СКД
	КонструкторСКД = Новый КонструкторСхемыКомпоновкиДанных(СКД);
	КонструкторСКД.Редактировать(ЭтаФорма);
		
КонецПроцедуры

Процедура НадписьАлгоритмРаспределенияБУРАУЗНажатие(Элемент)
	
	СКД = АлгоритмБУРАУЗ.Получить();
	Если СКД = Неопределено Тогда
		СКД = Новый СхемаКомпоновкиДанных;
	КонецЕсли;
	
	ВыбраннаяСКД = "АлгоритмБУРАУЗ";
	
	// Вызовем конструктор для интерактивного изменения СКД
	КонструкторСКД = Новый КонструкторСхемыКомпоновкиДанных(СКД);
	КонструкторСКД.Редактировать(ЭтаФорма);
		
КонецПроцедуры

Процедура АлгоритмРаспределенияНУНажатие(Элемент)
	
	СКД = АлгоритмНУ.Получить();
	Если СКД = Неопределено Тогда
		СКД = Новый СхемаКомпоновкиДанных;
	КонецЕсли;
	
	ВыбраннаяСКД = "АлгоритмНУ";
	
	// Вызовем конструктор для интерактивного изменения СКД
	КонструкторСКД = Новый КонструкторСхемыКомпоновкиДанных(СКД);
	КонструкторСКД.Редактировать(ЭтаФорма);
		
КонецПроцедуры

Ну вот вроде бы и всё, осталось сохранить конфигурацию, обновить информационную базу, и написать собственный запрос на распределение, использую всё удобство и всю мощь формирования запросов СКД Smile

СКД в режиме предприятия

Пример запроса для "Алгоритм распределения БУ":

ВЫБРАТЬ
	ХозрасчетныйОстатки.Счет КАК СчетКт,
	&Счет_90021 КАК СчетДт,
	ХозрасчетныйОстатки.Субконто1 КАК СубконтоКт1,
	ХозрасчетныйОстатки.Субконто2 КАК СубконтоКт2,
	ХозрасчетныйОстатки.Субконто2 КАК СубконтоДт1,
	ХозрасчетныйОстатки.Организация КАК Организация,
	ХозрасчетныйОстатки.СуммаОстаток КАК Сумма,
	&КонецПериода КАК Период,
	"Закрытие Выполнение услуг" КАК Содержание
ИЗ
	РегистрБухгалтерии.Хозрасчетный.Остатки(&КонецПериодаГраница, Счет В ИЕРАРХИИ (&Счет_20), , Субконто2 В ИЕРАРХИИ (&СубконтоНГ)) КАК ХозрасчетныйОстатки

В приведенном коде возможно имеются некоторые ошибки, связанные с упрощением механизма работы, т.к. пример взят из рабочей базы, где был первоначально реализован проект. Но, тем не менее, я думаю, данная статья будет всё-таки полезна и принесет свою лепту в развитие метода доработки стандартной 1С.

Всем спасибо за прочтение и внимание, и извиниюсь, что статья довльна сжата (упускаются многие моменты выбора решения применения технологий).


PS

Спасибо за оставленные комментарии, в которых обсалютно верно было замечено, что здесь приведена только реализация, а вот когда и зачем этот механизм использовать не сказано.

Мысль реализовать подобное решение возникала уже давно, но раньше хватало возможностей всё необходимое вывернуть из стандартного механизма (хотя кое-что и приходилось дописывать в модулях). Но чем дальше, тем хуже... Сейчас работаю во франчайзе, встречаются различные конторы, и ,что самое поразительное, вопрос о себестоимости встает очень часто. И часто слышу следующее: "Хорошо, стандартный механизм работает, но мы по-другому производим распределение затратных счетов, как быть?". А что самое главное, ошибки в их методике нет, просто она, в основном, ориентирована на возможность собрать данные для финансовой отчетности (рентабельности не только производства в целом, а в отдельности по каждому направлению, продукции направления в разрезе всех затрат). Еще одно важное свойство - возможность ведения НЗП даже в бухгалтерии. При этом Вы полностью самостоятельно определяете по каким правилам это всё происходит. И заметим, что если в "1С:Бухгалтеия 2.0" еще можно сделать операции вручную, то уже в комплексной, при включенном РАУЗ, распределение затрат произвольным способом не представляется возможным.

Внедряя данный механизм на предприятии, мы получили большой плюс в уходе от ручного труда: планово-экономический отдел, также как и заместители главного бухгалтера, смогли отказаться от части своих excel-документов. Что значительно повышает достоверность данных, да и время на получение этих данных значительно сократилось. А значит, данный механизм, смог повысить эффективность работы предприяти в целом.

Но, как и всегда, есть и ложка дёгтя: для настройки и правильной работы механизма требуется не просто программист 1С, а программист, который хоть что-то понимает в бухгалтерском учете. А если конфигурация будет КА или УПП, то тут еще сложнее...

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Lukich66 82 01.02.13 19:29 Сейчас в теме
из анекдота. Говорят изобрели новый способ делать детей. Хм,а чем старый то плох?
В пятницу вечером оч. тяжело разбираться в тонкостях распределения с/с по 20му счету. Первое впечатление: человек Вы явно смелый и одаренный несомненно,но замахнуться на самое святое в 1с-себестоимость? Подвергнуть сомнению их методику? Кто это у Вас за главбух?
3. redwonder87 28 04.02.13 06:54 Сейчас в теме
(1) мысль реализовать подобное решение возникала уже давно, но раньше хватало возможностей всё необходимое вывернуть из стандартного механизма (хотя кое-что и приходилось дописывать в модулях). Но чем дальше, тем хуже... Сейчас работаю во франчайзе, встречаются различные конторы, и ,что самое поразительное, вопрос о себестоимости встает очень часто. И часто слышу следующее: "Хорошо, стандартный механизм работает, но мы по-другому производим распределение затратных счетов, как быть?". А что самое главное, ошибки в их методике нет, просто она, в основном, ориентирована на возможность собрать данные для финансовой отчетности (рентабельности не только производства в целом, а в отдельности по каждому направлению, продукции направления в разрезе всех затрат). Еще одно важное свойство - возможность ведения НЗП даже в бухгалтерии. При этом Вы полностью самостоятельно определяете по каким прпавилам это всё происходит.
Lukich66; +1 Ответить
5. Lukich66 82 04.02.13 12:09 Сейчас в теме
(3) redwonder87, добрый день. Пожалуй могу и согласиться с Вами. Взять хотя бы с/хозяйство- здесь незавершенки пруд пруди,схем закрытия как тетя Катя захочет. Например от затрат дойного стада нужно 10% отдать на приплод молодняка. Типовой схемой - это множественный подбор плановой стоимости выхода 11/20.01- а у Вас это чем-то можно предусмотреть? И все-таки механизм реализации довольно-таки сложен,не вникнув в него, по-легкому не внедрить( надо же еще и Бухов с ним познакомить). Кстати в 3-ей версии БП с/с поимела отличия,насколько принципиальные еще не изучали?
7. redwonder87 28 06.02.13 06:24 Сейчас в теме
(5) нет 3ью версию не смотрел. Т.е. видел интерфейс, но устанавливать и настраивать еще не приходилось.
10. ula1c 01.03.13 23:57 Сейчас в теме
(7) redwonder87, хотелось бы все-таки увидеть описания вашего примера использования произвольного закрытия, с аргументацией и доводами невозможности использования стандартного механизма.
11. redwonder87 28 05.03.13 16:39 Сейчас в теме
(10) Реальная задача:
Затраты с 25 счета должны распределиться на 20 счет по номенклатурным группам, у которых стоит свойство производственные, в статью "прямые распределяемые". После на 20 счете затраты по НГ "Проектные" должны распределиться пропорционально на НГ со свойством "проектные", а проектные НГ должны закрываться полностью только если была реализация по этой НГ. Всё остальное распределяется и закрывается по стандартной схеме, но не трогая вышеупомянутые объекты.
Вот такое вот строительство долгосрочных объектов с НЗП.
2. TODD22 18 01.02.13 19:50 Сейчас в теме
А можете рассказать чем ваш механизм выгодно отличается от механизма 1С? То есть в чём профит? А то только реализацию описали.
4. redwonder87 28 04.02.13 07:12 Сейчас в теме
(2) TODD22, исходя из предыдущего моего комментария, получаем - остаток НЗП. А также возможность распределения статей затрат по определенным номенклатурным группам в строго определенные подразделения, а не валом размазывать... А значит мы получаем не просто затраты, а корректный финансовый результат на основании которого могут работать экономисты без дополнительных трудозатрат. Также бывают ситуации, когда есть расходы по НГ, по которым нет не выпуска, не реализации. Но затраты по этой группе должны распределяться на выпуск или реализацию, да еще не прямопропорционально, а в определенной зависимости именно по подразделениям. Но это только то, с чем мне приходилось сталкиваться. Подобных задач на самом деле много, и они часто возникают, но сложность их реализации заставляет компании отказываться от автоматизации, перекладывая данные проблемы на плечи своих сотрудников (и тут появляется "всемогущий" excel).
8. Константин С. 666 15.02.13 14:05 Сейчас в теме
(2) TODD22, И еще навивает на мысль о не полном знании типового механизна. Который позволяет создать "Способ распределения" с собственным запросом. Не зачем залезать во внутрь)))
9. TODD22 18 15.02.13 17:23 Сейчас в теме
(8) часто такое встречаю... когда можно решить типовым функционалом, кто нибудь обязательно что нибудь допишет :)
Прежде чем что то дописать нужно наверное мат. часть учить... ну и не забывать мантру программиста... читать её каждый день 10 раз до начала работы: "Я не буду изобретать велосипед, я возьму готовый и согну как мне нужно" я думаю где то через неделю должно придти "просветление". А если практиковать от полугода то вполне может быть что всевышней одарит программиста лучезарной кармой.
18. Светлый ум 261 19.07.16 17:50 Сейчас в теме
(8) Константин С., Это как приведите пример если не трудно:
- куда запрос втыкать?
6. TODD22 18 05.02.13 18:15 Сейчас в теме
Также бывают ситуации, когда есть расходы по НГ, по которым нет не выпуска, не реализации.

Это скорее не правильно поставленный учёт или незнание конфигурации.
А также возможность распределения статей затрат по определенным номенклатурным группам в строго определенные подразделения, а не валом размазывать...

А типовая разве так не умеет? У затраты мы указываем подразделение и НГ. И соответствующим образом настраиваем способы распределения.
Подобных задач на самом деле много, и они часто возникают, но сложность их реализации заставляет компании отказываться от автоматизации, перекладывая данные проблемы на плечи своих сотрудников (и тут появляется "всемогущий" excel).

Скорее всего такие задачи возникают из за плохого знания теории производственного учёта и расчета СС.
И как верно подмечено "И схем закрытия "Как тетя Катя захочет".

А так разработка зачётная.
irishka77; l-Rain; Lukich66; +3 Ответить
12. WildFire 23.04.13 10:58 Сейчас в теме
Я так понимаю, эта разработка исключительно под РАУЗ? Ведь при партионке никакого закрытия затратных счетов не существует вовсе. Подписку на событие попросту не к чему цеплять и т.д.
13. Ele1234567 23.12.13 11:56 Сейчас в теме
14. soba 03.03.15 23:51 Сейчас в теме
Некоторые картинки с внешнего хостинга не отображаются. Перезалейте, пожалуйста
15. freep777 05.03.15 07:28 Сейчас в теме
Картинки не отображаются (некоторые)!
16. Swetlana 13 05.03.15 14:51 Сейчас в теме
тоже интересно было бы просмотреть полностью статью
17. Raimz 1 06.08.15 09:41 Сейчас в теме
Та же самая проблема! Перезалейте статью или линк на файл .doc ;)
Оставьте свое сообщение

См. также

Использование программных перечислений, ч.1: строковые константы Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Часто ли у вас возникает необходимость в коде выполнять сравнение на строку?

10.12.2016    37819    unichkin    74    

Базовые вещи БСП, которые облегчат жизнь программисту 1С

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Россия Бесплатно (free)

В данной публикации я опишу полезные процедуры и функции модуля общего назначения библиотеки стандартных подсистем, обязательные к использованию любым программистом 1С.

30.08.2020    8002    quazare    33    

Программная работа с настройками СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Нюансы программной работы с настройками системы компоновки данных в отчетах и динамических списках. Обзор всех видов настроек компоновки. Что в каких случаях правильно применять. В качестве примера рассмотрена работа с отборами и группировками.

27.01.2020    30921    ids79    26    

"Секреты" закрытия месяца в 1С:ERP

Закрытие периода v8 ERP2 Россия БУ НУ Бесплатно (free)

В рамках данной статьи мне хотелось обобщить в одном месте накопленную информацию по закрытию периода в 1С:ERP. Цель – дать консультанту, внедряющему регламентированный учет и расчет себестоимости в 1С:ERP, инструмент, с помощью которого он сможет понять, на основании чего в Закрытии месяца появляются те или иные операции, какие регистры анализирует система, какие действия должны быть выполнены по результатам.

22.01.2020    33368    1СERP    56    

Вспомогательные инструкции в коде 1С Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    31024    tormozit    100    

[СКД] Программное создание схемы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Сделаем отчет на СКД полностью программно, без использования макета "схема компоновки данных".

15.01.2020    26620    John_d    22    

Последовательности событий при проведении документа 1С. Шпаргалка + про формы + про расширения

Практика программирования v8 Россия Бесплатно (free)

Собрал информацию о событиях/подписках/расширениях в одном месте.

30.12.2019    20296    kuzyara    38    

30 задач. Странных и не очень

Практика программирования v8 Бесплатно (free)

30 задач на знание языка программирования 1С и некоторого поведения платформы. Маленьких. Странных и не очень.

02.12.2019    17708    YPermitin    72    

Оформление и рефакторинг сложных логических выражений Промо

Практика программирования v8 Россия Бесплатно (free)

В сложных логических выражениях нередко самому автору спустя какое-то время тяжело разобраться, не говоря уже о других программистах. Предлагаемая методика позволяет повысить наглядность таких выражений путем оформления в виде И-ИЛИ дерева и одновременно выполнять их рефакторинг.

20.09.2012    78530    tormozit    131    

Как передать IP адрес, который вызвал HTTP запрос в 1C (для веб-сервера Apache)

Практика программирования v8 Бесплатно (free)

Столкнулся с задачей получения IP адреса, который вызывает http сервис 1С. Итак, решение:

22.11.2019    8834    Sibars    19    

Полезные процедуры и функции для программиста

Практика программирования Универсальные функции v8 1cv8.cf Россия Бесплатно (free)

Все мы пишем программный код и часто используем процедуры, облегчающие его написание. Ниже приведена выборка таких полезных процедур и функций.

07.10.2019    30973    HostHost    40    

Таблица значений. Нюансы

Практика программирования v8 Бесплатно (free)

Обзор некоторых аспектов использования общеизвестного инструмента 1С.

01.10.2019    35841    Yashazz    50    

Запись значения в поле ввода/формы со срабатыванием события ПриИзменении Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Иногда возникает необходимость после записи значения в какое либо поле ввода/формы вызвать для него обработчик события ПриИзменении, а о вызове самого события приходится только мечтать. В этой статье приводится программный способ вызова этого события.

11.07.2007    49082    tormozit    42    

О программе Postman для тестирования API и для чего она нужна 1С-нику

Практика программирования Программное обеспечение (software) v8 Бесплатно (free)

Для чего нужна программа Postman для тестирования API и какая от него польза для 1С-программиста.

24.09.2019    12765    budidich    28    

[Шпаргалка] Программное создание элементов формы

Практика программирования Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Программное создание практически всех популярных элементов формы.

06.09.2019    55930    rpgshnik    63    

Агрегатные функции СКД, о которых мало кто знает

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    52795    ids79    54    

Как сделать из &НаКлиентеНаСервереБезКонтекста почти &НаКлиентеНаСервере Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Как сделать метод формы, доступный на клиенте и на сервере одновременно, и сохранить при этом удобство разработки

10.09.2017    45535    tormozit    74    

Регистры бухгалтерии. Общая информация

Практика программирования Математика и алгоритмы v8 v8::БУ БУ Бесплатно (free)

Общая информация о внутреннем устройстве регистров бухгалтерии.

05.09.2019    30219    YPermitin    24    

Три костыля. Сказ про фокусы в коде

Практика программирования v8 Бесплатно (free)

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    26100    YPermitin    80    

Отслеживание выполнения фонового задания

Практика программирования Универсальные функции Разработка v8 1cv8.cf Бесплатно (free)

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    32873    ids79    16    

Выгрузка документа по условию Промо

Практика программирования Разработка v8 Бесплатно (free)

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    16206    m-rv    2    

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    91890    ids79    56    

Фоновое выполнение кода в 1С - это просто

Практика программирования v8 1cv8.cf Бесплатно (free)

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    38849    avalakh    25    

Разбираемся с параметрами редактирования СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Связь по типу, Параметры выбора, Связи параметров выбора

31.07.2019    25837    json    15    

Как прикрутить ГУИД к регистру сведений Промо

Практика программирования Перенос данных из 1C8 в 1C8 Разработка v8 Бесплатно (free)

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    20599    m-rv    17    

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    65898    ids79    12    

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ

Инструментарий разработчика Практика программирования v8 v8::СКД Бесплатно (free)

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    37446    ids79    27    

Регистры сведений. За кулисами

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Небольшие заметки по внутреннему устройству регистров сведений.

09.07.2019    26997    YPermitin    14    

Как сделать запрос на изменение данных Промо

Практика программирования v8 v8::Запросы 1cv8.cf Бесплатно (free)

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    31343    m-rv    21    

"Меньше копипаста!", или как Вася универсальную процедуру писал

Практика программирования Разработка v8 v8::СКД 1cv8.cf Бесплатно (free)

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    19977    SeiOkami    50    

Работа с настройками системы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Варианты отчетов, работа с настройками вариантов: структура группировок, поля отчета, отборы, сортировка, условное оформление, другие настройки, настройки отображения диаграмм.

02.07.2019    51491    ids79    17    

Создание отчетов с помощью СКД - основные понятия и элементы

Практика программирования Математика и алгоритмы v8 v8::СКД Бесплатно (free)

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    55660    ids79    25    

Метод формирования движений в типовых регистрах нетиповыми регистраторами Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    28513    itriot11    34    

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017

Практика программирования Производительность и оптимизация (HighLoad) v8 v8::Запросы Бесплатно (free)

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    25967    dmurk    146    

Регистры накопления. Структура хранения в базе данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    45505    YPermitin    30    

О расширениях замолвите слово...

Практика программирования Разработка v8 Бесплатно (free)

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    36277    ellavs    126    

Использование классов .Net в 1С для новичков Промо

Практика программирования Разработка внешних компонент Универсальные функции v7.7 v8 Бесплатно (free)

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    77197    Serginio    110    

Git-репозитории для 1С-кода (опыт использования при небольших проектах)

Практика программирования v8 Бесплатно (free)

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    27871    ellavs    90    

Трюки с внешними источниками данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    32441    YPermitin    53    

Ошибки при работе с хранилищем конфигурации и способы их решения

Практика программирования v8 Бесплатно (free)

В статье собраны наиболее распространенные ошибки при работе с хранилищем конфигурации и способы их обхода и решения.

01.03.2019    42569    Смешной 1С    30    

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С Промо

Математика и алгоритмы Практика программирования v8 v8::blocking 1cv8.cf Бесплатно (free)

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    35742    ids79    40    

Разработка и сценарное тестирование с Vanessa-ADD. Отчетность Allure. Автоматизация запуска сценариев

Практика программирования Vanessa Automation v8 Россия Бесплатно (free)

Формируем отчетность о результатах выполнения сценариев. Автоматизируем запуск.

26.02.2019    22902    Vladimir Litvinenko    27    

Тестер: частые вопросы Промо

Практика программирования v8 Бесплатно (free)

Ошибкам бой - тесты норма жизни!

25.07.2018    29607    grumagargler    28    

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS)

Практика программирования БСП (Библиотека стандартных подсистем) Роли и права v8 v8::Права Бесплатно (free)

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    42171    ids79    9    

EnterpriseData – часть 2. Процесс выгрузки данных

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Основные этапы выгрузки данных через ED, обработчики событий выгрузки, правила обработки данных, правила конвертации объектов, конвертация свойств первого и второго этапов, процедуры БСП, используемые при выгрузке данных, структура «КомпонентыОбмена».

26.12.2018    27746    ids79    31    

Ускоряем 1С: модули с повторным использованием возвращаемых значений Промо

Практика программирования v8 Бесплатно (free)

По роду своей деятельности, мне часто приходится обсуждать с программистами детали реализации той или иной функциональности. Очень часто, разговаривая даже с квалифицированными специалистами я сталкиваюсь с незнанием сути платформенной функциональности Повторного использования возвращаемых значений общих модулей. В данной статье я постараюсь дать краткий обзор и основные особенности этой функциональности.

04.09.2017    53600    m-rv    61    

Новый подход к обмену данными EnterpriseData

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Хочу предложить Вашему вниманию цикл статей, посвященных обмену данными через универсальный формат (EnterpriseData или ED).

14.12.2018    42937    ids79    72    

EnterpriseData - пример доработки правил конвертации без использования КД 3.0 в расширении конфигурации

Практика программирования Обмен через XML v8 v8::УФ БП3.0 УТ11 Россия Бесплатно (free)

В статье подробно описан реальный пример доработки обмена данными через EnterpriseData (универсальный формат обмена) между конфигурациями УТ 11.4 и Бухгалтерия 3.0

16.11.2018    38275    ids79    42