Доработка отчета "Структура подчиненности"

23.03.15

Задачи пользователя - Анализ учета

Расширение типового поведения отчета. Небольшая доработка позволяет сразу построить дерево документов "от корня", при этом текущий документ также остаётся выделен жирным шрифтом.

Скачать исходный код

Наименование Файл Версия Размер
ФайлыПубликации
.rar 214,15Kb
37
.rar 1.0 214,15Kb 37 Скачать

Несколько небольших изменений в коде общей команды и общей форме  "Структура подчиненности" позволяют получить удобный отчет по всему дереву подчиненных документов. 

Вся информация по доработке представлена на рисунках к публикации.

Файлы можно скачать, если только нет желания набрать вручную код, показанный на рисунках.

В качестве оригинала для доработки использовался код Библиотеки стандартных подсистем, редакция 2.2 (2.2.4.45).
Отчет "Структура подчиненности" используется во всех типовых конфигурациях 1С.

Структура подчиненности

См. также

Анализ расхождений выручки НДС и Налога на прибыль в декларациях (БП 3.0 ПРОФ и КОРП, КА 2, ЕRP)

Анализ учета Закрытие периода Бухгалтер Платформа 1С v8.3 Бухгалтерский учет 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Комплексная автоматизация 2.х Россия Бухгалтерский учет Налоговый учет Налог на прибыль НДС Платные (руб)

Каждый бухгалтер не раз сталкивался с требованием от налоговой инспекции пояснить расхождения в показателях декларации по Налогу на прибыль («Доходы от реализации» + «Внереализационные доходы») и налоговой базой по НДС за год. Являются ли ошибкой подобные расхождения? Как пояснить налоговой их причину? Отчет «Анализ расхождений выручки НДС и Налога на прибыль в декларациях» поможет найти все расхождения.

7200 руб.

21.10.2017    84726    266    171    

262

Управленческий учет в 1С УНФ: экспресс-проверка

Анализ учета Бухгалтер Пользователь Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Управление нашей фирмой 3.0 Россия Управленческий учет Платные (руб)

Расширение автоматически анализирует управленческий учёт 1С:УНФ, помогает находить и исправлять ошибки, а также проверять те места, которые хорошо бы проверить. Разработка для тех, кто хочет построить управленческий финансовый учет в УНФ.

12000 руб.

28.07.2022    8759    7    25    

21

Дополнительный анализ расходов УСН в 1С:Бухгалтерии 3.0

Учет доходов и расходов Анализ учета Бухгалтер Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Налоговый учет УСН Платные (руб)

Мы добавили девять новых проверок в Экспресс-проверку учета. Цель таких проверок — узнать, есть ли потенциальные проблемы в учёте УСН.

7200 руб.

27.09.2021    13784    28    11    

36

Экселька. Универсальный инструмент, построенный по типу классических электронных таблиц, с возможностью использования данных 1С.

Загрузка и выгрузка в Excel Регламентированный учет и отчетность Анализ учета БДР, БДДС Бизнес-аналитик Бухгалтер Пользователь Платформа 1С v8.3 Конфигурации 1cv8 Платные (руб)

Инструмент является симбиозом базового функционала Excel с возможностью получения и использования данных 1С для конструирования произвольных отчетов. Область применения - от простого получения нескольких контрольных сумм по типу "Отчет руководителю", до составления сложных аналитических отчетов всех видов учета.

12000 руб.

08.02.2021    19783    12    66    

28

Сверка остатков товаров БУХ3 - УТ11

Анализ учета Бухгалтер Платформа 1С v8.3 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 Россия Бухгалтерский учет Платные (руб)

Обработка позволяет сравнивать количественные остатки номенклатуры между Бухгалтерия 3.0 и УТ 11.5

3600 руб.

06.02.2023    4177    7    1    

12

Сверка данных УНФ - БУХ по документам и по долгам

Взаиморасчеты Анализ учета Бухгалтер Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Платные (руб)

Обработка позволяет сравнивать по документам и сверять по долгам покупателей и поставщиков между базами УНФ 1.6, УНФ 3.0 и Бухгалтерия 3.0,

6000 руб.

24.08.2022    6388    4    1    

6

Отчет контроля целостности остатков.

Анализ учета Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Управленческий учет Платные (руб)

Если вы не хотите испортить базу и платить деньги за исправления - контролируйте и своевременно устраняйте проблемы! Наш отчет поможет вам выявить расхождения в остатках на ранней стадии, когда стоимость исправления ничтожно мала!

2400 руб.

09.08.2023    1709    3    0    

5
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. vlastapov 49 28.03.15 22:35 Сейчас в теме
Да, очень необходимо, спасибо!
2. vlastapov 49 28.03.15 22:38 Сейчас в теме
Жаль только с изменением исходной конфигурации. Может 1С сама встроит этот механизм?
3. AndrewVVS 13.05.15 17:34 Сейчас в теме
Да, жесть! убрать суммы из прошлого варианта. А чтобы еще и вернуть возможность прямо из структуры проводить, распроводить, помечать на удаление документы - долго делать?
4. hobi 616 13.05.15 22:48 Сейчас в теме
(3) AndrewVVS, делать не долго.

Добавьте в модуль общей формы "СтруктураПодчиненности", например такой код:

&НаСервере
Процедура Действие(Док,Действие)
	
	Попытка
		Об = Док.ПолучитьОбъект();
		Если Действие = "Проведение" Тогда
			Если Об.ПометкаУдаления Тогда
				Об.УстановитьПометкуУдаления(Ложь);
			КонецЕсли;
			Если Об.Проведен Тогда
				Об.Записать(РежимЗаписиДокумента.ОтменаПроведения);
			Иначе	
				Об.Записать(РежимЗаписиДокумента.Проведение);
			КонецЕсли;	
		ИначеЕсли Действие = "ПометкаУдаления" Тогда
			Об.УстановитьПометкуУдаления(Не Об.ПометкаУдаления);
		КонецЕсли;	
		ОбновитьДеревоСтруктурыПодчиненности();
	Исключение
		Сообщить("Не удалось выполнить: " + Действие);
	КонецПопытки;
	
КонецПроцедуры

&НаСервереБезКонтекста
Функция СтатусДокумента(Док)
	
	Возврат Новый Структура("Проведен,ПометкаУдаления",Док.Проведен,Док.ПометкаУдаления);
	
КонецФункции

&НаКлиенте
Процедура ТаблицаОтчетаОбработкаДополнительнойРасшифровки(Элемент, Расшифровка, СтандартнаяОбработка)
	
	Статус = СтатусДокумента(Расшифровка);
	СписокЗн = Новый СписокЗначений;
	
	Если Статус.Проведен Тогда
		АктивнаяСтрока = 
		СписокЗн.Добавить("Проведение","Отмена проведения",,БиблиотекаКартинок.ОтменаПроведения);
	Иначе
		АктивнаяСтрока = 
		СписокЗн.Добавить("Проведение","Проведение документа",,БиблиотекаКартинок.Провести);
	КонецЕсли;   
	Если Статус.ПометкаУдаления Тогда
	   СписокЗн.Добавить("ПометкаУдаления","Снять пометку удаления",,БиблиотекаКартинок.ПометитьНаУдаление);
	Иначе
	   СписокЗн.Добавить("ПометкаУдаления","Пометка удаления",,БиблиотекаКартинок.ПометитьНаУдаление);
	КонецЕсли;   
	   
	ВыбранныйЭлемент = СписокЗн.ВыбратьЭлемент("Действие:",АктивнаяСтрока);
	Если ВыбранныйЭлемент = Неопределено Тогда
		Возврат;
	КонецЕсли;		
	Действие(Расшифровка,ВыбранныйЭлемент.Значение);
	
КонецПроцедуры
Показать


И не забудьте связать функцию ТаблицаОтчетаОбработкаДополнительнойРасшифровки() с событием обработка дополнительной расшифровки для элемента формы ТаблицаОтчета.
Тогда по правой кнопке мышки можно проводить/распроводить и изменять пометку удаления.
wakrush; AndrewVVS; +2 Ответить
5. AndrewVVS 14.05.15 11:33 Сейчас в теме
Спасибо! Заработало!! Правда все время пишет: "Использование модальных окон в данном режиме запрещено!" + когда стал переносить код В модуль команды пишет ошибку: Переменная не определена (Ссылка). ОткрытьФорму("ОбщаяФорма.СтруктураПодчиненности",Новый Структура("ОбъектОтбора,ВыбранныйОбъект", Ссылка, ПараметрКоманды),
7. hobi 616 14.05.15 15:07 Сейчас в теме
(5) AndrewVVS, кажется я понял, в чем проблема с "Переменная не определена (Ссылка)". Обычно реквизит "Ссылка" не размещают на форме, поэтому из модуля формы в клиентской процедуре обратиться к нему нельзя. Поэтому опять же, есть два пути:

1. Создать функцию &НаСервере, которая возвращает значение ссылки для использования в вызове формы.
2. В самой форме у реквизита "Ссылка" установить флажок "Использовать всегда".

Надеюсь, поможет.
9. AndrewVVS 14.05.15 18:09 Сейчас в теме
(7) хотел убрать действия: "проведение документа" и "отмена проведения документа" для тех документов, которые не проводятся, например счета или инвентаризации по Метаданные.СвойстваОбъектов.Проведение.Разрешить, НО оказалось, что в версии 3.0 у этих документов свойство Проведение из "запретить" - стало "разрешить"!!, хотя никаких движений они так и не делают :).
6. hobi 616 14.05.15 14:57 Сейчас в теме
Про модальные окна: я не стал заморачиваться для краткости кода. Если сильно мешает, есть два пути убрать сообщение о запрете модальности:

1. В свойствах конфигурации (всё равно уже сняли с поддержки, если исправили код общего модуля и общей формы) установить "Режим использования модальности" в значение "Использовать". Если не работаете в режиме Web-клиента, это быстрее и проще.

2. Сделать рефакторинг строки (как рекомендует 1С):
ВыбранныйЭлемент = СписокЗн.ВыбратьЭлемент("Действие:",АктивнаяСтрока);
Заменить процедуру ВыбратьЭлемент() на ПоказатьВыборЭлемента(). Как это сделать - есть пример в справке по процедуре
ПоказатьВыборЭлемента().

Про модуль команды не совсем понятно, что вы сделали. В публикации шла речь только об изменениях в общей форме и общем модуле.
Нужен ваш код, чтобы ответить.
8. AndrewVVS 14.05.15 16:08 Сейчас в теме
(6) и снова: СПАСИБО! уже заморочился с ВыбранныйЭлемент = СписокЗн.ПоказатьВыборЭлемента(Новый ОписаниеОповещения("Действие", ЭтотОбъект),"Действие:",АктивнаяСтрока);
http://its.1c.ru/db/metod8dev#content:5293:hdoc
P.S. в режиме Web-клиента не работаем, это ДЕЙСТВИТЕЛЬНО быстрее и проще!! :) установить "Режим использования модальности" в значение "Использовать"
10. hobi 616 14.05.15 19:55 Сейчас в теме
Проверку возможности проведения для документов, которые не проводятся, я не реализовал.
Просто минимальный код привел. Но сделать не проблема.
11. Светлый ум 406 06.11.16 07:59 Сейчас в теме
-1. Обработки в архиве нет.
12. wakrush 12.11.17 12:37 Сейчас в теме
Спасибо огромное автору за подсказку с кнопками
Оставьте свое сообщение