Прогноз продаж, план, факт, АКБ для КА2.0, УТ11.2, ERP2.1

21.06.16

Функциональные - Бюджетирование и планирование

Данный отчет и доп. функционал поможет вам легко и быстро устанавливать план продаж для ваших торговых представителей и контролировать их выполнение, а также прогнозировать % выполнения плана.

Скачать файл

ВНИМАНИЕ: Файлы из Базы знаний - это исходный код разработки. Это примеры решения задач, шаблоны, заготовки, "строительные материалы" для учетной системы. Файлы ориентированы на специалистов 1С, которые могут разобраться в коде и оптимизировать программу для запуска в базе данных. Гарантии работоспособности нет. Возврата нет. Технической поддержки нет.

Наименование SM По подписке [?] Купить один файл
Отчет прогноз продаж
.erf 9,53Kb
14
14
1 SM
Скачать Купить за 1 850 руб.

Для работы данного отчета необходимо добавить в конфигурацию следующие объекты:

Справочники:

  • ПлановыеПоказатели

Документы:

  • ПланПродажПоПоказателям

Регистры сведений:

  • ПоказателиПланаПродаж

Справочник ПлановыеПоказатели имеет следующие реквизиты:

  • Наименование - длина 100
  • Код - длина 12
  • ПоказательПланаПродаж - Булево

Документ ПланПродажПоПоказателям имеет следующие реквизиты:

  • Дата - Дата,Время
  • Номер - Длина 9, контроль уникальности, непериодический(можно пожеланию сделать периодичность в пределах года и сократить длину)
  • Дополнительно: непериодический, подчинен регистратору
  • Регистраторы: Документ ПланПродажПоПоказателям

Содержит табличные части:

  • ГруппыПродаж - содержит следующие реквизиты:
  1. Менеджер -  тип Справочник.Пользователи
  2. ПлановыйПоказатель - тип Справочник.ПлановыеПоказатели  отбор по реквизиту ПоказательПланаПродаж  = Истина
  3. План                            - тип Число(15,2)
  4. Коэффициент            - тип Число(5,2)
  • РасчетныеПоказатели - содержит следующие реквизиты:
  1. Менеджер -  тип Справочник.Пользователи
  2. ПлановыйПоказатель - тип Справочник.ПлановыеПоказатели  отбор по реквизиту ПоказательПланаПродаж  = Истина
  3. Значение   - Тип Число(15,3)

      Код модуля объекта:

Процедура ПриЗаписи(Отказ)
	
	//Проверим, что не задвоены показатели
	Запрос = новый Запрос;
	Запрос.Текст = "ВЫБРАТЬ
	               |	ПланПродажПоПоказателямГруппыПродаж.Менеджер,
	               |	ПланПродажПоПоказателямГруппыПродаж.ПлановыйПоказатель,
	               |	ПРЕДСТАВЛЕНИЕ(ПланПродажПоПоказателямГруппыПродаж.Менеджер),
	               |	ПРЕДСТАВЛЕНИЕ(ПланПродажПоПоказателямГруппыПродаж.ПлановыйПоказатель),
	               |	ПланПродажПоПоказателямГруппыПродаж.НомерСтроки КАК НомерСтроки
	               |ИЗ
	               |	Документ.ПланПродажПоПоказателям.ГруппыПродаж КАК ПланПродажПоПоказателямГруппыПродаж
	               |		ВНУТРЕННЕЕ СОЕДИНЕНИЕ Документ.ПланПродажПоПоказателям.ГруппыПродаж КАК ПланПродажПоПоказателямГруппыПродаж1
	               |		ПО ПланПродажПоПоказателямГруппыПродаж.Менеджер = ПланПродажПоПоказателямГруппыПродаж1.Менеджер
	               |			И ПланПродажПоПоказателямГруппыПродаж.ПлановыйПоказатель = ПланПродажПоПоказателямГруппыПродаж1.ПлановыйПоказатель
	               |			И (ПланПродажПоПоказателямГруппыПродаж1.Ссылка = &Ссылка)
	               |			И ПланПродажПоПоказателямГруппыПродаж.НомерСтроки > ПланПродажПоПоказателямГруппыПродаж1.НомерСтроки
	               |ГДЕ
	               |	ПланПродажПоПоказателямГруппыПродаж.Ссылка = &Ссылка";
	Запрос.УстановитьПараметр("Ссылка",Ссылка);
	РЗ = Запрос.Выполнить();
	Если не РЗ.Пустой() Тогда
		
		Отказ = Истина;
		Выборка = РЗ.Выбрать();
		Сообщить("При записи документа: " + Ссылка + " обнуржены ошибки: ");
		
		Пока Выборка.Следующий() Цикл
			Сообщить("В строке: " + Выборка.НомерСтроки + " задвоены значения, Менеджер: "
			+ Выборка.МенеджерПредставление + " Показатель: " + Выборка.ПлановыйПоказательПредставление); 
		КонецЦикла;
		
	КонецЕсли;
	
КонецПроцедуры

Процедура ОбработкаПроведения(Отказ, РежимПроведения)
	Движения.ПоказателиПланаПродаж.Записывать = Истина;
	Движения.ПоказателиПланаПродаж.Очистить();
	Запрос = новый Запрос;
	Запрос.Текст = "ВЫБРАТЬ
	|	ПланПродажПоПоказателямГруппыПродаж.Менеджер,
	|	ПланПродажПоПоказателямГруппыПродаж.ПлановыйПоказатель КАК ПлановыеПоказатели,
	|	&ПериодПлана,
	|	ПланПродажПоПоказателямГруппыПродаж.План КАК Значение,
	|	ПланПродажПоПоказателямГруппыПродаж.Коэффициент КАК Процент
	|ИЗ
	|	Документ.ПланПродажПоПоказателям.ГруппыПродаж КАК ПланПродажПоПоказателямГруппыПродаж
	|ГДЕ
	|	ПланПродажПоПоказателямГруппыПродаж.Ссылка = &Ссылка
	|
	|ОБЪЕДИНИТЬ ВСЕ
	|
	|ВЫБРАТЬ
	|	ПланПродажПоПоказателямРасчетныеПоказатели.Менеджер,
	|	ПланПродажПоПоказателямРасчетныеПоказатели.ПлановыйПоказатель,
	|	&ПериодПлана,
	|	ПланПродажПоПоказателямРасчетныеПоказатели.Значение,
	|	0
	|ИЗ
	|	Документ.ПланПродажПоПоказателям.РасчетныеПоказатели КАК ПланПродажПоПоказателямРасчетныеПоказатели
	|ГДЕ
	|	ПланПродажПоПоказателямРасчетныеПоказатели.Ссылка = &Ссылка";
	Запрос.УстановитьПараметр("Ссылка",Ссылка);
	Запрос.УстановитьПараметр("ПериодПлана",НачалоМесяца(Дата));
	РЗ = Запрос.Выполнить();
	Если не РЗ.Пустой() Тогда
		Движения.ПоказателиПланаПродаж.Загрузить(РЗ.Выгрузить());
	КонецЕсли;
	
КонецПроцедуры

Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
	Если Дата <> НачалоМесяца(Дата) Тогда
		Дата = НачалоМесяца(Дата);
	КонецЕсли;
КонецПроцедуры

Регистр сведений ПоказателиПланаПродаж

  • Измерения:
  1. ПериодПлана - Тип Дата
  2. ПлановыеПоказатели - Тип Справочник.ПлановыеПоказатели
  3. Менеджер - Тип Справочник.Пользователи
  • Ресурсы:
  1. Значение- Тип Число(15,2)
  2. Процент - Тип Число(5,2)

Настройка

  1. В конфигураторе вносим данные изменения, в справочнике ПлановыеПоказатели заводим предопределенный элемент АКБ, реквизит ПоказательПланаПродаж  = Ложь!
  2. Заполняем справочник ПлановыеПоказатели, для показателей обязательно взводим реквизит ПоказательПланаПродаж  = Истина, для реквизитов с ложь на данный момент функционал предусмотрен тока програмно в отчете и реализован только для АКБ(Активной клиентской базы)
  3. Работаем со справочником номенклатуры, в него добавим реквизит - ПлановыеПоказатели - отбор выбора ПоказательПланаПродаж  = Истина и распределяем номенклатуру по ним.
  4. Заполняем документ ПланПродажПоПоказателям
  5. Формируем отчет за месяц продаж каждый день, период начало месяца - текущий день.

Жду ваши комментарии.

См. также

Бюджетирование и планирование Оптовая торговля Розничная торговля Логистика, склад и ТМЦ Анализ продаж Пользователь Платформа 1С v7.7 Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Управление нашей фирмой 1.6 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Беларусь Украина Россия Казахстан Управленческий учет Платные (руб)

Система управления запасами для 1С помогает работать с запасами правильно: автоматически рассчитывает потребность и делает заказ поставщику, загружает прайсы, перемещает товары по филиалам, анализирует продажи и позволяет управлять ассортиментом.

28500 руб.

21.04.2017    93453    119    40    

210

Оптовая торговля Розничная торговля Обмен с ГосИС Бухгалтер Платформа 1С v8.3 1С:Управление торговлей 10 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Рестораны, кафе и фаст-фуд Россия Бухгалтерский учет Управленческий учет Акцизы Платные (руб)

Полнофункциональное расширение (ранее известное как Модуль 1С-ЕГАИС) для взаимодействия типовых конфигураций 1С и ЕГАИС, предоставляющее максимум возможностей по работе с УТМ. Получение и отправка ТТН, отправка акта о постановке на баланс и акта о списании. Получение остатков. Загрузка и сопоставление номенклатуры и контрагентов. Оправка в ЕГАИС отчетов о производстве и импорте.

8970 руб.

15.12.2015    168541    759    364    

394

Бюджетирование и планирование Бизнес-аналитик Бухгалтер Пользователь Управляемые формы Конфигурации 1cv8 Россия Управленческий учет Платные (руб)

«ФинОфис» - программный продукт для автоматизации бюджетирования, казначейства, консолидации данных и настройки бизнес-процессов в 1С.

25000 руб.

20.12.2017    50242    8    7    

87

Оптовая торговля Розничная торговля Обмен с ГосИС Программист Бухгалтер Пользователь Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия Бухгалтерский учет Управленческий учет Платные (руб)

Данная публикация создана для помощи разработчикам, интеграторам и другим заинтересованным лицам по настройке системы маркировки обуви, одежды, лекарств, табака, фото, молока, духов(парфюма), питьевой воды, велосипедов и шин. Смело задавайте вопросы по работе с ЦРПТ, GS1, ЭДО, Национальным каталогом, накопили достаточно большую базу знаний по данным темам и готовы ответить на все Ваши вопросы.

5000 руб.

18.03.2019    111743    28    114    

181

SALE! 20%

Загрузка и выгрузка в Excel Оптовая торговля Бухгалтер Пользователь Платформа 1С v8.3 Управляемые формы Платформа 1C v8.2 Конфигурации 1cv8 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 Бухгалтерский учет Управленческий учет Платные (руб)

Универсальная обработка для загрузки документов из Excel в 1С одним нажатием. Не требует указания параметров (номера колонок, номер первой строки таблицы и т.д.) и предварительной настройки. Просто выбираете файл Excel, документ 1С и нажимаете кнопку "Загрузить". Обработка сама находит таблицу в файле Excel, необходимые для загрузки данные в ней (номенклатура, количество, НДС, цена, сумма) и загружает ее в 1С. Вместе с номенклатурой может найти контрагента, номер и дату документа, штрих-коды, серии ГТД, страну и т.д. Распознает документы ЛЮБОЙ ФОРМЫ (УПД, ТОРГ-12, заказ, отчет комиссионера и т.д.). Не требует MS Office. Для поиска таблиц используются методы эвристического поиска. Загружает только то, что нужно, т.е. пропускает повторы шапки таблицы, заголовки, промежуточные итоги, подписи и т.д. Содержит модуль работы с электронной почтой и api-загрузчик отчетов о продажах маркетплейсов.

5000 4000 руб.

09.11.2016    222629    957    891    

964

SALE! %

Перенос данных 1C Взаиморасчеты Оптовая торговля Логистика, склад и ТМЦ Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Управление торговлей 10 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Управленческий учет Платные (руб)

Можно проверить до покупки, оставьте заявку! Воспользовались более 268 компаний! Перенос в продаже с 2015г., и мы постоянно работаем над его развитием. Перенос данных из УТ 10.3 в УТ 11 | из УТ 10.3 в КА 2 | из УТ 10.3 в ERP. Предлагаем качественное и проверенное временем решение для перехода с УТ 10.3. Можно перенести начальные остатки, нормативно-справочную информацию и все возможные документы. При выгрузке можно установить отбор по периоду, организациям и складам. При выходе новых релизов конфигураций 1C оперативно выпускаем обновление переноса данных.

45650 27000 руб.

24.04.2015    192423    141    241    

272
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. user1235302 17.06.20 14:43 Сейчас в теме
Хм, очень интересно. Надо проверить. Стандартные средства не удобны.
2. elzetto 23.11.21 05:34 Сейчас в теме
Оставьте свое сообщение