Формирование и отправка данных в SPOT 2D для 1С: 7.7

05.09.16

Учетные задачи - Оптовая торговля

Для тех, кто еще не написал сам - не претендующая на профессионализм обработка, но вполне рабочая. Будет неплохим примером с некоторыми подсказками...

Скачать файл

ВНИМАНИЕ: Файлы из Базы знаний - это исходный код разработки. Это примеры решения задач, шаблоны, заготовки, "строительные материалы" для учетной системы. Файлы ориентированы на специалистов 1С, которые могут разобраться в коде и оптимизировать программу для запуска в базе данных. Гарантии работоспособности нет. Возврата нет. Технической поддержки нет.

Наименование SM По подписке [?] Купить один файл
Выгрузка для SPOT2D.ert
.ert 33,50Kb
9
9
1 SM
Скачать Купить за 1 850 руб.

Несправедливо так! Для платформы 8.2 есть две публикации, а для 7.7 - ни одной ! Так вот: Данная обработка, сделанная на быструю руку, может стать неплохой подсказкой для тех, кто собирается все это реализовать у себя. В данной обработке учтены особенности учета в моей фирме, поэтому обязательно выдаст ошибки, если попытаться просто запускать в среде 1С: Торговля 7.7 для Украины.

Описания форматов файлов и вообще о чем речь идет можно найти на страницах аналогичных обработок для 8.2:

//infostart.ru/public/439115/

//infostart.ru/public/452606/

Мне будет очень приятно, если данная обработка окажется полезной хотя бы для одного коллеги.

SPOT 2D SPOT2D 7.7 Торговля 7.7 для Украины

См. также

Бюджетирование и планирование Оптовая торговля Розничная торговля Логистика, склад и ТМЦ Анализ продаж Пользователь Платформа 1С v7.7 Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Управление нашей фирмой 1.6 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Беларусь Украина Россия Казахстан Управленческий учет Платные (руб)

Система управления запасами для 1С помогает работать с запасами правильно: автоматически рассчитывает потребность и делает заказ поставщику, загружает прайсы, перемещает товары по филиалам, анализирует продажи и позволяет управлять ассортиментом.

28500 руб.

21.04.2017    93537    119    40    

210

Оптовая торговля Розничная торговля ККМ ЭДО и ОФД Обмен с ГосИС Системный администратор Программист Оперативный учет 7.7 Бухгалтерский учет 7.7 1С:Бухгалтерия 7.7 1С:Комплексная 7.7 1С:Торговля и склад 7.7 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия Платные (руб)

Подключение фискального регистратора к 1С 7.7 в режиме онлайн-кассы (в соответствии с 54-ФЗ). Поддержка крайних версий драйверов ККТ: ДТО 10 и ДТО 8 для Атол, 4.15, 5.16 для Штрих-М. Поддержка протоколов ФФД 1.0, 1.05, 1.1 и 1.2, развитые настройки для применения частичных оплат и авансов в оптовой и розничной торговле. Поддержка чеков коррекции всех версий. Поддержка розничной продажи маркированной продукции (ЕГАИС, табак, обувь, лекарства, шины, одежда, белье, парфюмерия, молочная продукция, вода и пр.). Вывод электронного чека (на е-майл, телефон) по требованию покупателя, поддерживаются комбинированные типы оплаты, режим эмуляции печати чека на ФР. Полный цикл работы из 1С 7.7 с маркировкой Честный ЗНАК (ГИСМТ, ЦРПТ) из 1С 7.7. ЭДО (табак, обувь, шины, одежда, молочная продукция, вода и прочие группы товаров) для розницы и опта (приемка и оптовая отгрузка маркированной продукции). Поддерживается как объемно-сортовой учет (ОСУ) так и поштучный (поэкземплярный) учет.

2000 руб.

28.03.2017    471893    4332    3473    

2443

Оптовая торговля Обмен с ГосИС Программист Бухгалтер Платформа 1С v7.7 Конфигурации 1cv7 Сельское хозяйство и рыболовство Оптовая торговля, дистрибуция, логистика Пищевая промышленность Бухгалтерский учет Платные (руб)

В обработке реализован полный цикл работы с ГИС Меркурий из 1С на платфоме 7.70.027 (поддерживается конфигурация "Торговля и Склад") через Ветис.API: реализованы процедуры обмена с подсистемами заявок и справочников Ветис.API в формате 2.0.

5040 руб.

03.07.2018    37218    79    27    

60

Оптовая торговля Розничная торговля Обмен с ГосИС Бухгалтер Оперативный учет 7.7 Бухгалтерский учет 7.7 1С:Бухгалтерия 7.7 1С:Комплексная 7.7 1С:Торговля и склад 7.7 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия Бухгалтерский учет Управленческий учет Акцизы Платные (руб)

Полностью автоматизированный обмен данными между конфигурациями 1С 7.7 и универсальным транспортным модулем (УТМ) ЕГАИС для всех видов деятельности (Опт, Розница, Производство, Импорт). Для организации обмена с ЕГАИС требуется минимальная доработка конфигураций (поддерживается 1С: "Торговля и склад ред. 9.2", 1С: "Бухгалтерия 7.7", 1С: "УСН 7.7", другие конфигурации по заказу, включая нетиповые). В данном программном продукте реализованы все технические требования ФСРАР по обмену с УТМ ЕГАИС (включая отправку чеков розничных продаж в ЕГАИС - требование с 01.07.16). Поддержана фиксация чеков ЕГАИС на онлайн-кассах (в соответствии с 54-ФЗ). Поддержана версия 3 документооборота и поштучный (помарочный) учет. Поддержан эксперимент Татарстана по маркировке нефасованного (кегового) пива.

3000 руб.

13.12.2015    136799    169    400    

146

Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Обмен с ГосИС Программист Бухгалтер Оперативный учет 7.7 Бухгалтерский учет 7.7 1С:Бухгалтерия 7.7 1С:Комплексная 7.7 1С:Торговля и склад 7.7 1С:Упрощенное налогообложение 7.7 Сельское хозяйство и рыболовство Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Рестораны, кафе и фаст-фуд Пищевая промышленность Россия Бухгалтерский учет Управленческий учет Платные (руб)

Полностью автоматизированный обмен между конфигурациями 1С 7.7 и ФГИС Меркурий через Ветис.API для всех видов деятельности (Опт, Розница, Производство). Для организации обмена с ФГИС Меркурий требуется минимальная доработка конфигураций (поддерживается "из коробки" 1С: "Торговля и склад ред. 9.2", 1С: "Комплексная ред. 4.5", 1С: "Бухгалтерия 7.7", 1С: "УСН 7.7", 1С Предприниматель, другие конфигурации по заказу, включая нетиповые и самописные). Модуль разработан таким образом, чтобы минимизировать затраты по внедрению в произвольную конфигурацию на базе 1С 7.7. Вы можете БЕСПЛАТНО скачать демо-версию без ограничения по функционалу и опробовать решение в полном объеме перед покупкой. В данном программном продукте реализованы все технические требования Россельхознадзора по обмену в формате 2.0 и 2.1. Решение прошло опытную эксплуатацию и тестирование на крупных объектах всех видов деятельности: Производство, Опт, Розница.

10000 руб.

21.11.2018    53444    155    105    

69

Внешние источники данных Программист Платформа 1С v7.7 Конфигурации 1cv7 Украина Абонемент ($m)

Рабочий механизм чтения/записи строк в формате JSON для 1С 7.7. Тестировалось на релизах 7.70.25 и 27.

1 стартмани

16.12.2019    22432    61    Volvo32    33    

25

Анализ учета Оптовая торговля Бухгалтер Бухгалтерский учет 7.7 1С:Комплексная 7.7 Россия Бухгалтерский учет НДС Абонемент ($m)

Отчет написан для Комплексной конфигурации 4.2. Отчет позволяет выполнить сверку кредитовых оборотов счета 76.АВ (НДС с авансов полученных) с книгой покупок, проверить правильность выписки счетов фактур на зачет аванса по счетам БУ в разрезе разных ставок НДС 18% и 20% в комплексной конфигурации 1С:Предприятия 7.7. Позволяет найти и исправить ошибки в процессе перехода на 20% НДС. Помогает с закрытием квартала 18% и 20% НДС. Отчет обновлен для анализа данных 2 квартала 2019 года и всех следующих кварталов (стал более универсальным).

1 стартмани

27.03.2019    24197    13    ksnik    5    

2
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. пользователь 05.10.16 20:17
Сообщение было скрыто модератором.
...
5. rougudz 26.10.16 18:00 Сейчас в теме
если кому интересно то передача post запроса реализовал так.
// XMLstr текст csv файла отправки.
Функция ОтправкаPOSTзапросом(XMLstr="",ИмяФайла)
	
	MSXMLver = "6";
	Попытка
		Http = CreateObject("MSXML2.ServerXMLHTTP."+MSXMLver+".0");
	Исключение 
		Попытка
			MSXMLver = "4";
			Http = CreateObject("MSXML2.ServerXMLHTTP."+MSXMLver+".0"); 
		Исключение 
			Сообщить(ОписаниеОшибки(),"!");
			Сообщить("Для работы модуля обмена необходима библиотека MSXML не ниже 4.0","!");
			Возврат "Для работы модуля обмена необходима библиотека MSXML не ниже 4.0";
		КонецПопытки;
	КонецПопытки;
	
	
	login = "**";
	passw = "**";
	DistrID = "**";
	
	Если ПустаяСтрока(XMLstr) = 0 Тогда
		Boundary = СтрЗаменить(ТекущееВремя(),":","");
		//формируем тело запроса
		
		Body = +"--"+Boundary+РазделительСтрок
		+"Content-Disposition: form-data; name=""ufile""; filename="""+СтрЗаменить(ИмяФайла,".csv","")+""""+РазделительСтрок
		+"Content-Type: text/plain"+РазделительСтрок+РазделительСтрок
		+XMLstr+РазделительСтрок+РазделительСтрок
		+"--"+Boundary+РазделительСтрок
		+"Content-Disposition: form-data; name=""__login"""+РазделительСтрок+РазделительСтрок
		+login+РазделительСтрок
		+"--"+Boundary+РазделительСтрок
		+"Content-Disposition: form-data; name=""__password"""+РазделительСтрок+РазделительСтрок
		+passw+РазделительСтрок
		+"--"+Boundary+РазделительСтрок
		+"Content-Disposition: form-data; name=""__did"""+РазделительСтрок+РазделительСтрок
		+DistrID+РазделительСтрок
		+"--"+Boundary;
		
	КонецЕсли;
	
	ServiceRequest = "http://aqualife.spot2d.com/dinfo/auto-upload.phtml";
	ServiceIP = "aqualife.spot2d.com";
	
	Http.Open ("POST", ServiceRequest, -1); //асинхронный запрос
	Http.SetRequestHeader("Content-Type","multipart/form-data; boundary="+Boundary);
	
	//ЗначениеВФайл(КаталогИБ()+ИмяФайла,Body,0);
	
	Http.Send(Body);
	
	Состояние("Ожидание ответа на запрос...");
	ВремяОжидания = 0;
	Пока Http.ReadyState <> 4 Цикл
		Попытка
			Если Http.waitForResponse(1) = 0 Тогда //превышено время ожидания ответа =1s
				Если ВремяОжидания >= 60 Тогда //60s
					Состояние("");
					Сообщить("Превышен интервал ожидания запроса сервера "+ServiceIP,"!");
					Возврат 0; 
				КонецЕсли;
				ВремяОжидания = ВремяОжидания + 1; //1s
				Состояние("Ожидание ответа на запрос... "+Строка(ВремяОжидания)+"s");
			КонецЕсли;
		Исключение 
			Сообщить(ОписаниеОшибки(),"!");
			Возврат 0;
		КонецПопытки; 
	КонецЦикла; 
	
	//Состояние("");
	
	Response = Http.ResponseXML;
	Заголовки = Http.getAllResponseHeaders();
	Сообщить("Заголовки: "+СпС(Лев(СпС(Заголовки),255)));
	
	ОтветСервера = Http.responseText; 
	Сообщить("Response: "+СпС(Лев(СпС(Response),255)));
	Сообщить("ОтветСервера: "+СпС(Лев(СпС(ОтветСервера),255)));
	текст = СоздатьОбъект("Текст");
	текст.ДобавитьСтроку(ОтветСервера);
	текст.Записать(КаталогВременныхФайлов()+"AquaОтвет.xml");
	
	Если Http.Status = 200 Тогда
		Сообщить("HTTP status: "+Http.Status+" "+Http.StatusText+", время ожидания "+?(ВремяОжидания=0,"<1",Строка(ВремяОжидания))+"s");
		Возврат "HTTP status: "+Http.Status+" "+Http.StatusText+", "+ОтветСервера+", время ожидания "+?(ВремяОжидания=0,"<1",Строка(ВремяОжидания))+"s";
	Иначе
		Сообщить("HTTP status: "+Http.Status+" "+Http.StatusText+", ошибка!","!");
		Возврат "HTTP status: "+Http.Status+", "+Http.StatusText+", "+ОтветСервера+", ошибка!";
	КонецЕсли;
	
	
КонецФункции // SendHTTPRequest
Показать
bds22; EvgeTrofi; +2 Ответить
6. Khaled 1 27.10.16 10:24 Сейчас в теме
(5) rougudz, Весьма иньтересно, брольшое спасибо, НО: имеются непонятные моменты.

1 - Первое, что бросается в глаза - строка, проверяющая не превышен ли интервал времени ответа:

Если Http.waitForResponse(1) = 0 Тогда //превышено время ожидания ответа =1s

На языке 1С, строка в таком виде вызовет кучу ошибок.

2 - Функция СпС - что именно делает ??
7. rougudz 27.10.16 11:08 Сейчас в теме
(6) сорри по спс это я для своего удобства делаю всегда
кнвертит все что угодно в строку и обрезает пробелы, лень писать СокрЛП(строка(чтото))
пишу спс(чтото)

Функция СпС(что) Экспорт
    Возврат СокрЛП(Строка(что))
КонецФункции //СпС()


по поводу Если Http.waitForResponse(1) = 0 Тогда
все нормально работает.
Http это не объект 1с, а MSXML2.ServerXMLHTTP.х.0
8. Khaled 1 27.10.16 16:49 Сейчас в теме
(7) rougudz, Я хотел сказать, что строка:
Если Http.waitForResponse(1) = 0 Тогда //превышено время ожидания ответа =1s

в таком виде, как тут изображена не выполнится в среде 1с.
9. rougudz 27.10.16 17:11 Сейчас в теме
(8)чегойто не то с копипастом видимо
косяки со вставкой кода...
10. bds22 20 09.01.22 18:43 Сейчас в теме
(5)спасибо, Ваш пример помог понять, как отправить от 8ки. тоже раньше через curl отправлял, решил переделать
2. rougudz 13.10.16 16:36 Сейчас в теме
Передача в SPOT2D идет через post запросы. сдесь сие реализовано? я никак не могу дать с ними толку. ответ от сервера приходит что мол: 200 т.е. все ОК. а они утверждают что ничего к ним не приходило.... не сталкивались?
3. Khaled 1 14.10.16 16:36 Сейчас в теме
Нет, я передачу реализовал с помощью внешнего bat-файла, который запускается обработкой по окончания формирования файлов выгрузок:
В процедуре Сформировать: (И еще один момент: Возможно параметр __did оставлен без внимание, аон должен содержать "код дистрибьютора в SPOT 2D")
=== Начало ===
// Процедуры формирования файлов выгрузок
.
.
.
Если ФлагОтладки = 0 Тогда	
      КомандаСистемы("SendAllWithSSL.bat"); // Команда запуска передачи файлов
КонецЕсли;
=== Конец ===

Содержание файла SendAllWithSSL.bat // изменено слегка
=== Начало ===
@Echo off
FOR %%I IN (Send\*.*) DO call SendFileWithSSL.bat %%~dI %%~pI %%~nI protocol.log
=== Конец ===

Содержание файла SendFileWithSSL.bat // изменено слегка
=== Начало ===
@Echo off
set Path2cvs=%1%2
set FileType=%3
set LogFile=%4
echo Date %date%  Time %time% >> protocol.log
echo. Send %Path2cvs%%FileType%.cvs ...  >> %LogFile%
curlssl.exe -v -F "ufile=@%Path2cvs%%FileType%.csv;type=text/plain;filename=%FileType%" -F "__login=ْْْْXXXXXXXX" -F "__password=XXXXXXXX" -F "__did=XXXXXXXX" http://XXXXXXXX.spot2d.com/dinfo/auto-upload.phtml  >> %LogFile%
=== Конец ===
Показать

Все сделано по их инструкции. запустилось с пол-пинка, и сейчас работает в автоматическом режиме.
4. rougudz 15.10.16 11:01 Сейчас в теме
(3) спасибо. но интересует имеено POST запрос. нелюблю бантики.
Оставьте свое сообщение