ЗУП. Арифмометр для документа "Отпуска организаций"

22.10.10

Учетные задачи - Зарплата

Внешняя обработка заполнения табличной части. Считает конечную дату отпуска в кадровом документе "Отпуска организаций" так же, как и в расчетном документе.

Скачать исходный код

Наименование Файл Версия Размер
Калькулятор_отпуска
.epf 10,17Kb
95
.epf 10,17Kb 95 Скачать

Может быть интересна там, где кадровик и расчетчик - разные люди.

Сделана по просьбе кадровиков, мол не хотим руками отпуск считать, да еще и праздники выбрасывать. Цепляется как обычная форма для заполнения табличных частей. Отлаживалась на платформа 8.1.15.14, конфа ЗУП редакция (2.5.27.6). Военного там ничего нет, на всех ЗУП-ах  вроде должна работать.

Это первая публикация, поэтому интересны любые отзывы почтенного собрания.

См. также.

Зарплата Регламентированный учет и отчетность Кадровый учет Обновление 1С Бухгалтер Платформа 1С v8.3 Сложные периодические расчеты 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 2.0 1С:Зарплата и Управление Персоналом 2.5 Бухгалтерский учет Налоговый учет Управленческий учет Акцизы ЕНВД ЕСН Земельный налог ИП, ПБОЮЛ, КФХ Налог на имущество Налог на прибыль НДС НДФЛ ФОМС, ЕФС Транспортный налог УСН ПСН (патентная система налогообложения) Платные (руб)

Обновления для конфигураций: КА 1.1; ЗУП 2.5; БУХ 2.0; КА 1.1 Комплексная автоматизация торговли алкогольной продукцией; КА 1.1 Комплексный учет сельскохозяйственного предприятия

19900 руб.

01.04.2020    142480    671    352    

234

Перенос данных 1C Зарплата Бюджетный учет Программист Бухгалтер Платформа 1С v8.3 Сложные периодические расчеты 1С:Зарплата и кадры государственного учреждения 3 1С:Зарплата и Управление Персоналом 3.x Государственные, бюджетные структуры Россия Бюджетный учет Платные (руб)

Обработки для быстрого перехода с конфигураций «КАМИН:Расчет зарплаты для бюджетных учреждений 3.5» и «КАМИН:Зарплата для бюджетных учреждений 5.5» на конфигурацию «Зарплата и кадры государственного учреждения».

12000 руб.

28.07.2016    57874    148    141    

125

Зарплата Программист Бизнес-аналитик Бухгалтер Платформа 1С v8.3 1С:Зарплата и кадры государственного учреждения 3 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет Платные (руб)

При заполнении ведомости на выплату зарплаты вылазят задолженности прошлых периодов, которых быть не должно? Наша обработка позволяется убрать эти доходы прошлых периодов за пару секунд. Больше не нужно тратить часы на анализ каждого такого случая.

15600 руб.

14.09.2022    13753    66    26    

68

Зарплата Роли и права Системный администратор Бухгалтер Платформа 1С v8.3 Бухгалтерский учет Управление правами 1С:Бухгалтерия 3.0 1С:Комплексная автоматизация 2.х Молдова Россия Казахстан Бухгалтерский учет Платные (руб)

Расширение позволяет максимально полно ограничить доступ пользователей к данным по заработной плате, а именно закрывает доступ к документам начисления и выплаты заработной платы, не позволяет просматривать бухгалтерские отчеты по счету учета зарплаты а также убирает зарплатные проводки из журнала проводок. Расширение запрещает просматривать платежные документы на выплату зарплаты, так же не доступны регламентные отчеты в ПФР и ИФНС. Расширение предлагает готовые настроенные профили "Бухгалтер без зарплаты", "Только просмотр без зарплаты".

5700 руб.

27.05.2021    34184    214    89    

173

Корректировка данных Зарплата Бухгалтер Платформа 1С v8.3 Сложные периодические расчеты 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет НДФЛ Платные (руб)

Обработка исправляет технические ошибки по НДФЛ, взаиморасчетам с сотрудниками в 1С:ЗУП (1С:ЗКГУ) на начало года. Фактически все ошибки, которые проявляются в ведомостях на выплату, расчетных листках, при заполнении ведомостей на выплату и отчетах 6-НДФЛ и т.д. нужно начинать исправлять с начала расчетного года. Это позволит быть уверенными, что после завершения расчетов предыдущего года, начали работать с «чистого листа» без ошибочных остатков.

4800 руб.

06.10.2023    3274    33    17    

40

Внешние источники данных Зарплата Бюджетный учет Программист Бухгалтер Платформа 1С v8.3 Сложные периодические расчеты 1С:Зарплата и кадры государственного учреждения 3 Государственные, бюджетные структуры Россия Бухгалтерский учет Бюджетный учет Платные (руб)

Обработка позволяет перенести кадровую информацию и данные по заработной плате, фактических удержаниях, НДФЛ, вычетах, страховых взносах из базы Парус 7.хх учреждений в конфигурацию 1С:Зарплата и кадры государственного учреждения ред. 3 (ЗГУ) и начать с ней работать с любого месяца года.

24000 руб.

24.04.2017    49275    97    165    

87

Корректировка данных Зарплата Бухгалтер Пользователь Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Платные (руб)

Внешняя обработка предназначена для исправления самых различных ошибок, возникших по самым разным причинам. Общее проявление этих ошибок видно в различии данных между: проводками и различными отчетами по НДФЛ, заполнении ведомостей на выдачу зарплаты, неверным расчетом НДФЛ при начислении ЗП и т.д.

3600 руб.

09.02.2024    1128    5    5    

8
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. Арчибальд 2707 14.10.10 08:17 Сейчас в теме
Названа разработки сильнО. Фрейд в гробу ворочается... :o
2. Jako 48 14.10.10 11:13 Сейчас в теме
Перебор есть, но другого названия, чтобы коротко и понятно в голову не пришло. Опыт- сын ошибок трудных......
3. ПСВ 114 14.10.10 11:13 Сейчас в теме
я так понял документ заполняете по графику отпусков ,а потом вручную редактируете каждую запись

и заголовк смени , там только букву "р" убрать, это слово даже в википедии есть
почитай - очень забавно! :D
4. Jako 48 14.10.10 11:31 Сейчас в теме
Документ заполняют по заявлению, которое чаще всего ничего общего с графиком не имеет.
5. sound 536 22.10.10 10:36 Сейчас в теме
Может сделать чтобы рабочий год сам подставлялся? Пару строк вставить

ДанныеСтроки = ЭлементыФормы.РаботникиОрганизации.ТекущиеДанные;
ОпределитьРабочийГодОсновногоОтпуска(ДанныеСтроки);
6. sound 536 22.10.10 10:39 Сейчас в теме
хотя нет, парой строк наверно не получится :)
7. sound 536 22.10.10 10:57 Сейчас в теме
Передрал функцию из модуля формы документа отпуска, малость подправил:

Процедура ОпределитьРабочийГодОсновногоОтпуска(ДанныеСтроки, Ссылка)
	Если ДанныеСтроки.Сотрудник.Пустая()
		ИЛИ Не ЗначениеЗаполнено(ДанныеСтроки.ДатаНачала)
		ИЛИ ДанныеСтроки.ПричинаОтсутствия <> Перечисления.ПричиныОтсутствияНаРаботеВОрганизации.ОтпускЕжегодный Тогда
		Возврат;
	КонецЕсли;
	ДатаОкончания = ?(ЗначениеЗаполнено(ДанныеСтроки.ДатаНачалаДоп), ДанныеСтроки.ДатаНачалаДоп - мДлинаСуток, ДанныеСтроки.ДатаОкончания);
	Если Не ЗначениеЗаполнено(ДатаОкончания) Тогда
		Возврат;
	КонецЕсли;
	ЗаполнитьЗначенияСвойств(ДанныеСтроки,ПроцедурыУправленияПерсоналом.РассчитатьПериодРаботыДляОсновногоОтпуска(Ссылка, ДанныеСтроки.Сотрудник, ДанныеСтроки.ДатаНачала, ДатаОкончания));
КонецПроцедуры
Показать


Потом в Вашей обработке в модуле объекта в процедуре Инициализировать() добавил одну строку:

	Если РезФормы = "ОК" Тогда
		ТабличноеПолеОбъекта.ТекущаяСтрока.ДатаНачала= Форма.ЭлементыФормы.ДатаНачалаОсновного.Значение;
		ТабличноеПолеОбъекта.ТекущаяСтрока.ДатаОкончания= Форма.ЭлементыФормы.ДатаОкончания.Значение;
		ОпределитьРабочийГодОсновногоОтпуска(ТабличноеПолеОбъекта.ТекущиеДанные, Объект.Ссылка);
	КонецЕсли; 


Теперь еще рабочий год считает, а то тоже как-то кадровики плакались
Прикрепленные файлы:
ЗТЧ_КалькуляторОтпуска.epf
8. Jako 48 22.10.10 11:40 Сейчас в теме
Огромное спасибо sound проверю и перзалью
9. Jako 48 22.10.10 12:47 Сейчас в теме
Не сконвертилась от sound поправил ручками и перезалил, теперь и с годом, еще раз решпект.
10. gutentag 253 23.11.10 11:11 Сейчас в теме
11. lees 16.05.12 11:22 Сейчас в теме
Добавил в свою ЗУП, спасибо, работает!
12. medv 20.05.13 16:03 Сейчас в теме
Клиенты до сих пор "пользуют" в том или ином документе, и довольны!
спасибо до сих пор говорят.
Оставьте свое сообщение