ЗУП. Арифмометр для документа "Отпуска организаций"

Обработки - Обработка документов

Внешняя обработка заполнения табличной части. Считает конечную дату отпуска в кадровом документе "Отпуска организаций" так же, как и в расчетном документе.

Может быть интересна там, где кадровик и расчетчик - разные люди.

Сделана по просьбе кадровиков, мол не хотим руками отпуск считать, да еще и праздники выбрасывать. Цепляется как обычная форма для заполнения табличных частей. Отлаживалась на платформа 8.1.15.14, конфа ЗУП редакция (2.5.27.6). Военного там ничего нет, на всех ЗУП-ах  вроде должна работать.

Это первая публикация, поэтому интересны любые отзывы почтенного собрания.

Скачать файлы

Наименование Файл Версия Размер
Калькулятор_отпуска
.epf 10,17Kb
22.10.10
95
.epf 10,17Kb 95 Скачать

См. также

Комментарии
1. Александр Рытов (Арчибальд) 2661 14.10.10 08:17 Сейчас в теме
Названа разработки сильнО. Фрейд в гробу ворочается... :o
2. Сергей Корнев (Jako) 47 14.10.10 11:13 Сейчас в теме
Перебор есть, но другого названия, чтобы коротко и понятно в голову не пришло. Опыт- сын ошибок трудных......
3. ПСВ (ПСВ) 113 14.10.10 11:13 Сейчас в теме
я так понял документ заполняете по графику отпусков ,а потом вручную редактируете каждую запись

и заголовк смени , там только букву "р" убрать, это слово даже в википедии есть
почитай - очень забавно! :D
4. Сергей Корнев (Jako) 47 14.10.10 11:31 Сейчас в теме
Документ заполняют по заявлению, которое чаще всего ничего общего с графиком не имеет.
5. sound sound (sound) 524 22.10.10 10:36 Сейчас в теме
Может сделать чтобы рабочий год сам подставлялся? Пару строк вставить

ДанныеСтроки = ЭлементыФормы.РаботникиОрганизации.ТекущиеДанные;
ОпределитьРабочийГодОсновногоОтпуска(ДанныеСтроки);
6. sound sound (sound) 524 22.10.10 10:39 Сейчас в теме
хотя нет, парой строк наверно не получится :)
7. sound sound (sound) 524 22.10.10 10:57 Сейчас в теме
Передрал функцию из модуля формы документа отпуска, малость подправил:

Процедура ОпределитьРабочийГодОсновногоОтпуска(ДанныеСтроки, Ссылка)
	Если ДанныеСтроки.Сотрудник.Пустая()
		ИЛИ Не ЗначениеЗаполнено(ДанныеСтроки.ДатаНачала)
		ИЛИ ДанныеСтроки.ПричинаОтсутствия <> Перечисления.ПричиныОтсутствияНаРаботеВОрганизации.ОтпускЕжегодный Тогда
		Возврат;
	КонецЕсли;
	ДатаОкончания = ?(ЗначениеЗаполнено(ДанныеСтроки.ДатаНачалаДоп), ДанныеСтроки.ДатаНачалаДоп - мДлинаСуток, ДанныеСтроки.ДатаОкончания);
	Если Не ЗначениеЗаполнено(ДатаОкончания) Тогда
		Возврат;
	КонецЕсли;
	ЗаполнитьЗначенияСвойств(ДанныеСтроки,ПроцедурыУправленияПерсоналом.РассчитатьПериодРаботыДляОсновногоОтпуска(Ссылка, ДанныеСтроки.Сотрудник, ДанныеСтроки.ДатаНачала, ДатаОкончания));
КонецПроцедуры
Показать


Потом в Вашей обработке в модуле объекта в процедуре Инициализировать() добавил одну строку:

	Если РезФормы = "ОК" Тогда
		ТабличноеПолеОбъекта.ТекущаяСтрока.ДатаНачала= Форма.ЭлементыФормы.ДатаНачалаОсновного.Значение;
		ТабличноеПолеОбъекта.ТекущаяСтрока.ДатаОкончания= Форма.ЭлементыФормы.ДатаОкончания.Значение;
		ОпределитьРабочийГодОсновногоОтпуска(ТабличноеПолеОбъекта.ТекущиеДанные, Объект.Ссылка);
	КонецЕсли; 


Теперь еще рабочий год считает, а то тоже как-то кадровики плакались
Прикрепленные файлы:
ЗТЧ_КалькуляторОтпуска.epf
8. Сергей Корнев (Jako) 47 22.10.10 11:40 Сейчас в теме
Огромное спасибо sound проверю и перзалью
9. Сергей Корнев (Jako) 47 22.10.10 12:47 Сейчас в теме
Не сконвертилась от sound поправил ручками и перезалил, теперь и с годом, еще раз решпект.
10. Igоr Sаulеviсh (gutentag) 253 23.11.10 11:11 Сейчас в теме
11. lees lees (lees) 16.05.12 11:22 Сейчас в теме
Добавил в свою ЗУП, спасибо, работает!
12. Татьяна Медведева (medv) 20.05.13 16:03 Сейчас в теме
Клиенты до сих пор "пользуют" в том или ином документе, и довольны!
спасибо до сих пор говорят.
Оставьте свое сообщение