Получение курсов валют через веб-сервисы Центробанка РФ

15.03.12

Учетные задачи - Банковские операции

Получение курсов валют напрямую через веб-сервисы Центробанка РФ

Скачать файл

ВНИМАНИЕ: Файлы из Базы знаний - это исходный код разработки. Это примеры решения задач, шаблоны, заготовки для того, чтобы самостоятельно ее доработать для вашей базы данных. Файлы ориентированы на специалистов 1С, которые могут разобраться в коде и оптимизировать программу для запуска в вашей базе данных. Гарантии работоспособности нет. Возврата нет. Технической поддержки нет.

Наименование SM По подписке Купить один файл
Обработка
.zip 11,72Kb
121
121
1 SM
Скачать Купить за 1 850 руб.

Обработка предназначена для демонстрации использования веб-сервисов на примере получения курсов валют напрямую через веб-сервисы Центрального банка РФ.

Платформа 8.2. Толстый клиент.

В архиве также находится WSDL-файл описания всех веб-сервисов Центрального банка РФ.

См. также

Банковские операции Обмен с интернет-банком Эквайринг/ридер магнитных карт Программист Бухгалтер Пользователь Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 Бухгалтерский учет Управленческий учет Платные (руб)

Устали вручную дозаполнять и корректировать документы по банку после загрузки банковской выписки? С помощью правил обработки банковской выписки вы сможете автоматически определять правильный вид хозяйственной операции, заполнять расшифровку, аналитику платежа и многое другое.

15000 руб.

21.03.2023    9149    51    13    

49

Сайты и интернет-магазины Интеграция WEB-интеграция Платформа 1С v8.3 Конфигурации 1cv8 Управленческий учет Платные (руб)

Интеграция 1С и Битрикс 24. Разработка имеет двухстороннюю синхронизацию 1С и Bitrix24 задачами. Решение позволяет создавать пользователя в 1С из Битрикс24 и наоборот. Данная разработка технически подходит под все основные конфигурации линейки продуктов 1С:Предприятие 8.3 (платформа начиная с 8.3.23). При приобретении предоставляется 1 месяц бесплатных обновлений разработки. Доступна демо-версия продукта с подключением Вашего Битрикс24

5040 руб.

04.05.2021    18719    10    15    

16

Сайты и интернет-магазины WEB-интеграция Системный администратор Программист Пользователь Платформа 1С v8.3 Конфигурации 1cv8 1С:Управление торговлей 11 Автомобили, автосервисы Россия Управленческий учет Платные (руб)

Интеграционный модуль обмена между конфигурацией Альфа Авто 5 и Альфа Авто 6 и порталом AUTOCRM. Данный модуль универсален. Позволяет работать с несколькими обменами AUTOCRM разных брендов в одной информационной базе в ручном и автоматическом режиме.

36000 руб.

03.08.2020    16487    15    18    

15

Обмен с интернет-банком Банковские операции Программист Бухгалтер Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Платные (руб)

Модуль представляет собой комплексную автоматизацию обмена данными 1С с банком для БП 3.0, ERP 2.4, ERP 2.5. Выписка клиент-банка загружается и обрабатывается по Вашим правилам. Заполнение реквизитов документов, анализ назначения платежа. Работа с клиент банком не отличается от типового варианта, а документы автоматически заполняются так, как нужно вам. Дополнительная обработка, работающая совместно с основным расширением позволяет подключать собственные произвольные алгоритмы.

20400 руб.

03.04.2013    123598    247    377    

161
Внимание! Тема закрыта. Добавлять сообщения в закрытую тему запрещено.
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. iov 407 25.02.11 13:52 Сейчас в теме
а график где??? он туда сам напрашивается...
2. Dmitryiv 161 25.02.11 14:24 Сейчас в теме
Кому нужен график - сами нарисуют. Обработка создана в академических целях. :D
3. r.pronin 06.11.11 01:29 Сейчас в теме
http://www.cbr.ru/scripts/Root.asp?Prtid=DWS
Я для примера взял загрузку курсов в Excel.
В 8.2.13 все получилось. Вот как-то так.

самая большая хитрость это в конфигураторе надо создать WS-ссылку из адреса http://www.cbr.ru/DailyInfoWebServ/DailyInfo.asmx?WSDL

Вот типа текст.

Перем СервисЕжедневнойИнформации ;

Функция ПолучитьПоследнююДатуУстановкиКурса ()
	ТипWSПарамера	= СервисЕжедневнойИнформации.ФабрикаXDTO.Пакеты.Получить("http://web.cbr.ru/").Получить("GetLatestDateTime"); 
	WSПараметр 		= СервисЕжедневнойИнформации.ФабрикаXDTO.Создать(ТипWSПарамера);
	
	WSРезультат = СервисЕжедневнойИнформации.GetLatestDateTime(WSПараметр);
	
	Возврат WSРезультат.GetLatestDateTimeResult ;

КонецФункции

Функция ПолучитьСписокКотируемыхВалют ()
	// Получаем список валют
	ТипWSПараметра	 	= СервисЕжедневнойИнформации.ФабрикаXDTO.Пакеты.Получить("http://web.cbr.ru/").Получить("EnumValutes"); 
	WSПараметр			= СервисЕжедневнойИнформации.ФабрикаXDTO.Создать(ТипWSПараметра);
	WSПараметр.Seld		= ложь ;
	СписокВалют			= СервисЕжедневнойИнформации.EnumValutes(WSПараметр);
КонецФункции

Процедура КнопкаВыполнитьНажатие(Кнопка)
	
	Если НЕ ЗначениеЗаполнено (ДатаКурса) Тогда
		ДатаКурса = ПолучитьПоследнююДатуУстановкиКурса();
	КонецЕсли;
	
	// Получаем курсы
	ТипWSПараметра 		= СервисЕжедневнойИнформации.ФабрикаXDTO.Пакеты.Получить("http://web.cbr.ru/").Получить("GetCursOnDate"); 
	WSПараметр			= СервисЕжедневнойИнформации.ФабрикаXDTO.Создать(ТипWSПараметра);
	WSПараметр.On_Date	= ДатаКурса ;
	СписокКурсов 		= СервисЕжедневнойИнформации.GetCursOnDate(WSПараметр);
	
	
	// Загрузить 
	КурсыВалют.Очистить();
	Для Каждого Стр Из СписокКурсов.GetCursOnDateresult.diffgram.ValuteData.ValuteCursOnDate Цикл
		Строка = КурсыВалют.Добавить() ;
		Строка.Курс = Стр.Vcurs ;
		Строка.Кратность = Стр.Vnom ;
		Строка.ВалютаКодСимвольный = Стр.VchCode ;
		Строка.ВалютаКодЧисловой = Прав ("000"+Стр.VCode, 3);
		Строка.ВалютаИмя = Стр.VName ;
	КонецЦикла;
	
КонецПроцедуры

Процедура ПолучитьПоследнююДатуУстановкиКурсовНажатие(Элемент)
	ДатаКурса = ПолучитьПоследнююДатуУстановкиКурса ();
КонецПроцедуры


СервисЕжедневнойИнформации	= WSСсылки.CBR_RU_DailyInfoWebServ.СоздатьWSПрокси	("http://web.cbr.ru/", "DailyInfo", "DailyInfoSoap" );
Показать
7. пользователь 11.07.22 09:41
Сообщение было скрыто модератором.
...
4. пользователь 06.11.11 11:47
Сообщение было скрыто модератором.
...
5. пользователь 06.11.11 15:16
Сообщение было скрыто модератором.
...
6. пользователь 06.11.11 17:02
Сообщение было скрыто модератором.
...
Оставьте свое сообщение