Создание ведомостей на выплату зарплаты в банк из XML банка

Публикация № 1203211

Разработка - Системная интеграция - Обмен с интернет-банком

Обработка создает документы ведомость на выплату зарплаты в банк из файлов XML (Выгруженного с банка). Множественный выбор проверено на Бухгалтерии 3.0.62.17.

Для использования необходимо:

1. Необходимо включить использование начислений по зарплате  в этой программе.   Администрирование - параметры учета - настройки зарплаты - общие настройки - в этой программе.

2. Создать зарплатный проект

пример структуры файла XML^

<?xml version="1.0" encoding="Windows-1251" standalone="yes"?>
<СчетаПК ДатаРеестра="2019-01-16+03:00" НомерРеестра="1" БИК="123456789" РасчетныйСчетОрганизации="21212121212121212" ИНН="0000000000" НаименованиеОрганизации="XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX" ДатаДоговора="2018-08-07+03:00" НомерДоговора="67110430" ДатаФормирования="2019-01-16+03:00">
    <РезультатЗачисленияЗарплаты>
        <Сотрудник Нпп="1">
            <Фамилия>Иванов</Фамилия>
            <Имя>Иван</Имя>
            <Отчество>Иванович</Отчество>
            <ЛицевойСчет>12345678901234567890</ЛицевойСчет>
            <Сумма>1000</Сумма>
            <Результат>Зачислено</Результат>
            <РасшифровкаРезультата>Зачисление успешно проведено</РасшифровкаРезультата>
        </Сотрудник>
        <Сотрудник Нпп="2">
            <Фамилия>Петров</Фамилия>
            <Имя>Петр</Имя>
            <Отчество>Петрович</Отчество>
            <ЛицевойСчет>12345678901234567890</ЛицевойСчет>
            <Сумма>2000</Сумма>
            <Результат>Зачислено</Результат>
            <РасшифровкаРезультата>Зачисление успешно проведено</РасшифровкаРезультата>
        </Сотрудник>
        <Сотрудник Нпп="3">
            <Фамилия>Сидоров</Фамилия>
            <Имя>Сидр</Имя>
            <Отчество>Сидорович</Отчество>
            <ЛицевойСчет>12345678901234567890</ЛицевойСчет>
            <Сумма>3000</Сумма>
            <Результат>Зачислено</Результат>
            <РасшифровкаРезультата>Зачисление успешно проведено</РасшифровкаРезультата>
        </Сотрудник>
    </РезультатЗачисленияЗарплаты>
    <ВидЗачисления>01</ВидЗачисления>
    <КонтрольныеСуммы>
        <КоличествоЗаписей>3</КоличествоЗаписей>
        <СуммаИтого>6000</СуммаИтого>
    </КонтрольныеСуммы>
</СчетаПК>

 

Если в вашей конфигурации нет сотрудника или физического лица то он их создаст и примет на работу на начало месяца из даты реестра. каждый документ ведомости будет на дату из каждого файлика.

&НаКлиенте
Процедура Загрузить(Команда)
    ЧтениеВРучную_XML()
КонецПроцедуры

&НаКлиенте
Функция ПолучитьПутьКФайлу(Режим)
    Диалог = Новый ДиалогВыбораФайла(Режим);
    Диалог.Заголовок = "Выбрать"; 
    Диалог.Фильтр = "XML (*.xml)|*.xml"; 
    Диалог.МножественныйВыбор = Истина;
    Если Диалог.Выбрать() тогда
        Возврат Диалог;            
    Иначе                
        возврат Неопределено;
    КонецЕсли;
КонецФункции

&НаКлиенте
Процедура ЧтениеВРучную_XML()
    ПутьКФайлу =  ПолучитьПутьКФайлу(РежимДиалогаВыбораФайла.Открытие);
    Если ПутьКФайлу = Неопределено Тогда
        возврат;
    КонецЕсли;

    
    МассивФайлов = ПутьКФайлу.ВыбранныеФайлы;
    Для Каждого ИмяФайла Из МассивФайлов Цикл
        
        ВыбФайл = Новый Файл(ИмяФайла);
        ЧтениеXML = Новый ЧтениеXML; 
        ЧтениеXML.ОткрытьФайл(ВыбФайл.ПолноеИмя);
        

        
        ТекущееИмяУзла = "";
        Пока ЧтениеXML.Прочитать() Цикл
            Если ЧтениеXML.ТипУзла = ТипУзлаXML.НачалоЭлемента И ЧтениеXML.Имя = "СчетаПК" Тогда     
                ТаблицаРеестра.Очистить();
                
                ДатаДокумента = Дата( СтрЗаменить(Лев(ЧтениеXML.ЗначениеАтрибута("ДатаРеестра"),10),"-",""));
                Продолжить;
            ИначеЕсли ЧтениеXML.ТипУзла = ТипУзлаXML.НачалоЭлемента И ЧтениеXML.Имя = "Сотрудник" Тогда            
                НоваяСтрока = ТаблицаРеестра.Добавить();    
                Продолжить;    
            ИначеЕсли ЧтениеXML.ТипУзла = ТипУзлаXML.НачалоЭлемента И ЧтениеXML.Имя = "Фамилия" Тогда            
                ТекущееИмяУзла = ЧтениеXML.Имя;    
                Продолжить;
            ИначеЕсли ЧтениеXML.ТипУзла = ТипУзлаXML.НачалоЭлемента И ЧтениеXML.Имя = "Имя" Тогда            
                ТекущееИмяУзла = ЧтениеXML.Имя;    
                Продолжить;
            ИначеЕсли ЧтениеXML.ТипУзла = ТипУзлаXML.НачалоЭлемента И ЧтениеXML.Имя = "Отчество" Тогда            
                ТекущееИмяУзла = ЧтениеXML.Имя;    
                Продолжить;
            ИначеЕсли ЧтениеXML.ТипУзла = ТипУзлаXML.НачалоЭлемента И ЧтениеXML.Имя = "ЛицевойСчет" Тогда            
                ТекущееИмяУзла = ЧтениеXML.Имя;    
                Продолжить;
            ИначеЕсли ЧтениеXML.ТипУзла = ТипУзлаXML.НачалоЭлемента И ЧтениеXML.Имя = "Сумма" Тогда            
                ТекущееИмяУзла = ЧтениеXML.Имя;    
                Продолжить;    
            
            ИначеЕсли ЧтениеXML.ТипУзла = ТипУзлаXML.Текст Тогда     
                Если ТекущееИмяУзла = "Фамилия" ТОгда 
                    НоваяСтрока.Фамилия = ЧтениеXML.Значение;
                ИначеЕсли ТекущееИмяУзла = "Имя" ТОгда 
                    НоваяСтрока.Имя = ЧтениеXML.Значение;    
                ИначеЕсли ТекущееИмяУзла = "Отчество" ТОгда 
                    НоваяСтрока.Отчество = ЧтениеXML.Значение;
                ИначеЕсли ТекущееИмяУзла = "ЛицевойСчет" ТОгда 
                    НоваяСтрока.ЛицевойСчет = ЧтениеXML.Значение;    
                ИначеЕсли ТекущееИмяУзла = "Сумма" ТОгда 
                    НоваяСтрока.Сумма = Число(ЧтениеXML.Значение);
                КонецЕсли;
                Продолжить;
            ИначеЕсли ЧтениеXML.ТипУзла = ТипУзлаXML.КонецЭлемента И ЧтениеXML.Имя = "Сумма" Тогда
                ТекущееИмяУзла = "";
                Продолжить;
            КонецЕсли;
            
        КонецЦикла;
        ЧтениеXML.Закрыть();
        НовыйДокументНаСервере(ДатаДокумента, ТаблицаРеестра)
    КонецЦикла;
    
    ПоказатьОповещениеПользователя("Уведомление",,"Документ записан!",БиблиотекаКартинок.Успешно32);
КонецПроцедуры

&НаСервере
Процедура НовыйДокументНаСервере(ДатаДокумента,знач Таблица)
    новаяВедомость = Документы.ВедомостьНаВыплатуЗарплатыВБанк.СоздатьДокумент();
    новаяВедомость.ПериодРегистрации = НачалоМесяца(ДатаДокумента);
    новаяВедомость.Дата = ДатаДокумента;
    новаяВедомость.Организация = Объект.Организация;
    новаяВедомость.ЗарплатныйПроект = Объект.ЗарплатныйПроект;
    новаяВедомость.СпособВыплаты = Справочники.СпособыВыплатыЗарплаты.Зарплата;
    новаяВедомость.Округление = Справочники.СпособыОкругленияПриРасчетеЗарплаты.НайтиПоНаименованию("Без округления");
        
    Для каждого Стр из Таблица Цикл
        
        ФИОФИЗЛИЦА = Справочники.ФизическиеЛица.НайтиПоНаименованию(Стр.Фамилия + " " + Стр.Имя + " " + Стр.Отчество);
        Если ФИОФИЗЛИЦА = Справочники.ФизическиеЛица.ПустаяСсылка() Тогда 
            НовыйФизЛицо = Справочники.ФизическиеЛица.СоздатьЭлемент();
            НовыйФизЛицо.Наименование = Стр.Фамилия + " " + Стр.Имя + " " + Стр.Отчество;
            НовыйФизЛицо.ФИО = Стр.Фамилия + " " + Стр.Имя + " " + Стр.Отчество;
            НовыйФизЛицо.Фамилия = Стр.Фамилия;
            НовыйФизЛицо.Имя = Стр.Имя;
            НовыйФизЛицо.Отчество = Стр.Отчество;    
            НовыйФизЛицо.Записать();
        КонецЕсли;
        
        ФИОСотрудника = Справочники.Сотрудники.НайтиПоНаименованию(Стр.Фамилия + " " + Стр.Имя + " " + Стр.Отчество); 
        Если ФИОСотрудника = Справочники.Сотрудники.ПустаяСсылка() Тогда 
            НовыйСотрудник = Справочники.Сотрудники.СоздатьЭлемент();
            НовыйСотрудник.Наименование = Справочники.ФизическиеЛица.НайтиПоНаименованию(Стр.Фамилия + " " + Стр.Имя + " " + Стр.Отчество).Наименование;
            НовыйСотрудник.ФизическоеЛицо = Справочники.ФизическиеЛица.НайтиПоНаименованию(Стр.Фамилия + " " + Стр.Имя + " " + Стр.Отчество);
            НовыйСотрудник.ГоловнаяОрганизация = Объект.Организация;            
            НовыйСотрудник.Записать();
            
            МенеджерЗаписи = РегистрыСведений.ФИОФизическихЛиц.СоздатьМенеджерЗаписи();
            МенеджерЗаписи.ФизическоеЛицо = Справочники.ФизическиеЛица.НайтиПоНаименованию(Стр.Фамилия + " " + Стр.Имя + " " + Стр.Отчество);
            МенеджерЗаписи.Фамилия = Стр.Фамилия;
            МенеджерЗаписи.Имя = Стр.Имя;
            МенеджерЗаписи.Отчество = Стр.Отчество;
            МенеджерЗаписи.Период = НачалоМесяца(ДатаДокумента);        
            МенеджерЗаписи.Записать();
            
            МенеджерЗаписи1 = РегистрыСведений.ОсновныеСотрудникиФизическихЛиц.СоздатьМенеджерЗаписи();
            МенеджерЗаписи1.ГоловнаяОрганизация = Объект.Организация;
            МенеджерЗаписи1.ФизическоеЛицо = Справочники.ФизическиеЛица.НайтиПоНаименованию(Стр.Фамилия + " " + Стр.Имя + " " + Стр.Отчество);
            МенеджерЗаписи1.Сотрудник = Справочники.Сотрудники.НайтиПоНаименованию(Стр.Фамилия + " " + Стр.Имя + " " + Стр.Отчество);
            МенеджерЗаписи1.ДатаОкончания = '39991231';
            МенеджерЗаписи1.Записать();
            
            МенеджерЗаписи2 = РегистрыСведений.ТекущиеКадровыеДанныеСотрудников.СоздатьМенеджерЗаписи();
            МенеджерЗаписи2.ТекущаяОрганизация = Объект.Организация;
            МенеджерЗаписи2.ГоловнаяОрганизация = Объект.Организация;
            МенеджерЗаписи2.ФизическоеЛицо = Справочники.ФизическиеЛица.НайтиПоНаименованию(Стр.Фамилия + " " + Стр.Имя + " " + Стр.Отчество);
            МенеджерЗаписи2.Сотрудник = Справочники.Сотрудники.НайтиПоНаименованию(Стр.Фамилия + " " + Стр.Имя + " " + Стр.Отчество);
            МенеджерЗаписи2.ДатаПриема = НачалоМесяца(ДатаДокумента);
            МенеджерЗаписи2.ОсновноеРабочееМестоВОрганизации = Истина;
            МенеджерЗаписи2.Записать();
            
        КонецЕсли;
        
        
        
        ИдентификаторСтроки = Новый УникальныйИдентификатор;
        
        ДобавитьСтрокуСостава = новаяВедомость.Состав.Добавить();
        ДобавитьСтрокуСостава.ИдентификаторСтроки = ИдентификаторСтроки;
        ДобавитьСтрокуСостава.ФизическоеЛицо = Справочники.ФизическиеЛица.НайтиПоНаименованию(Стр.Фамилия + " " + Стр.Имя + " " + Стр.Отчество);
        ДобавитьСтрокуСостава.НомерЛицевогоСчета = Стр.ЛицевойСчет;
        
        ДобавитьСтрокуЗарплата = новаяВедомость.Зарплата.Добавить();
        ДобавитьСтрокуЗарплата.ИдентификаторСтроки = ИдентификаторСтроки;
        ДобавитьСтрокуЗарплата.Сотрудник = Справочники.Сотрудники.НайтиПоНаименованию(Стр.Фамилия + " " + Стр.Имя + " " + Стр.Отчество);
        ДобавитьСтрокуЗарплата.ФизическоеЛицо = Справочники.ФизическиеЛица.НайтиПоНаименованию(Стр.Фамилия + " " + Стр.Имя + " " + Стр.Отчество);
        ДобавитьСтрокуЗарплата.ПериодВзаиморасчетов = НачалоМесяца(ДатаДокумента);
        ДобавитьСтрокуЗарплата.СтатьяРасходов = Справочники.СтатьиФинансированияЗарплата.НайтиПоКоду("ОТ");    
        ДобавитьСтрокуЗарплата.КВыплате = стр.Сумма;
        ДобавитьСтрокуЗарплата.НомерЛицевогоСчета = Стр.ЛицевойСчет;

        ДобавитьСтрокуФизЛица = новаяВедомость.ФизическиеЛица.Добавить();
        ДобавитьСтрокуФизЛица.ФизическоеЛицо = Справочники.ФизическиеЛица.НайтиПоНаименованию(Стр.Фамилия + " " + Стр.Имя + " " + Стр.Отчество);

    КонецЦикла;
    
    
    новаяВедомость.Записать(РежимЗаписиДокумента.Проведение);
    
КонецПроцедуры

 

Скачать файлы

Наименование Файл Версия Размер
Создание ведомостей на выплату зарплаты в банк из XML банка :

.epf 8,04Kb
1
.epf 1 8,04Kb 1 Скачать

Специальные предложения

Оставьте свое сообщение

См. также

Выгрузка реестра зарплаты в ГазПромБанк ЗУП 2.5 c ведущими нулями Промо

Обмен с банком Банковские операции Зарплата Банковские операции Зарплата v8 v8::СПР ЗУП2.5 Россия БУ Абонемент ($m)

Корректно выгружает в текстовый формат поля, начинающиеся на НОЛЬ (Например, серии паспортов вида 0803)

5 стартмани

16.05.2016    33529    16    asher72    1    

Клиент-Банк для УНФ (для Украины) редакция 1.6. Управляемые формы

Обмен с банком v8 v8::УФ УНФ Украина БУ Абонемент ($m)

Обработка Клиент-Банк для УНФ (Украина) с правилами обмена по банкам Пивденный и УкрСибБанк.

2 стартмани

25.02.2021    351    0    user1004898    0    

Загрузка валютной выписки БП 3.0 - исправление ошибок

Банковские операции Обмен с банком v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Исправление ошибок поиска контрагента при загрузке валютной выписки.

1 стартмани

27.10.2020    1391    1    KVIKS    0    

Выгрузка зарплаты в Россельхозбанк

Банковские операции Зарплата Обмен с банком Загрузка и выгрузка в Excel v8::СПР v8::УФ ЗУП3.x БУ Абонемент ($m)

Выгрузка в банк в текстовом и Excel формате для конфигурации ЗУП 3.1.

1 стартмани

26.10.2020    1259    4    Olesia010    1    

Обмен с банком с формированием имени файла по номеру выгружаемой ведомости для 1С: ЗУП

Обмен с банком v8::СПР v8::УФ ЗУП3.x Россия БУ Абонемент ($m)

Обработка необходима бухгалтерам по зарплате, для формирования файлов начислений с именами по номерам ведомостей в базе 1С для выгрузки в банк, а также для загрузки из банка полученных счетов с формированием документов: "Заявки на открытие лицевых счетов", "Подтверждение открытия счетов", а также формируются записи в регистре сведений "Лицевые счета сотрудников". Помимо прочего реализовано автоматическое изменение зарплатного проекта в карточках сотрудников в соответствии с поставляемым списком реестра счетов из банка. Тестирование на версии ЗУП КОРП 3.1 (3.1.15.40).

2 стартмани

06.10.2020    1745    5    Pom2    0    

Выгрузка из ЗУП 3.1 на карты сотрудников для банка "Энергобанк"

Обмен с банком v8::СПР v8::УФ ЗУП3.x БУ Абонемент ($m)

Выгружает в текстовый файл данные из документа ЗуП для загрузки в банк "Энергобанк"

1 стартмани

10.08.2020    1761    1    nico2    1    

Автоматическая загрузка выписок в 1С из клиент банка

Банковские операции Обмен с банком v8 УНФ БГУ БП3.0 БАУ Россия БУ Абонемент ($m)

Загружает выписки в 1с через электронную почту высланные банком.

2 стартмани

06.08.2020    3869    20    user1209971    7    

Удобная выгрузка зарплаты в формат CSV для Сбербанк Бизнес Онлайн (ЗУП 2.5) Промо

Обмен с банком Банковские операции Зарплата Банковские операции Зарплата v8 ЗУП2.5 Россия БУ Абонемент ($m)

Самая удобная внешняя обработка для бухгалтера, не требует лишних действий! Выбрал документ и выгрузил в формате CSV для Сбербанк Бизнес Онлайн

10 стартмани

06.11.2015    41944    29    adinez    7    

Заполнение банковских выписок. БП 3.0

Банковские операции Обмен с банком v8::БУ БП3.0 Россия БУ Абонемент ($m)

Данное расширение предназначено для автоматического заполнения реквизитов в выписках из банка. Возможно заполнение любых реквизитов документов "Поступление на расчетный счет" и "Списание с расчетного счета".

1 стартмани

04.08.2020    2544    15    Tash.B    19    

Выгрузка ведомостей в банк в формат CSV для ЗУП 3.1

Зарплата Банковские операции Обмен с банком v8::СПР v8::УФ ЗУП3.x БУ Абонемент ($m)

Обработка для выгрузки документов "Ведомость в банк" в формате CSV для ЗУП 3.1.

1 стартмани

14.07.2020    2693    0    Neuroproton    0    

Выгрузка зарплаты в Аверс банк

Банковские операции Зарплата Обмен с банком v8::СПР v8::УФ ЗУП3.x БУ Абонемент ($m)

Внешняя обработка для создания реестра и TXT файла выгрузки перечисления зарплаты в Аверс банк.

1 стартмани

11.06.2020    2019    2    WeterSoft    2    

Выгрузка в банк Уралсиб из БП 3.0 Промо

Обмен с банком Банковские операции Банковские операции v8 БП3.0 БУ Абонемент ($m)

Внешняя обработка для выгрузки зарплатной ведомости и зарплатных счетов сотрудников

2 стартмани

15.09.2015    15353    0    hawk    0    

Выгрузка зарплаты в банк в новом формате XML (Сбербанк, ПСБ и прочие)

Зарплата Обмен с банком Обмен через XML v8::СПР v8::УФ ЗКГУ3.0 ЗУП3.x БУ Госбюджет Абонемент ($m)

Выгрузка зарплаты в банк в новом формате XML согласно Указанию ЦБ от 14.10.2019 № 5286-У.

1 стартмани

09.06.2020    4942    30    forestman2010    4    

Ошибка "Код назначения платежа" при загрузке из банк-клиента

Обмен с банком v8::БУ БП2.0 Россия БУ Абонемент ($m)

Исправленная обработка КлиентБанк, позволяет загрузить платежные документы из банка в 1С, игнорируя код назначения платежа. Будет полезна тем, у кого старая версия Бухгалтерии предприятия.

1 стартмани

03.06.2020    5941    10    Gr@y    3    

1С:Деньги: Загрузка выписки банка из личного кабинета Тинькофф Банка

Обмен с банком Учет доходов и расходов WEB Интеграция v8 1cv8.cf Домашние учет и финансы УУ Абонемент ($m)

Для тех, кто ведет домашние финансы в 1С:Деньги и пользуется услугами Тинькофф Банка. Расширение позволяет загружать операции из личного кабинета Тинькофф Банка напрямую, без промежуточных файлов.

1 стартмани

18.05.2020    4155    17    Bazil    25    

Выгрузка данных по зарплатному проекту для ЗАО "КРЕДИТ ЕВРОПА БАНК" в Excel (для 1С 8.2 HRM) Промо

Обработка документов Загрузка и выгрузка в Excel Обмен с банком Зарплата Зарплата v8 ЗКБУ Россия Абонемент ($m)

Внешняя обработка: Выгрузка данных по зарплатному проекту для ЗАО "КРЕДИТ ЕВРОПА БАНК" с созданием файла Excel в 1С 8.2 HRM

1 стартмани

09.11.2011    47856    178    02RUSlan    28    

Выгрузка зарплаты в АК Барс банк

Банковские операции Зарплата Обмен с банком v8::СПР v8::УФ ЗУП3.x БУ Абонемент ($m)

Выгрузка зарплаты (ведомости) в АК Барс банк для ЗУП 3.1 форматы TXT и DBF.

1 стартмани

28.04.2020    2359    2    WeterSoft    0    

Импорт реестра Сбербанка для БП 3.0

Обмен с банком v8::БУ БП3.0 Россия БУ Абонемент ($m)

Импорт реестра оплаты физических лиц из Сбербанка в документ "Поступление на расчетный счет". Обработка предназначена для 1С8:Бухгалтерия предприятия 3.0 (УФ). Проверена на версии 3.0.76.77

2 стартмани

27.04.2020    2798    9    islogin400    1    

Реестр на выплату по зарплатному проекту ДВБ (Дальневосточный банк) Excel

Загрузка и выгрузка в Excel Обмен с банком Банковские операции Зарплата v8 v8::БУ v8::СПР БП3.0 ЗУП3.x Россия БУ Абонемент ($m)

Внешняя печатная формы "Реестра на выплату" по зарплатному проекту банка Дальневосточный. Механизм простой: Добавляем обработку в базу - Из документа "Ведомость на выплату" выводим на печать - Сохраняем в Excel - Отправляем в банк. Есть возможность сформировать для резидентов и не резидентов.

1 стартмани

16.04.2020    3211    1    machnef    0    

Выгрузка в банк из "Камин" заработной платы Промо

Обмен с банком Банковские операции Зарплата Банковские операции Зарплата v8 1cv8.cf БУ Абонемент ($m)

Выгрузку можно делать для 2 банков ВТБ и Уралсиб, уралсиб выгружает 2 вида файлов

2 стартмани

23.10.2014    23653    0    hawk    1    

Автозагрузка банковских выписок (БП 3.0)

Банковские операции Обмен с банком v8 v8::БУ БП3.0 БУ Абонемент ($m)

Расширение позволяет автоматизировать загрузку банковских выписок в программу 1С:Бухгалтерия предприятия, ред. 3.0. При начальной настройке создается регламентное задание. Период срабатывания регламентного задания в дальнейшем можно поменять в консоли заданий. Требуется указать каталог, из которого нужно загружать банковские выписки.

1 стартмани

06.04.2020    5976    7    primat    10    

Загрузка платежных поручений из УРМ для БГУ 2.0

Банковские операции Обмен с банком v8 v8::БУ БГУ Россия БУ Абонемент ($m)

Загрузка платежных поручений из Управляемого Рабочего Места в БГУ 2.0. Обработка загружает платежные поручения в 1С:БГУ 2.0 из выгруженного файла УРМ.

2 стартмани

06.04.2020    3040    13    Grosheva    0    

Импорт (загрузка) платежных поручений из WEB-Исполнение в БГУ 2.0. По формату обмена TXPP190513

Внешние источники данных Обмен с банком v8 v8::БУ БГУ Россия Госбюджет Абонемент ($m)

Загрузка платежных поручений из файла в БГУ 2.0 . Тестировалось на релизе 2.0.68.16

1 стартмани

02.03.2020    3202    13    Rafhat    6    

Выгрузка в Сбербанк Промо

Файловые протоколы обмена, FTP Обмен с банком Банковские операции Зарплата Банковские операции Зарплата v8 ЗКБУ Государственные, бюджетные структуры Россия БУ Абонемент ($m)

Обработка для выгрузки списка лицевых счетов для зачисления заработной платы в формате DBF, согласно требованиям СБРФ

1 стартмани

31.01.2013    28646    134    alfaservice    7    

Клиент-банк УкрСибБанк для Украины

Обмен с банком v8::БУ УПП1 Украина БУ Абонемент ($m)

В январе 2020 года украинские банки перешли на новый формат расчетного счета - IBAN. И почти все банки поменяли структуру и формат выгрузки данных, которые использовались для импорта в 1С8. Это коснулось и банка УкрСибБанк. Раньше использовался файл формата DBF. Сейчас банк выгружает данные в формате XLS. Для решения задачи обмена было сделано следующее:

1 стартмани

11.02.2020    4883    8    sojuznik    0    

Загрузка строк выписки банка (расход) на основании файлов выгрузки из ЗУП по ВТБ и РСХБ (и подобных)

Обработка документов Банковские операции Обмен с банком v8::ОУ v8::УФ УТ11 Россия УУ Абонемент ($m)

Загрузка строк выписки банка (расход) на основании файлов выгрузки из ЗУП по ВТБ (обработка банка для выгрузки ведомостей в клиент-банк) и РСХБ (стандартная выгрузка в файл).

1 стартмани

10.02.2020    2279    0    Alexkoz1980    0    

Выгрузка зарплатных ведомостей для импорта в "Приват24 для Бизнеса"

Банковские операции Зарплата Обмен с банком v8 v8::БУ БП3.0 Украина БУ Абонемент ($m)

Обработка выгрузки зарплатных ведомостей для импорта в “Приват24 для Бизнеса”. Для BAS Бухгалтерия и BAS Бухгалтерия КОРП. Формат DBF.

1 стартмани

22.01.2020    3122    3    user1035175    5    

Загрузка операций по карте Сбербанка в 1С:Деньги Промо

Обмен с банком Банковские операции Банковские операции v8 1cv8.cf Домашние учет и финансы Россия Абонемент ($m)

Обработка для импорта операций по карте Сбербанка в 1С:Деньги; Сегодня многие платят за покупки с помощью банковских карт. Особенно актуально если у вас зарплатная карта от Сбербанка и вы ведете учет личных финансов в программе 1С Деньги. В какой-то момент мне надоело коллекционировать чеки и я написал эту обработку. :) Надеюсь вам она тоже сэкономит личное время. UPD Добавлена версия для "Деньги 8, редакция 2.0 (2.0.18.6)"

1 стартмани

01.09.2013    30569    66    el-gamberro    33    

Загрузка из Клиент-банка, автоматическое заполнение договора и счета на оплату

Обмен с банком Банковские операции v8::БУ БП3.0 Россия БУ Абонемент ($m)

Учим Клиент-банк «читать» Назначение платежа из файла загрузки. Как правило, текст содержит достаточно информации для поиска договора контрагента и счета на оплату.

2 стартмани

11.12.2019    5766    30    suvig    31    

Загрузка данных из реестров Сбербанка

Обмен с банком v8::БУ БГУ Государственные, бюджетные структуры Россия БУ Абонемент ($m)

Внешняя обработка, предназначенная для автоматического занесения данных из реестров Сбербанка в 1С:Бухгалтерию.

1 стартмани

10.12.2019    3182    2    vlan76    0    

Клиент-банк для Комплексной автоматизации 2 (2.4.10.56)

Банковские операции Обмен с банком v8::БУ КА2 Россия БУ Абонемент ($m)

Расширение функционала клиент-банка для КА 2.

1 стартмани

13.11.2019    4672    8    maks_20    9    

Зачисление на карты Сбербанка групповое (1С ЗКБУ 8.2) Промо

Обработка документов Обмен с банком Банковские операции Зарплата Банковские операции Зарплата v8 ЗКБУ Абонемент ($m)

Изменил типовую обработку "Операции с лицевыми счетами". Позволяет сформировать один общий файл выгрузки по группе документов "Ведомость в банк" и распечатать Реестр. При наличии одного и того же физлица в разных документах - суммы схлопываются.

1 стартмани

24.02.2012    22199    125    LuckyBeast    16    

Выгрузка реестра (ведомости) по зарплате в Газпромбанк в формате xls (БП 3 / ЗУП 3)

Зарплата Обмен с банком Загрузка и выгрузка в Excel v8 v8::БУ БП3.0 Абонемент ($m)

Обработка позволяет выгрузить документ "Ведомость на выплату зарплаты" из 1С:Бухгалтерия предприятия 3.0, Зарплата и Управление персоналом 3.0 в онлайн-банк Газпромбанк по установленному формату (Excel).

1 стартмани

27.09.2019    3920    9    deemko48    0    

Обмен с Ситибанком в формате CDFF, МТ940 и PAYROLL

Обмен с банком Банковские операции Банковские операции v8 v8::БУ v8::СПР БП3.0 ЗУП3.x Россия БУ Абонемент ($m)

1. Обработка Клиент-банк для 1С:Бухгалтерия предприятия 3.0 (релиз 3.0.67.63) для работы с CitiDirect . Выгрузка в формате CDFF, загрузка – SWIFT MT940. 2. Обработка Обмен с банками для 1С:Зарплата и управление персоналом 3.1. (релиз 3.1.9.205) Выгрузка в формате PAYROLL CARDS FORMAT.

1 стартмани

20.08.2019    5590    62    leon111    7    

Перевод номера банковского счета в стандарт IBAN для Украины

Обмен с банком Банковские операции Банковские операции v8 1cv8.cf Украина Абонемент ($m)

Перевод номера банковского счета в стандарт IBAN (только для Украины). Функции для повторного использования и демо-обработка для платформы 1С 8.х. Тестировалась на платформе 1С 8.3.12.1529

1 стартмани

09.08.2019    12865    3    alexpot    6    

Клиент-банк для Бухгалтерии 8.2 (БП 2.0). Гибкая настройка загрузки на основе построителя. Быстрое чтение из файла. Промо

Обмен с банком Банковские операции Банковские операции v8 v8::БУ БП2.0 Россия БУ Абонемент ($m)

Обычный клиент-банк решает за вас, как будет выглядеть загруженное. Сколько документов приходится обрабатывать дополнительно? Часто ли вы восклицали "уж лучше бы я это вручную создал!", меняя вид операции, реквизиты документа, а то и заводя новый? Если это про вас - ловите шанс на облегчение жизни :) Обработка основана на стандартном клиент-банке из одного из последних релизов БП 2.0 под 8.2 (2.0.29.10). Изменения коснулись ТОЛЬКО блока загрузки, блок выгрузки целиком типовой. UPD 08/04/2014: учтены изменения по ФЗ 107-н (по релизу 2.0.56.3). ВНИМАНИЕ для всех, кто ищет аналог для БП 3! Вышла (не моя и платная) обработка: https://infostart.ru/public/632621/ С автором никак не связана, не тестировала, но поскольку часто задают вопрос "а когда" - желающим пока туда. Если кто по результатам сможет написать мне в личку - буду очень благодарна. Обработка для 3.0 с более длинной историей: https://infostart.ru/public/180797/ (так же не смотрела и не щупала, но скриншоты обнадёживают).

1 стартмани

17.06.2011    41514    695    e.kogan    110    

Выгрузка компенсации родительской платы в Сбербанк в формате dbf. БГУ 2.0

Банковские операции Файловые протоколы обмена, FTP Обмен с банком Банковские операции v8 v8::БУ БГУ Россия БУ Абонемент ($m)

Была необходимость выгрузить ведомость компенсации родительской платы в сбербанк в формате DBF. Почему-то банк требовал именно этот формат. Конфигурация Бухгалтерия государственного учреждения 2.0.

1 стартмани

07.08.2019    4773    8    agates    3    

Обработка реестров начислений Сбербанк

Обработка документов Обмен с банком Банковские операции Банковские операции v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Экспорт реестра счетов (начислений) на оплату в Сбербанк бизнес онлайн, импорт реестра платежей.

1 стартмани

17.07.2019    3263    1    denissekh    2    

Загрузка реестра платежей физических лиц из Сбербанка бизнес онлайн

Обмен с банком Банковские операции Банковские операции v8::БУ БП3.0 Россия БУ Абонемент ($m)

Обработка загружает реестры платежей Сбербанка Бизнес Онлайн в документ "Операции по платежным картам".

1 стартмани

08.07.2019    13364    68    Poyarkov696    9    

Выгрузка начислений в Альфа-банк Промо

Обмен с банком Зарплата Зарплата v8 ЗУП2.5 ЗКБУ УПП1 Россия БУ Абонемент ($m)

Обработка позволяет подготовить файл начислений для Альфа банка, который полностью соответствует требованиям банка.

1 стартмани

23.10.2012    33173    94    Lyns_owner    28    

Загрузка реестра Сбербанка для 1С:Расчет квартплаты и бухгалтерия ЖКХ 3

Обмен с банком Банковские операции Банковские операции v8 v8::БУ БП3.0 Энергетика и ЖКХ Россия БУ Абонемент ($m)

Загрузка реестра в Сбербанк бизнес онлайн по лицевым счетам. Загрузка реестра из СБЕРБАНКА. Указывается файл загрузки, По нажатию на кнопку "Прочитать файл" заполняется табличная часть для просмотра. По шаблону 10_2 (шаблон 10 2).

2 стартмани

25.06.2019    5030    3    kras_dar    0    

Обработка для импорта выписки из iFOBS Client ОТП-банка в 1С (поддерживается DBF)

Банковские операции Обмен с банком Файловые протоколы обмена, FTP Банковские операции v8::БУ БП2.0 Украина БУ Абонемент ($m)

Бухгалтерия управляемые формы работает 1С:Предприятие 8.3 (8.3.12.) можно пребывать в других конфигурациях .Обработка для импорта выписки банка ОТП-банк, получаемой из клиента-банка iFOBS. А также банк Аваль Подключается к внешней обработке "Обмен данными с системами "Клиент-банк""

3 стартмани

21.06.2019    6843    4    pashaa2002    0    

ДиректБанк: автоматическая загрузка и разбор банковских выписок по расписанию для УТ 11.4

Обмен с банком Банковские операции Банковские операции v8::ОУ v8::УФ УТ11 Россия БУ Абонемент ($m)

Обработка предназначена для автоматической загрузки по расписанию выписок по расчетному счету из сервиса Директ Банк, без использования цифровой подписи и СМС.

2 стартмани

16.06.2019    6496    21    Hexkiller    7    

Выгрузка в банки (ведомости и заявки на открытие) для ЗУП 3.1

Обмен с банком Банковские операции Зарплата Управление персоналом (HRM) Банковские операции Зарплата Управление персоналом (HRM) v8::СПР v8::УФ ЗУП3.x Россия БУ Абонемент ($m)

Выгрузка в банки (очередная): Газпромбанк: XLS, TXT, XML ВТБ24 АльфаБанк ВБРР Уралсиб Выгрузка может производится из следующих документов (имя метаданных): Ведомость в банк (ВедомостьНаВыплатуЗарплатыВБанк) Ведомость прочих доходов в банк (ВедомостьПрочихДоходовВБанк) Ведомость прочих доходов на счета (ВедомостьПрочихДоходовПеречислением) Ведомость на счета (ВедомостьНаВыплатуЗарплатыПеречислением) Выплата бывшим сотрудникам (ВыплатаБывшимСотрудникам) Так же реализована выгрузка заявок на открытие счета ГазпромбанкКарты: XLS,TXT,XML ВТБ24.

1 стартмани

28.05.2019    5206    36    navic    1    

Выгрузка зарплатной ведомости для Альфабанк: АЗОН или создаем файл xls с несколькими листами без использования Excel

Загрузка и выгрузка в Excel Обмен с банком Банковские операции Зарплата Банковские операции Зарплата v8::БУ КА1 ЗУП2.5 ЗКБУ УПП1 Россия БУ Абонемент ($m)

Альфабанк является одним из крупнейших банков в нашей стране. В корпоративном секторе этот банк предлагает своим клиентам множество услуг, в число которых входит зарплатный проект - "Альфа-Зарплата Онлайн" или знакомый многим как "АЗОН". В АЗОН есть возможность загрузки зарплатных ведомостей из файлов XLS. Но в формате файла есть небольшая особенность: в файле должно быть несколько листов с различными данными. В этой публикации разберемся, как сформировать такой файл без использования COM-объекта Microsoft Excel.

1 стартмани

26.04.2019    7567    5    Johny_v    0    

Загрузка лицевых счетов в ЗУП 3.1 из эксель и выгрузка в эксель по шаблону Газпромбанка

Обмен с банком Банковские операции Зарплата Банковские операции Зарплата v8 v8::СПР v8::УФ ЗУП3.x Россия БУ Абонемент ($m)

Внешняя обработка, позволяющая произвести Загрузку лицевых счетов в ЗУП 3.1 из эксель и выгрузку в эксель по шаблону ГАзпромбанка. Первая часть производит загрузку лицевых карточных счетов сотрудников в базу. вторая часть отвечает за выгрузку зарплаты в банк согласно документу "ВедомостьНаВыплатуЗарплатыВБанк".

1 стартмани

02.04.2019    5878    9    mentozavr    0    

Зарплатная ведомость в БАНК для ЗУП Промо

Обмен с банком Зарплата Зарплата v8 v8::СПР ЗУП2.5 Россия БУ Абонемент ($m)

Выгрузка зарплатной ведомости в БАНК.

1 стартмани

13.03.2013    20990    17    platon-81    1    

Выгрузка платежных ведомостей в банк для Сбербанка и ВТБ

Обмен с банком Обмен через XML Банковские операции Зарплата Банковские операции Зарплата v8 v8::СПР ЗУП3.x Россия БУ Абонемент ($m)

Данная обработка формирует платёжки в формате .xml для Сбербанка и в формате .txt для ВТБ. Так же, помимо документа "Ведомость в банк" можно подхватить документ "Выплаты бывшим сотрудникам", где сотрудникам после увольнения продолжают начислять заработную плату. Разработка велась на версии ЗУП 3.1.8.246.

1 стартмани

25.03.2019    5318    17    nestokay    3    

Выгрузка реестра Cбербанка в Excel для ЗУП 3

Загрузка и выгрузка в Excel Обмен с банком Банковские операции Зарплата Банковские операции Зарплата v8 v8::СПР v8::УФ ЗУП3.x Россия БУ Абонемент ($m)

Обработка по выгрузке реестра Cбербанка в Excel (файл для выгрузки предоставляется Сбербанком, пользователь выбирает его сам) для последующего формирования XML-файла на открытие лицевых счетов.

1 стартмани

15.02.2019    4748    12    Fantasisto    0    

Загрузка реестра физических лиц дольщиков из Сбербанка

Обмен с банком Банковские операции Банковские операции v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Загрузка Реестра физических лиц дольщиков из банка. Загрузка реестра Физ. лиц. из Сбербанка.

1 стартмани

03.02.2019    4424    2    karen0602    2    

Выгрузка из документа "Ведомость в банк" в формате csv для Сбербанка. ЗУП 3.1

Обмен с банком Банковские операции Банковские операции v8::СПР v8::УФ ЗУП3.x Россия БУ Абонемент ($m)

Расширение для конфигурации "Зарплата и управление персоналом" 3.1. Добавляется функционал выгрузки из документа "Ведомость в банк" файла в формате CSV для Сбербанк-Онлайн. Для бухгалтеров.

1 стартмани

11.01.2019    12062    55    korelski    5