Создание ведомостей на выплату зарплаты в банк из XML банка

Публикация № 1203211

Разработка - Системная интеграция - Обмен с интернет-банком

Обработка создает документы ведомость на выплату зарплаты в банк из файлов XML (Выгруженного с банка). Множественный выбор проверено на Бухгалтерии 3.0.62.17.

Для использования необходимо:

1. Необходимо включить использование начислений по зарплате  в этой программе.   Администрирование - параметры учета - настройки зарплаты - общие настройки - в этой программе.

2. Создать зарплатный проект

пример структуры файла XML^

<?xml version="1.0" encoding="Windows-1251" standalone="yes"?>
<СчетаПК ДатаРеестра="2019-01-16+03:00" НомерРеестра="1" БИК="123456789" РасчетныйСчетОрганизации="21212121212121212" ИНН="0000000000" НаименованиеОрганизации="XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX" ДатаДоговора="2018-08-07+03:00" НомерДоговора="67110430" ДатаФормирования="2019-01-16+03:00">
    <РезультатЗачисленияЗарплаты>
        <Сотрудник Нпп="1">
            <Фамилия>Иванов</Фамилия>
            <Имя>Иван</Имя>
            <Отчество>Иванович</Отчество>
            <ЛицевойСчет>12345678901234567890</ЛицевойСчет>
            <Сумма>1000</Сумма>
            <Результат>Зачислено</Результат>
            <РасшифровкаРезультата>Зачисление успешно проведено</РасшифровкаРезультата>
        </Сотрудник>
        <Сотрудник Нпп="2">
            <Фамилия>Петров</Фамилия>
            <Имя>Петр</Имя>
            <Отчество>Петрович</Отчество>
            <ЛицевойСчет>12345678901234567890</ЛицевойСчет>
            <Сумма>2000</Сумма>
            <Результат>Зачислено</Результат>
            <РасшифровкаРезультата>Зачисление успешно проведено</РасшифровкаРезультата>
        </Сотрудник>
        <Сотрудник Нпп="3">
            <Фамилия>Сидоров</Фамилия>
            <Имя>Сидр</Имя>
            <Отчество>Сидорович</Отчество>
            <ЛицевойСчет>12345678901234567890</ЛицевойСчет>
            <Сумма>3000</Сумма>
            <Результат>Зачислено</Результат>
            <РасшифровкаРезультата>Зачисление успешно проведено</РасшифровкаРезультата>
        </Сотрудник>
    </РезультатЗачисленияЗарплаты>
    <ВидЗачисления>01</ВидЗачисления>
    <КонтрольныеСуммы>
        <КоличествоЗаписей>3</КоличествоЗаписей>
        <СуммаИтого>6000</СуммаИтого>
    </КонтрольныеСуммы>
</СчетаПК>

 

Если в вашей конфигурации нет сотрудника или физического лица то он их создаст и примет на работу на начало месяца из даты реестра. каждый документ ведомости будет на дату из каждого файлика.

&НаКлиенте
Процедура Загрузить(Команда)
    ЧтениеВРучную_XML()
КонецПроцедуры

&НаКлиенте
Функция ПолучитьПутьКФайлу(Режим)
    Диалог = Новый ДиалогВыбораФайла(Режим);
    Диалог.Заголовок = "Выбрать"; 
    Диалог.Фильтр = "XML (*.xml)|*.xml"; 
    Диалог.МножественныйВыбор = Истина;
    Если Диалог.Выбрать() тогда
        Возврат Диалог;            
    Иначе                
        возврат Неопределено;
    КонецЕсли;
КонецФункции

&НаКлиенте
Процедура ЧтениеВРучную_XML()
    ПутьКФайлу =  ПолучитьПутьКФайлу(РежимДиалогаВыбораФайла.Открытие);
    Если ПутьКФайлу = Неопределено Тогда
        возврат;
    КонецЕсли;

    
    МассивФайлов = ПутьКФайлу.ВыбранныеФайлы;
    Для Каждого ИмяФайла Из МассивФайлов Цикл
        
        ВыбФайл = Новый Файл(ИмяФайла);
        ЧтениеXML = Новый ЧтениеXML; 
        ЧтениеXML.ОткрытьФайл(ВыбФайл.ПолноеИмя);
        

        
        ТекущееИмяУзла = "";
        Пока ЧтениеXML.Прочитать() Цикл
            Если ЧтениеXML.ТипУзла = ТипУзлаXML.НачалоЭлемента И ЧтениеXML.Имя = "СчетаПК" Тогда     
                ТаблицаРеестра.Очистить();
                
                ДатаДокумента = Дата( СтрЗаменить(Лев(ЧтениеXML.ЗначениеАтрибута("ДатаРеестра"),10),"-",""));
                Продолжить;
            ИначеЕсли ЧтениеXML.ТипУзла = ТипУзлаXML.НачалоЭлемента И ЧтениеXML.Имя = "Сотрудник" Тогда            
                НоваяСтрока = ТаблицаРеестра.Добавить();    
                Продолжить;    
            ИначеЕсли ЧтениеXML.ТипУзла = ТипУзлаXML.НачалоЭлемента И ЧтениеXML.Имя = "Фамилия" Тогда            
                ТекущееИмяУзла = ЧтениеXML.Имя;    
                Продолжить;
            ИначеЕсли ЧтениеXML.ТипУзла = ТипУзлаXML.НачалоЭлемента И ЧтениеXML.Имя = "Имя" Тогда            
                ТекущееИмяУзла = ЧтениеXML.Имя;    
                Продолжить;
            ИначеЕсли ЧтениеXML.ТипУзла = ТипУзлаXML.НачалоЭлемента И ЧтениеXML.Имя = "Отчество" Тогда            
                ТекущееИмяУзла = ЧтениеXML.Имя;    
                Продолжить;
            ИначеЕсли ЧтениеXML.ТипУзла = ТипУзлаXML.НачалоЭлемента И ЧтениеXML.Имя = "ЛицевойСчет" Тогда            
                ТекущееИмяУзла = ЧтениеXML.Имя;    
                Продолжить;
            ИначеЕсли ЧтениеXML.ТипУзла = ТипУзлаXML.НачалоЭлемента И ЧтениеXML.Имя = "Сумма" Тогда            
                ТекущееИмяУзла = ЧтениеXML.Имя;    
                Продолжить;    
            
            ИначеЕсли ЧтениеXML.ТипУзла = ТипУзлаXML.Текст Тогда     
                Если ТекущееИмяУзла = "Фамилия" ТОгда 
                    НоваяСтрока.Фамилия = ЧтениеXML.Значение;
                ИначеЕсли ТекущееИмяУзла = "Имя" ТОгда 
                    НоваяСтрока.Имя = ЧтениеXML.Значение;    
                ИначеЕсли ТекущееИмяУзла = "Отчество" ТОгда 
                    НоваяСтрока.Отчество = ЧтениеXML.Значение;
                ИначеЕсли ТекущееИмяУзла = "ЛицевойСчет" ТОгда 
                    НоваяСтрока.ЛицевойСчет = ЧтениеXML.Значение;    
                ИначеЕсли ТекущееИмяУзла = "Сумма" ТОгда 
                    НоваяСтрока.Сумма = Число(ЧтениеXML.Значение);
                КонецЕсли;
                Продолжить;
            ИначеЕсли ЧтениеXML.ТипУзла = ТипУзлаXML.КонецЭлемента И ЧтениеXML.Имя = "Сумма" Тогда
                ТекущееИмяУзла = "";
                Продолжить;
            КонецЕсли;
            
        КонецЦикла;
        ЧтениеXML.Закрыть();
        НовыйДокументНаСервере(ДатаДокумента, ТаблицаРеестра)
    КонецЦикла;
    
    ПоказатьОповещениеПользователя("Уведомление",,"Документ записан!",БиблиотекаКартинок.Успешно32);
КонецПроцедуры

&НаСервере
Процедура НовыйДокументНаСервере(ДатаДокумента,знач Таблица)
    новаяВедомость = Документы.ВедомостьНаВыплатуЗарплатыВБанк.СоздатьДокумент();
    новаяВедомость.ПериодРегистрации = НачалоМесяца(ДатаДокумента);
    новаяВедомость.Дата = ДатаДокумента;
    новаяВедомость.Организация = Объект.Организация;
    новаяВедомость.ЗарплатныйПроект = Объект.ЗарплатныйПроект;
    новаяВедомость.СпособВыплаты = Справочники.СпособыВыплатыЗарплаты.Зарплата;
    новаяВедомость.Округление = Справочники.СпособыОкругленияПриРасчетеЗарплаты.НайтиПоНаименованию("Без округления");
        
    Для каждого Стр из Таблица Цикл
        
        ФИОФИЗЛИЦА = Справочники.ФизическиеЛица.НайтиПоНаименованию(Стр.Фамилия + " " + Стр.Имя + " " + Стр.Отчество);
        Если ФИОФИЗЛИЦА = Справочники.ФизическиеЛица.ПустаяСсылка() Тогда 
            НовыйФизЛицо = Справочники.ФизическиеЛица.СоздатьЭлемент();
            НовыйФизЛицо.Наименование = Стр.Фамилия + " " + Стр.Имя + " " + Стр.Отчество;
            НовыйФизЛицо.ФИО = Стр.Фамилия + " " + Стр.Имя + " " + Стр.Отчество;
            НовыйФизЛицо.Фамилия = Стр.Фамилия;
            НовыйФизЛицо.Имя = Стр.Имя;
            НовыйФизЛицо.Отчество = Стр.Отчество;    
            НовыйФизЛицо.Записать();
        КонецЕсли;
        
        ФИОСотрудника = Справочники.Сотрудники.НайтиПоНаименованию(Стр.Фамилия + " " + Стр.Имя + " " + Стр.Отчество); 
        Если ФИОСотрудника = Справочники.Сотрудники.ПустаяСсылка() Тогда 
            НовыйСотрудник = Справочники.Сотрудники.СоздатьЭлемент();
            НовыйСотрудник.Наименование = Справочники.ФизическиеЛица.НайтиПоНаименованию(Стр.Фамилия + " " + Стр.Имя + " " + Стр.Отчество).Наименование;
            НовыйСотрудник.ФизическоеЛицо = Справочники.ФизическиеЛица.НайтиПоНаименованию(Стр.Фамилия + " " + Стр.Имя + " " + Стр.Отчество);
            НовыйСотрудник.ГоловнаяОрганизация = Объект.Организация;            
            НовыйСотрудник.Записать();
            
            МенеджерЗаписи = РегистрыСведений.ФИОФизическихЛиц.СоздатьМенеджерЗаписи();
            МенеджерЗаписи.ФизическоеЛицо = Справочники.ФизическиеЛица.НайтиПоНаименованию(Стр.Фамилия + " " + Стр.Имя + " " + Стр.Отчество);
            МенеджерЗаписи.Фамилия = Стр.Фамилия;
            МенеджерЗаписи.Имя = Стр.Имя;
            МенеджерЗаписи.Отчество = Стр.Отчество;
            МенеджерЗаписи.Период = НачалоМесяца(ДатаДокумента);        
            МенеджерЗаписи.Записать();
            
            МенеджерЗаписи1 = РегистрыСведений.ОсновныеСотрудникиФизическихЛиц.СоздатьМенеджерЗаписи();
            МенеджерЗаписи1.ГоловнаяОрганизация = Объект.Организация;
            МенеджерЗаписи1.ФизическоеЛицо = Справочники.ФизическиеЛица.НайтиПоНаименованию(Стр.Фамилия + " " + Стр.Имя + " " + Стр.Отчество);
            МенеджерЗаписи1.Сотрудник = Справочники.Сотрудники.НайтиПоНаименованию(Стр.Фамилия + " " + Стр.Имя + " " + Стр.Отчество);
            МенеджерЗаписи1.ДатаОкончания = '39991231';
            МенеджерЗаписи1.Записать();
            
            МенеджерЗаписи2 = РегистрыСведений.ТекущиеКадровыеДанныеСотрудников.СоздатьМенеджерЗаписи();
            МенеджерЗаписи2.ТекущаяОрганизация = Объект.Организация;
            МенеджерЗаписи2.ГоловнаяОрганизация = Объект.Организация;
            МенеджерЗаписи2.ФизическоеЛицо = Справочники.ФизическиеЛица.НайтиПоНаименованию(Стр.Фамилия + " " + Стр.Имя + " " + Стр.Отчество);
            МенеджерЗаписи2.Сотрудник = Справочники.Сотрудники.НайтиПоНаименованию(Стр.Фамилия + " " + Стр.Имя + " " + Стр.Отчество);
            МенеджерЗаписи2.ДатаПриема = НачалоМесяца(ДатаДокумента);
            МенеджерЗаписи2.ОсновноеРабочееМестоВОрганизации = Истина;
            МенеджерЗаписи2.Записать();
            
        КонецЕсли;
        
        
        
        ИдентификаторСтроки = Новый УникальныйИдентификатор;
        
        ДобавитьСтрокуСостава = новаяВедомость.Состав.Добавить();
        ДобавитьСтрокуСостава.ИдентификаторСтроки = ИдентификаторСтроки;
        ДобавитьСтрокуСостава.ФизическоеЛицо = Справочники.ФизическиеЛица.НайтиПоНаименованию(Стр.Фамилия + " " + Стр.Имя + " " + Стр.Отчество);
        ДобавитьСтрокуСостава.НомерЛицевогоСчета = Стр.ЛицевойСчет;
        
        ДобавитьСтрокуЗарплата = новаяВедомость.Зарплата.Добавить();
        ДобавитьСтрокуЗарплата.ИдентификаторСтроки = ИдентификаторСтроки;
        ДобавитьСтрокуЗарплата.Сотрудник = Справочники.Сотрудники.НайтиПоНаименованию(Стр.Фамилия + " " + Стр.Имя + " " + Стр.Отчество);
        ДобавитьСтрокуЗарплата.ФизическоеЛицо = Справочники.ФизическиеЛица.НайтиПоНаименованию(Стр.Фамилия + " " + Стр.Имя + " " + Стр.Отчество);
        ДобавитьСтрокуЗарплата.ПериодВзаиморасчетов = НачалоМесяца(ДатаДокумента);
        ДобавитьСтрокуЗарплата.СтатьяРасходов = Справочники.СтатьиФинансированияЗарплата.НайтиПоКоду("ОТ");    
        ДобавитьСтрокуЗарплата.КВыплате = стр.Сумма;
        ДобавитьСтрокуЗарплата.НомерЛицевогоСчета = Стр.ЛицевойСчет;

        ДобавитьСтрокуФизЛица = новаяВедомость.ФизическиеЛица.Добавить();
        ДобавитьСтрокуФизЛица.ФизическоеЛицо = Справочники.ФизическиеЛица.НайтиПоНаименованию(Стр.Фамилия + " " + Стр.Имя + " " + Стр.Отчество);

    КонецЦикла;
    
    
    новаяВедомость.Записать(РежимЗаписиДокумента.Проведение);
    
КонецПроцедуры

 

Скачать файлы

Наименование Файл Версия Размер
Создание ведомостей на выплату зарплаты в банк из XML банка :
.epf 8,04Kb
10.03.20
0
.epf 1 8,04Kb Скачать

Специальные предложения

Оставьте свое сообщение

См. также

Онлайн-интенсив "1C:Предприятие для программистов: Бухгалтерские задачи" с 22 июня по 8 июля 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, которые предназначены для решения задач бухгалтерского учета. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей прикладного решения “1С:Бухгалтерия” и прочих прикладных решений, в которых реализованы соответствующие механизмы для автоматизации бухгалтерских задач.

4900 рублей

Клиент-банк УкрСибБанк для Украины

Инструменты и обработки Программист Бухгалтер Архив с данными v8::БУ УПП1 Украина БУ Windows Абонемент ($m) Обмен с банком

В январе 2020 года украинские банки перешли на новый формат расчетного счета - IBAN. И почти все банки поменяли структуру и формат выгрузки данных, которые использовались для импорта в 1С8. Это коснулось и банка УкрСибБанк. Раньше использовался файл формата DBF. Сейчас банк выгружает данные в формате XLS. Для решения задачи обмена было сделано следующее:

1 стартмани

11.02.2020    862    sojuznik    0       

Загрузка строк выписки банка (расход) на основании файлов выгрузки из ЗУП по ВТБ и РСХБ (и подобных)

Инструменты и обработки Программист Бухгалтер Внешняя обработка (ert,epf) v8::ОУ v8::УФ УТ11 Россия УУ Абонемент ($m) Обработка документов Банковские операции Обмен с банком

Загрузка строк выписки банка (расход) на основании файлов выгрузки из ЗУП по ВТБ (обработка банка для выгрузки ведомостей в клиент-банк) и РСХБ (стандартная выгрузка в файл).

1 стартмани

10.02.2020    609    Alexkoz1980    0       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

Выгрузка зарплатных ведомостей для импорта в "Приват24 для Бизнеса"

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 v8::БУ БП3.0 Украина БУ Абонемент ($m) Банковские операции Зарплата Обмен с банком

Обработка выгрузки зарплатных ведомостей для импорта в “Приват24 для Бизнеса”. Для BAS Бухгалтерия и BAS Бухгалтерия КОРП. Формат DBF.

1 стартмани

22.01.2020    853    user1035175    2       

Загрузка из Клиент-банка, автоматическое заполнение договора и счета на оплату

Инструменты и обработки Бухгалтер Архив с данными v8::БУ БП3.0 Россия БУ Абонемент ($m) Обмен с банком Банковские операции

Учим Клиент-банк «читать» Назначение платежа из файла загрузки. Как правило, текст содержит достаточно информации для поиска договора контрагента и счета на оплату.

2 стартмани

11.12.2019    1370    4    suvig    2       

1C:Предприятие для программистов: Расчетные задачи (зарплата). Онлайн-интенсив с 01 по 17 июня 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, которые предназначены для автоматизации периодических расчетов, а именно - для расчета зарплаты. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей прикладного решения “1С:Зарплата и управление персоналом” и прочих прикладных решений, в которых реализован функционал расчета зарплаты.

4900 рублей

Загрузка данных из реестров Сбербанка

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8::БУ БГУ Государственные, бюджетные структуры Россия БУ Абонемент ($m) Обмен с банком

Внешняя обработка, предназначенная для автоматического занесения данных из реестров Сбербанка в 1С:Бухгалтерию.

1 стартмани

10.12.2019    1141    vlan76    0       

Онлайн-курс «Автоматизация процессов управления МТО: методика сбора и формализации требований» с 1 апреля по 13 мая 2020 года. Промо

Цель курса - повысить полноту и качество сбора и формализации требований к автоматизации процессов управления материально-техническим обеспечением. Курс основан на процессном подходе, позволяет в полном объеме выявить и учесть все факторы, влияющие на специфику процессов управления МТО. Участники курса получают теоретические знания в области организации процессов управления МТО и готовый инструментарий для сбора и формализации требований по автоматизации этих процессов (шаблоны, опросники, модели).

40000 рублей

Выгрузка реестра (ведомости) по зарплате в Газпромбанк в формате xls (БП 3 / ЗУП 3)

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 v8::БУ БП3.0 Абонемент ($m) Зарплата Обмен с банком Загрузка и выгрузка в Excel

Обработка позволяет выгрузить документ "Ведомость на выплату зарплаты" из 1С:Бухгалтерия предприятия 3.0, Зарплата и Управление персоналом 3.0 в онлайн-банк Газпромбанк по установленному формату (Excel).

1 стартмани

27.09.2019    1950    deemko48    0       

Обмен с Ситибанком в формате CDFF, МТ940 и PAYROLL

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 v8::БУ v8::СПР БП3.0 ЗУП3.x Россия БУ Банковские операции Абонемент ($m) Обмен с банком

1. Обработка Клиент-банк для 1С:Бухгалтерия предприятия 3.0 (релиз 3.0.67.63) для работы с CitiDirect . Выгрузка в формате CDFF, загрузка – SWIFT MT940. 2. Обработка Обмен с банками для 1С:Зарплата и управление персоналом 3.1. (релиз 3.1.9.205) Выгрузка в формате PAYROLL CARDS FORMAT.

1 стартмани

20.08.2019    2362    20    leon111    4       

Онлайн-курс «Практические аспекты внедрения регламентированного учета и расчета себестоимости в 1С:ERP на крупных промышленных предприятиях» с 20 апреля по 15 мая 2020 года. Промо

Курс рассчитан для подготовки экспертов по регламентированному учету и учету затрат для внедрения на крупных промышленных предприятиях с «исторически сложившимся» учетом

9000 рублей

Выгрузка компенсации родительской платы в Сбербанк в формате dbf. БГУ 2.0

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 v8::БУ БГУ Россия БУ Банковские операции Абонемент ($m) Файловые протоколы обмена, FTP Обмен с банком

Была необходимость выгрузить ведомость компенсации родительской платы в сбербанк в формате DBF. Почему-то банк требовал именно этот формат. Конфигурация Бухгалтерия государственного учреждения 2.0.

1 стартмани

07.08.2019    2272    2    agates    3       

Обработка реестров начислений Сбербанк

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 v8::БУ БП3.0 Россия БУ Банковские операции Абонемент ($m) Обработка документов Обмен с банком

Экспорт реестра счетов (начислений) на оплату в Сбербанк бизнес онлайн, импорт реестра платежей.

1 стартмани

17.07.2019    1729    1    denissekh    2       

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

Загрузка реестра платежей физических лиц из Сбербанка бизнес онлайн

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8::БУ БП3.0 Россия БУ Банковские операции Абонемент ($m) Обмен с банком

Обработка загружает реестры платежей Сбербанка Бизнес Онлайн в документ "Операции по платежным картам".

1 стартмани

08.07.2019    4437    27    Poyarkov696    2       

Загрузка реестра Сбербанка для 1С:Расчет квартплаты и бухгалтерия ЖКХ 3

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 v8::БУ БП3.0 Энергетика и ЖКХ Россия БУ Windows Банковские операции Абонемент ($m) Обмен с банком

Загрузка реестра в Сбербанк бизнес онлайн по лицевым счетам. Загрузка реестра из СБЕРБАНКА. Указывается файл загрузки, По нажатию на кнопку "Прочитать файл" заполняется табличная часть для просмотра. По шаблону 10_2 (шаблон 10 2).

2 стартмани

25.06.2019    2657    kras_dar    0       

Базовый курс по обмену данными в системе 1С:Предприятие. Онлайн-интенсив с 12 по 28 мая 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, обеспечивающих обмен данными между различными прикладными 1С-решениями и взаимодействие с другими информационными системами. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”.

5500 рублей

Обработка для импорта выписки из iFOBS Client ОТП-банка в 1С (поддерживается DBF)

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8::БУ БП2.0 Украина БУ Банковские операции Абонемент ($m) Обмен с банком Файловые протоколы обмена, FTP

Бухгалтерия управляемые формы работает 1С:Предприятие 8.3 (8.3.12.) можно пребывать в других конфигурациях .Обработка для импорта выписки банка ОТП-банк, получаемой из клиента-банка iFOBS. А также банк Аваль Подключается к внешней обработке "Обмен данными с системами "Клиент-банк""

3 стартмани

21.06.2019    3617    3    pashaa2002    0       

ДиректБанк: автоматическая загрузка и разбор банковских выписок по расписанию для УТ 11.4

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8::ОУ v8::УФ УТ11 Россия БУ Банковские операции Абонемент ($m) Обмен с банком

Обработка предназначена для автоматической загрузки по расписанию выписок по расчетному счету из сервиса Директ Банк, без использования цифровой подписи и СМС.

2 стартмани

16.06.2019    3194    4    Hexkiller    7       

DevOps для 1С. Онлайн-курс проходит с 16 апреля по 11 июня 2020 года. Промо

Данный онлайн-курс предусматривает изучение процессов DevOps, их применение при разработке на платформе 1С. В результате прохождения онлайн-курса вы сможете: настроить ПО необходимое для проведения проверок и тестирования, создавать сценарии тестирования и объединять их в комплексные процессы, создавать скрипты для автоматизации процессов DevOps.

12000 рублей

Выгрузка в банки (ведомости и заявки на открытие) для ЗУП 3.1

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8::СПР v8::УФ ЗУП3.x Россия БУ Банковские операции Зарплата Управление персоналом (HRM) Абонемент ($m) Обмен с банком

Выгрузка в банки (очередная): Газпромбанк: XLS, TXT, XML ВТБ24 АльфаБанк ВБРР Уралсиб Выгрузка может производится из следующих документов (имя метаданных): Ведомость в банк (ВедомостьНаВыплатуЗарплатыВБанк) Ведомость прочих доходов в банк (ВедомостьПрочихДоходовВБанк) Ведомость прочих доходов на счета (ВедомостьПрочихДоходовПеречислением) Ведомость на счета (ВедомостьНаВыплатуЗарплатыПеречислением) Выплата бывшим сотрудникам (ВыплатаБывшимСотрудникам) Так же реализована выгрузка заявок на открытие счета ГазпромбанкКарты: XLS,TXT,XML ВТБ24.

1 стартмани

28.05.2019    2931    9    navic    1       

Выгрузка зарплатной ведомости для Альфабанк: АЗОН или создаем файл xls с несколькими листами без использования Excel

Инструменты и обработки Программист Бухгалтер Внешняя обработка (ert,epf) v8::БУ КА1 ЗУП2.5 ЗКБУ УПП1 Россия БУ Банковские операции Зарплата Абонемент ($m) Загрузка и выгрузка в Excel Обмен с банком

Альфабанк является одним из крупнейших банков в нашей стране. В корпоративном секторе этот банк предлагает своим клиентам множество услуг, в число которых входит зарплатный проект - "Альфа-Зарплата Онлайн" или знакомый многим как "АЗОН". В АЗОН есть возможность загрузки зарплатных ведомостей из файлов XLS. Но в формате файла есть небольшая особенность: в файле должно быть несколько листов с различными данными. В этой публикации разберемся, как сформировать такой файл без использования COM-объекта Microsoft Excel.

1 стартмани

26.04.2019    3709    2    Johny_v    0       

Подборка решений для взаимодействия со ФГИС «Меркурий» Промо

С 1 июля 2019 года все компании, участвующие в обороте товаров животного происхождения, должны перейти на электронную ветеринарную сертификацию (ЭВС) через ФГИС «Меркурий». Инфостарт предлагает подборку программ, связанных с этим изменением.

Загрузка лицевых счетов в ЗУП 3.1 из эксель и выгрузка в эксель по шаблону Газпромбанка

Инструменты и обработки Программист Бухгалтер Внешняя обработка (ert,epf) v8 v8::СПР v8::УФ ЗУП3.x Россия БУ Банковские операции Зарплата Абонемент ($m) Обмен с банком

Внешняя обработка, позволяющая произвести Загрузку лицевых счетов в ЗУП 3.1 из эксель и выгрузку в эксель по шаблону ГАзпромбанка. Первая часть производит загрузку лицевых карточных счетов сотрудников в базу. вторая часть отвечает за выгрузку зарплаты в банк согласно документу "ВедомостьНаВыплатуЗарплатыВБанк".

1 стартмани

02.04.2019    3602    3    mentozavr    0       

Выгрузка реестра Cбербанка в Excel для ЗУП 3

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 v8::СПР v8::УФ ЗУП3.x Россия БУ Банковские операции Зарплата Абонемент ($m) Загрузка и выгрузка в Excel Обмен с банком

Обработка по выгрузке реестра Cбербанка в Excel (файл для выгрузки предоставляется Сбербанком, пользователь выбирает его сам) для последующего формирования XML-файла на открытие лицевых счетов.

1 стартмани

15.02.2019    2860    4    Fantasisto    0       

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

Загрузка реестра физических лиц дольщиков из Сбербанка

Инструменты и обработки Бухгалтер Расширение (cfe) v8 v8::БУ БП3.0 Россия БУ Банковские операции Абонемент ($m) Обмен с банком

Загрузка Реестра физических лиц дольщиков из банка. Загрузка реестра Физ. лиц. из Сбербанка.

1 стартмани

03.02.2019    2928    1    karen0602    2       

Выгрузка из документа "Ведомость в банк" в формате csv для Сбербанка. ЗУП 3.1

Инструменты и обработки Бухгалтер Расширение (cfe) v8::СПР v8::УФ ЗУП3.x Россия БУ Банковские операции Абонемент ($m) Обмен с банком

Расширение для конфигурации "Зарплата и управление персоналом" 3.1. Добавляется функционал выгрузки из документа "Ведомость в банк" файла в формате CSV для Сбербанк-Онлайн. Для бухгалтеров.

1 стартмани

11.01.2019    7137    42    korelski    4       

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

Обработка "Обмен с банком" с дополнительными настройками загрузки

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 v8::БУ БП3.0 Россия БУ Банковские операции Абонемент ($m) Обмен с банком

Обработка "Обмен с банком" с дополнительными настройками загрузки(доработанная типовая обработка обмена с банком)

1 стартмани

02.01.2019    3356    7    m_aster    0       

Обработка банковских выписок из почты (различные форматы)

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 v8::УФ ERP2 Россия БУ Банковские операции Абонемент ($m) Обработка документов Обмен с банком

Обработка предназначена для автоматической обработки вложений почты для загрузки банковских документов.

1 стартмани

27.12.2018    2625    3    Aparatus    0       

Программы для исполнения 488-ФЗ: Маркировка товаров Промо

1 января 2019 года вступил в силу ФЗ от 25.12.2018 № 488-ФЗ о единой информационной системе маркировки товаров с использованием контрольных (идентификационных) знаков, который позволяет проследить движение товара от производителя до конечного потребителя. Инфостарт предлагает подборку программ, связанных с применением 488-ФЗ и маркировкой товаров.

Загрузка выписок из клиент-банка ДНР

Инструменты и обработки Программист Бухгалтер Внешняя обработка (ert,epf) v8::БУ 1cv8.cf Украина БУ Windows Банковские операции Абонемент ($m) Обмен с банком Файловые протоколы обмена, FTP

Стандартная обработка загрузки из клиент-банка в 1С:Бухгалтерию для Украины 1.2 не поддерживает загрузку из клиент-банка в формате dbf. Именно в этом формате ЦБ ДНР формирует выписку из клиент-банка. Обработка поддерживает загрузку из файла в формате DBF. Для ее получения в клиент-банке ЦРБ ДНР перейдите в раздел «Платежи»->«Экспорт». Точно работает на 1С: 8.3.10.25.61 и 8.3.10.26.99 (поскольку обработка стандартная и все доделки универсальные, то думаю что и на других версиях должно работать).

1 стартмани

05.12.2018    5135    1    Scottlinch    0       

Загрузка платежей из реестра переводов от ПАО Сбербанк и создание документа "Кассовое поступление" в БГУ2

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 v8::БУ БГУ Россия БУ Банковские операции Кассовые операции Абонемент ($m) Обработка документов Обмен с банком

Реализация задачи по загрузке данных по платежам из реестра (файла выгрузки) переводов от ПАО Сбербанк и создания документа "Кассовое поступление" в БГУ2 по каждому плательщику.

1 стартмани

24.10.2018    4775    16    dendzu    0