Доработка конфигурации для загрузки отчета по транзакциям с сайта Газпромнефть

Публикация № 365353

Учет и отчетность - Учет ТМЦ

Газпромнефть Газпром ГСМ топливные карты

Доработка для загрузки данных по транзакциям с сайта Газпромнефть из формата xml.

Доработка конфигурации для загрузки данных с сайта.

На сайте Газпромнефть в личном кабинете формируешь отчет, загружаешь его в табличную часть документа "Загрузка Газпром". Документ формирует движения в регистре накопления, и по его данным строится отчет.  Таким образом имеем информацию по картам. Адрес заправки, вид топлива, количество литров, цена и сумма по каждой карте. 

 

Писалась для конфигурации Резон Мясокомбинат, для автоматизации блока учета ГСМ. Встраивается в любую конфигурацию на обычных формах.

Состав объектов конфигурации:

  • Справочник "Автомобили"
  • Справочник "Топливные карты"
  • Справочник "Типы ГСМ"
  • Справочник "Водители"
  • Регистр накопления "Заправки"
  • Документ "загрузка"
  • Отчет "Данные по картам"

Скачать файлы

Наименование Файл Версия Размер
Конфигурация cf
.cf 149,12Kb
22.06.15
5
.cf 149,12Kb 5 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
1. kravius12 26 24.05.16 15:28 Сейчас в теме
Формат файла поменялся:
Текст процедуры для нового файла:
Процедура загрузка()

	XML = Новый ЧтениеXML;
	XML.ОткрытьФайл(ПутьКФайлу);
	
	Таблица = новый ТаблицаЗначений;
	Таблица.Колонки.Добавить("НомерКарты",новый ОписаниеТипов("Строка"));
	Таблица.Колонки.Добавить("Бензин", Новый ОписаниеТипов("Строка"));  
	Таблица.Колонки.Добавить("ЦенаСоСкидкой", Новый ОписаниеТипов("Строка")); 
	Таблица.Колонки.Добавить("СуммаСоСкидкой", Новый ОписаниеТипов("Строка")); 
	Таблица.Колонки.Добавить("ID", Новый ОписаниеТипов("Строка")); 
	Таблица.Колонки.Добавить("DT", Новый ОписаниеТипов("Строка")); 
	Таблица.Колонки.Добавить("АдресЗаправки", Новый ОписаниеТипов("Строка")); 
	Таблица.Колонки.Добавить("ВидОперации", Новый ОписаниеТипов("Строка")); 
	Таблица.Колонки.Добавить("количество", Новый ОписаниеТипов("число")); 
	
	
	Таблица.Колонки.Добавить("SERVICE",новый ОписаниеТипов("Строка"));
	
	состояние("Загрузка...");                                                          
	Уровень = ложь;
	ТЭ = неопределено;
	НомерКарты = "";
	состояние("Загрузка файла данных...");
	
	Пока XML.Прочитать() Цикл                  
		//ПолучитьXMLТип(ЧтениеXML);
		
		Если XML.ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда
			ТЭ = XML.Имя;
			Если XML.Имя = "G_CARD" Тогда
				
				Уровень = 1;
			ИначеЕсли XML.Имя = "G_TRANSACTION" Тогда	
				Уровень = 2;
				НС = таблица.Добавить();
				НС.НомерКарты = НомерКарты;
			иначеЕсли XML.Имя = "G_PRODUCT" Тогда
				Уровень = 3;
			иначеЕсли XML.Имя = "G_PRODUCT_GROUP" Тогда
				Уровень = 31;				
			иначеЕсли XML.Имя = "G_GAS_STATION" Тогда
				Уровень = 32;				
			КонецЕсли;
		КонецЕсли;
		
		Если XML.ТипУзла = ТипУзлаXML.Текст Тогда
			Если Уровень = 1  Тогда
				
				Если ТЭ = "S_NUMBER" Тогда
					
					номерКарты = XML.Значение;
				КонецЕсли; 
			иначеЕсли уровень = 2 тогда
				Если ТЭ = "F_PRICE_WO_DISCOUNT" Тогда
					
					НС.ЦенаСоСкидкой = XML.Значение;
				иначеЕсли ТЭ = "F_SUM_WO_DISCOUNT"  тогда	 
					НС.СуммаСоСкидкой = XML.Значение;
				иначеЕсли ТЭ = "ID_TRANS"  тогда	 
					НС.ID = XML.Значение;
				иначеЕсли ТЭ = "DT_TRANS"  тогда	 
					НС.DT = XML.Значение;
				иначеЕсли ТЭ = "TRANS_TYPE_NAME"  тогда	 
					НС.ВидОперации = XML.Значение;
				иначеЕсли ТЭ = "F_QTY"  тогда	 
					НС.количество = XML.Значение;
						
				КонецЕсли;
				
			иначеЕсли уровень = 3 тогда
				Если ТЭ = "S_NAME" Тогда
					
					НС.Бензин = XML.Значение;
				КонецЕсли; 
			иначеЕсли уровень = 32 тогда
				Если ТЭ = "S_ADDRESS" Тогда
					
					нс.АдресЗаправки = XML.Значение;
					
				КонецЕсли; 
			КонецЕсли; 
		КонецЕсли;
		
		Если XML.ТипУзла = ТипУзлаXML.КонецЭлемента Тогда
			Если XML.Имя = "G_CARD" Тогда
				
				ЗагружаемКарту = ложь;
				
			КонецЕсли;
			
			
		КонецЕсли;
	КонецЦикла;
	XML.Закрыть();
	состояние("Запись данных в документ...");
	Заправки.Очистить();
	Для каждого строка Из таблица Цикл
		карта = справочники.ТопливныеКарты.НайтиПоРеквизиту("НомерКарты",строка.номерКарты);
		Если карта <> справочники.ТопливныеКарты.ПустаяСсылка() Тогда
			
			нс = Заправки.Добавить();
			нс.Карта = карта;
		иначе
			сообщить("Не найдена карта с номером: " + строка.номерКарты);
			продолжить;
		КонецЕсли; 
		нс.сумма = строка.СуммаСоСкидкой;
		нс.НомерЧека = строка.ID;
		типГСМ = Справочники.ТипыГСМ.НайтиПоРеквизиту("Газпром",строка.Бензин);
		
		НС.ТипГСМ = ТипГСМ;
		НС.Цена = строка.ЦенаСоСкидкой;
		НС.ВидОбслуживания = строка.ВидОперации;
		нс.АдресЗаправки = строка.АдресЗАправки;
		нс.Количество = строка.Количество;
		Год = лев(Строка.DT,4);
		месяц = сред(строка.DT,6,2);
		день = сред(строка.DT,9,2);
	    период = Дата(год + месяц + день);
		нс.Период = период;
		
	КонецЦикла; 
	сообщить("Загрузка данных завершена!",СтатусСообщения.Информация);


КонецПроцедуры
Показать
Оставьте свое сообщение

См. также

Правильные аналоги номенклатуры (кроссы запчастей) для 1С / Управляемые формы Промо

Обработка справочников Оптовая торговля Учет ТМЦ Оптовая торговля Учет ТМЦ v8 v8::УФ 1cv8.cf УУ Абонемент ($m)

По опыту работы с запчастями много раз сталкивался с проблемой организации кроссов в разных 1С - от записи артикулов через запятую в текстовом поле до хранения кроссов в документах. Предлагаю одну из простейших и функциональных на мой взгляд схем "одноуровневого" хранения кроссов.

5 стартмани

29.07.2015    28926    7    taurus__    19    

"Убер на складе": динамический расчет маршрутов с учетом реальных расстояний

Учет ТМЦ Практика программирования Учет ТМЦ v8 УУ Абонемент ($m)

Представляю методику и инструмент для динамического расчета маршрутов отбора на высоконагруженных складах для максимального повышения эффективности склада, ускорения проходимости и, как следствие, экономии денег. Это методика и обработка для интеграции в WMS решения. Тестировалось на 1С 8.3.14.1565.

3 стартмани

24.06.2019    12078    7    informa1555    17    

Документы и Справочники в JSON

Обмен через XML v8 1cv8.cf Абонемент ($m)

Пример выгрузки всех данных Документа или Справочника в JSON

1 стартмани

20.06.2019    9475    12    darkmessiahan    15    

XDTO для чайников

Обмен через XML v8 1cv8.cf Абонемент ($m)

Пример использования XDTO пакетов для выгрузки документа с табличной частью.

1 стартмани

29.05.2019    21943    19    HAMMER_59    37    

[Расширение] Контроль отрицательных остатков по регистру бухгалтерии при проведении Промо

Универсальные функции Инструментарий разработчика Учет ТМЦ Учет ТМЦ v8 1cv8.cf Россия БУ Абонемент ($m)

Расширение позволяет без изменений конфигурации проверять остатки по регистру бухгалтерии при проведении каждого документа и запрещает проведение при появлении отрицательных остатков после проведения.

1 стартмани

17.08.2015    44037    155    ekaruk    31    

1C + Python + Django Rest Framework + Vue.js. Опыт несложной full-stack разработки

Практика программирования Внешние источники данных Обмен через XML WEB Разработка v8 1cv8.cf Абонемент ($m)

В этой статье мы рассмотрим путь и основные моменты создания небольшого вэб-сервиса, который мы называем "Онлайн Прайс-лист". Выгрузка из 1С, бэкенд, фронтенд, получение заказов в 1С.

1 стартмани

22.04.2019    26626    32    riposte    63    

Выгрузка и загрузка данных XML с гибкими отборами

Обмен через XML Перенос данных из 1C8 в 1C8 v8 1cv8.cf Абонемент ($m)

Обработка выгрузки и загрузки данных через XML между идентичными конфигурациями с возможностью установки произвольных отборов на выгружаемые объекты.

1 стартмани

07.04.2019    13228    334    sapervodichka    7    

SOAP для чайников

Обмен через XML WEB v8 1cv8.cf Абонемент ($m)

Немножко про SOAP сервис. И пример работы с подключением и получением данных по SOAP за 5 минут.

1 стартмани

05.09.2018    37097    34    dusha0020    18    

Менеджер загрузки данных из весов с печатью этикеток Промо

Внешние источники данных Весы Учет ТМЦ Учет ТМЦ v8 УТ10 УПП1 Абонемент ($m)

Программное обеспечение "Менеджер загрузки данных из весов с печатью этикеток" предназначено для автоматического получения данных по сети Ethernet из весов МАССА-К моделей ВПМ и ТВ_Р3 (модификация MF) в режиме On-Line.

1 стартмани

20.12.2011    18497    3    hrip    10    

Корректировка остатков ЕГАИС для 1С:Розница/УТ 10.3 - альтернативный вариант

Обработка документов Розничная торговля Учет ТМЦ Розничная торговля Учет ТМЦ v8 Розница Розничная и сетевая торговля (FMCG) БУ Абонемент ($m)

Обработка корректировки остатков ЕГАИС для 1С Розница версии 2.2.7/2.2.8/2.2.9/2.2.10/2.2.11/УТ 10.3.47.ХХХ-48.XXX-49.XXX-50.XXX раздельно по маркируемому/немаркируемому алкоголю + создание документов постановки/списания по пересортице.

1 стартмани

02.06.2018    28435    373    independ    256    

Правила конвертации документов ЗУП 2.5 - ЗУП 3.1

Обмен через XML Зарплата Перенос данных из 1C8 в 1C8 Зарплата v8 v8::СПР ЗУП2.5 ЗУП3.x Россия БУ Абонемент ($m)

Правила конвертации документов ЗУП 2.5 - ЗУП 3.1. Позволяют вести параллельную работу в базах ЗУП редакций 2,5 и 3.1.

10 стартмани

06.03.2018    34818    151    kostya_whiskas    24    

Организация обмена с базой филиала (розничного магазина) в торговой сети через XML (универсальный обмен)

Обмен через XML Перенос данных из 1C8 в 1C8 Розничная торговля Розничная торговля v8 КД УТ11 Розничная и сетевая торговля (FMCG) Абонемент ($m)

В статье по шагам рассматривается создание обмена между центральной базой и базами филиалов на базе конфигурации УТ 11. Для решения поставленной задачи было решено не использовать РИБ, т.к. требуется односторонний обмен ограниченным набором данных, к тому же по определенным условиям. Обмен реализован на основе типовой синхронизации на основе универсального обмена в формате EnterpriseData. Данная публикация может быть полезна внедренцам, которые работают с торговыми сетями, в том числе по модели франчайзинга.

1 стартмани

26.02.2018    33976    13    Kutuzov    18    

Перемещение остатков по счету МЦ04 между материально ответственными лицами для конфигураций (8.2). Промо

Обработка документов Универсальные обработки Учет ТМЦ Учет ТМЦ v8 БП2.0 Россия БУ Абонемент ($m)

Небольшая обработка, которая позволяет перекидывать остатки по счету МЦ04 с одного материально ответственного лица на другое

1 стартмани

22.11.2012    10836    13    niksaf    4    

Создание в 1С 7.7 XML в формате EnterpriseData (универсальный формат обмена), версия 1.5. Инструкции и примеры переноса данных из устаревшей конфигурации 1С 7.7 в любую современную 1С 8.3, поддерживающую EnterpriseData, через Конвертацию данных 3

Перенос данных из 1С7.7 в 1C8.X Обмен через XML v7.7 v8 1cv7.md Россия Абонемент ($m)

Воспользоваться современным средством переноса данных "Конвертация данных 3.0.5.3" можно только выгрузив из системы - источника данных XML в формате обмена данными EnterpriseData. В этой публикации можно скачать приемы выгрузки из 1С 7.7 универсального формата обмена для Конвертации данных 3. Выполняем перенос данных из «1С:Предприятие 7.7» в «1С:Предприятие 8.3». Используем Конвертацию данных КД 3.0 из 1c 7.7 --> 1С 8.3. На первой стадии еще не опубликовано иного способа подложить файл для Конвертации данных 3 кроме как сформировать его вручную, постараемся решить данную проблему.

1 стартмани

26.02.2018    34674    49    ksnik    3    

“Заставим сканер пищать!” или Получаем обратную связь из 1С при сканировании штрихкодов

Сканер штрих-кода Учет ТМЦ Учет ТМЦ v8 1cv8.cf Абонемент ($m)

Получаем обратную связь из 1С при сканировании штрихкодов.

1 стартмани

10.01.2018    38310    96    vadnevzorov    70    

Давно обещанная автовесовая 8.Х

Производство Учет ТМЦ Учет ТМЦ v8 Россия УУ Абонемент ($m)

Финальная версия автовесовой без оператора.

10 стартмани

02.01.2018    17408    6    Арчибальд    1    

Пример заполнения/создания файла XML из XSD схемы, используя XDTO

Обмен через XML WEB v8 1cv8.cf Абонемент ($m)

Добрый день, коллеги! Наконец-то дошли руки написать сию статью. Хочу поделиться своим опытом по разбору xsd схемы используя Фабрику XDTO, а также связанным с этим XML файлом. Думаю, наверняка кому-то понадобится.

1 стартмани

21.12.2017    40499    52    sandybaev    23    

Контроль учёта спецодежды

Бухгалтерские Анализ учета Учет ТМЦ Учет ТМЦ v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Отчет предназначен для выявления ошибок возникших в бухгалтерском учёте специальной одежды в эксплуатации.

8 стартмани

08.09.2017    29213    34    sansys    14    

Конструктор мобильного клиента Simple WMS Client: способ создать полноценный ТСД без мобильной разработки. Теперь новая версия - Simple UI (обновлено 14.11.2019) Промо

Инструментарий разработчика Сканер штрих-кода Терминал сбора данных Мобильная разработка Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ v8 v8::Mobile БУ УУ Абонемент ($m)

Simple WMS Client – это визуальный конструктор мобильного клиента для терминала сбора данных(ТСД) или обычного телефона на Android. Приложение работает в онлайн режиме через интернет или WI-FI, постоянно общаясь с базой посредством http-запросов (вариант для 1С-клиента общается с 1С напрямую как обычный клиент). Можно создавать любые конфигурации мобильного клиента с помощью конструктора и обработчиков на языке 1С (НЕ мобильная платформа). Вся логика приложения и интеграции содержится в обработчиках на стороне 1С. Это очень простой способ создать и развернуть клиентскую часть для WMS системы или для любой другой конфигурации 1С (УТ, УПП, ERP, самописной) с минимумом программирования. Например, можно добавить в учетную систему адресное хранение, учет оборудования и любые другие задачи. Приложение умеет работать не только со штрих-кодами, но и с распознаванием голоса от Google. Это бесплатная и открытая система, не требующая обучения, с возможностью быстро получить результат.

5 стартмани

09.01.2019    36356    238    informa1555    200    

Правила обмена ЗУП 3.1 - БП 2.0 и ЗУП 3.1 - УПП 1.3 (отражение, ведомости и справочники)

Перенос данных из 1C8 в 1C8 Обмен через XML Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 v8::БУ v8::СПР БП2.0 БП3.0 ЗУП3.x Россия БУ Абонемент ($m)

Правила обмена для выгрузки документов "Отражение зарплаты в бухучете", "Ведомость в банк", "Ведомость в кассу", справочников "Сотрудники" и "Физические лица"

1 стартмани

01.08.2017    71521    1533    forseil    205    

«Горыныч - то НЕ НАСТОЯЩИЙ!» … или О Конвертации Данных ред.3 (КД 3) и обменах в универсальном формате Enterprise Data… доступным русско-народным языком

Внешние источники данных Обмен через XML Перенос данных из 1C8 в 1C8 v8 КД Абонемент ($m)

Тем, кто хочет быстро разобраться с темой инструмента Конвертация данных 3.0 и технологией обмена по новому формату 1С, активно применяемому во всех новых конфигурациях от 1С на БСП, расширяющем возможности интеграции, пакет полезных материалов.

1 стартмани

13.06.2017    19198    138    Davlad_A    16    

"Конвертация данных" + Git. Решение проблемы различий в файлах

Инструментарий разработчика Обмен через XML v8 КД Абонемент ($m)

Как известно, типовая конфигурация «Конвертация данных» обладает одним недостатком, мешающим работать с ней в Git-е. Если выгруженные из нее правила обмена загрузить в другую КД, а потом снова выгрузить, то полученные два файла будут очень сильно отличаться друг от друга, и при сравнении (diff) доработок будет невозможно провести код-ревью, равно как найти сами изменения, которые закоммитил разработчик.

1 стартмани

08.06.2017    22210    39    stas_ganiev    13    

Автозаказ для 1С:Управление торговлей 11 Промо

Управленческие Оптовая торговля Учет ТМЦ Оптовая торговля Учет ТМЦ v8 v8::ОУ УТ11 УУ Абонемент ($m)

Отчет выводит информацию, помогающую принять решение о пополнении товарного запаса.

3 стартмани

26.09.2017    25520    45    The Ded    25    

Обмен данными онлайн через Веб-сервис с использованием обработки "Универсальный обмен данными XML"

Обмен через XML v8 1cv8.cf Абонемент ($m)

Доработка позволяет организовать двухсторонний обмен данными в режиме реального времени между любыми конфигурациями (типовые, самописные, обычные формы, управляемые формы). Также предлагается вариант в виде расширения конфигурации (.cfe) для конфигураций стоящих на поддержке без возможности изменения. В обмене может участвовать любое количество баз. Правила обмена подготавливаются с использованием конфигурации "Конвертация данных".

2 стартмани

28.10.2016    39373    229    linkov    47    

Использование SoapUi для работы с веб-сервисами. Часть1

Практика программирования Обмен через XML v8 Абонемент ($m)

Как работать с SoapUi для тестирования веб-сервисов .

1 стартмани

30.09.2016    116654    35    kiv1c    29    

Выгрузка изображений из справочника на диск Промо

Учет ТМЦ Универсальные обработки Учет ТМЦ v8 УТ11 Оптовая торговля, дистрибуция, логистика Россия Абонемент ($m)

Обработка позволяет записать изображения из справочка Номенклатура на диск в указанное место.

1 стартмани

30.11.2018    13468    5    wrooom    8    

Редактор движений документа. Сохранение в XML, обмен между базами, замена регистратора.

Обработка документов Универсальные обработки Обмен через XML v8 Абонемент ($m)

Редактор набора записей движений документа. Позволяет сохранить набор записей в XML, в настройки пользователя, прочитать сохраненный XML в другой идентичной базе, заменить регистратор. Можно изменять порядок записей, менять активность, как массово, так и по одной и др. Тонкий клиент, управляемые формы.

1 стартмани

07.09.2016    37698    151    Aphanas    4    

Загрузка файлов грузовых таможенных деклараций из файлов ФТС формата xml (Альта софт, Сигма софт, Декларант +)

Внешнеэкономическая деятельность (ВЭД) Обмен через XML Внешнеэкономическая деятельность (ВЭД) v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Федеральная таможенная служба России давно поддерживает унифицированный формат электронных документов для обмена с информационными системами предприятий. xmlns="urn:customs.ru:Information:ExchangeDocuments:" если что. Структура, утвержденная комиссией Таможенного союза. Осталось только сделать загрузку в 1С из этого формата. На выходе - два документа ГТД по импорту и Поступление (акты, накладные)

5 стартмани

09.08.2016    41898    170    capitan    283    

Неликвиды на складе Pro и Lite версия. Редактирование реквизита в таблице документа. Для конфигурации Управление торговлей 11.2, 11.1 1С Предприятие 8.3

Управленческие Оптовая торговля Розничная торговля Учет ТМЦ Оптовая торговля Розничная торговля Учет ТМЦ v8 v8::ОУ УТ11 Оптовая торговля, дистрибуция, логистика УУ Абонемент ($m)

Внешний отчет для анализа товаров, находящихся на складе без движения. Работает для конфигураций 1С Управление Торговлей 11.2, 11.1. Отчет отображает товары на складах, движения по которым не производились в течении заданного периода дней. Подключается как внешний отчет в конфигурации 1С Управление торговлей 11. В Pro версии можно установить общий реквизит номенклатуры, для дальнейшего включения в отбор в установке цен номенклатуры. Редактирование в табличном документе ускоряет процесс работы с неликвидами номенклатуры на складах. Отчет можно использовать для стоимостной оценки товаров на складах. Полный доступ к тексту модулей и СКД.

1 стартмани

17.06.2016    30786    47    Ликреонский    2    

Товарный отчет Торг-29 с фактической стоимостью продажи, себестоимостью и отклонениями Промо

Управленческие Оптовая торговля Розничная торговля Учет ТМЦ Оптовая торговля Розничная торговля Учет ТМЦ v8 Розница БУ УУ Абонемент ($m)

Товарный отчет Торг-29 с фактической стоимостью продажи, себестоимостью и отклонениями.

10 стартмани

17.04.2013    13555    18    pryaneg2008    9    

Остатки на каждый день в запросе

Практика программирования Учет ТМЦ Учет ТМЦ v8 1cv8.cf УУ Абонемент ($m)

Запрос формирует остатки товаров на каждый день в пределах выбранного периода.

1 стартмани

26.04.2016    48862    19    arakelyan    18    

Номенклатура (Расширенная форма списка) и Корзина [Расширение]

Рабочее место Обработка справочников Учет ТМЦ Учет ТМЦ v8 БП3.0 Абонемент ($m)

Красивая, удобная и эргономичная форма списка номенклатуры. В общем списке номенклатуры отображаются и остатки, и цены. А еще есть возможность быстро создать документы по выбранным позициям через корзину.

5 стартмани

29.02.2016    34060    111    mrXoxot    52    

Пакетная замена номенклатуры с учетом характеристик

Обработка документов Оптовая торговля Учет ТМЦ Оптовая торговля Учет ТМЦ v8 КА1 УТ10 УПП1 УУ Абонемент ($m)

Обработка "Пакетная замена номенклатуры" в Заказе покупателя, Реализации и Поступлении товаров с использованием отбора по значениям характеристик

1 стартмани

22.01.2016    19722    6    trendy    1    

1С:Интеграция ЕГАИС + Инвентаризация на ТСД

Обработка справочников Обмен через XML Оптовая торговля Оптовая торговля v8 1cv8.cf Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Абонемент ($m)

Интеграция ЕГАИС модуля для 1С: 8.3 + модуль WMS контура для инвентаризации алкогольных марок на ТСД.

1 стартмани

10.12.2015    33971    27    JetBrain    5    

Складские операции на ТСД

Терминал сбора данных Учет ТМЦ Учет ТМЦ v8 УУ Абонемент ($m)

Складская мобильная программа для терминалов сбора данных.

1 стартмани

15.11.2015    24090    4    JetBrain    8    

Остатки номенклатуры по датам поступления

Управленческие Оптовая торговля Учет ТМЦ Оптовая торговля Учет ТМЦ v8 ERP2 УТ11 УУ Абонемент ($m)

Отчет покажет залежавшиеся позиции.

1 стартмани

10.11.2015    27913    62    van_za    8    

Остатки товаров на складах по выбранным документам Промо

Печатные формы документов Учет ТМЦ Учет ТМЦ v8 ERP2 УТ11 УУ Абонемент ($m)

Печатная форма подключается к документам. Даёт возможность быстро оценить остатки товара на складе по номенклатуре, указанной в документе, и ответить на вопрос, хватает ли остатков, чтобы отгрузить счет? На каких складах продукция по этому документу?

2 стартмани

09.11.2017    39712    23    A7758735    5    

Преобразование XML в объекты 1С

Обмен через XML v8 1cv8.cf Абонемент ($m)

Преобразование XML в типовые объекты 1С всего лишь парой строк кода.

1 стартмани

17.10.2015    23219    87    PrinzOfMunchen    30    

Простой универсальный обмен между отличающимися конфигурациями. Код открыт! (СериализаторXDTO,ПостроительDOM) +примеры использования

Обмен через XML v8 1cv8.cf Абонемент ($m)

Очень удобная обработка всего с двумя "командами": Выгрузить(Что, Куда) Загрузить(Откуда)

1 стартмани

02.09.2015    21836    100    Mi4man    15    

Перенос справочников и документов из 1С 7.7 "Торговля и склад 9.2" в 1С 8.2 "Бухгалтерия предприятия 2.0".

Перенос данных из 1С7.7 в 1C8.X Обмен через XML v8 БП2.0 1С7:ТиС Россия Абонемент ($m)

Немного доработанные типовые правила обмена для конфигураций из ТиС 9.2. в БП 2.0 - «ПОД_Перенос_Справочников_ТиС_БП20.xml» и «ОбработкаВыгрузкиСправочников.ert». Добавлены правила выгрузки справочников: Организации, контрагенты и номенклатура. Доработал типовые ПОД для переноса только контрагентов и номенклатуры без документов в новую базу бухгалтерии 2.0, протестировал на типовых конфигурациях ТиС 9.2 рел.984 и БП 2.0.64.23.

1 стартмани

05.06.2015    47459    91    Kuzya_brаtsk    3    

Выгрузка - загрузка данных в XML с отбором по организации Промо

Обмен через XML Перенос данных из 1C8 в 1C8 v8 1cv8.cf Абонемент ($m)

Выгрузка - загрузка данных в XML с отбором по организации (УФ)

1 стартмани

25.05.2014    44196    297    buganov    42    

Загрузка товаров из таблицы в реализацию и поступление УТ 10.3 по артикулу и производителю + создание товаров и ГТД

Обработка документов Загрузка и выгрузка в Excel Оптовая торговля Учет ТМЦ Оптовая торговля Учет ТМЦ v8 УТ10 Россия УУ Абонемент ($m)

Обработка встраивается в конфигурацию (только кнопка для вызова обработки) и позволяет быстро и просто загрузить список товаров в реализацию или поступление. В процессе загрузки создаются отсутствующие товары и ГТД.

2 стартмани

03.03.2015    12403    1    taurus__    0    

Сверка остатков МПЗ (товаров, материалов, продукции) между планом счетов (БУ) и регистрами (РАУЗ) для КА 1.1, УПП 1.3

Бухгалтерские Анализ учета Учет ТМЦ Учет ТМЦ v8 КА1 УПП1 БУ Абонемент ($m)

Контрольный отчет для конфигураций "Комплексная автоматизация 1.1", "Управление производственным предприятием 1.3", позволяющий убедиться в том, что в регистрах регламентированного учета материально-производственных запасов (в варианте расширенной аналитики учета затрат (РАУЗ), раздел МПЗ) и на плане счетов бухгалтерского учета отражены одинаковые значения количества и стоимости МПЗ, а также позволяющий "уловить" другие ошибки учета МПЗ.

1 стартмани

24.02.2015    38895    198    stvorl    7    

Заполнение по остаткам спецодежды и инвентаря по сотрудникам

Обработка документов Учет ТМЦ Учет ТМЦ v8 БП2.0 БУ Абонемент ($m)

Обработки для заполнения по остаткам спецодежды и инвентаря по сотрудникам (можно указать список) для документа "Списание материалов из эксплуатации" и "Возврат материалов из эксплуатации"

1 стартмани

04.02.2015    11214    15    portal2011    3    

Загрузка дополнительных реквизитов и сведений справочника Номенклатура из Excel и таблиц УТ 11, ERP 2 Промо

Обработка справочников Загрузка и выгрузка в Excel Учет ТМЦ Учет ТМЦ v8 v8::ОУ ERP2 УТ11 Россия УУ Абонемент ($m)

Внешняя обработка "Загрузка дополнительных реквизитов и сведений справочника Номенклатура"

1 стартмани

07.08.2017    34760    230    Windyhead    32    

Перенос данных из Бухгалтерии 2.0 в Бухгалтерию 3.0

Перенос данных из 1C8 в 1C8 Обмен через XML v8 БП2.0 БП3.0 Россия БУ Абонемент ($m)

Перенос данных и остатков с Бухгалтерии 2.0 в Бухгалтерию 3.0 с помощью универсального обмена данными XML.

1 стартмани

30.12.2014    42663    297    sergeyzhuravlev    10    

Инвентаризационная опись 0504087 с группировкой по счету для БГУ 1.0

Печатные формы документов Учет ОС и НМА Учет ТМЦ Учет ОС и НМА Учет ТМЦ v8 БГУ Россия БУ Абонемент ($m)

Внешняя печатная форма предназначена для печати ф. 0504087 с группировкой по счёту учёта для документов:"Инвентаризация ОС (НМА,НПА) на балансовых счетах", "Инвентаризация основных средств (забалансовый учет)", "Инвентаризация ОС в оперативном учете", "Инвентаризация материалов на счете 105", "Инвентаризация материалов (забалансовый учет)".

5 стартмани

22.12.2014    32129    6    agospodarin    2    

Разбор XML документа - почти все возможные способы

Обмен через XML Практика программирования v8 1cv8.cf Абонемент ($m)

К вам пришел XML документ, как получить из него данные для обработки в 1С. ЧтениеXML, ДокументDOM, XPath, ФабрикаXDTO, ПакетыXDTO в сравнении.

1 стартмани

05.11.2014    210175    535    svenderevsky    91    

"КОММУНИКАТОР" - обмен заказами, номенклатурой, сообщениями, история работы по сделке без изменения конфигурации.

Универсальные обработки Учет ТМЦ Учет ТМЦ v8 КА1 УТ10 УПП1 Россия УУ Абонемент ($m)

Внешняя обработка(печатная форма) к конфигурациям УТ 10.3, УПП, КА для совместной работы над заказами между Покупателем и Продавцом - автоматическая передача заказа (распознавание номенклатуры поставщика/покупателя) между базами, обсуждение цен, корректировки состава, проведение согласований и т.д. Имеется лента сообщений в стиле мессенджера, в котором можно обмениваться просто сообщениями или передавать состав заказа. Обработка работает как в направлении от заказчика к покупателю, так и наоборот, т.е. инициатором может быть и менеджер по закупкам, и менеджер по продажам.

1 стартмани

24.10.2014    18143    21    informa1555    10