1С: Предприятие + корпоративный чат, как наладить оперативные уведомления за 10 минут

Публикация № 542472

Разработка - Практика программирования

IM мгновенные сообщения корпоративный чат интеграция уведомления

Как сделать автоматические уведомления о разных событиях из 1С в корпоративный чат MyChat для сотрудников компании

Есть в 1С: Предприятие несколько задач, которые хотелось бы решить без применения «чёрной магии» и малыми силами, но система не позволяет сделать такое, потому что в ней нет нормального корпоративного чата. Речь идёт о линейке версий 1С 8.xx.

  1. 1С + корпоративный чат, зачем?
  2. Какой чат взять?
  3. Как увязать эти две системы?
  4. Что делать, когда не получается?

1. 1С + корпоративный чат, зачем?

Например, при создании заказа автоматически отправлять уведомление исполнителю, это гораздо быстрее, чем через почту. Или ускорить согласование заявок на платежи. Либо уведомлять людей о том, что пришли выписки по платежкам из банка.

Было бы круто отправлять такие сообщения сразу в корпоративный чат, нужному человеку.

Экономим время — уведомления рассылаются сразу же по событию, нет задержек. Телефон не занят, необязательно, чтобы человек сидел на рабочем месте, уведомление пришло в чат и будет прочитано.

Автоматические напоминания о важных событиях  система не пропустит ничего и не забудет уведомить нужного человека.

Хорошая история  раз это корпоративный чат, то можно открыть историю сообщений и прочитать, что, когда и в каком порядке приходило. С поиском, в хронологическом порядке.

2. Какой чат взять?

Про «вкусности» рассказали, теперь о прозе. Как это всё сделать, желательно побыстрее и попроще?

Вам понадобится офисный чат MyChat, если у вас его ещё нет  скачайте бесплатную версию на 20 человек, «на попробовать» хватит, потом можно расширить лицензию. Бесплатная версия по функционалу почти ничем не отличается от коммерческой, да и триала на 30 дней нету, лицензия не ограничена по времени.

Итак, скачали, установили сервер и хотя бы один клиент, подключили клиент к серверу. Это всё можно сделать на одном компьютере, для теста хватит вполне. Ставится всё линейно, без умных вопросов. Если вдруг возникнет заминка, то вот руководства по установке:

Как установить сервер MyChat? (пошаговое руководство)

Как установить клиент MyChat? (как поставить и подключить к серверу, официальная справка)

У нас сейчас запущены сервер и клиент MyChat на одном компьютере:

Клиент и сервер MyChat, запущенные на одном компьютере

Итак, всё готово и можно переходить к следующему шагу. Как отправить сообщение из 1С прямо в офисный чат?

3. Как увязать эти две системы?

Нам понадобится два файла:

  1. Компонент для 1С, C:\Program Files (x86)\MyChat Server\doc\IntegrationAPI\1C\8.xx\mychatvk.dll, сделан по технологии NativeAPI.
  2. Библиотека MyChat Integration API, C:\Program Files (x86)\MyChat Server\doc\IntegrationAPI\MyChatIntegrationAPIDLLs\x32\mychat.dll

Берём эти две dll-библиотеки и выкладываем их в в папку \bin установленной 1С (C:\Program Files (x86)\1cv8t\8.3.5.1248\bin\).

Теперь открываем тестовую конфигурацию 1С и пишем туда вот такое (у моего компьютера с работающим сервером MyChat IP адрес 192.168.10.107, а пользователь, которого я зарегистрировал, UIN=2), а вы впишите свои данные:

Перем КомпонентMyChat;

Процедура ПоказатьТекстСтатусаНажатие(Элемент)
   ТекстСообщения = ТекстСтатуса + Символы.CR + Символы.LF + "Вторая строка";  
                            // адрес сервера, номер порта, ключ Integration API, отправитель, получатель, текст сообщения
   Результат = КомпонентMyChat.SendPrivateMessage("192.168.10.107", 2004, "iddqd", "0", "2", ТекстСообщения);
   Сообщить(Результат); // результат работы функции
КонецПроцедуры

Процедура ПриОткрытии()
   Сообщить("Версия MyChat.dll - " + КомпонентMyChat.GetMyChatLibVersion());
   Сообщить("Дата MyChat.dll - " + КомпонентMyChat.GetMyChatLibReleaseDate());
   Сообщить("Версия MyChatVK.dll - " + КомпонентMyChat.GetMyChatVKLibVersion());
   Сообщить("Дата MyChatVK.dll - " + КомпонентMyChat.GetMyChatVKLibReleaseDate());
КонецПроцедуры

Результат=ПодключитьВнешнююКомпоненту("mychatvk.dll","MyChat", ТипВнешнейКомпоненты.Native);
Если Результат Тогда
   КомпонентMyChat = Новый ("AddIn.MyChat.MyChatClass");
Иначе Сообщить("Ошибка подключения mychatvk.dll!");
КонецЕсли;

Набираем сообщение, жмём кнопку «Показать» и вуаля:

Сообщение из 1С, полученное в корпоративный чат

Что вообще произошло?

Мы нажали кнопку в 1С, отработала процедура, «дёрнула» функцию компоненты, а та, в свою очередь, через MyChat IntegrationAPI уже отправила личное сообщение от имени робота, встроенного в мессенджер  реальному человеку.

Можно и не от имени робота, но так проще, у нас ведь пользователей-то нет ещё, конфигурация тестовая.

Понятно, что в примере всё линейно и максимально просто, но для теста и понимания, как оно работает  достаточно.

Надо сказать, что сообщения отправляются надёжно, MyChat работает по схеме клиент-сервер. Можно отправлять сообщения тем людям, которых нет в сети. Можно увязать в корпоративный чат разбросанные по городу или стране подразделения, можно отправлять сообщения массово, с обязательным подтверждением прочтения. Есть всякие «вкусности», но это всё темы для отдельных статей.

Обязательно посмотрите справку по интеграции офисного чата MyChat и 1С: Предприятие, хотя бы мельком.

4. Что делать, когда не получается?

Кто ничего не делает, тот никогда не ошибается. Если что-то поломалось или не работает, а разобраться, почему, самому никак не выходит  пишите на форум поддержки MyChat. Там отзывчивые адекватные люди, вам всегда оперативно ответят и постараются помочь.

Скачать файлы

Наименование Файл Версия Размер
NativeAPI компонента для интеграции 1С и MyChat

.dll 305,02Kb
13.08.16
21
.dll 305,02Kb 21 Скачать
Библиотека для работы с MyChat IntegrationAPI

.dll 1,19Mb
13.08.16
19
.dll 1,19Mb 19 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Serega-artem 14 14.08.16 08:36 Сейчас в теме
Я вот не очень понял. Компоненты для интеграции - это автор разработал, или они уже штатно идут?
2. Demanoidos 61 14.08.16 12:06 Сейчас в теме
Сергей, эти компоненты идут штатно в комплекте с дистрибутивом MyChat Server, бесплатно. Разработаны авторами мессенджера.
3. Serega-artem 14 14.08.16 12:53 Сейчас в теме
(2) Спасибо за информацию!
4. Demanoidos 61 14.08.16 16:35 Сейчас в теме
(3) Serega-artem, пожалуйста, обращайтесь на форум поддержки, если что.
Serega-artem; +1 Ответить
5. eskor 92 15.08.16 11:57 Сейчас в теме
(4) лично я считаю, что интегрировать что-то типа MyChat жуткий моветон. Есть куча решений по чатам в самой 1С, как на уровне событий, так и совсем других. А глобально, наиболее удобно и перспективно использовать внешние сервисы, например telegramm с внятным API и кросс-платформенными клиентами. На форуме есть несколько примеров организации ботов, организовать чат на порядок проще. Причем никаких внеших компонент, исключительно http.
user835613; 127.0.0.0; Mogilnikova; Inkasor; D-masterrr; olegmedvedev; dark_wolf; sys1c; PrinzOfMunchen; Rik30; dj_serega; Silenser; Trucker; +13 2 Ответить
6. Demanoidos 61 15.08.16 12:15 Сейчас в теме
(5) eskor, возражу. Чаты на основе самой 1С это жуткое УГ. В силу того, что платформа для этого не предназначена. Прежде, чем делать какие-то выводы, рекомендую хотя бы попробовать.

Далее, чаты на основе Telegram это здорово, но ему нужен Интернет, а MyChat — это сервер внутри вашей сети. Если вы добровольно согласны сливать внутреннюю информацию компании на чужие сервера непонятно куда - это ваше право. Лично я на такое не готов. Как и множество наших клиентов.

организовать чат на порядок проще. Причем никаких внеших компонент, исключительно http


Пример в студию, покажите, насколько это проще, в отличие от того примера, что я привел.
Alligator84; inf012; Yakud3a; jONES1979; Serega-artem; A7758735; shibanovan; +7 3 Ответить
7. eskor 92 15.08.16 17:36 Сейчас в теме
(6) да не вопрос. Вот готовый пример от автора<тыц>
И насчет безопасности не перебарщивайте. Принципиально то - кто инициирует соединение и какие порты при этом используются. Впрочем это тема отдельного разговора, достаточно того, что telegramm можно встроить в 1С без танцев с бубном, и безопасность при этом не пострадает.
8. kare 21 16.08.16 13:56 Сейчас в теме
(7) eskor, платформа, не у всех 8.3 !
9. Demanoidos 61 16.08.16 14:07 Сейчас в теме
(7) eskor, наверное, вы пошутили насчёт простоты :) Там кода на три порядка больше, я специально зашёл и посмотрел. Уже не говоря про версию 8.3. Идём дальше, нужен бот. А получатели должны подписаться на этого бота. В статье, что я написал, речь идёт о корпоративном чате, с Windows. У людей десктопы. Вы предлагаете всем установить Telegram.
И насчет безопасности не перебарщивайте.

Хотелось бы. Но использование своего мессенджер-сервера - принципиальная вещь. При чём тут порты и кто инициирует соединение? Я говорю о том, что вы предлагаете конфиденциальную коммерческую информацию сливать на сервера Телеграма в Интернет. Это несерьёзно и недопустимо для бизнеса. Хотя, возможно, каким-то компаниям и наплевать на это.
Впрочем это тема отдельного разговора

100% согласен с вами.
Alligator84; inf012; +2 Ответить
11. enzain 17.08.16 11:01 Сейчас в теме
(5) eskor, Гораздо лучше - это рассылка СМС со СВОЕГО шлюза. своим работникам, или кому еще пожелаете.
Чаты, телеграммы - это все зло ...
10. enzain 17.08.16 10:58 Сейчас в теме
Если вам нужны оперативные уведомления - то нужно отправлять СМС.
slauter77; +1 Ответить
12. Demanoidos 61 17.08.16 12:38 Сейчас в теме
(10) enzain, SMS это здорово, но стоит денег. Каждая. Как минимум вам нужен шлюз и тарифный пакет для отправки сообщений. И в SMS вы запихнёте максимум 70 русских символов. Это очень мало. Мало того, посмотреть архив СМС, сделать поиск по нему. А как ответить в чат?... Ну вы поняли ход мысли :) И да, никаких гарантий насчёт получения.

Наша компания делала такой шлюз на основе Siemens MC35i, всё работало, но не бесплатно.

P.S. Забыл про бонус. Оператор связи и все интересующиеся будут знать про все ваши телодвижения в бухгалтерии. Привет Яровой :):)
shibanovan; Westbound; slauter77; +3 Ответить
13. slauter77 20 17.08.16 12:55 Сейчас в теме
Вообще-то правы все! Я бы совместил идеи. SMS - для сотрудников работающих в "полях", и чат для "офисного планктона".
Типа SMS: Вася! Обнови 1С:Бухгалтерию ООО "Василёк"
Чат: Марья Ивановна! Платеж не прошел на сумму бла бла бла для организации бла бла ссылка, документ ссылка ...
Serega-artem; Demanoidos; +2 Ответить
14. Demanoidos 61 17.08.16 13:05 Сейчас в теме
(13) slauter77, да, это хороший вариант, когда до сотрудника никак не достучаться и интернета у него нет. SMS - единственный способ прислать хоть какое-то сообщение.
15. dreamadv 148 22.08.16 10:21 Сейчас в теме
У нас для подобного решения и оповещений используется свой jabber сервер с глобальным ростером единным для всех.
16. Demanoidos 61 22.08.16 12:14 Сейчас в теме
(15) dreamadv, покажите своё решение, если не жалко, может, у него есть какие-то сильные стороны, которых мы, возможно, не заметили.
17. bas_nsk 01.10.16 05:55 Сейчас в теме
Автору, большой респект за публикацию!!!! Давно подыскивал чат , такой что бы была возможность поженить его с 1С. Почта -не оперативно , СМС - тоже не совсем то, так как в сообщении есть ссылка объект 1С .
Кое что находил из бесплатного , но из за заморочек в настройке проект так и не взлетел. А тут утром наткнулся на статью , а в обед уже первые 15 человек , радовались оперативностью оповещения. Пару недель понаблюдаю и если все будет Ок , будем брать коммерческую версию.Из минусов немного тормозит диалог передачи файлов , а так все ГУД.

18. Demanoidos 61 01.10.16 10:15 Сейчас в теме
(17) bas_nsk, Пожалуйста, пользуйтесь на здоровье. Андрей, насчёт диалога передачи файлов — лучше написать в официальный форум, там выясним, что конкретно не так и как это полечить.
19. rasswet 82 05.10.16 07:59 Сейчас в теме
в одном из новейших релизов БУДЕТ чат от самой 1С +видеозвонки. Уже видел демонстрацию. Правда не известно когда он выйдет.
20. Demanoidos 61 05.10.16 08:39 Сейчас в теме
(19) rasswet, где об этом можно почитать? И, я так понимаю, всем, кто его захочет, придётся за новый релиз заплатить. Они не говорят, сколько?
21. Serega-artem 14 07.10.16 12:28 Сейчас в теме
(19) rasswet, В новом релизе чего? Платформы? Там только чата нехватает с видеозвонками.
22. Demanoidos 61 01.03.17 15:30 Сейчас в теме
В новой версии MyChat (5.24+) добавлена возможность размещения сообщений на доске объявлений для всех пользователей сети и отправка оповещения с обязательным требованием прочтения на любое количество пользователей.

И там и там можно указать дату актуальности сообщения.

P.S. Надо скачать свежую версию библиотеки mychatvk.dll с официального сайта.
23. azubar 37 13.05.17 22:21 Сейчас в теме
Этот ваш MyChat работает только под виндой?
Решение конечно имеет право на жизнь, но я бы смотрел в сторону открытых систем.
Тот же Jabber (XMPP), реализаций найти можно уйму на этом сайте, клиенты есть под все ОС в том числе и мобильные и веб, сервера Jabber тоже есть под различные ОС и поднять свой собственный не составит труда.
Ну и собственно сама 1С уже выпустила продукт "1С:Предприятие - Сервер взаимодействия", можно как собственный сервер поднять так и пользоваться облачным от 1С, чат уже есть из коробки 1С начиная с версии 8.3.10.2168:
https://wonderland.v8.1c.ru/blog/sistema-vzaimodeystviya/
24. Demanoidos 61 15.05.17 12:55 Сейчас в теме
(23)
Александр, MyChat работает под Windows/Linux/MacOS/Android/WEB. Сервер - только под Windows.

Насчёт Jabber и 1С - я рекомендую вам самому развернуть эти системы и сравнить функционал и стоимость с MyChat, а уже потом давать комментарии, владея конкретными цифрами и функционалом.

Открытые системы - это здорово, но, к сожалению, очень сложно и часто работает далеко не всё. Когда дело доходит до реальных задач, нужны восьмигранные напильники с алмазным напылением, и то не всегда помогает :) Говорю не просто так, есть приличный опыт работы с OpenFire/ejabberd. Серьёзные же коммерческие системы стоят уйму денег. Например, Skype for business. MyChat между ними посредине. В любом случае, для начала попробуйте бесплатную версию, чтобы сложить своё собственное мнение. До 20 человек онлайн - бесплатно, без ограничения по времени использования.

Насчёт решения от 1С. Да, в статусе беты, наверное, допилят до какого-то уровня со временем. Функционал слабенький, системные требования - весьма серьёзные, без 1С - не работает. Работает через WebSockets. То есть внутри что-то типа Electron или WebKit (обрезанный Chrome, ниже Windows 7/Vista работать не будет). Вы серьёзно считаете, что для компании на 200-300 человек нужно закупать лицензии на 1С на все рабочие места, чтобы общаться в корпоративном чате? Во сколько это обойдётся?
25. azubar 37 16.05.17 08:21 Сейчас в теме
(24) Насчёт Jabber и 1С, неоднократно разворачивал и использую. Например наиболее активно используется корпоративный чат на коробке Битрикс24 там свой Jabber (XMPP) сервер, есть интеграция с 1С с Jabber (вполне себе без сторонних компонент), все отлично работает, про какие напильники идет речь?
Туда же в Битрикс заведены открытые линии, так что менеджеры из единого чата могут общаться с клиентами через Telegram, Viber, VK, Facebook и пр.

MyChat безусловно молодцы что сделали библиотеку для интеграции, функционал действительно достаточно широк и выходит за рамки корпоративного чата, я даже проголосовал за публикацию в знак одобрения и поддержки.
Но справедливости ради надо заметить что это не единственное достойное решение.
26. Demanoidos 61 16.05.17 15:42 Сейчас в теме
(25) Понятно, что не единственное. Когда я говорил о Jabber серверах, я имел в виду не готовое решение от 1С, а отдельный ejabberd или openfire сервер, с ними, собственно, и хлебнули радостей :)
27. sertak 253 23.11.17 11:50 Сейчас в теме
Добавлю свои 5 копеек что ли.
В октябре 2017 сменил не удовлетворявший требованиям чат *** на бесплатную версию MyChat (от скайпа ранее решили уйти по причине его врожденной ущербности зависимости от сети интернет и периодической глючности разной степени серьезности), благо число сотрудников компании пока меньше 20 и в бесплатную версию вписываемся. Меня как 1Сника естественно интересовала интеграция чата с ней любимой. Оказалось все довольно просто: закинуть 2 библиотеки в каталог 1С.
Ниже пример процедуры, рассылающей информацию о днях рождения сотрудников из конфигурации Бухгалтерия для Беларуси 2.1 за 3 дня и в день рождения всем, кроме именинников. Конфигурация доработана следующим образом:
В справочник Сотрудники добавлены реквизиты ТА_UIN (UIN пользователя чата), ТА_ПолучатьУведомления (необходимость отправки данному сотруднику сообщений) и ТА_РассылатьУведомленияОДР (необходимость оповещения коллег о ДР данного сотрудника). При приеме я вношу в сотрудника UID, при проведении увольнения флаги сбрасываются автоматом (код из увольнения не привожу, он примитивен). Требования к моему примитивному механизму: у каждого сотрудника должна быть учетка в MyChat, тогда каждый актуальный сотрудник будет гарантированно уведомлен о ДР других сотрудников, кроме собственного.
На данный момент есть нюанс: при отправке из 64-битной версии 1С компонента не загружается из-за ошибки, поэтому я через планировщик задач windows открываю внешнюю обработку в пустой базе 32-битной версии 1С, при этом к бухгалтерии подключаюсь удаленно через COM для получения списка сотрудников, но разработчики пообещали исправить ошибку, так что это неудобство временное. Приведенный код предназначен для 32-битной 1С. Если хотите сделать через планировщик, то в коде добавьте выполнение запроса через COM, в остальном все то же.
Функция УстановитьСоединениеСMyChat(ТекстОшибки)
	Результат = ПодключитьВнешнююКомпоненту("mychatvk.dll","MyChat", ТипВнешнейКомпоненты.Native);
	Если Результат Тогда
		Возврат Новый ("AddIn.MyChat.MyChatClass");
	Иначе 
		ТекстОшибки = "Ошибка подключения к mychatvk.dll на сервере";
		Возврат Неопределено;
	КонецЕсли;
КонецФункции
Показать

Функция ОтправитьСообщениеОдномуПользователю(Подключение, UINПользователя, ТекстСообщения)
	// адрес сервера, номер порта, ключ Integration API, отправитель, получатель, текст сообщения
	КлючIntegrationAPI = "***";
  	Подключение.SendPrivateMessage("192.168.0.123", 2004, КлючIntegrationAPI, "0", Строка(UINПользователя), ТекстСообщения);
КонецФункции

Процедура НапомнитьОДняхРожденияСотрудников() Экспорт
	
	ТекстОшибки = "";
	ПодключениеКMyChat = УстановитьСоединениеСMyChat(ТекстОшибки);
	Если ПодключениеКMyChat = Неопределено Тогда
		Сообщить(ТекстОшибки);
		Возврат;
	КонецЕсли;
	
	//Список получателей
	Запрос = Новый Запрос;
	Запрос.Текст = 
		"ВЫБРАТЬ РАЗЛИЧНЫЕ
		|	Сотрудники.ТА_UIN КАК UIN
		|ИЗ
		|	Справочник.Сотрудники КАК Сотрудники
		|ГДЕ
		|	Сотрудники.ТА_ПолучатьУведомления
		|	И Сотрудники.ТА_UIN > 0
		|УПОРЯДОЧИТЬ ПО
		|	Сотрудники.ТА_UIN";
	
	РезультатЗапроса = Запрос.Выполнить();
	ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
	СписокПолучателейМассив = Новый Массив;
	Пока ВыборкаДетальныеЗаписи.Следующий() Цикл		
		СписокПолучателейМассив.Добавить(ВыборкаДетальныеЗаписи.UIN);		
	КонецЦикла;
	
	//Список потенциальных именинников
	Запрос = Новый Запрос;
	Запрос.Текст = 
		"ВЫБРАТЬ
		|	Сотрудники.ФизическоеЛицо.ФИО КАК ФИО,
		|	Сотрудники.ФизическоеЛицо.ДатаРождения КАК ДатаРождения,
		|	Сотрудники.ТА_UIN КАК UIN
		|ИЗ
		|	Справочник.Сотрудники КАК Сотрудники
		|ГДЕ
		|	Сотрудники.ТА_РассылатьУведомленияОДР
		|	И Сотрудники.ФизическоеЛицо.ДатаРождения <> &ПустаяДата";
	
	Запрос.УстановитьПараметр("ПустаяДата", Дата(1,1,1));
	РезультатЗапроса = Запрос.Выполнить();
	ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
	
	Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
		
		ЧислоСутокДоДняРожденияДляНапоминания1 = 3;
		ЧислоСутокДоДняРожденияДляНапоминания2 = 0;
		
		СегодняшнийДень = НачалоДня(ТекущаяДата());
		ДатаНапоминания1 = (Дата(Год(СегодняшнийДень), Месяц(ВыборкаДетальныеЗаписи.ДатаРождения), День(ВыборкаДетальныеЗаписи.ДатаРождения)) - ЧислоСутокДоДняРожденияДляНапоминания1 * 24 * 3600);
		ДатаНапоминания2 = (Дата(Год(СегодняшнийДень), Месяц(ВыборкаДетальныеЗаписи.ДатаРождения), День(ВыборкаДетальныеЗаписи.ДатаРождения)) - ЧислоСутокДоДняРожденияДляНапоминания2 * 24 * 3600);
		
		Если СегодняшнийДень <> ДатаНапоминания1 И СегодняшнийДень <> ДатаНапоминания2 Тогда
			Продолжить;
		КонецЕсли;
		
		UINИменинника = Строка(ВыборкаДетальныеЗаписи.UIN);
		
		Для Счетчик = 0 По СписокПолучателейМассив.ВГраница() Цикл
			
			UINПолучателя = Строка(СписокПолучателейМассив[Счетчик]);
			Если UINИменинника = UINПолучателя Тогда
				Продолжить;
			КонецЕсли;
			
			ТекстСообщения = 
				"Напоминание: " + 
				Строка(День(ВыборкаДетальныеЗаписи.ДатаРождения)) + " " + 
					ПолучитьНаименованиеМесяца(Месяц(ВыборкаДетальныеЗаписи.ДатаРождения)) +
					" празднует день рождения "
					+ ВыборкаДетальныеЗаписи.ФИО;
					
			ОтправитьСообщениеОдномуПользователю(ПодключениеКMyChat, UINПолучателя, ТекстСообщения);		
		КонецЦикла;		
	КонецЦикла;			
	ПодключениеКMyChat = Неопределено;	
КонецПроцедуры
Показать
Alligator84; +1 Ответить
28. sertak 253 23.11.17 11:58 Сейчас в теме
(27) П.С. Насчет оптимальности кода и прочее - это не та ветка ).
29. webcisp 11.03.18 18:39 Сейчас в теме
Есть проверка работы на платформе 8,2 в клиент серверном варианте, почему спрашиваю, потому что уже наступал на эти грабли с библиотеками API / COM и т.п.
30. Demanoidos 61 12.03.18 18:12 Сейчас в теме
(29) Совместимость есть, тестировалось всё на 8.3, но на 8.2 должно работать точно так же.
31. Luck_DMST 24 26.07.18 15:56 Сейчас в теме
Автор безусловно молодец, спасибо за наводку, но к этому чату очень много вопросов, не тянет он на корпоративный чат, очень много косяков обнаружил наш сисадмин, писал им в поддержку несколько раз ответы "порадовали"))) создание msi пакетов за денежку, поддержки универсальных путей: //server100500/files - увы нет :( ну не хотим мы файлы, передаваемые пользователями хранить у них на компе, хотим все хранить на серверах
32. Demanoidos 61 26.07.18 17:05 Сейчас в теме
(31) MSI пакет есть, берите и пользуйтесь. Вы что-то явно путаете. А не хотите файлы у клиентов хранить - ну не передавайте их напрямую, проблем-то. Заливайте штучно, они ж на сервере хранятся :) Перетащили мышкой в окно и бросили, что проще может быть?
33. Luck_DMST 24 26.07.18 18:58 Сейчас в теме
(32) Про то что есть MSI согласен, не верно выразился, прошу извинить, есть функция такая создание своего msi пакета, так вот там можно создавать пакет, но он не корректно работает, хотя создается...
На счет заливать файлы, ошибка :(
[ERROR] Ошибка #0234: ошибка заливки файла на сервер (URL "https://192.168.0.1:80/uploading/", #10091, "Network subsystem is unusable")
34. Demanoidos 61 26.07.18 19:23 Сейчас в теме
(33) Если вы про Distrib Maker - то там нет MSI вообще, только EXE. А про сетевую ошибку - это у вас файрвол или касперский на сервере хулиганит, не даёт залить файл по https. Вы на форуме поддержки спрашивали про это?
35. Maxx2008 06.08.18 10:24 Сейчас в теме
"корпоративный чат" - это когда много пользователей) а цены на лицензии этой программы просто "конские"( 100 человек - 4000 баксов, 300 человек (количество пользователей для нашего предприятия) - 15000 баксов. Уж лучше самим сделать, на регистрах сведений, на порядок дешевле получается, ИМХО
36. Demanoidos 61 06.08.18 13:50 Сейчас в теме
(35) Макс, у вас нелады с математикой. Лицензия на 100 человек стоит 400 долларов, а не 4 тысячи. На порядок промахнулись.
37. Maxx2008 06.08.18 17:38 Сейчас в теме
(36) Моё упущение))) Посмотрел на сайте, там они хотят ввести количество лицензий кратное 10. После надписи "Укажите, сколько подключений вам необходимо:" я в поле ввёл необходимое количество, и совсем не смотрел на какие-то арифметические действия. Ввел количество, посмотрел на цену))) Не внятно этот момент на сайте прописан, или надпись поменять, или принцип ввода количества
Прикрепленные файлы:
38. Demanoidos 61 06.08.18 17:56 Сейчас в теме
То есть, цены уже не конские ? :):)
39. Maxx2008 06.08.18 18:00 Сейчас в теме
(38) за 300 лицензий 1200 баксов? На такое начальство может и согласится) Беру свои слова обратно)
40. ivdic 30 15.11.18 17:22 Сейчас в теме
А Может кто приведет код как оповещать о новых задачах в документообороте в чат? (фактически дублирование сообщений внутри программы, но только когда программа не запущена.
сообщение типа такого: вам назначена задача - ознакомление и ссылка ....
41. Demanoidos 61 15.11.18 19:01 Сейчас в теме
(40) Вам надо событие отловить в самом 1С, что новая задача назначена. А что отправлять в чат - это уже дело техники.
42. ivdic 30 16.11.18 08:12 Сейчас в теме
(41) вот и хотелось бы чтобы все увдедомления окном (см. скрин) перехватывались и передавались в мессенжер причем любой .. или даже самописный агент...который бы сидел в трее и автозагрузке и выдавал сообщения при выключенной программе.. (смысл то всего ..это оповестить о событии как можно раньше...чтобы сэкономить время на обработку задания)

1с реализовало обсуждения через сервер взаимодействия...но настолько криво и неумело... (сообщения можно посылать только из программы.. и вручную...хотя направление правильное ..
Прикрепленные файлы:
43. Demanoidos 61 16.11.18 14:21 Сейчас в теме
(42) как перехватить в самом 1С — я не знаю, не специалист в этом вопросе. Но когда перехватите — то отправить эти сообщения в MyChat в конференцию или личкой - пара пустяков, пример.
44. ivdic 30 16.11.18 16:07 Сейчас в теме
вот именно кто даст решение на пальцах как это сделать...очень актуально!


можно наверно как то реализовать оповещение через сервер взаимодействия... https://its.1c.ru/db/v8311doc#bookmark:dev:TI000001962
например что то в виде этого...

ИдентификаторОбсуждения = СистемаВзаимодействия.ПолучитьОбсуждение(ИмяКомпьютера + ИдентификаторПользователя + "Сообщить");
Сообщение = СистемаВзаимодействия.СоздатьСообщение(ИдентификаторОбсуждения);
Сообщение.Текст = "Зарегистрирован новый документ!";
Сообщение.Записать();


у кого какие мысли?
45. sertak 253 28.01.19 14:48 Сейчас в теме
Итак, продолжу свои скромные заметки.
Второй вариант отправки сообщений из 1С в MyChat - через REST-запросы. Этот вариант не зависит от разрядности платформы 1С:Предприятие. Вот мой примерчик:

	Сервер = "192.168.1.223";
	Порт = 8081;
	Отправитель = 0; //UIN той самой Элизы, т.е. робота (на мой взгляд, именно от робота наиболее целесообразно осуществлять рассылку)
	Получатель = 3; //UIN, email или ник пользователя-получателя

	ТекстСообщения = "Первая строка тестового сообщения." + Символы.ПС + "Вторая строка тестового сообщения!"; //обычная строка из мира 1С
	//Столь родной сердцу символ Символы.ПС заменяем на странные кракозябры управляющие символы в соответствии с законами мира web-технологий
	РазделительСтрок = "\r\n";
	ТекстСообщения = СтрЗаменить(ТекстСообщения, Символы.ПС, РазделительСтрок);
	
	//Ключ берем из http://<сервер>:<порт>/admin/#/navSettings/SettingsAPI/
	КлючIngtegrationAPI = "*****";
	
	Ресурс = "API/?data={""cmd"":""0002"",""UserFrom"":""" + Отправитель + """,""UserTo"":""" + Получатель + """,""Msg"":""" + ТекстСообщения + """,""APIStype"":""mydata"",""ServerKey"":""" + КлючIngtegrationAPI + """}";
	
	Попытка
		Соединение = Новый HTTPСоединение(Сервер, Порт);
		HTTPЗапрос = Новый HTTPЗапрос(Ресурс);
		Ответ  = Соединение.Получить(HTTPЗапрос);
	Исключение
	    Сообщить(ИнформацияОбОшибке().Описание, СтатусСообщения.Важное);
	КонецПопытки;
Показать
Demanoidos; +1 Ответить
46. Demanoidos 61 28.01.19 15:32 Сейчас в теме
(45) выглядит неплохо. А есть в 1С какой-то встроенный механизм для работы с JSON, чтобы руками его не лепить?
47. sertak 253 28.01.19 15:45 Сейчас в теме
(46) да, надо время найти да добить по-человечески
48. sertak 253 28.01.19 16:26 Сейчас в теме
Вариант с REST через метод POST. Параметры собираются в объект типа Структура, затем преобразуются в JSON (его можно скормить сразу готовый) и передаются на сервер:

	Сервер = "192.168.1.223";
	Порт = 8081;
	Ресурс = "/API/?data=";
	
	ПараметрыЗапроса = Новый Структура;
	ПараметрыЗапроса.Вставить("cmd", "0002");
	ПараметрыЗапроса.Вставить("UserFrom", "0");
	ПараметрыЗапроса.Вставить("UserTo", "3");
	ПараметрыЗапроса.Вставить("Msg", "Тестовое сообщение от " + ТекущаяДата());
	ПараметрыЗапроса.Вставить("APIStype", "mydata");
	ПараметрыЗапроса.Вставить("ServerKey", "********");
	
	ФайлЗапроса = ПолучитьИмяВременногоФайла();
	ФайлРезультата = ПолучитьИмяВременногоФайла();	
	
	ЗаписьJSON = Новый ЗаписьJSON; 
	ЗаписьJSON.ОткрытьФайл(ФайлЗапроса);
	ЗаписатьJSON(ЗаписьJSON, ПараметрыЗапроса); 
	ЗаписьJSON.Закрыть();

	Попытка
		HTTP = Новый HTTPСоединение(Сервер,Порт);
		HTTPЗапрос = Новый HTTPЗапрос(Ресурс);
	    HTTPЗапрос.УстановитьИмяФайлаТела(ФайлЗапроса);
	    Результат  = HTTP.ОтправитьДляОбработки(HTTPЗапрос, ФайлРезультата);
		ЧтениеJSON = Новый ЧтениеJSON;
		ЧтениеJSON.ОткрытьФайл(ФайлРезультата); 							
		пJSON = ПрочитатьJSON(ЧтениеJSON);
		ЧтениеJSON.Закрыть();
		//При желании можно почитать данные возвращаемого JSON,
		//можно проверить Результат.КодСостояния <> 200 и т.д.
	Исключение
		Сообщить("Ошибка при отправке запроса: " + ОписаниеОшибки());
	КонецПопытки;
	
	Попытка
		УдалитьФайлы(ФайлЗапроса);
	Исключение КонецПопытки;
	
	Попытка
		УдалитьФайлы(ФайлРезультата);
	Исключение КонецПопытки;
Показать
Mogilnikova; +1 Ответить
49. Demanoidos 61 28.01.19 16:33 Сейчас в теме
(48) А без сохранения в файл можно сделать? Сделали JSON -> отправили запрос.
50. sertak 253 28.01.19 16:51 Сейчас в теме
(49) да, примерно так:

	Сервер = "192.168.1.223";
	Порт = 8081;
	Ресурс = "/API/?data=";
			
	СтрокаJSON = "{""cmd"":""0002"",""UserFrom"":""0"",""UserTo"":""3"",""Msg"":""Hellomsg"",""APIStype"":""mydata"",""ServerKey"":""*****""}";
	
	Попытка
		HTTP = Новый HTTPСоединение(Сервер,Порт,,,,30);
		HTTPЗапрос = Новый HTTPЗапрос(Ресурс);
		HTTPЗапрос.Заголовки.Вставить("Content-type", "application/x-www-form-urlencoded");
		HTTPЗапрос.УстановитьТелоИзСтроки(СтрокаJSON, КодировкаТекста.UTF8, ИспользованиеByteOrderMark.НеИспользовать);
		Результат  = HTTP.ОтправитьДляОбработки(HTTPЗапрос);
		//Если Результат.КодСостояния <> 200 Тогда ...
	Исключение
		Сообщить("Ошибка при отправке запроса: " + ОписаниеОшибки());
	КонецПопытки;
Показать
Mogilnikova; +1 Ответить
51. sertak 253 29.01.19 08:51 Сейчас в теме
(50) Стандартных средств преобразования из структуры в строку JSON без сохранения в файл я не нашел, но с помощью дополнительных функций это можно сделать (функции взяты отсюда: Обмен данными с сайтом используя формат JSON в 1С, добавил в них только замену Символы.ПС на "\r\n"):

&НаКлиенте
Процедура ОтправитьСообщениеПользователю(UINПользователя, ТекстСообщения)
	
	Сервер = "192.168.1.223";
	Порт = 8081;
	Ресурс = "/API/?data=";
	
	СтруктураДанных = Новый Структура;
	СтруктураДанных.Вставить("cmd", "0002");
	СтруктураДанных.Вставить("UserFrom", "0");
	СтруктураДанных.Вставить("UserTo", UINПользователя);
	СтруктураДанных.Вставить("Msg", ТекстСообщения);
	СтруктураДанных.Вставить("APIStype", "mydata");
	СтруктураДанных.Вставить("ServerKey", "*****");
	
	СтрокаJSON = СформироватьСтрокуJSON(СтруктураДанных);
	
	Попытка
		HTTP = Новый HTTPСоединение(Сервер,Порт,,,,30);
		HTTPЗапрос = Новый HTTPЗапрос(Ресурс);
		HTTPЗапрос.Заголовки.Вставить("Content-type", "application/x-www-form-urlencoded");
		HTTPЗапрос.УстановитьТелоИзСтроки(СтрокаJSON, КодировкаТекста.UTF8, ИспользованиеByteOrderMark.НеИспользовать);
		Результат  = HTTP.ОтправитьДляОбработки(HTTPЗапрос);
		Если Результат.КодСостояния <> 200 Тогда 
			Сообщить("Ошибка при отправке запроса: " + Результат.КодСостояния);
		КонецЕсли;
	Исключение
		Сообщить("Ошибка при отправке запроса: " + ОписаниеОшибки());
	КонецПопытки;

КонецПроцедуры

&НаКлиенте
Функция СформироватьСтрокуJSONИзМассива(Объект)

	СтрокаJSON = "[";
	
	Для каждого Элемент Из Объект Цикл
		Если ТипЗнч(Элемент) = Тип("Строка") Тогда
			СтрокаJSON = СтрокаJSON + """" + СтрЗаменить(Элемент, Символы.ПС, "\r\n") + """";
		ИначеЕсли ТипЗнч(Элемент) = Тип("Число") Тогда
			СтрокаJSON = СтрокаJSON + СтрЗаменить(Строка(Элемент), Символы.НПП, "");
		ИначеЕсли ТипЗнч(Элемент) = Тип("Булево") Тогда
			СтрокаJSON = СтрокаJSON + Формат(Элемент, "БЛ=false; БИ=true");
		ИначеЕсли ТипЗнч(Элемент) = Тип("Дата") Тогда
			СтрокаJSON = СтрокаJSON + Формат(Элемент - Дата(1970,1,1,1,0,0), "ЧГ=0");
		ИначеЕсли ТипЗнч(Элемент) = Тип("Массив") Тогда
			СтрокаJSON = СтрокаJSON + СформироватьСтрокуJSON(Элемент);
		ИначеЕсли ТипЗнч(Элемент) = Тип("Структура") Тогда
			СтрокаJSON = СтрокаJSON + СформироватьСтрокуJSON(Элемент);
		ИначеЕсли ТипЗнч(Элемент) = Тип("ТаблицаЗначений") Тогда
			СтрокаJSON = СтрокаJSON + СформироватьСтрокуJSON(Элемент);
		Иначе
			СтрокаJSON = СтрокаJSON + """" + URLEncode(Строка(Элемент)) + """";
		КонецЕсли;
		
		СтрокаJSON = СтрокаJSON + ",";
	КонецЦикла;
	
	Если Прав(СтрокаJSON, 1) = "," Тогда
		СтрокаJSON = Лев(СтрокаJSON, СтрДлина(СтрокаJSON)-1);
	КонецЕсли;
	
	Возврат СтрокаJSON + "]";

КонецФункции

&НаКлиенте
Функция СформироватьСтрокуJSONИзСтруктуры(Объект)

	СтрокаJSON = "{";
	
	Для каждого Элемент Из Объект Цикл
		Если Элемент.Значение = "" Тогда
			Продолжить;
		КонецЕсли;
		
		СтрокаJSON = СтрокаJSON + """" + Элемент.Ключ + """" + ":";
		
		Если ТипЗнч(Элемент.Значение) = Тип("Строка") Тогда
			СтрокаJSON = СтрокаJSON + """" + СтрЗаменить(Элемент.Значение, Символы.ПС, "\r\n") + """";
		ИначеЕсли ТипЗнч(Элемент.Значение) = Тип("Число") Тогда
			СтрокаJSON = СтрокаJSON + СтрЗаменить(Строка(Элемент.Значение), Символы.НПП, "");
		ИначеЕсли ТипЗнч(Элемент.Значение) = Тип("Булево") Тогда
			СтрокаJSON = СтрокаJSON + Формат(Элемент.Значение, "БЛ=false; БИ=true");
		ИначеЕсли ТипЗнч(Элемент.Значение) = Тип("Дата") Тогда
			СтрокаJSON = СтрокаJSON + Формат(Элемент.Значение - Дата(1970,1,1,1,0,0), "ЧГ=0");
		ИначеЕсли ТипЗнч(Элемент.Значение) = Тип("Массив") Тогда
			СтрокаJSON = СтрокаJSON + СформироватьСтрокуJSON(Элемент.Значение);
		ИначеЕсли ТипЗнч(Элемент.Значение) = Тип("Структура") Тогда
			СтрокаJSON = СтрокаJSON + СформироватьСтрокуJSON(Элемент.Значение);
		ИначеЕсли ТипЗнч(Элемент.Значение) = Тип("ТаблицаЗначений") Тогда
			СтрокаJSON = СтрокаJSON + СформироватьСтрокуJSON(Элемент.Значение);
		Иначе
			СтрокаJSON = СтрокаJSON + """" + URLEncode(Строка(Элемент.Значение)) + """";
		КонецЕсли;
		
		СтрокаJSON = СтрокаJSON + ",";
	КонецЦикла;
	
	Если Прав(СтрокаJSON, 1) = "," Тогда
		СтрокаJSON = Лев(СтрокаJSON, СтрДлина(СтрокаJSON)-1);
	КонецЕсли;
	
	Возврат СтрокаJSON + "}";

КонецФункции

&НаКлиенте
Функция СформироватьСтрокуJSON(Объект) Экспорт

	СтрокаJSON = "";
	
	Если ТипЗнч(Объект) = Тип("Массив") Тогда
		СтрокаJSON = СформироватьСтрокуJSONИзМассива(Объект);
	ИначеЕсли ТипЗнч(Объект) = Тип("Структура") Тогда
		СтрокаJSON = СформироватьСтрокуJSONИзСтруктуры(Объект);
	ИначеЕсли ТипЗнч(Объект) = Тип("ТаблицаЗначений") Тогда
		СоставСтруктуры = "";
		Для каждого Колонка Из Объект.Колонки Цикл
			СоставСтруктуры = СоставСтруктуры + ?(ЗначениеЗаполнено(СоставСтруктуры), ",", "") + Колонка.Имя;
		КонецЦикла;
		
		МассивСтрок = Новый Массив;
		Для каждого Строка Из Объект Цикл
			СтруктураКолонок = Новый Структура(СоставСтруктуры);
			ЗаполнитьЗначенияСвойств(СтруктураКолонок, Строка);
			МассивСтрок.Добавить(СтруктураКолонок);
		КонецЦикла;
		
		СтрокаJSON = СформироватьСтрокуJSONИзМассива(МассивСтрок);
	КонецЕсли;
	
	Возврат СтрокаJSON;
КонецФункции

&НаКлиенте
Функция URLEncode(стр) Экспорт	

	Длина=СтрДлина(Стр);
	Итог="";
	Для Н=1 По Длина Цикл
		Знак=Сред(Стр,Н,1);
		Код=КодСимвола(Знак);
		
		если ((Знак>="a")и(Знак<="z")) или
			 ((Знак>="A")и(Знак<="Z")) или
			 ((Знак>="0")и(Знак<="9")) тогда
			Итог=Итог+Знак;
		Иначе
			Если (Код>=КодСимвола("А"))И(Код<=КодСимвола("п")) Тогда
				Итог=Итог+"%"+ПреобразоватьвСистему(208,16)+"%"+ПреобразоватьвСистему(144+Код-КодСимвола("А"),16);
			ИначеЕсли (Код>=КодСимвола("р"))И(Код<=КодСимвола("я")) Тогда
				Итог=Итог+"%"+ПреобразоватьвСистему(209,16)+"%"+ПреобразоватьвСистему(128+Код-КодСимвола("р"),16);
			ИначеЕсли (Знак="ё") Тогда
				Итог=Итог+"%"+ПреобразоватьвСистему(209,16)+"%"+ПреобразоватьвСистему(145,16);
			ИначеЕсли (Знак="Ё") Тогда
				Итог=Итог+"%"+ПреобразоватьвСистему(208,16)+"%"+ПреобразоватьвСистему(129,16);
			Иначе
				Итог=Итог+"%"+ПреобразоватьвСистему(Код,16);
			КонецЕсли;
		КонецЕсли;
	КонецЦикла;
	Возврат Итог;

КонецФункции

&НаКлиенте
Функция ПреобразоватьвСистему(Число10,система) Экспорт

	Если система > 36 или система < 2 тогда
		Сообщить("Выбранная система исчисления не поддерживается");
		Возврат -1;
	КонецЕсли;
	
	СтрокаЗначений = "0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZ";
	СтрокаСистема = "";
	Пока Число10 > 0 цикл
		РезДеления = Число10/система;
		ЧислоСистема = цел(РезДеления);
		остатокОтДеления = Число10 - система*(ЧислоСистема);
		СтрокаСистема = сред(СтрокаЗначений,остатокОтДеления+1,1)+ СтрокаСистема;
		Число10 = ?(ЧислоСистема=0,0,РезДеления); 
	КонецЦикла;
	
	Нечётное = стрДлина(СтрокаСистема) - цел(стрДлина(СтрокаСистема)/2)*2;
	Если Нечётное тогда
		СтрокаСистема = "0"+СтрокаСистема;
	КонецЕсли;
	
	Возврат СтрокаСистема;

КонецФункции
Показать
52. sertak 253 30.01.19 14:35 Сейчас в теме
(49) добил, наконец, через средства, появившиеся в версии 8.3.6 и позволяющие преобразовывать без лишних телодвижений:

	Сервер = "192.168.1.223";
	Порт = 8081;
	Ресурс = "/API/?data=";
	UINПолучателя = "3";
	Ключ = "PHbL-wNirbUVWJ2q93YO";
	ТекстСообщения = "Тестовое сообщение от " + ТекущаяДата() + Символы.ВК + Символы.ПС + "строка 2";
	
	Соответствие = Новый Соответствие;
	Соответствие.Вставить("cmd", "0002");
	Соответствие.Вставить("UserFrom", "0");
	Соответствие.Вставить("UserTo", UINПолучателя);
	Соответствие.Вставить("Msg", ТекстСообщения);
	Соответствие.Вставить("APIStype", "mydata");
	Соответствие.Вставить("ServerKey", Ключ);
	
	//Для ПараметрыЗаписиJSON можно задавать различные настройки в конструкторе, в данном примере используется конструктор по умолчанию
	ПараметрыJSON = Новый ПараметрыЗаписиJSON();
	ЗаписьJSON = Новый ЗаписьJSON;
	ЗаписьJSON.УстановитьСтроку(ПараметрыJSON); 
	
	ЗаписьJSON.ЗаписатьНачалоОбъекта();
	
	Для Каждого КлючЗначение Из Соответствие Цикл
		
		ЗаписьJSON.ЗаписатьИмяСвойства(КлючЗначение.Ключ);
		ЗаписьJSON.ЗаписатьЗначение(КлючЗначение.Значение);
				
	КонецЦикла;
	
	ЗаписьJSON.ЗаписатьКонецОбъекта();
	
	СтрокаJSON = ЗаписьJSON.Закрыть();  
	
	Попытка
		HTTP = Новый HTTPСоединение(Сервер,Порт,,,,30);
		HTTPЗапрос = Новый HTTPЗапрос(Ресурс);
		HTTPЗапрос.Заголовки.Вставить("Content-type", "application/x-www-form-urlencoded");
	    HTTPЗапрос.УстановитьТелоИзСтроки(СтрокаJSON, КодировкаТекста.UTF8, ИспользованиеByteOrderMark.НеИспользовать);
	    Результат  = HTTP.ОтправитьДляОбработки(HTTPЗапрос);
		Если Результат.КодСостояния <> 200 Тогда
			Сообщить("Ошибка при отправке запроса: " + Результат.КодСостояния);
		КонецЕсли;
	Исключение
		Сообщить("Ошибка при отправке запроса: " + ОписаниеОшибки());
	КонецПопытки;
Показать
53. sertak 253 01.02.19 08:39 Сейчас в теме
(49) упростил код:
	Сервер = "192.168.1.223";
	Порт = 8081;
	Ресурс = "/API/?data=";
	Ключ = "******";
	UINПолучателя = "3";
	
	ТекстСообщения = "Тестовое сообщение от " + ТекущаяДата() + Символы.ВК + Символы.ПС + "строка 2";
	
	СтруктураДанных = Новый Структура;
	СтруктураДанных.Вставить("cmd", "0002");
	СтруктураДанных.Вставить("UserFrom", "0");
	СтруктураДанных.Вставить("UserTo", UINПолучателя);
	СтруктураДанных.Вставить("Msg", ТекстСообщения);
	СтруктураДанных.Вставить("APIStype", "mydata");
	СтруктураДанных.Вставить("ServerKey", Ключ);
	
	ЗаписьJSON = Новый ЗаписьJSON;
	ЗаписьJSON.УстановитьСтроку(); 
	ЗаписатьJSON(ЗаписьJSON, СтруктураДанных);
	СтрокаJSON = ЗаписьJSON.Закрыть();  
	
	Попытка
		HTTP = Новый HTTPСоединение(Сервер,Порт,,,,30);
		HTTPЗапрос = Новый HTTPЗапрос(Ресурс);
		HTTPЗапрос.Заголовки.Вставить("Content-type", "application/x-www-form-urlencoded");
	    HTTPЗапрос.УстановитьТелоИзСтроки(СтрокаJSON, КодировкаТекста.UTF8, ИспользованиеByteOrderMark.НеИспользовать);
	    Результат  = HTTP.ОтправитьДляОбработки(HTTPЗапрос);
		Если Результат.КодСостояния <> 200 Тогда
			Сообщить("Ошибка при отправке запроса: " + Результат.КодСостояния);
		КонецЕсли;
	Исключение
		Сообщить("Ошибка при отправке запроса: " + ОписаниеОшибки());
	КонецПопытки;
Показать
Demanoidos; +1 Ответить
54. Demanoidos 61 24.02.19 16:09 Сейчас в теме
(53) Спасибо за хороший пример, включили его в официальную справку.
59. sertak 253 16.08.19 13:15 Сейчас в теме
(53)
Некоторые символы сообщения перед отправкой нужно заменить, иначе оно не отправится:

РазделительСтрок = "\r\n";
ТекстСообщения = СтрЗаменить(ТекстСообщения, "\", "/"); //замена обратного слэша на прямой
ТекстСообщения = СтрЗаменить(ТекстСообщения, Символы.ПС, РазделительСтрок);
ТекстСообщения = СтрЗаменить(ТекстСообщения, """", "'"); //замена двойной кавычки на одинарную
60. sertak 253 30.08.19 09:57 Сейчас в теме
(59) Сообщение о замене символов написал ошибочно, не нужно заменять, т.к. при формировании строки JSON через объект ЗаписьJSON символы преобразуются автоматически. Я собирал строку вручную, поэтому у меня и возникла проблема с символами.

Коллеги, удалите вышеприведенный код (сообщение 59), если добавляли.
55. Mogilnikova 64 27.03.19 10:41 Сейчас в теме
Поразительно, столько шума за два года и никто не обратил внимание на то, что в главе "2. Какой чат взять?" не рассматривается причин взять этот чат. Словно бы действительно это единственный чат, который может во внешнее API. А ведь причин объективно нет. API сейчас у любого современного чата, полно свободного ПО с открытым кодом для организации корпоративных мессенджеров. Народ не торчит у компов и корпоративный - это прежде всего который из программы присылает пуш-уведомление на телефон.

Да и фиг бы с тем что реклама, но ребята, если я создаю чат, в который из 1С буду отправлять сообщения, я ведь хочу иметь возможность ещё и прочитать эти сообщения в программе 1С, а у вас только отправка в Intergation API описана.

У вас есть возможность через апи зарегистрировать пользователя, перенести пользователя из общего чата в группу. Но откуда возьмется группа нигде не сказано! И почему любой человек может переносить в группу людей, или там какие-то права настраиваются на группе или что там происходит? Почему это -то не описали во внешнем Апи, или к вашему мессенджеру надо ещё брать комплект администраторов этого мессенджера? так ведь они тоже денег стоят.

Половина документации просто пустые разделы, зачем-то втюхан глоссарий с кучей слов в алфавитном порядке и несколько из них даже описаны. Вероятно какие-то сложные термины про Rest,сервера, протоколы обмена? Нет, там указано объяснение слов "Админка", "Мессадж", "Онлайн", "Чат".

В документации на консоль кони пляшут(смотреть скрины)


Создается устойчивое впечатление, что функционал настолько печален, что потребовалось сделать как можно больше пустых и бесполезных разделов, чтобы покупатель запутался, заблудился и не увидел этой пустоты.
Возможно, во времена Фидонета это было актуально и весело, но вы вроде как продаете лицензии на ПО, написанное в течение 15 лет на паскале, за неплохие деньги в 2019ом году. Ну за 15 лет можно было сделать к ней нормальную документацию или там действительно описывать нечего?
Прикрепленные файлы:
56. Demanoidos 61 27.03.19 19:41 Сейчас в теме
(55) Куча вопросов ни о чем. Документация огромна и постоянно обновляется. Задайте конкретный вопрос - ответим. Не нравится MyChat - не юзайте его, никто не заставляет. Клиенты есть под Windows, Android, macOS, Linux и WEB.
я ведь хочу иметь возможность ещё и прочитать эти сообщения в программе 1С

Ок, как?
57. Mogilnikova 64 28.03.19 13:05 Сейчас в теме
(56) В плане "как"? обратиться к апи и по неким фильтрам(id пользователей, группы пользователей, idчатов, период времени) получить сообщения.

А что неконкретного и "ни о чем" в моем посте?
Я вроде достаточно конкретно указала, что судя по документации в программе очень ограниченный функционал, нет описания как добиться базовых вещей. Рекламируемое в этой публикации API не дает возможности полностью контролировать чаты из 1С - следовательно после того как один раз программу настроят к ней ещё надо будет штатного администратора чатов, который будет в этой программе постоянно сидеть и раздавать права, создавать группы - ещё вложения в программу, постоянные вложения.
Проект за 15 лет не развился в серьезное ПО, но денюжки сосет. Документация не информативная, много пустых разделов, зачем то развлекательные разделы включены, у части разделов не коррелируют название и наполнение.

Это совсем не выглядит как "Документация огромна и постоянно обновляется", скорее как любительская разработка бывшего фидошника или дипломная работа на заочном факультете.
58. Demanoidos 61 28.03.19 17:09 Сейчас в теме
(57) Благодарю за пояснение насчёт контроля сообщений из 1С. Вы имеете право на собственное мнение. Но должны понимать, что то, что вы хотите читать логи либо получать историю сообщений удаленно из другой системы - просто не существует. Не существует, потому что мы этого не делали, такой задачи не стояло. Если вам это реально нужно - оплачиваете и мы сделаем.
Проект за 15 лет не развился в серьезное ПО, но денюжки сосет.

Снова ваше личное мнение. История версий и что в них было сделано.
следовательно после того как один раз программу настроят к ней ещё надо будет штатного администратора чатов, который будет в этой программе постоянно сидеть и раздавать права, создавать группы

Не надо ничего настраивать, все работает сразу "из коробки". Можете вообще не распихивать пользователей по группам прав, они автоматически назначаются. Напишите, что конкретно вы хотите сделать - я отвечу, предметно. Лучше на официальном форуме, конечно, но можно и здесь, если вам удобнее.
Оставьте свое сообщение

См. также

Вам нравятся запросы в 1С? Промо

Практика программирования Разработка v8 v8::Запросы 1cv8.cf Абонемент ($m)

Речь не только о том, что простейший запрос с "легальным" оформлением растянется на пол-экрана, речь еще обо всем, что нужно написать "в нагрузку" к тексту запроса. Все эти "Новый Запрос", "УстановитьПараметр" и последующие пляски с обработкой результата... Пора с этим заканчивать!

1 стартмани

03.07.2019    21145    5    m-rv    88    

Интерактивная справка по объектам 1С (автономное расширение)

Практика программирования Работа с интерфейсом v8 ERP2 Абонемент ($m)

База знаний, подключаемая к объектам основной базы. Ведётся интерактивно, формируется в виде статей прямо в 1С (текст, картинки, таблицы, ссылки). Есть возможность прикрепления файлов, привязки к объектам 1С, возможности рейтинга и комментирования пользователями.

3 стартмани

29.09.2020    6570    33    sapervodichka    33    

Конвейер проверки качества кода

Инструментарий разработчика Практика программирования Математика и алгоритмы v8 1cv8.cf Абонемент ($m)

Jenkinsfile для выполнения проверки качества кода. Собирает информацию с АПК, EDT и BSL-LS. Сопоставляет ошибки с гит-репозиторием, выгруженным ГитКонвертором. Отправляет в Сонар.

3 стартмани

04.09.2019    25497    22    Stepa86    46    

Алгоритмы поиска пути в графе

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

Реализуем алгоритмы поиска пути в графе на платформе 1С 8.3, такие как алгоритм А*, поиск в ширину, жадный поиск, алгоритм Дейкстры и вконце волновой.

1 стартмани

09.07.2019    17923    12    RonX01    10    

ВСТАВИТЬ В Справочник.Номенклатура (Код, Наименование) ЗНАЧЕНИЯ ("001", "Новый товар") Промо

Практика программирования v8 v8::Запросы 1cv8.cf Абонемент ($m)

Вас не обманывают ваши глаза, это запрос на изменение данных! И это работает без прямого доступа к БД, регистрации и смс.

1 стартмани

01.06.2018    30855    86    m-rv    57    

Работа с публикациями "Инфостарт"

Практика программирования О сообществе WEB v8 УУ Абонемент ($m)

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    22100    13    RocKeR_13    16    

HTTP Сервисы: Путь к своему сервису. Часть 3

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Продолжение статьи «HTTP Сервисы: Путь к своему сервису. Часть 2». В предыдущих частях мы использовали только Get, в этой части поговорим о других методах и длительных операциях.

1 стартмани

27.08.2018    38658    56    dsdred    17    

Позиционирование в помещении с помощью нейросети по сигналу Wi-Fi. Интерактивная карта склада в 1С с показом позиции

Инструментарий разработчика Практика программирования v8 Абонемент ($m)

Данная публикация содержит в себе редактор и интерактивную карту склада или иного помещения, на которой в реальном времени отображается позиция устройства, координаты которого вычисляются по уровням сигнала нескольких роутеров Wi-Fi. В статье и приложенным к ней разработкам предлагаются инструменты и методика для реализации вычисления точной геопозиции внутри помещений с помощью нейронной сети. Конфигурация написана на релизе 1С:Предприятие 8.3.12.1412, клиентское приложение имеет минимальный уровень совместимости SDK -16.

5 стартмани

09.08.2018    28604    26    informa1555    26    

Заполняем по шаблону (по умолчанию) Промо

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Простой в подключении, универсальный и достаточно удобный механизм заполнения реквизитов произвольных документов/справочников значениями по умолчанию. Реализован в расширении, но может быть и непосредственно включен практически в любую конфигурацию на управляемых формах простым копированием одной формы и двух команд. Весь код в статье.

1 стартмани

08.02.2018    28682    19    mvxyz    17    

Работа с данными выбора

Практика программирования Работа с интерфейсом v8 Россия Абонемент ($m)

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений - уже задать без программирования не получится.

1 стартмани

17.07.2018    48965    17    kalyaka    16    

Полезные примеры составления схемы компоновки данных #2

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Еще один набор примеров как решить частные задачи в СКД

1 стартмани

22.05.2018    31652    11    SITR-utyos    13    

Печатная форма, сделанная как расширение конфигурации для БП 3.0. Новые возможности БСП

Практика программирования Универсальные печатные формы v8 БП3.0 Абонемент ($m)

Печатные формы на внешних обработках скоро канут в лету. На смену им приходят ПФ, реализованные в виде расширений конфигурации. Не нашел на сайте примеров таких расширений. Привожу пример подобного расширения для БП 3.0.

1 стартмани

06.12.2017    27398    54    kwazi    6    

Нечеткий поиск одним запросом Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

Использование механизма полнотекстового поиска в 1С не всегда оправдано, т.к. построение индекса и поддержание его в актуальном состоянии может значительно нагружать систему. Предлагаемая реализация нечеткого поиска методом N-грамм выполняется одним запросом, что позволяет производить поиск в любой таблице и не требует предварительного построения индекса.

1 стартмани

28.12.2015    28200    71    vasvl123    9    

Паузы при исполнении кода (Sleep для 1С)

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Решил проверить все найденные варианты паузы для 1С. В результате получилась обработка для тестирования и небольшая статья с итогом.

1 стартмани

28.11.2017    46991    12    swimdog    42    

Макет в СКД - пример всех возможных типовых вариантов

Практика программирования Инструментарий разработчика v8 v8::СКД 1cv8.cf Абонемент ($m)

Макет СКД: наглядное представление того, что, как и куда выводится при типовых настройках.

1 стартмани

09.11.2017    22244    76    freelancer    4    

Telegram-боты

Практика программирования v8 Абонемент ($m)

Описание теории, разбор архитектуры и пример реализации telegram-ботов. Сразу скажу, со структурированием изложения мало что могу поделать. :) редакция от 18.07.2018 Правки последней редакции выделены жирным.

1 стартмани

01.09.2017    33210    132    PLAstic    59    

Быстрое определение интервалов в запросе Промо

Практика программирования v8 Абонемент ($m)

В статье описывается новый метод определения интервалов между данными различных записей в запросе. В отличие от общеизвестного метода, время работы предлагаемого метода зависит от объема данных ЛИНЕЙНО. Это обеспечивает ему значительный выигрыш по быстродействию на больших объемах данных. В качестве иллюстрации возможностей метода приведен отчет, показывающий гистограмму распределения времени между продажами.

1 стартмани

01.10.2015    52133    35    ildarovich    41    

Умный дом на 1С + ардуино

Практика программирования v8 Абонемент ($m)

Конфигурация для автоматизации быта программиста 1C и не только. В данной статье будет рассказано, как можно использовать 1С для задач, не входящих в стандартные рамки этой платформы. Например, управление домом. В качестве периферии для подключения будет использован микроконтроллер (МК) Ардуино, но на нём не будет никакой логической нагрузки, весь процесс будет проходить на сервере 1С. Работа с пинами ввода/вывода происходит напрямую из 1С.

1 стартмани

07.08.2017    23151    21    sasha777666    63    

Расширения конфигураций 1С: учимся перехватывать методы

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

В этой статье я на примерах разберу некоторые механизмы расширений конфигураций 1С. А именно «перехваты» методов модуля объекта и «перехваты» событий формы и элементов формы. Данная статья написана с учебными целями, чтобы показать, как при помощи расширений конфигурации можно делать такие доработки, ради которых раньше приходилось снимать конфигурацию с поддержки.

1 стартмани

30.05.2017    132401    13    signum2009    48    

Регулярные выражения – это просто. Построитель и отладчик регулярных выражений

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Предлагается к использованию построитель регулярных выражений. Выполненный в виде внешней обработки, он позволит строить сложно-структурированные выражения на основе параметрического описания, тестировать их, и в результате получить программный код 1С.

1 стартмани

13.03.2017    31896    113    romasna    49    

Хранение файлов в томах на диске (для УПП 1.3) Промо

Практика программирования v8 УПП1 Абонемент ($m)

Доработка типовой УПП 1.3 в плане хранения присоединенных файлов вне базы данных

2 стартмани

05.06.2016    58171    10    wowik    32    

Распознавание текста с помощью нейросетей Google Cloud Vision и 1С

Практика программирования v8 1cv8.cf Абонемент ($m)

Возможности Google Cloud Vision в распознавании текста.

1 стартмани

08.02.2017    30036    127    kiv1c    18    

Графическая схема. Управление при помощи XDTO.

Практика программирования v8 Абонемент ($m)

В статье описывается методика программного управления элементами графической схемы при помощи механизма XDTO. Приложена готовая к использованию библиотека функций для создания и удаления графических объектов, а также для связи элементов схемы соединительными линиями.

2 стартмани

16.01.2017    22758    105    Alxby    23    

Простой редактор плана помещения JavaScript

Практика программирования Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

На ресурсе сейчас очень много решений, которые позволяют редактировать карты, используя географические схемы. Так же много решений, которые позволяют редактировать объекты онлайн веб-карт. Мне же нужно было простое решение, для того чтобы расставить квадратные объекты на плане, показать их пользователю. Ну и распечатать, опять же. Я решил написать простенький редактор на JavaScript с использованием библиотеки Raphael.

1 стартмани

23.11.2016    21432    96    igel9780    22    

Расчет средних по периодам в запросе - это элементарно! Промо

Практика программирования Анализ учета v8 1cv8.cf Россия Абонемент ($m)

Распространено мнение, что расчет средних по периодам в запросе - это сложно. В статье приводится прием, позволяющий опровергнуть это заблуждение. Приводится описание метода, его обоснование и ограничения использования. Как примеры прилагаются два практичных отчета на СКД: для расчета среднедневных остатков товаров и для расчета среднедневной задолжности контрагентов. Отчеты созданы на платформе 8.1 для конфигурации УТ10.3 .

1 стартмани

29.09.2011    68982    45    ildarovich    34    

Работа с двоичными данными на примере чтения файлов изображений. Новые возможности 8.3.9

Практика программирования WEB v8 1cv8.cf Россия Абонемент ($m)

В статье приводятся новые функции по работе с двоичными данными, появившимися в версии платформы 8.3.9 , на примере анализа формата и размера изображений. А также пример отправки изображения через API ВКонтакте с помощью новых объектов (без использования ОбъединитьФайлы())

1 стартмани

14.11.2016    26556    16    Anton64    22    

Загрузка файлов на сервер с прогрессом и докачкой

Практика программирования v8 1cv8.cf Россия Абонемент ($m)

Пример использования новых возможностей платформы 8.3.9 по низкоуровневой работе с двоичными данными для инкрементальной передачи файлов на сервер.

1 стартмани

04.10.2016    13577    53    mrstomak    21    

Несколько шаблонов для доработки типовых конфигураций

Практика программирования Инструментарий разработчика v8 v8::УФ Абонемент ($m)

Предлагаю несколько каркасов для создания новых объектов в типовых конфигурациях. Это выжимка из кода нескольких конфигураций, которая позволит быстро и красиво создавать и дорабатывать объекты метаданных с соблюдением идеологии исходной системы

1 стартмани

03.10.2016    37036    95    json    25    

HTTP-сервис: отчеты [Расширение]

Практика программирования Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Это HTTP-сервис, который возвращает почти любой отчет в HTML, XLSX или в JSON. Сохраните вариант отчета, получите на него ссылку и можно получить данные без захода в 1С. Работает в конфигурациях на основе БСП 2.3.3+, для отчетов на СКД и в 1С 8.3.8+

2 стартмани

30.08.2016    27230    137    Stepa86    15    

Недокументированное использование стандартных форм Upd.

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Вам не хватает возможностей в платформе 1С или у Вас нет времени на углубленное изучение платформы 1С? Рассмотрены возможности использования стандартных форм, вызываемых из платформы.

1 стартмани

26.07.2016    28659    77    ZhokhovM    60    

БСП 2.3 и БСП 3.0: Просто про выполнение внешней обработки в фоне (c индикацией прогресса выполнения)

Инструментарий разработчика Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Простое пояснение о том, как сделать внешнюю обработку с фоновым выполнением и индикацией процесса для любой конфигурации на основе БСП 2.3.2. UPDATE 20/09/19: добавлен вариант обработки с индикацией процента выполнения и статусом выполнения для БСП 3.0.

1 стартмани

18.05.2016    62572    184    rozer    65    

Остатки на каждый день в запросе

Практика программирования Учет ТМЦ Учет ТМЦ v8 1cv8.cf УУ Абонемент ($m)

Запрос формирует остатки товаров на каждый день в пределах выбранного периода.

1 стартмани

26.04.2016    59812    19    arakelyan    19    

Еще один способ расчета остатков на каждый день в запросе

Математика и алгоритмы Практика программирования v8 Абонемент ($m)

Предлагается новый способ расчета остатков на каждый день (час, минуту, секунду) в запросе. Способ не требует предварительного формирования таблицы дат и также подходит для расчета курсов валют, цен номенклатуры и других периодических сведений на каждую дату периода. На больших объемах данных предлагаемый способ может превосходить по быстродействию ранее известные методы из-за линейной (в лучшем случае) зависимости трудоемкости от длины периода.

1 стартмани

24.04.2016    34979    49    ildarovich    23    

Вывод печатных форм с запросом данных в форму "Печать документов" из подсистемы БСП "Печать".

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Все не раз видели, как в типовых конфигурациях, построенных на основе БСП (Библиотека стандартных подсистем), печатные формы, построенные на основе Табличного документа, выводятся в специальную форму "ПечатьДокументов". Эта форма входит в состав подсистемы "Печать" из БСП. При разработке своих печатных форм, иногда необходимо запросить у пользователя дополнительные данные необходимые для печати. Тут встает вопрос, как в этом случае вывести печатную форму в форму "Печать документа". В этой статье я рассмотрю, как реализовать вывод печатной формы в упомянутую форму из подсистемы "Печать", в случае если мы хотим перед выводом печатной формы запросить у пользователя дополнительные данные. Здесь будут рассмотрены два случая: когда реализуется печатная форма с использованием подсистемы "Дополнительные отчеты и обработки" и когда печатная форма добавляется в конфигурацию в режиме конфигуратора, т.е. вносятся изменения в типовую конфигурацию.

1 стартмани

29.03.2016    91470    181    lopatin    14    

Выполнение JavaScript кода из 1С в объекте Поле HTML Документа (HTML 5) и вызов события в 1С ПриНажатии

Практика программирования v8 1cv8.cf Россия Абонемент ($m)

Пример выполнения JS кода из 1С в Поле HTML Документа под управляемыми формами, с удобным получением результата в 1С(С помощью вызова привязанного события ПриНажатии к элементу ПолеHTMLДокумента)

1 стартмани

22.03.2016    82110    160    igo1    54    

Количество дней недели (понедельников/вторников/...) в заданном диапазоне одним запросом

Практика программирования v8 Абонемент ($m)

При реализации периодического авто-заполнения маршрутных листов по графику (недельному) необходимо было просчитать стоимость всего периода, с условием выездов только по определенным дням. Заморачиваться с обходом результата не хотелось. Пришлось написать "Небольшой" запрос.

1 стартмани

03.03.2016    18560    1    Alexander.Shvets    5    

Простые радости жизни программиста 1С: выбор типа значения

Работа с интерфейсом Практика программирования v8 1cv8.cf Абонемент ($m)

Предлагаемая в работе обработка включает обычную и управляемую формы, которые максимально точно реализуют функциональность системного диалога выбора типа в толстом клиенте обычное приложение (включая оформление диалога). Эти формы имеют дополнительные интерфейсные удобства и могут быть использованы в качестве альтернативных диалогов выбора типа.

1 стартмани

17.02.2016    50613    53    yuraos    17    

Отображение прогресса выполнения длительных операций в БСП и их отладка в текущем сеансе.

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

В статье описан способ исполнения длительных операций в конфигурациях, в которых используется библиотека стандартных подсистем, с визуализацией прогресса исполнения и отображения хода обработки данных. Также дается краткое описание процесса отладки длительных операций в текущем сеансе.

1 стартмани

17.02.2016    56090    179    balanton    23    

Яндекс.Деньги "Благотворительность"

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Яндекс.Деньги теперь в 1С. Форма для приема благотворительных взносов. Форму легко сделать и вставить на любую страницу сайта или блога. Платежи будут приходить на ваш кошелек. На форме есть три способа платежа: из кошелька, с банковской карты, с баланса мобильного.

1 стартмани

16.02.2016    23627    8    Tatitutu    5    

Мастер рассылки e-mail 2.2 для управляемых форм

Практика программирования Email v8 v8::УФ ERP2 БП3.0 УТ11 Абонемент ($m)

Для пользователей: переделанный из старый разработки под 8.2 с использованием библиотеки Мастер рассылки e-mail 2.2 (ERP, УТ, БП) (Только управляемые формы), который теперь может запускаться под любой версией платформы с разрешенными или запрещенными модальными/синхронными вызовами в конфигурации. Также удобный выбор e-mail и их владельцев с помощью отбора динамического списка по любым критериям и галочки исключения.

1 стартмани

29.12.2015    37341    20    milkers    4    

Передача больших пакетов через веб-сервисы

Практика программирования Администрирование данных 1С Внешние источники данных v8 Абонемент ($m)

Реализация механизма передачи больших пакетов через веб-сервисы. С его помощью передать файл размером в несколько гигабайт не составит проблем.

1 стартмани

06.12.2015    57576    48    YPermitin    19    

Пример связи 1С и мессенджера Telegram. Получение данных из 1С запросом из Telegram

Практика программирования Внешние источники данных v8 1cv8.cf Абонемент ($m)

В результате чтения публикации Вы получите готовую внешнюю обработку, позволяющую получать из 1С данные, запрашиваемые через Telegram. В данной статье рассмотрим следующее: Использование HTTPСоединение; Чтение JSON для версии 1С 8.3.6 и выше, а также аналог JSON для версии 1С ниже 8.3.6; Подключение обработчика ожидания; Некоторые основные возможности API Telegram; Как создать бота для Telegram; Программное создание колонок дерева на управляемой форме;

1 стартмани

19.11.2015    94723    464    Luchik    207