В «1С:ЗУП КОРП 3.1» тормоза (медленная работа) в журналах документов при использовании критериев отбора

Публикация № 722861

Администрирование - Производительность и оптимизация (HighLoad)

ЗУП 3.1 КОРП тормозит медленная оптимизация конструктор динамический запрос журнал документов критерии отбора доработка типовых RLS отбор динамический список избыточное

Статья для тех, у кого: 1) используете RLS (ограничение доступа на уровне записей и полей), 2) много документов (более 100 тысяч в одном журнале), 3) используете «Журналы документов», 4) отборы в динамическом списке (по сотруднику). Скорее всего, Вы испытали на себе, как отбор происходит минутами (жутко тормозит) – тогда Вам сюда.

Введение

В 1С когда то давно появился новый объект конфигурации «Критерий отбора» зачем он нужен и какой он хороший писали не раз, например, //infostart.ru/public/401743/

 

Вопросы производительно и особенности использования так же осуждали не раз, например, //infostart.ru/public/548778/

 

Но, например, в типовом «1С: Зарплата и Управление Персоналом КОРП, редакция 3.1» и многих других типовых конфигураций используют данный механизм критерия отборов не обращая внимания на вопросы производительности. ПОЧЕМУ?!

 

Ответ, наверное, очень прост: использование «Журналов документов» и «Критериев отбора» упрощает разработку типовых конфигураций, а вопросы производительности пусть потом решают специально обученные люди, как бы 1С намекает зачем нужны «1С:Эксперт по технологическим вопросам» да и вообще Франчайзинг или Консалтинг.

 

Более детально описание проблемы в «Журнале документов», например, «Кадровые документы» при установки отбора по сотруднику происходит зависание и после этого медленно работает пролистывание списка. Смотрим в код и что видим?! При установки/изменения отбора по сотруднику при помощи «Критерия отбора» «Документы сотрудников» происходит получение массива документов, где есть физ.лицо выбранного сотрудника, а затем этот массив устанавливается в отбор динамического списка в «Журнале документов» «Кадровые документы».

 

Вроде все «кашерно» и логично, но есть несколько но:

  1. Основная причина проблем. Список видов документов в «Журнале документов» «Кадровые документы» и «Критерия отбора» «Документы сотрудников» сильно различается. Скриншоты в конце статьи.
  2. Избыточные чтения ненужных таблиц документов при получении массива документов для отбора.
    В результате чего будет произведен поиск при помощи «Критерия отбора» «Документы сотрудников» по видам документов, которые не входят в «Журнале документов» «Кадровые документы».
  3. Избыточные данные в массиве документов для отбора.
    В результате чего в массив документов, который будет получен из «Критерия отбора» «Документы сотрудников» могут входить документы, которых нет в «Журнале документов» «Кадровые документы».
  4. Сам механизм «Критерии отбора» работает не идеально, то есть выполнения запроса ко всем документам из критерия отбора работает быстрее.

При попытке сделать динамический конструктор запроса, который эмулирует работу запроса, по критерию отбора получилась довольно универсальная функция «ПолучитьТекстЗапроса_ДокументыСотрудников()" (пример ниже по тексту).

Далее встал вопрос как «зарулить» все вызовы из журналов документов на нужный мне код, и о СПАСИБО функций которых надо поправить было всего ТРИ и изменения в одну строчку. Надо отдать должное разработчикам типовых конфигураций, которые сделали общие функции для работы отборов по сотрудникам - универсальными функциями и использовали их по максимум.

 

Вся доработка заключалась в том, что бы:

  1. В функции «ДокументыПоФизическомуЛицу()» заменить текст запроса на свой. Добавить новый параметр, для получения имени формы;
  2. В функциях «ПараметрКритерияОтбораНаФормеСДинамическимСпискомПриИзменении()» и «ОбновитьФормыСДинамическимСписком()» которые добавить параметр для вызова «ДокументыПоФизическомуЛицу()»;
  3. Добавить свою функцию конструктор запросов «ПолучитьТекстЗапроса_ДокументыСотрудников()» в общем модуле (с настройкой: повторное использование - «На время сеанса»);
  4. Добавить свою функцию переопределения текста запроса «ПереопределениеДокументыПоФизическомуЛицу()» в общем модуле.
  5. Исключения для журнала документов «Кадровые документы» в форме списка была ДВА вызова, которые почему то шли не через общий механизм «ПриСозданииНаСервере()» и «ОбновитьНаСервере()»

 

Итого при использовании журналов документов:

  1. скорость работы выросла примерно в 200 раз,
  2. количество чтений уменьшилось в 300 раз.

Думаю хороший результат.

Проверка и доработка проводилась на «Зарплата и управление персоналом КОРП, редакция 3.1 (3.1.3.224) (http://v8.1c.ru/hrmcorp)».

 

Листинг кода:

ОбщийМодуль.ЗарплатаКадры
Процедура ПараметрКритерияОтбораНаФормеСДинамическимСпискомПриИзменении(Форма, ИмяЭлемента) Экспорт
	
	НайденныеСтроки = Форма.ПараметрыКритерияОтбора.НайтиСтроки(Новый Структура("ИмяЭлементаФормыПараметра", ИмяЭлемента));
	Если НайденныеСтроки.Количество() > 0 Тогда
		// Изменение параметра, установим использование
		СтрокаПараметра = НайденныеСтроки[0];
		Форма[СтрокаПараметра.ИмяРеквизитаФормыПараметраИспользование] = Истина;
	Иначе
		НайденныеСтроки = Форма.ПараметрыКритерияОтбора.НайтиСтроки(Новый Структура("ИмяЭлементаФормыПараметраИспользование", ИмяЭлемента));
		Если НайденныеСтроки.Количество() = 0 Тогда
			Возврат;
		КонецЕсли;
		// Изменение использования параметра
		СтрокаПараметра = НайденныеСтроки[0];
	КонецЕсли;
	
	МассивДокументов = Новый Массив;
	Если Форма[СтрокаПараметра.ИмяРеквизитаФормыПараметраИспользование] Тогда
		// +++ замена критерии отбора на прямые запросы
		//МассивДокументов = ДокументыПоФизическомуЛицу(Форма[СтрокаПараметра.ИмяРеквизитаФормыПараметра]);
		МассивДокументов = ДокументыПоФизическомуЛицу(Форма[СтрокаПараметра.ИмяРеквизитаФормыПараметра], Форма.ИмяФормы);
		// --- 
	КонецЕсли;
	
	Список = Форма[Форма.НаименованиеРеквизитаФормыДинамическийСписок];
	ОбщегоНазначенияКлиентСервер.УстановитьПараметрДинамическогоСписка(
		Список,
		СтрокаПараметра.ИмяПараметра,
		МассивДокументов,
		Форма[СтрокаПараметра.ИмяРеквизитаФормыПараметраИспользование]);
	
КонецПроцедуры

Процедура ОбновитьФормыСДинамическимСписком(Форма) Экспорт
	
	Список = Форма[Форма.НаименованиеРеквизитаФормыДинамическийСписок];
	Для Каждого СтрокаПараметра Из Форма.ПараметрыКритерияОтбора Цикл
		МассивДокументов = Новый Массив;
		Если Форма[СтрокаПараметра.ИмяРеквизитаФормыПараметраИспользование] Тогда
			// +++ замена критерии отбора на прямые запросы
			//МассивДокументов = ДокументыПоФизическомуЛицу(Форма[СтрокаПараметра.ИмяРеквизитаФормыПараметра]);
			МассивДокументов = ДокументыПоФизическомуЛицу(Форма[СтрокаПараметра.ИмяРеквизитаФормыПараметра], Форма.ИмяФормы);
			// --- 
			
			ОбщегоНазначенияКлиентСервер.УстановитьПараметрДинамическогоСписка(
				Список,
				СтрокаПараметра.ИмяПараметра,
				МассивДокументов,
				Форма[СтрокаПараметра.ИмяРеквизитаФормыПараметраИспользование]);
		Иначе
			Для каждого ЭлементФормы Из Форма.Элементы Цикл
				Если ТипЗнч(ЭлементФормы) = Тип("ТаблицаФормы") И ЭлементФормы.ПутьКДанным = Форма.НаименованиеРеквизитаФормыДинамическийСписок Тогда
					ЭлементФормы.Обновить();
				КонецЕсли;
			КонецЦикла;
		КонецЕсли;
	КонецЦикла;
	
КонецПроцедуры

// +++ замена критерии отбора на прямые запросы
//Функция ДокументыПоФизическомуЛицу(ФизическоеЛицо) Экспорт
Функция ДокументыПоФизическомуЛицу(ФизическоеЛицо, ИмяФормы = "") Экспорт
// --- 
	
	
	МассивДокументов = Новый Массив;
	
	УстановитьПривилегированныйРежим(Истина);
	
	Запрос = Новый Запрос;
	Запрос.УстановитьПараметр("ФизическоеЛицо", ФизическоеЛицо);
	
	Запрос.Текст =
	"ВЫБРАТЬ
	|	КритерийОтбораДокументыСотрудников.Ссылка
	|ИЗ
	|	КритерийОтбора.ДокументыСотрудников(&ФизическоеЛицо) КАК КритерийОтбораДокументыСотрудников";
	
	// +++ замена критерии отбора на прямые запросы
	add_ОбщийМодуль.ПереопределениеДокументыПоФизическомуЛицу(Запрос.Текст, ИмяФормы);
	// --- 
	
	Выборка = Запрос.Выполнить().Выбрать();
	Пока Выборка.Следующий() Цикл
		МассивДокументов.Добавить(Выборка.Ссылка);
	КонецЦикла;
	
	УстановитьПривилегированныйРежим(Ложь);
	
	Возврат МассивДокументов;
	
КонецФункции


ОбщийМодуль.add_ОбщийМодуль (* компиляция сервер)
Процедура ПереопределениеДокументыПоФизическомуЛицу(ТекстЗапроса, ИмяФормы) Экспорт 
	
	Если СтрНайти(ИмяФормы, "ЖурналДокументов.") > 0 И СтрНайти(ИмяФормы, ".Форма.ФормаСписка") > 0 Тогда 
		Поз = Найти(ИмяФормы, ".Форма.ФормаСписка");
		ИмяЖурнала = Сред(ИмяФормы, 18, Поз - 18);
	Иначе 
		Возврат;
	КонецЕсли;
	
	НовыйТекст = "";
	НовыйТекст = add_ОбщегоНазначенияПовтИсп.ПолучитьТекстЗапроса_ДокументыСотрудников(ИмяЖурнала);

	Если ЗначениеЗаполнено(НовыйТекст) Тогда 
		ТекстЗапроса = НовыйТекст;
	КонецЕсли;
КонецПроцедуры

ОбщийМодуль.add_ОбщегоНазначенияПовтИсп (* компиляция - «Сервер», повторное использование - «На время сеанса»)

Функция ПолучитьТекстЗапроса_ДокументыСотрудников(ИмяЖурналаДокументов) Экспорт 
	Попытка
		_СЗ = Новый СписокЗначений;	

		Для Каждого _Док Из Метаданные.Документы Цикл 
			Если НЕ Метаданные.ЖурналыДокументов[ИмяЖурналаДокументов].РегистрируемыеДокументы.Содержит(_Док) Тогда 
				Продолжить;
			КонецЕсли;
			
			Для Каждого _Рек Из _Док.Реквизиты Цикл 
				Если Метаданные.КритерииОтбора.ДокументыСотрудников.Состав.Содержит(_Рек) Тогда 
					_СЗ.Добавить(_Док.Имя, _Рек.Имя);			
				КонецЕсли;
			КонецЦикла;
			
			Для Каждого _ТЧ Из _Док.ТабличныеЧасти Цикл 
				Для Каждого _Рек Из _ТЧ.Реквизиты Цикл 
					Если Метаданные.КритерииОтбора.ДокументыСотрудников.Состав.Содержит(_Рек) Тогда 
						_СЗ.Добавить(_Док.Имя + "." + _ТЧ.Имя, _Рек.Имя);			
					КонецЕсли;
				КонецЦикла;
			КонецЦикла;
		КонецЦикла;
		
		Шаблон = "Выбрать Ссылка из Документ.#Документ# где #Поле# = &ФизическоеЛицо";
		Разделитель = Символы.ПС + "ОБЪЕДИНИТЬ ВСЕ" + Символы.ПС;
		Текст = "";
		ЭтоПервый = Истина;
		
		Для Каждого _Строка Из _СЗ Цикл 
			Если ЭтоПервый Тогда 
				СтрокаШаблон = СтрЗаменить("Выбрать Разрешенные Ссылка Из Документ.#Документ# Где #Поле# = &ФизическоеЛицо", "#Документ#", _Строка.Значение);
				СтрокаШаблон = СтрЗаменить(СтрокаШаблон, "#Поле#", _Строка.Представление);
				Текст = СтрокаШаблон;	
				ЭтоПервый = Ложь;
			Иначе 
				СтрокаШаблон = СтрЗаменить(Шаблон, "#Документ#", _Строка.Значение);
				СтрокаШаблон = СтрЗаменить(СтрокаШаблон, "#Поле#", _Строка.Представление);
				Текст = Текст + Разделитель + СтрокаШаблон;
			КонецЕсли;
		КонецЦикла;
	Исключение
		Сообщить(ОписаниеОшибки());
		Текст = "";
	КонецПопытки;
		
	Возврат Текст;
КонецФункции

Исключения
ЖурналДокументов.КадровыеДокументы.Форма.ФормаСписка.Форма.Модуль 	

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	
	// Пропускаем инициализацию, чтобы гарантировать получение формы при передаче параметра "АвтоТест".
	Если Параметры.Свойство("АвтоТест") Тогда
		Возврат;
	КонецЕсли;
	
	Если Параметры.Свойство("Заголовок") Тогда
		Заголовок = Параметры.Заголовок;
	КонецЕсли;
	
	Параметры.Свойство("СотрудникСсылка", СотрудникСсылка);
	
	Если ЗначениеЗаполнено(СотрудникСсылка) Тогда
		
		КадровыеДанныеСотрудников = КадровыйУчет.КадровыеДанныеСотрудников(Истина, СотрудникСсылка, "ГоловнаяОрганизация,ФизическоеЛицо,ТекущаяОрганизация");
		Если КадровыеДанныеСотрудников.Количество() > 0 Тогда
			
			ДанныеСотрудника = КадровыеДанныеСотрудников[0];
			
			Организация = ДанныеСотрудника.ТекущаяОрганизация;
			
			ОбщегоНазначенияКлиентСервер.УстановитьЭлементОтбораДинамическогоСписка(
				Список, "ГоловнаяОрганизация", ДанныеСотрудника.ГоловнаяОрганизация);
				
			// +++ замена критерии отбора на прямые запросы
			//МассивДокументов = ЗарплатаКадры.ДокументыПоФизическомуЛицу(ДанныеСотрудника.ФизическоеЛицо);
			МассивДокументов = ЗарплатаКадры.ДокументыПоФизическомуЛицу(ДанныеСотрудника.ФизическоеЛицо, ЭтаФорма.ИмяФормы);
			// --- 
			ОбщегоНазначенияКлиентСервер.УстановитьПараметрДинамическогоСписка(Список, "МассивДокументов", МассивДокументов, Истина);
			УстановитьТипыОбъектовОповещения();
			
			ОбщегоНазначенияКлиентСервер.УстановитьСвойствоЭлементаФормы(
				Элементы,
				"Сотрудник",
				"Видимость",
				Ложь);
			
			Если Не ОбщегоНазначения.ЗначениеРеквизитаОбъекта(ДанныеСотрудника.ГоловнаяОрганизация, "ЕстьОбособленныеПодразделения") Тогда
				
				ОбщегоНазначенияКлиентСервер.УстановитьСвойствоЭлементаФормы(
					Элементы,
					"Организация",
					"Видимость",
					Ложь);
				
			КонецЕсли;
			
		КонецЕсли;
		
	Иначе
		
		ОписаниеТипаФизическоеЛицо = Новый ОписаниеТипов("СправочникСсылка.ФизическиеЛица");
		СтруктураПараметраФизическоеЛицо = Новый Структура("ТипПараметра, ИмяПараметра", ОписаниеТипаФизическоеЛицо, "МассивДокументов");
		СтруктураПараметровОтбора = Новый Структура("Сотрудник", СтруктураПараметраФизическоеЛицо);
		ЗарплатаКадры.ПриСозданииНаСервереФормыСДинамическимСписком(ЭтотОбъект, "Список", "СписокНастройкиОтбора",
			СтруктураПараметровОтбора, "СписокКритерииОтбора");
		
	КонецЕсли;
	
	ОбщегоНазначенияКлиентСервер.УстановитьСвойствоЭлементаФормы(Элементы, "ФормаУтвердить", "Видимость", Пользователи.РолиДоступны("ДобавлениеИзменениеДанныхДляНачисленияЗарплатыРасширенная, ДобавлениеИзменениеНачисленнойЗарплатыРасширенная"));
	ЗарплатаКадрыРасширенный.УстановитьУсловноеОформлениеСпискаМногофункциональныхДокументов(ЭтаФорма);
	
	ЗарплатаКадрыРасширенный.СформироватьПодменюСоздатьФормыСпискаДокументов(ЭтаФорма, "ЖурналДокументов.КадровыеДокументы");
	
	// СтандартныеПодсистемы.ПодключаемыеКоманды
	ПараметрыРазмещения = ПодключаемыеКоманды.ПараметрыРазмещения();
	ПараметрыРазмещения.КоманднаяПанель = Элементы.КоманднаяПанельФормы;
	
КонецПроцедуры

&НаСервере
Процедура ОбновитьНаСервере()
	
	Если ЗначениеЗаполнено(СотрудникСсылка) Тогда
		// +++ замена критерии отбора на прямые запросы
		//МассивДокументов = ЗарплатаКадры.ДокументыПоФизическомуЛицу(ОбщегоНазначения.ЗначениеРеквизитаОбъекта(СотрудникСсылка, "ФизическоеЛицо"));
		МассивДокументов = ЗарплатаКадры.ДокументыПоФизическомуЛицу(ОбщегоНазначения.ЗначениеРеквизитаОбъекта(СотрудникСсылка, "ФизическоеЛицо"), ЭтаФорма.ИмяФормы);
		// --- 
		ОбщегоНазначенияКлиентСервер.УстановитьПараметрДинамическогоСписка(Список, "МассивДокументов", МассивДокументов, Истина);
	Иначе
		ЗарплатаКадры.ОбновитьФормыСДинамическимСписком(ЭтотОбъект);
	КонецЕсли;
	
КонецПроцедуры

Журнал документов

Критерий отбора

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
1. PerlAmutor 103 04.01.18 18:56 Сейчас в теме
В ERP тоже есть критерии отборов и к счастью их мало, а в последней версии так еще меньше. На сертификационном экзамене по платформе есть следующие вопросы:

"1.9 Для включения отборов в списках (обычных форм) по содержимому табличных частей объектов и их свойств, не отображаемых в форме. ":
Ответ: "необходимо создать объект критерии отбора"

и точно такой же вопрос
"1.10 Для включения отборов в списках (управляемых форм) по содержимому табличных частей объектов и их свойств, не отображаемых в форме. ":
Ответ: "реализуется произвольным запросом динамического списка"

Из чего можно сделать вывод, что объект "критерий отбора" сам по себе - анахронизм, оставленный для совместимости со старыми конфигурациями под обычное приложение.
2. Nykyanen 281 04.01.18 21:04 Сейчас в теме
(1) да, у меня были мысли, что 1С:ЗУП 3 писали те же, что и 1С:ЗУП 2.5.
3. MrWonder 609 10.01.18 09:06 Сейчас в теме
Алексей! Результат, безусловно, хороший. Это видно на продуктивной среде. Но вопрос поведения остаётся непонятным.
Оставьте свое сообщение

См. также

Еще один тест 1C: Postgres SQL 11 Pro Enterpise против MSSQL 14 под Windows 2012 Server R2 Промо

Производительность и оптимизация (HighLoad) v8 Абонемент ($m)

Проработав 15 лет с MSSQL в 2017 начал активно СУБД Postgres SQL. За два года успел поработать в 9 версии Postgres и в 10-ой. И пришел к выводу, что существуют реальное замедление работы баз после перехода на Postgres. Недавно вышла 11 версия Postgres Pro Enterpise, которая обещает почти 2-х кратное ускорение над 11 Pro Standart и 10-ой версией. Закупив лицензию Postgres 11 Pro Enterpise Это я и решил проверить на 1С.

1 стартмани

05.09.2019    13166    39    Indgo    106    

Расширение объекта Запрос

Практика программирования v8 v8::Запросы 1cv8.cf Абонемент ($m)

Упрощение / ускорение работы с объектом Запрос в программном коде для программистов.

1 стартмани

13.04.2020    1063    0    serferian    2    

Преобразование объекта Отбор компоновки данных в Запрос

Практика программирования Прочие инструменты разработчика v8::УФ v8::Запросы v8::СКД 1cv8.cf Абонемент ($m)

Преобразует объект Отбор компоновки данных в объект Запрос (с заполнением текста и параметров).

1 стартмани

20.12.2019    2743    3    okon-teh    2    

Полезные процедуры и функции для программиста

Практика программирования Универсальные функции v8 1cv8.cf Россия Абонемент ($m)

Все мы пишем программный код и часто используем процедуры, облегчающие его написание. Ниже приведена выборка таких полезных процедур и функций.

1 стартмани

07.10.2019    26622    14    HostHost    40    

Безопасная работа с транзакциями во встроенном языке Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

Разбираемся с опасностями использования транзакций во встроенном языке 1С. Познаем ошибку "В данной транзакции уже происходили ошибки". Учимся защищаться от них.

1 стартмани

25.03.2019    30314    10    tormozit    44    

Кто круче: "ИЛИ" или "ОБЪЕДИНИТЬ ВСЕ" в запросе?

Производительность и оптимизация (HighLoad) v8 v8::СПР v8::Запросы ЗУП2.5 Абонемент ($m)

Реальный пример оптимизации запроса. Статья будет полезна людям, изучающим вопросы оптимизации запросов в 1С и для подготовки к экзамену "1С: Эксперт по технологическим вопросам", поскольку в статье описывается один их методов расследования причин неоптимальных запросов. UPD. Коллеги в комментариях заметили ошибку, она была исправлена и сейчас выложены данные с корректным решением.

1 стартмани

14.09.2019    5098    0    azazana    27    

Процедура ПриКомпоновкеРезультата

Практика программирования v8 1cv8.cf Абонемент ($m)

Коллекция кода

1 стартмани

26.07.2019    31765    13    vasilev2015    63    

1С:Ассемблер. Немного летнего веселья!

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

Все вы, наверное, слышали, что 1С-ники жалуются на свою систему, считая язык 1С недостаточно низкоуровневым, скучным и т.п. Все они с тоской поглядывают в сторону "настоящих" языков программирования. Так вот, господа, они неправы. В системе 1С есть места, где можно размять программерский мозг и получить удовольствие от низкоуровневой техники. Предлагаю вам погрузиться в недра виртуальной машины 1С и понять, как она работает. Там есть свой "ассемблер" и мы попробуем его в действии!

1 стартмани

21.06.2019    26318    76    Evil Beaver    119    

Вам нравятся запросы в 1С? Промо

Практика программирования Разработка v8 v8::Запросы 1cv8.cf Абонемент ($m)

Речь не только о том, что простейший запрос с "легальным" оформлением растянется на пол-экрана, речь еще обо всем, что нужно написать "в нагрузку" к тексту запроса. Все эти "Новый Запрос", "УстановитьПараметр" и последующие пляски с обработкой результата... Пора с этим заканчивать!

1 стартмани

03.07.2019    17276    4    m-rv    86    

Простые примеры сложных отчетов на СКД

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Подписи в отчете. Особенности соединения наборов: как соединить несоединяемое. Остатки на дату и обороты по месяцам в одном отчете. Курс валюты на каждую дату без группировок и соединений в запросе. Отчет с произвольными колонками и с произвольной последовательностью. "Неадекватный отчет".

1 стартмани

12.06.2019    26792    19    Hatson    22    

Многопоточная обработка данных

Производительность и оптимизация (HighLoad) Администрирование данных 1С v8 v8::УФ 1cv8.cf Абонемент ($m)

Конфигурация "Универсальные механизмы: пакеты данных". Набор инструментов для быстрой организации отказоустойчивой многопоточной обработки данных.

1 стартмани

23.11.2018    18298    53    _ASZ_    15    

Работа с публикациями "Инфостарт"

Практика программирования О сообществе WEB v8 УУ Абонемент ($m)

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    18812    12    RocKeR_13    16    

ВСТАВИТЬ В Справочник.Номенклатура (Код, Наименование) ЗНАЧЕНИЯ ("001", "Новый товар") Промо

Практика программирования v8 v8::Запросы 1cv8.cf Абонемент ($m)

Вас не обманывают ваши глаза, это запрос на изменение данных! И это работает без прямого доступа к БД, регистрации и смс.

1 стартмани

01.06.2018    27578    86    m-rv    57    

Применение множественных условий по отсрочке платежа в запросе

Практика программирования Дебиторская и кредиторская задолженность Дебиторская и кредиторская задолженность v8 v8::Запросы УУ Абонемент ($m)

Практический пример решения задачи по вычислению срока отсрочки платежа по набору условий, которые определяются пользователем в настройках. Вычисление выполняется при помощи одного запроса. Ход решения задачи расписан поэтапно.

1 стартмани

03.09.2018    4942    1    zhichkin    0    

Позиционирование в помещении с помощью нейросети по сигналу Wi-Fi. Интерактивная карта склада в 1С с показом позиции

Инструментарий разработчика Практика программирования v8 Абонемент ($m)

Данная публикация содержит в себе редактор и интерактивную карту склада или иного помещения, на которой в реальном времени отображается позиция устройства, координаты которого вычисляются по уровням сигнала нескольких роутеров Wi-Fi. В статье и приложенным к ней разработкам предлагаются инструменты и методика для реализации вычисления точной геопозиции внутри помещений с помощью нейронной сети. Конфигурация написана на релизе 1С:Предприятие 8.3.12.1412, клиентское приложение имеет минимальный уровень совместимости SDK -16.

5 стартмани

09.08.2018    25395    25    informa1555    26    

Работа с данными выбора

Практика программирования Работа с интерфейсом v8 Россия Абонемент ($m)

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений - уже задать без программирования не получится.

1 стартмани

17.07.2018    39267    17    kalyaka    16    

Заполняем по шаблону (по умолчанию) Промо

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Простой в подключении, универсальный и достаточно удобный механизм заполнения реквизитов произвольных документов/справочников значениями по умолчанию. Реализован в расширении, но может быть и непосредственно включен практически в любую конфигурацию на управляемых формах простым копированием одной формы и двух команд. Весь код в статье.

1 стартмани

08.02.2018    25474    19    mvxyz    17    

HTTP Сервисы: Путь к своему сервису. Часть 1

Практика программирования WEB v8 1cv8.cf Абонемент ($m)

Уже много было написано про http-сервисы, но то и дело всплывают «Новые» статьи по обмену между базами V8 по COM, что «Немножко» удивляет. Решил внести свои 5 копеек, поработаем с http-сервисом.

1 стартмани

15.07.2018    73774    23    dsdred    24    

Жизненный цикл управляемой формы. Шпаргалка разработчика

Практика программирования Математика и алгоритмы v8::УФ 1cv8.cf Абонемент ($m)

Прочитав когда-то давно книжку "Разработка управляемых форм", составил для себя такую схемку-напоминалку для обращения в процессе разработки. С тех пор не раз выручала и избавляла от необходимости лезть в гуглы.

1 стартмани

29.06.2018    28991    52    stas_ganiev    26    

Представления в запросах. ЗУП

Практика программирования v8::СПР v8::Запросы ЗУП3.x Россия Абонемент ($m)

О пользе функции ЗаменитьЗапросыКПредставлениямВиртуальныхТаблиц(Запрос.Текст, ). Где есть запрос-пустышка, например, "Представления_КадровыеДанныеСотрудников. Тестировано в Зарплата и управление персоналом КОРП, редакция 3.1 (3.1.4.171) на платформе 8.3.12.1412. В этой конфигурации я насчитал 66 макетов в различных отчетах, где применяется этот механизм, в которых можно получить до 220 различных данных о сотруднике. Если доработать типовой код, то возможно этот список добавить. В моем примере я нахожу данные: Организация, Сотрудник, ФизЛицо, ФИОПолные, ДатаРождения, МестоРождения, ДокументПредставление, АдресПоПропискеПредставление, АдресМестаПроживанияПредставление, ДатаПриема, Должность, ДатаУвольнения,ТрудовойДоговорДата,ТрудовойДоговорНомер, Подразделение.

1 стартмани

28.05.2018    19947    26    IgorXml    15    

Нечеткий поиск одним запросом Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

Использование механизма полнотекстового поиска в 1С не всегда оправдано, т.к. построение индекса и поддержание его в актуальном состоянии может значительно нагружать систему. Предлагаемая реализация нечеткого поиска методом N-грамм выполняется одним запросом, что позволяет производить поиск в любой таблице и не требует предварительного построения индекса.

1 стартмани

28.12.2015    25095    66    vasvl123    9    

БСП: Дополнительная обработка (Регламенты), примеры от простого к сложному

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Очень много попадается странных решений, которые можно решить через БСП:Дополнительные отчеты и обработки. Я бы вообще БСП из-за этой подсистемы переименовал в «Большое Спасибо Программистам». Поработаем с подсистемой в части написания регламентных заданий.

1 стартмани

10.05.2018    41125    33    dsdred    36    

Как выполнить отчет на СКД через COM и получить данные отчета?

Практика программирования v8 УПП1 Россия Абонемент ($m)

Для чего это нужно. Например, нужно в одной базе получить какой-либо показатель из другой базы. Этот показатель вычисляется в каком-либо сложном отчете, который написан на СКД. Можно, конечно, "скопипастить" текст запроса из другой базы, немного подправить его и выполнять в том же COM подключении. Но с этим теряется гибкость: если отчет изменился, то нужно помнить о том, что где-то есть его "немного модифицированная" копия. В статье будет рассмотрен пример получения данных из базы ЗУП.

2 стартмани

08.05.2018    25687    8    wowik    3    

Работа со схемой запроса

Инструментарий разработчика Практика программирования v8 v8::Запросы Абонемент ($m)

Стандартом взаимодействия с реляционной базой данных стал язык SQL. Приемником SQL в 1С является язык запросов. Язык запросов, также как и SQL, является структурированным. Составляющие структуры запроса отвечают на разные вопросы о том, какие данные требуется получить и какие манипуляции с множествами данных необходимо произвести при получении. В простых случаях текст запроса можно написать вручную, однако в сложных случаях, а также при программном формировании, - лучше воспользоваться объектной моделью запроса и использовать объект "Схема запроса". В статье дается описание объектной модели и особенностей работы с ней, а также приводится решение, упрощающее взаимодействие с объектом "Схема запроса".

1 стартмани

24.04.2018    40977    85    kalyaka    34    

1С: Предприятие + корпоративный чат, как наладить оперативные уведомления за 10 минут Промо

Практика программирования v8 Абонемент ($m)

Как сделать автоматические уведомления о разных событиях из 1С в корпоративный чат MyChat для сотрудников компании

1 стартмани

14.08.2016    44693    36    Demanoidos    60    

Бесплатная проверка контрагентов в ФНС (общий модуль с алгоритмом). На примере выводим статус в список справочника контрагентов

Практика программирования v8 1cv8.cf Абонемент ($m)

Если вам интересно проверить контрагенте в ФНС, вам поможет данная публикация. Весь алгоритм работы строится на основе данных, полученных с сервиса http://npchk.nalog.ru совершенно бесплатно.

1 стартмани

01.02.2018    33125    54    rpgshnik    48    

Программное создание динамического списка на управляемой форме. (Динамическое создание динамического списка). Готовая процедура + обработка - демонстрационный пример

Практика программирования Универсальные функции v8::УФ 1cv8.cf Абонемент ($m)

Если у вас возникает необходимость на форму влиять динамически и создавать элементы управляемой формы программно, а особенно хотите вывести программно (динамически) динамический список, вам будет интересна эта процедура. Процедура включает также возможность формирования своей командной панели (а-ля снятие галочки "Автозаполнение" у стандартной командной панели списка).

1 стартмани

19.01.2018    53562    60    rpgshnik    27    

Расширение возможностей печати: Вывод произвольного нижнего и верхнего колонтитула

Печатные формы документов Практика программирования Универсальные функции v8 1cv8.cf Абонемент ($m)

Расширяем функционал вывода нижнего / верхнего колонтитула. Стандартно 1С имеет достаточно ограничений по выводу и наполнению колонтитулов содержимым, взять хотя бы такие, как вывод только текста и отсутствие ограничения на номер конечной страницы. А при разработке кода сталкиваешься с тем, что свой блок с нижним колонтитулом нужно прижимать к низу страницы. Казалось бы быстро решаемый вопрос, но и в нем есть нюансы. Сейчас я расскажу о том, как решалась эта задача. UPD 15.02.2018. Добавлен вывод верхнего колонтитула; Вывод колонтитулов на первой и последней странице управляется параметрами; Научился считать страницы: Добавлено заполнение переменных аналогичных стандартным из колонтитулов; Задаются форматы даты и времени. Ограничения прежние: 1. Повторно сформировать табличный документ после смены параметров страницы интерактивно.; 2. Передавать данные для более плотной печати как можно более мелко нарезанными кусками.

1 стартмани

29.12.2017    36566    27    agent00mouse    0    

Как нарисовать граф на 1С Промо

Практика программирования v8 Абонемент ($m)

Описывается реализация на языке запросов 1С метода расположения вершин графа на плоскости, основанного на использовании электромеханической аналогии. При этом вершины графа представляются одноименными электрическими зарядами, дуги - пружинками. Силы взаимодействия вершин в этой системе переводят их из случайного начального в нужное конечное положение. Приведена обработка рисования графов "ГрафОграф", реализующая данный подход, показывающая также динамику процесса. Граф можно задать списком ребер вручную, выбрать из нескольких предопределенных примеров или сформировать по данным информационной базы.

1 стартмани

09.08.2013    68743    206    ildarovich    117    

Практика доступа в базу 1С через протокол oData. Чтение данных

Сервисные утилиты Практика программирования Администрирование данных 1С v8 1cv8.cf Абонемент ($m)

Для чего нужен доступ в базу 1С через REST-интерфейс по протокол oData? Как его организовать? Как не будучи гуру в JavaScript и .NET получить быстрый визуальный доступ к данным базы 1С? Попробую дать ответ на эти вопросы и прокомментирую некоторые нюансы, с которыми я столкнулся.

1 стартмани

11.12.2017    87403    300    Dementor    48    

Печатная форма, сделанная как расширение конфигурации для БП 3.0. Новые возможности БСП

Практика программирования Универсальные печатные формы v8 БП3.0 Абонемент ($m)

Печатные формы на внешних обработках скоро канут в лету. На смену им приходят ПФ, реализованные в виде расширений конфигурации. Не нашел на сайте примеров таких расширений. Привожу пример подобного расширения для БП 3.0.

1 стартмани

06.12.2017    24820    49    kwazi    6    

Простой бесплатный DashBoard с помощью http сервиса

Практика программирования v8 Абонемент ($m)

Как создать свой DashBoard без дополнительных затрат и сложных технических доработок.

1 стартмани

25.11.2017    51758    63    dewersia    32    

Макеты СКД

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Рассмотрены некоторые типовые задачи, которые решаются с помощью предопределенных макетов, а также перечислены несколько случаев, для которых макеты не подходят

1 стартмани

25.07.2017    90911    122    json    27    

Расширения конфигураций 1С: учимся перехватывать методы

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

В этой статье я на примерах разберу некоторые механизмы расширений конфигураций 1С. А именно «перехваты» методов модуля объекта и «перехваты» событий формы и элементов формы. Данная статья написана с учебными целями, чтобы показать, как при помощи расширений конфигурации можно делать такие доработки, ради которых раньше приходилось снимать конфигурацию с поддержки.

1 стартмани

30.05.2017    116488    13    signum2009    46    

Многопоточность. Универсальный «Менеджер потоков» (фреймворк) с отслеживанием зависимости объектов

Практика программирования Математика и алгоритмы Универсальные функции Производительность и оптимизация (HighLoad) v8 1cv8.cf Россия Абонемент ($m)

Восстановление партий, расчет зарплаты, пакетное формирование документов или отчетов - теперь все это стало доступнее. * Есть желание повысить скорость работы медленных алгоритмов! Но... * Нет времени думать о реализации многопоточности? * о запуске и остановке потоков? * о поддержании потоков в рабочем состоянии? * о передаче данных в потоки и как получить ответ из потока? * об организации последовательности? Тогда ЭТО - то что надо!!!

26.05.2017    47316    15    DarkAn    86    

СКД. Использование встроенного макета, разделителя страниц

Практика программирования v8::СКД 1cv8.cf Абонемент ($m)

Пример работы с макетом СКД для начинающих программистов. За основу взят справочник подразделений, который есть в большинстве конфигураций. Показано, как вывести заголовок, детальные записи, подвал группировки и общий подвал. Приведен пример вставки разделителя страниц. Отчет можно использовать в любой конфигурации 1С: 8.

1 стартмани

31.03.2017    13903    16    Vin_Tik    0    

Запрос для получения остатков по дням даже если не было движений

Практика программирования v8::Запросы 1cv8.cf Абонемент ($m)

Запрос для получения таблицы остатков на каждый день в пределах выбранного периода, даже если движений в этом периоде не было. Вытаскивается одним запросом, без дополнительной обработки результата.

1 стартмани

23.01.2017    12013    1    Homyak    9    

Пример универсальной функции для создания схемы компоновки данных

Практика программирования Универсальные функции v8::СКД 1cv8.cf Россия Абонемент ($m)

Если вам приходится часто создавать схему компоновки данных программно или вы начинающий специалист и пытаетесь разобраться, что же за зверь такой СКД, то эта статья может оказаться вам полезной. Функция создает схему компоновки с минимально необходимой структурой данных. С помощью передачи дополнительных параметров есть возможность добавления ресурсов и оформления.

1 стартмани

12.01.2017    30855    47    dbachinsky    32    

Разбираемся с механизмом Дополнительные отчеты и обработки в БСП

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Чуть более комплексное описание, чем на других ресурсах

1 стартмани

30.10.2016    140568    952    json    66    

Оптимизация запросов 1С:Предприятие – от теории к практике

Практика программирования Математика и алгоритмы v8 Бесплатно (free)

Я давно отметил достаточно серьезный интерес сообщества к вопросам оптимизации и повышения производительности высоконагруженных систем. Общаясь с различными специалистами, обслуживающими малые и большие предприятия (торговые и производственные), я пришел к выводу, что вопросы повышения производительности интересны почти всем, вне зависимости от того, какую конфигурацию они обслуживают – большую или маленькую, измененную или без значительных изменений. В связи с этим я пришел к выводу, что стоит посвятить данный материал вопросам оптимизации запросов, поскольку именно запросы являются основным инструментом извлечения данных из системы.

07.10.2016    37108    0    bpc222    20    

Простой способ индексирования интервалов

Практика программирования v8 Абонемент ($m)

Предлагается простой способ индексирования интервалов для решения задач выборки записей, включающих заданный момент времени, пересекающихся с заданным интервалом или множеством интервалов. Способ основан на добавлении к исходной таблице особого числового индексированного поля, рассчитываемого по специальной формуле. Приведен код функций, необходимых для расчетов поля поиска и параметров поисковых запросов. Приведены также результаты тестирования метода, доказывающие его высокую эффективность.

1 стартмани

28.09.2016    38123    38    ildarovich    22    

Полезные процедуры по работе с СКД и табличными документами (часть 1)

Практика программирования v8::СКД 1cv8.cf Абонемент ($m)

На одном из последних проектов пришлось делать большое количество отчетов на СКД, в которых некоторые требования к оформлению нельзя было реализовать настройками схемы компоновки. В данной публикации приводятся несколько процедур, дополняющие возможности СКД, при решении таких задач

1 стартмани

03.09.2016    52622    96    json    23