Выгрузка проводок ЗУП 3.1 -> КА 1.1

Публикация № 801736

Учет и отчетность - Зарплата

На настройку выгрузки проводок из ЗУП 3.1 в КА 1.1 я потратил 2 рабочих дня. Выгрузка еще не завершена, но большая часть, считаю, реализована. Задача интересна и как частный случай - выгрузка проводок ЗУП 3.1 -> КА 1.1, и как общий случай - настройка обмена между базами. Релизы конфигураций: Зарплата и управление персоналом, редакция 3.1 (3.1.5.129) Комплексная автоматизация, редакция 1.1 (1.1.96.1)

С конца прошлого года холдинг где я работаю начал переход на ЗУП 3.1. 

Вместе с этим появилось много задач в т.ч. выгрузка проводок в КА 1.1.  При этом все нужно сделать в кратчайшие сроки, ведь еще нужно выполнить много других задач.

Типового обмена между вышеуказанными решениями пока нет, а возможно, и никогда не будет.

Варианты обмена

Готовых решений я не нашел и начал решать задачу собственными силами.

Начал со знакомства с типовым обменом с другими конфигурациями. Технология обмена сильно изменилась, по сравнению с ЗиК, и ЗУП 2.5 (насчет ЗУП 2.5 могу ошибаться), привычной настройки проводок, и обработки выгрузки проводок теперь нет. Но все не так страшно, как кажется при беглом осмотре.

Для знакомства с настройкой обмена  пользовался информацией с сайта ИТС.

Информация для формирования бухгалтерских проводок заносится в:

  • справочник организации;
  • справочник подразделения;
  • справочник сотрудники;
  • виды начисления;
  • некоторые виды документов.

При указании данных для формирования бухгалтерских проводок, используется справочник "Способы отражения зарплаты в бухгалтерском учете".

После заполнения способов отражения в БУ, можно сформировать документ "Отражение зарплаты в бухгалтерском учете". Заполнив документ увидим, что практически вся необходимая информация для формирования проводок у нас есть (скриншот с рабочей базы приложить не могу).

Типовой механизм предусматривает выгрузку элементов справочника "Отражение зарплаты в бухгалтерском учете" с последующим его заполнением (счетами и аналитикой) в бухгалтерской базе.

В книгах пишут, что человеку свойственно ходить привычными путями, пускай и не самыми лучшими.  На текущий момент, я считаю, что данный вариант лучше, но когда приступал к реализации выбрал альтернативный вариант, который также предложен на ИТС.

Я решил сделать выгрузку на подобие ЗиК, т.е. настройка формирования проводок настраивается в ЗУП.

В данном варианте нужно будет синхронизировать следующие данные:

  1.  Сотрудников. Данные по сотрудникам заполняются в каждой базе, элементы синхронизируются по реквизиту "ИНН".
  2. Бухгалтерские счета. Синхронизация по коду.
  3. Аналитика проводок:
    1. Перечисления - по имени.
    2. Элементы справочников по уникальному идентификатору.

Для получения уникального идентификатора элементов справочника и имя значений перечислений, была написана небольшая обработка:

Процедура КнопкаВыполнитьНажатие(Кнопка)
	// Вставить содержимое обработчика.
	
	Если Справочники.ТипВсеСсылки().СодержитТип(ТипЗнч(выбСправочник)) Тогда
		текGUID = выбСправочник.УникальныйИдентификатор();
	Иначе
		
		НужноеЗначение = выбСправочник; 
		ИмяПеречисления = НужноеЗначение.Метаданные().Имя;
		НужныйИндекс = Перечисления[ИмяПеречисления].Индекс(НужноеЗначение);
		ИмяЗначения = Метаданные.Перечисления[ИмяПеречисления].ЗначенияПеречисления[НужныйИндекс].Имя;
		
		текGUID = ИмяЗначения;		
	КонецЕсли;
	//Сообщить(СтрДлина(текGUID)); //36
КонецПроцедуры

Для хранения счетов и аналитики добавил дополнительные реквизиты к справочнику  "Способы отражения зарплаты в бухгалтерском учете" Администрирование -> общие настройки -> Дополнительные реквизиты и сведения

Дополнительные реквизиты

Для реквизита "Счет" длина строки 10, "Субконто" - 100, GUID - 36.

Далее настроил форму справочника  "Способы отражения зарплаты в бухгалтерском учете"

Форма элемента справочника

Реквизит "Субконто" используется следующим образом:

  1. При указании элемента справочника, только информативно.
  2. При указании значения перечисления - содержит имя перечисления, уникальный идентификатор при этом не заполняется.

Остальная информация для формирования проводок будет вводится в форме обработки выгрузки проводок.

Форма обработки выгрузки проводок

Сначала я пытался хранить данные из вышеуказанной формы в хранилище настроек, у меня так и не получилось сделать чтобы настройки были общими для всех пользователей. В итоге решил добавить дополнительное свойство  "НастройкиПроводок" для справочника организации, с типом строка неограниченной длины, как выяснилось позже, нельзя создать дополнительной свойство с типом - строка неограниченной длины. Остановился на варианте: дополнительное свойство для каждого взноса - длинной 830. 10  (длина кода счета) + 6 * (36 (Длина уникального идентификатора) + 100)  + символы разделители.

Дополнительный свойства справочника "Организации"

Дополнительные сведения

Теперь есть все необходимые данные для формирования проводок, приступаем к выгрузке.

Функции выгрузки выглядят следующим образом (обработки добавлены к статье, в тексте опишу только интересные, на мой взгляд, моменты)

&НаСервере
Функция ВыгрузитьПроводкиНаСервере()
	// Вставить содержимое обработчика.
	СписокДокументов = ВыгрузитьПроводкиНаСервере_ПолучитьСписокДокументов();
	
	ствСвойстваСпособовОтраженияБУ = ВыгрузитьПроводкиНаСервере_ПолучитьСвойстваОтбораженияБУ(СписокДокументов);
	
	стрВыгрузка = Новый Структура("Организация,НачалоПериода,КонецПериода,Проводки");
	стрВыгрузка.Организация = Организация.Наименование;
	стрВыгрузка.НачалоПериода = НачДата;
	стрВыгрузка.КонецПериода = КонДата;
	
	Проводки = Новый Массив();
	
	ВыгрузитьПроводкиНаСервере_СформироватьПроводкиПоНачислениям(СписокДокументов, ствСвойстваСпособовОтраженияБУ, Проводки);
	ВыгрузитьПроводкиНаСервере_СформироватьПроводкиПоВзносам(СписокДокументов, ствСвойстваСпособовОтраженияБУ, Проводки);
	ВыгрузитьПроводкиНаСервере_СформироватьПроводкиПоНДФЛ(СписокДокументов, ствСвойстваСпособовОтраженияБУ, Проводки);
	
	стрВыгрузка.Проводки = Проводки;
	
	ТекстXML = СтруктураВXML(стрВыгрузка, "ВыгрузкаЗУП_КА");
	
	Возврат ТекстXML;
	
КонецФункции

&НаКлиенте
Процедура ВыгрузитьПроводки(Команда)
	ТекстXML = ВыгрузитьПроводкиНаСервере();
	
	ЗаписьXML = Новый ЗаписьXML();
	ЗаписьXML.ОткрытьФайл(выбФайл, "windows-1251");
	ЗаписьXML.ЗаписатьОбъявлениеXML();
	ЗаписьXML.ЗаписатьБезОбработки(ТекстXML);

   	ЗаписьXML.Закрыть();
	
	ПоказатьПредупреждение(, "Обработка завершена");
	
КонецПроцедуры

В данном случае можно было воспользоваться стандартной сериализацией, собственную функцию я использую, т.к. структура XML получается проще, а соответственно и более читабельной.

Функция СтруктураВXML(вхСтруктура, НаименованиеКорневогоУзла)
	ТекстXML = "";	
	ЗаписьXML = Новый ЗаписьXML();
	ЗаписьXML.УстановитьСтроку("windows-1251");
	ЗаписьXML.ЗаписатьНачалоЭлемента(НаименованиеКорневогоУзла);
	
	Для Каждого Элемент Из вхСтруктура Цикл
		Если ТипЗнч(Элемент.Значение) = Тип("Структура") Тогда
			ЗаписьXML.ЗаписатьБезОбработки(СтруктураВXML(Элемент.Значение, Элемент.Ключ));
		ИначеЕсли ТипЗнч(Элемент.Значение) = Тип("Массив") Тогда
			ЗаписьXML.ЗаписатьНачалоЭлемента(Элемент.Ключ);
			Для Каждого СтрокаТаблицы Из Элемент.Значение Цикл
				ЗаписьXML.ЗаписатьБезОбработки(СтруктураВXML(СтрокаТаблицы, "Строка"));
			КонецЦикла;
			ЗаписьXML.ЗаписатьКонецЭлемента();
		Иначе
			ЗаписьXML.ЗаписатьАтрибут(Элемент.Ключ, XMLСтрока(Элемент.Значение));			
		КонецЕсли;		
	КонецЦикла;
	
	ЗаписьXML.ЗаписатьКонецЭлемента();
	ТекстXML = ЗаписьXML.Закрыть();
	Возврат ТекстXML;
	
КонецФункции

Данную функция я написал, когда делал обмен между базами 1С8 -> 1С77, также рассматривал стандартную реализацию, но решил что проще написать собственную.

Добавить свою обработку в дополнительные в новых конфигурациях уже не так просто. ЗУП отказывается добавлять обработку  в список дополнительных, без нижеуказанной функции в модуле:

Функция СведенияОВнешнейОбработке() Экспорт
    РегистрационныеДанные = Новый Структура;
    РегистрационныеДанные.Вставить("Наименование", "Выгрузка проводок ЗУП 3.1 -> КА 1.1");
    РегистрационныеДанные.Вставить("БезопасныйРежим", Ложь);
    РегистрационныеДанные.Вставить("Вид", "ДополнительнаяОбработка");
    РегистрационныеДанные.Вставить("Версия", "1.0");
    РегистрационныеДанные.Вставить("Информация", "Обработка выгрузки проводок из ЗУП 3.1 в КА 1.1" );
    
    ///////////// команды /////////////////////////
	тзКоманд = Новый ТаблицаЗначений;
	тзКоманд.Колонки.Добавить("Идентификатор",             Новый ОписаниеТипов("Строка"));
	тзКоманд.Колонки.Добавить("Представление",             Новый ОписаниеТипов("Строка"));
	тзКоманд.Колонки.Добавить("Модификатор",             Новый ОписаниеТипов("Строка"));
	тзКоманд.Колонки.Добавить("ПоказыватьОповещение",     Новый ОписаниеТипов("Булево"));
	тзКоманд.Колонки.Добавить("Использование",             Новый ОписаниеТипов("Строка"));
	
	
	Идентификатор_Команды = "ОткрытьФорму";
	строкаКоманды = тзКоманд.Добавить();
	строкаКоманды.Идентификатор         = Идентификатор_Команды; 
	строкаКоманды.Представление         = "Открыть форму выгрузки проводок ЗУП 3.1 -> КА 1.1";
	строкаКоманды.ПоказыватьОповещение     = Истина;
	строкаКоманды.Использование         = "ОткрытиеФормы";
	
	РегистрационныеДанные.Вставить("Команды", тзКоманд);
    
    Возврат РегистрационныеДанные;
КонецФункции

При загрузке проводок, отмечу функцию, которая определяет тип данных по коду счета:

Функция ПолучитьСчетСубконто(СчетКод, Субконто1, Субконто2, Субконто3)
	стрСчетСубконто = Новый Структура("Счет,Субконто1,Субконто2,Субконто3");
	
	текСчет = ПланыСчетов.Хозрасчетный.НайтиПоКоду(СчетКод);
	
	стрСчетСубконто.Счет = текСчет;
	
	Если СчетКод = "70" Тогда
		Запрос = Новый Запрос();
		Запрос.Текст = 
		"ВЫБРАТЬ ПЕРВЫЕ 1
		|	ФизическиеЛица.Ссылка
		|ИЗ
		|	Справочник.ФизическиеЛица КАК ФизическиеЛица
		|ГДЕ
		|	ФизическиеЛица.ИНН = &ИНН";
		
		Запрос.УстановитьПараметр("ИНН", Субконто1);
		Выборка = Запрос.Выполнить().Выбрать();		
		Если Выборка.Следующий() Тогда
			стрСчетСубконто.Субконто1 = Выборка.Ссылка;			
		Иначе
			стрСчетСубконто.Субконто1 = Справочники.ФизическиеЛица.ПустаяСсылка();			
		КонецЕсли;		
	Иначе
		Если текСчет.ВидыСубконто.Количество() > 0 Тогда
			ВидСубконто = текСчет.ВидыСубконто[0];
			Типы = ВидСубконто.ВидСубконто.ТипЗначения.Типы();
			текМетаданные = Метаданные.НайтиПоТипу(Типы[0]);
			
			Если Справочники.ТипВсеСсылки().СодержитТип(Типы[0]) Тогда
				УИД = Новый УникальныйИдентификатор(Субконто1);
				стрСчетСубконто.Субконто1 = Справочники[текМетаданные.Имя].ПолучитьСсылку(УИД);
			Иначе
				стрСчетСубконто.Субконто1 = Перечисления[текМетаданные.Имя][Субконто1];
			КонецЕсли			
		КонецЕсли;
		
		Если текСчет.ВидыСубконто.Количество() > 1 Тогда
			ВидСубконто = текСчет.ВидыСубконто[1];
			Типы = ВидСубконто.ВидСубконто.ТипЗначения.Типы();
			текМетаданные = Метаданные.НайтиПоТипу(Типы[0]);
			
			Если Справочники.ТипВсеСсылки().СодержитТип(Типы[0]) Тогда
				УИД = Новый УникальныйИдентификатор(Субконто2);
				стрСчетСубконто.Субконто2 = Справочники[текМетаданные.Имя].ПолучитьСсылку(УИД);
			Иначе
				стрСчетСубконто.Субконто2 = Перечисления[текМетаданные.Имя][Субконто2];
			КонецЕсли				
		КонецЕсли;
		
		Если текСчет.ВидыСубконто.Количество() > 2 Тогда
			ВидСубконто = текСчет.ВидыСубконто[2];
			Типы = ВидСубконто.ВидСубконто.ТипЗначения.Типы();
			текМетаданные = Метаданные.НайтиПоТипу(Типы[0]);
			
			Если Справочники.ТипВсеСсылки().СодержитТип(Типы[0]) Тогда
				УИД = Новый УникальныйИдентификатор(Субконто3);
				стрСчетСубконто.Субконто3 = Справочники[текМетаданные.Имя].ПолучитьСсылку(УИД);
			Иначе
				стрСчетСубконто.Субконто3 = Перечисления[текМетаданные.Имя][Субконто3];
			КонецЕсли	
		КонецЕсли;
	КонецЕсли;
	
	Возврат стрСчетСубконто;
	
КонецФункции

 

Скачать файлы

Наименование Файл Версия Размер
Обработка выгрузки проводок из ЗУП 3.1 в КА 1.1

.epf 12,34Kb
20.03.18
22
.epf 12,34Kb 22 Скачать
Обработка загрузки проводок в КА 1.1 из ЗУП 3.1

.epf 8,14Kb
20.03.18
19
.epf 8,14Kb 19 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
2. Brawler 469 20.03.18 11:39 Сейчас в теме
Вам стоило посмотреть БП 3.0.
Там на вход поступает документ из ЗУП 3.Х в котором конечно же нет проводок, но в нем говорится какие способы отражения должны быть использованы для формирования проводок.
Имея все суммы и способы отражения (аналитики в них нужно на стороне БП 3.Х заполнять) БП 3.0 генерирует проводки.
Я сам когда сидел думал над реализацией переноса отражения из ЗУП 3.Х в УПП обдумывал именно вариант работы как при обмене с ЗУП 3.Х и БП 3.0. Не супер сложно в правилах переноса данных цепляться за способы отражения описанные в КА/УПП, брать из них счета учета и субконто, а так как все суммы в ЗУП 3.Х в документе отражения ЗП расписаны по полочкам. то не сложно для отражения всяких там налогов прописать конкретные счета учетов...

+ еще есть, юзерам на стороне ЗУП 3.1 вообще не нужно заполнять аналитики в способах отражениях, все аналитики заполнены в КА/УПП и главное при переносе данных совместить способы отражения разных баз.
3. HAMMER_59 206 20.03.18 12:05 Сейчас в теме
(2) Практически в самом начале я так и написал, что если бы делал заново, тогда бы выгружал "способы отражения в БУ", а не проводки.
Лучшее - враг хорошего. Можно очень долго думать как сделать лучше, и ничего так и не сделать. Вариант вполне себе рабочий.
Также у варианта, который я реализовал есть неоспоримый плюс - не нужно вносить изменения в бухгалтерскую базу, в данном случае в КА 1.1. В случае с выгрузкой "способов отражения в БУ", придется эти данные где-то хранить, т.е. нужно будет вносить изменения в конфигурацию.
4. Brawler 469 20.03.18 12:38 Сейчас в теме
(3) Каждая реализация имеет право на свое существование.
Я немного не понял, что вам бы потребовалось менять на стороне КА, так как мои размышления по поводу обмена данными сводились все к тому, что на стороне КА ну в моем случае УПП, нужно данные перенести из документа отражения ЗП в ЗУП 3.Х, в документ отражения ЗП в УПП, при этом в УПП заполнить только первую вкладку документа там, где проводки. Все алгоритмы формирования проводок размещались бы в правилах переноса данных.
Способы отражения ЗП в УПП типовые и должны быть просто заполнены юзером. В ситуации когда к примеру происходит переход зарплатного блока из КА/УПП в отдельную базу ЗУП, то способы отражения как правило в большинстве своем уже есть и настроены.

Собственно аналогичные варианты решения проблемы уже есть https://infostart.ru/public/601831/

Еще раз оговорюсь, я не против вашего решения.
У всех видение ситуации свое и возможно у вас там есть заковырки в учете, которые проще решать так как они решены сейчас.
Оставьте свое сообщение

См. также

Рабочий стол зарплатчика Промо

Зарплата Рабочее место v8 v8::СПР v8::УФ ЗУП3.x Россия БУ Абонемент ($m)

Назначение обработки: - Консолидация основных операций работника кадровой службы, расчетчика заработной платы в одном окне; - Весь цикл кадровых операций: от создания сотрудника, до ввода любого необходимого кадрового документа; - Ввод зарплатных документов: плановых начислений, удержаний; ввода документов расчета, перерасчета, выплаты зарплаты; ввода налоговых документов.

15.01.2020    5048    4    HostHost    0    

Пакетная печать документов. ЗУП 3.1

Зарплата Управление персоналом (HRM) Печатные формы документов v8::СПР ЗУП3.x Россия БУ Абонемент ($m)

1.1 Назначение расширения: - Печать комплекта документов. Вывод нескольких печатных форм документа в одном окне, нажатием одной кнопки. - Для каждого вида документов доступен свой список печатных форм, в том числе и подключаемые внешние печатные формы.

05.02.2020    3330    7    HostHost    5    

Загрузка табелей рабочего времени из файлов Excel

Зарплата Обработка документов Учет рабочего времени Загрузка и выгрузка в Excel v8 v8::СПР ЗУП3.x Россия БУ Абонемент ($m)

Обработка по загрузке в типовой документ «Табель» конфигурации ЗУП 3.1 данных из файлов MS Excel, согласно шаблону.

18.10.2019    7433    5    HostHost    0    

Трудовой договор, Дополнительное соглашение к трудовому договору, Лист ознакомления, Договор о материальной ответственности, Договор о коммерческой тайне, Согласие на обработку персональных данных для ЗУП 3.1

Печатные формы документов Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 v8::СПР ЗУП3.x Россия БУ Абонемент ($m)

Комплект печатных форм для отдела кадров для документов Прием на работу и Кадровый перевод: Трудовой договор, Доп. соглашение к трудовому договору, Лист ознакомления с локальными нормативными актами, Договор о полной материальной ответственности, Договор о неразглашении коммерческой тайны, Согласие на обработку персональных данных.

2 стартмани

12.03.2019    27663    145    Asenka    34    

Расчет Тарификации и зарплаты в средних общеобразовательных школах для ЗКГУ 3.1 (релиз 3.1.14.97) Промо

Бухгалтерия Зарплата Зарплата v8 v8::СПР ЗКГУ3.0 Государственные, бюджетные структуры Россия БУ Госбюджет Абонемент ($m)

Данная настройка конфигурации предназначена для расчета Тарификации педработников и расчета зарплаты в средних общеобразовательных учреждениях. Настройка сделана на базе Типовой конфигурации "Зарплата и кадры государственного учреждения" редакции 3.1.

2 стартмани

05.09.2018    23496    42    ivnik    11    

Обмен без правил. От простого к сложному

Перенос данных из 1C8 в 1C8 v8 1cv8.cf Абонемент ($m)

Пишем обмен с нуля, разбираемя с разными способами сериализации, учимся редактировать XML документы, создаем XDTO и Web service, осваиваем Script variant - English.

1 стартмани

16.01.2019    21180    14    nbeliaev    26    

Справка 2-НДФЛ для ЗУП 2.5 / ЗУП 3.1 (Приложение № 5 к Приказу ФНС России от 02.10.2018 № ММВ-7-11/566@)

Зарплата Справки Зарплата v8 v8::СПР ЗУП2.5 ЗУП3.x БУ НДФЛ Абонемент ($m)

Печатная форма Справки 2-НДФЛ для ЗУП 2.5 / ЗУП 3.1 Форма с 2019 года Приложение № 5 к Приказу ФНС России от 02.10.2018 № ММВ-7-11/566@

1 стартмани

10.01.2019    20178    135    prime9    20    

Универсальная выгрузка/загрузка данных для отличающихся конфигураций (JSON, Такси+ОФ) Промо

Перенос данных из 1C8 в 1C8 Универсальные обработки Распределенная БД (УРИБ, УРБД) v8 1cv8.cf Абонемент ($m)

Простой перенос через JSON данных между двумя базами 1С (документов, справочников, ПВХ, ПВР, счетов). Аналогична произвольной выгрузке в типовой "Выгрузка/загрузка XML", но может использоваться для отличающихся конфигураций. Подходит для любых пар баз с любым интерфейсом (управляемый + обычный). Без настроек. Не требует идентичности конфигураций и платформ. При переносе типы данных сопоставляются по наименованиям метаданных, объекты и ссылки по UID.

1 стартмани

22.10.2014    202342    3081    ekaruk    178    

Пример получения данных из другой базы 1С через Web-сервис

Перенос данных из 1C8 в 1C8 v8 Россия Абонемент ($m)

В данной статье описан пример получения данных справочника из другой базы 1С через Web-сервис.

1 стартмани

11.11.2018    25399    23    flyDrag    29    

Выгрузка проводок из ЗУП 3.1 в КА 1.1, Бух77

Обмен через XML Зарплата Перенос данных из 1С7.7 в 1C8.X Перенос данных из 1C8 в 1C8 Зарплата v8 v77::БУ КА1 1С7:Бух ЗУП3.x БУ Абонемент ($m)

Обработка выгрузки документа "Отражение зарплаты в бухучете". Механизм загрузки в КА 1.1. Механизм загрузки в Бух 77.

1 стартмани

13.09.2018    7144    78    HAMMER_59    7    

Перенос объектов 1С Промо

Перенос данных из 1C8 в 1C8 v8 v8::УФ 1cv8.cf Абонемент ($m)

Простой и наглядный перенос объектов между любыми базами 1С 8 с предварительным анализом на возможные различия в данных (через файл, через интернет, через буфер обмена). Интерактивная настройка правил обмена на стороне источника и получателя. В обработке есть удобный обзор по подсистемам, поиск и обработка данных по заданному фильтру. Сравнение объектов, поиск ссылок. Конструктор кода по созданию объектов, написание скриптов и отладка мини-функций в УФ. Отключение/включение регламентных заданий. Регистрация/снятие с регистрации объектов в планах обмена. И многое другое. Инструменты администратора в одной обработке.

1 стартмани

16.03.2015    86651    1377    moolex    193    

Расширение резервов отпусков

Обработка документов Зарплата Зарплата v8 v8::СПР ERP2 ЗКГУ3.0 ЗУП3.x Россия БУ Абонемент ($m)

Произвольная настройка базы для расчета резервов отпусков.

2 стартмани

10.08.2018    23190    51    СергейКа    16    

Опыт проведения сложных переносов данных на 1С

Перенос данных из 1C8 в 1C8 Интеграция v8 КД Абонемент ($m)

В статье я расскажу про опыт сложных переносов на платформе 1С:Предприятие. Она будет адресована в первую очередь разработчикам 1С, которые уже имеют опыт использования методики «Конвертация данных» (как второй, так и третьей редакции) – я думаю, это большинство из нас. • Я расскажу про различные методики организации переносов данных. • Мы рассмотрим рекомендуемые способы оптимизации правил конвертации, которые позволят вам быстрее выполнять свои переносы. • Также мы разберем, какие могут возникнуть сложности в ходе переноса данных. • Я покажу сравнительный анализ по ряду параметров инструментов «Конвертация данных» второй редакции и третьей, которая вышла уже более года назад.

1 стартмани

30.07.2018    34703    8    primat    14    

Проверка и корректировка данных по выплате зарплаты

Закрытие периода Бухгалтерские Анализ учета Зарплата Зарплата v8 v8::СПР ЗКГУ3.0 ЗУП3.x Россия БУ Госбюджет Абонемент ($m)

Обработка показывает остатки и движения взаиморасчетов с сотрудниками. Также обработка может откорректировать сумму остатков. Конфигурации: "Зарплата и управление персоналом" , релиз не ниже 3.1.2.105 и "Зарплата и кадры государственного учреждения" , релиз не ниже 3.1.2.105.

2 стартмани

08.06.2018    23618    155    APTEM_SLV    14    

Соответствия объектов обмена Промо

Распределенная БД (УРИБ, УРБД) Перенос данных из 1C8 в 1C8 v8 КА1 Россия Абонемент ($m)

Обработка позволяет проверять, исправлять ошибки, добавлять и удалять соответствия объектов в обменах данными между конфигурациями на основе «Комплексной автоматизации 1.1» или похожими конфигурациям. Подходит для обменов с использованием регистра сведений «СоответствиеОбъектовДляОбмена».

2 стартмани

26.08.2016    19903    11    xxxelaaa    0    

Автоматическое заполнение графиков в ЗУП 3.1

Зарплата Учет рабочего времени Обработка справочников Зарплата Учет рабочего времени v8 v8::СПР ЗУП3.x Россия БУ Абонемент ($m)

Данная разработка будет актуальна для организаций с большим количеством графиков (несколько десятков/сотен).

1 стартмани

05.05.2018    20959    18    notserioussam    2    

Настройки отчета "Анализ начислений и удержаний" для ЗУП/ЗГУ 3.1

Бухгалтерские Зарплата Зарплата v8 v8::СПР ЗКГУ3.0 ЗУП3.x НДФЛ ФОМС, ПФ, ФСС Абонемент ($m)

Несколько полезных настроек отчета "Анализ начислений и удержаний" для зарплаты редакции 3.1. В состав входят настройки: Свод в разрезе налогообложения, Сводные данные для статистики, Реестр пособий, Расчетная ведомость по зарплате, Свод в разрезе финансирования, Отклонения от режима работы, Свод по зарплате в разрезе ИФНС, Начисления с детализацией отсутствий, Лицевые счета сотрудников, Распределение отпусков, Сводка затрат

2 стартмани

03.05.2018    35066    229    the1    39    

Правила конвертации документов ЗУП 2.5 - ЗУП 3.1

Обмен через XML Зарплата Перенос данных из 1C8 в 1C8 Зарплата v8 v8::СПР ЗУП2.5 ЗУП3.x Россия БУ Абонемент ($m)

Правила конвертации документов ЗУП 2.5 - ЗУП 3.1. Позволяют вести параллельную работу в базах ЗУП редакций 2,5 и 3.1.

10 стартмани

06.03.2018    36627    151    kostya_whiskas    24    

Анализ НДФЛ и сверка данных учета при подготовке 2-НДФЛ (ЗИК 1.0, ЗУП 2.5, ЗГУ 3.1, ЗУП 3.1) Промо

Анализ учета Налоговые Бухгалтерские Зарплата Зарплата v8 v8::СПР v8::СКД КА1 ЗУП2.5 ЗКБУ УПП1 БУ НДФЛ Абонемент ($m)

Два в одном. Наглядная информация об исчисленном налоге, и налоге, учтенном в справках, о суммах начислений по своду и о доходах, включенных в справки. Все это в разрезе физических лиц, так что станет очевидно, какой сотрудник не включен в справки, у кого недоучтен доход, кому неверно предоставлен вычет, а у кого неверно исчислен, удержан или перечислен налог.

1 стартмани

28.01.2016    32282    153    the1    10    

Трудовой договор, Дополнительное соглашение, Материальная ответственность, Коллективная материальная ответственность, Кадровый перевод, Индексация, Т-53 для ЗУП 3 внешние (7 печатных форм). Создание ведомостей по каждому сотруднику одной кнопкой

Печатные формы документов Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 v8::СПР ЗУП3.x БУ Абонемент ($m)

1. Комплект из 6 печатных форм для документов: Прием на работу, Индексация, Кадровый перевод, Кадровый перевод списком для ЗУП 3.1.11 и более ранних Трудовой договор, дополнительное соглашение, договор личной материальной ответственности, договор коллективной материальной ответственности, индексация, Ведомость Т-53 без лишних строк. Не требуется изменения конфигурации. Подключается через стандартное подключение внешних обработок. 2. Обработка для создания ведемостей из начисления зарплаты. 3. Расширение конфигурации для ЗУП 3.1.11 и КА 2.4.6 для редактирования стажа как в ЗУП 2.5 (Из трудовой деятельности сотрудника. Если ввели строки трудовой деятельности, то стаж считается до даты приема сотрудника).

1 стартмани

26.01.2018    42118    486    p.ugrumov    96    

Проверка данных после неполного ("нового") переноса из ЗУП 2.5 в ЗУП 3.1

Зарплата Бухгалтерский учет Перенос данных из 1C8 в 1C8 Зарплата v8 v8::СПР ЗУП3.x Россия БУ Абонемент ($m)

Описаны данные, которые необходимо проверить после неполного ("нового") переноса из ЗУП 2.5 в ЗУП 3.1. Описано, на что необходимо обратить внимание, где найти перенесенные данные, что НЕ переносится, где найти настройки.

1 стартмани

17.01.2018    28392    142    btydj    3    

Расчет начисления зарплаты со сложной формулой, по данным из внешнего источника. ЗУП 3.1

Обработка документов Загрузка и выгрузка в Excel Зарплата Зарплата v8 v8::СПР ЗКГУ3.0 ЗУП3.x БУ Абонемент ($m)

Расчет начисления зарплаты со сложной формулой, по данным из внешнего источника по данным экономического отдела. ЗУП 3.1.

3 стартмани

20.12.2017    44364    31    mvv1975    7    

Выгрузка данных из УТ 10.3 в БП 3.0 (своими руками) Промо

Перенос данных из 1C8 в 1C8 v8 УТ10 БП3.0 Россия Абонемент ($m)

Старая добрая, позабытая многими выгрузка из УТ 10.3 в БП 1.6. Ее еще можно оживить, и она послужит на благо всем желающим, всем уставшим от автоматических обменов.

3 стартмани

30.10.2014    38014    177    TESL    40    

Справка о заработной плате и других доходах (измененная форма №46)

Справки Зарплата Зарплата v8 v8::СПР ЗКГУ3.0 Россия БУ Абонемент ($m)

Форма разработана для автоматизированного формирования справки по форме № 46. Внешний отчет с возможностью пользовательских настроек.

3 стартмани

24.11.2017    37767    52    agospodarin    15    

Налоги и взносы (кратко) по подразделениям и сотрудникам. ЗУП 3

Бухгалтерские Зарплата Зарплата v8 v8::СПР ЗУП3.x Россия БУ НДФЛ ФОМС, ПФ, ФСС Абонемент ($m)

Отчет "Налоги и взносы (кратко)" в разрезе подразделений и сотрудников.

3 стартмани

13.11.2017    33767    166    tritonof    9    

Синхронизация данных по правилам КД2.0

Перенос данных из 1C8 в 1C8 v8 1cv8.cf Абонемент ($m)

Новый инструмент для сравнения и загрузки данных, сочетающий в себе: гибкость запросов (используются для сопоставления объектов); наглядный вывод отличий; удобный отбор загружаемых данных; возможность пообъектной синхронизации двух баз по правилам КД2 с помощью вызова обработки "Универсальный обмен XML" в базе-источнике через COM-соединение.

1 стартмани

27.08.2017    22456    111    vikad    35    

Правила обмена ЗУП 3.1 - БП 2.0 и ЗУП 3.1 - УПП 1.3 (отражение, ведомости и справочники)

Перенос данных из 1C8 в 1C8 Обмен через XML Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 v8::БУ v8::СПР БП2.0 БП3.0 ЗУП3.x Россия БУ Абонемент ($m)

Правила обмена для выгрузки документов "Отражение зарплаты в бухучете", "Ведомость в банк", "Ведомость в кассу", справочников "Сотрудники" и "Физические лица"

1 стартмани

01.08.2017    75332    1543    forseil    209    

Перенос справочников и документов из УТ 10.3 в БП 3.0

Перенос данных из 1C8 в 1C8 v8 УТ10 БП3.0 Россия БУ НУ УУ Абонемент ($m)

Синхронизация справочников и документов из Управление торговлей 10.3 в Бухгалтерию предприятия 3.0. Обработка не затрагивает штатный механизм. Подключение и перенос документов происходит посредством OLE. Без ввода начальных остатков.

10 стартмани

25.07.2017    20816    14    2casp    5    

П-4 и П-4 (НЗ) за 1 квартал 2020г. (январь-март) для ЗУП 2.5 с ОКВЭД 2 (в новой ред. № 404 от 15.07.2019) (ОКУД 0606010)

Статистические Статистики Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8::СПР ЗУП2.5 Россия БУ Абонемент ($m)

1) П-4 в новой редакции за 1 квартал 2020 г. для ЗУП 2.5 и УПП с отбором по подразделению и КПП, ред. №404 от 15.07.2019 с указанием новых кодов статистики ОКВЭД2 2) П-4 (НЗ) в новой редакции за 1 квартал 2020 г. для ЗУП 2.5 и УПП - с отбором по подразделениям и КПП, в ред. №404 от 15.07.2019.выгрузка в электронном виде в соответствии с XML-шаблоном от 30.12.2019,

1 стартмани

13.02.2017    50817    1000    ilnet    79    

T-11а. Премии работников организации (отображение в %) для ЗУП 3.1

Печатные формы документов Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8::СПР ЗУП3.x Россия БУ Абонемент ($m)

Внешняя печатная форма приказа о поощрении сотрудников (Т-11а отображение в %) для ЗУП 3.1 подключаемая к документу "Премия". Добавляется через Сервис - Дополнительные отчеты и обработки.

1 стартмани

06.02.2017    16247    39    chervic    0    

Поиск и исправление ошибок при заполнении 6-НДФЛ в ЗУП 2.5, Бухгалтерии 2.0, УПП 1.3 версия от 28.08.2018

Регламентированная отчетность Бухгалтерские Анализ учета Зарплата Зарплата v8 v8::БУ v8::СПР БП2.0 ЗУП2.5 УПП1 Россия БУ НДФЛ Абонемент ($m)

Помощь в поиске и исправлении ошибок при заполнении отчёта 6-НДФЛ в ЗУП 2.5, Бухгалтерии 2.0 Просмотр всех записей регистров, имеющих отношение к учёту НДФЛ с детализаций до сотрудника и документа. Ручная корректировка основных регистров. Обновлённая версия от 02.07.2018г

3 стартмани

25.10.2016    35376    212    serge_msk    21    

Выгрузка реестра зарплаты в ГазПромБанк ЗУП 2.5 c ведущими нулями

Обмен с банком Банковские операции Зарплата Банковские операции Зарплата v8 v8::СПР ЗУП2.5 Россия БУ Абонемент ($m)

Корректно выгружает в текстовый формат поля, начинающиеся на НОЛЬ (Например, серии паспортов вида 0803)

5 стартмани

16.05.2016    29484    16    asher72    1    

Краткий регистр налогового учета НДФЛ 2016

Бухгалтерские Налоговые Зарплата Зарплата v8 v8::БУ v8::СПР БП3.0 ЗУП3.x Россия БУ НДФЛ Абонемент ($m)

C 2016 года у ИФНС повысились требования к учету НДФЛ. Предлагаю вам отчет "Краткий регистр налогового учета НДФЛ", компактный, простой и информативный. Самое главное - от обычного "Регистр налогового учета НДФЛ" отличается размерами.

2 стартмани

18.04.2016    29548    26    Craig    6    

Откуда берутся данные 6-НДФЛ в ЗУП 2.5

Бухгалтерский учет Зарплата Зарплата v8 ЗУП2.5 Россия БУ НДФЛ Абонемент ($m)

Как заполняются данные 6-НДФЛ? Файл с картинками и описанием дополнений учета НДФЛ в ЗУП 2_5_99 по сравнению с прежними версиями.

1 стартмани

03.02.2016    173794    156    milov.aleksey    126    

Перечисление НДФЛ в бюджет РФ (13%, 30%)

Обработка документов Зарплата Зарплата v8 v8::СПР ЗУП2.5 БУ НУ НДФЛ Абонемент ($m)

Внешняя обработка (табличных частей), предназначенная для корректного заполнения документа "Перечисление НДФЛ в бюджет РФ". Конфигурация: Зарплата и Управление Персоналом, редакция 2.5

1 стартмани

27.01.2016    32651    235    1kashak    16    

Выгрузка/загрузка данных в формате JSON v 1.0.6

Распределенная БД (УРИБ, УРБД) Перенос данных из 1C8 в 1C8 v8 1cv8.cf Абонемент ($m)

Обработка предназначена для обмена данными между схожими конфигурациями в формате JSON. Этот формат обладает рядом существенных преимуществ по сравнению с xml и прочими популярными форматами. В отличие от существующих аналогов, обработка не использует никаких дополнительных библиотек. (де)Сериализация всех объектов происходит средствами встроенного языка и методов ЗаписатьJSON() и ПрочитатьJSON(). Работает на платформе версии не ниже 8.3.6.

3 стартмани

27.01.2016    42246    325    kser87    41    

Перечисление НДФЛ в бюджет: заполнение НДФЛ по расчетной ведомости для ЗУП 2.5

Обработка документов Зарплата Зарплата v8 ЗУП2.5 Россия БУ НДФЛ Абонемент ($m)

Внешняя обработка для заполнению сумм НДФЛ для перечисления в бюджет по данным расчетной ведомости для 1С ЗУП 2.5

2 стартмани

30.12.2015    20048    71    Snork    4    

Резервы отпусков для УПП 1.3

Обработка документов Зарплата Зарплата v8 УПП1 Россия БУ Абонемент ($m)

Обработка для создания резерва отпусков в 1С: УПП 1.3

1 стартмани

14.12.2015    24240    38    sarun    5    

Интерфейс сопоставления объектов для обмена (для типового регистра СоответствиеОбъектовДляОбмена)

Инструментарий разработчика Универсальные обработки Перенос данных из 1C8 в 1C8 v8 КА1 БП2.0 ЗУП2.5 УТ10 УПП1 Абонемент ($m)

Вы внедряете обмен данными между двумя типовыми или основанными на типовых БД и вам необходим инструмент, чтобы сопоставить между собой справочники этих конфигураций? Вы хотите навести порядок в обмене данными, потому что вам надоело вылавливать дублирующиеся объекты? Вам очень хочется перепоручить сопоставление объектов обменивающихся баз пользователям, но нет подходящего и понятного пользователям интерфейса? Тогда вам нужна именно эта обработка!

4 стартмани

11.11.2015    37225    133    catsam    8    

Удобная выгрузка зарплаты в формат CSV для Сбербанк Бизнес Онлайн (ЗУП 2.5)

Обмен с банком Банковские операции Зарплата Банковские операции Зарплата v8 ЗУП2.5 Россия БУ Абонемент ($m)

Самая удобная внешняя обработка для бухгалтера, не требует лишних действий! Выбрал документ и выгрузил в формате CSV для Сбербанк Бизнес Онлайн

10 стартмани

06.11.2015    37486    28    adinez    7