Приведение взаиморасчетов к одному договору и правильный зачет авансов

17.03.17

Учетные задачи - Взаиморасчеты

Обработка полезна, когда образовалась "фиктивная" задолженность контрагентов на 60 и 62 счетах из-за неверного закрытия долгов в Бухгалтерии 3.0. Это когда на контрагента заводились различные договоры (или документы взаиморасчетов для оплат по банку), но разнести все документы по ним ровно не представилось возможным. и образовались сальдо на счетах авансов и взаиморасчетов (которые должны взаимоперекрываться). Обработка приводит все документы контрагентов к одному договору (своего вида) и поправляет счет авансов для сворачивания задолженности в один разрез по счету.

Скачать исходный код

Наименование Файл Версия Размер
Обработка приведения взаиморасчетов к одному договору и правильному зачету авансов:
.epf 8,70Kb
65
.epf 8,70Kb 65 Скачать

Обработка выбирает все документы по счетам 60.х, затем по 62.х. В найденных документах проверяется реквизит ДоговорКонтрагента и СчетУчетаРасчетовПоАвансам и, если необходимо, меняет эти реквизиты.

Договор берется типовой для контрагента, если типового нет, - то первый попавшийся (и делает его основным). Счет авансов устанавливается типовой из плана счетов. Для Поступления и Списания с расчетного счета так же выбирается способ погашения задолженности - Автоматически.

По итогам выполнения выдается сообщение - какого типа были найдены документы; где не нашелся реквизит договор (как правило, это ручная операция или корректировка долга - обработка их не меняет); измененные обработкой документы; некоторые служебные сообщения.

Обработка протестирована на типовой бухгалтерии 3.0, на приходных, расходных накладных, списаниях и поступлениях расчетного счета.

Обработка приведения взаиморасчетов к одному договору и правильному зачету авансов кредиторская дебиторская баланс сворачивание бухгалтерия 3.0

См. также

Перенос данных из УТ 10.3 в УТ 11 / КА 2 / ERP 2. Переносятся документы, справочники и остатки

Перенос данных 1C Взаиморасчеты Оптовая торговля Логистика, склад и ТМЦ Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Управление торговлей 10 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Управленческий учет Платные (руб)

Можно проверить до покупки, оставьте заявку! Воспользовались более 268 компаний! Перенос в продаже с 2015г., и мы постоянно работаем над его развитием. Перенос данных из УТ 10.3 в УТ 11 | из УТ 10.3 в КА 2 | из УТ 10.3 в ERP. Предлагаем качественное и проверенное временем решение для перехода с УТ 10.3. Можно перенести начальные остатки, нормативно-справочную информацию и все возможные документы. При выгрузке можно установить отбор по периоду, организациям и складам. При выходе новых релизов конфигураций 1C оперативно выпускаем обновление переноса данных.

45650 руб.

24.04.2015    191697    135    239    

270

"Акты сверки +" Групповая подготовка и рассылка актов сверки для Бухгалтерии 3.0.

Взаиморасчеты Email рассылки Акт сверки Бухгалтер Пользователь Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Бухгалтерский учет Платные (руб)

Внешняя обработка для Бухгалтерии 3.0 - позволяет автоматически формировать документы «Акт сверки расчетов» с контрагентами за выбранный период с последующей фоновой отправкой на почту контрагента.

3000 руб.

25.11.2020    22759    186    7    

167

УТ 11, КА 2, ERP 2: Настраиваемые под каждую организацию печать и подпись ответственных лиц в печатных формах (ТОРГ-12, Счёт-фактура, УПД, УКД, Заказ клиента, Акт сверки, М-15 и др.)

Печатные формы Взаиморасчеты Оптовая торговля Производство готовой продукции (работ, услуг) Акт сверки Бухгалтер Пользователь Оперативный учет Управляемые формы 1С:Управление торговлей 11 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Задайте для каждой организации свою печать и для каждого физического лица свою подпись. Выберите в документе печатную форму "... с печатью и подписью" - и автоматически сформируется табличный документ с печатью и подписями той организации и ответственных лиц, которые указаны в документе.

12000 руб.

13.03.2018    57334    187    76    

117

Дебиторская задолженность по срокам долга

Взаиморасчеты Бухгалтер Пользователь Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Управление производственным предприятием 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Бухгалтерский учет Управленческий учет Платные (руб)

Один из лучших вариантов отчета по дебиторской задолженности. Отображает сроки возникновения задолженности, просроченной задолженности с точностью до регистратора, а также многое другое, вне зависимости от схемы взаиморасчетов (online / offline) и объекта расчетов (УТ 11.3, 11.4, 11.5, КА 2.4, 2.5, ERP 2.4, 2.5), состояния флажка "по документам расчета" ( УТ 10, КА 1.1, УПП 1.3) в договоре. Группирует задолженность по интервалам. Имеет большое количество настроек. Не требует доработок конфигурации.

15120 руб.

28.09.2012    95248    591    281    

141

Автоматический зачет авансов в 1С:УНФ по ФИФО

Взаиморасчеты Бухгалтер Пользователь Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Управление нашей фирмой 3.0 Россия Управленческий учет Платные (руб)

Знаем о взаиморасчетах в Управлении нашей фирмой все, что только можно знать. Самая большая проблема взаиморасчетов в УНФ в том, что зависают непонятные долги и предоплаты, в Пульсе бизнеса показываются неадекватные цифры, отчеты по долгам показывают не пойми что. Автоматический зачет авансов в 1С:УНФ поможет решить эту проблему.

12000 руб.

22.07.2021    24040    27    34    

33

Перенос начальных остатков из Парус 7.71 в БГУ

Внешние источники данных Взаиморасчеты Учет ОС и НМА Логистика, склад и ТМЦ Бюджетный учет Программист Бухгалтер Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 2.0 1С:Бухгалтерия государственного учреждения Государственные, бюджетные структуры Россия Бюджетный учет Абонемент ($m)

Перенос словарей и начальных остатков из ПП Парус-Бухгалтерия Бюджет 7.71 в 1Сv8 БГУ2. Заполнение словарей и документов по вводу начальных остатков. Не требуется установка ПП Парус7. Возможна дозагрузка. Позволит автоматически ввести основные данные в программу для начала работы. 

10 стартмани

08.12.2011    81901    4    Skaredov    124    

147

Отчеты по расчетам с контрагентами для 1С:Бухгалтерии

Взаиморасчеты Бизнес-аналитик Бухгалтер Пользователь Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Внешние управленческие отчеты показывают дебиторскую и кредиторскую задолженность при расчетах с контрагентами – подробно и в различных разрезах, в том числе по срокам долга.

3600 руб.

13.01.2023    7111    11    9    

10
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. Fanil 27.03.17 10:25 Сейчас в теме
Будет работать в 1С:Предприятие 8.3 (8.3.5.1486) Бухгалтерия предприятия КОРП, редакция 2.0 (2.0.35.5) ?
2. user712781 10 27.03.17 13:06 Сейчас в теме
Не могу знать,
смотрите
	СчетУчета = ПланыСчетов.Хозрасчетный[ИмяСчета];
	Запрос = Новый Запрос;
	Запрос.Текст = 
	  "ВЫБРАТЬ
	  |	ХозрасчетныйОборотыДтКт.Регистратор,
	  |	ХозрасчетныйОборотыДтКт.Период,
	  |	ТИПЗНАЧЕНИЯ(ХозрасчетныйОборотыДтКт.Регистратор) КАК ВидДок
	  |ИЗ
	  |	РегистрБухгалтерии.Хозрасчетный.ОборотыДтКт(&Нач, &Кон, Регистратор, , , , , ) КАК ХозрасчетныйОборотыДтКт
	  |ГДЕ
	  |	(ХозрасчетныйОборотыДтКт.СчетДт В ИЕРАРХИИ (&Счета)
	  |			ИЛИ ХозрасчетныйОборотыДтКт.СчетКт В ИЕРАРХИИ (&Счета))";
	Если ЗначениеЗаполнено(Контрагент) Тогда
	  Запрос.Текст = Запрос.Текст + "
	  |И (ХозрасчетныйОборотыДтКт.СубконтоКт1 В ИЕРАРХИИ (&Контрагент)
	  |	ИЛИ ХозрасчетныйОборотыДтКт.СубконтоДт1 В ИЕРАРХИИ (&Контрагент))";
	  Запрос.УстановитьПараметр("Контрагент", Контрагент);
	КонецЕсли;
	  Запрос.Текст = Запрос.Текст + "
	  |СГРУППИРОВАТЬ ПО
	  |	ХозрасчетныйОборотыДтКт.Период,
	  |	ХозрасчетныйОборотыДтКт.Регистратор
	  |
	  |УПОРЯДОЧИТЬ ПО
	  |	ХозрасчетныйОборотыДтКт.Период,
	  |	ХозрасчетныйОборотыДтКт.Регистратор
	  |АВТОУПОРЯДОЧИВАНИЕ";
	  	  
	Запрос.УстановитьПараметр("Нач", Нач);
	Запрос.УстановитьПараметр("Кон", ?(ЗначениеЗаполнено(Кон), КонецДня(Кон), Кон));
	
	Счета = Новый Массив;
	Счета.Добавить(СчетУчета);
	Запрос.УстановитьПараметр("Счета", Счета);
//	Запрос.УстановитьПараметр("Организация", Организация);

	РезультатЗапроса = Запрос.Выполнить();

	ВидыДокум = РезультатЗапроса.Выгрузить();
	ВидыДокум.Свернуть("ВидДок");
    Сообщить("=== Список найденных видов документов по счету учета "+СчетУчета+" ===");
	Для Каждого Стр Из ВидыДокум Цикл
        Сообщить(Стр.ВидДок);
	КонецЦикла;
    Сообщить("=====================================================");
 	//Возврат;
Показать


ТекВидДоговора = ?(ИмяСчета = "РасчетыСПоставщикамиИПодрядчиками", Перечисления.ВидыДоговоровКонтрагентов.СПоставщиком,
?(ИмяСчета = "РасчетыСПокупателямиИЗаказчиками", Перечисления.ВидыДоговоровКонтрагентов.СПокупателем,
Перечисления.ВидыДоговоровКонтрагентов.Прочее));
ТекСчетАвансов = ?(ИмяСчета = "РасчетыСПоставщикамиИПодрядчиками", ПланыСчетов.Хозрасчетный.РасчетыПоАвансамВыданным,
?(ИмяСчета = "РасчетыСПокупателямиИЗаказчиками", ПланыСчетов.Хозрасчетный.РасчетыПоАвансамПолученным,
ПланыСчетов.Хозрасчетный.ПрочиеРасчетыСРазнымиДебиторамиИКредиторами));

Выборка = РезультатЗапроса.Выбрать();
	Пока Выборка.Следующий() Цикл
		
		Регистратор = Выборка.Регистратор;
		МетаданныеДокумента = Регистратор.Метаданные();
		Если ОбщегоНазначения.ЕстьРеквизитОбъекта("ДоговорКонтрагента", МетаданныеДокумента) Тогда
			ТекДоговор = Регистратор.ДоговорКонтрагента;
			ОтборОснДоговора = Новый Структура;
			ОтборОснДоговора.Вставить("Организация", ТекДоговор.Организация);
			ОтборОснДоговора.Вставить("Контрагент", ТекДоговор.Владелец);
			ОтборОснДоговора.Вставить("ВидДоговора", ТекВидДоговора);
			ОсновнойДоговор = РегистрыСведений.ОсновныеДоговорыКонтрагента.Получить(ОтборОснДоговора).Договор;
			Документ = Регистратор.ПолучитьОбъект();
			Изменен = Ложь;
// Попытка
			Если НЕ ЗначениеЗаполнено(ОсновнойДоговор) Тогда
				МенеджерЗаписи = РегистрыСведений.ОсновныеДоговорыКонтрагента.СоздатьМенеджерЗаписи();
				МенеджерЗаписи.Организация = ТекДоговор.Организация;
				МенеджерЗаписи.Контрагент = ТекДоговор.Владелец;
				МенеджерЗаписи.ВидДоговора = ТекВидДоговора;
				МенеджерЗаписи.Договор = ТекДоговор;
				МенеджерЗаписи.Записать();
				ОсновнойДоговор = ТекДоговор;
			ИначеЕсли ОсновнойДоговор <> ТекДоговор и ЗначениеЗаполнено(ТекДоговор) Тогда
				Документ.ДоговорКонтрагента = ОсновнойДоговор;
				Изменен = Истина;
			КонецЕсли;
			
			Если ОбщегоНазначения.ЕстьРеквизитОбъекта("СчетУчетаРасчетовПоАвансам", МетаданныеДокумента) Тогда
				Если Регистратор.СчетУчетаРасчетовПоАвансам <> ТекСчетАвансов Тогда
					Документ.СчетУчетаРасчетовПоАвансам = ТекСчетАвансов;
					Изменен = Истина;
				КонецЕсли;
			КонецЕсли;
			
			Если МетаданныеДокумента.Имя = "СписаниеСРасчетногоСчета" Тогда
				Если Документ.ВидОперации = Перечисления.ВидыОперацийСписаниеДенежныхСредств.ОплатаПоставщику Тогда
					Для Каждого ТекущаяСтрока Из Документ.РасшифровкаПлатежа Цикл
						Если Сред(Строка(ТекущаяСтрока.СчетУчетаРасчетовСКонтрагентом),1,2) = Сред(Строка(СчетУчета),1,2) Тогда
							Если ТекущаяСтрока.СпособПогашенияЗадолженности <> Перечисления.СпособыПогашенияЗадолженности.Автоматически Тогда
								Изменен = Истина;
								ТекущаяСтрока.СпособПогашенияЗадолженности = Перечисления.СпособыПогашенияЗадолженности.Автоматически;
							КонецЕсли;	
							Если ТекущаяСтрока.ДоговорКонтрагента <> ОсновнойДоговор Тогда
								ТекущаяСтрока.ДоговорКонтрагента = ОсновнойДоговор;
								Изменен = Истина;
							КОнецЕсли;
							Если ТекущаяСтрока.СчетУчетаРасчетовПоАвансам <> ТекСчетАвансов Тогда
								Изменен = Истина;
								ТекущаяСтрока.СчетУчетаРасчетовПоАвансам = ТекСчетАвансов;
							КонецЕсли;
						Иначе
							Сообщить("! У регистратора: "+Регистратор+" попался левый счет: "+ТекущаяСтрока.СчетУчетаРасчетовСКонтрагентом, СтатусСообщения.Информация);
						КонецЕсли;
					КонецЦикла; 						
				Иначе
					Сообщить("/ По сч. 60.х у регистратора: "+Регистратор+" иной вид операции: "+Документ.ВидОперации, СтатусСообщения.Информация);
				КонецЕсли;
			ИначеЕсли МетаданныеДокумента.Имя = "ПоступлениеНаРасчетныйСчет" Тогда
				Если Документ.ВидОперации = Перечисления.ВидыОперацийПоступлениеДенежныхСредств.ОплатаПокупателя Тогда
					Для Каждого ТекущаяСтрока Из Документ.РасшифровкаПлатежа Цикл
						Если Сред(Строка(ТекущаяСтрока.СчетУчетаРасчетовСКонтрагентом),1,2) = Сред(Строка(СчетУчета),1,2) Тогда
							Если ТекущаяСтрока.СпособПогашенияЗадолженности <> Перечисления.СпособыПогашенияЗадолженности.Автоматически Тогда
								Изменен = Истина;
								ТекущаяСтрока.СпособПогашенияЗадолженности = Перечисления.СпособыПогашенияЗадолженности.Автоматически;
							КонецЕсли;	
							Если ТекущаяСтрока.ДоговорКонтрагента <> ОсновнойДоговор Тогда
								ТекущаяСтрока.ДоговорКонтрагента = ОсновнойДоговор;
								Изменен = Истина;
							КОнецЕсли;
							Если ТекущаяСтрока.СчетУчетаРасчетовПоАвансам <> ТекСчетАвансов Тогда
								Изменен = Истина;
								ТекущаяСтрока.СчетУчетаРасчетовПоАвансам = ТекСчетАвансов;
							КонецЕсли;
						Иначе
							Сообщить("! У регистратора: "+Регистратор+" попался левый счет: "+ТекущаяСтрока.СчетУчетаРасчетовСКонтрагентом, СтатусСообщения.Информация);
						КонецЕсли;
					КонецЦикла; 						
				Иначе
					Сообщить("/ По сч. 62.х у регистратора: "+Регистратор+" иной вид операции: "+Документ.ВидОперации, СтатусСообщения.Информация);
				КонецЕсли;
			КОнецЕсли;
			
			Если Изменен Тогда
				Документ.Записать(РежимЗаписиДокумента.Проведение);
				Сообщить("= Изменен = "+Документ);
			КонецЕсли;
 //Исключение
 //    ТекстОшибки = ""+ ОписаниеОшибки() + " = "+Регистратор;
 //    Сообщить(ТекстОшибки);
 //КонецПопытки
		Иначе
			Сообщить("~ У регистратора проводок "+Регистратор+" нет реквизита ""ДоговорКонтрагента""", СтатусСообщения.Важное);
		КонецЕсли;
 		
	КонецЦикла
Показать
3. Kam260374 22.03.18 18:04 Сейчас в теме
Сегодня скачал.
Пытался установить ее через допотчеты выдала ошибку-

Невозможно подключить дополнительную обработку из файла.
Возможно, она не подходит для этой версии программы.

У меня
Бухгалтерия предприятия, редакция 3.0 (3.0.59.45)
4. user712781 10 21.09.18 07:51 Сейчас в теме
(3) настроек для подключения куда либо не делал, все открывалось через меню открыть файл, по старинке ... и сейчас даже не вспомню, возможно она проверялась только на толстом клиенте, точнее говоря, даже в файловом варианте запускаемом по умолчанию, так что сервиса по-минимуму. насчет совместимости версий, вообще весь код (основной) приведен в комменте, и используется перезаполнение реквизитов проведенных документов, так что если реквизиты документов относящиеся к контрагентам / счетам в конфигурациях новых БП не менялись, то должно работать.
5. RustIG 1642 22.08.20 15:17 Сейчас в теме
Коллеги, что-то подобное реализовал, выложил тут https://infostart.ru/public/1229849/
Оставьте свое сообщение