Перенос документов из УТ 10.3 в Бухгалтерию 3.0

Надоели постоянные проблемы с синхронизацией УТ 10.3 и Бухгалтерии? Предлагаем удобное решение для одностороннего переноса данных из конфигурации "Управление Торговлей" 10.3 в конфигурацию "Бухгалтерия предприятия" 3.0

Арт.: 200386

Распродажа - 20%

Продано: 197

Анимация.gif
Рис.1. Выбор видов документов для переноса
Рис.2. Предварительный отбор документов
Рис.5. Отчет по перенесенным объектам
Рис.4. Отчет по перенесенным объектам
Рис.3. Настройка обмена
Анимация.gif
Рис.1. Выбор видов документов для переноса
Рис.2. Предварительный отбор документов
Рис.5. Отчет по перенесенным объектам
Рис.4. Отчет по перенесенным объектам
Рис.3. Настройка обмена
Лицензии

19200 руб.
15360 руб.

Техподдержка

5000 руб.

3000 руб.

Разработка предназначена для организаций, где требуется простой односторонний перенос данных из УТ в Бухгалтерию несколько раз в отчетный период! 

Особенности обработки:

  • Перенос работает только на ПРОФ версиях 1С:Предприятия 8 и только на ОС Windows;
  • Необходимо запускать в Бухгалтерии предприятия 3.0 на платформе 8.3
  • Подключение к базе-источнику осуществляется через COM-connector и переносить данные можно как из файловой базы, так и из серверной. Данный вид подключения не поддерживается базовыми конфигурациями. 
  • Не гарантируется работа переноса на разных платформах.
  • Не гарантируется работа на отраслевых и региональных конфигурациях.
  • Не гарантируется работа на отозванных релизах конфигураций 1С и платформы, а так же на версиях платформы, для которых зарегистрированы ошибки com-подключения и аварийного завершения работы на сайте bugboard.v8.1c.ru.

Реализован перенос следующих видов документов:

Особенности:

Переносятся только проведенные не помеченные на удаление документы с отметкой "отражать в бухгалтерском учете". Можно переносить только новые документы, можно с заменой уже существующих, также можно проводить документы в момент переноса (если провести не удается, документ записывается). Все справочники создаются по ходу переноса, если не найдены в БП (о синхронизации справочников далее).

Особенности переноса банковских платежных документов:

В виду того, что в Управление торговлей 10.3 для отражения платежей по банковским счетам существует 6 видов документов - Платежное поручение входящее, Платежное поручение исходящее, Платежный ордер на списание ДС, Платежный ордер на поступление ДС, Платежное требование выставленное, Платежное требование полученное - которые в Бухгалтерию переносятся в виде документов Поступление на расчетный счет и Списание с расчетного счета, реализовано преобразование номеров документов с помощью префикса вида документа. Номер документа в БП формируется по следующему правилу: [префикс базы]+[префикс вида документа]+[номер документа]. Префиксы видов документа: 

П - платежное поручение;

О - платежный ордер;

Т - платежное требование.

Если в Бухгалтерии уже есть банковские документы, перенесенные из УТ с теми же номерами, что в УТ, обработка не сможет их сопоставить. В этой ситуации необходимо отключить преобразование номеров для используемого вами вида документа. Для этого вы можете обратиться за доработкой в рамках техподдержки обработки.

Особенности заполнения договора эквайринга:

Для заполнения договора эквайринга в Отчете о розничных продажах и документе Оплата платежной картой в настройках переноса необходимо заполнить реквизит Эквайер.

Для эквайера должен быть создан договор, в котором будет заполнен дополнительный реквизит Договор эквайринга.

Поиск договора эквайринга при переносе происходит по организации, контрагенту и реквизиту ДоговорЭквайринга = Истина.

Документы переносятся с предварительным просмотром (рис.2), т.е. перед загрузкой можно отметить галками только те документы, которые должны быть перенесены. 

Синхронизация справочников:

1. «Организации» - по ИНН;
2. «Склады» - по коду;
3. «Номенклатура» - по коду (с учетом иерархии); по наименованию; сначала по коду, затем по наименованию; по артикулу;
4. «НомераГТД» - по коду;
5. «Страны» - по коду;
6. «КлассификаторЕдиницИзмерения» - по коду;
7. «ДоговорыКонтрагентов» - по значению реквизитов «ВидДоговора», «Организация», «Контрагент»;
8. «Контрагенты» - в зависимости от настройки, по коду или по ИНН+КПП;
9. «БанковскиеСчета» - по значению реквизита «НомерСчета»;
10. «СтатьиДвиженияДенежныхСредств» - по коду. 

Синхронизация документов:

Номер + дата. 

Требования для корректного переноса данных:

- В Бухгалтерии 3.0 обязательно создать организацию с заполненным ИНН + банковский счет, т.к. перенос документов происходит по организации, а организации синхронизируются по ИНН. 

- Заполнить учетную политику организации. 

- Заполнить регистры "СчетаУчетаНоменклатуры" и "СчетаУчетаРасчетовСКонтрагентами", т.к. в документах счета учета заполняются стандартными процедурами из этих регистров сведений. (Начиная с версии 1.4 можно сделать прямо из настроек обработки)

Краткая инструкция по настройке и запуску:

1. Подготовить конфигурацию Бухгалтерия 3.0 (см. "Требования для корректного переноса данных");

2. Открыть обработку через "Файл-Открыть" в конфигурации Бухгалтерия 3.0;

3. В настройках (Рис. 3) указать параметры подключения к УТ 10.3 (Путь к базе или имя сервера, пользователь, пароль);

4. Выбрать организацию и период для переноса документов;

5. Отметить выды документов для переноса;

6. Нажать кнопку "Отобрать документы";

7. В таблице предварительной загрузки отметить документы, которые д.б. перенесены (можно отметить все, можно только те, которые еще не перенесены);

8. Нажать кнопку "Перенести".

Почему стоит попробовать эту версию:

Есть возможность попробовать перенос на демо-версии бесплатно (переносится только 1 вид документов)!

После покупки в течение года получение новых версий обработки - бесплатно!

Бесплатная техподдержка 1 месяц после покупки.

Обработка распространяется с открытым кодом!

 

Изменения в версиях:

 
 Предыдущие версии

Актуальная версия

Версия 1.10.2 от 16.11.2023

1. Исправлены выявленные ошибки

Перенос протестирован на релизе УТ 10.3.85.1 и БП 3.0.143.42

 

Внимание! Добавлена демо-версия переноса.

Ограничения демо-версии: Переносится только документ "Поступление товаров и услуг".

Другие наши разработки:

Перенос данных из УНФ 1.6 в Бухгалтерию 3.0

Перенос документов из УТ 11.4 в Бухгалтерию 3.0

Сверка остатков между базами (Розница 2.3, УТ 11, БП 3.0)

Проверено на следующих конфигурациях и релизах:

  • Бухгалтерия предприятия, редакция 3.0, релизы 3.0.141.39
Статистика:
Просмотры 101993
Загрузки 197
Рейтинг 191
Создание 25.09.13 15:04
Обновление 10.01.24 13:33
№ Публикации 200386
Характеристики:
Теги

Перенос данных из УТ 10.3 в Бухгалтерию 3.0 перенос документов торговли бухгалтерию синхронизация и Бухгалтерии Бух

Рубрики Перенос данных 1C
Кому Системный администратор ,
Программист
Тип файла Внешняя обработка (ert,epf)
Платформа Платформа 1С v8.3
Конфигурация 1С:Управление торговлей 10 ,
1С:Бухгалтерия 3.0
Операционная система Windows
Страна Россия
Отрасль Не имеет значения
Налоги Не имеет значения
Вид учета Не имеет значения
Доступ к файлу Платные (руб)
Код открыт Да
Наименование Файл Версия Размер
Перенос документов из УТ 10.3 в Бухгалтерию 3.0 (ДЕМО)
БП 3.0
.epf 1.5 59,39Kb 976 Скачать
Инструкция по работе переноса документов из УТ 10.3 в Бухгалтерию 3.0 .pdf 1,65Mb 2 Скачать
200. Aven 10.12.21 13:20 Сейчас в теме
(199) Вопрос по счёт-фактуре снимается, сф переносятся.
Но по поводу не проведённых остается и ещё нельзя ли предусмотреть сохранение настроек обработки.
Нам оплатить часы индивидуальной доработки?
(200)
Настройки должны сохраняться по умолчанию, загрузите обработку в дополнительные обработки, укажите настройки и потом они будут сами подтягиваться.
По непроведенным документам сейчас вам ничего не предложу, потому что конец года и разработка прилично загружена задачами.
Код переноса открыт, поэтому если есть свои ресурсы, можете дописать сами.
Версия 1.9.2 от 17.12.2021
1. Добавлен перенос тары в документы Поступление/Реализация товаров и услуг, Возврат от покупателя/поставщику.
2. Исправлены выявленные ошибки.
203. Cool_vsi 28.12.21 11:25 Сейчас в теме
это правила обмена? как постоянный обмен их можно сделать?
(203)
Нет, это не правила обмена. Это внешняя обработка, которая запускается на БП и работает по ком-коннектору. Актуально для файловых/серверных баз в одной локальной сети/на одном сервере. Фреш/ГРМ не поддерживается.
Перед покупкой советуем проверить на демо-версии.
205. user652996_simbavl 25.01.22 13:44 Сейчас в теме
подскажите с 1с Фреш работает можно ли из локальной 10.3 перекинуть документы в облачную БП?
(205)
Здравствуйте, нет, облачные базы не поддерживаются
207. user652996_simbavl 25.01.22 13:54 Сейчас в теме
а перебросить из локальной БП3 в облачную БП чем то можно?
(207)
Вы хотите использовать локальную БП как буфер между УТ и Фрешом?
Я бы посомтрел универсальный обмен xml, обработка встроеная, вроде должна быть доступна во Фреше.
Ну либо типовая синхронизация между УТ и БП в сервисе.
209. user652996_simbavl 26.01.22 13:30 Сейчас в теме
Укажите Вид поиска по номенклатуре по умолчанию на вкладке "Параметры переноса".

такой вкладке НЕТУ где надо указать и что?
(209)
Переименовали в "Параметры подключения" http://prntscr.com/26jjvmh
211. Aven 04.02.22 15:02 Сейчас в теме
Добрый день! При запуске из БП 3.0 (3.0.107.34), платформа 1С:Предприятие 8.3 (8.3.19.1467) выскакивает ошибка. "-2147221005(0х800401А3): Недопустимая строка с указанием класса" как с этим бороться?
(211)
Здравствуйте, зарегистрируйте ком-коннектор https://helpf.pro/faq/view/1825.htm
213. Aven 07.02.22 12:18 Сейчас в теме
214. Aven 11.02.22 18:31 Сейчас в теме
Уважаемая поддержка, ещё вопрос: при переносе с поиском номенклатуры "По Артикулу" новая номенклатура не создаётся! Пишет сообщение:
"Номенклатура по артикулу "P200- GPU-NVTP100-SXM" и наименованию "Видеокарта Tesla P200 SXM2 16GB CoWoS HBM2, NVLink " не найдена!"
Документ поступление создаётся, на месте номенклатуры прочерки!
Что делать в таком случае?
При выборе поиска номенклатуры "По Наименованию" всё работает, но нам такой поиск не подходит.
(214)
Здравствуйте, поправим ошибку и выложим релиз
(214)
Здравствуйте, обновили, проверяйте. Была проблема с созданием номенклатуры при поиске по артикулу.
217. Aven 18.02.22 16:16 Сейчас в теме
(216) Добрый день! Спасибо, заработало!
218. Farpost 18.03.22 06:24 Сейчас в теме
Вопрос - обновления рассылаете по почте или через Инфостарт отслеживать?
(218)
Через Инфостарт при наличии поддержки или в течение года после покупки переноса
Версия 1.9.3 от 23.03.2022
1. Добавлен перенос документа Оплата платежной картой
2. Исправлены выявленные ошибки.
221. serg70 13.04.22 15:45 Сейчас в теме
Здравствуйте! Если я покупал вашу обработку более года назад (у меня: v1.8.9.1) могу ли я при оплате техподдержки получать новые версии в течении года?
(221)
Здравствуйте, да, конечно.
223. smv_a 18.04.22 08:40 Сейчас в теме
Здравствуйте! Поддерживается загрузка документов с прослеживаемыми товарами ?
УТ 10.3.72.3
224. Farpost 01.05.22 09:12 Сейчас в теме
Доброго времени суток!
Столкнулся с таким казусом, который может быть у многих:
длина номера у документов в Торговых базах может отличаться от таковой в Бухгалтерии, например столкнулся с тем, что клиент захотел, что бы номер в СФ соответствовал полностью номеру реализации, а у СФ 1Сники почему то забабахали не 11 символов, а 12 - непонятно такое решение, но да ладно.
Столкнулся при этом с тем, что в бухгалтерию нумерация идёт криво, написал такую конструкцию в вашей обработке:
Функцию. которая убирает один ноль из номера реализации при несовпадении количества символов в ту или иную сторону, то есть равняет по минимальной длине.

Функция ОткорректироватьНомер(ИмяДокумента,НомерИсточника) 
	СимволовИсточника	= СтрДлина(НомерИсточника); 
	Док = Документы[ИмяДокумента].ПустаяСсылка();
	МетаданныеДокумента	= Док.Метаданные();
	СимволовИБ			= МетаданныеДокумента.ДлинаНомера;
	Разность			= СимволовИсточника - СимволовИБ;
	Если Разность <= 0 Тогда
		Возврат НомерИсточника;
	Иначе //Надо уменьшить количество нолей на число Разность
		Префикс = "";
		Для Н = 1 По СимволовИсточника Цикл
			СимволН	= Сред(НомерИсточника,Н,1);
			Если СтроковыеФункцииКлиентСервер.ТолькоЦифрыВСтроке(СимволН) Тогда
				Прервать;
			Иначе
				Префикс = Префикс + СимволН;
			КонецЕсли;
		КонецЦикла;
		НомерЧисло	= Число(СтрЗаменить(НомерИсточника,Префикс,""));
		НомерСтр	= Строка(НомерЧисло);
		НужноНолей	= СимволовИБ - (СтрДлина(Префикс) + СтрДлина(НомерСтр));
		НомерВИБ	= Префикс;
		Для Н = 1 По НужноНолей Цикл
			НомерВИБ	= НомерВИБ + "0";			
		КонецЦикла;
		Возврат НомерВИБ + НомерСтр;
	КонецЕсли;
КонецФункции
Показать


И соответственно вызов этой функции при поиске документов в базе бухгалтерии и при создании новых документов.
Функция "сидит" в модуле объекта обработки.
Возможно кому нибудь пригодится.
Версия 1.9.4 от 17.05.2022
1. Добавлен перенос номенклатуры, имеющий признак прослеживаемости.
2. Добавлен перенос Уведомления о ввозе прослеживаемых товаров при переносе Поступления товаров и услуг, Уведомления о перемещении - при переносе Реализации товаров и услуг, Уведомления об остатках - при переносе Инвентаризации.
3. Исправлены выявленные ошибки.
Перенос протестирован на релизе Управления торговлей 10.3.73.2
226. partnerc 19.05.22 13:53 Сейчас в теме
Добрый день!
Будет ли добавлен перенос счетов покупателям?
(226)
Здравствуйте, в данный момент не планиурем.
228. zerik 21.05.22 05:40 Сейчас в теме
Требует оптимизации, только начал смотреть уже глаза полезли на лоб от процедуры "ВыбратьНаСервере".
229. zerik 23.05.22 04:39 Сейчас в теме
При переносе не сохраняются внутренние идентификаторы ни у одно объекта!
Если вдруг потом с базу надо будет переключить на типовой способ это будут огромные вилы...
230. zerik 23.05.22 06:44 Сейчас в теме
Функция НайтиРасчетныйСчет
Условие есть, разного поведения нет.
Если Владелец<>Неопределено Тогда
РС = Справочники.БанковскиеСчета.НайтиПоРеквизиту("НомерСчета",РС_УТ.НомерСчета, ,Владелец);
Иначе
РС = Справочники.БанковскиеСчета.НайтиПоРеквизиту("НомерСчета",РС_УТ.НомерСчета, ,Владелец);
КонецЕсли;
Версия 1.9.4.1 от 17.06.2022

1. В настройки переноса добавлена опция "Обновлять данные номенклатуры". Если опция активирована, то при переносе происходит обновление реквизитов: Единица измерения, Ставка НДС, Производитель, Код ТНВЭД, Признак маркированного товара и Описание.
2. Добавлено заполнение GUID номенклатуры и контрагента при переносе новой номенклатуры.
3. Исправлены выявленные ошибки.

Перенос протестирован на релизе Управления торговлей 10.3.73.3
232. zerik 27.06.22 07:15 Сейчас в теме
по ГТД норм, почитал увидел..
Версия 1.9.5 от 22.07.2022

1. Добавлен Отчет комиссионера о продажах (+ счет-фактура).
2. Добавлен Отчет комитенту о продажах (+ счет-фактура).
3. Исправлены выявленные ошибки.
Перенос протестирован на релизе Управления торговлей 10.3.73.3
234. 4buz 23.10.22 14:02 Сейчас в теме
Добрый день!
При переносе из УТ 10.3.73.3 в БП 3.0.117.20 возникает ошибка:
Не удалось записать счёт-фактуру!{ВнешняяОбработка.ПереносДокументов_УТ103_БП30.МодульОбъекта(2055)}: Ошибка при вызове метода контекста (Записать): Ошибка при выполнении обработчика - 'ПередЗаписью': {ОбщийМодуль.ЭлектронноеВзаимодействиеБП.Модуль(966)}: Метод объекта не обнаружен (ДляВидаОперацииДокументаДоступенЭДО)
Из-за этого не создаются счета-фактуры созданные в УТ. Подскажите, как решить проблему?
(234)
Здравствуйте, проверим на демо-базах указанных релизов.
Если есть возможность, можете прислать базы, отладим сразу на них.
Версия переноса 1.9.5?
236. 4buz 24.10.22 23:25 Сейчас в теме
(235)
Версия 1.9.5. Как бы это не было банально, но помогло тестирование и исправление базы + установка обновления на БП.
Видимо предыдущее обновление БП встало не совсем корректно.
237. 4buz 13.01.23 09:06 Сейчас в теме
Добрый день!
Возникает непредвиденная ошибка...
Версия платформы 8.3.22.1750
БП 3.0.128.10
УТ 10.3.73.3
Версия обработки 1.9.5
Серверный тип подключения.
Подскажите, куда копать? Спасибо.
Прикрепленные файлы:
(237)
Здравствуйте, текст ошибки можно увидеть, если перейти по ссылке "Сформировать отчет об ошибке". После обновления платформы надо перерегистрировать ком-коннектор на сервере, скорей всего у вас проблема в нем.
239. 4buz 13.01.23 09:30 Сейчас в теме
(238)
Текст ошибки ниже
Ошибка при вызове конструктора (COMобъект)
{ВнешняяОбработка.ПереносДокументов_УТ103_БП30.Форма.Форма.Форма(204)}:db = Новый COMобъект(ОбщегоНазначенияКлиентСервер.ИмяCOMСоединителя());
{ВнешняяОбработка.ПереносДокументов_УТ103_БП30.Форма.Форма.Форма(275)}:УТ = ПодключитьсяКБазе(ИмяСервера, ИмяБазы, ПутьКБазе, Пользователь, Пароль);
{ВнешняяОбработка.ПереносДокументов_УТ103_БП30.Форма.Форма.Форма(262)}:ВыбратьНасервере();

по причине:
-2147467238(0x8000401A): Процесс сервера не может быть запущен, так как указана неправильная идентификация. Проверьте правильность указания имени пользователя и пароля.
Логин-пароль правильные 100%, возможно УЗ должна обладать какими-то доп.привилегиями?
(239)
Перерегистрируйте ком-коннектор
241. 4buz 13.01.23 09:40 Сейчас в теме
(240)
(240)
Перерегистрацию com-коннектора в данном случае нужно делать на сервере 1С?
243. 4buz 15.01.23 14:00 Сейчас в теме
(242)
Спасибо за помощь, всё работает.
244. 4buz 16.01.23 17:11 Сейчас в теме
Добрый день! Подскажите пожалуйста, встают ли изменения выгруженных ранее документов из УТ на обмен при повторной выгрузке?
245. 4buz 18.01.23 13:43 Сейчас в теме
(244)
Дополню вопрос:
- что за пропущенные документы и как с ними работать?
- если изменят документ, который уже выгружен (не важно сумма или дата), то отобразиться ли это при следующей выгрузке, если выгружать такой же период еще раз?
- надо ли ставить документы на регистрацию, если что-то не пришло в выгрузке или такой вариант исключен?
(245)
Здравствуйте,
- если документ не перенесен из-за какой-либо ошибки, он будет пропущен. Такие документы надо проверить в УТ и повторить перенос. Например, при переносе не будет создан Счет-фактура, если не проведен документ-основания.
- если документ уже выгружен и в нем есть критические расхождения, то строка будет подсвечена красным. Но вообще лучше принудительно повторно перенести, если знаете что что-то менялось.
- обработка подключается напрямую к базе и отбирает документы по указанным отборам и периоду, регистрация не используется.
247. 4buz 19.01.23 08:35 Сейчас в теме
(246)
Большое спасибо за комментарии и разъяснения!
248. Aven 19.01.23 17:51 Сейчас в теме
Добрый день,
Пользуемся вашей обработкой уже год, спасибо!
Но, недавно обратили внимание на то, что в перенесённых документах меняется Ответственный.
В БП 3.0 Ответственным в перенесённом документе становится Пользователь который запустил обработку, а не тот кто был автором документа
в УТ 10.3, по моему это не правильно. Поскольку документ один и тот же хоть он и отображается в разных базах.
Можете это поправить?
249. 4buz 20.01.23 14:57 Сейчас в теме
И снова здравствуйте!
Версия обработки 1.9.5, версия платформы 8.3.22.1750, БП 3.0.128.10, УТ 10.3.71.1
При выполнении загрузки уже полученных обработкой данных возникает следующая ошибка:
Ошибка при получении значения атрибута контекста (Дата)
{ВнешняяОбработка.ПереносДокументов_УТ103_БП30.МодульОбъекта(2369)}:Сообщить("Не удалось провести документ  ""ПоступлениеТоваровУслуг от " + Формат(ПоступленияУТ.Дата, "ДЛФ=Д") + """! Документ был записан. Причина: " +ОписаниеОшибки());
{ВнешняяОбработка.ПереносДокументов_УТ103_БП30.Форма.Форма.Форма(1109)}:СтруктураПереноса = Обработка.СоздатьПоступление(ДокУТ, СсылкаБух);
{ВнешняяОбработка.ПереносДокументов_УТ103_БП30.Форма.Форма.Форма(1063)}:ПеренестиНаСервере(ТабличныйДокумент);

по причине:
Неизвестная ошибка


Подскажите, как лечить?
250. 4buz 20.01.23 16:07 Сейчас в теме
(249)
и что самое интересное - теперь сессия, от имени которого запускается обработка - висит как активная...
Прикрепленные файлы:
251. iultin 15.02.23 11:59 Сейчас в теме
Добрый день!
Демо-версия отработала отлично, купленная же версия сразу выдала ошибку:

Поле объекта не обнаружено (ПрослеживаемыйТовар)
{ВнешняяОбработка.ПереносДокументов_УТ103_БП30.МодульОбъекта(1482)}:Если Товар.КодТНВЭД.ПрослеживаемыйТовар = Истина тогда
{ВнешняяОбработка.ПереносДокументов_УТ103_БП30.МодульОбъекта(2268)}:НовСтрока.Номенклатура = СоздатьТовар(Стр.Номенклатура);
{ВнешняяОбработка.ПереносДокументов_УТ103_БП30.Форма.Форма.Форма(1100)}:СтруктураПереноса = Обработка.СоздатьПоступление(ДокУТ, Док.СсылкаБух);
{ВнешняяОбработка.ПереносДокументов_УТ103_БП30.Форма.Форма.Форма(1063)}:ПеренестиНаСервере(ТабличныйДокумент);

УТ10.3.62.1, БП3.0.131.27
252. serg70 08.03.23 10:02 Сейчас в теме
Добрый день!
Если у кого-то возникнет проблема работы обработки на разных версиях платформы и разрядности советую обратиться по следующим ссылкам, мне помогло решить проблему:
https://infostart.ru/1c/articles/1671080/
https://www.hostedredmine.com/issues/922012
Версия 1.9.5.1 от 16.03.2023
1. Адаптирован перенос справочной информации контрагента для более старых релизов УТ
2. Доработан перенос номенклатуры для версий УТ без поддержки прослеживаемых товаров.
3. Исправлены выявленные ошибки.
Перенос протестирован на релизе УТ10.3.77.2 и БП 3.0.131.34
254. dvoinik 19.03.23 14:23 Сейчас в теме
Добрый день. Скачал обработку Демо. УТ 10.3.52.1 и БУ 3.0.133.17 Поступление перенеслось но с ошибками. Справочники товары перенеслись некорректно, группы не верно, НДС не проставился. И при переименовании в торговли товара. Создалась новая позиция в Бухгалтерии. Как происходит синхронизация по коду или наименованию?
(254)
Здравствуйте, в полной версии переноса доступен 1 из 4 вариантов синхронизации номенклатуры на выбор:
- по коду
- по наименованию
- по коду, затем наименованию
- артикулу.
Демо-версия отличается от полной и предназначена для демонстрации основных механизмов работы и проверки работосопособности ком-соединения.
256. gerandy 22.03.23 10:43 Сейчас в теме
Здравствуйте. Версия 1.9.5, при переносе некоторых платёжных поручений входящих в ТЧ не находились договоры. В тех ПП, где договора в ТЧ совпадают с договором в шапке, всё нормально. Пришлось изменить одну строку (стр 3638)
			
			Если ЗначениеЗаполнено(Стр.ДоговорКонтрагента.Код) Тогда
				НовСтрока.ДоговорКонтрагента 	= НайтиДоговор(Стр.ДоговорКонтрагента, НоваяПлатежка.Контрагент, УТ.XMLСтрока(Стр.ДоговорКонтрагента.ВидДоговора));
				//НовСтрока.ДоговорКонтрагента 	= НайтиДоговор(Стр.ДоговорКонтрагента, НоваяПлатежка.Контрагент, УТ.XMLСтрока(ППВ_УТ.ДоговорКонтрагента.ВидДоговора));;	//	так было
			КонецЕсли;
			
257. AndrewKorobko 22.03.23 12:07 Сейчас в теме
Купил обработку. Лень было писать свою!
Обработка отличная, ребята проделали много работы, но сразу не завелась. Не видела документы в УТ!
Пришлось "доработать напильником".

&НаСервере
Функция ПолучитьСписокДокументовНаСервере(ВнешнееПодключение,ВидДокумента,НачПериода,Конпериода)
	
		Запрос = ВнешнееПодключение.NewObject("Запрос");
		
		Запросы = "
		|ВЫБРАТЬ
		|	Документы.Ссылка
		|ИЗ
		|	Документ."+ВидДокумента+" КАК Документы
		|ГДЕ
		|	Документы.Проведен
		|	И НЕ Документы.ПометкаУдаления
		|	И Документы.Дата МЕЖДУ &Дата1 И &Дата2
		|";
		
		Запрос.УстановитьПараметр("Дата1", НачалоДня(НачПериода));
		Запрос.УстановитьПараметр("Дата2", КонецДня(КонПериода));
		
		Запрос.Текст = Запросы;
		Результат = Запрос.Выполнить().Выбрать();
		
		Возврат Результат;

	
КонецФункции


а в ВыбратьНаСервере()

		ПоступленияУТ = ПолучитьСписокДокументовНаСервере(УТ,"ПоступлениеТоваровУслуг",Обработка.НачалоПериода,Обработка.КонецПериода);
			
		//ПоступленияУТ = УТ.Документы.ПоступлениеТоваровУслуг.Выбрать(НачалоДня(Обработка.НачалоПериода), КонецДня(Обработка.КонецПериода));  		
		Пока ПоступленияУТ.Следующий() цикл 			
			
			НайденноеПоступление = Документы.ПоступлениеТоваровУслуг.НайтиПоНомеру(ПоступленияУТ.Ссылка.Номер, ПоступленияУТ.Ссылка.Дата);			
			Если НЕ ПереноситьДокумент(ПоступленияУТ.Ссылка, НайденноеПоступление) Тогда
				Продолжить;
			КонецЕсли; 			
			НовДок = Объект.СписокДокументов.Добавить();
			НовДок.Выбран = Истина;
			НовДок.Вид = "Поступление товаров и услуг";
			НовДок.Номер =ПоступленияУТ.Ссылка.Номер;
			НовДок.Дата = ПоступленияУТ.Ссылка.Дата;
			НовДок.Контрагент = УТ.XMLСтрока(ПоступленияУТ.Ссылка.Контрагент.Наименование);
			НовДок.Сумма = ПоступленияУТ.Ссылка.СуммаДокумента;
			НовДок.Комментарий = УТ.XMLСтрока(ПоступленияУТ.Ссылка.Комментарий);
			НовДок.СсылкаБух = НайденноеПоступление;
			НовДок.СуммаБух = ?(НайденноеПоступление<>Неопределено, НайденноеПоступление.СуммаДокумента,"");
			
		КонецЦикла; 
Показать


и все прекрасно полетело!!! Спасибо!!!
258. dvoinik 12.05.23 09:44 Сейчас в теме
Добрый день. При обмене не переносится адреса контрагентов (юр адрес и фатический). Этой возможности нет или что то не так делаю? При выгрузки потом в ЭДО в бухгалтерии пишет ошибку про адрес. Приходится руками заполнять повторно
(258)
Здравствуйте, у вас УТ 10.3.52.1?
Релиз старый, на нем надо дополнительно проверить.
Но вообще на актуальных релизах УТ и обработки адреса переносятся в БП.
260. dvoinik 17.05.23 09:33 Сейчас в теме
"Управление торговлей", редакция 10.3 (10.3.52.1) Да верно.
Версия 1.9.6 от 30.05.2023
1. Добавлена возможность отбора документов по нескольким организациям.
2. Добавлен отбор документов по контрагенту. Отбор заполняется из справочника в Бухгалтерии.
3. Переработан механизм заполнения договора эквайера при переносе платежных документов в связи с добавлением возможности отбора по нескольким организациям.
В элемент справочника Договор добавлен дополнительный реквизит "Договор эквайринга", тип булево. Реквизит будет создан автоматически при загрузке новой версии обработки в БП. При переносе проверяется организация, контрагент и подбирается действующий договор с ДоговорЭквайринга = Истина.
4. Исправлены выявленные ошибки.
Перенос протестирован на релизе УТ 10.3.79.1 и БП 3.0.136.32.
Версия 1.10.2 от 16.11.2023
1. Исправлены выявленные ошибки
Перенос протестирован на релизе УТ 10.3.85.1 и БП 3.0.143.42

Оставьте свое сообщение

См. также

SALE! 15%

Перенос данных из УПП 1.3 в ERP 2 / УТ 11 / КА 2. Переносятся документы, справочная информация и остатки

Перенос документов, начальных остатков и справочной информации из УПП 1.3 в ERP 2 | из УПП 1.3 в УТ 11 | из УПП в КА 2 | Правила конвертации (КД 2) в продаже с 2015 года, постоянно работаем над их развитием | Более 360 предприятий выполнили...

45650 руб.

Перенос данных из ERP 2 / КА 2 / УТ 11 в БП 3.0. Переносятся документы, начальные остатки и справочники

Перенос данных из ERP в БП 3 | из КА 2 в БП 3 | из УТ 11 в БП 3 | из ЕРП в БП 3 | В продаже с 2019г. | Воспользовались более 176 предприятий! | Сэкономьте время - используйте готовое решение для перехода! | Перенос разработан в формате КД 2...

34650 руб.

Перенос данных из УТ 10.3 в УТ 11.5. Переносятся документы (обороты за период), справочная информация и остатки

Перенос данных из 1С:Управление торговлей 10.3 в 1С:Управление торговлей 11.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УТ 10.3.87.x и УТ 11.5.16...

28000 руб.

[ED2] Обмен УПП 1.3, КА 1.1, УТ 10.3 с EnterpriseData (универсальный формат обмена), обработка

Регулярный обмен, выгрузка, перенос из КА 1.1, УПП 1.3, УТ 10.3 для обмена с любыми конфигурациями, поддерживающими обмен в формате EnterpriseData (КД3) - БП 3.0, ERP, КА 2, УТ 11, Розница 2, УНФ 1.6 и другими. Правила для старых и доработ...

14580 руб.

Перенос данных из БП 3.0 в УТ 11 / КА 2 / ERP 2. Переносятся начальные остатки, документы и справочники

В продаже с 2014г. | Воспользовались более 122 предприятий! | Перенос данных из БП 3.0 в УТ 11 | из БП 3.0 в КА 2 | из БП 3.0 в ERP | Сэкономьте свое время - используйте готовое решение для перехода! | Постоянно работаем над развитием перен...

45650 руб.

Переход и перенос данных из УПП 1.3 в ERP 2.5, КА 2.5. Переносятся документы (обороты за период), справочная информация и ост...

Переход и перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:ERP Управление предприятием 2.5 и 1С:Комплексную автоматизацию 2.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная инфо...

28000 руб.

Перенос данных из ERP 2 / КА 2 в ЗУП 3. Переносятся остатки, документы и справочники

Перенос данных из ERP в ЗУП 3 | из КА 2 в ЗУП | Воспользовались более 79 предприятий! | Готовые правила конвертации данных (КД 2) для переноса остатков, документов с движениями и справочной информации 3 | В продаже с 2020г. | Оперативно обн...

43450 руб.

Перенос данных из УПП 1.3 / КА 1.1 / УТ 10.3 в УНФ 3.0 / УНФ 1.6. Переносятся остатки, документы и справочники

Перенос данных из УПП 1.3 в УНФ | из КА 1.1 в УНФ | из УТ 10.3 в УНФ | В продаже с 2019г. | Воспользовались более 32 предприятий! | Продукт включен в реестр российского ПО | Перенос разработан в формате КД 2 (правила конвертации объектов) |...

38100 руб.

Перенос данных из УПП 1.3 в БП 3.0. Переносятся документы (обороты за период), справочная информация и остатки

Перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:Бухгалтерия предприятия 3.0 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УПП 1...

28000 руб.