Универсальный журнал документов с выводом табличной части (Управляемые формы)

Публикация № 635676

Разработка - Обработки - Универсальные обработки

Универсальный журнал документов с выводом табличной части (Управляемые формы)

Как работать с журналом

1. Нажмите на кнопку Типы документов в журнале. И выберите необходимые вам типы документов

2. Для каждого типа документа можно настроить состав выводимых к нему табличных частей и состав реквизитов этих табличных частей. Для этого в списке типов документов необходимо выделить нужный тип документа и нажать кнопку Настроить отображение табличных частей.

После окончания настройки нажмите кнопку Сохранить.

Состав табличных частей можно не настраивать, тогда будет выведена первая табличная часть документа со всеми реквизитами.

Если для документа выбрано несколько табличных частей, то они будут отображаться в отдельных вкладках.

Функции журнала

1. Функции группового проведения, отмены проведения, пометки удаления и снятия пометки удаления доступны в контекстном меню и меню Еще.

2. Функция копирования документов доступны в контекстном меню и меню Еще.

3. Функция просмотра документов доступны в контекстном меню и меню Еще. А также по двойному клику в списке.

4. На каждый выбранный тип документа в списке доступна команда создания нового документа.

5. Доступны функции быстрого отбора по значению в колонке и снятия отбора, а так же функции снятия  отбора. Так же доступна функция отбора по периоду.

6. Все реквизиты табличных частей кликабельны.

7. Обработка совместима с механизмом внешних отчетов и обработок БСП.

8. Выводить дополнительные реквизиты можно при помощи типовой функции Изменить форму

Технические требования:

Минимальный релиз платформы - 8.2.16

Демонстрация:

Достоинства

Есть возможность выводить табличные части документов

Есть возможность групповой обработки документов

Гарантия возврата денег

ООО "Инфостарт" гарантирует Вам 100% возврат оплаты, если программа не соответствует заявленному функционалу из описания. Деньги можно вернуть в полном объеме, если вы заявите об этом в течение 14-ти дней со дня поступления денег на наш счет.

Программа настолько проверена в работе, что мы с полной уверенностью можем дать такую гарантию. Мы хотим, чтобы все наши покупатели оставались довольны покупкой.

Для возврата оплаты просто свяжитесь с нами.

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. klaus38 06.10.17 21:40 Сейчас в теме
Два вопроса: 1) УТ 11,3,4 будет работать?. 2) Можно запихнуть такой журнал на начальную страницу?
2. Техподдержка 07.10.17 12:10
(1) 1) Будет.
2) Можно встроить обработку в конфигурацию и добавить на начальную страницу.
3. vitek77 27.11.20 20:21 Сейчас в теме
Доброго!
Запустил в УТ 11.4.12.91.
В этой версии есть документ: "РегистраторГрафикаДвиженияТоваров" у этого документа длина номера = 0.
Обработка выдает ошибку и не работает.
Ошибка выявлена в процедуре: Процедура СоздатьОбновитьСписок()
Исправляется, если добавить вот такой код:
Для Каждого СтрокаНастройки Из НастройкиИспользуемыхТипов Цикл
			Если Итерация = 0 Тогда
				ТекстЗапросаДинамическогоСписка = СтрЗаменить(ШаблонДинамическогоСписка,"%ТипОбъекта%",СтрокаНастройки.ИмяТипа);	
			Иначе
				ТекстЗапросаДинамическогоСписка = ТекстЗапросаДинамическогоСписка +
				"
				 |ОБЪЕДИНИТЬ ВСЕ
				 |";
				 ТекстЗапросаДинамическогоСписка = ТекстЗапросаДинамическогоСписка+СтрЗаменить(ШаблонДинамическогоСписка,"%ТипОбъекта%",СтрокаНастройки.ИмяТипа); 
			 КонецЕсли;

//{ИСПРАВЛЕНИЕ ДЛЯ КОРРЕКТНОГО ПОДБОРА ДОКУМЕНТА БЕЗ НОМЕРА

			 Если Метаданные.Документы[СтрокаНастройки.ИмяТипа].ДлинаНомера = 0 Тогда
					ТекстЗапросаДинамическогоСписка = СтрЗаменить(ТекстЗапросаДинамическогоСписка, СтрокаНастройки.ИмяТипа + ".Номер,", """"" КАК Номер,")	 
			 КонецЕсли;
//}

			Итерация = Итерация +1;
		КонецЦикла;
Показать


Что еще не очень удобно, не привычно:
Обычно в журнале документы идут друг за другом в порядке их ввода в систему, а в этом журнале все документы упорядочены по виду, а внутри вида по дате.

Еще один глюк вылез: если стоял на документе, у которого есть табличная часть, а потом перешел на документ без табличных частей, то вываливается ошибка: "Индекс находится за границами массива"
4. vitek77 27.11.20 23:41 Сейчас в теме
(3)
Еще один глюк вылез: если стоял на документе, у которого есть табличная часть, а потом перешел на документ без табличных частей, то вываливается ошибка: "Индекс находится за границами массива"


Это лечится, если в процедуре УстановитьПараметрСписка(ОбъектИсточник)
Взять добавление табличной части в массив в условие:

Процедура УстановитьПараметрСписка(ОбъектИсточник)
	
	НастройкиТЧ = ХранилищеОбщихНастроек.Загрузить("НастройкаОтображенияТабличныхЧастей",,Строка(ПараметрыСеанса.ТекущийПользователь));
	НесколькоТабличныхЧастей = Ложь;
	МассивТабличныхЧастей = Новый Массив;	
	Если НастройкиТЧ  <> Неопределено Тогда	
		Для Каждого Стр Из НастройкиТЧ Цикл	
			Если Стр.ТЧИспользовать И Стр.ОбъектНастройки = ТипТекущегоОбъекта Тогда
				Если МассивТабличныхЧастей.Найти(Стр.ТабличнаяЧасть) = Неопределено Тогда
					МассивТабличныхЧастей.Добавить(Стр.ТабличнаяЧасть);
				КонецЕсли;
			КонецЕсли;		
		КонецЦикла;	
	КонецЕсли;
	
        //{Добавленное условие на проверку наличия табличных частей у документа
	Если ОбъектИсточник.Метаданные().ТабличныеЧасти.Количество() > 0 Тогда
        //
		Если МассивТабличныхЧастей.Количество() = 0 Тогда
			ТабЧасть = ОбъектИсточник.Метаданные().ТабличныеЧасти.Найти("Товары");
			Если ТабЧасть <> Неопределено Тогда
				МассивТабличныхЧастей.Добавить(ТабЧасть.Имя);
			Иначе
				МассивТабличныхЧастей.Добавить(ОбъектИсточник.Метаданные().ТабличныеЧасти[0].Имя);
			КонецЕсли;
		КонецЕсли;
		Для Каждого ИмяТабличнойЧасти Из МассивТабличныхЧастей Цикл 
			ЭтаФорма[ИмяТабличнойЧасти].Параметры.УстановитьЗначениеПараметра("Ссылка", ОбъектИсточник);
		КонецЦикла;

        //{Окончание условия
	КонецЕсли;
	
КонецПроцедуры // ()
Показать
5. Техподдержка 28.11.20 10:01
(4) Спасибо. Поправлю в следующей версии
Оставьте свое сообщение

См. также

Проверка по банку данных исполнительных производств ФССП России из 1С 8 Промо

Универсальные обработки Внешние источники данных WEB v8 1cv8.cf Россия Платные (руб)

Получение общедоступных сведений из банка исполнительных производств Федеральной Службы Судебных Приставов из любой конфигурации 1С 8.3.

5000 руб.

08.11.2018    13242    5    3