Простая организация согласования документов с рассылкой уведомлений участникам процесса

23.04.24

Функциональные - Документооборот и делопроизводство (СЭД)

При разработке или доработке конфигурации, описанное решение позволяет организовать процесс согласования произвольного документа пользователями системы. Для разработчиков конфигурации.

Скачать исходный код

Наименование Файл Версия Размер
Простая организация согласования документов с рассылкой уведомлений участникам процесса.:
.cf 109,61Kb
1
.cf 109,61Kb 1 Скачать

Приветствую читателя!

Разрабатывая собственную конфигурацию, может возникнуть необходимость включить функционал согласования документов участниками бизнес процесса. что собственно говоря и произошло со мной при разработке документа "Заявка на предоставление транспорта".

 

 

Задача следующая: при создании документа список согласующих должен заполнятся на основании последнего документа о назначении ответственных, в этом случае это документ "Назначение согласующих". Нужна возможность назначить согласующих для любого документа. Решение должно быть простым.

В результате в системе создан документ "Назначение согласующих" в указанном документе есть реквизит "ТипДокумента". При создании формы документа, заполняем Список реквизита, всеми типами документов в конфигурации, с помощью процедуры: 

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	// Вставить содержимое обработчика.
		а =Метаданные.Документы.Количество();
//Выборка = Документы.атсЗаявкаНаТС.Выбрать();
Для аи =0 по а-1 цикл
	Метаданные.Документы.Получить(аи).ПолноеИмя();
	Элементы.ТипДокумента.СписокВыбора.Вставить(аи,Метаданные.Документы.Получить(аи).ПолноеИмя(),Метаданные.Документы.Получить(аи).Имя);
КонецЦикла;
КонецПроцедуры

Для списка согласующих предусмотрена табличная часть "Согласующие"

В документе который планируется согласовать в примере это "Заявка на предоставление транспорта" создана табличная часть "Согласование" заполняется процедурой:

&наСервере
Процедура ЗаполнитьСогласование ()

	
	
	
	Если Объект.Согласование.Количество()>0 тогда
		
	Иначе
		ТипДокумента = Объект.Ссылка.Метаданные().ПолноеИмя();
		Период = ТекущаяДата();
		Проведен = истина;
	
			//{{КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
	// Данный фрагмент построен конструктором.
	// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
	
	Запрос = Новый Запрос;
	Запрос.Текст = 
		"ВЫБРАТЬ ПЕРВЫЕ 1
		|	НазначениеСогласующих.Ссылка КАК Ссылка
		|ИЗ
		|	Документ.НазначениеСогласующих КАК НазначениеСогласующих
		|ГДЕ
		|	НазначениеСогласующих.ТипДокумента ПОДОБНО &ТипДокумента
		|	И НазначениеСогласующих.Проведен = &Проведен
		|
		|УПОРЯДОЧИТЬ ПО
		|	НазначениеСогласующих.Дата УБЫВ";
	
	Запрос.УстановитьПараметр("ТипДокумента", ТипДокумента);
	Запрос.УстановитьПараметр("Проведен", Проведен);
	
	РезультатЗапроса = Запрос.Выполнить();
	
	ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
	
	Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
		// Вставить обработку выборки ВыборкаДетальныеЗаписи
		Ссылка = ВыборкаДетальныеЗаписи.Ссылка;
		Документ = Ссылка.ПолучитьОбъект();
		Для Каждого Согласующий из Документ.Согласующие цикл
		стр = Объект.Согласование.Добавить();
		стр.Сотрудник = Согласующий.Сотрудник;
		КонецЦикла;
		
	КонецЦикла;
	
	//}}КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
	

КонецЕсли

Запросом получаем последний проведенный документ "Назначение согласующих".

После создания документа выполняем рассылку email с навигационной ссылкой на объект конфигурации.

Согласующий получает письмо:

 

 

Переходит по ссылке и согласует или не согласует документ.

Пример конфигурации прилагается к данной публикации, включает в себя так же пример рассылки email (Нужно заполнить параметры отправки). 

Тестировалось на версии платформы 8.3.14.

Благодарю за прочтение, надеюсь, материал будет вам полезен.

Конфигурация пример согласования документов отправка email 1C навигационная ссылка бизнес процесс отправка email.

См. также

1С:Документооборот - цена на лицензии КОРП, ПРОФ и ДГУ

Документооборот и делопроизводство (СЭД) Типовые Платформа 1С v8.3 Управленческий учет Платные (руб)

Организуйте правильный оборот документов на вашем предприятии в 1С. Ведение учета и хранения документов. Управление потоками документации между подразделениями. Работа с договорами в компании. Автоматизация процессов подготовки, согласования и подписания документов. Сократите время и объем ошибок с 1С:ДО!

48500 руб.

19.02.2016    107492    106    5    

87

RayCon® Foreign Trade - Документооборот валютного контроля и международных платежей для участников ВЭД

Операции по ВЭД Документооборот и делопроизводство (СЭД) Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Управление холдингом 1С:Комплексная автоматизация 2.х Россия Бухгалтерский учет Платные (руб)

Программа предназначена для автоматизации внешнеторговых компаний и обеспечивает документооборот валютного контроля: присвоение Уникального номера контракта (УНК), формирований сведений о валютных операциях (СВО) и справок о подтверждающих документах (СПД), прочих необходимых форм учета и отчетности по валютным операциям согласно действующему валютному законодательству Российской Федерации, документооборот валютных платежей согласно международным стандартам и документооборот купли-продажи валюты, а также выгрузку любых документов 1С в любую систему клиент-банк.

30000 руб.

13.05.2009    67140    3    29    

42

Таймлист (1С:Совещание, Таймлист Лайт)

Документооборот и делопроизводство (СЭД) Конфигурации 1cv8

«Таймлист» – экосистема сервисов («Таймлист Лайт», «1C:Совещание», «Таймлист Recorder»), основанная на искусственном интеллекте Таймлист, который позволяет эффективно работать с легкими поручениями за счет фиксации всех важных идей при расшифровке и последующем формировании автопротокола встречи. Сервисы, в которые интегрирован ИИ, позволяют работать с задачами (поручениями), полученными из автопротокола.

10000 руб.

06.12.2023    1654    0    0    

8

1С:Архив

Документооборот и делопроизводство (СЭД) Платформа 1С v8.3 Платные (руб)

"1С:Архив" – это универсальная система, обеспечивающая надежное долговременное хранение документов с гарантией юридической значимости на неограниченный срок. "1С:Архив" разработан на основе нормативно-правовых актов по архивному делу, поддерживает операции хранения документов – от попадания в архив до уничтожения – и не имеет ограничений на объем хранимых данных. "1С:Архив" сопровождается методологической поддержкой в виде организационных документов по хранению, входящих в состав "Комплекта нормативных документов" к "Методике управления документами и совместной работой", разработанной специалистами фирмы "1С". Использование "1С:Архива" позволяет организовать единое хранилище всех бумажных и электронных документов из разных информационных систем, вести архивный учет в соответствии с требованиями Росархива и снизить нагрузку на учетные системы. Продукт подходит для малых, средних, крупных предприятий и учреждений любых отраслей.

90000 руб.

24.10.2022    5026    5    1    

5

SALE! 30%

Распознавание и загрузка сканов в 1С "одним нажатием": УПД, ТОРГ-12, накладные, счета, номенклатура, заказы и т.д.

Загрузка и выгрузка в Excel Документооборот и делопроизводство (СЭД) Учет документов Распознавание документов и образов Управляемые формы 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Управление холдингом 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 Бухгалтерский учет Управленческий учет Платные (руб)

Универсальная программа для распознавания ЛЮБЫХ СКАНОВ ИЛИ ФОТО ТОВАРНЫХ ДОКУМЕНТОВ в 1С. Не требует указания параметров и предварительной настройки. Просто выбираете файл (PDF, JPG, DOC, XLS, HTML и т.д.) выбираете документ 1С и нажимаете кнопку "Распознать и загрузить".

6000 5520 руб.

04.06.2019    102688    299    173    

315

Легкий документооборот (+чат-бот для Telegram)

Документооборот и делопроизводство (СЭД) Мессенджеры и боты Учет документов Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия государственного учреждения 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 Платные (руб)

Расширение для согласования справочников и документов в конфигурациях "1С: Бухгалтерия 3.0", "Управление нашей фирмой", "1С ERP Управление предприятием", "Бухгалтерия государственного учреждения". Ролевая адресация, условная маршрутизация, последовательное и параллельное согласование, уведомление о новых задачах на почту, блокировка объектов в зависимости от статуса, запрет проведения в зависимости от статуса, автозапуск процессов согласования, отчеты по исполнительской дисциплине. Не требуется снятие конфигурации с поддержки. Настройка без программирования. Версия для 1cfresh.com. Сертификат 1С-Совместимо.

14900 руб.

15.11.2018    28358    28    48    

61

ЭДО: организация архива оригиналов первичных документов, комплексный отчет по ошибкам

Документооборот и делопроизводство (СЭД) ЭДО и ОФД Учет документов Платформа 1С v8.3 Конфигурации 1cv8 Россия Платные (руб)

Мощный, единый инструмент для решения всех проблем, связанных с переходом на ЭДО. Экономит бумагу и время - организует архив оригиналов первичных документов прямо в базе 1С, в прикрепленных файлах к соответствующим документам. С помощью комплексного отчета по ошибкам в ЭДО позволяет выявить и исправить все возможные ошибки - ошибочно сопоставленные документы, не подписанные документы, подписанные, но не загруженные в 1С документы. Автоматически сопоставляет не сопоставленные между собой документы. Может работать по расписанию и присылать отчет о состоянии архива/по ошибкам на почту. Взаимодействует напрямую с сервисами Диадок/СБИС, имеет интуитивно понятный интерфейс и учитывает 3-х летний опыт 40+ клиентов.

14880 руб.

17.12.2018    44667    60    51    

74

Бесшовная интеграция 1С:Бухгалтерия 3.0 ПРОФ + 1С:Документооборот. Модуль интеграции 1С:БП и 1С:ДО (ПРОФ или КОРП)

Перенос данных 1C Документооборот и делопроизводство (СЭД) Учет документов Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Бухгалтерский учет Платные (руб)

Бесшовная интеграция с 1С:Документооборот (КОРП или ПРОФ) - вот что обеспечит Вам и Вашим сотрудникам оперативный доступ и продуктивную работу с документами в учётной системе 1С на базе "1С:Бухгалтерия предприятия 3.0 ПРОФ". Бесшовный обмен и связь позволяют экономить до 60% времени на поиск и согласование первичной документации (актов, счетов-фактур, накладных), не говоря уже о других полезных функциональных возможностях: создании и запуске бизнес-процессов, работе с электронной почтой, штрихкодировании документов и многом другом.

30000 руб.

23.05.2017    54442    34    67    

41
Оставьте свое сообщение