Единый семинар «1С» для бухгалтеров и руководителей

Расчетный листок с группировкой по сотрудникам для ЗУП 3.1 и БП 3.0

Отчеты - Бухгалтерские

Печатная форма: Расчетный листок, формируемый с группировкой по сотруднику ЗУП 3.1 и БП 3.0

Формирует расчетные листки в БП 3.0 и ЗУП 3.1 по сотруднику в разрезе месяцев. т.е. группировка листков идет по сотрудникам. В оригинальной форме шруппировка идет по месяцам. Очень удобно прикладывать эти расчетные листки к форме Т54а.

Что было сделано:

  • Выделена СКД и Макет для расчетного листка в отдельную обработку
  • Доработана процедура формирования таблицы расчетного документа на основании выборки СКД
  • Открыта возможность доработки этого отчета под себя

Разрабатывалась и проверялась на конфигурации: Зарплата и управление персоналом 3.1  версия 3.1.3.184. и Бухгалтерия предприятия, редакция 3.0 (3.0.52.32) , Платформа 1С:Предприятие 8.3 (8.3.10.2561)

С дополнениями от Петр Лунегов (pvlunegov) от 08.11.2017.

Скачать файлы

Наименование Файл Версия Размер
Формирует расчетный листок с группировкой по сотрудникам (В оригинале по месяцам):
.epf 89,73Kb
08.11.17
31
.epf 1.0.1 89,73Kb 31 Скачать

См. также

Комментарии
1. Григорий Колосовский (igortar) 13.10.17 11:11 Сейчас в теме
Добрый день, в типовой ЗУП 3.1 есть возможность формировать расчетный листок один по физ.лицу, если сотрудник работает по основному и по совместительству. Сейчас формируется два разных листка.
2. Сергей Колебанов (psixo666) 12 18.10.17 00:22 Сейчас в теме
Спасибо за Ваш комментарий.
Такая задача и стояла, если Вам необходимо, то я могу выслать обработку с требуемыми изменениями.
3. Юля Фамилия (Hla) 64 27.10.17 13:32 Сейчас в теме
Сергей, делает ли ваш расчетный листок группировку по видам начисления?
Прикрепленные файлы:
8. Петр Лунегов (pvlunegov) 108 08.11.17 15:22 Сейчас в теме
(3) Делает. Можно настроить в отчете, в Макете СКД_РасчетныЛист.Параметры.ВыводитьПоказателиНачисленийИУдержаний - установить его в истина в Макете.
4. Сергей Колебанов (psixo666) 12 29.10.17 19:39 Сейчас в теме
Эти начисления в расчетный листок выводится одной строкой. Как и в стандартном расчетном листке.
5. Петр Лунегов (pvlunegov) 108 08.11.17 13:15 Сейчас в теме
Добрый день! Скачал ваш отчет.
Ошибки:
1. Если по 1 физическому лицу существует 2-3 действующих сотрудника в разных организациях, то
по каждой организации выдается свой расчетный листок в котором затраиваются зачетверяются записи.

Например, Иван Пупкин работает в организации 1, 2, 3
При построении вашего отчета за октябрь 2017 будет:
3 листа, в каждом листе своя организация (1,2,3)
На каждом листе ровно по 3 ОДИНАКОВЫХ таблицы (расчетных)
с начислениями!
6. Петр Лунегов (pvlunegov) 108 08.11.17 13:56 Сейчас в теме
Нашел и исправил недочет в вашем отчете, который обозначил выше.

Выкладываю исправление:
Модуль объекта, строка № 183

было:

Для Каждого ГоловнойСотрудник из СтрокаКоллекции.ГоловныеСотрудники Цикл
	ДокументРезультатСтраница = Новый ТабличныйДокумент;
	ДокументРезультатПромежуточный = Новый ТабличныйДокумент;
	ВыводимаяКоллекция = Новый Массив;
	ВыводимаяКоллекция.Добавить(ГоловнойСотрудник.СтрокаГоловногоСотрудника);
				
	ВывестиСотрудникаРасчетныйЛисток(ВыводимаяКоллекция, ДокументРезультатПромежуточный, ДокументРезультатСтраница, Макет,
	СоответствиеПользовательскихПолей, ГоловнойСотрудник.ДанныеПоНДФЛИВзносам, Ложь,
	ВыводимыеГруппировки, НастройкиВывода, Ложь);
	Если ДокументРезультатСтраница.ВысотаТаблицы > 0 Тогда
		ДокументРезультат.Вывести(ДокументРезультатСтраница);
	КонецЕсли;
КонецЦикла;
Показать


Стало:

ТекущийСотрудник = Справочники.Сотрудники.ПустаяСсылка();
		
Для Каждого ГоловнойСотрудник из СтрокаКоллекции.ГоловныеСотрудники Цикл
	Если ТекущийСотрудник<>ГоловнойСотрудник.СтрокаГоловногоСотрудника.ГоловнойСотрудник Тогда
		ТекущийСотрудник = ГоловнойСотрудник.СтрокаГоловногоСотрудника.ГоловнойСотрудник;
				
		ДокументРезультатСтраница = Новый ТабличныйДокумент;
		ДокументРезультатПромежуточный = Новый ТабличныйДокумент;
		ВыводимаяКоллекция = Новый Массив;
		ВыводимаяКоллекция.Добавить(ГоловнойСотрудник.СтрокаГоловногоСотрудника);
			
		ВывестиСотрудникаРасчетныйЛисток(ВыводимаяКоллекция, ДокументРезультатПромежуточный, ДокументРезультатСтраница, Макет,
		СоответствиеПользовательскихПолей, ГоловнойСотрудник.ДанныеПоНДФЛИВзносам, Ложь,
		ВыводимыеГруппировки, НастройкиВывода, Ложь);
		Если ДокументРезультатСтраница.ВысотаТаблицы > 0 Тогда
			ДокументРезультат.Вывести(ДокументРезультатСтраница);
		КонецЕсли;
	КонецЕсли;
КонецЦикла;
Показать
7. Петр Лунегов (pvlunegov) 108 08.11.17 15:19 Сейчас в теме
В ваш отчет добавил регистрацию как внешнего отчета в модуль объекта.
Дополнительно исправил вышеобозначенную ошибку
Теперь в 1с ЗУП 3 можно зарегистрировать его в списке внешних отчетов и обработок.
Прикрепленные файлы:
ДП_РасчетныйЛисток_Обработка.epf
Swetlana; ulgr0m; Hla; +3 Ответить
9. Сергей Колебанов (psixo666) 12 08.11.17 16:54 Сейчас в теме
Спасибо за правку. Обработку перезалил с указанием благодарности.
Оставьте свое сообщение