INFOSTART EVENT 2018 EDUCATION

Второй тур голосования за доклады.
Окончание 5 сентября.

Бобрышов Александр | Ведущий программист | ООО "Проф ИТ"

«Как организовать консолидацию данных из трёх десятков предприятий не привлекая программистов на местах?»

Давайте представим, что у нас есть "зоопарк" из разных конфигураций 1С, от разных организаций одного холдинга, занимающихся совершенно непохожей деятельностью (от промышленного производства до туристической деятельности). Бухгалтерские данные должны стекаться из этих предприятий в управляющую компанию, учет в которой ведется в системе, принципиально отличающейся от 1С. Некоторые дочерние организации работают на решениях без штатных программистов и находятся за 1000+ км. Я расскажу, какую архитектуру и технологии выбрать для такого обмена. Как наладить выгрузку данных по одной кнопке без изменения конфигурации предприятия. Как создавать и модифицировать правила обмена для разных предприятий из офиса управляющей компании. Как следить за состоянием обмена из единого центра управления.

Расчетный листок с группировкой по сотрудникам для ЗУП 3.1 и БП 3.0

Отчеты - Бухгалтерские

5
Печатная форма: Расчетный листок, формируемый с группировкой по сотруднику ЗУП 3.1 (Не работает с 3.1.5 и выше!)

Формирует расчетные листки в БП 3.0 и ЗУП 3.1 по сотруднику в разрезе месяцев. т.е. группировка листков идет по сотрудникам. В оригинальной форме шруппировка идет по месяцам. Очень удобно прикладывать эти расчетные листки к форме Т54а.

Что было сделано:

  • Выделена СКД и Макет для расчетного листка в отдельную обработку
  • Доработана процедура формирования таблицы расчетного документа на основании выборки СКД
  • Открыта возможность доработки этого отчета под себя

Разрабатывалась и проверялась на конфигурации: Зарплата и управление персоналом 3.1  версия 3.1.3.184. и Бухгалтерия предприятия, редакция 3.0 (3.0.52.32) , Платформа 1С:Предприятие 8.3 (8.3.10.2561)

+ Исправления: для ЗУП 3.1.4.161

 

ВНИМАНИЕ !!!! Отчет пока не работает с 3.1.5 и выше!!!!

5

Скачать файлы

Наименование Файл Версия Размер
Формирует расчетный листок с группировкой по сотрудникам (В оригинале по месяцам):
.epf 89,92Kb
26.03.18
60
.epf 1.0.1 89,92Kb 60 Скачать

См. также

Комментарии
Сортировка: Древо
1. igortar 13.10.17 11:11 Сейчас в теме
Добрый день, в типовой ЗУП 3.1 есть возможность формировать расчетный листок один по физ.лицу, если сотрудник работает по основному и по совместительству. Сейчас формируется два разных листка.
2. psixo666 12 18.10.17 00:22 Сейчас в теме
Спасибо за Ваш комментарий.
Такая задача и стояла, если Вам необходимо, то я могу выслать обработку с требуемыми изменениями.
3. Hla 64 27.10.17 13:32 Сейчас в теме
Сергей, делает ли ваш расчетный листок группировку по видам начисления?
Прикрепленные файлы:
8. pvlunegov 121 08.11.17 15:22 Сейчас в теме
(3) Делает. Можно настроить в отчете, в Макете СКД_РасчетныЛист.Параметры.ВыводитьПоказателиНачисленийИУдержаний - установить его в истина в Макете.
4. psixo666 12 29.10.17 19:39 Сейчас в теме
Эти начисления в расчетный листок выводится одной строкой. Как и в стандартном расчетном листке.
5. pvlunegov 121 08.11.17 13:15 Сейчас в теме
Добрый день! Скачал ваш отчет.
Ошибки:
1. Если по 1 физическому лицу существует 2-3 действующих сотрудника в разных организациях, то
по каждой организации выдается свой расчетный листок в котором затраиваются зачетверяются записи.

Например, Иван Пупкин работает в организации 1, 2, 3
При построении вашего отчета за октябрь 2017 будет:
3 листа, в каждом листе своя организация (1,2,3)
На каждом листе ровно по 3 ОДИНАКОВЫХ таблицы (расчетных)
с начислениями!
6. pvlunegov 121 08.11.17 13:56 Сейчас в теме
Нашел и исправил недочет в вашем отчете, который обозначил выше.

Выкладываю исправление:
Модуль объекта, строка № 183

было:

Для Каждого ГоловнойСотрудник из СтрокаКоллекции.ГоловныеСотрудники Цикл
	ДокументРезультатСтраница = Новый ТабличныйДокумент;
	ДокументРезультатПромежуточный = Новый ТабличныйДокумент;
	ВыводимаяКоллекция = Новый Массив;
	ВыводимаяКоллекция.Добавить(ГоловнойСотрудник.СтрокаГоловногоСотрудника);
				
	ВывестиСотрудникаРасчетныйЛисток(ВыводимаяКоллекция, ДокументРезультатПромежуточный, ДокументРезультатСтраница, Макет,
	СоответствиеПользовательскихПолей, ГоловнойСотрудник.ДанныеПоНДФЛИВзносам, Ложь,
	ВыводимыеГруппировки, НастройкиВывода, Ложь);
	Если ДокументРезультатСтраница.ВысотаТаблицы > 0 Тогда
		ДокументРезультат.Вывести(ДокументРезультатСтраница);
	КонецЕсли;
КонецЦикла;
Показать


Стало:

ТекущийСотрудник = Справочники.Сотрудники.ПустаяСсылка();
		
Для Каждого ГоловнойСотрудник из СтрокаКоллекции.ГоловныеСотрудники Цикл
	Если ТекущийСотрудник<>ГоловнойСотрудник.СтрокаГоловногоСотрудника.ГоловнойСотрудник Тогда
		ТекущийСотрудник = ГоловнойСотрудник.СтрокаГоловногоСотрудника.ГоловнойСотрудник;
				
		ДокументРезультатСтраница = Новый ТабличныйДокумент;
		ДокументРезультатПромежуточный = Новый ТабличныйДокумент;
		ВыводимаяКоллекция = Новый Массив;
		ВыводимаяКоллекция.Добавить(ГоловнойСотрудник.СтрокаГоловногоСотрудника);
			
		ВывестиСотрудникаРасчетныйЛисток(ВыводимаяКоллекция, ДокументРезультатПромежуточный, ДокументРезультатСтраница, Макет,
		СоответствиеПользовательскихПолей, ГоловнойСотрудник.ДанныеПоНДФЛИВзносам, Ложь,
		ВыводимыеГруппировки, НастройкиВывода, Ложь);
		Если ДокументРезультатСтраница.ВысотаТаблицы > 0 Тогда
			ДокументРезультат.Вывести(ДокументРезультатСтраница);
		КонецЕсли;
	КонецЕсли;
КонецЦикла;
Показать
9. psixo666 12 08.11.17 16:54 Сейчас в теме
Спасибо за правку. Обработку перезалил с указанием благодарности.
10. gc1c 27.12.17 16:10 Сейчас в теме
Спасибо большое, очень помог, но подскажите пожалуйста, встала задача, убрать разбивку по организациям, т.е. делаем отбор по физику, он сейчас выводит:
Расчетный листок
Организация1
Иванов И.
Начислено = 5 000
--------------------------------
Расчетный листок
Организация2
Иванов И.
Начислено = 7 000

А хочется:
Расчетный листок
Организация
Иванов И.
Начислено = 12 000

Т.е. все схлопнуть в один расчетный листок по сотруднику. Я понимаю, что возможно нужно где-то в одном месте строчку закомментировать и будет желаемый результат, но никак не могу понять где, все не то получается. Подскажите пожалуйста, очень нужно, или если возможно выложите подобный вариант, я скачаю. Можно тогда сделать опционально, галочкой, либо с разбивкой по организации, либо схлопнуть все организации по сотруднику. Очень пожалуйста.
11. user624560_kasatkin_va 24.01.18 13:08 Сейчас в теме
После обновления конфигурации Зарплата и управление персоналом 3.1 до версии 3.1.4.161 выходит ошибка по поводу отсутствия параметра "ИсключаемыеСсылки". После добавления параметра в СКД отчет выходит, но сумма к выплате неправильная. Поправьте, пожалуйста, очень нужно. Заранее спасибо.
12. Oks_a 05.02.18 10:01 Сейчас в теме
А можно "К выплате" указать сумму Долг предприятия на конец месяца, как зуп 2.5?
13. user920037 20.02.18 12:32 Сейчас в теме
добрый день. подскажите пожалуйста как мне настроить виды начислений в Расчетном листке по сотрудникам: встают сначала доплаты за совмещение, премия а потом уже оплата по окладу. А мне нужно как положено Оплата по окладу, доплаты, премия и РК. Заранее благодарю.
14. user614822_yanchenko.a 13 23.03.18 11:24 Сейчас в теме
Для 3.1.5.129 уже не работает
15. user614822_yanchenko.a 13 23.03.18 11:44 Сейчас в теме
И для ЗУП 3.1.4.169 тоже не работает. ВООБЩЕ

ПУСТЫШКА
Оставьте свое сообщение