Инструменты: v81_82_83: об./упр. формы. Отключение пользователей: файловый, кл-сервер. Запуск/Вход под другим польз-м. Поиск ссылок на объект СКД. Консоль запр. Отладка ВПФ и ОЗТЧ. Гр.печать, Перепровед-е немоноп-е и др.(Один архив)

Публикация № 546466

Администрирование - Администрирование данных 1С - Поиск данных

Набор внешних обработок необходимый перед обновлением базы и проверки внесенных изменений после, которые сделал и пользуюсь уже несколько лет и периодически одной из них, да и не окажется под рукой.

1.Отключение пользователей:

 Файловый режим (обычные/управляемые формы):

- внешняя обработка блокирующая и завершающая сеансы пользователей, без доработки конфигурации (8.2/8.3).

2. Вход под пользователем  (обычные/управляемые формы)

3.Поиск ссылок на объект СКД  (обычные/управляемые формы)

4. Также добовалено 10 инструментов для обычных и управляемых форм.

5. Добавил инструкцию по блокировке сеансов пользователей обычные и упр.формы.

6. Шаблоны отчетов СКД (с отборами и кнопками) обычные и управляемы формы

P.s. пишите пожелания, возможна доработка одной из ваших форм или запуск обработки на вашей конфигурации (после создания БэкАпа)

 

Скачать файлы

Наименование Файл Версия Размер
Отключение пользователей - обычные формы - файловая 8.2

.epf 16,83Kb
15.10.16
10
.epf 1.0 16,83Kb 10 Скачать
ЗапускПодПользователем - обычные формы

.epf 9,30Kb
02.09.16
2
.epf 1.0 9,30Kb 2 Скачать
ЗапускПодПользователем - Управляемые формы

.epf 17,16Kb
02.09.16
3
.epf 1.0 17,16Kb 3 Скачать
Отключение пользователей ( Обычные формы - Клиент_Сервер )

.epf 22,95Kb
02.09.16
6
.epf 1.0 22,95Kb 6 Скачать
Отключение пользователей ( Управляемые - Клиент_Сервер )

.epf 23,00Kb
02.09.16
9
.epf 1.0 23,00Kb 9 Скачать
ОтключениеПользователей (Управляемые - файловая)

.epf 21,82Kb
02.09.16
13
.epf 1.0 21,82Kb 13 Скачать
ПоискСсылокНаОбъектСКД - Обычные формы

.erf 11,07Kb
06.09.16
2
.erf 2.0 11,07Kb 2 Скачать
ПоискСсылокНаОбъектСКД - Управляемые формы

.erf 15,44Kb
02.09.16
8
.erf 1.0 15,44Kb 8 Скачать
Архив обработок ВСЕ в ОДНОМ - v2.1

.rar 600,71Kb
29.10.16
39
.rar 2.1 600,71Kb 39 Скачать
Отключение пользователей - 8.3 - файловая обычные формы

.epf 16,83Kb
11.10.16
2
.epf 16,83Kb 2 Скачать
ГрупповаяПечатьПФ_Документов_82

.epf 13,78Kb
29.10.16
0
.epf 13,78Kb Скачать
Консоль запросов - с произвольным алгоритмом (82)

.epf 136,43Kb
29.10.16
0
.epf 136,43Kb Скачать
КонсольЗапросов_УФ_83

.epf 230,34Kb
29.10.16
0
.epf 230,34Kb Скачать
ОтладкаВнешнейПечатнойФормы.82

.epf 13,93Kb
29.10.16
2
.epf 13,93Kb 2 Скачать
ОтладкаОбработокЗТЧ_8

.epf 21,18Kb
29.10.16
2
.epf 21,18Kb 2 Скачать
Перепроведение документов по контрагенту 82

.epf 19,01Kb
29.10.16
1
.epf 19,01Kb 1 Скачать
ПоискИЗаменаЗначений_с_перепроведением_82

.epf 22,38Kb
29.10.16
0
.epf 22,38Kb Скачать
ПроведениеДокументов_НеМонопольное_82

.epf 22,34Kb
29.10.16
1
.epf 22,34Kb 1 Скачать
Сравнение модулей обарботок - final (82)

.epf 8,47Kb
29.10.16
1
.epf 8,47Kb 1 Скачать
УниверсальныйРеестрДокументов_ПечатьРеквизитов_спроизв_алгоритмом_82

.epf 78,09Kb
29.10.16
1
.epf 78,09Kb 1 Скачать
ОбновитьИдентификаторыОбъектовМетаданных (УФ, 83)

.epf 6,66Kb
30.10.16
0
.epf 6,66Kb Скачать
Инструкция по блокировке сеансов пользов. обычные и упр. формы

.docx 259,05Kb
01.11.16
3
.docx 259,05Kb 3 Скачать
Отключение пользователей _81 (клиент-сервер)

.epf 86,89Kb
24.12.16
0
.epf 86,89Kb Скачать
Удобная читалка XML в 1С 8.2 (обычные формы)

.epf 64,88Kb
24.12.16
1
.epf 64,88Kb 1 Скачать
Шаблон отчета СКД - управляемые формы

.erf 27,79Kb
31.08.17
1
.erf 27,79Kb 1 Скачать
Шаблон отчета СКД - обычные формы

.erf 63,39Kb
31.08.17
1
.erf 63,39Kb 1 Скачать
Удаление записей независимых регистров сведений

.epf 13,71Kb
11.06.20
0
.epf 13,71Kb Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Bitnikov 306 27.09.16 23:38 Сейчас в теме
Понадобилось отключить зависшее соединение в обычных формах на 8.3. Скачал - Отключение пользователей - обычные формы - файловая. Сходу на 8.3 не заработала, допилил сам. Ставлю + в надежде, что доработаете и обновите обработку.
2. Светлый ум 259 28.09.16 05:51 Сейчас в теме
(1) Bitnikov, протестирую на 8.3 - использую 8.2, поэтому возможно чего-то не учел
3. Светлый ум 259 11.10.16 17:07 Сейчас в теме
(1) Bitnikov, сбацал - качаем для 8.3 отдельно прикрепляю - архив позже обновлю.
19. Светлый ум 259 27.06.19 18:32 Сейчас в теме
Загрузка из Иерархического Экселя:
Процедура ПрочитатьИзФайла(Дерево) Экспорт
	
	ВыбФайл = Новый Файл(Путь);
	Если НЕ ВыбФайл.Существует() Тогда
		Сообщить("Файл не существует!");
		Возврат;
	КонецЕсли;
	
	Попытка
		Excel = Новый COMОбъект("Excel.Application");
		Excel.WorkBooks.Open(Путь);
		ExcelЛист = Excel.Sheets(1);
	Исключение
		Сообщить("Ошибка. Возможно неверно указан номер листа книги Excel.");
		Возврат;
	КонецПопытки;
	ТекСтр = 1;
	
	НачальнаяГруппировка = Дерево.Строки.Добавить();
	НачальнаяГруппировка.Наименование = "Корень";
	НачальнаяГруппировка.Глубина = 0;
	xlCellTypeLastCell = 11;
	ExcelПоследняяСтрока = ExcelЛист.Cells.SpecialCells(xlCellTypeLastCell).Row;
	ДобавитьВеткуВДерево(ExcelЛист, НачальнаяГруппировка, 0, 1);
	
	Excel.WorkBooks.Close();
	Excel = 0;
	
КонецПроцедуры    

Процедура ДобавитьВеткуВДерево(ExcelЛист, ТекущаяВетвь, ПредыдущийУровень, ТекСтр)
	
	Пока Истина Цикл 
		
		НаименованиеТовара = СокрЛп(ExcelЛист.Cells(ТекСтр, 1).Value);
		Если НаименованиеТовара = "" Тогда 
			Прервать;
		КонецЕсли;

		ТекущийУровень = ExcelЛист.Rows(ТекСтр).OutlineLevel;
		Если ПредыдущийУровень < ТекущийУровень Тогда
			// Прочитали дочерний узел
			НоваяВетвь = ТекущаяВетвь.Строки.Добавить();
		ИначеЕсли ПредыдущийУровень > ТекущийУровень Тогда
			Возврат;
		Иначе
			Если ТекущаяВетвь.Глубина = ТекущийУровень Тогда 
				// Закончили группировку, которая евляется концом вышестоящей
				НоваяВетвь = ТекущаяВетвь.Родитель.Строки.Добавить();
			Иначе 
				// Перебираем элементы текущей группировки
				НоваяВетвь = ТекущаяВетвь.Строки.Добавить();
			КонецЕсли;
		КонецЕсли;
		
		НоваяВетвь.Наименование = НаименованиеТовара;
		НоваяВетвь.Глубина = ТекущийУровень;
			
		СледующийУровень = ExcelЛист.Rows(ТекСтр + 1).OutlineLevel;
		Если СледующийУровень < ТекущийУровень Тогда 
			ТекСтр = ТекСтр + 1;
			Возврат;
		Иначе
			ТекСтр = ТекСтр + 1;
			Если СледующийУровень > ТекущийУровень Тогда 
				ДобавитьВеткуВДерево(ExcelЛист, НоваяВетвь, ТекущийУровень, ТекСтр)
			КонецЕсли;
		КонецЕсли;
		
	КонецЦикла;
	
КонецПроцедуры
Показать
Прикрепленные файлы:
МодульОбъекта_ЗагрExcel.txt
МодульФормы_ЗагрExcel.txt
тест.xls
4. Светлый ум 259 29.10.16 15:23 Сейчас в теме
V 2.1:
- архив обновлен 29.10.2016
- 1 инструмент доработан, 10 добавлено
(версия платформы указываю для каждого файла)
Team leader; +1 Ответить
5. Team leader 9 20.07.17 09:50 Сейчас в теме
Для принудительного запуска предприятия в Обычном или Управляемом приложении используются следующие ключи:

/RunModeOrdinaryApplication запуск толстого клиента в обычном режиме, несмотря на настройки конфигурации и пользователя, от имени которого будет выполняться запуск.

/RunModeManagedApplication запуск толстого клиента в режиме управляемого приложения, несмотря на настройки конфигурации и пользователя, от имени которого будет выполняться запуск.

При указании любого из этих двух ключей отключается механизм автоматического выбора клиентского приложения кроме случаев, когда пользователь в командной строке явно указал ключ /AppAutoCheckMode (с 8.2.15)

Параметр можно указать в настройках запуска базы:


Примеры создания ярлыков:

"C:\Program Files (x86)\1cv82\8.2.13.219\bin\1cv8.exe" /RunModeOrdinaryApplication

или

\\server1c\Client_8_3\1cv8s.exe ENTERPRISE /S"server1c\buh_3_0" /DisableStartupMessages /RunModeOrdinaryApplication
6. Team leader 9 20.07.17 10:46 Сейчас в теме
Сервис - Параметры - Запуск 1С:Предприятия - Основные - Толстый клиент (обычное приложение)
7. Светлый ум 259 20.04.18 11:35 Сейчас в теме
еще, 5 копеек. (себе напоминание)
- в дополнительные параметры запуска вставляем:

/C ЗапуститьОбновлениеИнформационнойБазы
71. Светлый ум 259 22.11.19 06:51 Сейчас в теме
Литература по программированию 1С
https://forum.infostart.ru/forum6/topic230143/

(7) 21 день программиста от Гилева посмотрим, затем курс по запросам на юутубе от Кузнецова, а затем 110 уроков Гилева по СКД.
Дальше можно почитать книгу разработчика. Ну для систематизации хватит.

http://v8.1c.ru/metod/books/
Вот тут можно выбрать
Если есть ИТС, можно читать прямо с сайта некоторые книги
8. Светлый ум 259 22.05.19 20:53 Сейчас в теме
тестовая обработка
Прикрепленные файлы:
файлы.rar
9. Светлый ум 259 02.06.19 12:45 Сейчас в теме
62. Светлый ум 259 22.10.19 10:26 Сейчас в теме
11. Светлый ум 259 04.06.19 09:41 Сейчас в теме
Обрезание функционала для увеличения скорости обработки больших объемов данных:

https://infostart.ru/public/387232/
12. Светлый ум 259 04.06.19 11:30 Сейчас в теме
Работа с XML:

1) Разбор XML документа - почти все возможные способы

https://infostart.ru/public/311011/

2) XDTO на службе у лентяев. Самый простой способ чтения xml
https://infostart.ru/public/414940/
13. Светлый ум 259 07.06.19 11:55 Сейчас в теме
14. Светлый ум 259 11.06.19 13:29 Сейчас в теме
Работа с динамическим списком
//снять галку: автоматическое сохранение пользовательских настроек

Процедура СортироватьПоКодуБыстрогоВыбора_Вниз()
	
	ЭлементыПользовательскихНастроек = Список.КомпоновщикНастроек.ПользовательскиеНастройки.Элементы;
	Для Каждого Элемент Из ЭлементыПользовательскихНастроек Цикл
		Если ТипЗнч(Элемент) = ТипЗнч(Список.КомпоновщикНастроек.Настройки.Порядок) Тогда
			Элемент.Элементы.Очистить();
			УсловиеСортировки = Элемент.Элементы.Добавить(Тип("ЭлементПорядкаКомпоновкиДанных"));
			УсловиеСортировки.Поле = Новый ПолеКомпоновкиДанных("КодБыстрогоВыбора");
			УсловиеСортировки.ТипУпорядочивания = НаправлениеСортировкиКомпоновкиДанных.Убыв;
			УсловиеСортировки.Использование = Истина;
		КонецЕсли;    
	КонецЦикла;
	
КонецПроцедуры


&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	
	ЭлементыПользовательскихНастроек = Список.КомпоновщикНастроек.ПользовательскиеНастройки.Элементы;
	Для Каждого Элемент Из ЭлементыПользовательскихНастроек Цикл
		Если ТипЗнч(Элемент) = ТипЗнч(Список.КомпоновщикНастроек.Настройки.УсловноеОформление) Тогда
			//Элемент.Элементы.Очистить();	
			НовыйЭлементУсловногоОформления = Элемент.Элементы.Добавить(); //Тип("ЭлементУсловногоОформленияКомпоновкиДанных") 
			НовыйЭлементУсловногоОформления.Использование = Истина;
			ПолеЭлемента               = НовыйЭлементУсловногоОформления.Поля.Элементы.Добавить();
			ПолеЭлемента.Поле          = Новый ПолеКомпоновкиДанных("Наименование");
			ПолеЭлемента.Использование = Истина;
			//Отбор    
			ЭлементОтбора = НовыйЭлементУсловногоОформления.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных")); //
			ЭлементОтбора.Использование  = Истина; 
			ЭлементОтбора.ЛевоеЗначение  = Новый ПолеКомпоновкиДанных("Наименование");
			ЭлементОтбора.ВидСравнения   = ВидСравненияКомпоновкиДанных.Меньше; 
			ЭлементОтбора.ПравоеЗначение = "тест_5";
			НовыйЭлементУсловногоОформления.Оформление.УстановитьЗначениеПараметра("ЦветФона", WebЦвета.Синий);
		КонецЕсли;    
	КонецЦикла;

	
КонецПроцедуры
Показать
15. Светлый ум 259 13.06.19 09:53 Сейчас в теме
Задание выражения для ЗагрузкиИзТабличногоДокумента, программного:

Для каждого ЗагружаемыйРеквизит Из ТаблицаЗагружаемыхРеквизитов Цикл
		ЗагружаемыйРеквизит.Пометка = Ложь;		
	      Если ЗагружаемыйРеквизит.ИмяРеквизита = "Код" Тогда 
			ЗагружаемыйРеквизит.Пометка    = Истина;
			ЗагружаемыйРеквизит.ПолеПоиска = Истина;
			
			ЗагружаемыйРеквизит.РежимЗагрузки = "Вычислять";	 
			ТекстВыражения                    = 
                        "Если Прав(ТекстЯчейки, 1) <> ""."" Тогда Результат = ТекстЯчейки + "".""; Иначе Результат =    ТекстЯчейки; КонецЕсли";

			ЗагружаемыйРеквизит.ПредставлениеДопУсловий = ТекстВыражения;  
			ЗагружаемыйРеквизит.Выражение               = ТекстВыражения;
		КонецЕсли;	

		Если ЗагружаемыйРеквизит.ИмяРеквизита = "Наименование" Тогда 
			ЗагружаемыйРеквизит.НомерКолонки  = 2;
			ЗагружаемыйРеквизит.Пометка       = Истина;
               КонецЕсли;	
Показать
16. Светлый ум 259 20.06.19 10:33 Сейчас в теме
Лучший анализ прав (Управляемые формы)
https://infostart.ru/public/875774/
17. Светлый ум 259 24.06.19 12:05 Сейчас в теме
18. Светлый ум 259 25.06.19 21:29 Сейчас в теме
ВПФ на СКД:

Функция СведенияОВнешнейОбработке() Экспорт
	
	МассивНазначений = Новый Массив;
	МассивНазначений.Добавить("Документ.РеализацияТоваровУслуг");
	
	ТаблицаКоманд = Новый ТаблицаЗначений;
	ТаблицаКоманд.Колонки.Добавить("Представление");
	ТаблицаКоманд.Колонки.Добавить("Идентификатор");
	ТаблицаКоманд.Колонки.Добавить("Использование");
	ТаблицаКоманд.Колонки.Добавить("ПоказыватьОповещение");
	ТаблицаКоманд.Колонки.Добавить("Модификатор");
	
	НоваяКоманда = ТаблицаКоманд.Добавить();
	НоваяКоманда.Представление = "Лист сбора";
	НоваяКоманда.Идентификатор = "ВнешняяПечатнаяФорма";
	НоваяКоманда.Использование = "ВызовСерверногоМетода";
	НоваяКоманда.ПоказыватьОповещение = Истина;
	НоваяКоманда.Модификатор = "ПечатьMXL";
	
	ПараметрыРегистрации = Новый Структура;
	ПараметрыРегистрации.Вставить("Вид", 				"ПечатнаяФорма");   
	ПараметрыРегистрации.Вставить("Назначение", 		МассивНазначений);
	ПараметрыРегистрации.Вставить("Наименование", 		"Лист сбора");
	ПараметрыРегистрации.Вставить("Версия", 			"1");
	ПараметрыРегистрации.Вставить("БезопасныйРежим", 	Ложь);
	ПараметрыРегистрации.Вставить("Информация", 		"Расходный ордер - Лист сбора");
	ПараметрыРегистрации.Вставить("Команды", 			ТаблицаКоманд);
	
	Возврат ПараметрыРегистрации;
	
КонецФункции

Процедура Печать(ОбъектыНазначения, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт
	
	ТабличныйДокумент = СформироватьПечатнуюФормуРеестра(ОбъектыНазначения, ОбъектыНазначения);
	
	УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(
		КоллекцияПечатныхФорм,
		"ВнешняяПечатнаяФорма",
		"Внешняя печатная форма",
		ТабличныйДокумент);
		
КонецПроцедуры

Функция СформироватьПечатнуюФормуРеестра(МассивОбъектовНазначения, ОбъектыПечати);
	
	ТабДокумент = Новый ТабличныйДокумент;
	
	Док = МассивОбъектовНазначения[0];
	Заголовок = Строка(Док.Метаданные().Представление()) + " №" + Док.Номер + " от " + Формат(Док.Дата, "ДФ=dd.MM.yy");
	
	Если Док.СпособДоставки = Перечисления.СпособыДоставки.Самовывоз Тогда
		Доставка = "Самовывоз" + 
					?(Не ЗначениеЗаполнено(Док.АдресДоставки), "", Символы.ПС + "Адрес доставки: " + Док.АдресДоставки);
		
	ИначеЕсли Док.СпособДоставки = Перечисления.СпособыДоставки.СиламиПеревозчика Тогда
		Доставка = "Трансп. компания: " + Док.ПеревозчикПартнер.НаименованиеПолное + 
					?(Не ЗначениеЗаполнено(Док.АдресДоставки), "", Символы.ПС + "Адрес доставки: " + Док.АдресДоставки) +
					?(Не ЗначениеЗаполнено(Док.ДополнительнаяИнформацияПоДоставке), "", Символы.ПС + Док.ДополнительнаяИнформацияПоДоставке);
					
	Иначе
		Доставка = "";
					
	КонецЕсли;
	
	Инфо = "Заказчик: " + Док.Контрагент.НаименованиеПолное + Символы.ПС +
			"Менеджер: " + Док.Партнер.ОсновнойМенеджер.Наименование + Символы.ПС +
			Доставка;
	
	СхемаКомпоновкиДанных = ПолучитьМакет("СКД");
	Настройки = СхемаКомпоновкиДанных.ВариантыНастроек.Основной.Настройки;
	
	Настройки.ПараметрыВывода.Элементы.Найти("Заголовок").Значение = Заголовок;
	Настройки.Структура[0].ПараметрыВывода.Элементы.Найти("Заголовок").Значение = Инфо;
	
	Компоновщик = Новый КомпоновщикНастроекКомпоновкиДанных;
    Компоновщик.ЗагрузитьНастройки(Настройки);

    Компоновщик.Настройки.ПараметрыДанных.Элементы[0].Значение = Док;

    КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;
    ПроцессорКомпоновки = Новый ПроцессорКомпоновкиДанных;
    МакетКомпоновки = КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных, Компоновщик.Настройки);

    ПроцессорКомпоновки.Инициализировать(МакетКомпоновки);

    ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
    ПроцессорВывода.УстановитьДокумент(ТабДокумент);
    ПроцессорВывода.Вывести(ПроцессорКомпоновки, Истина);
	
	Возврат ТабДокумент;
	
КонецФункции
Показать
20. Светлый ум 259 02.07.19 13:43 Сейчас в теме
Формирование Источника данных CКД

ДокОбъект             = РеквизитФормыВЗначение("Объект");
			СхемаКомпоновкиДанных = ДокОбъект.ПолучитьМакет("СхемаКомпоновкиДанных");
			КоличествоДокументов  = 1;	
			ПользовательскиеНастройкиМодифицированы = Ложь;
			
			//УстановитьОбязательныеНастройки(ПользовательскиеНастройкиМодифицированы, );		
			КомпоновщикНастроек = Новый КомпоновщикНастроекКомпоновкиДанных();
			КомпоновщикНастроек.Инициализировать(Новый ИсточникДоступныхНастроекКомпоновкиДанных(СхемаКомпоновкиДанных)); 
			//Позже заменим на настройки из реквизита документа
			КомпоновщикНастроек.ЗагрузитьНастройки(СхемаКомпоновкиДанных.НастройкиПоУмолчанию); 
			НастройкиОтчета     = КомпоновщикНастроек.ПолучитьНастройки();
			
			//ВнешниеНаборы = НаборыДанных();	НастройкиОтчета         = КомпоновщикНастроек.ПолучитьНастройки();
			ПараметрыПолученияФакта = ПараметрыПолученияФактаПоНастройкамОтчета(НастройкиОтчета);
			
			ВнешниеНаборы = Новый Структура;	
			//Факт
			ОборотыФакт = ОборотыФакт(НастройкиОтчета, ПараметрыПолученияФакта);
			ВнешниеНаборы.Вставить("ОборотыФакт", ОборотыФакт);
			ВнешниеНаборы.Вставить("ОборотыТолькоФакт", ОборотыФакт.Скопировать(Новый Структура("Сценарий", Справочники.Сценарии.ФактическиеДанные)));
			//План
			ВнешниеНаборы.Вставить("ОборотыПлан", ОборотыПлан(НастройкиОтчета));	
			БюджетированиеСервер.ДополнитьСКДАналитикойПоВиду(СхемаКомпоновкиДанных, "СтатьяБюджетов");		
			БюджетированиеСервер.ДополнитьСКДВыражениямиПредставленияАналитики(СхемаКомпоновкиДанных,
			"НаборыДанных.АналитикаОборотов.Поля",
			"СтатьяБюджетов");	
			Период = БюджетированиеСервер.ЗначениеНастройкиСКД(КомпоновщикНастроек, "Период");
			НачалоПериода = Период.ДатаНачала;
			КонецПериода = Период.ДатаОкончания;
			ДопСвойства = КомпоновщикНастроек.ПользовательскиеНастройки.ДополнительныеСвойства;
			
			ДопСвойства.Удалить("КоличествоДокументовКОтражениюВБюджетировании");
			Если РегистрыСведений.ЗаданияКОтражениюВБюджетировании.ТребуетсяОтражениеВБюджетированииДляОтчетаЗаПериод(
				НачалоПериода, КонецПериода, КоличествоДокументов) Тогда
				
				ФактическиеДанныеБюджетированияСервер.ОтразитьДокументыФоновымЗаданием(НачалоПериода, КонецПериода);
				ДопСвойства.Вставить("КоличествоДокументовКОтражениюВБюджетировании", КоличествоДокументов);
				ДопСвойства.Вставить("НачалоПериода", НачалоПериода);
				ДопСвойства.Вставить("КонецПериода", КонецПериода);
				
			КонецЕсли;	
			////////////////////////////////////////////////////////////­//////////////////////////////////////////
			КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;
			ДанныеРасшифровки = Неопределено;
			МакетКомпоновки   = КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных, КомпоновщикНастроек.ПолучитьНастройки(), ДанныеРасшифровки);
			ДокументРезультат = Новый ТабличныйДокумент;
			
			СкорректироватьСвязиНаборовДанныхМакетаКомпоновки(МакетКомпоновки);
			
			ПроцессорКомпоновкиДанных = Новый ПроцессорКомпоновкиДанных;
			ПроцессорКомпоновкиДанных.Инициализировать(МакетКомпоновки, ВнешниеНаборы, ДанныеРасшифровки, Истина);
			
			ПроцессорВыводаВТабличныйДокумент = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
			ПроцессорВыводаВТабличныйДокумент.УстановитьДокумент(ДокументРезультат);
			ПроцессорВыводаВТабличныйДокумент.Вывести(ПроцессорКомпоновкиДанных);
			
			ФактическиеДанныеБюджетированияСервер.ВывестиАктуальностьОтраженияФактическихДанных(ДокументРезультат, ДопСвойства);
						
			ДокументРезультат.ОтображатьЗаголовки = Ложь;
			ДокументРезультат.ОтображатьСетку = Ложь;
			ДокументРезультат.АвтоМасштаб = Истина;
			
			Возврат ДокументРезультат;//.Показать();
Показать
21. Светлый ум 259 04.07.19 20:09 Сейчас в теме
Программное формирование СКД на форме :


Процедура ДействияФормыСформировать(Кнопка)
	
	
	Параметр = ЭтотОбъект.КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("ДатаНач");
	Параметр.Значение = НачалоПериода;
	Параметр.Использование = Истина;
	Параметр = ЭтотОбъект.КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("ДатаКон");
	Параметр.Значение = КонецПериода;
	Параметр.Использование = Истина;
	
	//Заголовок
	Параметр = ЭтотОбъект.КомпоновщикНастроек.Настройки.ПараметрыВывода.Элементы.Найти("Title");	
	Нач = Формат(НачалоПериода, "ДЛФ=Д");
	Кон = Формат(КонецПериода,  "ДЛФ=Д");
	Параметр.Значение = "Отчет по ""Остаткам товаров"" за период, с: " + Нач + "---  по: "+  Кон;
	Параметр.Использование = Истина;
	
	ЭлементыФормы.Результат.Очистить();
	ЭтотОбъект.СкомпоноватьРезультат(ЭлементыФормы.Результат, ДанныеРасшифровки);
	
	СгенерироватьКнопкиУправленияГруппировкой();
    ЭлементыФормы.Результат.ПоказатьУровеньГруппировокСтрок(0);

КонецПроцедуры


Процедура _СменаВариантаНастройки (Элемент) 
	Для каждого Настройка Из СхемаКомпоновкиДанных.ВариантыНастроек Цикл 
		Если Элемент.Текст = Настройка.Представление тогда 
			КомпоновщикНастроек.ЗагрузитьНастройки(Настройка.Настройки); 
			Прервать; 
		КонецЕсли;
	КонецЦикла;
КонецПроцедуры 

Процедура УстановитьВариантыНастроек()
	КП = ЭлементыФормы.ДействияФормы; 
	НоваяКнопка = КП.Кнопки.Вставить(1,"_ВариантыОтчетов", ТипКнопкиКоманднойПанели.Подменю, "Варианты отчетов", ); 
	НовоеДействие = Новый Действие("_СменаВариантаНастройки"); 
	ч = 1; 
	Для каждого Настройка Из СхемаКомпоновкиДанных.ВариантыНастроек Цикл
		НоваяКнопка = КП.Кнопки._ВариантыОтчетов.Кнопки.Добавить("Вариант"+Строка(ч), ТипКнопкиКоманднойПанели.Действие, Настройка.Представление, НовоеДействие); 
		ч = ч + 1; 
	КонецЦикла; 
КонецПроцедуры
Показать
22. Светлый ум 259 05.07.19 04:02 Сейчас в теме
Вариант 2 Источники на форму СКД:

&НаСервере
Процедура СформироватьОтчетНаСервере()
	
	Если не ЗначениеЗаполнено(ВариантОтчета) Тогда
		Сообщить("Вы не выбрали вариант отчета - отчет не будет сформирован");	
	Иначе
		
		Для Каждого СтрНастроек Из ТаблицаНастроекВарианта Цикл
			Если не ЗначениеЗаполнено(СтрНастроек.Значение) и СтрНастроек.ЗапрещатьНезаполненныеЗначения Тогда
				Сообщить("Вы не выбрали "+СтрНастроек.Заголовок+" - отчет не будет сформирован");	
				Возврат;
			КонецЕсли;	
		КонецЦикла;	
		
		ОтчетОбъект = ЭтаФорма.РеквизитФормыВЗначение("Отчет");
		СхемаКомпоновки = ОтчетОбъект.ПолучитьМакет(ВариантОтчета);
		Отчет.КомпоновщикНастроек.Инициализировать(Новый ИсточникДоступныхНастроекКомпоновкиДанных(СхемаКомпоновки));	
		Отчет.КомпоновщикНастроек.ЗагрузитьНастройки(СхемаКомпоновки.НастройкиПоУмолчанию);
		
		Для Каждого СтрНастроек Из ТаблицаНастроекВарианта Цикл
			Если СтрНастроек.ЭлементОтбораИлиПараметр = "ЭлементОтбора" Тогда
				Для Каждого ЭлементОтбора Из Отчет.КомпоновщикНастроек.Настройки.Отбор.Элементы Цикл
					Если Строка(ЭлементОтбора.ЛевоеЗначение) = СтрНастроек.Имя и
						 ЭлементОтбора.Представление = СтрНастроек.ПредставлениеОтбора Тогда
						ЭлементОтбора.ПравоеЗначение = СтрНастроек.Значение;
						ЭлементОтбора.Использование  = СтрНастроек.Использование;
						ЭлементОтбора.ВидСравнения = СтрНастроек.ВидСравнения;
					КонецЕсли;
				КонецЦикла;
			ИначеЕсли СтрНастроек.ЭлементОтбораИлиПараметр = "Параметр" Тогда
				Параметр = Отчет.КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти(СтрНастроек.Имя);
				Параметр.Значение = СтрНастроек.Значение;
				Параметр.Использование = СтрНастроек.Использование;
			КонецЕсли;	
		КонецЦикла;
		
		ДанныеРасшифровки = Новый ДанныеРасшифровкиКомпоновкиДанных;
		КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;
		МакетКомпоновки = КомпоновщикМакета.Выполнить(СхемаКомпоновки,Отчет.КомпоновщикНастроек.Настройки,ДанныеРасшифровки);
		ПроцессорКомпоновкиДанных = Новый ПроцессорКомпоновкиДанных;
		ПроцессорКомпоновкиДанных.Инициализировать(МакетКомпоновки,,ДанныеРасшифровки);
		Результат.Очистить();
		ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
		ПроцессорВывода.УстановитьДокумент(Результат);
		ПроцессорВывода.Вывести(ПроцессорКомпоновкиДанных);
		
		АдресХранилищаДанныхРасшифровки = ПоместитьВоВременноеХранилище(ДанныеРасшифровки, ЭтаФорма.УникальныйИдентификатор);
		
	КонецЕсли;	
	
КонецПроцедуры

Процедура ПоказатьПараметрыИОтборВариантаОтчета(ИмяСхемы)
	
	ТЗ = ЭтаФорма.РеквизитФормыВЗначение("ТаблицаНастроекВарианта");
	ТаблицаНастроекВрем = ТЗ.Скопировать();
	
	ТаблицаНастроекВарианта.Очистить();
	ОтчетОбъект = ЭтаФорма.РеквизитФормыВЗначение("Отчет");
	СхемаКомпоновки = ОтчетОбъект.ПолучитьМакет(ИмяСхемы);
	
	Для Каждого Параметр Из СхемаКомпоновки.Параметры Цикл
		СтрНастроек = ТаблицаНастроекВарианта.Добавить();
		СтрНастроек.Имя = Параметр.Имя;
		СтрНастроек.Заголовок = Параметр.Заголовок+":";
		СтрНастроек.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
		СтрНастроек.Использование = Истина;
		СтрНастроек.ТипЗначения = Параметр.ТипЗначения;
		СтрНастроек.ЭлементОтбораИлиПараметр = "Параметр";
		СтрНастроек.ЗапрещатьНезаполненныеЗначения = Параметр.ЗапрещатьНезаполненныеЗначения;
		Если Параметр.ДоступенСписокЗначений Тогда
			СтрНастроек.Значение = Новый СписокЗначений;
		Иначе
			СтрНастроек.Значение = Параметр.ТипЗначения.ПривестиЗначение(Параметр.Значение);
		КонецЕсли;	                                        
	КонецЦикла;	
	
	Отбор = СхемаКомпоновки.ВариантыНастроек.Основной.Настройки.Отбор;
	
	Для Каждого ЭлементОтбора Из Отбор.Элементы Цикл
		
		СтрНастроек = ТаблицаНастроекВарианта.Добавить();
		СтрНастроек.Имя = Строка(ЭлементОтбора.ЛевоеЗначение);
		СтрНастроек.Заголовок = Строка(ЭлементОтбора.ЛевоеЗначение)+":";
		СтрНастроек.ВидСравнения = ЭлементОтбора.ВидСравнения;
		СтрНастроек.Использование = ЭлементОтбора.Использование;
		СтрНастроек.ЭлементОтбораИлиПараметр = "ЭлементОтбора";
		СтрНастроек.ПредставлениеОтбора = ЭлементОтбора.Представление;
		
		МассивТипов = Новый Массив;
		Для Каждого НаборДанных Из СхемаКомпоновки.НаборыДанных Цикл
			Для Каждого Поле Из НаборДанных.Поля Цикл	
				Если СокрЛП(СтрНастроек.Имя) = Поле.Поле Тогда
					МассивТиповПоля = Поле.ТипЗначения.Типы();
					Для Каждого Тип Из МассивТиповПоля Цикл
						МассивТипов.Добавить(Тип);
					КонецЦикла;	
				КонецЕсли;
			КонецЦикла;	
		КонецЦикла;
		
		Для Каждого Поле Из СхемаКомпоновки.ВычисляемыеПоля Цикл
			Если СокрЛП(СтрНастроек.Имя) = Поле.ПутьКДанным Тогда
				МассивТиповПоля = Поле.ТипЗначения.Типы();
				Для Каждого Тип Из МассивТиповПоля Цикл
					МассивТипов.Добавить(Тип);
				КонецЦикла;	
			КонецЕсли;
		КонецЦикла;
		
		СтрНастроек.ТипЗначения = Новый ОписаниеТипов(МассивТипов);
		
		Если СтрНастроек.ВидСравнения = ВидСравненияКомпоновкиДанных.ВСписке или
			СтрНастроек.ВидСравнения = ВидСравненияКомпоновкиДанных.ВСпискеПоИерархии или
			СтрНастроек.ВидСравнения = ВидСравненияКомпоновкиДанных.НеВСписке или
			СтрНастроек.ВидСравнения = ВидСравненияКомпоновкиДанных.НеВСпискеПоИерархии Тогда
				СтрНастроек.Значение = Новый СписокЗначений;
		Иначе
				СтрНастроек.Значение = СтрНастроек.ТипЗначения.ПривестиЗначение(ЭлементОтбора.ПравоеЗначение);
		КонецЕсли;	
			
	КонецЦикла;
	
	Для Каждого СтрНастроек Из ТаблицаНастроекВарианта Цикл
		Для Каждого СтрНастроекСтарая Из ТаблицаНастроекВрем Цикл
			Если СтрНастроек.Имя = СтрНастроекСтарая.Имя и
				СтрНастроек.Заголовок = СтрНастроекСтарая.Заголовок и
				СтрНастроек.ЭлементОтбораИлиПараметр = СтрНастроекСтарая.ЭлементОтбораИлиПараметр и
                СтрНастроек.ПредставлениеОтбора = СтрНастроекСтарая.ПредставлениеОтбора Тогда
					СтрНастроек.Значение = СтрНастроекСтарая.Значение;	
					СтрНастроек.ВидСравнения = СтрНастроекСтарая.ВидСравнения;
			КонецЕсли;	
		КонецЦикла;	
	КонецЦикла;	
	

	
КонецПроцедуры
Показать
Прикрепленные файлы:
файлы.rar
23. Светлый ум 259 15.07.19 09:07 Сейчас в теме
Методические материал очного тренинга по теме
«Планирование производства в программе «1С:ERP Управление предприятием 2.0» (1С:ERP)

https://infostart.ru/public/275759/
24. Светлый ум 259 15.07.19 20:57 Сейчас в теме
Тестовые файлы
Прикрепленные файлы:
Тест_2.pdf
25. Светлый ум 259 22.07.19 10:10 Сейчас в теме
Универсальный генератор отчетов СКД (Управляемые формы, тонкий клиент)
https://infostart.ru/public/702221/
26. Светлый ум 259 22.07.19 10:11 Сейчас в теме
Очистка и удаление пользователей информационной базы (не до конца)
https://infostart.ru/public/907170/

Контроль над паролями пользователей для ЛЮБОЙ типовой конфигурации, работающей на платформе 8.3 и выше ( + Расширение)
https://infostart.ru/public/845506/
27. Светлый ум 259 24.07.19 10:56 Сейчас в теме
https://helpf.pro/faq/view/1847.html

17 правил для составления оптимального ЗАПРОСа к данным базы 1С

11) Интересный вариант оператора В - это проверка вхождения упорядоченного набора в множество таких наборов (Поле1, Поле2, ... , ПолеN) В (Поле1, Поле2, ... , ПолеN).

Пример:
ВЫБРАТЬ
Контрагенты.Ссылка
ГДЕ
(Контрагенты.Ссылка, Товары.Ссылка) В
(ВЫБРАТЬ Продажи.Покупатель, Продажи.Товар
ИЗ РегистрНакопления.Продажи КАК Продажи)
ИЗ
Справочник.Контрагенты,
Справочник.Товары   
Показать



15) Условие НЕ В в конструкции ГДЕ увеличивает время исполнения запроса, так как это своего рода НЕ (ИЛИ1 ИЛИ2 ... ИЛИn), поэтому для больших таблиц старайтесь использовать ЛЕВОЕ СОЕДИНЕНИЕ с условием ЕСТЬ NULL. Пример:

ВЫБРАТЬ
_ДемоКонтрагенты.Ссылка
ИЗ
Справочник._ДемоКонтрагенты КАК _ДемоКонтрагенты
ЛЕВОЕ СОЕДИНЕНИЕ Документ._ДемоЗаказПокупателя КАК _ДемоЗаказПокупателя
ПО _ДемоКонтрагенты.Ссылка = _ДемоЗаказПокупателя.Контрагент
ГДЕ
_ДемоЗаказПокупателя.Контрагент ЕСТЬ NULL


16) При использовании Временных таблиц нужно индексировать поля условий и соединений в этих таблицах, НО, при использовании индексов запрос может выполняться еще медленнее. Поэтому необходимо анализировать каждый запрос с применением индекса и без, замерять скорость выполнения запроса и принимать окончательное решение.

Если вы помещаете во временную таблицу данные, которые изначально индексированы по некоторым полям, то во временной таблице индекса по этим полям уже не будет.

17) Если вы не используете Менеджер временных таблиц, то явно удалять временную таблицу не требуется, она будет удалена после завершения выполнения пакетного запроса, иначе следует удалить временную таблицу одним из способов: командой УНИЧТОЖИТЬ в запросе, вызвать метод МенеджерВременныхТаблиц.Закрыть().
28. Светлый ум 259 24.07.19 11:14 Сейчас в теме
18) Наличие прикрепленного файла к Документу/Справочнику

ВЫБОР
	КОГДА ВложенныйЗапрос.Файл > 0
		ТОГДА 1
	ИНАЧЕ 0
КОНЕЦ
29. Светлый ум 259 24.07.19 12:49 Сейчас в теме
От стажера до эксперта
https://infostart.ru/public/1070298/

SQL-EX.RU, где есть много методических материалов и разнообразных заданий разного уровня сложности. Мы предлагаем пройти 80 запросов из учебного курса.

Правила и приемы доработки типовых конфигураций 1С
https://infostart.ru/public/647048/
31. Светлый ум 259 31.07.19 16:26 Сейчас в теме
32. Светлый ум 259 01.08.19 12:31 Сейчас в теме
Работа с изображениями / Групповая обработка изображений
https://infostart.ru/public/438923/
- компановка пакета в tif
--------------------------------------------------------------------------------------------
33. Светлый ум 259 05.08.19 10:46 Сейчас в теме
34. Светлый ум 259 06.08.19 06:34 Сейчас в теме
Универсальная загрузка XML
(с выбором загружаемых колонок)
https://infostart.ru/public/697785/
38. Светлый ум 259 20.08.19 16:30 Сейчас в теме
40. Светлый ум 259 20.08.19 16:58 Сейчас в теме
42. Светлый ум 259 20.08.19 17:20 Сейчас в теме
Кросс варианты:
Прикрепленные файлы:
КроссБезСКД .mxl
ДДС.mxl
43. Светлый ум 259 09.09.19 07:04 Сейчас в теме
Кросс-таблицы обычные
http://danila.org.ua/kross-tablitsa-1s-8-2-upravlyaemaya-forma/ (с примером dt)

Кросс-таблицы СКД (пример на БП_3)
https://infostart.ru/public/968830/
44. Светлый ум 259 09.09.19 07:20 Сейчас в теме
Пример преобразования ТЧ в кросс-таблицу (УФ)
https://infostart.ru/public/547892/
45. Светлый ум 259 09.09.19 07:50 Сейчас в теме
46. Светлый ум 259 09.09.19 10:20 Сейчас в теме
47. Светлый ум 259 09.09.19 10:29 Сейчас в теме
Пошаговые действия предшествующие формированию БДР:

1. Полностью заносите все документы по движению денежных средств(банк, касса)
2. Полностью проводите все движения ТМЦ (реализация, приобретение и списание материалов и т.д.)
3. Полностью проводите оприходование услуг (для их отражения на затратных счетах)
4. Проводите бухгалтерское закрытие периода
5. Формируете отчет о прибылях и убытках - собственно он и является БДР-ом.

https://forum.infostart.ru/forum63/topic48856/
48. Светлый ум 259 18.09.19 09:10 Сейчас в теме
Конфигурация "AXELOT: MDM Управление нормативно справочной информацией", релиз 2.0.3.1
50. Светлый ум 259 03.10.19 05:03 Сейчас в теме
Условия и циклы в тестах и тестовых сценариях вредны.

в тестах должно быть отражение реальной системы :)

1 Если есть некое условие, значит, это не один тестовый сценарий, а несколько.
А раз несколько сценариев у системы, значит, и тестовых сценариев должно быть несколько.
Значит, нужно в тестовой системе нужно зафиксировать эти разные тестовые сценарии

2 если внутри тест.сценария есть условие/цикл, как определить, какой из вариантов условия/цикла выполнялся, а какой нет?
ведь если какой-то не выполнился, значит, проверки этого поведения не было сделано и тестирование задачу проверки поведения системы выполнило только частично :(
51. Светлый ум 259 03.10.19 05:07 Сейчас в теме
artbear
https://infostart.ru/profile/9621/

По пунктам:
1. Изменение метаданных - сложный этап.
Но при создании генератора данных в xUnitFor1C мы как раз постарались помочь решить эту проблему.

После изменения метаданных есть несколько способов реагирования.
1.1 ничего не делать :) , т.к. вполне может быть, что добавлен не столь значащий реквизит документ и документ, созданный из макета, все равно будет находиться в консистентом состоянии
1.2 если все-таки добавлен значащий реквизит, можно выбрать один из 2х способов ниже.
1.3 заново сделать шаблон документа. это может быть трудно - например. нет подходящего документа, или на документ много завязано других ссылок

1.4 подредактировать макет вручную !
на самом деле это не так сложно.
+ Структура макета довольно простая и специально сделана для повышения человекочитаемости и человеко-редактируемости. Табличный документ рулит :)
+ Генератор специально не загружает/не выгружает, а пропускает поля, значения которых не отличается от полей пустого документа.
+ например, значение Ложь для реквизита с типом Булево не будет выгружено или пустая ссылка для ссылочного типа не будет выгружена.
+ в итоге в макете остаются только значащие поля, в отличие от, например, универсальной выгрузки xml, которая очень зависима от изменения метаданных
+ можно просто добавить несколько полей в макет документа - добавить имя поля, его значение. в большинстве случае этого хватает.

>1. Допустим делаю документ, выгрузил в шаблон макет а потом изменились его реквизиты(метаданные) выходит мне надо заново делать шаблон или пытаться править макет вручную. Это не удобно. Есть ли способ лучше?
>2. Допустим я тестирую некий функционал который пишет свои результаты в базу, далее мне надо тестить функционал который зависим от предыдущего и тд, те один зависит от другого. Сейчас я просто вызываю из одного теста другой. Насколько это правильно? Если я буду делать шаблоны и не вызывая "предыдущий функционал" сразу вносить данные в базу для работы текущего тестирования то при изменениях мне придется много менять а это очень неудобно.

Здесь нет простого решения, все зависит от конкретных особенностей.
Базовые рекомендации
+ либо используйте сценарии, т.е. из одного теста вызывайте другой
+ это возможно разными средствами xUnitFor1C -
+ например, ручной вызов теста из другого теста
+ либо используйте сценарный тест в самом xUnitFor1C - смотрите wiki продукта
+ либо можно развязать эти тесты от взаимного использовании и использовать только данные
+ сгенерируйте макет от первого теста и используйте его во втором.
+ тесты будут независимы, их будет легко проверять и разбирать в случае падения одного из тестов.

Напоминаю, что если тест/сценарий падает, то это возможно по 3-м причинам:
+ изменилось поведение системы (например, программист поменял код)
+ изменился тест
+ изменились данные

и бывает далеко не просто понять, в чем же проблема падения теста, и нужно принимать все меры к упрощению подобного анализа.

> Есть ли какой то способ/рекомендация как организовывать тесты ведь если их много и они тестят функции зависимые от др и при этом прогружают данные из макета(СериализаторMXL) то по прошествии времени не особо помнишь что для чего.

Есть разные варианты, как всегда :)
+ Можно делить по блокам функционала - один каталог на верхнем уровне соответствует одному блоку
+ Можно делить по метаданным - один каталог на верхнем уровне соответствует одному метаданному
+ можно совмещать эти подходы
+ например, создание НСИ - отдельный каталог
+ создание документов - другой каталог
+ блоки функциональности - третий каталог
52. Светлый ум 259 11.10.19 09:44 Сейчас в теме
Консоль запросов с алгоритмами

1) Консоль Внедренца v.3.3
https://infostart.ru/public/861748/
(Мощный инструмент)

2) Консоль запросов с возможностью сравнением данных между базами
https://infostart.ru/public/1113104/

3) Выполнение кода (Предприятие 1С)
https://infostart.ru/public/1039993/


---------------------------------------------------------------------------------------------------------
Групповая проверка доработок
https://infostart.ru/public/1056811/

ERWIN - визуализация схемы данных
https://infostart.ru/public/995921/

Хранение модулей во внешних обработках. Меняем код без обновления конфигурации
https://infostart.ru/public/988067/

Механизм версионирования для подсистемы "Дополнительные отчеты и обработки"
https://infostart.ru/public/971397/
53. Светлый ум 259 11.10.19 11:08 Сейчас в теме
Создание текстов договоров по шаблонам Word и организация их хранения в присоединенных файлах
https://infostart.ru/public/1131940/

- хранение присоединенных файлов для БП_3
54. Светлый ум 259 14.10.19 10:37 Сейчас в теме
Проверка кода в пользовательском режиме
https://infostart.ru/public/1126028/
55. Светлый ум 259 15.10.19 13:13 Сейчас в теме
56. Светлый ум 259 15.10.19 13:14 Сейчас в теме
57. Светлый ум 259 16.10.19 07:09 Сейчас в теме
Сканирочка-8. Модуль подключения сканера штрихкода к произвольной конфигурации 1С
https://infostart.ru/public/82996/
58. Светлый ум 259 16.10.19 07:17 Сейчас в теме
Работа с пользовательскими настройками: просмотр, редактирование, удаление, копирование (1см)
https://infostart.ru/public/663868/

Сохранение и восстановление пользовательских настроек при помощи сериализации в xml (управляемые формы)
https://infostart.ru/public/981707/
59. Светлый ум 259 16.10.19 11:15 Сейчас в теме
60. Светлый ум 259 21.10.19 11:18 Сейчас в теме
Повторный вывод шапки при печати новой страницы:

1)
https://helpf.pro/faq82/view/1730.html
// ТабДокумент.ПовторятьПриПечатиСтроки = ТабДокумент.Область("R21:R22");

2)
ТабличныйДокумент (SpreadsheetDocument)
ПроверитьВывод (CheckPut)

Синтаксис:ПроверитьВывод(<Таблицы>)

Пример: Т.Добавить(ШапкаДокумента);
Т.Добавить(СтрокаДокумента);
Т.Добавить(ПодвалДокумента);
Если Не ТабДок.ПроверитьВывод(Т) Тогда
Сообщить("Документ не умещается на страницу!");
КонецЕсли;
61. Светлый ум 259 21.10.19 13:24 Сейчас в теме
Работа с табличным документом (а-ля) Excel
индивидуальный помощник или скромная замена EXCEL
https://infostart.ru/public/640897/
(обычные формы)
63. Светлый ум 259 22.10.19 10:36 Сейчас в теме
64. Светлый ум 259 24.10.19 10:15 Сейчас в теме
65. Светлый ум 259 24.10.19 10:26 Сейчас в теме
РИБ минимальный набор


1) Быстрое создание начального полного подчиненного узла РИБ
https://infostart.ru/public/65830/

2) Отключение и подключение узла распределенной базы (РИБ)
https://forum.infostart.ru/forum86/topic182053/

3) Как создать периферийную базу при помощи DT
https://infostart.ru/public/398538/
66. Светлый ум 259 24.10.19 11:00 Сейчас в теме
Последовательность привязок-отвязок РИБ

Корректное отключение от главного узла РИБ и создание самостоятельной БД. Быстрое создание/восстановление узла РИБ без выгрузки начального образа для конфигураций на основе БСП

https://infostart.ru/public/458570/
67. Светлый ум 259 06.11.19 10:54 Сейчас в теме
68. Светлый ум 259 06.11.19 11:09 Сейчас в теме
Замер производительности
https://infostart.ru/public/96547/

Вариант_1 (УФ):
&НаКлиенте
Перем Замер;

&НаКлиенте
Процедура НачатьЗамер()
    Замер = ТекущаяДата();
КонецПроцедуры

&НаКлиенте
Функция ЗакончитьЗамер()
   
   КонВремя = ТекущаяДата();  КонДни      = 0;  КонЧасы     = 0;  КонМинуты   = 0; КонСекунды = 0;
   Если ПустаяСтрока(Замер) Тогда
        // Раз нет стартовой даты - значит процедура начала отсчета времени не была запущена.
        Возврат "Замер времени не начат!";
    КонецЕсли;

    ОстатокВремени = КонВремя - Замер;
    КонДни          = Цел(ОстатокВремени / 86400); //++ 86400 - Количество секунд в сутках
    ОстатокВремени = ОстатокВремени - КонДни * 86400;
    КонЧасы         = Цел(ОстатокВремени / 3600); //++ 3600 - Количество секунд в часе
    ОстатокВремени  = ОстатокВремени - КонЧасы * 3600;
    КонМинуты       = Цел(ОстатокВремени / 60); //++ 60 - Количество секунд в минуте
    ОстатокВремени  = ОстатокВремени - КонМинуты * 60;
    КонСекунды      = ОстатокВремени;
    ТекСтрока       = Формат(КонДни,"ЧН=2; ЧН=0; ЧВН=") + "/" + Формат(КонЧасы,"ЧЦ=2; ЧН=0; ЧВН=") + ":" 
+ Формат(КонМинуты,"ЧЦ=2; ЧН=0; ЧВН=") + ":" + Формат(КонСекунды,"ЧЦ=2; ЧН=0; ЧВН=");
    Возврат ТекСтрока;
КонецФункции
Показать


Вариант_2
ВремяСтарта = ТекущаяДата(); // ... Далее выполняется нужная обработка ... 
ЗатраченоСекунд = ТекущаяДата() - ВремяСтарта; 
Час_Мин_Сек = Строка(Формат(ЗатраченоСекунд/3600-0.5,"ЧЦ=2;ЧН=;ЧВН=") + ":" 
+ Формат(ЗатраченоСекунд%3600/60-0.5,"ЧЦ=2;ЧН=;ЧВН=") + ":" 
+ Формат(ЗатраченоСекунд%60,"ЧЦ=2;ЧН=;ЧВН=")); // Если ЗатраченоСекунд = 3723, то Час_Мин_Сек = "01:02:03" 

Час_Мин_Сек = Формат('00010101'+ЗатраченоСекунд, "ДФ=HH:mm:ss"); 


Вариант_3
КлючеваяОперация = "СозданиеФормыКонтактныеЛица"; 
ОценкаПроизводительностиКлиентСервер.НачатьЗамерВремени(КлючеваяОперация); 
69. Светлый ум 259 13.11.19 11:23 Сейчас в теме
Инструкции для программистов

1) Инструкция как написать консоль запросов с конструктором на управляемых
https://infostart.ru/public/719293/

2) Инструкция как создать загрузчик из табличного документа :


3) Загрузка из табличного документа копи-пастом (где-то есть старая инструкция)
https://infostart.ru/public/1000443/

4) Инструкция - Создание подключаемой обработки табличной части (УФ)
https://infostart.ru/public/825702/

5) Инструкция загрузки из Excel
https://programmist1s.ru/zagruzka-iz-excel-v-1s/
70. Светлый ум 259 15.11.19 05:43 Сейчас в теме
6) Инструкция загрузки из excel
https://1s83.info/programmirovanie/zagruzka-iz-excel-v-1s-dlya-programmista.html

//ТабличныйДокумент.Прочитать(Объект.ФайлExcel); - для платформы с версии 8.3.10
72. Светлый ум 259 25.11.19 04:58 Сейчас в теме
Обработка временной или постоянной замены пароля Аутентификации 1С: Предприятия 8.2-8.3
https://habr.com/ru/post/275999/
https://cloud.mail.ru/public/6Nad/k2GGjVEnb
73. Светлый ум 259 25.11.19 06:21 Сейчас в теме
https://infostart.ru/public/449681/

Универсальные функции с примерами использования

1. Замер времени выполнения
2. Проверка значения на вхождение в некоторый интервал
3. Разбиение строки на левую и правую часть
4. Преобразование табличного документа в коллекцию
4.1 Табличный документ в таблицу значений (перебор)
4.2. Табличный документ в дерево значений
5. Загрузка файлов: выбор на клиенте, обработка на сервере
6. Попытка записи данных в файл с таймаутом на время записи
7. Проверка интернет-соединения (ping)
8. Быстрое описание типа
9. Шаблон чтения Excell через ADO
10. Объединение ячеек шапки табличного документа с повторяющимся текстом
11. Формирование идентификатора по строке
12. Формирование представления по идентификатору
13. Формирование структуры для первой (единственной) записи результата запроса
74. Светлый ум 259 02.12.19 11:41 Сейчас в теме
75. Светлый ум 259 02.12.19 11:53 Сейчас в теме
76. Светлый ум 259 16.12.19 09:48 Сейчас в теме
1) Последовательность событий при проведении документа
2) Последовательность событий при отмене проведения
3)Последовательность событий при открытии формы

https://github.com/kuzyara/Sequences-of-events-for-1C-objects
https://infostart.ru/public/1098803/
77. Светлый ум 259 18.12.19 10:45 Сейчас в теме
78. Светлый ум 259 18.12.19 11:32 Сейчас в теме
(77)
1. Общее - 1 : 67
2. Планирование - 68 : 113
3. Бюджетирование - 114 : 158
4.Заказы - 158 : 202

https://xn----1-bedvffifm4g.xn--p1ai/1c-erp-2/1s-professional/razdel03/vopros03-01/
79. Светлый ум 259 23.12.19 05:56 Сейчас в теме
Семь рекомендуемых бесплатных курсов Microsoft для ИТ-администраторов
https://infostart.ru/public/973515/
80. Светлый ум 259 23.12.19 08:01 Сейчас в теме
Курс по управлению проектами : 28 частей
https://infostart.ru/profile/1008281/objects/

1) Устав проекта
https://infostart.ru/public/903702/

2) Создание концепции проекта (project scope statement)
https://infostart.ru/public/944448/

3) Управление качеством: блок-схемы, чек-листы
https://infostart.ru/public/966173/

4) Алгоритм управления сроками с использованием специального софта.
https://infostart.ru/public/983387/
81. Светлый ум 259 23.12.19 09:25 Сейчас в теме
1) Курс "Налоговый учет ПБУ (18/02)" (в формате видеокурса и онлайн-курса с 22 по 24 января 2020 г.)
https://infostart.ru/public/861990/
(от 2100 за видео)

2) Концепция прикладного решения "1С:ERP Управление предприятием 2" (в формате видеокурса и онлайн-курса 6-7 февраля 2020 г.)
https://infostart.ru/public/860626/
(от 2100 за видео)

3) Курс позволяет получить целостное представление о назначении и возможностях прикладного решения, а также подготовиться к экзамену "1С:Профессионал". На курсе представлен материал по "1С:ERP " версии 2.4

Для обучения предоставляется электронная книга, база из 600 вопросов для подготовки к тесту 1С:Профессионал, программа 1С:ERP 2. Также есть возможность задавать вопросы преподавателю во время и после окончания обучения в течении 90 дней.

! Технология работы с функционалом управления производством и ремонтами подробно рассматривается на отдельном курсе
(от 2100 за видео)
82. Светлый ум 259 23.12.19 09:57 Сейчас в теме
(81)
"Управление производством и ремонтами в прикладном решении "1С:ERP Управление предприятием"
https://infostart.ru/public/861043/


Аудитория курса
Курс ориентирован на пользователей ситемы, а также для подготовки к экзамену 1С:Профессионал
Объем курса
Видеокурс - 15 часа видеолекций / Онлайн-курс - 32 уч.ч

Расписание курса
Вы можете смотреть видеолекции курса в любое удобное время, доступ к материалам предоставляется на 90 дней
Онлайн-занятия проходят 4 дня, с 10 до 17 мск.
Даты: 27-30 января, 25-28 февраля, 16-19 марта.
83. Светлый ум 259 24.12.19 05:25 Сейчас в теме
84. Светлый ум 259 24.12.19 10:03 Сейчас в теме
Партионный учет товаров в конфигурациях УТ, КА, ЕРП
https://infostart.ru/public/955808/
85. Светлый ум 259 24.12.19 10:09 Сейчас в теме
Бюджетирование:

1) Бюджетирование и бюджетное планирование. Теория
https://infostart.ru/public/400683/

2) Еще о бюджетном управлении
https://infostart.ru/public/66629/

3) Диалоги о бюджетировании
https://infostart.ru/public/343440/

4) Бюджетирование - объект автоматизации. Часть 1. Актуальное из практики (от автора табулы/фин-план)
https://infostart.ru/public/1105692/
87. Светлый ум 259 24.12.19 13:01 Сейчас в теме
(85) 2.1) Что такое бюджетирование и подходы к его автоматизации
https://infostart.ru/public/66601/
88. Светлый ум 259 13.01.20 04:49 Сейчас в теме
https://forum.infostart.ru/forum15/topic187386/

Инструкция по переходу на с УТ 10.3 на УНФ 1.6
89. Светлый ум 259 13.01.20 11:29 Сейчас в теме
Анкета предпроектного обследования
https://infostart.ru/public/561378/
90. Светлый ум 259 14.01.20 13:29 Сейчас в теме
Настройки внешних отчетов и обработок для подключения в базу (БСП)

0) пример отчета СКД - можно взять из БСП "_ДемоОтчетПоСчетамНаОплатуКонтекстный_БСП" (подменив запрос на более простой)

1) пример обработки: https://infostart.ru/public/84001/

2) общее описание подхода, с шаблонами отч.,обр., впф : https://infostart.ru/public/558559/
91. Светлый ум 259 15.01.20 07:52 Сейчас в теме
(90) По примеру статьи создания болванки создания и регистрации внешней обработки:
https://wiseadvice-it.ru/o-kompanii/blog/articles/vneshnyaya-obrabotka-v-1s-8-3/

Итоговая процедура регистрации:
(добавляем ее в модуль объекта и больше ничего - все будет работать)

Функция СведенияОВнешнейОбработке() Экспорт
	
	ДанныеДляРег = Новый Структура();
	ДанныеДляРег.Вставить("Наименование","Новая внешняя обработка");
	ДанныеДляРег.Вставить("БезопасныйРежим", Истина);
	ДанныеДляРег.Вставить("Назначение", Новый Массив);
	ДанныеДляРег.Вставить("Информация", НСтр("ru = '""Болванка""'"));	
	//ДанныеДляРег.Вставить("ВерсияБСП", "2.1.2.1");
	ДанныеДляРег.Вставить("Версия", "1.0.0.1");
	ДанныеДляРег.Вставить("Вид", Перечисления.ВидыДополнительныхОтчетовИОбработок.ДополнительнаяОбработка);
	ТабЗнКоманды = Новый ТаблицаЗначений;
	ТабЗнКоманды.Колонки.Добавить("Идентификатор");
	ТабЗнКоманды.Колонки.Добавить("Использование");
	ТабЗнКоманды.Колонки.Добавить("Представление");
	НовСтрока = ТабЗнКоманды.Добавить();
	НовСтрока.Идентификатор = "НоваяВнешняяОбработка";
	НовСтрока.Использование = "ОткрытиеФормы";
	НовСтрока.Представление = "Новая внешняя обработка";
	ДанныеДляРег.Вставить("Команды", ТабЗнКоманды);
	Возврат ДанныеДляРег;
	
КонецФункции
Показать
92. cprit 348 20.01.20 16:03 Сейчас в теме
Добрый день!
Можем ли мы использовать размещенные тут разработки в свободно распространяемой подсистеме https://github.com/cpr1c/tools_ui_1c?

И если да, то можно ли без старт мани получить их? В первую очередь интересуют Отключение пользователей управляемые формы, ЗапускПодПользователем - Управляемые формы, КонсольЗапросов_УФ_83,
Удобная читалка XML в 1С 8.2 (обычные формы),ОтладкаВнешнейПечатнойФормы.82(если она для БСП)
93. Светлый ум 259 31.01.20 11:58 Сейчас в теме
Оформление динамических списков, по примеру статьи с зазеркалья:
https://wonderland.v8.1c.ru/blog/obrabotka-i-oformlenie-dannykh-dinamicheskogo-spiska/

//Задает оформление списку и изменяем строки динамического списка
&НаСервереБезКонтекста
Процедура СписокПриПолученииДанныхНаСервере(ИмяЭлемента, Настройки, Строки)
	
	Запрос = Новый Запрос;
	Запрос.УстановитьПараметр("ДС_Ключи", Строки.ПолучитьКлючи());
	Запрос.Текст = 
	"ВЫБРАТЬ РАЗЛИЧНЫЕ
	|	СправочникСЗ.Ссылка КАК Ссылка
	|ИЗ
	|	СправочникСЗ КАК СправочникСЗ
	|ГДЕ
	|	СправочникСЗ.Ссылка В(&ДС_Ключи)";	
	ВыборкаДетальныеЗаписи = Запрос.Выполнить().Выбрать();
	
	Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
		
		ТекущаяСтатья = ВыборкаДетальныеЗаписи.Ссылка;
		СтрокаСписка  = Строки[ВыборкаДетальныеЗаписи.Ссылка];
		
		//1.Получаем список ЧегоЛибо
		"ВЫБРАТЬ ПЕРВЫЕ 5"	
		
		ВыборкаЦДЗ                   = ЗапросЦО.Выполнить().Выбрать();
		Если ВыборкаЦДЗ.Количество() = 0 Тогда 
			//Выделяем цветом не принадлижащих к консолидирующему предприятию
			Попытка
				СтрокаСписка.Оформление["Код"].УстановитьЗначениеПараметра("ЦветТекста",   WebЦвета.НейтральноСерый);
				СтрокаСписка.Оформление["Наименование"].УстановитьЗначениеПараметра("ЦветТекста",     WebЦвета.НейтральноСерый);
				СтрокаСписка.Оформление["Код_A"].УстановитьЗначениеПараметра("ЦветТекста",     WebЦвета.НейтральноСерый);
				СтрокаСписка.Оформление["Код_B"].УстановитьЗначениеПараметра("ЦветТекста",     WebЦвета.НейтральноСерый);
				СтрокаСписка.Оформление["ПредставлениеЦФО"].УстановитьЗначениеПараметра("ЦветТекста", WebЦвета.НейтральноСерый);
				СтрокаСписка.Оформление["Ответственный"].УстановитьЗначениеПараметра("ЦветТекста",    WebЦвета.НейтральноСерый);
			Исключение
			КонецПопытки;	
			
			Продолжить;
			
		КонецЕсли;		
		
		ПредставлениеСтрокой                     = "";
		ПредставлениеЦО_Строкой                  = "";
		ПредставлениеРуководителя                = "";
		ПринадлежитКонсолидирующемуПредприятию   = Ложь;	
		
		ТаблицаОтветственных = Новый ТаблицаЗначений;
		СтрокаСписка.Данные["ПредставлениеЦО"] = ПредставлениеСтрокой;
		
		//Выделяем цветом не принадлижащих к ЦО
		Если НЕ ПринадлежитК_ЦО Тогда 
			Попытка //исключение ошибок при перестроении списка
			СтрокаСписка.Оформление["Код"].УстановитьЗначениеПараметра("ЦветТекста",   WebЦвета.НейтральноСерый);
			СтрокаСписка.Оформление["Наименование"].УстановитьЗначениеПараметра("ЦветТекста",     WebЦвета.НейтральноСерый);
			СтрокаСписка.Оформление["Код_А"].УстановитьЗначениеПараметра("ЦветТекста",     WebЦвета.НейтральноСерый);
			СтрокаСписка.Оформление["Код_В"].УстановитьЗначениеПараметра("ЦветТекста",     WebЦвета.НейтральноСерый);
			СтрокаСписка.Оформление["ПредставлениеЦО"].УстановитьЗначениеПараметра("ЦветТекста", WebЦвета.НейтральноСерый);
			СтрокаСписка.Оформление["Ответственный"].УстановитьЗначениеПараметра("ЦветТекста",    WebЦвета.НейтральноСерый);
			Исключение
			КонецПопытки;
		КонецЕсли;		
				
	КонецЦикла;	
	
КонецПроцедуры
Показать
94. Светлый ум 259 07.02.20 07:43 Сейчас в теме
https://infostart.ru/journal/news/mir-1s/o-nachale-prodazh-onlayn-produkta-1s-baza-znaniy-po-metodologiyam-vnedreniya-i-soprovozhdeniya_1191374/

//Как приобрести
Продажа осуществляется только официальным пользователям программных продуктов 1С, зарегистрированным на территории Российской Федерации сроком на 12 месяцев (доступно продление неограниченное количество раз) с доступом до 5 пользователей за 22 500 руб. Тестовый доступ к продукту не предусмотрен.

Про «1С:Технологию корпоративного внедрения 2.0»
«1С:Технология корпоративного внедрения 2.0» разработана на основании положений отечественных и международных стандартов и сводов знаний, «лучших практик», документов и материалов фирмы «1С», отечественном опыте реализации проектов создания и внедрения информационных систем на базе программных продуктов фирмы «1С» с целью:

определения общих подходов к выполнению проектов создания и внедрения информационных систем;
повышения эффективности организации и управления проектами;
обеспечения качества внедрений программных продуктов фирмы «1С» и повышение удовлетворенности заказчиков.
1С:ТКВ включает в себя:

рекомендации по организации и применению основных процессов (процессов создания результатов) проекта:
описание жизненного цикла проекта (ЖЦП) создания и внедрения ИС;
описание регулярных мероприятий управления проектами;
описание работ по блоку «Производительность системы»;
описание работ по блоку «Информационная безопасность»;
авторский надзор фирмы «1С»;
роли и основные обязанности участников команды проекта.
48 шаблонов документов, включая:
План-график и бюджет проекта,
Полный пакет документов управления проектом,
Концепции, проектные решения;
29 примеров документов, включая:
План-график и бюджет проекта,
Полный пакет документов управления проектом;
Базу знаний по рискам проекта.
95. Светлый ум 259 07.02.20 10:58 Сейчас в теме
//ВПФ на СКД

	СсылкаНаОбъектПФ = Объект.Ссылка;
	
	ПечатнаяФормаВыгрузкаExcel.Очистить();
	ДокСсылка             = СсылкаНаОбъектПФ;
	
	СхемаКомпоновкиДанных = Документы.Экземпляр.ПолучитьМакет("ПечатнаяФорма1");
	
	КолонкиТаблицыДанныхВидаБюджета = СформироватьКолонкиТаблицы();
	Периодичности     = Новый Массив;
	МассивПериодов  = ПериодыОтчета(НачалоПериода, ОкончаниеПериода, МинимальнаяПериодичность);
	
	МассивПериодовТаблицей = ВернутьТаблицуПериодов(МассивПериодов);
	НаборыДанных           = Новый Структура("Периоды", МассивПериодовТаблицей);
	
	Настройки = СхемаКомпоновкиДанных.НастройкиПоУмолчанию;
	Настройки.ПараметрыДанных.УстановитьЗначениеПараметра("Ссылка", ДокСсылка);
	Настройки.ПараметрыДанных.УстановитьЗначениеПараметра("Ответственный", Ответственный);
	Настройки.ПараметрыДанных.УстановитьЗначениеПараметра("Валюта", Валюта);
	Настройки.ПараметрыДанных.УстановитьЗначениеПараметра("Подразделение", Подразделение);	
	Настройки.ПараметрыДанных.УстановитьЗначениеПараметра("ОтборУслОформлВид2", 2);

	КомпоновщикНастроек = Новый КомпоновщикНастроекКомпоновкиДанных();
	КомпоновщикНастроек.ЗагрузитьНастройки(Настройки);
	
	НастройкиКомпоновщика     = КомпоновщикНастроек.Настройки;
	КомпоновщикМакета         = Новый КомпоновщикМакетаКомпоновкиДанных;
	МакетКомпоновки           = КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных, НастройкиКомпоновщика);
	ПроцессорКомпоновкиДанных = Новый ПроцессорКомпоновкиДанных;
	
	ПроцессорКомпоновкиДанных.Инициализировать(МакетКомпоновки, НаборыДанных);
	
	ДокументРезультат         = ПечатнаяФормаВыгрузкаExcel;
	ПроцессорВывода           = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
	ПроцессорВывода.УстановитьДокумент(ДокументРезультат);
	
	ПроцессорВывода.Вывести(ПроцессорКомпоновкиДанных);	
	Возврат ДокументРезультат; //ТабДок
Показать
96. Светлый ум 259 10.02.20 10:45 Сейчас в теме
Код-ревью - правильный подход к написанию КОДа
https://infostart.ru/public/1089005/

как его ввести у себя
https://infostart.ru/public/1093475/

аналог с хабра
https://habr.com/ru/post/250489/
97. Светлый ум 259 20.02.20 11:38 Сейчас в теме
Управление формами из общего модуля
https://infostart.ru/public/199480/
+1
98. Светлый ум 259 21.02.20 10:55 Сейчас в теме
Универсальный обмен данными XML (с гибкими отборами и сохранением вариантов настроек)

1. Установка произвольных фильтров на выгружаемые объекты при помощи механизма системы компоновки данных
2. Сохранение различных вариантов настроек (сохраняются правила обмена, фильтры выгрузки, параметры, настройки обработки) - что позволяет гибко настроить в базе-источнике фильтры для выгрузки объектов по различным правилам обмена для различных баз-приемников, сохранить выполненные настройки и в будущем уже пользоваться этими вариантами настроек.

Проверялась на 1С:ERP

https://infostart.ru/public/1055196/

https://github.com/cpr1c/tools_ui_1c/commit/fddeb56f41c54109c8b59cfab1fa92c­f0bdd33d5#diff-f5780bde728f88ba3c3c27c8a8ae5c16
99. Светлый ум 259 21.02.20 12:15 Сейчас в теме
взято с https://infostart.ru/public/118784/ - рабочий вариант,
взято от сюда http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=625538

&НаКлиенте
Процедура ОткрытьФормуНового(Команда)
 
               Форма = ПолучитьФорму("Документ.ПродажаТоваровУслуг.Форма.ФормаДокумента");
               ДанныеФормы = Форма.Объект;
               ЗаполнитьНаСервере(ДанныеФормы);
               КопироватьДанныеФормы(ДанныеФормы, Форма.Объект);
               Форма.Открыть();
 
КонецПроцедуры
 
&НаСервере
Процедура ЗаполнитьНаСервере(НовыйОбъект)
               НовыйОбъект.Контрагент = Справочники.Контрагенты.НайтиПоКоду("000000005");          
КонецПроцедуры
Показать
Оставьте свое сообщение

См. также

Загрузка табелей рабочего времени из файлов Excel Промо

Зарплата Обработка документов Учет рабочего времени Загрузка и выгрузка в Excel v8 v8::СПР ЗУП3.x Россия БУ Абонемент ($m)

Обработка по загрузке в типовой документ «Табель» конфигурации ЗУП 3.1 данных из файлов MS Excel, согласно шаблону.

18.10.2019    8753    5    HostHost    0    

Списание (корректировка) задолженности контрагентов УНФ 1.6

Закрытие периода Дебиторская и кредиторская задолженность Обработка документов Дебиторская и кредиторская задолженность v8 УНФ Украина БУ Абонемент ($m)

Обнуление задолженности контрагентов в конфигурации "Управление небольшой (нашей) фирмой" версии 1.6 с помощью документа "Корректировка регистров".

1 стартмани

24.07.2019    20264    13    DMon    1    

Регистрация документов с измененной суммой

Обработка документов v8 1cv8.cf Абонемент ($m)

Обработка берет информацию из истории изменения документов. Удобна для администраторов, когда документы с измененной суммой по какой-то причине не регистрируются в плане обменов. Можно регистрировать не все документы, а только те, которые были изменены.

1 стартмани

20.04.2019    17226    3    ryan    0    

Блин, мы забыли включить регламентные задания…

Сервисные утилиты v8 Абонемент ($m)

Привет, Инфостарт! Сегодня расскажу, как я решил проблему с выключенными регламентными заданиями в рабочих базах. Желая исключить человеческий фактор и минимизировать количество ошибок, я написал небольшую конфигурацию.  В конфигурации два регламентных задания. Первое периодически подключается к кластеру и сохраняет текущие параметры: имя, Сервер БД, базу СУДБ, блокировки входа и регламентных заданий и т.д. Второе задание периодически проверяет эти параметры на ошибки.

1 стартмани

08.04.2019    15905    15    slozhenikin_com    37    

StartManager 1.4 - Развитие альтернативного стартера Промо

Стартеры 1С v7.7 v8 Абонемент ($m)

Очередная редакция альтернативного стартера, являющегося продолжением StartManager 1.3. Спасибо всем, кто присылал свои замечания и пожелания, и тем, кто перечислял финансы на поддержку проекта. С учетом накопленного опыта, стартер был достаточно сильно переработан в плане архитектуры. В основном сделан упор на масштабируемость, для способности программы быстро адаптироваться к расширению предъявляемых требований (т.к. довольно часто просят добавить ту или иную хотелку). Было пересмотрено внешнее оформление, переработан существующий и добавлен новый функционал. В общем можно сказать, что стартер эволюционировал, по сравнению с предыдущей редакцией. Однако пока не всё реализовано, что планировалось, поэтому еще есть куда развиваться в плане функциональности.

1 стартмани

23.04.2014    117935    777    Alexoniq    1536    

Валовая прибыль для УПП 1.3, КА 1.1 в режиме РАУЗ (работа типового отчета без доработок конфигурации)

Обработка документов v8 КА1 УПП1 УУ Абонемент ($m)

Простое и мгновенное решение для использования типового отчета "Валовая прибыль" в конфигурациях "Управление производственным предприятием 1.3", "Комплексная автоматизация 1.1" (а также отраслевых решений на их базе) при включенном режиме РАУЗ (расширенная аналитика учета затрат). Не требует настройки или изменения конфигурации, либо может быть, для дополнительного удобства, интегрировано в нее с минимальными доработками.

2 стартмани

21.01.2019    17445    20    stvorl    11    

Легкое и гибкое управление списком доступных баз 1С у пользователей

Стартеры 1С Сервисные утилиты Администрирование СУБД v8 1cv8.cf Россия Абонемент ($m)

Когда в локальной сети много пользователей, а еще большое количество различных баз и при этом каждому нужны свои, то администрирование этого зоопарка превращается в АД! Этот комплекс позволяет централизованно управлять списком доступных баз в разрезе пользователей. За пару кликов можно добавить или убрать базу у всех пользователей.

5 стартмани

05.12.2018    14471    16    RomikR    9    

Многопоточная обработка данных

Производительность и оптимизация (HighLoad) Администрирование данных 1С v8 v8::УФ 1cv8.cf Абонемент ($m)

Конфигурация "Универсальные механизмы: пакеты данных". Набор инструментов для быстрой организации отказоустойчивой многопоточной обработки данных.

1 стартмани

23.11.2018    19302    56    _ASZ_    15    

Правильные аналоги номенклатуры (кроссы запчастей) для 1С / Управляемые формы Промо

Обработка справочников Оптовая торговля Учет ТМЦ Оптовая торговля Учет ТМЦ v8 v8::УФ 1cv8.cf УУ Абонемент ($m)

По опыту работы с запчастями много раз сталкивался с проблемой организации кроссов в разных 1С - от записи артикулов через запятую в текстовом поле до хранения кроссов в документах. Предлагаю одну из простейших и функциональных на мой взгляд схем "одноуровневого" хранения кроссов.

5 стартмани

29.07.2015    32170    8    taurus__    22    

Обнуление остатков регистров бухгалтерии и накопления

Универсальные обработки Чистка базы v8 v8::БУ v8::ОУ v8::УФ КА1 БП2.0 ЗУП2.5 УТ10 УПП1 УНФ БГУ ERP2 БП3.0 УТ11 УХ КА2 ЗУП3.x Россия Абонемент ($m)

Обработка позволяет обнулить остатки по регистру накопления или бухгалтерии на определенную дату. Поддерживается большинство типовых конфигураций (БП 3, БП 2, УТ 11, УТ 10, ЗУП 3, ЗУП 2, БГУ 2, БГУ 1, ERP, УПП, КА 2, КА 1, УХ 3, УХ 1, УНФ). Гибкая настройка (отборы, заполнение реквизитов и любых полей корр. счета, возможность обнулять ресурсы выборочно). Несколько режимов работы. Два интерфейса: простой и с расширенным набором настроек.

2 стартмани

19.11.2018    20988    271    morozov.sv    50    

Очистка кэша 1С 8 (8.0, 8.1, 8.2, 8.3). Грамотная чистка кэша 1С с сохранением настроек.

Чистка базы Сервисные утилиты Администрирование данных 1С v8 1cv8.cf Россия Абонемент ($m)

Эффективное средство для устранения ошибок, возникающих в локальном кэше 1С на клиенте, которым легко сможет воспользоваться пользователь с любым уровнем знаний. Wsf-скрипт, созданный на стандартном языке автоматизации Windows - "WSH JScript", очищает кэш 1С просто, быстро и безопасно. Кроме варианта, очищающего кэш текущего пользователя, имеется также вариант для чистки кэша 1С всех пользователей терминального-сервера.

1 стартмани

04.11.2018    35385    365    Eugen-S    34    

Универсальный инструмент для переноса данных через табличный документ (УФ)

Обработка документов Универсальные обработки Обработка справочников v8 v8::УФ 1cv8.cf Абонемент ($m)

Для опытных пользователей, разработчиков, администраторов, консультантов

5 стартмани

15.10.2018    31461    115    json    36    

Очистка регистрации обмена Промо

Чистка базы v8 v8::ОУ УТ10 Абонемент ($m)

Данная обработка предназначена для очистки узла. Для очистки необходимо указать период,организацию.

1 стартмани

19.09.2017    16289    5    serg-lom89    0    

TextRadar - нечеткий поиск в тексте

Разработка внешних компонент Поиск данных v8 1cv8.cf Абонемент ($m)

В отличие от нечеткого сравнения строк, когда обе сравниваемых строки равнозначны, в задаче нечеткого поиска выделяются строка поиска и строка данных, а вычислить необходимо не степень похожести двух строк, а степень присутствия строки поиска в строке данных. Нормированный коэффициент, находящийся между 0 и 1 позволяет отсечь заведомо низкие результаты, организовать поиск по синонимам и т.д. Наглядное отображение результатов в кратком и детальном виде поможет быстро найти интересующий фрагмент.

1 стартмани

19.09.2018    16017    18    TSSV    18    

Помощник корректировки остатков ЕГАИС в небольшом магазине. Розница 2.2

Розничная торговля Обработка документов Розничная торговля v8 Розница Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Россия УУ Абонемент ($m)

Данная обработка упрощает корректировку остатков алкогольной продукции небольшого магазина, где предполагается передача всей продукции в торговый зал сразу после приемки.

5 стартмани

08.09.2018    30354    82    asdfgcom    46    

Расширение резервов отпусков

Обработка документов Зарплата Зарплата v8 v8::СПР ERP2 ЗКГУ3.0 ЗУП3.x Россия БУ Абонемент ($m)

Произвольная настройка базы для расчета резервов отпусков.

2 стартмани

10.08.2018    24749    51    СергейКа    16    

Помощник по закрытию месяца для УТ 11.3 Промо

Закрытие периода Обработка документов Закрытие периода Закрытие периода v8 v8::ОУ УТ11 Россия УУ Абонемент ($m)

Помощник по закрытию месяца для УТ 11.3. Имеет две функции: обнуление товаров "К оформлению" в интеркампани и обнуление отрицательных остатков в регистре "Себестоимость товаров".

5 стартмани

10.11.2017    22043    26    Zalipaka    1    

Очистка периодических регистров посредством T-SQL (удаление записей, кроме среза последних)

Чистка базы v8 Абонемент ($m)

Обработка для ленивых. Составит вместо Вас запрос для SQL, который удалит все не актуальные записи (т.е все, кроме среза последних)

5 стартмани

22.06.2018    15145    19    Alexander.Shvets    9    

Автоматическое заполнение графиков в ЗУП 3.1

Зарплата Учет рабочего времени Обработка справочников Зарплата Учет рабочего времени v8 v8::СПР ЗУП3.x Россия БУ Абонемент ($m)

Данная разработка будет актуальна для организаций с большим количеством графиков (несколько десятков/сотен).

1 стартмани

05.05.2018    22528    18    notserioussam    2    

Добавление возможности в конфигурации ЗУП 3.1 работать с фотографиями сотрудников (Зарплата и Управление Персоналом, редакция 3.1)

Обработка справочников Управление персоналом (HRM) Управление персоналом (HRM) v8 v8::СПР ЗУП3.x БУ Абонемент ($m)

Добавление возможности в ЗУП 3.1 работать с фотографиями сотрудников (физических лиц). Расширение тестировалось на релизе ЗУП 3.1.5.129.

1 стартмани

09.04.2018    28428    67    charivnick    3    

Удаление помеченных объектов, замена ссылок. Обычное и управляемое приложение. Не монопольно, включая рекурсивные ссылки, с отбором по метаданным и произвольным запросом Промо

Чистка базы v8 1cv8.cf Абонемент ($m)

Обработка удаления помеченных объектов с расширенным функционалом. Работает в обычном и управляемом приложении. Монопольный и разделенный режим работы. Отображение и отбор по структуре метаданных. Отборы данных произвольными запросами. Копирование и сохранение отборов. Удаление циклических ссылок (рекурсия). Представление циклических в виде дерева с отображением ключевых ссылок, не позволяющих удалить текущий объект информационной базы. Удаление записей связанных независимых регистров сведений. Групповая замена ссылок. Индикатор прогресса при поиске и контроле ссылочности.

10 стартмани

31.10.2016    49875    582    m..adm    210    

Корректировка остатков ЕГАИС, возврат из регистра 2, загрузка ТТН из файлов, другое для УТ10.3

Розничная торговля Обработка документов Розничная торговля v8 v8::ОУ УТ10 Россия БУ Абонемент ($m)

Набор обработок для автоматизации работы с ЕГАИС: Обработка корректировки остатков ЕГАИС для УТ 10.3, аналогичная имеющимся в УТ 11, Рознице 2.2. Автоматически формирует документы "Передача в торговый зал", "Акт постановки на баланс в торговом зале", "Акт списания в торговом зале". Обработка возврата из регистра 2 с подбором справок Б. Обработка формирования ТТН из файлов xml.

1 стартмани

24.01.2018    33350    27    biz-intel    3    

Расчет начисления зарплаты со сложной формулой, по данным из внешнего источника. ЗУП 3.1

Обработка документов Загрузка и выгрузка в Excel Зарплата Зарплата v8 v8::СПР ЗКГУ3.0 ЗУП3.x БУ Абонемент ($m)

Расчет начисления зарплаты со сложной формулой, по данным из внешнего источника по данным экономического отдела. ЗУП 3.1.

3 стартмани

20.12.2017    46113    31    mvv1975    7    

Корректировка остатков регистров бухгалтерии (обычные и управляемые формы) Промо

Свертка базы Универсальные обработки Закрытие периода Чистка базы v8::БУ v8::УФ 1cv8.cf БУ НУ Абонемент ($m)

Внешняя обработка, предназначенная для удобного исправления остатков по регистрам бухгалтерии (Хозрасчетный, Налоговый или любой другой) посредством автоматизации ввода корректировочного документа ("Операция", "Корректировка записей регистров"), приводящего регистр в нужное состояние остатков от текущего. Удобна для массовых правок остатков по бухгалтерскому и налоговому учету на какую-то дату (обычно перед реорганизацией учета, сверткой базы и т.п.)

2 стартмани

03.06.2017    29743    157    stvorl    25    

История формирования отчётов. (Используем новые возможности расширений в 8.3.11)

Журнал регистрации v8::УФ v8::СКД УНФ ДО БП3.0 УТ11 ЗУП3.x Абонемент ($m)

Подсистема ведёт историю формирования отчётов и позволяет быстро подгрузить используется настройки в отчёт.

1 стартмани

28.11.2017    14154    19    SeiOkami    1    

Копирование меню в Трактир Management

Обработка документов Производство готовой продукции (работ, услуг) Производство готовой продукции (работ, услуг) v8 1cv8.cf Рестораны, кафе и фаст-фуд Россия УУ Абонемент ($m)

Механизм копирования меню в Трактир Management. Данная обработка расширяет функционал типового решения Трактир Management, позволяя быстро вводить в эксплуатацию новую точку путём создания нового меню на основании имеющегося.

1 стартмани

28.11.2017    26634    4    integrator1983    0    

Быстрое удаление неиспользуемых версий 1С:Предприятие 8, кэша метаданных и информационных баз

Сервисные утилиты v8 Абонемент ($m)

При обновлении платформы 1С:Предприятие 8 предыдущие версии не удаляются. Со временем количество неиспользуемых версий платформы растет. Они занимают место на диске. Для решения этой проблемы предназначена программа OneCleaner. Она позволяет быстро удалить неиспользуемые версии платформы, а также почистить кэш метаданных и удалить ненужные информационные базы данных.

1 стартмани

14.11.2017    20767    88    bonv    15    

Прыг-Скок...или из MS EXCEL в 1С (8.2) (открытый код) Промо

Обработка документов Обработка справочников Загрузка и выгрузка в Excel v8 1cv8.cf Абонемент ($m)

Универсальная загрузка данных из Microsoft Office Excel. Автоматическая загрузка из любых по форме документов с очень удобным редактором. Почти готовый шаблон для любой конфигурации. Не требует регистрации-бесплатно.

1 стартмани

16.09.2015    60952    353    Tatitutu    48    

Закрываем всплывающие сообщения платформы

Сервисные утилиты v8::УФ Абонемент ($m)

Принудительное закрывание сообщений платформы 8.3.10.

1 стартмани

10.11.2017    12313    13    RomaH    8    

Загрузка дополнительных реквизитов и сведений справочника Номенклатура из Excel и таблиц УТ 11, ERP 2

Обработка справочников Загрузка и выгрузка в Excel Учет ТМЦ Учет ТМЦ v8 v8::ОУ ERP2 УТ11 Россия УУ Абонемент ($m)

Внешняя обработка "Загрузка дополнительных реквизитов и сведений справочника Номенклатура"

1 стартмани

07.08.2017    38281    241    Windyhead    32    

Перемещение остатков по счету МЦ04 между материально ответственными лицами для конфигураций (8.2). Промо

Обработка документов Универсальные обработки Учет ТМЦ Учет ТМЦ v8 БП2.0 Россия БУ Абонемент ($m)

Небольшая обработка, которая позволяет перекидывать остатки по счету МЦ04 с одного материально ответственного лица на другое

1 стартмани

22.11.2012    13524    13    niksaf    4    

Упрощение работы с актами сверки в УТ/КА/УПП - вывод номеров счетов в документе и печатной форме

Обработка документов Печатные формы документов Дебиторская и кредиторская задолженность Дебиторская и кредиторская задолженность v8 КА1 УТ10 УПП1 БУ УУ Абонемент ($m)

Обычно акт сверки с клиентами содержат информацию о документах реализации товаров (накладных) и выполненных платежах. Но платежи делаются на основании счетов, номера которых отсутствуют в актах, что затрудняет собственно сверку. Данная обработка находит соответствующие расходным накладным счета/заказы, показывает их в форме документа и выводит в печатную форму акта.

2 стартмани

12.05.2017    28582    4    denmax    2    

Автокликер для 1С

Сервисные утилиты v8 1cv8.cf Абонемент ($m)

Внешняя обработка, запускаемая в обычном (неуправляемом) режиме для автоматизации действий пользователя (кликер). ActiveX компонента, используемая в обработке, получает события от клавиатуры и мыши по всей области экрана в любом приложении и транслирует их в 1С, получает информацию о процессах, текущем активном приложении, выбранном языке в текущем приложении, умеет сохранять снимки произвольной области экрана, активных окон, буфера обмена, а также, в режиме воспроизведения умеет активировать описанные выше события. Все методы и свойства компоненты доступны при непосредственной интеграции в 1С. Примеры обращения к компоненте представлены в открытом коде обработки.

1 стартмани

03.04.2017    29877    70    slava_1c    49    

Загрузка номенклатуры по штрихкоду: Управление Торговлей 11.3; Розница 2.2; Розница для Казахстана 2.2

Обработка справочников Оптовая торговля Розничная торговля Ценообразование, анализ цен Ценообразование, прайсы Оптовая торговля Розничная торговля Ценообразование, анализ цен v8 v8::ОУ v8::УФ Розница УТ11 Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Россия УУ Абонемент ($m)

Розница 2.2, Управление Торговлей 11.3. Создание номенклатуры из интернета с помощью сканера штрихкодов либо терминала сбора данных. Варианты создания, автовыбор наилучшей позиции, источники, цены, загрузка картинки - всё это очень гибко и просто настраивается. Текущие открытые источники: barcode-list.ru(на текущий момент не работает); goodsmatrix.ru; ean13.info(может не работать капча); barcodes.olegon.ru. Автор программы не несёт ответственность за информацию, предоставляемую перечисленными выше открытыми источниками, так же не отвечает за их работоспособность. Данные источники принадлежат не автору программы. Данная программа нужна лишь для автоматизированного поиска информации на них.

10 стартмани

30.03.2017    56723    121    myALKleon    40    

DroidRAC2 - консоль администрирования кластера серверов 1С:Предприятие 8.3 под Android

Администрирование данных 1С v8 1cv8.cf Абонемент ($m)

DroidRAC2 - клиент для RAS-сервиса кластера серверов платформы 1С:Предприятие 8.3 под Android.

1 стартмани

24.02.2017    21132    9    user700211_a.straltsou    12    

Статистика базы данных с отбором по подсистемам (кол-во и открытие списков: документов, справочников, регистров) и анализ наличия основных реквизитов: универсальная обработка (два файла - обычный и управляемый режим)

Статистика базы данных v8 v8::УФ 1cv8.cf Россия Абонемент ($m)

Универсальная обработка для статистики базы данных (документы, справочники, регистры, отчеты) с отбором по подсистемам и с анализом наличия основных реквизитов (организации, контрагенты, договора, номенклатура, сотрудники, физлица, валюта). Возможность просмотра списка документов или справочников или регистров при активизации в колонке "Документы, справочники, регистры, отчеты" в текущей строке. Полезная обработка для консультации пользователей, где искать метаданные в каком интерфейсе, т.к. подсистема указывает в каком интерфейсе находятся метаданные (документы, справочники, регистры, отчеты).

1 стартмани

20.02.2017    17084    47    strelec13    11    

Определение ИНН Сотрудника (service.nalog.ru). ЗУП, редакция 3.1 и 2.5 (Проф и Корп)

Обработка справочников Управление персоналом (HRM) Управление персоналом (HRM) v8 v8::СПР ЗУП2.5 Россия БУ Абонемент ($m)

Внешняя печатная форма для справочника "Сотрудники организаций". ЗУП, редакция 3.1 и 2.5 (Проф и Корп)

1 стартмани

03.02.2017    71268    49    Indgo    33    

Корректировка остатков по акцизным маркам ЕГАИС для Розницы 2.2

Розничная торговля Обработка документов Розничная торговля v8::ОУ v8::УФ Розница Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд УУ Абонемент ($m)

Розница 2.2. Корректировка остатков ЕГАИС. Пользователю необходимо считать все акцизные марки каждой бутылки, это даёт 100% точность инвентаризации (корректировки). Обработка приведёт остатки ЕГАИС к тем, которые вы занесёте (к фактическим). Останавливать продажи и работу кассиров не требуется, ведь есть функция удаления марки из нашего документа. Обработка по акцизной марке понимает, что это за бутылка. Если данных по бутылке нет, они запрашиваются в ЕГАИС. Если акцизную марку уже считывали, она не даст считать её повторно.

10 стартмани

26.12.2016    32939    63    myALKleon    62    

Редактор движений документа. Сохранение в XML, обмен между базами, замена регистратора.

Обработка документов Универсальные обработки Обмен через XML v8 Абонемент ($m)

Редактор набора записей движений документа. Позволяет сохранить набор записей в XML, в настройки пользователя, прочитать сохраненный XML в другой идентичной базе, заменить регистратор. Можно изменять порядок записей, менять активность, как массово, так и по одной и др. Тонкий клиент, управляемые формы.

1 стартмани

07.09.2016    39828    154    Aphanas    4    

Универсальный поиск объектов по глобальному уникальному идентификатору (ГУИД, GUID)

Универсальные обработки Поиск данных v8 v8::УФ 1cv8.cf Абонемент ($m)

Универсальная обработка поиска объектов информационной базы по глобальному уникальному идентификатору (ГУИД, GUID) или по его части.

1 стартмани

06.09.2016    31863    103    Dzenn    9    

Лекарство на случай, если перестала работать форма списка для сделок. (ERP).

Тестирование и исправление v8 ERP2 Абонемент ($m)

Форма списка справочник сделки стала выпадать с ошибкой?  Или все еще в порядке, но хочется спокойно съездить в отпуск, без паники, что менеджеры устроят бунт.

1 стартмани

28.07.2016    21416    0    milkers    2    

Многопоточное удаление объектов

Чистка базы v8 1cv8.cf Абонемент ($m)

Обработка предназначена для ускорения процедуры удаления объектов

2 стартмани

02.06.2016    24478    53    zzz_natali    20