Технология кэширования результата разузлования продукции по спецификации

Публикация № 1011273

Разработка - Практика программирования

УПП разузлование продукции спецификация кэширование производство производственный учет

Рассматривается технология кэширования результата разузлования продукции по спецификации. Данная технология может оказаться полезной для значительного ускорения работы системы в части разузлования в конфигурациях УПП. Тестировалось на платформе 1С 8.3.12.1469, релизы УПП 1.2, 1.3.

Все, кто плотно занимались производственным учетом в конфигурации УПП, знают о вопросе разузлования продукции по спецификации. В случае использования сложных спецификаций, с использованием формул, узлов, время на разузлование тратится очень много. А необходимость в разузлованиях возникает довольно часто.

И в голову пришла мысль - почему бы не использовать кэширование полученной на выходе таблицы материалов, чтобы при последующих разузлованиях продукции использовать ее, а не производить заново весь расчет. Скорость разузлования предсказуемо вырастет на порядок и больше (в зависимости от сложности спецификаций)!
Но все оказалось очень непросто..

Очевидно, что для хранения и использования результата разузлования нужен регистр сведений.

В качестве измерений будут объект разузлования (Номенклатура, Характеристика) и спецификация.

Ресурс - таблица материалов, в которой будут храниться рассчитанные по спецификации материалы.

Однако выяснилось, что результат разузлования при расчете зависит еще и от параметров, таких как КоличествоУровнейРазузлования, ПараметрыВыпуска и т.д.

Соответственно нужно добавлять еще одно измерение. Было решено, что оптимальнее формировать уникальный строковый хэш параметров (модули функций формирования хэша содержатся в приложенной к статье конфигурации). В результате регистр выглядит так:

Регистр сведений КЭШ_Разузлование

Измерения:
- Номенклатура
- ХарактеристикаНоменклатуры
- Спецификация
- ХэшПараметров (
тип Строка, 100)

Ресурсы:
- ТаблицаМатериалов (
тип ХранилищеЗначения)



Т.е. в регистре хранится готовая таблица материалов для объекта разузлования по определенной спецификации и определенным параметрам расчета.

Перейдем к коду. Непосредственно разузлование продукции производится в УПП (1.2, 1.3) в общем модуле "РазузлованиеНоменклатуры" в функции "РазузловатьНоменклатуру"


Добавим в начале функции следующий код. Задача - получить хэш параметров разузлования. Причем из параметров необходимо исключить те параметры, которые не влияют на результат разузлования (например такой параметр как ДатаСпецификации). Также рекомендую добавить константу "ИспользоватьКэш", чтобы можно было регулировать использование данного механизма (пригодится при начальной отладке).

Функция РазузловатьНоменклатуру(Источник, Результат = Неопределено, Параметры = Неопределено) Экспорт

    Если Константы.ИспользоватьКэш.Получить() Тогда
       
        КопияПараметры = Новый Структура();
        Для Каждого Параметр Из Параметры Цикл

            // Исключаем параметры, не влияющие на результат разузлования
            Если Параметр.Ключ = "ДатаСпецификации" Тогда
                Продолжить;
            КонецЕсли;
            КопияПараметры.Вставить(Параметр.Ключ, Параметр.Значение);
        КонецЦикла;
        стрXML = СериализоватьОбъектXDTO(КопияПараметры);
        ХэшПараметров= ХэшПараметров(стрXML);


   КонецЕсли;


....      

Функции СериализоватьОбъектXDTO и ХэшПараметров содержатся в конфигурации, прилагаемой к статье.

В процессе разработки выяснилось, что таблицу материалов (результат разузлования) необходимо формировать из расчета на 1 шт объекта разузлования (чтобы в дальнейшем при разузловании например 30 штук продукции, просто умножить каждое количество материала из исходной таблицы на 30).
Для этого было принято решение,  если в данную функцию РазузловатьНоменклатуру передано количество продукции для разузлования не равное 1 (это определяется по параметру передаваемому в функцию Источник.Количество), выполнить вначале разузлование на 1 единицу и сохранить результат разузлования в наш регистр. Причем повторное разузлование не будет выполняться далее, т.к. эту же таблицу мы уже и сможем использовать (будет понятно ниже).

Т.е. добавляем к нашему коду следующее:
   

Если Источник.Количество <> 1 Тогда
            
            УжеРазузловано = Ложь;
            НаборЗаписей = РегистрыСведений.Кэш_Разузлование.СоздатьНаборЗаписей();
            НаборЗаписей.Отбор.Номенклатура.Установить(Источник.Номенклатура);
            НаборЗаписей.Отбор.ХарактеристикаНоменклатуры.Установить(Источник.ХарактеристикаНоменклатуры);
            НаборЗаписей.Отбор.Спецификация.Установить(Источник.Спецификация);
            НаборЗаписей.Отбор.ХэшПараметров.Установить(ХэшПараметров);
            НаборЗаписей.Прочитать();
            УжеРазузловано = (НаборЗаписей.Количество() <> 0);

              Если Не УжеРазузловано Тогда

                    // Создадим копии структур Источник и Параметры для расчета на 1 единицу
                    КопияИсточник= Новый Структура;
                    Для Каждого ЭлементСтруктуры Из Источник Цикл
                        КопияИсточник.Вставить(ЭлементСтруктуры.Ключ, ЭлементСтруктуры.Значение);
                    КонецЦикла;
                    КопияПараметры = Новый Структура;
                    Для Каждого ЭлементСтруктуры Из Параметры Цикл
                        КопияПараметры.Вставить(ЭлементСтруктуры.Ключ, ЭлементСтруктуры.Значение);
                    КонецЦикла;

                    // Вот здесь укажем что надо разузловать на 1 единицу объекта разузлования
                    КопияИсточник.Количество = 1;
                    // Выполним разузлование на 1 единицу (причем результат разузлования на 1 единицу
                    // будет записан в наш регистр в конце данной функции (это будет описано чуть ниже)
                    Рез = РазузловатьНоменклатуру(КопияИсточник, Результат, КопияПараметры);
            КонецЕсли;
          


И ниже собственно производим считывание из нашего регистра таблицы материалов (из расчета на 1 шт) для данного объекта разузлования по данной спецификации для данного набора параметров. Если таблица есть, выполним пересчет количества материалов в ней на переданное количество и возвратим таблицу материалов как результат разузлования.
    

  // Типовой код функции
        ИнициализацияПараметров(Параметры);
        ИнициализацияРезультатаРазузлования(Результат, Источник);
        
        МассивОшибок = Новый Массив;
        Уровень = 0;
        // Типовой код функции

        НаборЗаписей = РегистрыСведений.Кэш_Разузлование.СоздатьНаборЗаписей();

        НаборЗаписей.Отбор.Номенклатура.Установить(Источник.Номенклатура);
        НаборЗаписей.Отбор.ХарактеристикаНоменклатуры.Установить(Источник.ХарактеристикаНоменклатуры);
        НаборЗаписей.Отбор.Спецификация.Установить(Источник.Спецификация);
        НаборЗаписей.Отбор.ХэшПараметров.Установить(ХэшПараметров);
        НаборЗаписей.Прочитать();
        

        // Если есть таблица материалов ее и вернем
        Если НаборЗаписей.Количество() <> 0 Тогда
                ЗаписьРегистра = НаборЗаписей[0];
                ТаблицаРазузлования = ЗаписьРегистра.ТаблицаМатериалов.Получить();
                // Пересчитаем количество материалов
                Если Источник.Количество <> 1 Тогда
                    Для Каждого СтрМатериал Из ТаблицаРазузлования Цикл
                        СтрМатериал.Количество = СтрМатериал.Количество * Источник.Количество;
                    КонецЦикла;
                КонецЕсли;
                Результат.ИсходныеКомплектующие = ТаблицаРазузлования ;
                Возврат МассивОшибок;
         КонецЕсли;

Вот и все, осталось только в самом конце функции РазузловатьНоменклатуру (куда при данном алгоритме мы попадем только если разузлование еще не было выполнено) добавить код, записывающий в наш регистр сформированную таблицу материалов (на 1 шт).

........
 

     Если Константы.ИспользоватьКэш.Получить() И Источник.Количество = 1 И МассивОшибок.Количество() = 0 Тогда

             Менеджер = РегистрыСведений.Кэш_Разузлование.СоздатьМенеджерЗаписи();
             ЗаполнитьЗначенияСвойств(Менеджер, Источник);
             Менеджер.ТаблицаМатериалов = Новый ХранилищеЗначения(Результат.ИсходныеКомплектующие, Новый СжатиеДанных(9));
             Менеджер.ХэшПараметров = ХэшПараметров ;
             Менеджер.Записать();

        КонецЕсли;
    
        Возврат МассивОшибок;
    
КонецФункции


В результат функция РазузловатьНоменклатуру выглядит так:


Функция РазузловатьНоменклатуру(Источник, Результат = Неопределено, Параметры = Неопределено) Экспорт
    
    Если Константы.ИспользоватьКэш.Получить() Тогда
        
        КопияПараметры = Новый Структура();
        Для Каждого Параметр Из Параметры Цикл
            Если Параметр.Ключ = "ДатаСпецификации" Тогда
                Продолжить;
            КонецЕсли;
            КопияПараметры.Вставить(Параметр.Ключ, Параметр.Значение);
        КонецЦикла;
        
        стрXML = СериализоватьОбъектXDTO(КопияПараметры);
        ХэшПараметров = ХЭШ(стрXML);
        
        // разузлуем на 1 шт, чтобы потом взять из кэша
        Если Источник.Количество <> 1 Тогда
            
            УжеРазузловано = Ложь;
            НаборЗаписей = РегистрыСведений.Кэш_Разузлование.СоздатьНаборЗаписей();
            НаборЗаписей.Отбор.Номенклатура.Установить(Источник.Номенклатура);
            НаборЗаписей.Отбор.ХарактеристикаНоменклатуры.Установить(Источник.ХарактеристикаНоменклатуры);
            НаборЗаписей.Отбор.Спецификация.Установить(Источник.Спецификация);
            НаборЗаписей.Отбор.ХэшПараметров.Установить(ХэшПараметров);
            НаборЗаписей.Прочитать();
            УжеРазузловано = (НаборЗаписей.Количество() <> 0);
            
            Если Не УжеРазузловано Тогда
                
                // Создадим копии структур Источник и Параметры для расчета на 1 единицу
                КопияИсточник= Новый Структура;
                Для Каждого ЭлементСтруктуры Из Источник Цикл
                    КопияИсточник.Вставить(ЭлементСтруктуры.Ключ, ЭлементСтруктуры.Значение);
                КонецЦикла;
                КопияПараметры = Новый Структура;
                Для Каждого ЭлементСтруктуры Из Параметры Цикл
                    КопияПараметры.Вставить(ЭлементСтруктуры.Ключ, ЭлементСтруктуры.Значение);
                КонецЦикла;
                
                // Вот здесь укажем что надо разузловать на 1 единицу объекта разузлования
                КопияИсточник.Количество = 1;
                // Выполним разузлование на 1 единицу (причем результат разузлования на 1 единицу
                // будет записан в наш регистр в конце данной функции (это будет описано чуть ниже)
                Рез = РазузловатьНоменклатуру(КопияИсточник, Результат, КопияПараметры);
            КонецЕсли;
        КонецЕсли;
        
        // Типовой код УПП
        ИнициализацияПараметров(Параметры);
        ИнициализацияРезультатаРазузлования(Результат, Источник);
        
        МассивОшибок = Новый Массив;
        Уровень = 0;
        // Типовой код УПП
        
        
        НаборЗаписей = РегистрыСведений.Кэш_Разузлование.СоздатьНаборЗаписей();
        НаборЗаписей.Отбор.Номенклатура.Установить(Источник.Номенклатура);
        НаборЗаписей.Отбор.ХарактеристикаНоменклатуры.Установить(Источник.ХарактеристикаНоменклатуры);
        НаборЗаписей.Отбор.Спецификация.Установить(Источник.Спецификация);
        НаборЗаписей.Отбор.ХэшПараметров.Установить(ХэшПараметров);
        НаборЗаписей.Прочитать();
        
        // Если есть таблица материалов ее и вернем
        Если НаборЗаписей.Количество() <> 0 Тогда
            ЗаписьРегистра = НаборЗаписей[0];
            ТаблицаРазузлования = ЗаписьРегистра.ТаблицаМатериалов.Получить();
            // Пересчитаем количество материалов
            Если Источник.Количество <> 1 Тогда
                Для Каждого СтрМатериал Из ТаблицаРазузлования Цикл
                    СтрМатериал.Количество = СтрМатериал.Количество * Источник.Количество;
                КонецЦикла;
            КонецЕсли;
            Результат.ИсходныеКомплектующие = ТаблицаРазузлования ;
            Возврат МассивОшибок;
        КонецЕсли;        
        
    КонецЕсли;
    
    ИнициализацияПараметров(Параметры);
    ИнициализацияРезультатаРазузлования(Результат, Источник);
    
    МассивОшибок = Новый Массив;
    Уровень = 0;

    
    // типовой код УПП..
    // типовой код УПП..
    // типовой код УПП..
  
    
    // Запишем результат разузлования в регистр
    Если Константы.ИспользоватьКэш.Получить() И Источник.Количество = 1 И МассивОшибок.Количество() = 0 Тогда
        Менеджер = РегистрыСведений.Кэш_Разузлование.СоздатьМенеджерЗаписи();
        ЗаполнитьЗначенияСвойств(Менеджер, Источник);
        Менеджер.ТаблицаМатериалов = Новый ХранилищеЗначения(Результат.ИсходныеКомплектующие, Новый СжатиеДанных(9));
        Менеджер.ХэшПараметров = ХэшПараметров ;
        Менеджер.Записать();
    КонецЕсли;
    
    Возврат МассивОшибок;    
    
КонецФункции // ВыполнитьРазузлование()


Но это еще не все...
Результат разузлования может измениться в результате внесения изменений в спецификацию, в узел спецификации либо в свойство характеристики, которое используется в формулах расчета.

Поэтому крайне важно производить выборочную очистку нашего регистра в этих случаях.

Т.е. при изменении спецификации - очищаем все записи регистра по данной спецификации (выполняем в модуле справочника СпецификацииНоменклатуры).
При изменении узла спецификации - очищаем все записи регистра по данному узлу и по спецификации, в которой используется этот узел (выполняем в модуле справочника СпецификацииНоменклатуры).
При изменении свойства характеристики - очищаем все записи регистра по данной характеристике (выполняем в модуле набора записей регистра сведений ЗначенияСвойствОбъектов).

Это пожалуй самый "узкий" момент, т.к. ошибка здесь чревата получением некорректных данных из регистра. Но результат того стоит, поверьте))

Во вложенной обработке приведены примеры использующихся у нас механизмов очистки записей регистра для всех этих случаям.

На этом все. Согласен, что вариант решения небезупречный, скорее всего потребует доработки. Но надеюсь, что он окажется полезен кому-то.
Открыт для критики и предложений по усовершенствованию! Спасибо)

Скачать файлы

Наименование Файл Версия Размер
Технология кэширования результата разузлования продукции по спецификации:

.cf 15,36Kb
10.06.19
1
.cf 15,36Kb 1 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Mkonst 54 01.03.19 08:26 Сейчас в теме
Не проще разузлование делать в несколько потоков, (ФоновыеЗадания использовать) ?
Оставьте свое сообщение

См. также

Безопасная работа с транзакциями во встроенном языке Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

Разбираемся с опасностями использования транзакций во встроенном языке 1С. Познаем ошибку "В данной транзакции уже происходили ошибки". Учимся защищаться от них.

1 стартмани

25.03.2019    34132    tormozit    44    

Библиотека программного изменения формы (УФ)

Инструментарий разработчика Работа с интерфейсом Универсальные функции v8 1cv8.cf Абонемент ($m)

Нам часто приходится дорабатывать различные управляемые формы. Проще внести изменения непосредственно на самой форме, но, для дальнейшего поддержания конфигурации, удобнее вносить все изменения на форме программно. Предлагаю Вам библиотеку для программного изменения управляемых форм, которую можно внедрить в конфигурацию либо совсем бесшовно, либо практически бесшовно.

1 стартмани

07.08.2020    3652    BuriyLesha    17    

Работа с хранилищем конфигурации из режима 1С: Предприятие минуя конфигуратор

Хранилище v8 1cv8.cf Абонемент ($m)

Описание приемов работы с хранилищем конфигурации 1С из режима 1С: Предприятие минуя конфигуратор. Статья содержит ряд примеров работы с хранилищем по протоколу HTTP, описание "внутренностей", а также демонстрационную обработку

3 стартмани

11.06.2020    5884    MaxxG    19    

История данных и БСП

БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

История данных от платформы и Версионирование объектов от БСП. Как мигрировать историю из подсистемы БСП и начать использовать функции платформы уже сейчас.

1 стартмани

09.06.2020    3346    zeegin    15    

План подготовки к аттестации на 1С: Специалиста по платформе (+ Ссылки на материалы) Промо

Решение задач на 1С:Специалист v8 Россия Абонемент ($m)

Хочу поделиться собственным планом подготовки к аттестации на 1С: Специалист по платформе 8.3 со ссылками на материалы (и указанием стоимости).

1 стартмани

23.12.2017    22025    tmn72.1C    38    

Telegram bot API - разбор документации с примерами

WEB v8 Абонемент ($m)

Перевод документации на язык 1С.

1 стартмани

06.04.2020    32797    leongl    44    

Методика обновления формы объекта данных при изменении объекта

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

В формах объектов данных часто встречаются элементы, косвенно связанные с объектом. Логику обновления этих элементов при изменении объекта обычно вызывают из обработчиков ПриСозданнииНаСервере и ПриОткрытии, забывая про наличие других способов изменения объекта. В статье предложена методика для обычных и управляемых форм, учитывающая все способы.

1 стартмани

09.03.2020    7386    tormozit    13    

Как выполнить отчет на СКД через COM и получить данные отчета? Промо

Практика программирования v8 УПП1 Россия Абонемент ($m)

Для чего это нужно. Например, нужно в одной базе получить какой-либо показатель из другой базы. Этот показатель вычисляется в каком-либо сложном отчете, который написан на СКД. Можно, конечно, "скопипастить" текст запроса из другой базы, немного подправить его и выполнять в том же COM подключении. Но с этим теряется гибкость: если отчет изменился, то нужно помнить о том, что где-то есть его "немного модифицированная" копия. В статье будет рассмотрен пример получения данных из базы ЗУП.

2 стартмани

08.05.2018    26909    wowik    3    

Отправка уведомлений с помощью командной строки, Оповещения с сервера на клиент с помощью командной строки

Практика программирования v8 1cv8.cf Россия Абонемент ($m)

Отправка уведомлений с помощью команды командной строки msg. Оповестить пользователей из серверного модуля или регламентного задания, с помощью командной строки msg.

1 стартмани

05.03.2020    5398    user5300    3    

Конвертация данных 2. Использование исходящих и входящих данных. Свойство "Получить из входящих данных"

Обмен данными 1С Перенос данных из 1C8 в 1C8 v8 КД Абонемент ($m)

Разработка правил обмена с использованием исходящих и входящих данных. В качестве примера рассмотрена реальная задача конвертации номенклатуры через регистр сопоставления номенклатур. Статья предназначена в первую очередь для тех, кто только начинает осваивать Конвертацию данных.

17.02.2020    13637    Drivingblind    31    

Вывод сообщений в HTML поле средствами 1С

Практика программирования v8 v8::УФ Абонемент ($m)

Пример использования вывода большого количества сообщений в поле HTML. С возможностью открывать ссылочные объекты и создавать новые объекты передавая параметры прямо из HTML поля. Протестировано на релизах 8.3.12 и 8.3.15+

2 стартмани

31.01.2020    5533    burni4    16    

Как нарисовать граф на 1С Промо

Практика программирования v8 Абонемент ($m)

Описывается реализация на языке запросов 1С метода расположения вершин графа на плоскости, основанного на использовании электромеханической аналогии. При этом вершины графа представляются одноименными электрическими зарядами, дуги - пружинками. Силы взаимодействия вершин в этой системе переводят их из случайного начального в нужное конечное положение. Приведена обработка рисования графов "ГрафОграф", реализующая данный подход, показывающая также динамику процесса. Граф можно задать списком ребер вручную, выбрать из нескольких предопределенных примеров или сформировать по данным информационной базы.

1 стартмани

09.08.2013    70151    ildarovich    117    

Краткое руководство по внесению изменений в конфигурацию

Практика программирования v8 1cv8.cf Абонемент ($m)

Кратко описаны основополагающие моменты при старте групповой разработки конфигурации несколькими программистами. Полезно для проектной документации как требование к разработчикам или сопровождающей компании.

1 стартмани

13.01.2020    16568    sapervodichka    41    

Разбираемся с web-kit в 1С, на примере интеграции TinyMCE в управляемую форму в УТ 11.4. Допиливаем обмен с сайтом в УТ 11.4

Обмен данными 1С Интеграция Адаптация типовых решений v8 v8::УФ УТ11 Абонемент ($m)

Многие уже знают, что в релизе платформы 8.3.14.1565, браузер Internet Explorer был заменен на Web-Kit, это на самом деле большой шаг вперед, но я уверен, многим, как и мне, пока не совсем понятно, что к чему. Возник опыт использования web-kit в 1С, вызова JS из 1С и вызова 1С из JS. Давайте вместе попробуем понять, чем одно отличается от другого, и заодно сделаем, что-нибудь полезное. Да и наверняка многим придется переписывать свои подобные поделки после обновления на новую платформу, так что надеюсь мой опыт окажется полезным.

2 стартмани

08.12.2019    8174    Бэнни    25    

Массовое изменение режима поддержки объектов конфигурации

Структура метаданных v8 1cv8.cf Абонемент ($m)

Что делать, если при сравнении/объединении конфигураций нужно изменить режим поддержки для большого количества объектов? Штатного механизма для выполнения подобной задачи в Платформе нет. Изменять режим для всей конфигурации? Описывается способ, позволяющий выполнить изменение режима только для нужных объектов.

1 стартмани

05.11.2019    3994    VKislitsin    6    

Простой способ индексирования интервалов Промо

Практика программирования v8 Абонемент ($m)

Предлагается простой способ индексирования интервалов для решения задач выборки записей, включающих заданный момент времени, пересекающихся с заданным интервалом или множеством интервалов. Способ основан на добавлении к исходной таблице особого числового индексированного поля, рассчитываемого по специальной формуле. Приведен код функций, необходимых для расчетов поля поиска и параметров поисковых запросов. Приведены также результаты тестирования метода, доказывающие его высокую эффективность.

1 стартмани

28.09.2016    39286    ildarovich    22    

"Живые" картинки со Snap.SVG

Практика программирования WEB Работа с интерфейсом v8 Абонемент ($m)

В статье рассмотрен пример использования http-сервисов для визуализации данных

1 стартмани

24.10.2019    13274    blackhole321    7    

Интеграция 1С с сайтом (магазином) WordPress (WooCommerce) с помощью Rest API сайта. Часть 1. Авторизация

WEB v8 Абонемент ($m)

Интеграция 1С с сайтом (магазином) WordPress (WooCommerce) с помощью функционала Rest API предоставляемого платформой (CMS) WordPress (WooCommerce). Без дополнительных приложений на PHP/вставьте сюда любой другой язык программирования/.

1 стартмани

12.10.2019    24774    osivv    31    

RLS - дубли условий в запросах к СУБД

Практика программирования Роли и права v8 v8::Права 1cv8.cf Абонемент ($m)

"Подводные камни", возникающие при бездумном копировании ролей с ограничениями RLS, как это отражается на производительности, разбор примера и инструмент для анализа.

1 стартмани

07.10.2019    8286    geron4    4    

Бесплатная проверка контрагентов в ФНС (общий модуль с алгоритмом). На примере выводим статус в список справочника контрагентов Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

Если вам интересно проверить контрагенте в ФНС, вам поможет данная публикация. Весь алгоритм работы строится на основе данных, полученных с сервиса http://npchk.nalog.ru совершенно бесплатно.

1 стартмани

01.02.2018    34832    rpgshnik    49    

Полезные процедуры и функции для программиста

Практика программирования Универсальные функции v8 1cv8.cf Россия Абонемент ($m)

Все мы пишем программный код и часто используем процедуры, облегчающие его написание. Ниже приведена выборка таких полезных процедур и функций.

1 стартмани

07.10.2019    29146    HostHost    40    

Вебхук. Путь Телеграма

Внешние источники данных Интеграция v8 Абонемент ($m)

Долгое (на самом деле нет) и нелегкое путешествие телеграма к неведомым (из за РКН) конфигурациям 1С. Памятка себе.

1 стартмани

03.10.2019    16793    platonov.e    24    

Многопоточная обработка данных на примере перепроведения документов

Обработка документов Практика программирования v8 ERP2 УТ11 КА2 Абонемент ($m)

Дальнейшее развитие темы фоновой обработки данных - проведение документов в потоках. Настройка параметров и запуск основного процесса (менеджера потоков). Разбивка документов для проведения на не связанные друг с другом наборы и запуск дополнительных фоновых заданий для отдельных потоков. Отслеживание выполнения каждого потока в родительском сеансе.

1 стартмани

17.09.2019    8887    ids79    46    

БСП: Дополнительная обработка (Регламенты), примеры от простого к сложному Промо

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Очень много попадается странных решений, которые можно решить через БСП:Дополнительные отчеты и обработки. Я бы вообще БСП из-за этой подсистемы переименовал в «Большое Спасибо Программистам». Поработаем с подсистемой в части написания регламентных заданий.

1 стартмани

10.05.2018    44075    dsdred    36    

Описание формата внутреннего представления данных 1С в контексте обмена данными

Практика программирования Внешние источники данных v8 v8::УФ 1cv8.cf Абонемент ($m)

Фирма 1С не рекомендует использовать внутреннее представление данных для любых целей, которые отличны от обмена с 1С:Предприятием 7.7. Но сама возможность заглянуть на "внутреннюю кухню" платформы с помощью функций ЗначениеВСтрокуВнутр(), ЗначениеВФайл(), ЗначениеИзСтрокиВнутр() и ЗначениеИзФайла(), дала возможность сообществу программистов 1С разработать новые приемы разработки и анализа. Так, именно на использовании внутреннего представления был построен алгоритм "быстрого массива", который позволяет практически мгновенно создать массив в памяти на основании строки с разделителями. С помощью разбора внутреннего представления можно "на лету" программным кодом выполнить анализ обычной формы и даже сделать редактор графической схемы. Во внутреннем формате сохраняют свои данные между сеансами различные популярные внешние обработки. А еще это возможность сделать быстрый обмен с внешними системами.

1 стартмани

06.09.2019    19041    Dementor    30    

1С и PowerShell - обновление из хранилища

Администрирование данных 1С Инструментарий разработчика v8 Абонемент ($m)

Пример скрипта, упрощающего работу.

1 стартмани

29.08.2019    8431    Jokemas    24    

Удобный просмотр результата запроса с большим количеством временных таблиц

Практика программирования v8 Абонемент ($m)

Если Вам часто приходится просматривать в отладчике сложные пакетные запросы с большим количеством временных таблиц, то эта статья для Вас.

1 стартмани

27.08.2019    10712    ids79    21    

Некоторая работа с данными через COM Промо

Практика программирования v8 Абонемент ($m)

В статье приведены примеры работы с Платформой 8.X через COM (точнее, через объект COMConnector). Примеры кода были использованы при реализации прикладных задач в процессе трудовой деятельности.

2 стартмани

05.12.2012    57224    wowik    32    

Обмен большими данными между клиентом и сервером

Внешние источники данных v8 Абонемент ($m)

В статье рассматривается вопрос передачи больших объемов данных, превышающих теоретический лимит сеансовых данных (4Гб за вызов) (они же временное хранилище) как с клиента на сервер, так и в обратном направлении.

1 стартмани

27.08.2019    13297    logos    24    

Запуск фонового задания во внешней обработке. Отключение предупреждений защиты от опасных действий в фоновом задании

Практика программирования v8 1cv8.cf Абонемент ($m)

Как запустить фоновое задание из модуля внешней обработки используя БСП. Как отключить безопасный режим и сообщения защиты от опасных действий независимо от профиля безопасности пользователя в фоновом задании во внешней обработке.

2 стартмани

24.08.2019    10251    BenGunn    22    

Изменяющееся контекстное меню в 1С 8.3

Практика программирования Работа с интерфейсом Разработка v8 v8::УФ Абонемент ($m)

В одной практической задаче мне пришлось разрабатывать контекстное меню таблицы управляемой формы, которое должно было меняться в зависимости от данных, находящихся в этой таблице. Ниже приведен мой способ решения этой задачи.

1 стартмани

06.08.2019    15190    signum2009    16    

Работа со схемой запроса Промо

Инструментарий разработчика Практика программирования v8 v8::Запросы Абонемент ($m)

Стандартом взаимодействия с реляционной базой данных стал язык SQL. Приемником SQL в 1С является язык запросов. Язык запросов, также как и SQL, является структурированным. Составляющие структуры запроса отвечают на разные вопросы о том, какие данные требуется получить и какие манипуляции с множествами данных необходимо произвести при получении. В простых случаях текст запроса можно написать вручную, однако в сложных случаях, а также при программном формировании, - лучше воспользоваться объектной моделью запроса и использовать объект "Схема запроса". В статье дается описание объектной модели и особенностей работы с ней, а также приводится решение, упрощающее взаимодействие с объектом "Схема запроса".

1 стартмани

24.04.2018    43340    kalyaka    35    

Использование HTTP-сервиса для создания "фронтенда" HTML/CSS/jQuery с кэшированием

WEB v8 1cv8.cf Абонемент ($m)

В статье описан способ создания "фронтенда" на HTML/CSS/jQuery и скрипт кеширования AJAX запросов на PHP.

1 стартмани

06.08.2019    13689    Sedaiko    24    

Менеджер потоков: реализация "любой" задачи в потоках

Производительность и оптимизация (HighLoad) Инструментарий разработчика v8 Абонемент ($m)

Менеджер потоков – один их новых инструментов, который упрощает работу разработчиков. Насколько легко с ним, на конференции Infostart Event 2018 Education показал начальник отдела автоматизации 1С Иван Филимонов компании «Трансстроймеханизация».

01.08.2019    9394    DarkAn    6    

Процедура ПриКомпоновкеРезультата

Практика программирования v8 1cv8.cf Абонемент ($m)

Коллекция кода

1 стартмани

26.07.2019    36743    vasilev2015    64    

Многопоточность. Универсальный «Менеджер потоков» (фреймворк) с отслеживанием зависимости объектов Промо

Практика программирования Математика и алгоритмы Универсальные функции Производительность и оптимизация (HighLoad) v8 1cv8.cf Россия Абонемент ($m)

Восстановление партий, расчет зарплаты, пакетное формирование документов или отчетов - теперь все это стало доступнее. * Есть желание повысить скорость работы медленных алгоритмов! Но... * Нет времени думать о реализации многопоточности? * о запуске и остановке потоков? * о поддержании потоков в рабочем состоянии? * о передаче данных в потоки и как получить ответ из потока? * об организации последовательности? Тогда ЭТО - то что надо!!!

26.05.2017    48801    DarkAn    86    

10 способов получить модуль числа (а может, и больше)

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

Пишем функцию вычисления модуля числа. Сколько способов существует? Давайте посчитаем!

1 стартмани

11.07.2019    7761    sam441    29    

Ловец дедлоков СУБД

Производительность и оптимизация (HighLoad) Практика программирования Разработка v8 Россия Абонемент ($m)

Анализ простейшего дедлока СУБД в рабочей базе с использованием ЦУП (центра управления производительностью) и profiler MS SQL (Microsoft SQL Server). Эта статья будет полезна людям, изучающим вопросы оптимизации работы 1С, или тем, у кого возникают дедлоки в рабочей базе. UPD 09.07.2019 добавлено воспроизведение блокировки в случае установки управляемой блокировки перед чтением набора записей регистра сведений. UPD 10.07.2019 добавлена тестовая база с примером.

1 стартмани

08.07.2019    10907    azazana    79    

Мониторинг производительности и искусственный интеллект

Производительность и оптимизация (HighLoad) Практика программирования Разработка v8 Абонемент ($m)

Расскажем и покажем практически, как использовать искусственный интеллект на страже мониторинга производительности. У вас появится возможность создать собственного помощника Ларису, которая возьмет на себя вопросы по контролю и диагностике состояния обслуживаемой системы.

1 стартмани

01.07.2019    9094    ivanov660    28    

Агрегатное суммирование строк в запросе – сложно, но не невозможно Промо

Математика и алгоритмы v8 Абонемент ($m)

Описывается метод соединения строк из одной колонки таблицы в единую результирующую строку в запросе на языке 1С. Метод сложный и по сравнению с внезапросной техникой представляет больше спортивный, чем практический интерес.

1 стартмани

09.09.2013    77811    ildarovich    54    

"Убер на складе": динамический расчет маршрутов с учетом реальных расстояний

Учет ТМЦ Практика программирования Учет ТМЦ v8 УУ Абонемент ($m)

Представляю методику и инструмент для динамического расчета маршрутов отбора на высоконагруженных складах для максимального повышения эффективности склада, ускорения проходимости и, как следствие, экономии денег. Это методика и обработка для интеграции в WMS решения. Тестировалось на 1С 8.3.14.1565.

3 стартмани

24.06.2019    15098    informa1555    17    

1С:Ассемблер. Немного летнего веселья!

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

Все вы, наверное, слышали, что 1С-ники жалуются на свою систему, считая язык 1С недостаточно низкоуровневым, скучным и т.п. Все они с тоской поглядывают в сторону "настоящих" языков программирования. Так вот, господа, они неправы. В системе 1С есть места, где можно размять программерский мозг и получить удовольствие от низкоуровневой техники. Предлагаю вам погрузиться в недра виртуальной машины 1С и понять, как она работает. Там есть свой "ассемблер" и мы попробуем его в действии!

1 стартмани

21.06.2019    28210    Evil Beaver    126    

Простые примеры сложных отчетов на СКД

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Подписи в отчете. Особенности соединения наборов: как соединить несоединяемое. Остатки на дату и обороты по месяцам в одном отчете. Курс валюты на каждую дату без группировок и соединений в запросе. Отчет с произвольными колонками и с произвольной последовательностью. "Неадекватный отчет".

1 стартмани

12.06.2019    29133    Hatson    23    

Новый запрос и новая таблица значений как функции Промо

Практика программирования v8 Абонемент ($m)

Предлагается две простые функции, использование которых уменьшает объем кода в конфигурациях на платформе «1С:Предприятие 8». Эти функции можно добавлять к своему общему модулю, что сделает процесс программирования более эффективным.

1 стартмани

27.11.2012    45071    ildarovich    46    

Работа с графической схемой в объектной модели DOM

Универсальные функции v8 v8::УФ Абонемент ($m)

Пример кода для работы с графической схемой в объектной модели DOM, платформа 8.3.12.

1 стартмани

04.06.2019    7929    botokash    19    

XDTO для чайников

Обмен через XML v8 1cv8.cf Абонемент ($m)

Пример использования XDTO пакетов для выгрузки документа с табличной частью.

1 стартмани

29.05.2019    27426    HAMMER_59    39    

Отладка правил обмена КД2 для подсистемы БСП Обмен данными

Перенос данных из 1C8 в 1C8 v8 1cv8.cf Абонемент ($m)

Уже давно нельзя отлаживать правила обмена при помощи внешних файлов. Попробуем исправить это.

1 стартмани

27.05.2019    12024    fenixnow    5    

Уровни, глубина, прародители, циклы и аналоги запросом Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

В продолжение публикации «Транзитивное замыкание запросом» [http://infostart.ru/public/158512/] добавлены другие варианты использования того же приема. Приведены запросы для быстрого определения уровней всех элементов справочника, максимальной глубины справочника, прародителей произвольных элементов справочника, запрос для быстрого определения циклов (на примере справочника спецификаций «1С:Управление производственным предприятием») и определения множеств аналогов номенклатуры (также на примере конфигурации «1С:Управление производственным предприятием»).

1 стартмани

13.11.2012    111283    ildarovich    98    

Создание внешней печатной формы в формате документа Word

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

В статье написано, как создать внешнюю печатную форму (для конфигураций с БСП) в формате Word.

1 стартмани

17.05.2019    12722    ВикторП    20    

Программное формирование картинки в 1С:Предприятие 8.3.9 (ПотокВПамяти / ЗаписьДанных)

Универсальные функции v8 1cv8.cf Абонемент ($m)

В статье представлен код программного формирования картинки (двоичные данные) без всяких внешних компонент, без формирования строки Base64, используя лишь встроенные механизмы 1С предприятие 8.3.9 (объекты ПотокВПамяти и ЗаписьДанных). Сам по себе код формирования картинки не несёт ничего нового. Всё описано в википедии. Захотелось попробовать новые методы, но никак не доходитили руки. В приложении обработка практически с этим же кодом.

1 стартмани

16.05.2019    9173    yku    7    

Ops средствами 1С:Предприятие

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

В статье описан программный пакет "Автоматизация ИТ-процессов" (АИТП), позволяющий автоматизировать задачи по администрированию, управлению и обслуживанию ИТ-инфраструктуры.

1 стартмани

23.04.2019    17234    blackhole321    28    

1C + Python + Django Rest Framework + Vue.js. Опыт несложной full-stack разработки

Практика программирования Внешние источники данных Обмен через XML WEB Разработка v8 1cv8.cf Абонемент ($m)

В этой статье мы рассмотрим путь и основные моменты создания небольшого вэб-сервиса, который мы называем "Онлайн Прайс-лист". Выгрузка из 1С, бэкенд, фронтенд, получение заказов в 1С.

1 стартмани

22.04.2019    32334    riposte    65