Автоматическое создание связанного объекта в базе 1С: Документооборот через бесшовную интеграцию

Публикация № 1171361

Разработка - Практика программирования

бесшовная интеграция документооборот erp КА УТ БП ЗУП

При настройке бесшовной интеграции с базой документооборота часто возникает задача - пользователи просят автоматически создавать связанный объект в базе документооборота по некоторому условию. В данной публикации я хочу поделиться своим решением данной задачи.

В типовой конфигурации для того, чтобы создать связанный объект в базе ДО необходимо открыть форму документа и перейти по гиперссылке "Документооборот":

В открывшемся окне нажать на гиперссылку "Создать":

В форме связанного объекта нажать кнопку "Записать" / "Записать и закрыть" / "Зарегистрировать":

Для автоматизации этих действий можно использовать следующую процедуру:

 
 Код процедуры "СоздатьСвязанныйОбъектВДо"

 

// Процедура - Создать свзянный объект в ДО
//
// Параметры:
//  ВнешнийОбъект		 - 	 ЛюбаяСсылка - объект ИС, источник данных заполнения. 
//  ПравилоИнтеграции	 - 	 СправочникСсылка.ПравилаИнтеграцииС1СДокументооборотом. Правило интеграции по
//  которому будет производиться заполнение объекта в базе ДО. 
//  Процедура создает объект в базе ДО.
Процедура СоздатьСвзянныйОбъектВДо(ВнешнийОбъект, ПравилоИнтеграции)
	
	СвязанныйОбъект = ИнтеграцияС1СДокументооборотВызовСервера.ДанныеОбъектаДОПоВнешнемуОбъекту(ВнешнийОбъект);
	
	Если Не ЗначениеЗаполнено(СвязанныйОбъект) Тогда
		
		Результат = ИнтеграцияС1СДокументооборотВызовСервера.СоздатьОбъектДОПоПравилу(ВнешнийОбъект,
		Правило);
		
		Если ТипЗнч(Результат) = Тип("Строка") Тогда
			
			ВызватьИсключение Результат;
			
		КонецЕсли;
		
	КонецЕсли;
	
КонецПроцедуры

 

 

Данная процедура тестировалась в ERP 2.4.10.56 и ДО 2.1.15.4.

Специальные предложения

Оставьте свое сообщение

См. также

Serverless (Faas) в 1С. Создание и вызов Yandex Cloud Functions Промо

Универсальные функции Практика программирования v8 Бесплатно (free)

"Я не могу просто взять и скопировать код с гитхаба", "у нас 1С микросервисами окружена", "возможностей мало" - частые фразы 1С разработчиков. которым не хватает возможностей платформы в современном мире. Faas, конечно, история не новая, но нас сдерживало 152ФЗ и задержки по пингам. Для того, чтобы действительно использовать в 1С код, к примеру, на Python, надо было приложить усилия. Теперь всё намного проще - берём и используем.

28.12.2020    4277    comol    22