Мобильный клиент для сканирования QR-кодов и штрих-кодов и отправки их на сервер

Публикация № 1248373

Администрирование - Торговое оборудование - Сканер штрих-кода

QR-код QR-code Штрихкод Сканер Сканирование http-сервис web-сервис

В статье рассмотрены варианты реализации мобильного сканера.

Поставлена задача по занесению данных в базу 1С по QR-кодам через мобильное устройство. От мобильного устройства требуется только распознать QR-код и отправить его на сервер. Все остальные вопросы должны решаться на сервере. Такой подход сводит к минимуму человеческий фактор и значительно ускоряет весь процесс по передаче данных.

Анализ вариантов показывает три возможных решения:

  1. Использование существующего мобильного приложения
  2. Создание собственного мобильного приложения на 1С
  3. Совмещенный вариант

Рассмотрим каждый подробнее.

 

1. Использование существующего мобильного приложения.

Анализ рынка в магазинах приложений показывает, что большинство существующих сканеров распознают QR-коды плохо, и лишь отдельные делают это на удивление моментально. А умеют отправлять данные на сервер - единицы. Рассмотрим реализацию на примере одного такого приложения: "Штрихкод Коммандер"

Доступно в Google Play

 

Подготовка серверной части

Обмен с мобильным приложением "Штрихкод Коммандер" выполняется через http-сервис. Поэтому на сервере в 1С создаем метод http-сервиса и описываем алгоритм обработки полученного QR-кода. Работа с http-сервисами не нова, поэтому комментарии опустим. Пример:

      

 

                 

Функция ШаблонURL1Метод1(Запрос)
	
	МассивОтветов = Новый Массив;	
	Для каждого ОдинКод Из ПреобразоватьJSONвДанные(Запрос.ПолучитьТелоКакСтроку()) Цикл
		МассивОтветов.Добавить(ОбработатьШтрихКод(ОдинКод));
	КонецЦикла;	

	Возврат СформироватьОтветHTTP(МассивОтветов);

КонецФункции

Функция ПреобразоватьJSONвДанные(СтрокаJSON) 	
	
	мЧтениеJSON = Новый ЧтениеJSON;	
	мЧтениеJSON.УстановитьСтроку(СтрокаJSON);
	Результат = ПрочитатьJSON(мЧтениеJSON);
	мЧтениеJSON.Закрыть();	
	Возврат Результат;
	
КонецФункции

Функция ОбработатьШтрихКод(ОдинКод) 
	
	Если ОдинКод.id = 1 Тогда 		
		Возврат СформироватьОтвет(ОдинКод.id, "Аутентификация успешно пройдена.");
		
	ИначеЕсли Сред(ОдинКод.barcode, 1, 4) = "Демо" Тогда 		
		Возврат СформироватьОтвет(ОдинКод.id, "", 1,"Демо-режим");
	КонецЕсли;
	
	// Обработка полученного штрих-кода (ОдинКод.barcode) и описания (ОдинКод.description)
	
	// Создание записи в журнале регистрации (при необходимости)
	ЗаписьЖурналаРегистрации("HTTPСервис1.ШаблонURL1", УровеньЖурналаРегистрации.Ошибка, , ОдинКод.barcode, "Описание ошибки");
	
	// Сообщение результатов обработки
	Возврат СформироватьОтвет(ОдинКод.id, "Загрузка успешно завершена", 0,"Пример заголовока", Истина);
	
КонецФункции

Функция СформироватьОтвет(Идентификатор, Отчет, НомерИконки=0, Заголовок="", ЦветнойЗаголовок=Ложь, Фото="")
	
	Запись = Новый Структура;
	Запись.Вставить("result_id", 			Идентификатор);
	Запись.Вставить("result_title", 		Заголовок);
	Запись.Вставить("result_title_color",		?(ЦветнойЗаголовок, "1", "0"));
	Запись.Вставить("result_icon", 			НомерИконки);	
	Запись.Вставить("result_report", 		Отчет);
	Запись.Вставить("result_image", 		Фото);
	Возврат Запись;	
	
КонецФункции

Функция СформироватьОтветHTTP(МассивОтветов)
	
	мЗаписьJSON = Новый ЗаписьJSON;
	мЗаписьJSON.ПроверятьСтруктуру = Ложь;
	мЗаписьJSON.УстановитьСтроку(Новый ПараметрыЗаписиJSON());
	ЗаписатьJSON(мЗаписьJSON, МассивОтветов);
	СтрокаJSON = мЗаписьJSON.Закрыть(); 
		
	Ответ = Новый HTTPСервисОтвет(200);
	Ответ.УстановитьТелоИзСтроки(СтрокаJSON, КодировкаТекста.UTF8, ИспользованиеByteOrderMark.НеИспользовать);
	Возврат Ответ;
	
КонецФункции

Проверяем, что брандмауэр и/или антивирус не мешают подключению к сервису.

 

Подготовка клиентской части

Устанавливаем приложение на мобильное устройство:

Доступно в Google Play

Переходим в настройки и включаем переключатель: "Веб-сервер". Указываем свой сервер в поле "Адрес URL" (в примере выше это был:  "http://192.168.0.1/MyWS/hs/barcode/"). При необходимости вводим логин и пароль от базы 1С. При желании корректируем остальные настройки.

Вы, наверное, удивитесь, но на этом все! Сканируем и радуемся!

 

2. Создание собственного мобильного приложения на 1С

Так как в этом варианте мы самостоятельно разрабатываем и клиентскую, и серверную части, то вольны выбрать любую понравившуюся нам технологию передачи данных. Пример реализации http-сервиса мы рассмотрели выше, поэтому рассмотрим реализацию с использованием web-сервиса.

Подготовка серверной части

На сервере в 1С создаем метод web-сервиса и описываем алгоритм обработки полученного QR-кода. Пример:

                                                 

 

     

Функция SetQR(QRKod)
	
	// Обработка полученного QRKod 
	
	
	// Создание записи в журнале регистрации (при необходимости)
	ЗаписьЖурналаРегистрации("WebService1.SetQR", УровеньЖурналаРегистрации.Ошибка, , QRKod, "Пример описания ошибки");
	
	// Сообщение результатов обработки
	Возврат "Загрузка успешно завершена";

КонецФункции

 

Подготовка клиентской части

У 1С есть встроенные методы по сканированию штрих-кодов, что значительно облегчает разработку. Пример:

&НаКлиенте
Процедура Сканировать1С(Команда)

	#Если МобильноеПриложениеКлиент Тогда

	Если СредстваМультимедиа.ПоддерживаетсяСканированиеШтрихКодов() Тогда
		ОбработчикСканирования = Новый ОписаниеОповещения("ОбработкаРаспознанногоШтрихкода", ЭтаФорма);
		СредстваМультимедиа.ПоказатьСканированиеШтрихКодов("Сканируйте", ОбработчикСканирования,,ТипШтрихКода.Двухмерный);
	Иначе
		Сообщить("Не поддерживается сканирование штрихкодов!");
	КонецЕсли;

	#КонецЕсли

КонецПроцедуры

Процедура ОбработкаРаспознанногоШтрихкода(Штрихкод, Результат, Сообщение, ДопПараметр)
	
	Если Результат Тогда
		Сообщение = ОтправитьQRКодНаСервере(Штрихкод);
	КонецЕсли;
	
КонецПроцедуры
	
&НаСервере
Функция ОтправитьQRКодНаСервере(Штрихкод)

	ОписаниеСервиса = Новый WSОпределения("http://192.168.0.1/MyWS/ws/ws1.1cws?wsdl", "Login", "Password");
	Прокси = Новый WSПрокси(ОписаниеСервиса, "http://192.168.0.1/", "WebService1", "WebService1Soap");
	Прокси.Пользователь = "Login";
	Прокси.Пароль       = "Password";
	
	Возврат Прокси.SetCheck(Штрихкод);

КонецФункции

Преимуществом данного варианта является гибкость и возможность реализации дополнительных требований к мобильному приложению. Но, к сожалению, качество сканирования при этом страдает. По сравнению с аналогами в магазинах приложений, сканер от 1С сканирует значительно хуже, медленнее, а иногда вообще не распознает QR-код. Также страдает и итоговый объем приложения, так как вместе с ним на мобильное устройство устанавливается и платформа 1С, которая занимает в несколько раз больше места.

Сравнение мобильных технологий сканирования штрихкодов приведены в следующей статье.

 

3. Совмещенный вариант

Данный вариант является попыткой использовать преимущества предыдущих двух вариантов: гибкости собственного мобильного приложения и хорошего сканера из магазина приложений. Реализация заключается в создании мобильного приложения на 1С, которое реализует весь необходимый функционал, в том числе и отправку данных на сервер, а сканирование QR-кода поручает выполнить другому приложению, предварительно установленному на устройстве.

Рассмотрим реализацию на примере того же приложения:

Доступно в Google Play

Отправка данных на сервер рассмотрена достаточно подробно, поэтому остановимся лишь на моменте взаимодействия с другим мобильным приложением. Пример:

&НаКлиенте
Процедура СканироватьAndroid(Команда)
	
	#Если МобильноеПриложениеКлиент Тогда
	
		Нов = Новый ЗапускПриложенияМобильногоУстройства("com.tamadosky.barcode.SCAN");
		
		РезультатСканирования = Нов.Запустить(Истина);
		
		Если РезультатСканирования = -1 Тогда
			Штрихкод = Нов.ДополнительныеДанные.Получить("SCAN_RESULT").Значение;
			ОтправитьQRКодНаСервере(Штрихкод);
		КонецЕсли;
		
	#КонецЕсли
	
КонецПроцедуры

К недостаткам данного варианта можно отнести необходимость установки двух мобильных приложений и относительно большое занимаемое место на мобильном устройстве.

 

Надеюсь, что изложенный материал ответит на некоторые ваши вопросы и поможет в автоматизации сканирования штрих-кодов.

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. DERL 11.06.20 11:13 Сейчас в теме
да, похоже сканер от zxing единственный, который может передавать данные в другие приложения, но страшно медленный, после сканирования пару секунд думает прежде чем отправить данные в приложение 1С, еще один глюк - хоть и стоит в настройках галочка "не поворачивать автоматически" все равно переключается в ландшафтный режим при сканировании.

приходится его использовать только из-за того, что во встроенном сканере 1С на некоторых телефонах не срабатывает автофокус и сканировать невозможно (например Redmi Note 5 - автофокус работает шикарно, Mi9 Lite - автофокус не работает ни в какую). пробовал разные релизы, в т.ч. и самый свежий. Кто-нибудь сталкивался с такой проблемой, решили как нибудь?
2. serg33rus 11.06.20 16:41 Сейчас в теме
А чем не устраивает СредстваМультимедия? Делал на нем, отлично все работает. Никаких дополнительных приложений, драйверов и прочего. Штатные средства 1С.
6. MaramOyka 28 05.12.20 09:25 Сейчас в теме
(2)
Сравнение мобильных технологий сканирования штрихкодов:
https://infostart.ru/1c/articles/1330670/
3. SirStefan 46 18.06.20 18:35 Сейчас в теме
А почему для п.3 не использовали com.tamadosky.barcode?
4. MaramOyka 18.06.20 19:19 Сейчас в теме
(3) Если не ошибаюсь, на момент написания статьи не было этого функционала. Тогда нужно так:

		Нов = Новый ЗапускПриложенияМобильногоУстройства("com.tamadosky.barcode.SCAN");
		
		РезультатСканирования = Нов.Запустить(Истина);
		
		Если РезультатСканирования = -1 Тогда
			Штрихкод = Нов.ДополнительныеДанные.Получить("SCAN_RESULT").Значение;
			ОтправитьQRКодНаСервере(Штрихкод);
		КонецЕсли;
Показать
5. DERL 27.11.20 05:25 Сейчас в теме
com.tamadosky.barcode

кто-нибудь реально использует его? чёт цена у него кусачая да еще и помесячная оплата
Оставьте свое сообщение

См. также

Как я начал администрировать сервер 1С: Предприятие 8.3 с телефона Промо

Администрирование данных 1С Мобильная разработка v8 Бесплатно (free)

Развитие инструментов управления кластером серверов 1С:Предприятие 8.3.

14.04.2017    65057    user700211_a.straltsou    29    

Релиз Simple UI май 2021: плиточные экраны, плиточное главное меню, картинки из кеша, новое взаимодействие с ТСД и т.д.

Мобильная разработка v8::Mobile Бесплатно (free)

В релизе Simple UI 5.75.00 добавлен новый вид интерфейса – «плитки» и возможность переопределения стартового экрана, а также другие нововведения. Также важное нововведение - новый режим взаимодействия с некоторыми моделями ТСД - через подписку на сообщения. Дополнение к основной статье: https://infostart.ru/public/1153616/

17.05.2021    1405    informa1555    0    

1С в мобильном и лицензионная политика

Мобильная разработка v8::Mobile Бесплатно (free)

На екатеринбургском онлайн-митапе заместитель директора НП ППП и руководитель мобильного направления в фирме «1С» Анна Лавринова рассказала о мире мобайла в сфере 1С, примерах мобильных приложений и особенностях их лицензирования.

31.03.2021    867    1C_lava    4    

Как избавиться от горизонтальных серых разделителей (полосок) между элементами в форме мобильного приложения

Мобильная разработка Работа с интерфейсом v8::Mobile Бесплатно (free)

На профильных форумах часто возникает вопрос, как избавиться от горизонтальных полос-разделителей между элементами на формах мобильного приложения. Часто предлагают использовать декорации или html-поле. Однако, есть простое решение.

17.03.2021    659    Moroz2009    4    

Фитнес – твой личный тренер в зале и дома Промо

Пользователю системы Мобильная разработка v8 Развлечения, искусство, спорт Бесплатно (free)

Хочешь быть здоровым, прекрасно выглядеть и неустанно стремишься к совершенству? Фитнес поможет достигнуть реальных результатов на пути к идеальной фигуре и здоровому телу.

15.04.2016    37619    Baksheev-Nikita    54    

Большой пак дополнений март 2021: регламентные задания, распознавание дат и чисел, оповещения, поля с автозаполнением и многое, многое другое

Терминал сбора данных Мобильная разработка v8 Бесплатно (free)

Релиз с огромным количеством дополнений. Дополнение к основной статье Simple UI: https://infostart.ru/public/1153616/ Перечень изменений: 1. Оптическое распознавание дат в разных форматах 2. Оптическое распознавание чисел в разных форматах 3. Запуск кода из кода синхронно/асинхронно в фоне (Python) 4. Регламентные задания с расписанием от 1 мс 5. Всплывающие сообщения 6. Уведомления из любого контекста простые 7. Уведомления с ответом (для Anroid начиная с Oreo) 8. Поле ввода с событием на каждый символ 9. Поле ввода с автозаполнением (предварительно передается список) 10. Новый настраиваемый диалог ввода и работа с ответами диалога 11. Работа с речью и голосом из любого контекста А также изменения в документации. В данную статью не вошло описание системы группового администрирования и мониторинга.

11.03.2021    1786    informa1555    20    

Большой пакет дополнений для Simple UI - январь 2021

Мобильная разработка v8::Mobile Бесплатно (free)

В этот раз множество полезных нововведений в мобильной платформе, исправлено все, о чем просили, а также прибрался в документации, актуализировал конструктор на 1С (с учетом текущих изменений, а также скорого выхода стационарного клиента) и переснял видео по-новому. Конструктор на платформе 1С:Предприятие 8.3.13.1865. Данный пост является дополнением к статье  https://infostart.ru/public/1153616/

22.01.2021    929    informa1555    9    

Мобильный HTML-интерфейс, взгляд изнутри

Работа с интерфейсом Мобильная разработка v8::Mobile Бесплатно (free)

Для реализации красивого интерфейса в мобильном приложении 1С удобно использовать возможности стека HTML / CSS / JavaScript. О том, как построить отзывчивый HTML-интерфейс с перехватом событий и выполнением JavaScript-кода в поле HTML-документа на форме 1С, рассказал сотрудник отдела мобильной разработки в компании «1С-Рарус» Роман Сухоруков.

28.12.2020    2965    ingeneerz@gmail.com    10    

Мобильный корпоративный мессенджер (или чем мы занимаемся в свободное время) Промо

Мобильная разработка v8::Mobile Бесплатно (free)

Корпоративный мессенджер, пробы пера на мобильной платформе 1С.

18.12.2017    22025    starik-2005    70    

Младший брат Большого Брата? (управляем мобильным устройством с компьютера)

Мобильная разработка v8 1cv8.cf Бесплатно (free)

Сначала эта публикация задумывалась как небольшой обзор средств для облегчения жизни при мобильной разработке на 1С, но постепенно она переросла в ответ на вопрос, заданный в статье на Хабре: "Кто в доме хозяин: ПК, ноутбук, смартфон или… планшет?" Спойлер: это не они. Тех, кто заинтересовался, прошу под кат…

14.12.2020    1211    capitan    6    

Сравнение мобильных технологий сканирования штрихкодов

Сканер штрих-кода Мобильная разработка v8 Бесплатно (free)

В статье приведены результаты тестирования и сравнение популярных мобильных технологий сканирования штрихкодов

23.11.2020    1439    MaramOyka    6    

Ноябрьский релиз Simple UI: списки карточек для всех режимов работы и много полезного

Мобильная разработка v8::Mobile Бесплатно (free)

В новом релизе Simple UI добавлены режимы представления информации в виде настраиваемого списка карточек (в альтернативу таблице или списку) для любых источников – формируемого из 1С, оффлайн и из REST-интерфейса напрямую. Расширен набор методов для обработки JSON в самостоятельном режиме и настройки для работы с HTTP запросами напрямую (не через настройки) а также множество других полезных нововведений. Основная статья по Simple UI : https://infostart.ru/public/1153616/ Платформа 1С: Предприятие для демо-базы : 8.3.14.1865.

09.11.2020    1366    informa1555    2    

Отладка конфигураций на мобильной платформе Промо

Мобильная разработка v8 Бесплатно (free)

Настройка и подключение отладчика для отладки конфигураций на мобильной платформе.

25.09.2016    51990    spezc    49    

[mobile] Переносим HTML интерфейс на 1С

Работа с интерфейсом Мобильная разработка v8 v8::Mobile 1cv8.cf Бесплатно (free)

Разберем методы переноса HTML интерфейса на 1С на примере реализации нижнего меню для мобильного приложения. Сравним методы между собой. Данные методы можно применять не только для мобильной разработки, но и для веб-клиента и т.д

02.11.2020    6980    leobrn    66    

Обзор мобильного приложения 1С и лицензионная политика

Мобильная разработка v8::Mobile Бесплатно (free)

Все больше задач и бизнес-процессов решается с помощью мобильных приложений. Одно подсчитывает калории, другое – показывает руководителю, сколько сделок заключено по итогам месяца, третье – используется как канал связи между клиентом и заказчиком. О плюсах разработки мобильных приложений на платформе 1С рассказала заместитель директора НП ППП, координатор по вопросам защиты ИС 1С Анна Лавринова.

12.10.2020    5341    1C_lava    50    

Воспроизведение аудиофайлов в мобильной платформе

Мобильная разработка v8::Mobile Бесплатно (free)

Корректное добавление аудиоинформации при сборке мобильного приложения.

17.09.2020    950    QuirkyKot    1    

1С Переучет Android Промо

Сканер штрих-кода v8 1cv8.cf Бесплатно (free)

Приложение создано для удобного переучета товаров с помощью Android устройств с выгрузкой в 1С

31.08.2012    44677    bosterua    90    

Тест скорости работы мобильной платформы 1С

Мобильная разработка Производительность и оптимизация (HighLoad) v8 1cv8.cf Бесплатно (free)

С помощью этого приложения вы можете измерить производительность своего устройства, используя для этого мобильную платформу 1С:Предприятие. Набор действий теста полностью повторяет аналогичный тест для стационарных ПК, поэтому результаты сравнимы.

14.09.2020    1646    capitan    25    

Team: Торговля + Склад + Производство (Мобильное приложение на платформе 1С)

Мобильная разработка Производство готовой продукции (работ, услуг) Учет ТМЦ Управление торговлей v8::Mobile УУ Бесплатно (free)

TEAM - управленческий учет для любого бизнеса: склад; деньги, мультивалютность; продажи - покупки товаров, услуг; заказы и долги клиентов, поставщиков и других партнеров; учет производства, сборки комплектов; доходы и расходы, прибыль и финансовый результат. Приложение будет развиваться с учетом Ваших пожеланий и предложений.

14.09.2020    2024    naypak    10    

Мобильное приложение Goods info

Мобильная разработка v8 УТ11 Оптовая торговля, дистрибуция, логистика Бесплатно (free)

Мобильное приложение предназначено для получения информации о товарах на складах или торговых точках.

04.09.2020    1862    hpi    9    

Легкий способ подключения сканера штрих-кодов без установки драйвера Промо

Сканер штрих-кода v8 1cv8.cf Россия Бесплатно (free)

Предлагаемое описание позволит подключить сканер штрих-кодов к любому решению на платформе 8.x - короткая подготовка и быстрое подключение.

21.08.2012    143817    bforce    74    

Авто-ежедневник (мобильное приложение на платформе 1С)

Мобильная разработка v8::Mobile Автомобили, автосервисы Бесплатно (free)

С помощью этого мобильного приложения вы сможете отслеживать затраты на содержание автомобиля, узнать стоимость километра пробега, средний расход топлива и получать уведомления о приближающемся сроке замены деталей или прохождении ТО. Приложение будет развиваться с учетом общих пожеланий и надеюсь оно вас не разочарует.

25.08.2020    3293    capitan    29    

Настройка сканера для маркировки обуви в УТ 10.3 по RDP

Сканер штрих-кода v8 v8::ОУ УТ10 Розничная и сетевая торговля (FMCG) Россия Бесплатно (free)

Реально ли настроить без костылей работу сканера для маркировки обуви в УТ 10.3? Делюсь личным опытом.

21.08.2020    2900    yarrr    20    

Чат и задачи с интерактивными объектами через PostgREST. Новый подход к управлению бизнес-процессами и интерфейсу

Мобильная разработка v8 Бесплатно (free)

В новой версии Simple UI появилась возможность организовать свой корпоративный мессенджер и список задач с 1С, но не напрямую, а через PostgreSQL, чтобы не забивать 1С всякими пустяками. Причем не просто чат и задачи, а с множеством уникальных фишек: прием задач прямо из ленты чата, формат статусов в сообщении, старт процессов из задач с предопределенным состоянием переменных и сохранение переменной в задаче, отправка сообщений и задач из процессов и другое. Т.е. это такой новый способ доставки и контроля задач до исполнителя. Кроме того, в этом паке обновлений еще полный инструментарий для работы с JSON.

17.07.2020    3141    informa1555    8    

Отладка мобильного клиента

Мобильная разработка v8::Mobile Россия Бесплатно (free)

Инструкция по настройке и запуску отладке мобильного приложения, мобильного клиента, web-клиента и прочего, в т.ч. и клиентской части. Подходит для клиент-серверной архитектуры.

07.07.2020    4030    DmitrySinichnikov    6    

Как сделать телефонный справочник компании на мобильном телефоне для iOS

Мобильная разработка v8::Mobile Бесплатно (free)

При разработке мобильных приложений под iOS возникает много трудностей, решение которых не очевидно. Как упростить разработку под iPhone и снизить стоимость лицензий Apple с учетом лицензионной политики 1С на конференции Infostart Event 2019 Inception рассказал главный специалист ФАУ «РМРС» Ракитин Александр.

26.06.2020    3181    rujiy_kot    5    

Безопасность мобильных приложений 1С, взгляд по диагонали

Информационная безопасность Мобильная разработка v8::Mobile 1cv8.cf Бесплатно (free)

Что приходит первое в голову при словах «1С Предприятие»? Даже тем, кто далек от ИТ, представляется большущий компьютер (а тем, кто недалек, стойка двух-юнитных серверов), рядом слушает музыку сервера (как вариант просто музыку) сисадмин, за стеной в опен-спейсе менеджеры принимают заказы и бухгалтерия, сдающая отчетность. «Зарплата, зарплата!»: слышны их радостные крики. «И кадры»: уточняет HR. Да, все верно. Это 1С. Кто в теме, напомнит про крики не совсем приятные: «Все тормозит! Сделайте что-нибудь, #тыжпрограммист». И борющихся за живучесть ИТ-шников. В обычном офисном потоке дел, редко кто задумывается о безопасности. А тех, кто задумывается, прошу под кат…

05.06.2020    4249    capitan    33    

Инвентаризация весового товара терминалом сбора данных+ ERP 2.4

Сканер штрих-кода Терминал сбора данных v8 ERP2 Россия УУ Бесплатно (free)

Цель - печать этикеток на Штрих Принт (весы с печатью этикеток) весового товара и сбор штрихкодов на ТСД Cipher Lab CP55 в Mobile Smart Магазин 15.

15.05.2020    2004    dy4amaks    0    

Хранение статистики публикаций автора сообщества Инфостарт ® (мобильное приложение И ++)

Мобильная разработка WEB v8 1cv8.cf Бесплатно (free)

Инфостарт ® достаточно удобный в плане работы со своим личным кабинетом сайт. Но программисты тем и отличаются от большинства людей, что им хочется знать больше. Поэтому появилась конфигурация 1С (она же мобильное приложение 1С) для более подробного учета статистики публикаций: рейтинг, количество просмотров, количество комментариев в динамике и в разрезах.

24.04.2020    2561    capitan    15    

Автоматизация распределительных центров компании "Вкусвилл" на мобильной платформе 1С

Мобильная разработка v8::Mobile Бесплатно (free)

Мобильная платформа 1С многим кажется неготовой к масштабным проектам. Ее опасаются использовать из-за нестабильности работы, багов, проблем со связью, сложностью при подборе оборудования и драйверов. Но доклад руководителя проектов в компании «Автоматизация и Консалтинг» Алексея Матюшкина на конференции INFOSTART EVENT 2019 Inception показал, что не все так плохо. За последние несколько лет мобильная платформа 1С сильно эволюционировала, ее функционал расширился, и теперь это хорошая основа для самого смелого проекта автоматизации.

13.04.2020    6585    Potroshitel    21    

Диеты: качество и креатив нового уровня

Пользователю системы Мобильная разработка v8 Развлечения, искусство, спорт Бесплатно (free)

Приложение “Диеты” вернулось этой весной с мощным обновлением, в которое команда вложила не только время, но упорство и креативную идею.

06.04.2020    2509    Baksheev-Nikita    1    

Повышение удобства использования мобильного приложения

Мобильная разработка v8::Mobile 1cv8.cf Казахстан Бесплатно (free)

Здесь представлены методы, которые помогут повысить удобство использования приложений на мобильной платформе. Разработка велась на платформе 8.3.13.64, но, возможно, они помогут и тем, кто разрабатывает на более новой.

03.04.2020    5273    user602678_maxipunchik    13    

Как я собрал для себя высокопроизводительный и бесплатный облачный бекенд для 1С на PosgreSQL + PostgREST

Производительность и оптимизация (HighLoad) WEB Интеграция Мобильная разработка Администрирование веб-серверов v8 Бесплатно (free)

В этой статье я расскажу о проблемах бека для мобильных приложений или другого фронта, который требует производительности, быстрой реакции и отказоустойчивости, и как я решил это благодаря opensource проекту PostgREST и СУБД Postgre SQL 12. Проведу простой тест производительности для сравнения 1С с данным решением. Это может быть полезно всем, кто разрабатывает мобильные приложения либо фронтсайд-приложения для 1С на чем угодно - на мобильной платформе или на нативном языке или на Simple UI. И также обзор новых функций SimpleUI для связи с этим бекендом.

31.03.2020    15046    informa1555    35    

Мобильная платформа 1С 8.3: чтение СМС, журнала звонков и т.д. и т.п.

SMS рассылки Мобильная разработка v8 v8::Mobile Россия Бесплатно (free)

Пишем приложение по учету личных финансов с загрузкой СМС от банков на основе мобильной платформы 8.3.15.62 ...

27.02.2020    5610    kras_71    7    

Как продавать маркируемый товар (обувь) из 1С:Розница + сканер для маркировки

Розничная торговля Сканер штрих-кода v8 Розница Розничная и сетевая торговля (FMCG) Россия Бесплатно (free)

Маркировка обуви в нашей стране началась с 1 июля 2019 года. Но если в 2019м году от участников рынка требовалось только зарегистрироваться в системе «Честный знак», то теперь уже совсем не за горами дата, когда необходимо будет в обязательном порядке передавать данные о проданных единицах обуви. По графику этот судный день назначен на 1 марта 2020 года. Как все знают, русский человек всегда надеется на лучшее (или на авось, кому как нравится), надеется что правительство передумает. Сейчас в сети ходит информация о возможных сроках переноса судного дня на 1 июля, или, даже, 1 сентября 2020 года, это лишь отсрочки, но никак не отмена обязательной маркировки. В дополнении ко всему вышесказанному надо отметить, что самая популярная программа для розничной торговли, а именно 1С:Розница, как и ее пользователи не смогла заранее подготовиться к нововведениям. Обновление, в котором система стала работать более-менее корректно, вышло лишь 6 февраля 2020 года (менее чем за месяц до судного дня)

22.02.2020    6650    VCPro    10    

Цена победы, или Матчасть мобильного приложения "ТОИР Магнит"

Мобильная разработка v8::Mobile Бесплатно (free)

Проект по созданию мобильного приложения «ТОИР Магнит» стал победителем конкурса 1С:Проект года-2018. В чем его особенность, рассказал участникам конференции INFOSTART EVENT 2019 Inception директор по маркетингу и продажам группы компаний «Деснол Софт» Сергей Ребрин.

04.02.2020    4156    RebrinSG    13    

Простой и красивый интерфейс

Работа с интерфейсом Мобильная разработка v8::Mobile Бесплатно (free)

Разработчики мобильных приложений на платформе 1С сталкиваются с проблемой адаптации сгенерированного платформой интерфейса под удобство использования. О том, какие приемы помогут сделать интерфейс красивым и удобным, на конференции Infostart Event 2019 Inception рассказал руководитель отдела мобильной разработки компании «1С-Рарус» Никита Бакшеев.

30.01.2020    15039    Baksheev-Nikita    33    

Январский пак Simple UI: диаграммы и индикаторы, глобальные переменные,константы и многое другое

Мобильная разработка v8::Mobile Бесплатно (free)

Очередной пакет дополнений к Simple UI направленный на средства визуализации, а также важные дополнения по части управляющих конструкций которых не хватало раньше. Теперь на Simple UI можно делать электронное табло, киоск или монитор, выводить индикаторы и красивую визуализацию. В пакет вошло: 3 вида диаграмм, стрелочные индикаторы, вывод картинок в контейнерах, глобальные переменные приложения, константы хранящиеся на устройстве, управление переключением экрана с сервера и то что в 1С называется "Обработчик ожидания формы". Протестировано на 1С 8.3.13.1865

20.01.2020    3437    informa1555    5    

Собираем и запускаем приложение на Android (.apk файл)

Мобильная разработка v8::Mobile 1cv8.cf Бесплатно (free)

Пригодится тем, кто решит собрать 1С приложение на Android.

31.12.2019    32812    John_d    63    

Большой декабрьский пак дополнений Simple UI (Simple WMS): распознавание текста в обычных экранах и документах, отправка голосового сообщения на устройство даже в фоне и многое другое. Видео в конце поста

Мобильная разработка v8::Mobile УУ Бесплатно (free)

Теперь распознание текста, которое тестировалось вот тут https://infostart.ru/public/1159499/ встроено в конструктор экранов и документов, а также многие другие новые возможности Simple UI.

11.12.2019    3760    informa1555    0    

Как подключить сканер штрихкода

Сканер штрих-кода v8 Розница Розничная и сетевая торговля (FMCG) Россия Бесплатно (free)

Собственно, решил написать все, что знаю про подключение сканера штрих-кода. На первый взгляд кажется все просто, а на итог можно долго провозиться. Особенно когда до этого имел дело только с 1С и не имел опыта работы с торговым оборудованием.

11.11.2019    63986    VachKirp    53    

Бюджет-революция свершилась!

Пользователю системы Финансовый учет и бюджетирование (FRP) Мобильная разработка v8 v8::Mobile 1cv8.cf Домашние учет и финансы УУ Бесплатно (free)

Мы полностью обновили дизайн приложения и улучшили ряд основных функций и небольших деталей, что позволило нам вывести Бюджет на новый уровень.

08.11.2019    8241    Baksheev-Nikita    16    

Оффлайн-режимы в Simple WMS: полностью автономные приложения, отложенная отправка, гибридный режим

Мобильная разработка v8 Бесплатно (free)

Теперь Simple WMS имеет базу данных и можно создавать конфигурации для полностью автономных приложений, не зависящий от веб-сервера на стороне учетной системы, в выполнением логики на устройстве а не на стороне веб сервера. А также можно реализовывать другие гибридные режимы работы с использованием хранилища устройства. Тестировалось на платформе 1С 8.3.13.1865.

15.08.2019    6689    informa1555    3    

Как разработать успешное мобильное приложение на платформе 1С

Мобильная разработка v8::Mobile Бесплатно (free)

Мобильные приложения становятся все популярнее, но многие программисты считают, что создавать их не сложнее, чем настольные. В итоге появляются продукты, которые не приносят разработчикам ни удовольствия, ни денег. Какие особенности надо учитывать при разработке мобильного приложения, в главное – как добиться, чтобы оно было прибыльным, участникам конференции Infostart Event 2018 Education рассказал руководитель отдела мобильной разработки на платформе 1С в компании 1С-Рарус Никита Бакшеев.

09.08.2019    11126    Baksheev-Nikita    10    

Большой пакет дополнений для Simple WMS

Мобильная разработка v8 Бесплатно (free)

Обычно описание дополнений я публикую в конце основной статьи, но сейчас накопился большой пакет изменений о котором хотелось бы рассказать более развернуто. В этом дополнении: работа с произвольными таблицами везде в приложении, переработанный механизм запуска процессов из процессов и другое. Тестировалось на 8.3.13.1865

15.07.2019    5752    informa1555    2